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 Tutorial: Introduction to Hyperspectral Data 

Overview of This Tutorial 
This tutorial is designed to introduce you to imaging spectrometry, hyperspectral images, and selected spectral processing 
basics using ENVI. You will use Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data to learn how to spatially 
and spectrally browse imaging spectrometer data. You will start with 1995 AVIRIS radiance data for Cuprite, Nevada, 
USA, provided by NASA Jet Propulsion Laboratory (JPL), and compare the results of several reflectance calibration 
procedures. 
 

Files Used in This Tutorial 
ENVI Resource DVD: envidata\c95avsub 
 

File Description 
Required Files  
cup95_rd.int (.hdr) AVIRIS radiance data (400 samples, 350 lines, 50 bands) 
cup95_at.int (.hdr) AVIRIS atmospherically corrected reflectance data (50 bands) 
cup95cal.sli (.hdr) Spectral library of calibrations for selected minerals (integer) 
jpl1.sli (.hdr) JPL spectral library in ENVI format 
usgs_min.sli (.hdr) USGS spectral library in ENVI format 
  
Optional Files  
cup95_ff.int (.hdr) Flat-Field-calibrated apparent reflectance integer data (50 bands) 
cup95_ia.int (.hdr) Internal average relative reflectance (IARR) integer data 
cup95_el.int (.hdr) Empirical line-calibrated apparent reflectance integer data 
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Background: Imaging Spectrometry  
Imaging spectrometers, or hyperspectral sensors, are remote sensing instruments that combine the spatial presentation 
of an imaging sensor with the analytical capabilities of a spectrometer. They may have up to several hundred narrow 
spectral bands with spectral resolution on the order of 10 nm or narrower (Goetz et al., 1985). Imaging spectrometers 
produce a complete spectrum for every pixel of the image, as the following figure shows. 
 
 

 
 
Compare this to broadband multispectral scanners such as Landsat Thematic Mapper (TM), which only has six spectral 
bands and spectral resolution on the order of 100 nm or greater. The high spectral resolution from an imaging 
spectrometer allows you to identify materials, whereas broadband sensors only allow you to discriminate between 
materials. 
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Introduction to Basic ENVI Spectral Processing  
In this part of the tutorial, you will learn about ENVI features that are useful for spectral processing of imaging 
spectrometer data.  
 
Before attempting to start the program, ensure that ENVI is properly installed as described in the Installation Guide that 
shipped with your software. 
 

1. From the ENVI main menu bar, select File → Open Image File. 
 

2. Navigate to the envidata\c95avsub directory, and select cup95_rd.int. Click Open. The Available Bands 
List appears with a list of 50 bands (1.99-2.48 µm) of JPL-calibrated AVIRIS radiance for the Cuprite Mining 
District, Nevada, USA. 

Display a Grayscale Image  
1. In the Available Bands List, double-click Band 193. A gray scale image of Band 193 is loaded into an ENVI 

display group.  
 
2. In the Image window, move the Zoom box to a desired location. The Zoom window automatically updates.  

 
3. Use the Zoom controls to change the Zoom factor. Clicking in the Zoom window centers the selected pixel. 

Display a Color Image  
1. In the Available Bands List, select the RGB Color radio button.  

 
2. Click sequentially on Band 183, Band 193, and Band 207 (2.10, 2.20, and 2.35 µm, respectively).  

 
3. Click Display #1 and select New Display. A new display group appears. 

 
4. Click Load RGB. The color image is loaded into the display group.  

Link Two Display Groups 
Linking display groups allows you to query two or more images simultaneously. If you move the Zoom or Image box, 
change the zoom factor, or resize the display group window in one image, the other linked display groups reflect your 
changes.  
 

1. From any Display group menu bar, select Tools → Link → Link Displays. The Link Displays dialog appears. 
 

2. Accept the defaults and click OK to enable the link.  
 

3. Move the Zoom box in Display #1 to a new location. The Zoom window in Display #2 updates to correspond with 
Display #1.  

 
Multiple dynamic overlays are available when two or more display groups are linked, allowing real-time overlay 
and flicker of multiple gray scale or color images. Dynamic overlays are automatically activated when two or more 
display groups are first linked.  

 
4. Click in either Image window to cause the second linked image (the overlay) to appear in the first image (the 

base).  
 

5. You can quickly compare the images by repeatedly clicking in the Image window, which causes the overlay area 
to flicker.  
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6. Change the size of the overlay by clicking the middle mouse button in a display group and dragging the corner of 
the overlay to the desired location.  

 
7. After experimenting with linking and dynamic overlays, select Tools → Link → Unlink Display from a Display 

group menu bar.  

Extract Spectral Profiles  
ENVI’s Z Profile tool provides integrated spectral analysis. You can extract spectra from any multispectral dataset 
including MSS, TM, and higher spectral dimension data such as GEOSCAN (24 bands), GERIS (63 bands), and AVIRIS 
(224 bands). With a Z Profile, the spectrum for the current cursor location appears in a plot window. A vertical line on the 
plot marks the wavelength position of the currently displayed band. If a color composite image is displayed, three colored 
lines appear, one for each displayed band in the band’s respective color (red, green, or blue).  
 

1. From the Display #2 menu bar, select Tools → Profiles → Z Profile (Spectrum). A Spectral Profile plot 
window appears. 

 
2. Click in the Image or Zoom window to move the cursor position. The spectrum is extracted and plotted for the 

new point. The spectrum is based on radiance (not reflectance) data in this case. 
 

3. From the Spectral Profile menu bar, select Options → Collect Spectra.  
 

4. You will collect spectra in another plot window, so open a new plot window by selecting Options → New 
Window: Blank from the Spectral Profile menu bar. An ENVI Plot Window appears that will contain saved image 
spectra.  

 
5. Right-click in the Spectral Profile and select Plot Key to display the spectrum name to the right of the plot.  

 
6. Select a new spectrum from the image by moving the current pixel location in the Image or Zoom window. The 

spectrum is added to the Spectral Profile. 
 

7. Click and drag a spectrum name from the Spectral Profile to the ENVI Plot Window, and release the mouse 
button. 

 
8. Repeat Steps 4-5 a few times to build a collection of spectra in the ENVI Plot Window.  

 
9. From the ENVI Plot Window menu bar, select 

Options → Stack Plots. The spectra are 
vertically offset to assist in interpretation. Your 
plot should look similar to the figure at right. 

 
10. To change the color and line style of the 

different spectra, select Edit → Data 
Parameters from the ENVI Plot Window menu 
bar. A Data Parameters dialog appears, listing 
each spectrum by name and location.  

 
11. In the Data Parameters dialog, select a 

spectrum and change its properties as desired.  
 

12. When finished, click Cancel to close the Data 
Parameters  dialog.  

 
13. Select File → Cancel from the Spectral Profile 

and ENVI Plot Window menu bars.  
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Animate the Data  
You can animate gray scale images to make the spatial occurrence of spectral differences more obvious.  
 

1. From the Display #1 menu bar, select Tools → Animation to create a movie using the AVIRIS data. The 
Animation Input Parameters dialog appears. This dialog lists all of the bands provided in the Available Bands List.  

 
2. All bands are selected by default. Click once on the filename (cup95_rd.int) to deselect all of the bands. 

 
3. Click band 197, click <Shift>, and click band 216 to select a subset of 20 bands for animation.  

 
4. In the Window Size field, enter 320 x 280 to reduce the size of the image to be animated, thus increasing the 

speed of the animation.  
 

5. Click OK to start the animation loading process. A status bar appears as each image is processed. When all of the 
bands are loaded, the Animation Controls dialog appears and the animation begins. Selected bands are displayed 
sequentially. Use the Animation Controls dialog to specify the animation parameters. Vary the animation speed 
from 1 to 100 by entering a Speed value. 

 

 
 

6. Use the control buttons (which look like CD player buttons) to run the animation forward and reverse and to 
pause specific bands. When paused, click and drag the slider to manually select the band to display.  

 
7. From the Animation Controls dialog menu bar, click File → Cancel to end the animation.  

 
8. Close the two display groups. 
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Working with Cuprite Radiance Data  
1. In the Available Bands List, select the RGB Color radio button. 
 
2. Under cup95_rd.int, select bands 183, 193, and 207 in sequential order. Click Load RGB. The color 

composite is loaded into a new display group.  

Extract Radiance Spectra 
1. From the Display group menu bar, select Tools → Pixel Locator. A Pixel Locator dialog appears. 
 
2. Enter 590 in the Sample field and 570 in the Line field to center the Zoom window over Stonewall Playa. Click 

Apply.  
 

3. Extract the radiance spectrum for this location by selecting Tools → Profiles → Z Profile (Spectrum) from the 
Display group menu bar. A Spectral Profile plot window appears. 

 
4. From the Spectral Profile menu bar, select Options → Collect Spectra. 

 
5. Using the following table as a reference, enter Sample and Line values in the Pixel Locator dialog to extract 

radiance spectra for different surface features. When you click Apply each time, the Zoom box moves to that 
location and the corresponding spectra are loaded into the Spectral Profile plot window. 

 
Location Name Sample 

(with offset) 
Line 

(with offset) 
Varnished Tuff 435 555 
Silica Cap 494 514 
Opalite Zone with Alunite 531 541 
Strongly Argillized Zone with Kaolinite 502 589 
Buddingtonite Zone 448 505 
Calcite 260 613 

 
6. From the Spectral Profile menu bar, select Options → Stack Plots to offset each spectrum so you can better 

compare them.  
 
7. Right-click in the plot window and select Plot Key to display the legend for each spectra. Your Spectral Profile 

should similar to the figure below. 
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The radiance spectra appear very similar. The overall shape of the spectra is caused by the typical combined 
solar/atmospheric response. Small absorption features (minima) near 2.2 μm may be attributable to surface mineralogy. 
 

8. Close the Pixel Locator dialog, but keep open the Spectral Profile plot for the next exercise. 
 

Load Spectral Library Reflectance Spectra 
In this series of steps, you will compare apparent reflectance spectra from the image to selected library reflectance 
spectra.  
 

1. From the ENVI main menu bar, select Spectral → Spectral Libraries → Spectral Library Viewer. A Spectral 
Library Input File dialog appears. 

 
2. Click the Open drop-down button and select Spectral Library. From the ENVI Resource DVD, navigate to 

envidata\spec_lib\jpl_lib  and select jpl1.sli. Click Open. 
 

3. In the Spectral Library Input File dialog, select jpl1.sli and click OK. A Spectral Library Viewer dialog appears. 
 

 
  

4. Select the following spectra in the Spectral Library Viewer, one at a time. 
 

  ALUNITE SO-4A  
  BUDDINGTONITE FELDS TS-11A  
  CALCITE C-3D  
  KAOLINITE WELL ORDERED PS-1A  

 
5. When you select ALUNITE SO-4A, a Spectral Library Plots window appears with a spectral profile. As you select 

the remaining spectra, their profiles are added to the same Spectral Library Plots window. 
  
6. Right-click in the Spectral Library Plots window and select Plot Key to display the legend for each spectra. 
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7. From the Spectral Library Plots menu bar, select Edit → Plot Parameters. 

 
8. Enter Range values from 2.0 to 2.5. Click Apply, then Cancel. 

 
9. From the Spectral Library Plots menu bar, select Options → Stack Plots to offset each spectrum. Your Spectral 

Library Plots window should look similar to the following figure. 
 

 
 

10. Visually compare the Spectral Profile plot (AVIRIS radiance spectra) with the Spectral Library plot (laboratory 
measurements of mineral spectra). 

 
11. When you are finished with this section, close all of the plot windows by selecting Window → Close All Plot 

Windows from the ENVI main menu bar. 
 

12. Close the Spectral Library Viewer dialog. 
 

13. Keep open the display group for the next exercise. 
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Compare Radiance and Reflectance Spectra  
In this section, you will extract selected image radiance spectra and compare them to apparent reflectance spectra for 
specific targets in the AVIRIS radiance data.  

Load AVIRIS Radiance Data and Start the Z Profile  
1. From the Display group menu bar, select Tools → Profiles → Z Profile (Spectrum). 

 
2. When the Spectral Profile plot window appears, move it to the bottom of your screen for easy access.  

Load Apparent Reflectance Data and Start the Z Profile  
1. Open a second AVIRIS dataset. From the ENVI main menu bar, select File → Open Image File. Navigate to 

envidata\c95avsub and select cup95_at.int. This file is a 50-band (1.99 - 2.48 µm) subset of AVIRIS data 
calibrated to apparent reflectance. The 50 bands are added to the Available Bands List.  

 
2. In the Available Bands List, select Band 193 under cup95_at.int, and select the Gray Scale radio button. 

 
3. In the Available Bands List, click Display #1 and select New Display. 

 
4. Click Load Band.  

 
5. From both Display group menu bars, select Tools → Profiles → Z Profile (Spectrum).  

 
6. Arrange the two Spectral Profile plot windows side-by-side so you can compare them.  

Link Images and Compare Spectra  
1. From any Display group menu bar, select Tools → Link → Link Displays. The Link Displays dialog appears. 
 
2. Accept the defaults and click OK.  
 
3. From the Display #1 menu bar, select Tools → Link → Dynamic Overlay Off.  

 
4. If you click in the Display #1 Image window, drag the Zoom box, or use the Pixel Locator to change the current 

pixel location in Display #1, the second image automatically moves the cursor to the same pixel location. The Z 
Profiles for both images also change to show the radiance and apparent reflectance spectra at the current 
location. 

 
5. From any Display group menu bar, select Tools → Pixel Locator. A Pixel Locator dialog appears. 
 
6. Enter 590 in the Sample field and 570 in the Line field to center the Zoom window over Stonewall Playa. Click 

Apply.  
 

7. Visually compare the radiance and apparent reflectance spectrum for this location using the two Z Profiles. 
 

9. From both of the Spectral Profile menu bars, select Options → Collect Spectra. 
 

10. Using the following table as a reference, enter Sample and Line values in the Pixel Locator dialog to extract 
radiance spectra for different surface features. When you click Apply each time, the Zoom box moves to that 
location and the spectra are loaded into the Spectral Profile plot window. 
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Location Name Sample 
(with offset) 

Line 
(with offset) 

Varnished Tuff 435 555 
Silica Cap 494 514 
Opalite Zone with Alunite 531 541 
Strongly Argillized Zone with Kaolinite 502 589 
Buddingtonite Zone 448 505 
Calcite 260 613 

 
An alternate method for simultaneously getting linked spectral profiles from two or more images is to select Tools 
→ Profiles → Additional Z Profile from one of the Display group menu bars. Then choose additional datasets to 
extract spectral profiles from. 

 
11. From both of the Spectral Profile menu bars, select Options → Stack Plots to vertically offset data for 

comparison. 
 
12. When you are finished, select Window → Close All Plot Windows from the ENVI main menu bar. 

 
13. Close both display groups. 

 
14. Keep the Pixel Locator dialog open for the next exercise. 

 

Use the Spectral Analyst to Identify Spectra  
ENVI’s Spectral Analyst tool uses techniques such as Binary Encoding, Spectral Angle Mapper, and Spectral Feature Fitting 
to rank the match of an unknown spectrum to the materials in a spectral library. The output of the Spectral Analyst is a 
list of the materials in the input spectral library ranked in order of best-to-worst match. It reports an overall similarity 
score, along with individual 0.0 to 1.0 scores for each method, with 1.0 equaling a perfect match. The Spectral Analyst 
does not identify spectra; it only recommends likely candidates for identification. 
 
For this exercise, you will match an unknown spectrum in the Cuprite AVIRIS scene that is corrected for apparent 
reflectance (cup95_at.int) with the materials listed in the USGS spectral library. 
 

1. In the Available Bands List, select the RGB Color radio button.  
 

2. Under cup95_at.int, click sequentially on Band 183, Band 193, and Band 207 (2.10, 2.20, and 2.35 µm, 
respectively).  

 
3. Click Load RGB. A display group appears with an RGB image of cup95_at.int.  
 
4. In the Sample field of the Pixel Locator dialog, enter 502. In the Line field, enter 589. Click Apply. The Zoom 

box centers over a small, pink area with an unknown material. 
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5. From the Display group menu bar, select Tools → Profiles → Z Profile (Spectrum). A Spectral Profile plot 

window appears. 
 

6. Right-click in the Spectral Profile and select Plot Key to display a legend for the spectrum corresponding to the 
pixel underlying the cursor in the Zoom box. This represents the unknown spectrum. 

 
7. From the ENVI main menu bar, select Spectral → Spectral Analyst. A Spectral Analyst Input Spectral Library 

dialog appears. 
 
8. Select Open → Spectral Library at the bottom of the Spectral Analyst Input Spectral Library dialog.  

 
9. Navigate to envidata\spec_lib\usgs_min and select usgs_min.sli. Click Open.  

 
10. In the Spectral Analyst Input Spectral Library dialog, select usgs_min.sli and click OK. The Edit Identify 

Methods Weighting dialog appears. 
 

11. You will give equal weight to the Spectral Angle Mapper, Spectral Feature Fitting, and Binary Encoding methods. 
Enter 0.33 in each of the three Weight fields, and click OK. 

 
12. In the Spectral Analyst dialog, click Apply. The Spectral Analyst scores the unknown spectrum against the 

spectral library. The Score values range from 0.0 to 1.0, with 1.0 equaling a perfect match. 
 

 
 

13. Notice how many times the mineral kaolinite appears at the top of the list and its relatively high scores. This 
would indicate a high likelihood of kaolinite.  

 
14. Double-click the first spectrum name in the list. An Identify: Known vs. Unknown plot window appears with the 

unknown spectrum plotted in red against the (known) library spectrum. 
 
15. To zoom into the y-axis range of 0.6 to 1.0 μm so you can better discern the two spectra, choose one of the 

following options: 
 

  From the Identify plot menu bar, select Edit → Plot Parameters. In the Plot Parameters dialog, 
click the Y-Axis radio button. In the Range Field, enter 0.60. Leave the To field as 1.0. Click 
Apply, then click Cancel to close the Plot Parameters dialog. 
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  Click and drag the middle mouse button to draw a box around the full range of x-axis values and a 

range of y-axis values from 0.6 to 1.0, as shown below: 

 

Use your middle 
mouse button to 
draw a box 
around the range 
of plot values. 

 
 

 
 
 

16. Notice how the shape of the unknown spectrum (red) approximately resembles that of the known spectrum for 
kaolinite. This comparison, along with the relatively high ranking of kaolinite in the Spectral Analyst table, 
suggests a high likelihood that the pixel in question contains kaolinite. 

 
17. Close the Identify plot window, then double-click on pyrophy3.spc (pyrophyte) in the Spectral Analyst table. 

 
18. Zoom into the y-axis range of 0.6 to 1.0 μm so you can better discern the two spectra. 

 
19. Notice how the shape of the unknown spectrum is significantly different from that of the known pyrophyte 

spectrum. This visual comparison suggests that the pixel in question likely is not pyrophyte. 
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20. Continue comparing spectral plots from other minerals in the Spectral Analyst table with that of the unknown 
spectrum to verify the mineralogy for that location. Pay close attention to the similarity or differences of the 
spectra in absorption features (where the spectra suddenly decrease in value). Also remember that the library 
spectra of known minerals were derived a much larger number of samples (and are thus smoother in shape) than 
the Z Profile spectrum derived from the image. 

 
21. When you are finished with this section, select Window → Close All Plot Windows from the ENVI main menu 

bar, followed by Window → Close all Display Windows. Then close the Spectral Analyst dialog.  
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Compare Atmospheric Corrections  
This section of the tutorial compares several image apparent reflectance spectra. You will use a spectral library of 
apparent reflectance spectra generated from ENVI’s Flat Field Correction, IARR Correction, and Empirical Line Correction 
calibration methods and compare their characteristics. 

Flat Field Correction  
The Flat Field Correction method normalizes images to an area of known “flat” reflectance (Goetz and Srivastava, 1985; 
Roberts et al., 1986). The method requires that you locate a large, spectrally flat and uniform area in the AVIRIS data, by 
defining a region of interest (ROI). The radiance spectrum from this area is assumed to contain primarily atmospheric 
effects and the solar spectrum. The average AVIRIS radiance spectrum from the ROI is used as the reference spectrum, 
which is then divided into the spectrum at each pixel of the image. The result is apparent reflectance data that you can 
compare with laboratory spectra.  

Internal Average Relative Reflectance (IARR)  
The IARR calibration method normalizes images to a scene average spectrum. This is particularly effective for reducing 
imaging spectrometer data to relative reflectance in an area where no ground measurements exist and little is known 
about the scene (Kruse et al., 1985; Kruse, 1988). It works best for arid areas with no vegetation. The IARR calibration is 
performed by calculating an average spectrum for the entire AVIRIS scene and using this as the reference spectrum. 
Apparent reflectance is calculated for each pixel of the image by dividing the reference spectrum into the spectrum for 
each pixel.  

Empirical Line Calibration  
The Empirical Line correction method forces image data to match selected field reflectance spectra (Roberts et al., 1985; 
Conel et al., 1987; Kruse et al., 1990). This method requires ground measurements and/or knowledge. Two or more 
ground targets are identified and reflectance is measured in the field. Usually the targets consist of at least one light and 
one dark area. The same two targets are identified in the AVIRIS images and average spectra are extracted for ROIs. A 
linear regression is calculated between the field reflectance spectra and the image radiance spectra to determine a linear 
transform from radiance to reflectance for each band of the AVIRIS dataset. Gains and offsets calculated in the regression 
are applied to the radiance spectra for each pixel to produce apparent reflectance on a pixel-by-pixel basis.  

Select Spectral Library of Calibration Results Spectra  
1. From the ENVI main menu bar, select Spectral → Spectral Libraries → Spectral Library Viewer. The 

Spectral Library Input File dialog appears. 
 

2. Click Open → Spectral Library. Navigate to envi_data\c95avsub and select cup95cal.sli. Click Open. 
This spectral library contains the results from the various calibration methods. 

 
3. In the Spectral Library Input File dialog, select cup95cal.sli and click OK. A Spectral Library Viewer dialog 

appears. 

Select Atmospherically Corrected Spectra from Spectral Library  
1. In the Spectral Library Viewer, select the following: 

 
  Flat Field: Alunite 
  IARR: Alunite 
  Empirical Line: Alunite 
 

2. A Spectral Library Plot appears with spectral profiles of alunite generated from each calibration method. 
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3. Visually compare the calibrations and compare their characteristics. What might explain their differences? 

 
4. When finished, select Options → Clear Plots from the Spectral Library Viewer menu bar.  

 
5. Repeat this process for the minerals buddingtonite, calcite, and silica. What general conclusions can you draw 

about the quality of the different calibration procedures?  
 

Optional: Browse Corrected Data Files  
The corrected data files for all of the different corrections are available for spectral browsing. All files have been 
converted to integer format by multiplying the reflectance values by 1000 (to conserve disk space). Data values of 1000 
indicate an apparent reflectance of 1.0.  
 

1. Open and load the files listed in the table below. 
 

File Type File Name 
Flat Field cup95_ff.int 
IARR cup95_ia.int 
Empirical Line Cup95_el.int 

 
2. Use the Z Profile and multiple linked images to compare apparent reflectance spectra for specific areas of 

interest. 
 

3. After comparing all of the correction methods for a variety of minerals, which calibration methods best reproduce 
the laboratory spectra for all minerals? Do you find that one calibration method is the best?  
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