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 Tutorial: Mosaicking in ENVI 

Overview of This Tutorial 
This tutorial is designed to give you a working knowledge of ENVI’s image mosaicking capabilities. For additional details, 
please see ENVI Help. 
 

Files Used in this Tutorial 
ENVI Resource DVD: envidata/avmosaic 
 

File Description 
Pixel-based mosaicking  
dv06_2.img (.hdr) AVIRIS Scene 02 
dv06_3.img (.hdr) AVIRIS Scene 03 
dv06a.mos Mosaic template for end-to-end AVIRIS 

mosaic 
dv06b.mos Mosaic template for feathered overlapping 

AVIRIS mosaic 
dv06_fea.img (.hdr) Feathered mosaic 
Georeferenced mosaicking  
lch_01w.img (.hdr) Warped, histogram-matched image 
lch_01w.ann Cut-line feathering annotation for above 
lch_02w.img (.hdr) Warped, histogram matched image 
lch_a.mos Mosaic template for georeferenced image 

mosaicking 
lch_mos1.img (.hdr) Georeferenced mosaic result 
Color balancing during mosaicking  
mosaic1_equal.dat (.hdr) Subset of a Landsat-7 ETM image with a 

histogram equalization stretch 
independently applied to each band 

mosaic_2.dat (.hdr) Another subset from the same Landsat-7 
ETM image, without any stretching applied 

 

2 
ENVI Tutorial: Mosaicking in ENVI 



 Tutorial: Mosaicking in ENVI 

Mosaicking in ENVI 
Mosaicking involves combining multiple images into a single composite image. ENVI provides interactive capabilities for 
placing non-georeferenced images within a mosaic, and automated placement of georeferenced images within a 
georeferenced output mosaic. ENVI also provides transparency, histogram matching, and automated color balancing. 
ENVI’s Virtual Mosaic allows you to create and display mosaics without creating large output files. 
 
The following sections provide useful information about mosaics in ENVI before you start the exercises. The actual 
exercises begin with the section “Pixel-Based Mosaicking Example” on page 4.  

Feathering 
To blend or blur the seams between mosaicked images, you can feather the edges of overlapping areas using either edge 
feathering or cut-line feathering over a specified distance. To use feathering when mosaicking images, import the bottom 
image without feathering. Then import the overlapping images with edge or cut-line feathering. 

Edge Feathering 
Edge Feathering uses a pixel distance you specify to blend the seams along 
the edges of the mosaicked image. The edge is blended using a linear ramp 
that averages the two images across the specified distance. For example, if 
the specified distance is 20 pixels, 0% of the top image is used in the 
blending at the edge and 100% of the bottom image is used to make the 
output image. At 20 pixels from the edge, 100% of the top image is used to 
make the output image and 0% of the bottom image is used. At 10 pixels 
from the edge, 50% of each image is used to make the output image.  
 
 

Cut-line Feathering 
Cut-line Feathering uses a pixel distance and annotation file you specify to 
blend the image boundaries. You must define cut-lines using the annotation 
tools prior to mosaicking. The annotation file must contain a polyline defining 
the cut-line that is drawn from edge-to-edge, and you must place a symbol in 
the region of the image that will be cut off. The cut-line distance is used to 
create a linear ramp that averages the two images across that distance from 
the cut-line outwards. For example, if the specified distance is 20 pixels, 
100% of the top image is used in the blending at the cut-line and 0% of the 
bottom image is used to make the output image. At 20 pixels from the c
0% of the top image is used to make the output image and 100% of the 
bottom image is used. At 10 pixels from the cutline, 50% of each image is 
used to make the output image. 

utline, 

Virtual Mosaics 
You can use a mosaic template file to construct a “Virtual Mosaic,” one that can be displayed and used by ENVI without 
actually creating a mosaic output file. You cannot use feathering when creating a Virtual Mosaic in ENVI. 
 
After creating a mosaic, save the template file by selecting File → Save Template from the Image Mosaicking dialog 
menu bar. This creates a small text file describing the mosaic layout. 

 
To use the Virtual Mosaic, select File → Open Image File from the ENVI main menu bar and open the mosaic template 
file. All of the images used in the mosaic are opened and their bands are listed in the Available Bands List. Display or 
process any of the bands in the Virtual Mosaic, and ENVI treats the individual images as if they were an actual mosaic 
output file. The new processed file has the specified size of the mosaic, and the input files are in their specified positions 
within the mosaic. 
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Pixel-Based Mosaicking Example 
Before attempting to start the program, ensure that ENVI is properly installed as described in the Installation Guide that 
shipped with your software. 

Import and Position Images 
1. From the ENVI main menu bar, select Map → Mosaicking → Pixel Based. The Pixel Based Mosaic dialog 

appears. 
 

2. From the Pixel Based Mosaic dialog menu bar, select Import→ Import Files. The Mosaic Input Files dialog 
appears. 

 
3. Select Open → New File. Navigate to envidata\avmosaic and select dv06_2.img. Click Open. 

 
4. Repeat Step 3 for dv06_3.img. 

 
5. In the Mosaic Input Files dialog, click <Shift> to select both images. Click OK. The Select Mosaic Size dialog 

appears. 
 

6. In the Mosaic Xsize field, enter 614. In the Mosaic Ysize field, enter 1024. Click OK. A Pixel Mosaic dialog 
appears: 

 
 

7. The bottom of the Pixel Mosaic dialog lists the current position of the images. Select dv06_3.img, enter 513 in 
the Y0 field, and press <Enter>. The file dv06_3.img is placed directly below dv06_2.img. 
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8. From the Pixel Mosaic dialog menu bar, select File → Apply. A Mosaic Parameters dialog appears.  
 
9. In the Enter Output Filename field, enter dv06.img and click OK to create the mosaic. 
 
10. To create a Virtual Mosaic instead of a new mosaic file, select File → Save Template from the Pixel Based 

Mosaic dialog menu bar. When the Output Mosaic Template dialog appears, enter the output filename 
dv06a.mos. 

 
11. In the Available Bands List, select Mosaic (Band 1) under dv06.mos (or dv06a.mos from Step 9) and click 

Load Band. 

More on Positioning Images 
The second part of this example shows you how to position the two images into a composite mosaic image by entering 
X0 and Y0 values, or by dragging the images to the desired locations within the Pixel Mosaic dialog. The example also 
includes edge feathering. 
 

1. In the Pixel Mosaic dialog, select Options → Change Mosaic Size. The Select Mosaic Size dialog appears. 
 
2. In the Mosaic Xsize and Mosaic Ysize fields, enter 768. Click OK. 
 
3. In the Pixel Mosaic dialog, click the image surrounded by a green box (dv06_2.img) and drag it to the lower-

right corner of the dialog. 
 

4. Right-click inside this image and select Edit Entry. An Entry: dialog appears. 
 

5. In the Data Value to Ignore field, enter 0.  
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6. In the Feathering Distance field, enter 25. 

 
7. Leave the default values for other fields and click OK. 

 
8. Click the image surrounded by a red box (dv06_3.img) and drag it to the upper-left corner of the dialog. Then, 

repeat steps 4-7 for this image. 
 

 
 

9. From the Pixel Mosaic menu bar, select File → Save Template. An Output Mosaic Template dialog appears. 
 

10. In the Enter Output Filename field, enter dv06b.mos. Click OK.  
 

11. In the Available Bands List, select Virtual Mosaic (Band 1) and click Load Band. No feathering is performed 
with a Virtual Mosaic. 

 
12. Make the same image as a feathered mosaic by creating an output file. From the Pixel Mosaic dialog menu bar, 

select File → Apply. A Mosaic Parameters dialog appears. 
 

13. In the Enter Output Filename field, enter dv06f.img. 
 

14. In the Background Value field, enter 255. Click OK.  
 

15. In the Available Bands List, click Display #1 and select New Display. 
 

16. Select Mosaic (Band 1) under dv06f.img and click Load Band. If you cannot see the entire image in the 
Image window, click and drag a corner of the Image window to resize it. 

 
17. Compare the Virtual Mosaic and the feathered mosaic using image linking and dynamic overlays. The following 

figure shows the feathered output mosaic produced by overlapping the two AVIRIS scenes. 
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18. From the Available Bands List menu bar, select File → Close All Files. 

19. Close the Pixel Mosaic dialog and all display groups. 
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Map Based Mosaicking Example 

Create the Map Based Mosaic Image 
1. From the ENVI main menu bar, select Map → Mosaicking → Georeferenced. A Map Based Mosaic dialog 

appears. 
 
2. From the Map Based Mosaic dialog menu bar, select File → Restore Template. A file selection dialog appears. 

 
3. Navigate to envidata\avmosaic and select lch_a.mos. Click Open. This opens the files associated with the 

mosaic template and restores the mosaic parameters necessary for a georeferenced, feathered mosaic. 
 

  You can also individually import georeferenced images and set the feathering options by selecting Import → 
Import Files from the Map Based Mosaic dialog menu bar. Images will automatically be placed in their 
correct geographic locations. The location and size of the georeferenced images will determine the size of the 
output mosaic. 

View the Top Image, Cut-line and Virtual, Non-Feathered Mosaic 
1. In the Available Bands List, select Warp under lch_01w.img and click Load Band. 
 
2. Right-click in the Image window and select Toggle → Display Scroll Bars. Click the horizontal scroll bar until a 

good portion of the image is visible. 
 

3. From the Display group menu bar, select Overlay→ Annotation. An Annotation dialog appears. 
 

4. From the Annotation dialog menu bar, select File → Restore Annotation. A file selection dialog appears. 
 

5. Select lch_01w.ann and click OK. The display group shows a red cut-line used to blend the two images in this 
mosaic. 

 
6. In the Available Bands List, click Display #1 and select New Display. 

 
7. Select Warp under lch_02w.img and click Load Band.  

 
8. Can you identify the relationship between the cut-line and this image? 

 
9. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 

 
10. Select lch_a.mos and click Open.  

 
11. In the Available Bands List, click Display #2 and select New Display. 

 
12. Select Virtual Mosaic under lch_a.mos and click Load Band. 

 
13. Examine the non-feathered edge between the two images that were used to create the mosaic: 
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Create the Output Feathered Mosaic 
1. From the Mosaic dialog menu bar, select File → Apply. A Mosaic Parameters dialog appears. 
 
2. In the Enter Output Filename field, enter lch_mos.img and click OK to create the feathered mosaic. 
 
3. Close Display #1 (lch_01w.img) and Display #2 (lch_02w.img). 

 
4. In the Available Bands List, click Display #3 and select New Display. 

 
5. Select Warp under lch_01w.img and click Load Band. 

 
6. Compare the feathered mosaic to the non-feathered mosaic using image linking and dynamic overlays. 

 

9 
ENVI Tutorial: Mosaicking in ENVI 



 Tutorial: Mosaicking in ENVI 

Color Balancing During Mosaicking 
This tutorial describes the procedure for creating a georeferenced mosaic using automated color balancing. For this 
exercise, you will use two overlapping subsets from a Landsat-7 ETM image. 

Create the Mosaic Image without Color Balancing 
First, you will create a mosaic without color balancing. You will start by importing both of the images without any 
feathering so you can clearly see the seams between the images. 
 

1. From the ENVI main menu bar, select Map → Mosaicking → Georeferenced. A Map Based Mosaic dialog 
appears. 

 
2. From the Map Based Mosaic dialog menu bar, select Import → Import Files. A Mosaic Input Files dialog 

appears. 
 

3. In the Mosaic Input Files dialog, click Open and select New File. Navigate to envidata\avmosaic and select 
mosaic1_equal.dat. Click Open. A histogram equalization stretch was independently applied to each band in 
this image. 

 
4. Repeat Step 3 for mosaic_2.dat. 

 
5. In the Mosaic Input Files dialog, Click <Shift> to select mosaic_2.dat and mosaic1_equal.dat. Click OK. 

The two images are automatically placed in their correct geographic locations in the Mosaic dialog. By default, a 
2% contrast stretch is applied to the images. 
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RGB Mosaic Preview 
 

1. Right-click inside the image surrounded by a green box (mosaic1_equal.dat) and select Edit Entry. An 
Entry: dialog appears. 

 
2. Click the Mosaic Display toggle button to select RGB. 

 
3. In the Red field, enter 1. In the Green field, enter 2. In the Blue field, enter 3.  

 
4. Click OK. The file mosaic1_equal.dat is now displayed in color in the Mosaic dialog. 

 
5. Repeat steps 1 through 4 for the other file in the mosaic (mosaic_2.dat). 

 
By default, ENVI automatically creates an RGB composite in the Mosaic dialog using the first band as red, the second 
band as green, and the third band as blue. If an image has more than three bands, the Mosaic dialog only shows a gray 
scale version of Band 1. 

Output the Mosaic Without Color Balancing 
You should remember that what you see in the Mosaic dialog is not necessarily what you will see in the final mosaic. In 
the Mosaic dialog, the two images are stretched independently. If the images are mosaicked into one image and 
displayed, ENVI calculates a contrast stretch from the two images combined. 
 

1. From the Mosaic menu bar, select File → Apply. A Mosaic Parameters dialog appears. 
 

2. In the Enter Output Filename field, enter mosaic_unbalanced.dat and click OK. 
 

3. In the Available Bands List, click RGB Color. Select Band 1, Band 2, and Band 3, and click Load RGB. The 
seams between the two images are quite obvious. 

Output the Mosaic With Color Balancing 
You will now apply the mosaic again, this time using color balancing to minimize the contrast between the two images in 
the final mosaic. 
 

1. In the Mosaic dialog, right-click inside the image surrounded by a green box (mosaic1_equal.dat) and select 
Edit Entry. An Entry: dialog appears. 

 
2. Click the Adjust radio button. The contrast of this image will be adjusted to match the other image. Click OK. 

 
3. In the Mosaic dialog, right-click inside the image surrounded by a red box (mosaic_2.dat) and select Edit 

Entry. An Entry: dialog appears. 
 

4. Click the Fixed radio button. The contrast of this image will not change. The other image will be adjusted to 
match this image. Click OK. 

 
5. From the Mosaic dialog menu bar, select File → Apply. A Mosaic Parameters dialog appears with a Color Balance 

option near the bottom. Leave the default value "stats from overlapping regions." Color balancing is usually better 
when based on statistics calculated from only the overlapping regions. The other option (stats from complete 
files) is used when the mosaicked images have little or no overlap between them. 

 
6. In the Enter Output Filename field, enter mosaic_balanced.dat and click OK. 

 
7. In the Available Bands List, click RGB Color. Under mosaic_balanced.dat, select Band 1, Band 2, and 

Band 3, and click Load RGB. The seams between the two images are nearly invisible now. 
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