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OENVI Tutorial: Image Georeferencing and Registration

Overview of This Tutorial

This tutorial provides basic information about georeferenced images in ENVI and provides a starting point for conducting
image-to-image and image-to-map registration using ENVI. It assumes that you are already familiar with general image-
registration and resampling concepts. This tutorial is designed to be completed in about 1 to 2 hours.

Files Used in This Tutorial
ENVI Resource DVD: envidata\bldr_reg

File Description

bldr_sp.img (.hdr) Boulder SPOT georeferenced image subset

bldr_tm.img (.hdr) Non-georeferenced Boulder TM data

bldr_tm.pts GCPs for TM-SPOT image-to-image registration

bldrtm_m.pts GCPs for TM-Map registration

bldr_rd.dIg Boulder roads DLG

Generated Files

bldr_tm1.wrp (.hdr) Image-to-image result using RST and nearest neighbor

bldr tm2.wrp (.hdr) Image-to-image result using RST and bilinear interpolation

bldr_tm3.wrp (.hdr) Image-to-image result using RST and cubic convolution

bldr_tm4.wrp (.hdr) Image-to-image result using 1st degree polynomial and cubic
convolution

bldr_tm5.wrp (.hdr) Image-to-image result using Delaunay triangulation and cubic
convolution

bldrtm_m.img (.hdr) Image-to-map result using RST and cubic convolution for the Boulder
TM data

bldrtmsp.img (.hdr) Boulder TM/SPOT sharpening result using HSV sharpening, 10 meter
pixels

Georeferenced Images in ENVI

ENVI provides full support for georeferenced images in numerous predefined map projections including UTM and State
Plane. In addition, ENVI's user-configurable map projections allow construction of custom map projections utilizing 6 basic
projection types, over 35 different ellipsoids, and more than 100 datums to suit most map requirements.

ENVI map projection parameters are stored in an ASCII text file map_proj . txt that you can edit or modify using ENVI
map projection utilities. The information in this file is used in the ENVI header files associated with each image and allows
simple association of a reference pixel location with known map projection coordinates. Selected ENVI functions can then
use this information to work with the image in georeferenced data space.

ENVI’'s image registration and geometric correction utilities allow you to reference pixel-based images to geographic
coordinates and/or correct them to match base image geometry. Ground control points (GCPs) are selected using the
Image and Zoom windows for both image-to-image and image-to-map registration. Coordinates are displayed for both
base and uncorrected image GCPs, along with error terms for specific warping algorithms. Next GCP point prediction
allows simplified selection of GCPs.

Warping is performed using resampling, scaling and translation (RST), polynomial functions (of order 1 through n), or
Delaunay triangulation. Resampling methods supported include nearest-neighbor, bilinear interpolation, and cubic
convolution. Comparison of the base and warped images using ENVI's multiple dynamic overlay capabilities allows quick
assessment of registration accuracy.

The following sections provide examples of some of the map-based capabilities built into ENVI. Consult ENVI Help for
additional information.
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Opening and Displaying Georeferenced Data

Before attempting to start the program, ensure that ENVI is properly installed as described in the Installation Guide that
shipped with your software.

1.
2.

1.

4.

Displaying the Cursor Location and Value

Viewing Map Info in the ENVI Header

From the ENVI main menu bar, select File > Open Image File.

Navigate to the envidata\bldr_reg directory, select the file bldr_sp. img from the list, and click Open.
The Available Bands List appears.

From the Available Bands List, select the Georeferenced SPOT band from the list and click Load Band to load
the image into a new display group.

In the Available Bands List, right click on the Map Info icon and

. ] . . . — Image Coaordinate of Tie Point
select Edit Map Information. The Edit Map Information dialog

appears. Image | 1.0000 a
This dialog lists the basic map information used by ENVI in ImageY|1.UUDU -
georeferencing. The image coordinates correspond to a reference _ —
pixel used by ENVI as the starting point for the map coordinate — Map Coordinate of Tie Point
system. Eecguse ENVI knows the map projection,. pixel si;e, and Fioi: UTH. Zone 13 Merth
map projection parameters based on this header information and 8] Datur: Marth America 1927
the map projection text file, it can calculate the geographic
coordinates of any pixel in the image. You can enter coordinates 4550340000 :
S ; . . . | . E Ch Praj... |
in either map coordinates or geographic (latitude/longitude) ange T
coordinates. 44414730000 N |Units: Meters
Click on the projection field toggle button ﬂ to display the
latitude/longitude coordinates for the UTM Zone 13 North map — Pixel Size and Ratation
projection. Note that ENVI makes this conversion on-the-fly. o
# Pixel Size|10.00000000 Meters

Click the DDEG hutton then click the DMS to toggle between
degrees-minutes-seconds, and decimal degrees, respectively. ' Pixel Size |10.00000000 M eters
Click Cancel to exit the Edit Map Information dialog.

P g tap Ratation |0.000000 a

(] | Ear‘u:e|| Elear|

You can choose to display the location of your mouse cursor, screen value (RGB color), and the data value of the pixel
underneath the crosshair cursor using the Cursor Location/Value dialog. When several display groups are open, this
dialog specifies which display group’s location and value are being reported.

1.

To display the cursor location and value, select Window - Cursor Location/Value from either the ENVI main
menu bar or the Display group menu bar. You can also double-click inside the Image window.

Move the mouse cursor over the Image, Scroll, or Zoom windows to display location and value information in the
Cursor Location/Value dialog. Note that the coordinates are given in both pixels and georeferenced coordinates
for this georeferenced image. Also note the relation between map coordinates and latitude/longitude.

From the Cursor Location/Value menu bar, select File > Cancel to close the dialog.

Keep the display group open for the next exercise.
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Image to Image Registration

This section of the tutorial takes you step-by-step through Image to Image Registration. The georeferenced SPOT image
will be used as the base image, and a pixel-based Landsat TM image will be warped to match the SPOT.

Opening and Displaying a Landsat TM Image File
1. From the ENVI main menu bar, select File 2 Open Image File.

2. Navigate to the envidata\bldr_reg directory, select the file bldr_tm. img from the list, and click Open.
The Available Bands List appears and the RGB image is automatically loaded into a new display group.

Displaying the Cursor Location and Value
1. Double-click in the Image window to display the Cursor Location/Value tool.

2. Move the mouse cursor over the Image, Scroll, or Zoom windows to display location and value information in the
Cursor Location/Value dialog. Note that the coordinates are given in pixels since this is a pixel-based image rather
than a georeferenced image like the SPOT data you used in the previous exercise.

3. From the Cursor Location/Value menu bar, select File & Cancel to close the dialog.

Starting Image Registration and Loading Ground Control Points

1. From the ENVI main menu bar, select Map = Registration = Select GCPs: Image to Image. The Image to
Image Registration dialog appears.

2. In the Base Image field, select Display #1 (the SPOT image). In the Warp Image field, select Display #2
(the TM image).

3. Click OK to start the registration. The Ground Control Points Selection dialog appears.

#£ Ground Control Points Selection g@@

File Options Help

Base|20500  $v[10700 & | Dearee|l %

wap|201.00  &v|20000 &

&dd Pairtt |Num|:uer of Selectedﬂ%_‘

Show Ligt |RMS Emmor: NAS The Predict button allows
prediction of new GCPs based
on the current warp model.

N—

4. You can add individual ground control points (GCPs) by positioning the cursor in the two images to the same
ground location. In the Base field, type 753 for the x location and 826 for the y location. Press the Enter key
after typing each value, to move the cursor in the SPOT image. In the Warp field, type 331 for the x location
and 433 for the y location to move the cursor in the TM image.

5. Examine the locations in the two Zoom windows and adjust the locations if necessary by clicking the left mouse
button in each Zoom window at the desired locations. Note that sub-pixel positioning is supported in the Zoom
windows. The larger the zoom factor, the finer the positioning capabilities.

6. In the Ground Control Points Selection dialog, click Add Point to add the GCP to the list. Click Show List to view
the GCP list. Try this for a few points to get a feel for selecting GCPs. Note the list of actual and predicted points
in the dialog. Once you have at least 4 points, the RMS error is reported.
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7. From the Ground Control Points Selection dialog menu bar, select Options = Clear All Points to clear all of
your points.

8. From the Ground Control Points Selection dialog menu bar, select File > Restore GCPs from ASCII.

9. Navigate to the envidata\bldr_reg directory, select the file bldr_tm.pts from the list, and click Open.
Previously saved GCP parameters are loaded into the dialog.

10. Try positioning the cursor at a new location in the Image window containing the SPOT image. Click the Predict
button to move the cursor position in the TM image to match its predicted location based on the warp model.

11. The exact position can now be interactively refined by moving the pixel location slightly in the TM data.

12. Click Add Point in the Ground Control Points Selection dialog to add the new GCP to the list.

Working with GCPs

The following image provides descriptions of the features and functions available in the Image to Image GCP List. Click
Show List to view the GCP list. Click on individual GCPs in the Image to Image GCP List dialog and examine the
locations of the points in the two images, the actual and predicted coordinates, and the RMS error. Resize the dialog to
observe the total RMS Error listed in the Ground Control Points Selection dialog.

& Image to Image GCP List

File Options

Bazex | BazeY | Wapx | “Wapy | Predict | Predict™ | Emor Error 'y RS |

L ua oon-no 42000  BE200 4207518 BEZEIVF 07FR18 0B3VF 09883 A

0 3300 43300 3309989 43259335 |-00011  |-00BER | 0.0BES

030000 20000 3007910 2008478 (07910 |-00822  |0.7927

2335443 08975 04557 10065

Rav.2477 -0BRA0 02477 07040

831 01587 02208

03023 1.0432

5247 08937 W
*

Clicking on the On/Off button in the
Image to Image GCP List dialog
removes selected GCPs from
consideration in the Warp model and
RMS calculations. These GCPs are
not actually deleted, just
disregarded, and can be toggled
back on using the On/Off button.

o+

Clicking the Delete button
removes a GCP from the list.

Positioning the cursor location
in the Zoom window and
clicking the Update button
updates the selected GCP to

7 the current cursor locations.
Goto | Ofv0ft | Délete | Update [[| Hide D T

Warping Images

Images can be warped from the displayed band, or multiband images can be warped all bands at once. For this exercise
you will warp only the displayed band.

1. From the Ground Control Points Selection dialog menu bar, select Options - Warp Displayed Band. The
Registration Parameters dialog appears.

2. Click the Method drop-down list and select RST.
3. Ensure the Resampling drop-down list has the Nearest Neighbor option selected.

4. In the Enter Output Filename field, type bldr_tml.wrp as the new filename and click OK. The warped
image is listed in the Available Bands List when the warp is completed.

5. From the Ground Control Points Selection dialog menu bar, select Options > Warp Displayed Band. The
Registration Parameters dialog appears.

6. Click the Method drop-down list and select RST.
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10.

11.

Click the Resampling drop-down list and select Bilinear.

In the Enter Output Filename field, type bldr_tm2._.wrp as the new filename and click OK. The warped
image is listed in the Available Bands List when the warp is completed.

Repeat steps 5 — 8 using the RST method and Cubic Convolution resampling, then name the output file
bldr_tm3.wrp.

Repeat steps 5 — 8 using the Polynomial method and Cubic Convolution resampling, then name the output
file bldr_tm4 _wrp.

Repeat steps 5 — 8 using the Triangulation method and Cubic Convolution resampling, then name the output
file bldr_tm5._wrp.

Comparing Warp Results
Now you will use dynamic overlays to compare your warp results:

1.

10.
11.
12.

13.
14.

In the Available Bands List, click once to select the bldr_tm. img file, then select File - Close Selected File
from the menu bar. In the subsequent ENVI warning dialog, click Yes to close the associated display group.

In the Available Bands List, select the bldr_tml.wrp file, click the Display # drop-down button, select New
Display, then click Load Band to load the file into the new display.

Right-click in the Image window and select Link Displays. The Link Displays dialog appears.
Click OK in the Link Displays dialog to link the SPOT and the registered TM image.

Compare the SPOT and the TM images using the dynamic overlay by clicking the left mouse button in the Image
window of the TM image.

Load bldr_tm2_wrp and bldr_tm3.wrp into new displays and use the image linking and dynamic overlays to
compare the effect of the three different resampling methods: nearest neighbor, bilinear interpolation, and cubic
convolution.

Note how jagged the pixels appear in the nearest neighbor resampled image. The bilinear interpolation image
looks much smoother, but the cubic convolution image is the best result, smoother, but retaining fine detail.

Close the bldr_tml.wrp and bldr_tm2.wrp display groups (select File & Cancel from the associated Display
group menu bars).

Load bldr_tm4_wrp and bldr_tm5.wrp into new display groups, and use the image linking and dynamic
overlays to compare to bldr_tm3.wrp (RST Warp).

Note the effect of the three different warping methods: RST, 1st degree Polynomial, and Delaunay Triangulation
on the image geometry.

Use dynamic overlay to compare to the georeferenced SPOT data.
To display the Cursor Location/Value tool, double-click in the Image window.

Browse the georeferenced datasets and note the effect of the different resampling and warp methods on the data
values.

From the Display group menu bar, select File 2 Cancel to close the dialog.

From the ENVI main menu bar, select File = Close All Files to close all of the data files. Click Yes on the
corresponding warning dialog.
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Image to Map Registration

This section of the tutorial will take you step-by-step through an Image to Map registration. Many of the procedures are
similar to Image to Image registration and will not be discussed in detail. The map coordinates picked from the
georeferenced SPOT image and a vector Digital Line Graph (DLG) will be used as the base image, and the pixel-based
Landsat TM image will be warped to match the map data.

Opening and Displaying a SPOT Image File

1. From the ENVI main menu bar, select File 2 Open Image File.

2. Navigate to the envidata\bldr_reg directory, select the file bldr_sp. img from the list, and click Open.
The Available Bands List appears.

3. Select Georeferenced SPOT under bldr_sp. img, and click Load Band. The georeferenced SPOT image
appears in a new display group.

Opening and Displaying a Landsat TM Image File
1. From the ENVI main menu bar, select File > Open Image File.

2. Navigate to the envidata\bldr_reg directory, select the file bldr_tm. img from the list, and click Open. A
Landsat TM RGB image is automatically loaded into a new display group.

Selecting Image-to-Map Registration and Restoring GCPs

1. From the ENVI main menu bar, select Map = Registration 2 Select GCPs: Image to Map. The Image to
Map Registration dialog appears.

2. From the Display #1 drop-down menu, select Display #2. You will warp the Landsat TM image (in Display #2)
to match the georeferenced SPOT image.

Ensure UTM is selected as the projection.

Type 13 in the Zone field.

Enter 10.0 in the X/Y Pixel Size fields. SPOT data have a spatial resolution of 10m.
Click OK to start the registration. The Ground Control Points Selection dialog appears.

From the Ground Control Points Selection dialog menu bar, select File > Restore GCPs from ASCII.

© N o o A~ W

Navigate to the envidata\bldr_reg directory, select the file bldrtm_m.pts from the list, and click Open.
Previously saved ground control point parameters are loaded into the dialog.

9. In the Ground Control Points Selection dialog, click Show List. The Image to Map GCP List dialog appears.
Examine the base map coordinates, the actual and predicted image coordinates, and the RMS error.

Adding Map GCPs Using Vector Display of DLGs
1. From the ENVI main menu bar, select File > Open Vector File.
2. From the Files of type drop-down list, select USGS DLG.

3. Navigate to the envidata\bldr_reg directory, select the file bldr_rd.dlg from the list, and click Open.
The Import Vector Files Parameters dialog appears.

4. In the Import Vector Files Parameters dialog, click the Memory radio button, then click OK to read the DLG
data. The Available Vectors List dialog appears.

5. Select the ROADS AND TRAILS: BOULDER, CO file, then click Load Selected.
6. Select Display #1 and click OK. The Vector Parameters: Cursor Query dialog appears.
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7.

10.

11.

12.

13.

14.

Return to the Load Vector dialog (from The Available Vectors List dialog, select the ROADS AND TRAILS:
BOULDER, CO file then click Load Selected).

Select New Vector Window, and click OK. This loads the vectors into a new vector window.

Click and drag the mouse in the vector ® Vector Window #1 : Cursor Query
window to activate a crosshair cursor. Fie Mode Edt Oplions Heb

The map coordinates of the cursor will e

be listed at the bottom of the vector '
window.

From the Display group menu bar in the
TM image, select Tools -2 Pixel
Locator.

Type 402 in the Sample field and 418
in the Line field then click Apply to
place the cursor on the road intersection.

Note that sub-pixel positioning accuracy
is again available in the Zoom window.

In the Vector window, position the
vector cursor at the road intersection at
approximately 477593.74, 4433240.0
(40d 3m 3s N, -105d 15m 45s W) by
clicking and dragging with the left mouse
button and releasing when the circle at

the crosshair intersection overlays the 47TEE TACE, 4475040 40N Mode: Cursor Gasey
intersection of interest. 4ITISEN, 105154565W Active: "ROADS AND TRAILS: BOULDER, CO"

Right-click in the vector window and
select Export Map Location. The new map coordinates will appear in the Ground Control Points Selection
dialog.

In the Ground Control Points Selection dialog, click Add Point to add the map-coordinate/image pixel pair and
observe the change in RMS error.

RST and Cubic Convolution Warping

1.

o g k~ w

From the Ground Control Points Selection dialog menu bar, select Options = Warp File. The Input Warp
Image dialog appears.

Select the bldr_tm. img file, and click OK to select all six TM bands for warping. The Registration Parameters
dialog appears.

Click the Method drop-down list, and select RST.
Click the Resampling drop-down list, and select Cubic Convolution.
In the Background field, type 255.

In the Enter Output Filename field, type bldrtm_m. img as the new filename, and click OK. The warped
image is listed in the Available Bands List and automatically loaded into a new display group when the warp is
completed.

Note the skew of the image resulting from removal of the Landsat TM orbit direction. This image is
georeferenced, but at 30 meter resolution versus the 10 meter resolution provided by the SPOT image.

Displaying and Evaluating Results

1.

From the ENVI main menu bar, select File - Open Image File.
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2. Navigate to the envidata\bldr_reg directory, select the file bldr_sp. img from the list, and click Open.
The Available Bands List appears.

3. From the Available Bands List, select the Georeferenced SPOT band from the list, click the Display # drop-
down button and select New Display.

4. Click Load Band to load the SPOT image into a new display group.
Compare the image geometries and scale.

6. From the Ground Control Points Selection dialog menu bar, select File & Cancel to close that dialog. Save the
GCPs if desired.

Now that you have learned how to perform Image to Image and Image to Map registration, refer to the Map Composition
tutorial for guidance on adding grid lines and creating image maps in ENVI.

Ending the ENVI Session

You can quit your ENVI session by selecting File = Exit from the ENVI main menu.
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