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SENVI Tutorial: Interactive Display Functions

Overview of This Tutorial

This tutorial provides an introduction to using ENVI with Panchromatic (SPOT) data, including display, contrast
enhancement, basic information about ENVI and some suggestions for your initial investigations of the software. It is
designed to introduce first-time ENVI users to the basic concepts of the package and to explore some of its key features.
It assumes that you are already familiar with general image-processing concepts. It is recommended that new users
begin with either the Quick Start to ENV/ tutorial or the /ntroduction to ENVI tutorial before beginning this tutorial.

Files Used in This Tutorial
ENVI Resource DVD: envidata\enfidavi

File Description

enfidavi .bil SPOT Panchromatic Data, Enfidaville, Tunisia
enfidavi.hdr ENVI Header for Above

enfidavi .dsc GeoSpot Volume Descriptor File
enfidavi.rep GeoSpot report file (REP/B: GEOSPOT Structure)
enfidavi.rsc GeoSpot Raster Source Description File
dxf.txt DXF coding descriptor file

alti.dxf Spot height DXF file

energy .dxf Oil or Gas Pipeline DXF file

hydro.dxf Hydrology DXF file

industry.dxf Industrial Areas DXF file

physio.dxf Physiographic areas DXF file

popu.dxf Urban Features (Population Centers) DXF file
transpor .dxf Transportation Networks DXF file
copyrite.txt Data Copyright Notice Panchromatic Data and Vector Overlays

This dataset is a SPOT Panchromatic image and corresponding DXF files of Enfidaville, Tunisia, courtesy of ITT Visual
Information Solutions International France. These data are Copyright CNES-Spot Image and IGN France.

Opening a Panchromatic (SPOT) Image File

Before attempting to start the program, ensure that ENVI is properly installed as described in the Installation Guide that
shipped with your software.

1. From the ENVI main menu bar, select File 2 Open Image File.

2. Navigate to the envidata\enfidavi directory, select the file enfidavi.bil from the list, and click Open. The
Available Bands List appears on your screen. This is a SPOT Panchromatic image of Enfidaville, Tunisia, courtesy
of ITT Visual Information Solutions France. The data in this file is copyrighted as Copyright CNES-Spot Image and
IGN France.

3. Select Band 1.
4. Ensure the Gray Scale radio button is selected - then click Load Band to load the image into a new display.
5. Examine the image in the display group.

Performing Interactive Contrast Stretching

Interactive contrast stretching plots a histogram and allows you to interactively control the contrast of the displayed
image. Many different types of stretches can be applied. By default, a linear 2% stretch is applied to the data when it is
first displayed.

2
ENVI Tutorial: Interactive Display Functions



SENVI Tutorial: Interactive Display Functions

1.

2.

From the Display group menu bar, select Enhance = Interactive Stretching. An Interactive Stretching dialog
for the displayed band appears. This dialog allows you to change the contrast stretch of the displayed image.
Two histogram plots display the color or gray scale range of the input image (left) and the output image after
contrast stretching (right). Initially, the input and output histograms reflect the default stretch applied to the data
when the image was displayed.

& #1 Band:Band 1:enfidavi.bil
File Stretch_Type Histogram_Source Defaulks  Options  Help

APPlY | Shetch |1-I . [180

Input Histogram Dutput Histogram

|Eurrent: Linear, Hizt Source: Scrall (53,248 paintz]

Input histogram information can be extracted from the Image window, from the Scroll window (subsampled),
from the Zoom window, from the entire image band (all pixels of the data), or from a user defined region-of-
interest (ROI). Explore the options available in the Histogram_Source menu on the Interactive Stretching

dialog menu bar.

Linear Stretching Options

When images are loaded into the display group, a 2% linear contrast stretch is applied by default. This can be modified
by selecting File 2 Preferences from the Display group menu bar, then clicking the Display Defaults tab.

1.

From the Interactive Stretching dialog menu bar, select Stretch_Type - Linear. Two vertical dotted lines
appear in the input histogram plot—these bars can be repositioned to control the minimum and maximum value
used in the contrast stretch. Input Histagram

In the Input Histogram window, there are two dotted vertical bars on either
side of the histogram. These bars can be repositioned to control the minimum
and maximum value used in the contrast stretch. Position the mouse cursor
over the left bar then click and hold the left mouse button as you drag the bar
from side to side. As the dotted vertical bar is moved across the plot,
numbers appear on the status bar of the Interactive Stretching dialog.
Whenever the left mouse button is clicked over the histogram plot, the status
bar displays the current data value, the number of pixels and percentage of
pixels that have that value, and the cumulative percentage of pixels with
values less than or equal to the current value.

You can choose to have stretching or histogram changes applied to your images automatically, by selecting
Options 2 Auto Apply from the Interactive Stretching dialog menu bar. To have changes applied to your image
only when you click the Apply button, toggle the Auto Apply option off. For this exercise, toggle the Auto
Apply option on.

Position the left dotted vertical bar in the Input Histogram window so that a cumulative percentage of pixels
equaling approximately 5%6 is selected. Now move the right bar so that the cumulative percentage is
approximately 95%b6 of the pixels.
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5.

You can also position the bars by entering a minimum and maximum value (numbers or percentages) in the
Stretch fields provided in the dialog. Enter 4%6 in the left text field and 96%b in the right text field and press
the Enter key. The % values are converted to digital numbers and the left and right bars in the display are
updated with the data values at 4% and 96%, respectively.

Gaussian Stretching Options

The default Gaussian stretch is centered at a mean of 127 with the data values 3 standard deviations set to 0 and 255.

1.
2.

From the Interactive Stretching dialog menu bar, select Stretch_Type =2 Gaussian.

From the Interactive Stretching dialog menu bar, select Options 2 Set Gaussian Stdv to set the standard

deviation. The Set Gaussian Stdv dialog appears allowing you to adjust the standard deviation value and see the
effect when the new setting is applied to the display group.

& Set Gaussian Stdv g|
Murnber of Gaussian Stdws |4.00 &
k. Caricel

Set the Gaussian Stdvs to 4.00 and click OK.

You can choose to have the stretch automatically applied to the image display group by ensuring
Options - Auto Apply is selected from the Interactive Stretching dialog menu bar.

Equalization Stretching Options

You can use the Equalization option in the Interactive Stretching dialog to automatically scale the data to equalize the
number of digital numbers in each histogram bin.

1.
2.

3.

Applying ENVI Color Tables

From the Interactive Stretching dialog menu bar, select Stretch_Type - Equalization.

You can choose to have the stretch automatically applied to the image display group by ensuring
Options - Auto Apply is selected from the Interactive Stretching dialog menu bar.

From the Interactive Stretching dialog menu bar, click File = Cancel to close the Interactive Stretching dialog.

You can use Color Mapping to apply color tables to images, create Fila Options
interactive density sliced images, control the RGB image planes and to
change classification color mapping.
1. From the Display group menu bar, select Tools - Color
Mapping 2 ENVI Color Tables. The ENVI Color Tables dialog 4 ]
appears. Stretch Bottom
o . 4] 1]
2. Explore the (?olor options in the Color Table list and observe the Shetch Top
color-coded image. i T ol
3. Use the Stretch Bottom and Stretch Top sliders to apply quick Eméﬁiﬁf A
; ; I
stretches to the displayed image. EE‘E?ESPEE%JA}WJE
4. From the Color Tables dialog menu bar, select Options > Reset BLUE/GREERAEC ATELL D
Color Table to return to the original stretch and gray scale color STD GAMMA|
table. FRISM
RED-PURPLE
5. From the Color Tables dialog menu bar, select File - Cancel to EEEMH&%&%&&L
close the Color Tables dialog. GREEN-EINE
BLUE-RED bt
4
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Using the Pixel Locator

The Pixel Locator allows exact positioning of the cursor. You can manually enter a sample and line location to position
the cursor in the center of the Zoom window. If an image contains georeferenced data, you can optionally locate pixels
using map coordinates. If the image contains an associated DEM, elevation information displays. The Pixel Locator
pertains to the display group from which it was opened. You can open a Pixel Locator for each display group shown on
your screen.

1. From the Display group menu bar, select Tools - Pixel Locator to open the Pixel Locator dialog.

& #1 Pixel Locator Q@@

File Cptions

Sample|2|:|'| = Line|200 &

g

B91551.0000 E Change Proj...

|4n3a4?9.nnnn M |L|nits: Meters

Froj: UTH, Zone 32 Horth
Dratumn: Moaorth America 1927

e EEER

2. Place the cursor in any of the three windows of the display group and click the left mouse button. Notice that the
Pixel Locator provides the pixel location for the selected pixel.

3. Click the toggle button 4t next to the projection field to toggle between true map coordinates and
latitude/longitude geographic coordinates. You can also choose to change the selected projection by clicking the
Change Proj button.

4. From the Pixel Locator dialog menu bar, select File > Cancel to close the Pixel Locator dialog.

Displaying the Georeferenced Cursor Location

You can use ENVI's Cursor Location/Value to view image values and geographic location. The Cursor Location/Value
option displays the sample (horizontal, X) and line (vertical, Y) coordinates of the cursor along with the data value of the
pixel at the cursor location. The position is continuously updated as you move the cursor around the image.

1. From the Display group menu bar, select Tools = Cursor Location/Value. The Cursor Location/Value dialog
box appears displaying the location of the cursor in the Image, Scroll, or Zoom windows. The dialog also displays
the screen value (color) and the actual data value of the pixel underneath the crosshair cursor.

& Cursor Location... g@@

File Options

Disp #1 (182104] Scmn: B:0G:0 B33
Prajection: UTM, Zone 32 Morth

Map: 531361.00E 4033439.00M Meters
LL : 36°29'51 85"N, 10112 34"E

Data: 22

2. From the Cursor Location/Value dialog menu bar, select File & Cancel to close the Cursor Location/Value dialog.
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Applying Interactive Filters

ENVI gives you the ability to apply several different pre-defined or user-defined filters to a display. The following exercise
shows you how to apply a pre-defined filter to the image in the Image window.

1.

From the Display group menu bar, select Enhance - Filter and choose a desired filter type to apply to the
displayed image.

Experiment with the different sharpening, smoothing, and median filters on the displayed image.

From the Available Bands List, click the Display #1 drop-down button and select New Display to create a
second display group.

Select Band 1 and click Load Band to load the image into the second display.

From the Display group menu bar in image #2, select Enhance - Filter and select a filter different from that
applied to Image #1.

Comparing Images Using Dynamic Overlays

Use image linking and dynamic overlays to overlay portions of multiple images simultaneously (or flicker images) and to
perform identical operations on multiple images from within a single Image window.

1.

. . : Fil= Cpti
Reviewing GeoSpot Map Information pros
- fidai.bil
You can review the GeoSpot Map information for this image in the ENVI Header @ En Ba:;d;
file.
MG top inormation...
1. In the Available Bands List, right click on the Map Info icon and select
Edit Map Information. The Edit Map Information dialog appears. Foud A8 s
Linfold All Files
2. Note that the data are in UTM projection, Zone 32 utilizing the NAD27
datum. * GrayScale ( RGE Color
3. Click Cancel to close the Edit Map Information dialog.
Selected Band
[Band 1:enfidavi bi

From the Display group menu bar, select Tools - Link - Link Displays. You can also right-click in the image
and select Link Displays.

Click OK in the Link Displays dialog to establish the link.
Click the left mouse button in one of the Image windows to see the image displays overlaid on one another.

To create a smaller overlay area, position the mouse cursor anywhere in either Image window (or Zoom window)
and hold down and drag with the middle mouse button. Upon button release, the smaller overlay area is set
and a small portion of the linked image will be superimposed on the current Image window.

Click the left mouse button in the Image window and drag the small overlay window around the image to see the
overlay effects.

Resize the overlay area at by clicking and dragging the middle mouse button until the overlay area is the desired

size.
& Available Bands List D@@

Dims [4565 » 5606 [Byte] [BSQ]

Load Band | Display #2~
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Opening and Overlaying DXF Vector Files
1. From the ENVI main menu bar, select File - Open Vector File.
2. In the Select Vector Filenames dialog, click the Files of type drop-down list and select DXF (*.dxf).

3. Navigate to the envidata\enfidavi directory and select all of the files with the .dxf extension (use the Shift
key to select multiple files).

4. Click Open or OK. The Import Vector Files Parameters dialog appears.

In the Native File Projection section of the dialog (near the bottom), click on UTM. This field refers to the map
units of the imported vector data.

Click the Datum button. The Select Geographic Datum dialog appears.
Select the Mexico (NAD27) datum from the list and click OK.

In the Zone field of the Import Vector Files Parameters dialog, type 32 and click the N radio button.

© © N o

Click the Apply Projection to Undefined button then click OK to load the DXF files and convert them to .evf
(ENVI Vector Files). The Available Vectors List dialog appears.

10. On the Available Vectors List, click the Select All Layers button.
11. Click the Load Selected button. A Load Vector dialog appears which lists all of the available displays.

12. On the Load Vector Dialog, select Display #1 and click OK. The #1 Vector Parameters dialog appears showing
the named vector layers.

13. Click on one of the layer names in the #1 Vector Parameters dialog. In the Image window click and drag using
the left mouse button and observe map coordinates for the selected vectors in the #1 Vector Parameters dialog.

)

EEX

& 1 Band 1:enfidawvi. bil

File ©Cwerlay Enhance Tools  Window

& #1 Yector Parameters : Curs... g@ﬂ

Window: ™ Image  Scrol ¢ Zoom O OFff

Axailable Vector Layers

alti. dwf
erergy. dxf
hidro. dx

[FILaper:
[FILaper:

[FILaper:

pn:npu.u:l:-:f
[*ILaver: tranzpar. dxf
Current Layer |:| Current Highlight .
— —

Lacatian

——

591041.000E ., 4029

o 209.000N
N | [F5°2944 50N, 1005 38°E

Window W Image [ Scroll

Apply

[+ Zoom
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Composing a Basic Map

In this exercise, you will create a basic map. You will add grid lines, annotate your image, and save and output your
image.

Adding a Grid to Your Image

You can use Grid Lines to overlay one or more grids on an image. Grids can be pixel-based or map-coordinate and/or
latitude/longitude based (for georeferenced images). Each display group can have its own set of grids, which are
displayed in the Image, Scroll, and Zoom windows.

1. From the Display group menu bar, select Overlay - Grid Lines. The Grid Line Parameters dialog appears.
Note that an image border is automatically added when you overlay grid lines (visible in the Scroll window).

2. Using the Grid Line Parameters dialog menu bar Options menu, you can adjust the grid lines by setting the line
thickness and color and the grid spacing.

3. When you have added a satisfactory grid, click Apply in the Grid Line Parameters dialog.

Annotating the Image with a Map Key

ENVI's flexible annotation features allow you to add text, polygons, color bars, and other symbols to your plots and
images.

1. From the Display group menu bar, select Overlay - Annotation. The Annotation dialog appears.

& #1 Annotation: Map Key E][E|E|

File ©Object Selected Options Help

Wwindow: ™ Image O Scroll € Zoom O Off

En:nln:nr|:| Ban::kgrn:nunu:l Thick|1 =
Font Roman 3= Size|-IE ¢I:IriEr1| -

Edit Map Key ltems. .. | Rezet ltems v|

2. To annotate a map key corresponding to the DXF overlays, select Object > Map Key from the Annotation
dialog menu bar.

3. Click the Edit Map Key Items button to edit the map key characteristics. The Map Key Object Definition dialog
appears.

4. You can change the names, colors, and fill (for polygons) using the Map Key Object Definition dialog. Click OK to
return to the Annotation dialog.

5. Add a background color by clicking the color swatch in the Annotation dialog. Use the right-click menu to select a
color from a list.

6. Click the left mouse button to place the map key in the Image window. Reposition the map key by clicking, or by
clicking and dragging with the left mouse button. Set the map key by clicking the right mouse button in the
image.

Saving and Restoring Annotation

You can save your image annotation to a file. If you do not save your annotation in a file, it will be lost when you close
the Annotation dialog (you will be prompted to save the annotation if you close without first saving)

1. From the Annotation dialog menu bar, select File > Save Annotation.
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2.

You can also restore saved annotation files by selecting File > Restore Annotation from the Annotation dialog
menu bar.

To suspend annotation operations and return to normal ENVI functionality temporarily, select the Off radio
button at the top of the Annotation dialog. This allows you to use the scroll and zoom features in your display
without losing your annotations.

To return to the annotation function, select the radio button for the window in the display group that you are
annotating.

Saving and Outputting an Image (Burn-In)

ENVI gives you several options for saving and outputting your filtered, annotated, gridded images. You can save your
work in ENVI's image file format, or in several popular graphics formats (including Postscript) for printing or importing
into other software packages. You can also output directly to a printer. For this exercise, you will save the file in
GEOTIFF format.

1.

From the Display group menu bar, select File 2 Save Image As 2 Image File. The Output Display to Image
File dialog appears.

Click the Output File Type drop-down list and select TIFF/GeoTIFF output from the pull-down menu. If the
displayed image is annotated and gridded, both the annotation and grid lines will be automatically saved.

Type or choose an output filename in the field provided and click OK to save the image. Because this is a
georeferenced image, ENVI automatically saves it as a GEOTIFF.

Ending the ENVI Session

You can quit your ENVI session by selecting File = Exit from the ENVI main menu.
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