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14 Chapter 1 Getting Started with ENVI
Introduction to ENVI

ENVI® (the Enviroment for Visualizing Images) is a revolutionary image processing 
system. From its inception, ENVI was designed to address the numerous and specific 
needs of those who regularly use satellite and aircraft remote sensing data. ENVI 
provides comprehensive data visualization and analysis for images of any size and 
any type—all from within an innovative and user-friendly environment.

Advantages of ENVI

One of ENVI’s strengths lies in its unique approach to image processing—it 
combines file-based and band-based techniques with interactive functions. When a 
data input file is opened, its bands are stored in a list, where they can be accessed by 
all system functions. If multiple files are opened, bands of disparate data types can be 
processed as a group. ENVI displays these bands in 8- or 24- bit displays windows. 
ENVI’s display window groups consist of a main Image window, a Zoom window, 
and a Scroll window, all of which are re-sizeable. ENVI provides its users with many 
unique interactive analysis capabilities, accessed from within these windows. ENVI’s 
multiple dynamic overlay capabilities allow easy comparison of images in multiple 
displays. Real-time extraction and linked spatial/spectral profiling from multiband 
and hyperspectral data give users new ways of looking at high-dimensional data. 
ENVI also provides interactive tools to view and analyze vectors and GIS attributes. 
Standard capabilities such as contrast stretching and two-dimensional scatter plots are 
just a few of the interactive functions available to ENVI users. 

ENVI’s strong visual interface is complemented by its comprehensive library of 
processing algorithms. ENVI includes all the basic image processing functions within 
a friendly, interactive point-and-click graphical user interface (GUI). Because of 
ENVI’s GUI, many basic processing functions are easier to use. Some of these 
functions include data transforms, filtering, classification, registration and geometric 
corrections, spectral analysis tools, and radar tools. ENVI does not impose limitations 
on the number of spectral bands that can be processed, so multi-spectral or 
hyperspectral data sets can be used. ENVI also includes many advanced functions 
that allow for analysis of radar data sets.

ENVI addresses common image processing problem areas such as input of non-
standard data types, viewing and analysis of large images, and simple extension of 
analysis capabilities by users (plug-in functions). The software includes essential 
tools required for image processing across multiple disciplines, and has the flexibility 
to allow the user to implement his or her own analysis strategies. 
Introduction to ENVI ENVI User’s Guide
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ENVI, ENVI RT, and IDL

ENVI is written in Interactive Data Language (IDL®), a powerful structured 
programming language that offers integrated image processing. IDL is required to run 
ENVI and the flexibility of ENVI is due largely to IDL’s capabilities. There are two 
types of ENVI licenses, ENVI with a full version of IDL, and ENVI RT which 
includes a runtime version of IDL. ENVI users can utilize IDL’s strengths by 
customizing their own command-line functions. Advanced ENVI users should find 
the flexibility offered by IDL’s interactive features helpful for their dynamic image 
analyses. ENVI RT provides complete ENVI functionality, but custom routines 
cannot be written.

More information on IDL can be found in Using IDL, IDL Reference Guide, and 
other IDL documentation.
ENVI User’s Guide ENVI, ENVI RT, and IDL
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General Review of ENVI Functionality

ENVI simplifies comprehensive interactive processing of large multiband data sets, 
screen-sized images, spectral plots and libraries, and image regions-of-interest, all 
while providing flexible display capabilities and geographic-based image browsing. 
ENVI provides a multitude of interactive functions, including X, Y, Z profiling; 
image transects; linear and non-linear histogramming and contrast stretching; color 
tables, density slicing and classification color mapping; quick filter preview; and 
Region of Interest definition and processing. Simple methods are provided for 
locating specific pixels, and for interactive spatial/spectral pixel editing. ENVI also 
offers interactive scatter plot functions, including two-dimensional Dancing Pixels™ 
and n-Dimensional Visualization™. With ENVI, images can be linked together and 
dynamic overlays created interactively. Comprehensive vector overlays with GIS 
attributes can be created, and map and pixel grids as well as annotations can be added 
to images. Other ENVI interactive functions include three-dimensional (perspective) 
viewing, surface shading, image draping, image animation (movies), and geometric 
rectification and mosaicking.

ENVI’s strengths are not limited to its interactive mode: ENVI functions work with 
full data files and subsets. We provide the user with a complete set of tools to process 
panchromatic images, AVHRR, Landsat MSS data, Landsat TM data, and other 
multispectral and hyperspectral images as well as data from today’s and tomorrow’s 
advanced SAR systems. AVHRR tools allow display of ephemeris data, data 
calibration, geometric rectification, and calculation of sea-surface temperature. 
Landsat tools include functions for de-skewing and correcting aspect ratios for pre-
1979 MSS data, destriping and correcting for atmospheric interference, and 
calibrating to reflectance using pre-launch gains and offsets. Tools for calibrating 
thermal infrared data to emissivity using three methods are also included in ENVI. 

General-purpose image processing functions include data transformations such as 
principal components transformations, band ratios transformations, hue-saturation-
value (HSV), decorrelation stretching, and generation of vegetation indices. Filtering 
functions include convolution kernels for low pass, high pass, median, directional, 
and edge detection. ENVI supports user-defined convolution kernels up to M x N; all 
kernels can be interactively edited. Other specific filter types such as Sobel, Roberts, 
dilation, and erosion are also provided, along with adaptive filters such as Lee, Frost, 
Gamma, and Kuan. Texture filters, including measures for data range, mean, 
variance, entropy, skewness, variance, homogeneity, contrast, dissimilarity, entropy, 
and correlation are provided. With ENVI, frequency-domain filtering (FFT filtering) 
functions such as forward FFT transformations, interactive frequency domain 
filtering, and inverse FFT computations are easily performed.
General Review of ENVI Functionality ENVI User’s Guide
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ENVI provides KMEANS and Isodata unsupervised classification methods. 
Supervised classification in ENVI uses standardized training-set collection 
methodologies to simplify parallelepiped, minimum distance, maximum likelihood, 
and mahalanobis distance classifiers. ENVI also provides the Binary Encoding, 
Neural Net, and Spectral Angle Mapper (SAM) spectral classifiers. Post-
classification processing includes clump, sieve, combine classes, and an interactive 
classification display tool, which allow generalization of image-maps prior to export 
to GIS vector files. ENVI’s confusion matrix/Kappa Coefficient statistics allow 
assessment of classification accuracy. Generation of ROC Curves can be used to 
visualize a classifier’s performance in order to select a decision threshold.

ENVI provides a full suite of tools for processing hyperspectral data, including 
special mapping tools that use either image or library endmembers for linear spectral 
unmixing and matched filtering. ENVI routines can be used to access spectral 
libraries and compare library spectra to image spectra. The Pixel Purity Index™ 
(PPI™) allows users to find the most spectrally pure pixels in an image to determine 
spectral endmembers. The unique n-Dimensional visualizer in ENVI performs 
interactive animation of scatter plots in n-dimensions, providing a dynamic view of 
the data that allows determinative selection of endmember materials and their 
corresponding spectra. Spectral Feature Fitting™ of hyperspectral data to library 
spectra aids in identifying rocks, minerals, vegetation, and other materials. The linear 
spectral unmixing function allows determination of relative spectral abundances 
using multispectral and hyperspectral data. ENVI also provides the Spectral 
Analyst™ to identify materials based on comparison to spectral libraries. Flexible 
Band Math™ and Spectral Math™ functions allow users to enter complex 
mathematical expressions, functions, and procedures that access IDL’s powerful 
array-processing functions.

ENVI also contains comprehensive SAR processing capabilities. All standard ENVI 
processing routines are inherently SAR-capable. In addition, a full suite of SAR-
specific analysis methods is provided, including ingest of standard SAR formats such 
as Radarsat and ERS-1; review and reading of header information from CEOS-format 
data; antenna pattern correction, slant-to-ground range correction and generation of 
incidence angle images. Other SAR functions include adaptive and texture filters, 
creating a synthetic color image, and a broad range of polarimetric data analysis 
methods.
ENVI User’s Guide General Review of ENVI Functionality
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Finally, ENVI provides tools to take image data to final map form. These include 
both image-to-image and image-to-map registration, basic orthorectification, image 
mosaicking, and map composition utilities. An integrated set of vector GIS import, 
export, and analysis tools provide the capability to bring industry-standard GIS data 
into ENVI, view and analyze vectors and GIS attributes (as image overlays as well as 
in a separate vector analysis window), modify existing vectors, query attributes, 
utilize vector layers for raster analysis or generate new vector GIS layers from raster 
image processing results, and create standard GIS export-format files.

ENVI provides all of these capabilities and more in one tightly integrated image 
analysis package.
General Review of ENVI Functionality ENVI User’s Guide
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Starting ENVI

Before starting ENVI, ensure that it is properly installed as described in the 
installation guide. The installation guide is included with the ENVI CDs.

To start ENVI in UNIX

• For ENVI, enter envi at the UNIX command line. 

• For ENVI RT, enter envi_rt at the UNIX command line. 

To start ENVI from a Macintosh system

1. Navigate to the OroborOSX installation folder.

2. Double-click the OroborOSX icon. OroborOSX launches XDarwin and 
displays a UNIX X-Windows command line in an OS X window.

3. Do either of the following:

• For ENVI, enter envi at the OroborOSX command prompt.

• For ENVI RT, enter envi_rt at the OroborOSX command prompt.

To start ENVI from a Windows system

Select Start → Programs → ENVI 4.1 → ENVI.

The main ENVI menu bar appears when the program has successfully loaded and 
executed.
ENVI User’s Guide Starting ENVI
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Command Line Options for Starting ENVI

You can alter the way in which ENVI and IDL are started by supplying command line 
switches along with the command. 

ENVI for UNIX Switches

The following command line switches are available for ENVI on the UNIX platform:

-32

Start IDL in 32-bit mode, otherwise IDL starts in 64-bit mode by default for those 
platforms that support 64-bit. If you have not installed the 64-bit version, the 32-bit 
version will automatically be started. If you have not installed the 32-bit version, this 
flag will not work. For example:

%eniv -32
Starting ENVI ENVI User’s Guide
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ENVI Graphical User Interface (GUI)

To effectively use ENVI, you must be familiar with the concept 
of a Graphical User Interface (GUI). A GUI provides a graphical 
means (buttons, menus, dialog boxes, etc.) of interacting with 
software and data. You make selections by pointing and clicking 
or clicking and dragging using a mouse or other pointing device. 
This guide assumes that you are familiar with these concepts.

In ENVI, activities are initiated by using the main ENVI menu 
bar menus, which may be oriented horizontally as shown above, 
or vertically as shown on the right. The default arrangement 
depends on user-selected configuration parameters (see “The 
ENVI Configuration File” in Appendix A).

Tip
To change the orientation of the ENVI menu bar, simply grab a 
corner of the menu bar with the mouse and drag.

Emulating a Three-Button Mouse

To use all of ENVI’s functions, you need a three-button mouse or a way to emulate a 
three-button mouse. Systems that do not have a mouse with at least three buttons (or a 
way to emulate three buttons) and the appropriate mouse driver software will not be 
able to run portions of ENVI that require the third mouse button. A three-button 
emulation is included with ENVI for Windows and ENVI for Macintosh. 

Windows Platform Hardware

On a two button mouse, the left button is the mouse button 1, the right button is 
mouse button 3, and you emulate the middle button (mouse button 2) by 
simultaneously pressing the Ctrl key and the left mouse button.
ENVI User’s Guide ENVI Graphical User Interface (GUI)
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Macintosh Platform Hardware

For Mac OS X with the single-button mouse: use the mouse as the left mouse button 
(mouse button 1); use Option + mouse to emulate the right mouse button (mouse 
button 3); and use Command + mouse to emulate the middle mouse button (mouse 
button 2).
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General Image Display Concepts

An image display group in ENVI consists of three different image windows: a Main 
Image window, a Zoom window, and a Scroll window. An example of an ENVI 
image display group is shown in the following figure. The individual image windows 
of a display group can be re-sized, moved to anywhere on the screen, and the display 
style (which combination of three windows will appear) can be selected. For more 
information on setting display preferences, see “Setting ENVI Preferences” in 
Chapter 2. Multiple image display groups can be used to display many images at one 
time.

Figure 1-1: ENVI Display Group
ENVI User’s Guide General Image Display Concepts



24 Chapter 1 Getting Started with ENVI
The Main Image Window

The Main Image window consists of a portion of an image displayed at full 
resolution. This window is automatically displayed the first time you load an image. 
The initial size of the window is controlled by parameters set in the envi.cfg 
configuration file (see “The ENVI Configuration File” in Appendix A). It can also be 
dynamically resized (see “Resizing Windows” on page 25). ENVI allows loading 
multiple Main Image windows and their associated Scroll and Zoom windows.

The Display Menu in the Main Image Window

In the Main Image window (or Zoom window if alternative display window styles are 
used), the Display menu bar contains five pull-down menus that control all of the 
ENVI interactive display functions including image linking and dynamic overlays; 
spatial and spectral profiles; contrast stretching; color mapping; interactive features 
such as ROI definition, cursor location and value, scatter plots and surface plots; 
overlays such as annotation, grids, image contouring, and vector layers; animation; 
file management tools such as saving and printing images; and display controls such 
as viewing display information and opening displays. See Chapter 4, “Interactive 
Display Functions” for more information and step-by-step procedures.

The Scroll Window

The Scroll window is a small image display window that appears when an image is 
larger than can be displayed in the Main Image window at full resolution. The image 
in the Scroll window is displayed at subsampled resolution. The Scroll window 
controls what portion of the image is displayed in the Main Image window. The 
Scroll window location and size are initially set in the envi.cfg file and can be 
modified. You may dynamically resize it to any size up to the screen dimensions (see 
“Resizing Windows” on page 25). Multiple Scroll windows may be present—one for 
each Main Image window loaded.
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The Zoom Window

The Zoom window is a small image display window that displays a portion of the 
Main Image window at a user-defined zoom factor based on pixel replication or 
interpolation. The zoom window size, location and the default zoom factor are 
initially set in the envi.cfg file and can be modified. The Zoom window provides 
unlimited zoom capabilities, and the zoom factor is displayed as a number in 
parentheses in the window’s title bar. The Zoom window can be dynamically resized 
up to the available screen dimensions (see “Resizing Windows” on page 25). If 
alternative display window styles are used, the Display menu bar described above 
will appear in the Zoom window. Multiple Zoom windows may be present—one for 
each Main Display window loaded.

Resizing Windows

Most ENVI windows and dialogs, including all image display windows, can be 
dynamically resized up to the full screen dimensions. 

1. Place the mouse cursor on the edge or corner of the dialog or window until the 
cursor becomes a two-way arrow (see the following figure).

2. Click with the left mouse button and drag the window to the desired size and 
shape.

Figure 1-2: ENVI Display Window Resized
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Tip
When you resize a Scroll window, the resampling factor is automatically changed to 
take advantage of the new image size. The resampling factor appears in parentheses 
in the Scroll window’s title bar. If you resize the Main image window so that it is 
large enough to contain the entire image, the scroll window will disappear. It will 
reappear if the image window is made smaller.

The Active Display

At any given time, only one image display group (Main Image, Scroll, and Zoom 
windows) can be active. The active display is the display group into which the next 
image will be loaded. 

Supplemental Windows

ENVI image displays may have a large number of associated supplemental windows. 
Supplemental windows are typically started from the Display menu (see “The 
Display Menu Bar” in Chapter 4), and may include X, Y, Z, and arbitrary profiles, 
histograms, scatter plots, and animation windows. Each supplemental window is 
associated with a specific image display group. Multiple displays can have 
independent groups of supplemental windows.

Vector Display Groups

When vectors are displayed separately from any image display, they appear in a 
single window with a Vector menu at the top as shown in the following figure. When 
vectors are overlaid onto an image display, the items from the Vector menu appear in 
a separate Vector Parameters dialog.
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Like image display windows, vector windows can be re-sized and placed anywhere 
on the screen (see “Overlaying Vectors” in Chapter 4). 

Figure 1-3: ENVI Vector Display
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Data Management

ENVI provides a number of tools for managing images, vector data, dialogs, and 
individual windows. These tools are introduced in the following sections, but are 
covered more completely in Chapter 3, “Display Management” as well as in Chapter 
2, “File Management”.

The Available Bands List

The Available Bands List is the main control panel for accessing ENVI image files 
and the individual image bands within those files. The Available Bands List appears 
in its own dialog whenever an image file is opened, contains a list of all of the 
available image bands for all of the open files and any memory items (calculations 
performed in memory but not saved), and shows map information for registered 
images. If multiple files are open, all of the bands for all of the files are listed 
sequentially with the bands of the most recently opened file at the top of the list. Use 
the Available Bands List to load both grayscale and color images into the active 
display, to open and close files, or to delete individual bands from memory (see “The 
Available Bands List” in Chapter 3).

The Available Vectors List

The Available Vectors List contains a list of all vector files that are available in 
memory for display in either image display windows or in a vector display window. 
Once loaded, all of the vector layers read into memory are listed sequentially with the 
most recently read vectors at the top of the list. Use the Available Vectors List to start 
vector displays and to delete vector layers from memory (see “The Available Vectors 
List” in Chapter 3).

Scan Directory List and Geo-Browser

The Scan Directory List lists all the ENVI files in a selected directory or directories, 
prints file information, allows opening of selected files, and starts the Geo-Browser 
file display. The Geo-Browser marks the location of all geocoded data with a red flag 
on a world map (see “The Scan Directory List” in Chapter 2).
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The Available Files List

The Available Files List is a tool for managing ENVI image files. It lists the names of 
all currently open files and memory items. Selecting one of the file names lists all of 
the available information about the selected file. This includes parameters such as the 
full path and image name; the number of lines, samples, and bands; the header size; 
the file type; the data type; the interleave; the byte order of the data; and whether or 
not the data is georeferenced and if any wavelengths are associated with the bands. 
Options include removal of memory items, closing or deletion of individual files, and 
writing of memory calculations to disk files. These actions allow optimized use of 
system memory (see “The Available Files List” in Chapter 3).

The ENVI Window Finder

The ENVI Window Finder lists all open major ENVI windows. This includes the 
Main Image, Scroll, and Zoom windows, all of the supplemental windows, and many 
other windows and dialogs used by ENVI’s interactive functions. Use the Window 
Finder to call any window or dialog to the foreground (see “Using the Window 
Finder” in Chapter 3).
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ENVI Processing Status Window

Most ENVI functions report processing status as calculations proceed. A standard 
status window appears immediately after the function is started. The window title 
matches the function being executed and indicates whether the results are being 
placed in memory or an output file. A % Complete progress bar is updated 
periodically as data are processed. A text box indicates the size of each data 
increment processed, based on the tile size (see “Tiling Operations” on page 31). The 
function automatically determines the size of the processing increment. For example, 
the value of 8.3% shown in the following figure indicates that the data is being 
processed in several tiles, each of which contains 8.3% of the total data.

Note
Use the Cancel button to terminate processing if the increment is less than 100%. If 
the increment is equal to 100%, interruption of the function is not possible.

Figure 1-4: Processing Status Window
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Memory Management

ENVI allows processing of large data sets by tailoring to system memory resources. 
ENVI uses tiling to break data sets into manageable pieces and allows you to set the 
size of a tile in the ENVI configuration file.

Tiling Operations

ENVI uses tiling to allow the processing of large images and to control system 
memory usage. A tile is a piece of data read from the disk or from memory in one 
piece. The size of an individual tile in ENVI is controlled by setting the desired value 
in the ENVI configuration file (see “The ENVI Configuration File” in Appendix A). 
For images stored as BSQ (Band Sequential), each tile is a spatial subset of an 
individual band. For images stored sequentially in BIL (Band Interleaved by Line) 
format, each tile is a single image line of all bands. For BIP (Band Interleaved by 
Pixel) format, each tile is all of the pixels in an image line for all bands. Tiling is 
generally transparent to you as the user and is used by ENVI to insure that hardware 
memory limitations do not impose processing limitations (see “Configuration File 
Details” and “Additional Caching Information” in Appendix A).

File vs. Memory

For systems with large amounts of random access memory (RAM), efficient image 
processing without repeated storage of intermediate processing results in disk files is 
possible. For most functions, ENVI offers the option of either writing image 
processing results to a disk file or of keeping the results in system memory. 

Note
If you elect to use the memory option, save your results to disk files periodically.
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ENVI Basics

This section describes standard ENVI file opening procedures and options and other 
standard ENVI functions that are common in many ENVI windows and dialogs.

Selecting Files in ENVI

Before you apply any of ENVI’s functions to a specific data set, you must first select 
the file containing the data. To ensure consistency, nearly every ENVI image 
processing function uses a standard input file selection dialog. In the input selection 
dialog you can select an input file or a single band, perform a spatial or spectral 
subset, and in some cases, mask the input data.

The title bar of the input file selection dialog changes to reflect the current function 
and/or input file type. For example, the title bars in the following two figures specify 
whether the input selection is by band or by file (respectively). (This was 
accomplished using the ENVI_SELECT procedure with the TITLE keyword.) 

Figure 1-5: Input Selection by Band
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Selecting Bands or Files for Processing

1. Use the Select By arrow-toggle button to select File or Band input.

2. Click on the desired file or band name in the column labeled Select Input File 
or Select Input Band. When you are selecting by Band, data sets appear in an 
unfolded state by default. The names of unfolded data sets appear in this 
format: 

– filename.ext
Band
Band

3. To fold a data set, single-click on the minus symbol (–) next to the filename, or 
double-click on the filename of the data set. All of the bands of the data set are 
compressed and the data set appears in the list in this format:

+ filename.ext

4. To unfold a data set and make it available for processing, single-click on the 
plus symbol (+) next to the filename, or simply double-click on the filename.

Figure 1-6: Input Selection by File
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5. Select the input band or file by clicking on the name.

Note
If the Select By toggle in the dialog is set to File, you can select a subset by 
clicking the Spatial Subset or Spectral Subset buttons and then use the 
standard subsetting procedures (see “Selecting a Spatial Subset” on page 35 
or “Selecting a Spectral Subset” on page 40).

Note
To automatically start the selected function without selecting any subsetting, 
double-click on the file or band name.

6. Click OK.

Opening Files for Processing

The Open drop-down menu contains selections enabling you to open a new image 
file, a previously opened file, a spectral library, an ROI file, or an EVF file. 

Opening New Files

Follow these steps to open a new file for processing.

1. In the Input Selection dialog, click the Open drop-down button, and select 
New File… from the drop-down menu. A file selection dialog opens.

2. When the file selection dialog appears, select the desired file name.

3. Click Open.

Previously Opened Files

To open a previously opened file, click the Open drop-down button, and select 
Previous File from the drop-down menu to reveal the last 20 files and subsets used in 
previous ENVI sessions. Selecting a file from the list opens the file.

Opening a Spectral Library

Follow these steps to open a spectral library for processing.

1. In the Input Selection dialog, click the Open drop-down button, and select 
Spectral Library… from the drop-down menu. A file selection dialog opens.

2. When the file selection dialog appears, select the desired spectral library.

3. Click Open.
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Opening a Region of Interest

Follow these steps to open an ROI file to use when subsetting the selected image.

1. In the Input Selection dialog, click the Open drop-down button, and select 
ROI File… from the drop-down menu. An ROI file selection dialog opens.

2. When the file selection dialog appears, navigate to the desired ROI file.

3. Click Open.

Opening an EVF File

Follow these steps to open an EVF file to use when subsetting the selected image.

1. In the Input Selection dialog, click the Open drop-down button, and select 
EVF File… from the drop-down menu. A vector filename selection dialog 
opens.

2. When the file selection dialog appears, select the desired ENVI vector file.

3. Click Open.

To exit the Input Selection dialog without loading any files, click Cancel.

For detailed information about how to apply the selected function to only a portion of 
the entire file or band, see “Selecting a Spatial Subset” or “Selecting a Spectral 
Subset” on page 40.

Selecting a Spatial Subset

Use spatial subsetting to limit application of a function to a spatial subset of the 
image. Spatial subsets can be selected using the following methods: entering samples 
and line values, selecting interactively from the image, entering map coordinates, 
using the same spatial subset that was previously used on another file, using the 
image shown in the meta scroll window (see “Scroll Window Meta Zoom” on 
page 209), or by using the bounding box around a region of interest. 

For subsetting by spectral bands instead of by spatial regions, see “Selecting a 
Spectral Subset” on page 40.

1. In the file selection dialog, click the Spatial Subset button.

The Spatial Subset dialog appears. Its appearance varies depending on whether 
the current data is sample-line-based or georeferenced.

2. Select a subset using one of the methods described in the following sections.

3. Click OK to enter the selected subset into the Spatial Subset dialog.
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4. Click OK to return to the file selection dialog.

Subsetting by Samples/Lines

To select by starting and ending values of the subset, enter the starting and ending 
values of the samples and/or lines into the appropriate text boxes, or enter the desired 
number of lines or pixels in the boxes labeled NS or NL respectively.

The size of the original data set and the size of the currently-selected subset appear 
below the text boxes.

Subsetting by Images

To select the spatial subset interactively from the image: 

1. In the Select Spatial Subset dialog, click on the Image button.

Figure 1-7: Spatial Subset Dialog for a Georeferenced Image
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The Subset Function dialog appears. A subsampled version of the selected 
image band is displayed. A box on the image outlines the currently selected 
subset.

2. To change the subset size or location, select from the following options:

• In the Subset Function Dialog, click and grab on one of the corners of the 
box and drag to the desired location.

• To move the box around the image, click on the box and drag it to the 
desired location.

• Change the values in the Samples or Lines text boxes.

3. Click OK.

The starting and ending sample and line coordinates appear in the text boxes labeled 
Samples and Lines.

Subsetting by Map Coordinates

For georeferenced images, you may select the subset by map coordinates or 
latitude/longitude coordinates: 

1. In the Select Spatial Subset dialog, click on the Map button. The Spatial 
Subset By Map Coordinates dialog appears. It is divided into two sections: one 
for the upper left map coordinate and the other for the lower right coordinate.

2. Enter the upper left coordinate and lower right coordinate (the corners) of the 
subset into the corresponding text boxes.

Figure 1-8: Subset Function Window
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Note
The default values displayed are the upper left and lower right coordinates of 
the full image.

3. Use the arrow toggle buttons to select the subset by latitude and longitude 
values for each coordinate.

Note
To change the map projection of the coordinates, click on the corresponding 
Change Proj button and follow the instructions in “Selecting Map Projection 
Types” in Chapter 10.

4. Click OK.

Subsetting Using Another File’s Subset

There are two options for subsetting a file based on the subset area of a previously 
subset image: use the first option to subset your image based on a subset of an image 
that was originally the same size as the one you are subsetting; use the second to 
subset your image based on an image of the same or smaller size that was previously 
subset by map or pixel values.

Figure 1-9: Spatial Subset by Map Coordinates Dialog
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Using the Subset of an Image of the Same Size 

To use the same spatial subset previously entered for a file with the same spatial size, 
click the Previous button in the File Selection dialog or the Select Spatial Subset 
dialog. 

Using the Subset of an Image of the Same or Smaller Size 

1. In the Select Spatial Subset dialog, click the File button. 

2. In the file selection dialog, select the previously subsetted file (which must 
have originally been the same size as or smaller than the file you are currently 
subsetting).

The input file will be subset based on the subset parameters of the file you select.

Subsetting Using ROIs

To subset a file using the bounding box (i.e., the area encompassing) an ROI or group 
of ROIs, follow these steps:

1. In the Select Spatial Subset dialog, click the ROI button.

Note
To make previously saved ROIs available for selection in the Subset Image 
by ROI Extent dialog, click the Restore ROIs button in the Select Spatial 
Subset dialog and select the ROI file in the subsequent file selection dialog.

2. In the Subset Image by ROI Extent dialog, select the ROI(s) and click OK. The 
file will be subset to the area encompassing the selected ROI(s).

Figure 1-10: Subset Image by ROI Extent Dialog
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Subsetting by Scroll Window

To subset a file based on the image currently shown in the meta zoomed scroll 
window for the selected file, click the Scroll button in the Select Spatial Subset 
dialog. The starting and ending values will be set to include only the scroll window 
subset.

Note
This option is only available if the scroll window displaying the selected file has 
been meta zoomed (for further information, see “Scroll Window Meta Zoom” on 
page 209). If the file is displayed in multiple meta zoomed Scroll windows, the 
subset of the first window is used.

Selecting a Spectral Subset

Use spectral subsetting to limit application of a function to selected bands of an 
image. For subsetting by spatial regions instead of spectral bands, see “Selecting a 
Spatial Subset” on page 35.

1. From within the file selection dialog, click the Spectral Subset button. The 
File Spectral Subset dialog appears. The appearance of this dialog varies 
depending on whether the image has a bad bands list. A bad band will not be 
included in the processing. A list of bands available for selection appear in the 
center of the dialog.

Figure 1-11: Spectral Subset Dialog with Three Selected Bands
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2. Select a spectral subset using one of the following methods:

• Use the mouse to select a series of bands by left-clicking and dragging 
across the desired bands. Select multiple, non-adjacent bands by left-
clicking on individual bands while depressing the Ctrl key.

• Enter the min and max band numbers in the text fields to the left of the 
Add Range button to select a series of bands. The series will be selected 
when you click the Add Range button.

Note
For images with a Bad Bands list, click on the Apply BBL button to apply 
the Bad Bands List (see “Editing Ancillary Header Information” on 
page 107). ENVI automatically deselects individual bands that are marked 
Bad. Bad bands do not appear in the output image.

3. Click OK to return to the file selection dialog.

Using Previous Subsets

To select the same spectral subset previously used for a file with the same number of 
spectral bands, click the Open drop-down button. Select Previous File from the 
drop-down menu to reveal the last 20 files and subsets used in previous ENVI 
sessions. Selecting a file from the list opens the file.

Subsetting by Ranges

When selecting a range of bands to subset, the dialog default initially shows all bands 
selected. To select a specific range of bands instead of the default:

1. In the File Spectral Subset dialog, select Clear to reset the default setting.

2. Enter the starting and ending band numbers into the two text boxes next to the 
Add Range button.

3. Click Add Range. 

Subsetting from ASCII

Spectral subsetting from an ASCII file is useful if you have defined several special-
use spectral subsets for a file with a large number of bands. To spectrally subset your 
data using an ASCII file: 

1. In the File Spectral Subset dialog, click Import ASCII.

2. When the Enter ASCII Filename dialog appears, select the ASCII file.
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Note
The format of the ASCII file must have the same number of lines in the file as 
the number of bands in the image. 

3. Columns in the ASCII file define possible spectral subsets. Multiple columns 
can be entered to allow different band selections to be specified. For each 
column in the ASCII file a 0 indicates the band is not selected and a 1 indicates 
the band is selected. 

For instance, a 5-band AVHRR file could use an ASCII file with the following 
data:

0 1 1
0 0 1
0 1 1
1 0 0
1 1 0

Selecting column 1 deselects bands 1, 2 and 3, and selects bands 4 and 5.

Selecting column 2 selects bands 1, 3 and 5, and deselects bands 2 and 4.

Selecting column 3 selects bands 1, 2 and 3, and deselects bands 4 and 5.

Regardless of the number of rows in the ASCII file, only the top 5 bands are 
shown in the Input ASCII File dialog box.

Selecting a Mask

When you select a file to be processed you can apply a spatial mask. When a mask is 
used, ENVI does not apply the selected function to the masked portion of the image. 
A mask must be previously defined using Basic Tools → Masking → Build Mask. 
You can build a spatial mask from data ranges, Regions of Interest, and other types of 
input. See “Masking” in Chapter 5 for more details about building masks.

Note
Only certain ENVI functions allow spatial masking before processing. These 
functions include statistics, classification, un-mixing, matched filtering, continuum 
removal, and spectral feature fitting.

To apply a previously built spatial mask to your image:

1. In the file selection dialog, click Select Mask Band. The Select Mask Input 
Band dialog appears with a list of all bands that are the same spatial size as the 
input image.
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2. Select the band containing the mask.

Note
To remove the mask, click Clear Mask Band. 

Selecting Multiple Items in Lists

When using ENVI, you often have to select from a list of items. Some lists in ENVI 
allow you to select more than one item. The following describes the different ways to 
select multiple items in a list.

Selecting Items

• To select a group of files that are listed consecutively, click on the first file in 
the group, press and hold the Shift key, and click the last file in the group. Or, 
click and drag the cursor over the group of items with the left mouse button. 
The items are selected when they are highlighted.

• To select multiple files that are not listed consecutively, press and hold the Ctrl 
key on your keyboard and click on each desired file.

• If the dialog you’re working in displays a Select All Items button, click the 
button to select all of the items in the list.

Figure 1-12: Selecting Individual and Multiple Items in a Dialog
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Note
You cannot select multiple items from the Available Bands List or the Available 
Vectors List.

De-Selecting Items

• To de-select a single item, hold the Ctrl key down and click on the item.

• If the dialog you’re working in displays a Clear All Items or Clear button, 
click it to de-select all of the items in the list.

Selecting File or Memory Output

You are given the option to save your images and data to File or Memory. Saving an 
image to memory saves it in your computer’s system memory and allows the image to 
be displayed from the Available Bands List or the Available Vectors List. When you 
close ENVI, the image is deleted. Saving an image to a file saves the image to your 
hard drive. When you close ENVI, the item is not deleted. For more information, see 
“File vs. Memory” on page 31.

1. In any dialog where you are given the option to select output to File or 
Memory, click the File or Memory toggle button.

2. If you select output to File, enter the desired output filename in the Enter 
Output Filename text box or click the Choose button to select an output 
filename.

Figure 1-13: Output to File or Memory (left) and Output Filename (right) Dialogs
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Placing Un-executed Functions in Queue

Use the Queue button to save the parameters that you’ve set for a particular function 
(without executing the function) so that you can execute the function later. To execute 
the function later, use the ENVI Queue Manager (see “Using the ENVI Queue 
Manager” on page 172).

1. Start an ENVI function (for example, Basic Tools → Stretch Data).

2. In the file selection dialog, select the input file.

3. Enter the parameters for the function (for example, enter the stretch parameters 
in the Data Stretching dialog). 

4. Instead of clicking OK to execute the function, click the Queue button. 

The dialog closes, the parameters are saved, and the function can be executed later 
from the ENVI Queue Manager.

Note
If you exit ENVI without executing the queued functions, a warning will appear.

Compressing Output

Use the Compress check box to compress your output. ENVI applies a lossless GZIP 
format compression to the output file. When a compressed file is opened in ENVI, 
ENVI reads the file and un-compresses it on-the-fly.

Warning
Be aware that ENVI cannot read compressed files that are larger than two gigabytes. 
If you compress a large file and it remains larger than two gigabytes when 
compressed, you will not be able to read it with ENVI.

To output a file in compressed format:

• In any dialog where the Compress check box appears, select the Compress 
check box before clicking OK. 

Note
Compressed files are slower to output and input than un-compressed files; the 
Compress check box is only available in functions that output files sequentially. 
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ENVI File Formats

ENVI supports several image file formats, which are described in this section. Also 
discussed in this section are ENVI header files, file naming conventions, and cross-
platform portability issues.

ENVI Image Files

ENVI uses a generalized raster data format consisting of a simple flat binary file and 
a small associated ASCII (text) header file. This approach permits ENVI’s flexible 
use of nearly any image format, including those with embedded header information. 
All data types are supported in their native formats (byte, signed and unsigned 
integer, long integer, floating point, double precision, 64-bit integer, unsigned 64-bit 
integer, complex, or double complex). The generalized raster data is stored as a 
binary stream of bytes either in BSQ, BIP, or BIL formats (see “ENVI File Formats” 
in Appendix B).

BSQ (Band Sequential Format)

In its simplest form, the data is in BSQ format, with each line of the data followed 
immediately by the next line in the same spectral band. This format is optimal for 
spatial (X, Y) access of any part of a single spectral band.

BIP (Band Interleaved by Pixel Format)

Images stored in BIP format have the first pixel for all bands in sequential order, 
followed by the second pixel for all bands, followed by the third pixel for all bands, 
etc., interleaved up to the number of pixels. This format provides optimum 
performance for spectral (Z) access of the image data.

BIL (Band Interleaved by Line Format)

Images stored in BIL format have the first line of the first band followed by the 
first line of the second band, followed by the first line of the third band, interleaved 
up to the number of bands. Subsequent lines for each band are interleaved in 
similar fashion. This format provides a compromise in performance between spatial 
and spectral processing and is the recommended file format for most ENVI 
processing tasks.
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ENVI Header Files

The ENVI header file contains information used to read an image data file and is 
normally created the first time a data file is accessed by ENVI. The separate ENVI 
text header file provides information to ENVI about the dimensions of the image, the 
imbedded header if present, the data format, and other pertinent information. The 
required information is entered interactively or is automatically created with file 
ingest, and can be edited and changed later. You can generate an ENVI header outside 
ENVI by using a text editor (see “ENVI Header Format” in Appendix B).

ENVI File Naming Conventions

ENVI’s file handling routines were designed to be extremely flexible. ENVI does not 
impose any constraints on the way that files are named with the exception of the use 
of the.hdr extension used for header files. Some ENVI functions do pre-load lists of 
files with specific extensions for ease of use. These are listed in the following table 
and should be used consistently when running ENVI to maximize file handling 
efficiency. This does not preclude you from using different file names if desired.  

File Type Extension

ENVI Bad Lines List .bll

ENVI Band Math or Spectral Math Expression .exp

ENVI Calibration Factors .cff

ENVI Contour Levels File .lev

ENVI Density Slice Range File .dsr

ENVI Display Group .grp

ENVI Filter Kernels .ker

ENVI GCP file .pts

ENVI Grid File .grd

ENVI Header File .hdr

ENVI Image None defined

ENVI Look Up Table .lut

Table 1-1: ENVI File Types
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ENVI Map Key .key

ENVI Mosaic Template File .mos

ENVI n-D Visualizer State .ndv

ENVI PPI Count File .cnt

ENVI Region of Interest .roi

ENVI Spectral Library .sli

ENVI Statistics File .sta

ENVI Statistics Report .txt

ENVI Surface View Path File .pat

ENVI Tape Script .fmt

ENVI Vector File .evf

ENVI Vector Template File .vec

JPL AIRSAR Compressed Stokes Matrix Radar Data .stk

SIR-C Compressed Data Product .cdp

File Type Extension

Table 1-1: ENVI File Types (Continued)
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Cross-Platform File Portability

One additional factor to consider when naming files used with ENVI is cross-
platform portability. The filenames on UNIX systems have a .hdr appended to the 
file name. On Windows systems the .hdr replaces the current extension. This is 
particularly important for preserving the relation between image files and their 
corresponding header (.hdr) files. For example, a UNIX image file with the name 
image_1.img would have image_1.img.hdr. as its corresponding header file. A 
Windows image file named image_1.img would have image_1.hdr. as its 
corresponding header file. In Windows, the two images, image_1.img and 
image_1.dat, would have the same header file name of image_1.hdr and ENVI 
would have problems if the two images were of different sizes and characteristics. 
Under UNIX, the same two files would have the corresponding header file names of 
image_1.img.hdr and image_1.dat.hdr and no confusion would occur. If cross 
platform portability of images is an issue, then the easiest solution is to name image 
files without an extension. Thus the image file image_1 has the same header file 
name (image_1.hdr) under both UNIX and Windows. Alternatively, images and 
header files can be renamed to the Windows convention before moving the images 
from UNIX to Windows systems.
ENVI User’s Guide ENVI File Formats



50 Chapter 1 Getting Started with ENVI
ENVI Supported Input File Formats

The input file formats supported by ENVI are listed below. More information about 
these formats are found in “Opening Image Files”, “Opening External Files”, and 
“Opening Vector Files” in Chapter 2. ENVI supports numerous input file formats:

Flat Binary Files

Landsat Files 

SPOT Files 

IKONOS Files 

QuickBird Files

• BSQ (Band Sequential)

• BIL (Band Interleaved by Line)

• BIP (Band Interleaved by Pixel)

• FAST • MRLC

• GeoTIFF • ACRES CCRS

• HDF • ESA CEOS

• NLAPS

• SPOT • ACRES SPOT

• GEOSPOT • Vegetation

• DIMAP

• GeoTIFF

• NITF

• GeoTIFF

• NITF
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OrbView Files

IRS Files

AVHRR 

SeaWiFS Files 

EOS Files

EROS A Files

ENVISAT Files

• GeoTIFF

• NITF

• Fast

• SuperStructured

• KLM/Level 1b

• SHARP

• HDF

• CEOS

• ASTER 1A/1B

• MODIS 1B

• Level 1A

• Level 1B (GeoTIFF)

• AATSR • ASAR

• MERIS
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Radar Files

Military Files

Thermal Files

USGS and Digital Elevation Files

Miscellaneous Formats

Image Processing Software Formats

• RADARSAT • JERS

• ERS • TOPSAR

• AIRSAR • ASAR

• ADRG • CIB

• CADRG • NITF

• TIMS

• MASTER

• AATSR

• ASTER

• USGS DRG • USGS DEM • DTED

• USGS DOQ • SDTS DEM • SRTM DEM

• ATSR

• DMSP (NOAA)

• ArcView Raster (.bil) • ERDAS 8.x (.img)

• ECW • ER Mapper

• ERDAS 7.5 (.lan) • PCI (.pix)
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Generic Formats

Note
ENVI supports the following input TIFF compression formats: CCITT Group 3 & 4 
algorithms, Macintosh PackBits algorithm, THunderScan 4-bit RLE algorithm, 
NeXT 2-bit RLE algorithm, and LogLuv high dynamic range encoding.

Vector Files

• ASCII • PICT

• BMP • PNG

• HDF • SRF

• JPEG • TIFF/GeoTIFF

• JPEG2000 • TIFF world files (.tfw)

• MrSID • XWD

• PDS

• ARC/INFO Interchange Format • MapInfo Interchange

• ArcView Shape File • Microstation DGN

• DXF • USGS DLG

• ENVI Vector File (.evf) • USGS DLG in SDTS Format
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ENVI Supported Output File Formats

The output file formats supported by ENVI are listed below. More information about 
these formats are found in “Saving Files” in Chapter 2, and “Display Output Options” 
and “Working with Vector Layers” in Chapter 4. 

ENVI Flat Binary Files: 

Generic Image Formats

Image Processing Formats

Vector Formats

• BSQ (Band Sequential)

• BIL (Band Interleaved by Line)

• BIP (Band Interleaved by Pixel)

• ASCII • PICT

• BMP • SRF

• HDF • TIFF (GeoTIFF)

• JPEG • TIFF world files (.tfw)

• JPEG2000 • XWD

• ArcView Raster (.bil) • ER Mapper

• ERDAS 7.5 (.lan) • NITF 02.00/02.10

• PCI (.pix)

• ArcView Shape File • DXF

• ENVI Vector File (.evf)
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Reporting Problems

When you encounter a problem with ENVI, please report them as quickly as possible 
so we can fix it. This section is intended to help you report problems in a way that 
will help us correct the problem rapidly.

Background Information

When a bug is reported and verified, we correct it in a later release. Sometimes, a bug 
only occurs when running on a certain machine, operating system, or graphics device. 
For these reasons, we need to know the following facts when you report a bug:

• Your ENVI installation number.

• The version of ENVI you are running.

• The type of machine it is running on.

• The operating system version it is running under.

• The type and version of your windowing system.

• The graphics device, if the problem involves graphics.

The installation number is assigned by us when you purchase ENVI. The ENVI 
version, site number, and type of machine are printed when ENVI is started. 

Under UNIX, the version of the operating system can usually be found in the file 
/etc/motd. It is also printed when the machine boots. In any event, your system 
administrator should know.

Under Windows 98, Windows 2000, Windows NT version 4, and Windows XP, select 
About from the Help menu in the Windows Explorer. 

On the Macintosh, select About this Macintosh from the apple menu.

Double Check

Before reporting a problem, you should verify that the problem is a bug and not 
simply a matter of misinterpreting the expected outcome of a specific function or 
action. Double check by reviewing the documentation and the online help or by 
checking with a local expert. Make sure your system is properly configured with 
enough virtual memory and sufficient operating system quotas.
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If you cannot find the information you need in the ENVI written guides or online 
help, please let us know so we can improve the clarity and content of the 
documentation.

Describing the Problem

When describing the problem, it is important to use precise language. Vague terms 
like crashes, blows up, and fails are open to many interpretations. Does it really crash 
ENVI and leave you looking at an operating system prompt? This would be our 
interpretation of “crash.” Perhaps, however, it just issues an unexpected error 
message and gives another prompt. What is really meant by a term like “fails?”

Sending Data with Your Bug Report

If the data files are required to reproduce the bug, we will need you to send them to us 
on magnetic media or via e-mail. Call us for details. 

Contact Us

To report a problem, contact us at the following addresses.

Mail

Research Systems, Inc.

4990 Pearl East Circle

Boulder, CO 80301 USA

Telephone

(303) 786-9900 (Voice)

(303) 786-9909 (Fax)

(303) 413-3920 (IDL technical support direct line)

Electronic Mail

rsinc.com
Reporting Problems ENVI User’s Guide
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Can We Be of Service?

Our team of responsive, creative consultants is ready to listen and deliver what you 
want - on time and within budget. They can help you define requirements and lead the 
way throughout the development cycle - from prototyping to final installation - or 
jump in mid-stream and provide expert assistance. 

Each member of the team has many years of experience in areas such as image 
processing; data analysis; visualization; software development; a broad range of 
scientific application areas; and government civilian, defense and intelligence 
community requirements. RSI also has staff with the necessary security clearances to 
support classified projects.

At RSI, we offer a complete suite of project engineering capabilities. RSI’s Global 
Services Group (GSG) builds complete solutions for unique data analysis and 
visualization applications. Do you need shoulder-to-shoulder guidance that gets you 
up to speed? Do you want to outsource all or part of a project? Add Research Systems 
Professional Services Group to your team.

GSG team members know how to exploit and extend ENVI’s robust suite of user 
functions and batch programming capabilities. Because these same people help 
develop IDL and ENVI; they have the most up-to-date knowledge on recent product 
enhancements and future product direction. This knowledge gives them an edge. That 
advantage lets you reap maximum reward from your technology investment.
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File Management
This chapter covers the following topics:
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The File Menu

Use the File menu on the ENVI main menu to read files into ENVI, set preferences, 
and to exit ENVI and other file and program management functions. The individual 
File menu items are described in the following sections.

Figure 2-1: ENVI File Menu
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Opening Image Files

Use Open Image File to open ENVI image files (flat binary files, described in 
“ENVI File Formats” in Appendix B) or other binary image files of known format. 
ENVI automatically identifies and reads files of the following types: TIFF, GeoTIFF, 
JPEG, JPEG200, MrSID, BMP, SRF, HDF, PDS, MAS-50, NLAPS, RADARSAT, 
HDF SeaWiFS, Landsat 7 HDF, Landsat 7 Fast (.fst), MRLC (.dda), ERDAS 7.x 
(.lan), ERDAS 8.x (.img), ER Mapper, PCI (.pix), and AVHRR. The data is left in 
its native format and the necessary information is read from the data header. ENVI 
can also read several other file types (see “Opening External Files” on page 66).

1. Select File → Open Image File.

2. When the Enter Data Filenames dialog appears, select the file to open by 
clicking on its name and clicking OK or Open.

After the file is opened, the bands are listed in the Available Bands List (see “The 
Available Bands List” in Chapter 3). 

Tip
If a Header Info: dialog appears when opening a file that is supported in ENVI, 
select Open External File → your file type instead of using Open Image File (see 
“Opening External Files” on page 66).

Creating Header Files

When ENVI first opens a file, it requires specific information regarding the file 
characteristics. If the file is an ENVI format file, the necessary information is 
contained in a separate text header file. The text header file has the same name as the 
image file, but the file extension is.hdr. 

If ENVI cannot find the header file (.hdr file) or other valid header information upon 
opening a file, the Header Info: dialog box appears. You must enter the required 
information into the dialog (Figure 2-2) before an imported image can be displayed in 
ENVI. The information needs to be entered only once and is automatically stored into 
an ENVI header file in the input directory when the OK button at the bottom of the 
Header Info: window is selected. 

Tip
To change the header information for existing header files, use the Edit Header 
function (see “Editing ENVI Headers” on page 104).
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Use the Header Info: dialog to enter the number of samples or pixels, the number of 
lines, the number of bands, the offset in bytes from the start of the file to where the 
data begins, the storage order of the data, the byte order of the data, the data type and 
the file type. The offset is typically used to define the size of the embedded header, 
which, if present, contains external information about the file and is usually found 
before the actual image data begins; the storage order of the data is the interleave, 
which is in the format BSQ, BIP, or BIL; the byte order of the data is in the format 
Host (Intel) (Host Least Significant First) for DEC machines and PCs or Network 
(IEEE) (Network Most Significant First) for all other platforms); the data type is in 
the format byte, integer, floating point, etc.

All additional information stored in the ENVI Header is optional. To access this 
optional information, click the Edit Attributes button in the Header Info: dialog. 
This optional information includes setting the default Z-Plot range, default stretch for 
display, entering georeferencing information, associated wavelengths and associated 
FWHM (full-width-half-maximum) values, sensor type, band names, and bad bands. 
For more information, see “Editing ENVI Headers” on page 104. 

Note
If you are opening a file directly from a CD-ROM, the created header file will be 
saved to the Alternate Header Directory specified in the envi.cfg file because you 
cannot write to the CD-ROM input directory (see “Installing and Customizing 
ENVI” in Appendix A).

Figure 2-2: Header Information Dialog
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Opening Vector Files

Use Open Vector File from either the ENVI main menu or the Available Vectors 
List, to open the Select Vector Filenames dialog. You can use this dialog to navigate 
to, and open vector files. The Select Vector Filenames dialog enables you to filter for 
any of the following ENVI-supported vector file types or show all file types (*.*) 
using the Files of type: drop-down list.

In addition, you can open one or more files simultaneously from the list in the file 
selection dialog by using the Shift-click and Ctrl-click methods before selecting 
Open.

Note
You may load as many vector layers as desired, but note that each file should 
contain one vector layer only. 

1. To open vector files, select one of the following options:

• From either the ENVI main menu or the Available Bands List, select 
File → Open Vector File, or 

• From the ENVI main menu, select Vector → Open Vector File.

2. When the Select Vector Filenames dialog appears, use the Files of type: drop-
down list to select All Files (*).

3. Select one or more vector filenames and click Open. 

Tip
You can open one or more files simultaneously from the files shown in the 
dialog by using the Shift-click and Ctrl-click methods before selecting 
Open.

• ENVI vector files, *.EVF • MapInfo Interchange format, *.MIF

• ArcView Shapefiles, *.SHP • Microstation DGN, *.DGN

• ARC/INFO Interchange, *.EOO • USGS DLG files, *.DDF, *.DLG

• DXF vector files, *.DXF • USGS SDTS files, *.DLG
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When external vector files are opened, the Import Vector Files Parameter dialog 
appears (see Figure 2-3). 

All of the files opened in the Select Vector Filenames dialog are listed under Selected 
Input Files:. When a file in the list is highlighted, the Layer Name and Native File 
Projection sections of the dialog are updated with the information for that file. Since 
ENVI vector (.evf) files already contain layer name and map projection information, 
these sections are inactive in that dialog (as shown in Figure 2-3 left).

The Import Vector Files Parameters dialog enables you to open multiple vector files 
of different file types simultaneously in the dialog. 

Figure 2-3: Import Vector Files Parameters Dialog For .evf, and .shp File Types
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4. Select from the following options in the Import Vector Files Parameters dialog.

• To select another file to load, click the Input Additional Files… button in 
the Selected Input Files section of the Import Vector Files Parameters 
dialog. When the button is selected, the Select Vector Filenames dialog 
appears, and you can again choose one or more files of any vector type to 
be opened. 

• To send all of the non-EVF vector files to memory, click on the Output to 
Memory for All button in the Layer Name section. All non-EVF vector 
files listed in the dialog are sent to memory. Click OK, and the files are 
listed in the Available Vector List.

Note
EVF files are native to ENVI and do not require conversion to file or 
memory.

• To apply the current map projection parameters to all files in the list with 
unknown projections, click the Apply Projection to Undefined button in 
the Native File Projection section. Unknown projections are listed as 
Arbitrary in the map projections list box of the dialog. 

Note
Files listed with known projections are not converted to the current map 
projection when this button is clicked.

5. Click OK to start the conversions you have specified.
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Opening External Files

While Open Image File can be used to open most file types, it is often more 
convenient to use internal or external header information for specific known file 
types. Use Open External File to read several standard file types including formats 
for selected sensors, military formats, digital elevations model formats, image 
processing software formats, and generic image formats. ENVI reads the necessary 
parameters from internal headers and it is usually not necessary for you to enter any 
information in the Header Information dialog (see “Editing ENVI Headers” on 
page 104).

Note
For a list of ENVI’s supported input files, see “ENVI Supported Input File Formats” 
in Chapter 1.

1. Select File → Open External File → the desired format.

2. When the standard file selection dialog appears (see “Selecting Files in ENVI” 
on page 32), select a filename and click Open.

• To select a group of files that are listed consecutively, click on the first file 
in the group, press and hold the Shift key, and click the last file in the 
group. Or, click and drag with the left mouse button to select the desired 
group.

• To select multiple files that are not listed consecutively, press and hold the 
Ctrl key on your keyboard and click on each desired file.

3. If ENVI prompts you to enter Output Filename, enter a name for each file as 
requested.

See the following sections for detailed descriptions of how to access specific file 
formats.
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Opening Landsat Files

Use these selections to open Landsat data in FAST, GeoTIFF, HDF, NLAPS, MRLC, 
ACRES CCRS, and ESA CEOS formats.

Opening FAST TM Files

To read FAST format Landsat TM data:

1. Select File → Open External File → Landsat → FAST.

2. When the file selection dialog appears, select one of the following files:

• For Fast TM format data, select the header.dat file.

• For Landsat 7 FAST panchromatic data, select the HPN header file.

• For the 6 VNIR/SWIR Landsat 7 FAST data bands, select the HRF header 
file.

• For Landsat 7 FAST thermal bands, select the HTM header file.

The file names follow the naming conventions shown above. ENVI automatically 
extracts the header information, including georeferencing information, and enters the 
image bands into the Available Bands List. For Landsat 7 FAST files, ENVI also 
extracts the data acquisition date, the gains and bias factors, and the sun elevation and 
azimuth. ENVI also creates a meta file—a single file containing all of the bands—and 
lists it in the Available Bands List. ENVI assigns wavelengths to the bands based on 
the sensor type. For information about meta files, see “Saving Files as ENVI Meta 
Files” on page 129.

Opening Landsat GeoTIFF Files

To read GeoTIFF format Landsat files and extract the georeferencing information:

1. Select File → Open External File → Landsat → GeoTIFF. 

2. When the file selection dialog appears, select the desired input file. 

ENVI reads the GeoTIFF image, automatically extracts the necessary header 
information (including the associated georeferencing information) and places the 
image bands in the Available Bands List.
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Opening Landsat HDF Files

To read HDF format Landsat data: 

1. Select File → Open External File → Landsat → HDF.

2. When the file selection dialog appears, select the .hdf file. 

ENVI automatically extracts the header information, including georeferencing 
information, and enters the image bands into the Available Bands List. For Landsat 7 
HDF files, ENVI also extracts the data acquisition date, the gains and bias factors, 
and the sun elevation and azimuth. ENVI also creates a meta file—a single file 
containing all of the bands—and lists it in the Available Bands List. (For information 
about meta files, see “Saving Files as ENVI Meta Files” on page 129.) If the data is 
from Landsat 7, then the panchromatic band will also be opened and placed in its own 
file.

Opening NLAPS Landsat Files 

To read Landsat TM and MSS BSQ (band sequential) and BIL (band interleaved by 
line) NLAPS format data from CD-ROM or from disk: 

1. Select File → Open External File → Landsat → NLAPS. 

2. When the file selection dialog appears with the header files (.hd) listed by 
default, select the .hd file to open.

ENVI automatically extracts the necessary header information (including any UTM 
georeferencing information) and lists all the bands in the Available Bands List. ENVI 
also creates a meta file—a single file containing all of the bands—and lists it in the 
Available Bands List. For information about meta files, see “Saving Files as ENVI 
Meta Files” on page 129.

Opening MRLC Landsat Files

ENVI reads Multi-Resolution Land Characteristics (MRLC) format TM and DEM 
files and extracts the UTM georeferencing information.

To open the Landsat TM data (all bands):

1. Select File → Open External File → Landsat → MRLC. 

2. When the file selection dialog appears, select one of the TM (.dda) image 
files. 
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ENVI automatically extracts the header information (including UTM georeferencing 
information) and places the image bands in the Available Bands List. ENVI also 
creates a meta file—a single file containing all of the bands—and lists it in the 
Available Bands List. For information about meta files, see “Saving Files as ENVI 
Meta Files” on page 129.

Opening ACRES CCRS Files

To read the Australian Centre for Remote Sensing (ACRES) CCRS format Landsat 
files:

Note
For Landsat 7 ACRES files, you need to run re_name.bat (PC) or re_name.s 
(UNIX) from the ACRES CD to rename the files to their proper names before the 
data can be read into ENVI.

1. Select File → Open External File → Landsat → ACRES CCRS.

2. When the file selection dialog appears, select the Imag_xx.dat file. 

ENVI automatically extracts the header information, including UTM georeferencing 
information, and enters the image bands into the Available Bands List.

Opening ESA CEOS Landsat TM Files

To read European Space Agency Landsat TM format data:

1. Select File → Open External File → Landsat → ESA CEOS.

2. When the file selection dialog appears, select the input data file.

The files must follow the naming convention of dat_xx.xxx and lea_xx.xxx.

ENVI automatically extracts the necessary header information, including any UTM 
georeferencing information, and lists all of the bands in the Available Bands List. 
ENVI also creates a meta file—a single file containing all of the bands of a BSQ 
formatted file—and lists it in the Available Bands List. ENVI assigns wavelengths to 
the bands based on the sensor type. For information about meta files, see “Saving 
Files as ENVI Meta Files” on page 129.
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Opening SPOT Files

Use the following procedures to open old Spot files, GeoSPOT files, ACRES SPOT, 
SPOT vegetation files, and SPOT DIMAP files.

Opening SPOT Files

To read 1A, 2A, and 1B SPOT data directly from a CD-ROM or disk:

1. Select File → Open External File → Spot → SPOT. 

2. When the file selection dialog appears, select the image file to be read.

ENVI automatically extracts the header information and enters the image bands into 
the Available Bands List.

Opening GeoSPOT - ArcView Raster (.bil) Files

SPOT provides most of their data in the GeoSPOT format. ArcView raster image files 
have a similar format specification. The GeoSPOT format is described in detail in 
documentation available from SPOT Image. While the GeoSPOT format provides for 
a wide variety of both raster and vector data, ENVI currently supports only GeoSPOT 
raster images. These images have the .bil file extension and an associated header 
file with the extension .hdr.

1. Select File → Open External File → Spot → GeoSPOT.

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the header information, including UTM and State Plane 
projection georeferencing information, and enters the image bands into the Available 
Bands List.

Opening ACRES SPOT Files

To read the Australian Centre for Remote Sensing (ACRES) CCRS and SPIM format 
Spot files: 

1. Select File → Open External File → Spot → ACRES SPOT.

2. When the file selection dialog appears, select the Imag_xx.dat file.

ENVI automatically extracts the header information, including any UTM 
georeferencing information, and enters the image bands into the Available 
Bands List.
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Opening SPOT Vegetation Files

To read SPOT Vegetation files: 

1. Select File → Open External File → Spot → Vegetation.

2. When the file selection dialog appears, select the .hdf file.

ENVI automatically extracts the necessary header information, including 
georeferencing information, and lists all the bands in the Available Bands List. ENVI 
also creates a meta file—a single file containing all of the bands—and lists it in the 
Available Bands List. For information about meta files, see “Saving Files as ENVI 
Meta Files” on page 129.

Opening SPOT DIMAP Files

To read SPOT DIMAP files: 

1. Select File → Open External File → Spot → DIMAP.

2. When the file selection dialog appears, select any .dim file to be read.

ENVI automatically extracts the necessary header information, including 
georeferencing information, band wavelengths, gains, and offsets. Then, all the bands 
are listed in the Available Bands List. If the data is multispectral SPOT, ENVI 
automatically displays a color infrared image.

Note
It may take a long period of time to parse the header information from the 
metadata.dim file. It is quicker to open the TIFF image file using File → Open 
Image File directly if you do not plan to georeference the data. If you plan to 
georeference the SPOT data using ENVI, you must read the data using File → 
Open External File → Spot → DIMAP because the header information is needed. 
For more information, see “Georeferencing SPOT Data” in Chapter 10.
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Opening IKONOS Files

Use the following procedures to open IKONOS files in GeoTIFF or NITF formats.

Opening GeoTIFF IKONOS Files 

To read GeoTIFF format IKONOS files (or those labeled “11-bit TIFF”) and extract 
the georeferencing information:

1. Select File → Open External File → IKONOS → GeoTIFF. 

2. When the file selection dialog appears, select the desired input file. 

ENVI reads the GeoTIFF image, automatically extracts the necessary header 
information (including the associated georeferencing information) and places the 
image in the Available Bands List.

Opening NITF IKONOS Files

To read NITF format IKONOS files:

1. Select File → Open External File → IKONOS → NITF.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including georeferencing 
information, and places the image band in the Available Bands List.

Opening IKONOS Files with RPC Positioning

Use the following procedure to derive RPC-based geolocation information for 
individual pixels in an IKONOS image. A file containing the image RPCs (Rational 
Polynomial Coefficients or Rapid Positioning Coordinates) is required. The 
geolocations are determined from a pseudo projection, which is derived by ENVI 
from the provided RPC model. This method does not change the appearance of the 
image, it simply calculates the correct geolocation for each individual pixel.

Tip
This RPC-based georeferencing method is less computationally and disk space 
intensive than a full orthorectification process performed on the imagery; however, 
the full orthorectification process provides greater accuracy.
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To use an RPC pseudo projection to position (georeference) IKONOS data:

1. Select File → Open External File → IKONOS → Open with RPC 
Positioning.

2. When the file selection dialog appears, select the input file. If an associated 
RPC file cannot be found, you are prompted to select a file containing the RPC 
coefficients.

ENVI automatically extracts the remaining header information and places the image 
band in the Available Bands List. To automatically assign an RPC file to be used as a 
pseudo projection for a specific image, see “Emulating an RPC Projection” on 
page 115.

Opening QuickBird Files

Use the following procedures to open QuickBird 2.0 files in GeoTIFF or NITF 
formats.

Opening GeoTIFF QuickBird Files 

To read GeoTIFF format QuickBird 2.0 files and extract the georeferencing 
information:

1. Select File → Open External File → QuickBird → GeoTIFF. 

2. When the file selection dialog appears, select the desired input file. 

ENVI reads the GeoTIFF image, automatically extracts the necessary header 
information (including the associated georeferencing information) and places the 
image in the Available Bands List.

Opening NITF QuickBird Files

To read NITF format QuickBird 2.0 files:

1. Select File → Open External File → QuickBird → NITF.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including georeferencing 
information, and places the image band in the Available Bands List.
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Opening QuickBird Files with RPC Positioning

Use the following procedure to derive RPC-based geolocation information for 
individual pixels in an QuickBird image. A file containing the image RPCs (Rational 
Polynomial Coefficients or Rapid Positioning Coordinates) is required. The 
geolocations are determined from a pseudo projection, which is derived by ENVI 
from the provided RPC model. This method does not change the appearance of the 
image, it simply calculates the correct geolocation for each individual pixel.

Tip
This RPC-based georeferencing method is less computationally and disk space 
intensive than a full orthorectification process performed on the imagery; however, 
the full orthorectification process provides greater accuracy.

To use an RPC pseudo projection to position (georeference) QuickBird data:

1. Select File → Open External File → QuickBird → Open with RPC 
Positioning.

2. When the file selection dialog appears, select the input file. If an associated 
RPC file cannot be found, you are prompted to select a file containing the RPC 
coefficients.

ENVI automatically extracts the remaining header information and places the image 
band in the Available Bands List. To automatically assign an RPC file to be used as a 
pseudo projection for a specific image, see “Emulating an RPC Projection” on 
page 115.
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Opening OrbView-3 Files

Use the following procedures to open OrbView-3 files in GeoTIFF or NITF formats.

Opening GeoTIFF OrbView-3 Files 

To read GeoTIFF format OrbView-3 files and extract the georeferencing information:

1. Select File → Open External File → OrbView-3 → GeoTIFF.

2. When the file selection dialog appears, select the desired input file.

ENVI reads the GeoTIFF image, automatically extracts the necessary header 
information (including the associated georeferencing information) and places the 
image in the Available Bands List.

Opening NITF OrbView-3 Files

To read NITF format OrbView-3 files:

1. Select File → Open External File → OrbView-3 → NITF.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including georeferencing 
information, and places the image band in the Available Bands List.

Opening OrbView-3 Files with RPC Positioning

Use the following procedure to derive RPC-based geolocation information for 
individual pixels in an OrbView-3 image. A file containing the image RPCs (Rational 
Polynomial Coefficients or Rapid Positioning Coordinates) is required. The 
geolocations are determined from a pseudo projection, which is derived by ENVI 
from the provided RPC model. This method does not change the appearance of the 
image, it simply calculates the correct geolocation for each individual pixel.

Tip
This RPC-based georeferencing method is less computationally and disk space 
intensive than a full orthorectification process performed on the imagery; however, 
the full orthorectification process provides greater accuracy.
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To use an RPC pseudo projection to position (georeference) OrbView-3 data:

1. Select File → Open External File → OrbView-3 → Open with RPC 
Positioning.

2. When the file selection dialog appears, select the input file. If an associated 
RPC file cannot be found, you are prompted to select a file containing the RPC 
coefficients.

ENVI automatically extracts the remaining header information and places the image 
band in the Available Bands List. To automatically assign an RPC file to be used as a 
pseudo projection for a specific image, see “Emulating an RPC Projection” on 
page 115.

Opening IRS Files

Opening IRS-1 Data in FAST Format Files

To read IRS-1 data in FAST format:

1. Select File → Open External File → IRS → FAST.

2. When the file selection dialog appears, select the header.dat file to be read. 

The file names must follow the naming convention header.dat and bandx.dat, 
where x = band number or x = p for panchromatic. ENVI automatically extracts the 
header information (including UTM georeferencing information) and enters the 
image bands into the Available Bands List. ENVI also creates a meta file—a single 
file containing all of the bands—and lists it in the Available Bands List. ENVI assigns 
wavelengths to the bands based on the sensor type. For information about meta files, 
see “Saving Files as ENVI Meta Files” on page 129.

Opening IRS Super Structured Files

To read IRS Super Structured format:

1. Select File → Open External File → IRS → Super Structured. 

2. When the file selection dialog appears, select the leader file (LEADER* or 
b00.led). 

ENVI automatically extracts the header information (including wavelength 
information) and enters the image bands into the Available Bands List. For multiple 
band images where each band is stored in a separate file, ENVI will create a meta 
file—a single file containing all of the bands. For information about meta files, see 
“Saving Files as ENVI Meta Files” on page 129.
Opening External Files ENVI User’s Guide



Chapter 2: File Management 77
Note
Georeferencing information is not provided in IRS Super Structured format.

Opening AVHRR Files

Use the following procedures to read KLM/Level 1b and SHARP format AVHRR 
data. 

Note
ENVI only supports AVHRR Level 1b KLM formatted files that have been 
produced and are distributed by NOAA.

Opening KLM/Level 1b AVHRR Files

To read KLM/Level 1b AVHRR data:

1. Select File → Open External File → AVHRR → KLM/Level 1b.

2. When the file selection dialog appears (see “Selecting Files in ENVI” on 
page 32), select the input file.

ENVI reads 10-bit packed format as integer data, uncompressed formats as integer 
data, and 8-bit format as byte data. The necessary header information is automatically 
extracted and the bands are placed in the Available Bands List. 

Tip
To use the embedded information to georeference the data see “Georeference 
AVHRR Data” in Chapter 10.

Opening ESA SHARP Files

European Space Agency SHARP data contains 5 AVHRR bands plus supplementary 
information. ENVI reads the five AVHRR data bands and the supplementary 
information is read as three additional bands. The additional bands are 0-1 raster 
(mask) images of the latitude/longitude grid, coastlines, and state boundaries.
ENVI User’s Guide Opening External Files



78 Chapter 2: File Management
To read European Space Agency format AVHRR data:

1. Select File → Open External File → AVHRR → SHARP.

2. When the file selection dialog appears, select the input data file.

The input file must follow the naming convention of dat_xx.xxx and 
lea_xx.xxx.

The AVHRR bands and three supplementary bands appear in the Available Bands 
List.

Opening SeaWiFS Files

ENVI reads the following types of SeaWiFS data from CD-ROM or disk: OrbImage-
distributed CEOS LAC 1B, LAC 2A, LAC 2B, and SeaWiFS HDF Level 1A and 1B, 
and NASA/Goddard-distributed SeaWiFS HDF format data.

1. Select File → Open External File → SeaWiFS → HDF or CEOS.

2. When the file selection dialog appears, select the image file to be read.

ENVI automatically extracts the header information and enters the image bands into 
the Available Bands List. To use the imbedded information to georeference the data 
or to create geometry information, see “Georeferencing SeaWiFS Data” in Chapter 
10.

Opening EOS Files

Use the following procedures to open EOS ASTER or MODIS 1B files.

Opening EOS ASTER Files

ENVI reads the following EOS ASTER files:

• Level 1A

• Level 1B

• The following Level 2 products: 05, 07, 08, and 14 (DEM data).

To read EOS ASTER files:

1. Select File → Open External File → EOS → ASTER.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including any georeferencing 
information, and enters the image bands into the Available Bands List.
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Opening EOS MODIS 1B Files

To read EOS MODIS 1B files:

1. Select File → Open External File → EOS → MODIS 1B.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including any georeferencing 
information, and enters the image bands into the Available Bands List.

The gains and offsets are also extracted from the HDF metadata. These values are 
automatically applied when ENVI converts the 16-bit data in the input file to 
calibrated floating-point data. The resulting emissive and reflectance data are 
unitless. The units of the radiance data are Watts/meter2/micrometer/steradian.

Note
For EOS MODIS 1B files, values greater than 32767 (which indicate invalid data) 
are replaced by -999 when applying the gains and offsets. The data ignore value in 
the ENVI header is also set to -999.

Opening EROS A Files

Use the following procedures to open ImageSat International EROS A level 1A and 
1B files.

Opening EROS A level 1A Files

1. Select File → Open External File → EROS → Level 1A. 

2. When the file selection dialog appears, select the .1A file. ENVI automatically 
extracts the header information and lists the band in the Available Bands list.

Opening EROS A level 1B Files

1. Select File → Open External File → EROS → Level 1B (GeoTIFF). 

2. When the file selection dialog appears, select the .1B file. ENVI automatically 
extracts the header information, including any georeferencing information, and 
lists the band in the Available Bands list.
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Opening ENVISAT Files

Use the following procedures to open ENVISAT AATSR, ASAR, or MERIS files.

Opening ENVISAT AATSR Files

To read ENVISAT AATSR level 1B and level 2 files:

1. Select File → Open External File → ENVISAT → AATSR. 

2. When the file selection dialog appears, select the image file. ENVI 
automatically extracts the header information, including any georeferencing 
information, and places the image data and any ancillary image bands in the 
Available Bands list and groups them into appropriate meta files.

Opening ENVISAT ASAR Files

To read ENVISAT ASAR level 1B files:

1. Select File → Open External File → ENVISAT → ASAR. 

2. When the file selection dialog appears, select the image file. ENVI 
automatically extracts the header information, including any georeferencing 
information, and places the image bands in the Available Bands list.

Opening ENVISAT MERIS Files

To read ENVISAT MERIS level 1B and level 2 files:

1. Select File → Open External File → ENVISAT → MERIS. 

2. When the file selection dialog appears, select the image file. ENVI 
automatically extracts the header information, including any georeferencing 
information, and places the image data and any ancillary image bands in the 
Available Bands list and groups them into appropriate meta files.
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Opening ATSR Files

From the Rutherford Appleton Laboratory (RAL) SADIST-2 processing software for 
the ATSR-1 and ATSR-2 instruments, ENVI reads the gridded brightness 
temperature/reflectance (GBT), the gridded browse (GBROWSE), and the gridded 
sea surface temperature (GSST) data. ENVI automatically opens all the image 
product contents within the file.

To open ATSR-1 and ATSR-2 files: 

1. Select File → Open External File → ATSR.

2. When the file selection dialog appears, select the input file.

All the image products within the selected file are opened and appear in the Available 
Bands List. For forward view and nadir view images, the band names contain FV or 
NV respectively. The band names also supply the image units.

Opening DMSP (NOAA) Files

To read NOAA DMSP (OLS format only) data directly into ENVI: 

1. Select File → Open External File → DMSP (NOAA).

2. When the file selection dialog appears, select a file to be read. 

ENVI automatically extracts the header information and enters the image bands into 
the Available Bands List. 

Opening Thermal Files

Use the following procedures to open TIMS, AATSR, ASTER and MASTER data.

Opening TIMS Files

To read data from the NASA Thermal Infrared Multispectral Scanner (TIMS) from 
CD-ROM or disk:

1. Select File → Open External File → Thermal → TIMS.

2. Select the TIMS filename and click OK.

The bands appear in the Available Bands List. ENVI assumes the data has 6 bands, 
638 pixels, plus a 60 byte offset at the beginning of each line, and is in BIL storage 
order. Default wavelengths are entered into the header and can be edited if needed.
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Opening ASTER Files

To read ASTER 1A/1B files:

1. Select File → Open External File → Thermal → ASTER 1A/1B or File → 
Open External File → EOS → ASTER 1A/1B.

2. When the file selection dialog appears, select the input file.

ENVI automatically extracts the header information, including any georeferencing 
information, and enters the image bands into the Available Bands List.

Opening ENVISAT AATSR Files

To read ENVISAT AATSR level 1B files:

1. Select File → Open External File → Thermal → ENVISAT-AATSR

2. When the file selection dialog appears, select the image file. ENVI 
automatically extracts the header information, including any georeferencing 
information, and places the image data and any ancillary image bands in the 
Available Bands list and groups them into appropriate meta files.

Opening MASTER Files

To read MODIS/ASTER airborne simulator (MASTER) files:

1. Select File → Open External File → Thermal → MASTER. 

2. When the file selection dialog appears, select the input file. 

ENVI automatically extracts the necessary header information (including 
wavelengths) and places the bands in the Available Bands List. ENVI automatically 
applies the scale factor values to scale the data to radiance units.

Note
To access other HDF files, select File → Open External File → Remote Sensing 
Formats → HDF (see “Opening HDF Files” on page 101).
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Opening Radar Files

Use the following procedures to open radar files, including RADARSAT, ERS, JERS, 
and TOPSAR files, from CD or disk. 

Note
To open SIR-C or AIRSAR files, see “Using Polarimetric Tools” in Chapter 13.

Opening RADARSAT Files

To read RADARSAT data files into ENVI: 

1. Select File → Open External File → Radar → RADARSAT or 
Radar → Open/Prepare Radar File → RADARSAT. 

2. When the file selection dialog appears, select the input data file. 

3. Click OK to start the data reading.

ENVI automatically extracts the needed header information (including UTM 
georeferencing information) from the data file, leader file, and/or trailer file. 
The image band is entered into the Available Bands List. 

The image band is entered into the Available Bands List. 

Opening Integer Format RADARSAT Data

When the RADARSAT File Import dialog appears, select Import Data Type → 
Unsigned Integer.

The image band is entered into the Available Bands List. 

For Byte Scaling

1. When the RADARSAT File Import dialog appears, select Import Data 
Type → Scale to Byte.

2. Enter the scaling minimum and maximum data values or keep the default 
values. The Min and Max values are automatically entered as the 2% points 
from the histogram in the CEOS header if it is found. If the CEOS header is 
not available you must enter these values. 

3. Click OK to start the data reading.

The image band is entered into the Available Bands List. 
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Note
Complex RADARSAT data are read into ENVI as follows: Raw data product - two 
bands of byte data, one each for the Z and I Stokes parameters; SLC data product -
two bands of signed integer, one each for the Q and I Stokes parameters.

Opening ERS Files

To read ERS-1 and ERS-2 format data:

1. Select File → Open External File → Radar → ERS or Radar → 
Open/Prepare Radar File → ERS.

2. When the file selection dialog appears, select the image file to be read. 

ENVI automatically extracts the header information and places the image band in the 
Available Bands List. 

Opening JERS Files

To read JERS format data:

1. Select File → Open External File → Radar → JERS or Radar → 
Open/Prepare Radar File → JERS. 

2. When the file selection dialog appears, select the image file to be read. 

ENVI automatically extracts the header information and places the image band in the 
Available Bands List. 

Opening TOPSAR Files

To read the raw TOPSAR (AIRSAR Integrated Processor Data) format data files 
(Cvv, Incidence Angle, Correlation Image, or the DEM):

1. Select File → Open External File → Radar → TOPSAR or Radar → 
Open/Prepare Radar File → TOPSAR.

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the needed header information and places the image 
band into the Available Bands List. 

Note
To read all of the TOPSAR files and automatically convert them to physical units, 
see “Converting TOPSAR Data” in Chapter 13. To synthesize AIRSAR images, see 
“Synthesizing JPL AIRSAR Data” in Chapter 13.
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Opening ENVISAT ASAR Files

To read ENVISAT ASAR level 1B files:

1. Select File → Open External File → Radar → ENVISAT-ASAR.

2. When the file selection dialog appears, select the image file. ENVI 
automatically extracts the header information, including any georeferencing 
information, and places the image bands in the Available Bands list.

Opening Military Files

Use Military selections to open common military format files, including ADRG, 
CADRG, CIB and NITF.

Opening ADRG Files

To open files in the ARC Digitized Raster Graphics format from the Defense 
Mapping Agency:

1. Select File → Open External File → Military → ADRG.

2. When the file selection dialog appears, select the .img file.

The header information is read from the .gen file, including any georeferencing 
information, and the image bands are entered into the Available Bands List. 
Currently, ENVI does not read the associated legend images and does not support the 
georeferencing. Also, the scroll window is generated from the ADRG overview 
image for speed considerations.

Opening CADRG and CIB Files

To open Defense Mapping Agency Compressed ARC Digitized Raster Graphics or 
Controlled Image Base (CIB) files:

1. Select File → Open External File → Military → CADRG or CIB.

2. When the file selection dialog appears, select the A.toc file. A list of the 
frame files is displayed.

3. To open individual frame files, select File → Open External File → 
Military → NITF → NITF. The Enter NITF Filenames dialog appears.

4. Select the frame file.
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5. Select whether or not to mosaic all the files into a virtual mosaic by selecting 
Yes or No next to Mosaic Files. 

6. Click OK.

All the files within the selected frame and the virtual mosaic, if selected, appear in the 
Available Bands List.

Note
Each frame file may be made up of hundreds of individual files that appear in the 
Available Bands List.

Opening NITF Files

ENVI reads uncompressed and vector quantization (VQ) compressed NITF 2.0 and 
2.1 image data and automatically creates a virtual mosaic of the base image and the 
image inserts. NITF symbols and labels, except for CGM symbols, are read into 
separate ENVI annotation files (see “Annotating Images” in Chapter 4). NITF text 
data is displayed in an ENVI report dialog without any additional formatting.

To read National Imagery Transmission Format data:

1. Select File → Open External File → Military → NITF. 

2. When the file selection dialog appears, select the input file. If symbols or 
labels are present, an NITF File Parameters dialog appears.

3. Enter symbol and/or label output annotation filenames and click OK.

ENVI automatically extracts the header information and creates a virtual mosaic of 
all uncompressed and VQ compressed images in the file (see “Image Mosaicking” in 
Chapter 10). The virtual mosaic bands are entered into the Available Bands List. The 
symbol and/or label annotation files can be overlaid on the virtual mosaic image (see 
“Creating Virtual Mosaics” in Chapter 10). Any symbol bitmaps are shown as 
annotation RGB Image inserts. 

Note
The NITF support distributed with ENVI is non-compliant with JITC standards and 
provides limited functionality. For example, it does not read georeferencing 
information encoded in the MGRS (military grid reference system) format. 
However, the ENVI NITF/NSIF Module (which is a plug-in) provides full JITC-
compliant support and is available for purchase. See the ENVI NITF/NSIF Module 
Guide, and contact your sales representative or RSI ((303) 786-9900, 
info@rsinc.com) for more information.
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Opening Digital Elevation Files

United States Geological Survey Digital Elevation Model (USGS DEM) data, Digital 
Terrain Elevation Data (DTED), Spatial Data Transfer Standard (SDTS DEM), and 
Shuttle Radar Topography Mission (SRTM DEM) formats can be read directly in 
ENVI. Elevations are retained at full precision in the converted files. To georeference 
DEMs, use ENVI’s registration function to warp the DEM to a specified projection 
using the corner coordinates and given pixel size (see “Image-to-Map Ground 
Control Points” in Chapter 10).

Note
You can also use the Open Topographic File menu to read USGS DEM, DTED, 
and SDTS DEM data into ENVI (see “Opening Topographic Files” in Chapter 12).

Opening DTED Files

To convert DTED files from CD ROM or disk to mosaicked ENVI image files:

1. Select File → Open External File → Digital Elevation → DTED.

2. When the file section dialog appears, select the desired input filename.

The DTED Reader Input Parameters dialog appears. This dialog has the same 
parameters as the USGS DEM dialog (see the following section).

Opening USGS DEM Files

To convert USGS DEM files from disk to mosaicked ENVI image files (DEMs can 
also be read directly from tape, see “Reading Known Tape Formats” on page 142): 

1. Select File → Open External File → Digital Elevation → USGS DEM or 
File → Open External File → USGS → DEM.

2. When the file selection dialog appears, select an input file.

3. Click OK.

• To convert more than one DEM file, click Input Additional File and 
select the new file in the file selection dialog.

• To automatically mosaic the DEM files into one image based on their 
geographic coordinates, click Yes next to Mosaic Files? label.

4. Select output to File or Memory. A new file and standard ENVI header file are 
created from the information in the embedded header.
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Tip
If mosaicking is not selected and output is to a file, each DEM is converted to 
its own image. In this case, enter a filename without an extension. The output 
file for each separate image is automatically assigned a numerical extension 
(e.g., _1 for the first file, _2 for the second file, etc.).

5. Click OK to start the conversion. 

A status window appears indicating the processing status. When completed, the 
band(s) from the converted file appear in the Available Bands List (see “The 
Available Bands List” in Chapter 3), where they are available for standard display and 
analysis using ENVI functions.

Opening USGS SDTS DEM Files

ENVI reads USGS Digital Elevation Models (DEMs) in Spatial Data Transfer 
Standard (SDTS) format. The projection information is read automatically.

1. Select File → Open External File → Digital Elevation → USGS SDTS 
DEM or File → Open External File → USGS → SDTS DEM.

2. When the file selection dialog appears, select the catalog directory (typically 
the xxxxCATD.DDF file).

3. When the USGS SDTS DEM Input Parameters dialog appears, select from the 
options below:

• To convert more than one DEM file, click Input Additional File and 
select the new file using the file selection dialog.

• To automatically mosaic the DEM files into one image based on their 
geographic coordinates, click Yes next to Mosaic Files? label.

4. Select output to File or Memory.

• If you select output to File, a new file and standard ENVI header file is 
created from the information in the embedded header.

Tip
If mosaicking is not selected and output is to a file, each DEM is converted to 
its own image. In this case, you should enter a filename without an extension. 
The output file for each separate image is automatically assigned a numerical 
extension (e.g., _1 for the first file, _2 for the second file, etc.).

5. Click OK to start the conversion. 
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A status window appears, indicating the processing status. When completed, the 
band(s) from the converted file appear in the Available Bands List.

Opening SRTM DEM Files

To convert SRTM DEM (.hgt) files from CD ROM or disk to mosaicked ENVI 
image files:

1. Select File → Open External File → Digital Elevation → SRTM DEM.

2. When the file section dialog appears, select the desired input filename. If the 
file contains missing data points, you will be prompted to correct the missing 
values. If you click Yes, the -32768 values (which indicate missing data) are 
replaced by values interpolated from valid neighboring pixels.

ENVI then extracts the information and lists it in the Available Bands List.

Opening USGS Files

Use the USGS selections to read DRG, DOQ, DEM, and SDTS DEM format files.

Opening DRG (USGS) Files

To open USGS Digital Raster Graphic files: 

1. Select File → Open External File → USGS DRG.

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the header information (including UTM georeferencing 
information) and enters the image bands into the Available Bands List.

Opening DOQ (USGS) Files

To read USGS Digital Orthophoto Quadrangle data:

1. Select File → Open External File → USGS → DOQ.

2. When the file selection dialog appears, select a file to be read. 

ENVI automatically extracts the header information (including UTM georeferencing 
information) and enters the image bands (grayscale or RGB) into the Available Bands 
List. 

Opening DEM or SDTS DEM

For detailed instructions, see “Opening Digital Elevation Files” on page 87.
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Opening LAS Format LIDAR Files

ENVI allows you to read and convert LAS format LIDAR data with the .las 
extension into ENVI raster or ENVI vector (.evf) files.

Viewing the LAS LIDAR File Header

The header associated with the LAS LIDAR file is accessible as a viewable text file. 

• Select File → Open External File → LAS LIDAR → View LAS Header. 

The header file dialog is non-editable, but can be saved as a text file which can be 
printed if desired. If the LAS LIDAR file has geospatial data associated with the file, 
the information appears below the Projection Information heading in the LAS header. 

Converting LAS LIDAR Data

LAS LIDAR files are converted to ENVI compatible files as follows.

1. Select File → Open External File → LAS LIDAR → Convert LAS Data. 

An Enter LAS Filenames dialog opens. 

2. Navigate to the file with the .las extension, highlight it, and click Open.

The Output LAS Point Data dialog opens.

The Output LAS Point Data dialog has the following elements to be set for the data 
conversion.

• Output Format — Choose either ENVI Raster File to convert the .las data 
to raster format; or ENVI Vector File to convert to a point vector format 
(.evf).

• ENVI Raster File (default) — Selecting this model rasterizes the LAS 
data, creating output in a standard ENVI image file where the pixel values 
correspond to surface height or intensity. The converted data format results 
in an ENVI format file.

• ENVI Vector File — Selecting this model for the output creates an ENVI 
vector file (.evf) in which each vector point record corresponds to an 
(X, Y) pair of the LIDAR data with the elevation, intensity, and return 
number stored as corresponding attributes.
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Note
If you select the ENVI Vector File format for your output, each point will be 
converted to a vector item and the options for model type, output images, 
interpolation, pixel size, and output data type are desensitized.

• Model Type — This setting is required if the ENVI Raster File has been 
selected for the output format. There are three model types: Last Return, Full 
Feature, and First Return.

• Last Return (default) — Also known as the bare Earth model, the last 
return corresponds to a pulse return from the last (lowest) surface to return 
a pulse. This can include solid materials, such as bare Earth, that are under 
semi-transparent vegetation. 

Note
In the Last Return model, solid objects such as buildings that do not have 
any transparency are also returned. 

• Full Feature — This model returns an average value of all the returns at a 
given (X, Y) location.

• First Return — Also known as the first pulse return, this model 
corresponds to a pulse return from the first (highest) surface. This model 
can include returns from the top of any semi-solid object, such as 
vegetation.

• Output Images — This drop-down button allows you to select the elevation 
data, the intensity data, or both to be saved to an ENVI format file. If your 
Output Format is ENVI Vector File, then both elevation and intensity are saved 
as attributes to the vector file.

• Elevation and Intensity (default) — The output file contains a Digital 
Elevation Model (DEM) of the surface height, and an intensity image.

• Elevation — The output file contains only the DEM of the return height.

• Intensity — The output file contains only the intensity image.

• Select Output Image Projection — (These settings are only available if the 
LAS file has associated geospatial information.) This determines the data 
projection saved in the DEM or vector file. The default settings shown are the 
projection information of the input LAS data file. 

In the list of projection types, click on the name of a projection to select it.
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• To build a customized map projection, click New and follow the 
instructions under “Building Customized Map Projections” in Chapter 10 
of the ENVI User’s Guide manual.

Different parameters are available depending on the selected projection 
type.

• Enter or select the corresponding secondary parameters for the selected 
projection type; if you select Arbitrary, select either Pixel Based or Map 
Based by clicking on the arrow toggle button. 

Pixel-based uses the upper left corner as the origin and map-based uses the 
lower left corner as the origin. Either selection only affects the Y 
coordinates.

• To change the datum for a projection type, click the Datum button and 
select a datum from the list in the Select Geographic Datum dialog.

• If you select UTM, click the N or S toggle button to indicate if the selected 
latitude is north (N) or south (S) of the equator. Enter a zone, or click the 
Set Zone button and enter the latitude and longitude values to 
automatically calculate the zone.

• If you select a State Plane... projection, enter the zone or click the Set 
Zone button and select the zone name from the list.

Both NOS and USGS zone numbers are shown next to the zone name.

• To designate the units for a projection type, click the Units button and 
select a unit type from the pop-up dialog. 

Note
Be sure the values in the Output X Pixel Size and Output Y Pixel Size 
fields use the specified Units.

• Interpolation — This setting is required if the ENVI Raster File has been 
selected for the output format. This option determines if Linear or Quintic 
interpolation is used to create a regular grid of interpolated Z values. 

• Linear Interpolation (default) — A regular grid of linear interpolated Z 
values.

• Quintic Interpolation — A smooth interpolation performed using quintic 
polynomials. 

• Extrapolate Edges — This setting is required if the ENVI Raster File has 
been selected for the output format. Click the arrow toggle button to Yes to 
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extrapolate the boundary node indices within the geographic bounding box 
defining the data set. The default is No.

• Background Value — The Z value assigned to pixels outside of the calculated 
triangles. This setting is required if the ENVI Raster File has been selected for 
the output format. The default is 0.0000.

• Output X Pixel Size and Output Y Pixel Size — Enter the size of a pixel in 
the data in the specified projection units. This setting is required if the ENVI 
Raster File has been selected for the output format. The default values are set 
to 5.0. 

If projection information exists for the data file, then the units are the same as 
the units of the chosen projection. If no projection information exists, then the 
units are the same as the stored units of the data (unknown, meters, feet, etc.).

• Output Data Type — Choose from nine ENVI data types: Byte, Integer, 
Unsigned Int, Long Integer, Unsigned Long, Floating Point, Double 
Precision, 64-bit Integer, Unsigned 64-bit. This setting is required if the 
ENVI Raster File has been selected for the output format. The default data 
type is Integer.

Note
Select Floating Point, or Double Precision for highest data fidelity.

• Output Result to — Select either File or Memory.

• File (default) — When this option is chosen, the output is stored in a file 
and can be recalled in subsequent ENVI sessions. You must specify a 
filename for the saved output.

• Memory — When you choose this option, the output image or vector 
layer is saved in your computer system memory. The image or vector layer 
can be displayed during the current ENVI session, but will be deleted from 
memory when you close the ENVI session.
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Opening Image Processing Files

ENVI reads files stored in ArcView, ERDAS, ER Mapper, and PCI image processing 
formats. ENVI automatically reads the needed header information and enters the 
bands into the Available Bands List.

Opening ArcView Raster (.bil) Files

ENVI reads ArcView raster format files that have the.bil file extension and an 
associated header file with the extension .hdr. 

1. Select File → Open External File → IP Software → ArcView Raster (.bil).

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the header information, including the UTM and State 
Plane projection georeferencing information, and enters the image bands into the 
Available Bands List.

Note
A free plug-in to ArcGIS is available on the Research Systems download web site, 
www.rsinc.com/download/. This plug-in allows ArcGIS software to directly 
read the ENVI Raster format files.
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Opening ERDAS 7.5 (.lan) Files

To open files stored in the ERDAS 7.5 file format:

1. Select File → Open External File → IP Software → ERDAS 7.5 (.lan). 

2. When the file selection dialog appears, select an input file to be read. 

ENVI automatically extracts the header information and enters the image bands into 
the Available Bands List. ENVI will read the UTM georeferencing information from 
the associated ERDAS 7.5 .pro file.

Opening ERDAS 8.x (.img) Files

To open files stored in ERDAS 8.x Imagine file format:

1. Select File → Open External File → IP Software → ERDAS 8.x (.img).

2. When the file selection dialog appears, select an input file to be read.

ENVI automatically extracts the required header information, including any 
georeferencing and datum information, and enters the image bands into the Available 
Bands List. However, ENVI does not support compressed ERDAS 8.x (.img) files.

ENVI also supports ERDAS .img one band classification files. The class name and 
color lookup tables for this band are parsed from the file’s header.

Note
Because ERDAS’ tiling scheme is not optimized for ENVI, loading of large 
ERDAS files is extremely slow. We recommend converting to a standard flat file in 
ERDAS prior to use with ENVI. 

Opening ER Mapper Files

To open files stored in the raster ER Mapper file format: 

1. Select File → Open External File → IP Software → ER Mapper.

2. When the file selection dialog appears, select the data header file (.ers) to be 
read. 

ENVI automatically extracts the required header information, including UTM 
georeferencing information (unrotated), and places the image bands in the Available 
Bands List.
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Note
ENVI reads ER Mapper unsigned integer data, but does not read signed 8-bit or ER 
Mapper algorithm files.

Opening ECW Files

To open files stored in the ECW (Enhanced Compressed Wavelet) format:

1. Select File → Open External File → IP Software → ECW.

2. When the file selection dialog appears, select the ECW file.

ENVI extracts the information, including any georeferencing, and lists the image in 
the Available Bands List.

Opening PCI (.pix) Files

To open files stored in the PCI database file format:

1. Select File → Open External File → IP Software → PCI (.pix). 

2. When the file selection dialog appears, select a file to be read. 

ENVI automatically extracts the header information, including any georeferencing 
information, and places the image bands in the Available Bands List. 

Note
You cannot use this option to directly read PCI files that contain multiple data types 
or that are in file interleave format.

Opening and Writing ESRI GRID Data

Reading and writing ESRI GRID data format is supported on Windows platforms 
only.

Warning
Verify that you have a licensed version of ESRI ArcView or ArcGIS 8.x installed on 
your system. If you have ArcView or ArcGIS 8.x installed but not licensed, do not 
attempt to read or write ESRI GRID datasets with ENVI. Doing so may cause 
ENVI to exit immediately.

Note
The ability to read and write GRID datasets is only available in a licensed version of 
ENVI. You cannot access GRID datasets while ENVI is in demonstration mode.
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Opening ESRI GRID Files in ENVI

To read GRID datasets into ENVI, perform the following steps.

1. From the ENVI main menu, select File → Open External File → IP 
Software → ESRI GRID. The Select Grid to Open dialog appears.

2. Use the Select Grid to Open dialog to navigate to the directory containing the 
GRID (single band data) or GRID Stack 7.x (multiband data) data set you want 
to open in ENVI. Highlight the GRID or GRID Stack, and then click the Open 
button. The data appears in the ENVI Available Bands List with the associated 
map information. 

Note
An ESRI GRID or ESRI GRID Stack is stored in a directory, not a file. When 
a GRID directory is opened in ENVI, it is opened as single band data. When 
a GRID Stack directory is opened, it appears in the Available Bands List as 
an image with multiple bands.

3. To view the data, simply highlight the data in the Available Bands List, select 
Grayscale or RGB and load it into an ENVI display.

Writing an ESRI GRID File From ENVI

You can save your image files in the ESRI GRID raster format from either the ENVI 
main menu or the Display menu bar in the Main Image window.

Note
You can only save imagery to the GRID format if that imagery contains 49 or fewer 
bands and each band contains only square pixels. Datasets with non-square pixels or 
more than 49 bands are not allowed in the GRID format.

To save an image to a GRID, perform the following steps.

1. Select File → Save File As → ESRI GRID from the ENVI main menu. The 
Output to ESRI GRID Input Filename dialog appears.

2. Use the Output to ESRI GRID Input Filename dialog to select the image file 
you want to save to a GRID, then click OK. The Export to Grid dialog appears.

3. In the Export to GRID dialog, navigate to the directory under which the GRID 
will be saved. Select an existing GRID, or type in the name of a new GRID, 
and click the Open button to save the data to the specified GRID.
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To save the contents of an ENVI display to a GRID, perform the following steps.

1. Select File → Save Image As → Image File… from the Display menu bar. 
The Output Display to Image File dialog appears.

2. Use the Output File Type drop-down button to select the ESRI GRID option.

Note
When the ESRI GRID option is chosen, the three letter extension on the 
default filename is removed because the ENVI image file is saved as a GRID 
(as a directory, not a single file). 

3. Verify that the path name conforms to ESRI requirements before proceeding. 
ESRI grid names must have the following features:

• The first character must be alphabetic (a-z and A-Z).

• The grid name may not contain more than 13 characters.

• Valid characters are alphabetic or numeric (0-9).

4. When you are satisfied with your selections, click OK to save the file as a 
GRID.

Opening Generic Image Format Files

ENVI reads generic image format data including ASCII, BMP, HDF, JPEG, 
JPEG2000, MrSID, PDS, PICT, PNG, SRF, TIFF/GeoTIFF, and XWD. The files, 
with the exception of TIFF and BMP files, are converted to ENVI format files. TIFF 
and BMP files are kept in their native formats. See “Opening TIFF Files” on page 100 
and “Opening ASCII Files as Image Files” on page 100 for detailed instructions. If 
the envi.cfg option Open applicable formats automatically to memory is set, 
generic image format files will be automatically placed in memory.

Note
Converting generic image files to ENVI format is limited to images that fit entirely 
into system memory with the exception of TIFF, HDF, and BMP format images.
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Opening Standard Format Image Files

To open files stored in standard image file formats, including BMP, JPEG, 
JPEG2000, PICT, PNG, SRF, and XWD:

1. Select File → Open External File → Generic Formats → the file type to be 
read.

2. When the standard ENVI file selection dialog appears, select a file to be 
converted to RGB format. Files can be converted and read into memory or 
output to a disk file. 

Note
If the Open applicable formats automatically to memory parameter in the 
envi.cfg file is set to No, the External File Conversion dialog appears. For 
information about the envi.cfg file, see “The ENVI Configuration File” in 
Appendix A.

3. If the External File Conversion dialog appears, select output to File or 
Memory and click OK. If you select output to File, a new file and standard 
ENVI header file are created from the information in the embedded header.

Note
If you open a JPEG file that was created from a georeferenced image, the file may 
have a .jgw file associated with it. If a .jgw file is present, ENVI reads the map 
information from it.

The band(s) from the converted file are listed in the Available Bands List.

Opening MrSID Files

The MrSID (Multi-Resolution Seamless Image Database) format is a wavelet 
compressed, multi-resolution raster image format. MrSID images may be viewed 
without ever being fully decompressed. The memory requirements and time delays 
associated with opening a full image into memory are thus avoided, and an image, 
regardless of size, may be viewed quickly. To open MrSID compressed format single-
band or three-band files: 

Note
Opening MrSID files is only available on Windows platforms.

1. From the ENVI main menu, select File → Open External File → Generic 
Formats → MrSID, or select File → Open Image File.
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2. When the standard ENVI file selections dialog appears, select the MrSID 
compressed file to be read.

ENVI automatically extracts the needed header information, including any 
georeferencing information, and places the image bands in the Available Bands List.

Opening ASCII Files as Image Files

Use Generic Formats to open an ASCII file as an image. Each ASCII value is read as 
a pixel DN value. The ASCII values must be separated by white spaces or commas. 
Lines at the top of the file that have non-numeric characters or that start with a 
semicolon are skipped. The image data in the file must be in the format of an image 
array. The number of samples is determined by the number of values in a line, and the 
number of lines is determined by the number of lines in the file.

1. Select File → Open External File → Generic Formats → ASCII.

2. When the standard file selection dialog appears, select an ASCII file to input.

The number of samples and lines (columns and rows) are automatically 
determined.

3. When the Input ASCII File dialog appears, select BSQ, BIL, or BIP from the 
Interleave button menu.

4. From the Data Type button menu, select the correct data type.

5. Enter or select the number of input bands by using the arrow buttons next to 
the Number of Bands label or by typing a number into the box.

6. Click OK.

The bands are read into memory and entered into the Available Bands List.

Opening TIFF Files

ENVI supports the following TIFF files: TIFF world files (.tfw), GeoTIFF, 1-bit, 4-
bit, 8-bit, 16-bit signed and unsigned integer, 24-bit, 32-bit signed and unsigned long 
integer, and 32-bit floating point.

Note
ENVI does not support LZW-compressed TIFF files.

1. Select File → Open External File → Generic Formats → TIFF/GeoTIFF.
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2. When the standard file selection dialog appears, select a TIFF file to input. If 
you have a .tfw associated with your TIFF file, follow these additional steps. 

A. When the TIFF World File Input Projection dialog appears, select the 
desired input projection and enter the zone number, if needed (see 
“Selecting Map Projection Types” in Chapter 10).

B. Click OK.

Note
If you have a GeoTIFF file and a TIFF world file, all projection information will be 
read directly from the GeoTIFF file.

The bands are placed in the Available Bands List.

Opening HDF Files

Supported HDF files include raster format, images stored in three-dimensional 
scientific data format and plots stored in one-dimensional scientific data format. The 
HDF plot files are read directly into an ENVI plot window. 

To read HDF format data:

1. Select File → Open External File → Generic Formats → HDF. 

2. When the file selection dialog appears, select the input file. 

3. When the HDF Dataset Selection dialog appears, select the files to read by 
clicking in the text boxes next to their names and clicking OK.

Note
If a three-dimensional data file is selected, the Data Set Storage Order dialog 
appears. Select the HDF data storage order by clicking on BSQ (band 
sequential), BIL (band interleaved by line) or BIP (band interleaved by 
pixel).

All the one-dimensional HDF files selected are read directly into an ENVI plot 
window. The two-dimensional and three-dimensional files are read and placed in the 
Available Bands List.
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Opening PDS Image Files

ENVI reads uncompressed PDS format only and does not support VAX floating point 
(complex, double, or real) data. To read uncompressed Planetary Data System format 
files with attached and detached PDS data product labels:

1. Select File → Open External File → Generic Formats → PDS.

2. When the file selection dialog appears, select the desired .img input file.

ENVI automatically extracts the needed header information and enters the image 
bands into the Available Bands List. 
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Opening Previous Files

Use Open Previous File to view and select from a list of the last 20 files that were 
opened in ENVI. Selecting a file opens it. When a new file is opened, it is added to 
the top of the list. When more than 20 files have been opened, the file at the bottom of 
the list is removed. 

Tip
If a file is sticky, it remains at (sticks to) the top of the previous files list. See 
“Setting ENVI Preferences” on page 174 for instructions on making a file sticky. 

The file names under the Open Previous File menu item are stored in a user-selected 
ASCII file (see “Setting ENVI Preferences” on page 174). The format of this file is 
described in “ENVI Previous Files List” in Appendix B.

To open a file from the previous files list, select File → Open Previous File and click 
on the desired file name.

The filename appears in the Available Bands List.
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Editing ENVI Headers

ENVI stores information about files in a separate text header file with the same name 
as the image file, but with the file extension .hdr. Use the Edit ENVI Header 
function to change the header information. Each time a data file is opened, ENVI 
searches for the header file and uses the information to open the file. 

1. Select File → Edit ENVI Header.

The Edit Header Input File dialog appears.

Tip
You can also open the header by right-clicking the filename in the Available 
Bands List.

2. Click on the desired filename. The file details are displayed in the text box 
labeled File Information. 

3. Click OK. The Header Info: dialog appears. Use the Header Info: dialog to 
edit general image parameters, band names, wavelengths, and map 
information; or to associate a DEM with an image. Refer to the procedures in 
the following sections for specific editing instructions.

4. After editing the header, click OK.

Note
If you edit the header of a file that is currently open, ENVI closes that file 
and re-opens it when you click OK. Because the displays using that file close 
when the file closes, you must restart those displays from the Available 
Bands List.
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Modifying General Image Parameters

Use the Header Info: dialog to edit general image parameters. Each field is explained 
in this section.

Note
Use caution when editing the general image parameters for files not in the ENVI 
file format. For example, changing the data type of an image in an HDF file will not 
effect the data type of the displayed or returned data. The HDF format will override 
any setting by the user. To change the data type of an HDF image, first save the data 
to an ENVI file and then change the data type. This is also true for many external 
file formatted files opened in ENVI.

To save an image file as and ENVI format file, see “Saving Files as Standard ENVI 
Files” on page 127.

Figure 2-4: Header Info: Dialog
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• The Samples field displays the number of samples in the file.

• The Lines field displays the number of lines in the file.

• The Bands field displays the number of bands stored in the file.

• The Offset field displays the offset in bytes from the start of the file to where 
the actual data begins. (The Offset is sometimes known as the embedded 
header.)

• The xstart and ystart fields define the image coordinates for the upper left-
hand pixel in the image. Images that are spatial subsets of larger images will 
often use an image coordinate system that references the parent (or larger) 
image so that the two can be linked and dynamically overlaid. The default 
values are (1,1) so that the upper left hand pixel has an image coordinate of 
(1,1).

Note
Changing the value of xstart or ystart does not affect the way ENVI reads 
the image data from the file.

• Use the Data Type pull-down menu to select the appropriate data type (byte, 
integer, unsigned integer, long integer, unsigned long integer, floating point, 
double precision, 64-bit integer and unsigned 64-bit integer, complex, or 
double complex). 

• Use the Byte Order pull-down menu to select the byte order of the data. This 
parameter varies by platform:

• For DEC machines and PCs, select Host (Intel), for the host least 
significant first byte order. 

• For all other platforms, select Network (IEEE), for the network most 
significant first byte order. 

• Use the Interleave menu to select the data storage order from these choices:

• BSQ — band sequential

• BIL — band interleaved by line

• BIP — band interleaved by pixel

• Use the text field at the bottom of the Header Info: dialog to insert string text 
that describes the data file.
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Selecting File Types

ENVI uses the File Type header field to automatically identify certain types of data 
files. In the Header Info: dialog, use the File Type field to identify the native file type 
of the file that the ENVI header belongs to. The file will have an ENVI Header, but 
will still exist in its native format. The ENVI header file can be used to add ancillary 
information (i.e., wavelengths) that is used in ENVI.

From the File Type button menu, select a file type.

Tip
For a complete list of all file types recognized by ENVI, see the filetype.txt 
file that comes in the menu directory of each ENVI release. You may edit this file 
and add new user-defined file types (see Chapter 7, “Custom File Input” in the 
ENVI Programmer’s Guide).

The file types include ENVI-specific file types such as meta files, classification files, 
virtual mosaics, spectral libraries, and FFT results. The file types also encompass 
data-specific formats such as NLAPS, RadarSat, Spot, etc. TIFF, BMP, ERDAS 8.x 
and PCI files are also recognized.

Inputting Header Information from Other Files

In the Header Info: dialog, use the Input Header Info From pull-down menu to 
incorporate the header information of another open file into the header of the current 
file. 

1. Select Input Header Info From → Other File.

2. Select the file containing the header information and click OK.

Editing Ancillary Header Information

ENVI headers may have associated ancillary information (Band Names, Spectral 
Library Names, Wavelengths, Bad Bands List, FWHM) depending on the image data 
type.

In the Header Info: dialog, use the Edit Attributes pull-down menu to edit ancillary 
header information such as band names and wavelengths, to edit map, classification, 
Z-plot and stretching information, and to determine what images to display for 
complex data types.
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Selecting Bad Bands

Use the Bad Bands List to select bands to be excluded from plotting or optionally 
omitted during processing. The Bad Bands list is often used to omit the water vapor 
bands in hyperspectral data sets.

1. In the Header Info: dialog, select Edit Attributes → Bad Bands List.

2. In the Edit Bad Bands List values dialog, all bands in the list are highlighted by 
default as good. Deselect any desired bands in order to designate them as bad 
bands.

• To designate a range of bands, enter the beginning and ending band 
numbers in the text boxes next to the Add Range button. Click Add 
Range.

3. Click OK.

Editing Band Names or Spectral Library Names

1. Select Edit Attributes → Band Names, or Spectral Library Names.

2. Click on the name to change in the list. The value appears in the text box under 
the Edit Selected Item label.

3. In the text box, type the new name and press the Enter or Return key.

4. Click OK.

Figure 2-5: Edit Bad Bands List Values and Edit Band Name Values Dialogs
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Editing Wavelengths and FWHM

1. Select Edit Attributes → Wavelengths or FWHM.

2. Click on the value to change in the list. The value appears in the text box under 
the Edit Selected Item label.

3. In the text box, type the new value and press the Enter or Return key.

4. Click the Wavelength/FWHM Units: pull-down menu button to select the 
units to use with your wavelength and FWHM values. 

Note
The wavelength units are used to scale correctly between different 
wavelength units in ENVI’s Endmember Collection dialog. For more 
information, see “Collecting Endmember Spectra” in Chapter 6.

5. Click OK.

Importing Header Data from ASCII Files

1. In any Edit Values dialog, click Import ASCII. 

2. When the standard ENVI File Selection dialog appears, open the ASCII file. 
The Input ASCII File dialog appears with first few values from the ASCII file 
listed.

Note
The number of rows of the ASCII file must match the number of bands in the 
image file. The ASCII file may have one or more columns of ASCII data, 
while the file used to import band names can only contain strings. 

3. In the Wavelength Column text box, enter the number of the ASCII column 
that contains the wavelengths.

Note
To scale the wavelength values on-the-fly, enter a multiplicative scale factor 
in the Multiply Factor text box. For example, to multiply the imported 
wavelength values by 100, enter 100.

4. In the FWHM Column text box, enter the number of the ASCII column that 
contains the band width information (used in spectral resampling).
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Note
The ASCII file can also contain a Bad Bands List column. The Bad Bands 
List column specifies a good band with a 1 and bad band with a 0. 

5. Enter the number of the ASCII column that contains the Bad Bands List.

6. Click OK. 

7. Click OK in the Header Info: dialog to write all of the changes to the header 
file.

Setting Default Bands to Load

Use Default Bands to Load to identify bands that will be automatically loaded into 
the a new display group when the file is opened. Either a grayscale image or a color 
image can be selected. 

1. From the Header Info: dialog, select Edit Attributes → Default Bands to 
Load. The Default Bands to Load dialog appears with a list of all the bands in 
the file.

Figure 2-6: Input ASCII File Dialog
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2. Click on the bands names to load in the red (R), green (G), and blue (B) guns.

• If only one band is selected, it will be loaded as a grayscale image.

• Click Reset to clear the bands.

3. Click OK to return to the Header Info: window.

When the file is opened, the bands will automatically be loaded into a new display 
group.

Entering Gains and Offsets

Use Gains and Offsets to enter values that will be used as default values in the Basic 
Tools → Preprocessing → General Purpose Utilities → Apply Gain and Offset 
function. For more information, see “Applying Gain and Offset” in Chapter 5.

1. From the Header Info: dialog, select Edit Attributes → Gains or Offsets.

2. Click on the value to change in the list. The value appears in the text box under 
the Edit Selected Item label.

3. In the text box, type the new value and press Enter or Return.

4. Click OK.

Entering Map Information for Georeferenced Files

Map information is associated with georeferenced files. In ENVI, the term 
georeferenced refers to images that have been geometrically corrected (i.e., rectified) 
such that they conform to a known projection. To establish the georeferenced data 
coordinate system, you must know the sample and line coordinates of one pixel (the 
reference pixel), the pixel size, the map projection, and map coordinates of this pixel.

Note
In ENVI, pixel values always refer to the upper left corner of the pixel. Map 
coordinates also typically refer to the upper left corner of the pixel. However, if you 
want the map coordinate to reference the middle of the pixel, add 0.5 to the image 
coordinate of the reference pixel specified in the Map Info field of the header (e.g., 
x = 1.5, y = 1.5 would make the map coordinates refer to the center of the pixel).

1. From the Header Info: dialog, select Edit Attributes → Map Info.

2. In the Map Information dialog, enter the reference pixel coordinates in the 
Image Coord X and Y text boxes and the pixel size in the Pixel Size X and Y 
text boxes. Be sure to enter the pixel size in the units appropriate for your 
selected projection.
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Note
If north is not up in the image, enter a rotation angle in degrees in the Map 
Rotation text box. Measure the angle in a clockwise direction where zero 
degrees is straight up (see “Overlaying Grid Lines” in Chapter 4).

3. Select the map projection by clicking on Change Projection and selecting the 
appropriate projection from the list of projections (see “Selecting Map 
Projection Types” in Chapter 10).

4. Enter the coordinates of the reference pixel in the appropriate text boxes.

Note
The corresponding latitude and longitude will be automatically calculated 
and can be viewed by clicking on the arrow toggle button to Geographic 
Coordinates. 

5. Click OK to return to the Header Info: window.

Figure 2-7: Map Information Dialog
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Associating a DEM to a File

You can associate a DEM (Digital Elevation Model) with an image via the ENVI 
header file. This allows you to retain the association between the two files in a 
persistent manner. You can also break the association by editing the ENVI header file 
to remove the reference to the DEM file.

To associate a DEM with an image, perform the following steps.

Note
When a DEM band is chosen, no checks are performed to assure the DEM is 
complimentary to the image; that is, no check is made to verify they are 
georeferenced and cover the same area. 

1. In the main ENVI menu bar, select File → Edit ENVI Header.

2. Select the image file whose header you wish to edit.

3. In the Header Info: dialog, click the Edit Attributes → Associate DEM 
File… option. 

4. If an association already exists, the Associate DEM with File dialog opens 
(Figure 2-8). Select either Edit existing DEM file association, or Clear 
existing DEM file association. 

• If you choose Edit existing DEM file association, a Select DEM Band to 
Associate With This File dialog opens. The existing associated band is 
highlighted by default. Edit the DEM file association by selecting another 
band to associate. Click OK.

• If you choose Clear existing DEM file association, the Associate DEM 
with File dialog closes, the association no longer exists, and you are 
returned to the Header Info: dialog. 

Figure 2-8: New Associate DEM with File Dialog
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If the association of a DEM with this image is new, a file selection dialog 
appears. (Spectral or spatial subsets are not allowed in this dialog.) Select a 
band to be the associated DEM. Click OK.

When a DEM association is selected, two fields (Table 2-1) are written to the 
ENVI header file.

Whenever an image which has an associated DEM is opened, the DEM will also be 
opened in the Available Bands List.

The DEM is not displayed in the Available Bands List if the associated DEM file is 
not found by ENVI. When this happens, an error message is returned and the base 
image is still opened in the Available Bands List, but the DEM is not.

This DEM association also affects the following functionality in ENVI.

• Cursor Location/Value Tool — The DEM value for a given pixel is displayed 
next to the data value for areas where the DEM and the image share common 
geographic coordinates; for example, “Data:11  (DEM=1280)”. The DEM 
value is not shown if either the image or the DEM are not georeferenced.

• 3D SurfaceView — The associated DEM file is used as the default and you are 
not prompted to select a DEM for the surface.

• RPC Projection Emulation — If an image is displayed using RPC projection 
emulation and it has an associated DEM, the DEM is used to refine the RPC 
solution. This increases the positional accuracy of the RPC solution.

Field Description

dem file = /path/file Path and Filename of selected DEM file

dem band = 2 Index (starting at 1) of selected DEM band

The dem band will not be written if the DEM 
file contains a single band, or if the first band 
of an image was chosen. In these cases, the 
dem band value defaults to 0.

Note - Neither field will be written if an in-memory band is selected as 
the associated DEM band. In this case, the DEM association exists for 
the current ENVI session only; it does not persist for subsequent 
sessions.

Table 2-1: Associated DEM Header Fields
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Note
For this functionality, the DEM must contain map information covering the 
area for the RPC image; otherwise, the default elevation is used.

• RPC Orthorectification — If an image being orthorectified has an associated 
DEM file, then it is used by default as the elevation input to the 
orthorectification process. You can change this default designation at any time, 
if desired.

Emulating an RPC Projection

If your file has an associated RPC file, use this method to automatically use the RPC 
file to derive RPC-based geolocation information for individual pixels in an image. A 
file containing the image RPCs is required. The geolocations are determined from a 
pseudo projection, which is emulated from the provided RPC model. This method 
does not change the appearance of the image, it simply calculates the correct 
geolocation for each individual pixel.

Note
This RPC-based georeferencing method is less computationally and disk space 
intensive than a full orthorectification process performed on the imagery; however, 
the full orthorectification process provides greater accuracy.

To establish a pseudo projection emulated from a file containing RPCs, perform the 
following steps:

1. From the Header Info: dialog, select Edit Attributes → RPC Projection 
Emulation. If an associated RPC file cannot be found, a warning dialog 
appears prompting you to select a file containing the RPC coefficients. The 
RPC Parameters dialog opens when a file containing RPCs is determined.

2. In the RPC Parameters dialog, toggle the arrow button to set RPC Projection 
Emulation Enabled to either On (enabled projection) or Off (use the native 
map information, if any).

3. If needed, use the Select Projection section of the RPC Parameters dialog to 
modify the projection used to report the resulting geolocation information.

• To build a customized map projection, click New and follow the 
instructions under “Building Customized Map Projections” in Chapter 10 
of the ENVI User’s Guide manual.

Different parameters are available depending on the selected projection 
type.
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• To change the datum for a projection type, click the Datum button and 
select a datum from the list in the Select Geographic Datum dialog.

• If you select UTM, click the N or S toggle button to indicate if the selected 
latitude is north (N) or south (S) of the equator. Enter a zone, or click the 
Set Zone button and enter the latitude and longitude values to 
automatically calculate the zone.

• If you select a State Plane... projection, enter the zone or click the Set 
Zone button and select the zone name from the list.

Both NOS and USGS zone numbers are shown next to the zone name.

• To designate the units for a projection type, click the Units button and 
select a unit type for the pop-up dialog. 

4. Click OK to return to the Header Info: window.

Entering Geographic Information for Non-Georeferenced Files

If your file is not georeferenced but does include geographic information, use this 
procedure to place that information in the ENVI header file. Currently, ENVI uses the 
first geographic point to place a flag on the geo-browser showing the location of the 
file (see “Opening Files with the Geo-Browser” on page 168). The other points 
remain in the header for your information only (image georeferencing is defined 
using the MapInfo field).

1. From the Header Info: dialog, select Edit Attributes → Geographic Corners.

2. Enter between one and four pixel locations and their corresponding latitudes 
and longitudes.

Note
In ENVI, pixel values always refer to the upper left corner of the pixel. Map 
coordinates also typically refer to the upper-left corner of the pixel. However, if you 
want the map coordinate to reference the middle of the pixel, add 0.5 to the image 
coordinate of the reference pixel specified in the Map Info field of the header (e.g., 
x = 1.5, y = 1.5 would make the map coordinates refer to the center of the pixel).
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Entering Pixel Sizes for Non-Georeferenced Files

1. In the Header Info: dialog, select Edit Attributes → Pixel Sizes.

2. Enter the X and Y pixel sizes into the appropriate text boxes and select the 
desired units from the Units pull-down menu.

Editing Classification Info

1. From the Header Info: dialog, select Edit Attributes → Classification Info.

Note
The File Type must be set to Classification for this selection to be available. 

2. Enter the number of classes in the Classification Info dialog and click OK.

The Class Color Map Editing dialog appears.

Figure 2-9: Class Color Map Editing Dialog
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3. In the Class Color Map Editing dialog appears, click on the class name of the 
region to be changed from the list Selected Classes. 

• To change a selected class name, edit it in the Class Name text field. 

• To change the class color in the RGB color space (0-255 for the three 
colors), move the three sliders labeled Red, Green, or Blue. 

• To reset the original class colors and names, click Reset. 

• To change the class colors in the HSV or HLS color spaces, from the 
System pull-down menu in the Class Color Map Editing dialog, select the 
appropriate system. Move the Hue, Saturation, Value or Hue, Lightness, 
Saturation sliders to the desired values.

4. To make the changes permanent, click OK. 

Note
On 24-bit color displays, ENVI does not automatically apply the color 
changes. Instead, for 24-bit hardware, apply color changes to the image by 
clicking on the Apply Changes button, which appears only when 24-bit 
color is available.

Changing Z Plot Information

Use Z Plot Information to change Z profiles, set axes titles, set a Z Plot box size, or 
specify an additional Z profile file name.

1. From the Header Info: dialog, select Edit Attributes → Z Plot Information. 
The Edit Z Plot Information dialog appears.

2. Select from the following options:

• To set the Z plot Range: enter the minimum range value in the left and 
maximum value in the right text boxes labeled Z Plot Range. 

• To set the axes titles, enter the desired axes titles into the X Axis Title and 
Y Axis Title text boxes.

• To specify the size (in pixels) of the box used to calculate an average 
spectrum, enter the parameters into the Z Plot Average Box fields.

• To specify an additional file name from which to extract Z profiles, click 
on Default Additional Z Profiles. When the Default Additional Z Profiles 
dialog appears, click on Add New File.
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• Select the desired file name and click OK. The file name will appear in the 
list.

• To remove a file name from the list, click on the file name and click on 
Remove Selected File.

Entering a Reflectance Scale Factor

Use Reflectance Scale Factor to enter a reflectance scale factor that is used in 
ENVI’s Endmember Collection to correctly scale library data or other reflectance 
data to match the image data. If one of the files used in the Endmember Collection 
does not have a reflectance scale factor defined, then no scaling is done.

1. Select Edit Attributes → Reflectance Scale Factor and enter the value that, 
when divided into your data, would scale it from 0 to 1. For example, if the 
value of 10,000 in your data represents a reflectance value of 1.0, enter a 
reflectance scale factor of 10,000.

2. Click OK.

Entering a Data Value to Ignore

This parameter is currently used only for ENVI programming. See 
“ENVI_FILE_QUERY” in the ENVI Reference Guide manual for details.

Entering Sensor Types

1. From the Header Info: dialog, select Edit Attributes → Sensor Type. 

2. From the list, select a sensor type.

Setting the Default Stretch

Use Default Stretch to set the default stretch that will be used when displaying a 
band from the file.

1. In the Header Info: dialog, select Edit Attributes → Default Stretch. 

2. From the Default Stretch menu, select the stretch type. Your choices include: 
linear, linear range, gaussian, equalize, square root, or none.
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Some of the stretches require you to enter additional information: 

• For the % Linear stretch, enter the percentage of the data to clip (i.e. 5%). 

• For Linear Range stretching, enter the minimum and maximum DN 
values to use in the stretch. 

• For Gaussian stretching, enter the number of standard deviations to use in 
the stretch. 

ENVI saves the stretch setting in the .hdr file. Whenever you display this image, this 
stretch setting overrides the global default stretch given in the envi.cfg file.

Note
If the Default Stretch is set to None, use the Default Stretch set in the ENVI 
Configuration File (envi.cfg).

Using the Complex Lookup Function

For complex data types, use Complex Lookup Function to determine which image 
to display.

1. In the Header Info: dialog, select Edit Attributes → Complex Lookup 
Function.

2. When the Complex Data Lookup Function dialog appears, select the desired 
lookup function from the pull-down menu: Real (real portion of number), 
Imaginary (imaginary portion), Power (log10 of magnitude), Magnitude 
(square root of sum of the squares of the real and imaginary), and Phase (arc 
tangent of imaginary divided by real). The default image is Power.

Setting Row Offsets

Use Major/Minor Frame Offsets to set the number of extra bytes to skip at the 
beginning and ending of lines and bands. An offset is non-image data that you want to 
skip, and it comes before and/or after a frame. A minor frame is one-dimensional, and 
a major frame is two-dimensional. 

See the following table for definitions of major and minor frames for the various file 
formats.

1. In the Header Info: dialog, select Edit Attributes → Major/Minor Frame 
Offsets.

2. In the Major/Minor Frame Offsets dialog, enter or select the number of prefix 
and suffix bytes to skip per major or minor frame by clicking on the arrow 
buttons or by typing into the text boxes.
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The following table contains major and minor definitions for the file formats in 
ENVI.

3. Click OK.

File Format Minor Frame Major Frame

BSQ # of samples (line) # of samples by # of lines 
(band)

BIL # of samples (line) # of samples by # of bands

BIP # of bands (spectrum) # of bands by # of samples

Table 2-2: Major and Minor Frame Definitions
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Generating Test Data

Use Generate Test Data to create a variety of test images that may be useful for 
demonstrating or testing ENVI features. These include constant value images, 
horizontal and vertical ramps, random number images using both uniform and normal 
distributions, and images generated using a Gaussian Point Spread Function.

1. Select File → Generate Test Data.

2. Select the output image type by clicking the appropriate button (see 
descriptions in the following sections).

3. When the Generate Image Parameters dialog appears, select the number of 
output samples, lines, and bands and the output data type.

4. Select output to File or Memory.

5. Click OK to start the function.

A status box appears while the image is being processed. The new image will be 
listed in the Available Bands List when processing is complete.

Figure 2-10: Generate Image Parameters Dialog
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Generating Constant Value Images

To generate an image with a constant value for every pixel:

1. In the Generate Image Parameters dialog, select the Constant exclusive 
button.

2. Enter the desired DN value in the Value text box.

Generating Horizontal or Vertical Ramps

To generate an image with a either a horizontal or vertical linear ramp:

1. In the Generate Image Parameters dialog, select either the Horiz Ramp or 
Vert Ramp exclusive button, respectively. 

2. Enter the desired minimum value of the ramp in the text box labeled Min 
Value and the desired maximum value in the text box labeled Max Value.

Generating Random Number Images

To generate an image with randomly distributed values:

1. In the Generate Image Parameters dialog, select either the Random (uniform) 
or Random (normal) exclusive button.

Selecting the Random (normal) option returns an image with normally-
distributed random numbers. Selecting the Random (uniform) option returns 
an image with uniformly-distributed random numbers. 

2. Enter the desired minimum value to occur in the image in the text box labeled 
Min Value and the desired maximum value in the text box labeled Max Value.

3. Enter a Seed value in the Seed text box for initialization of the random number 
generator.

If no seed value is entered, the system clock will be used for initialization.
ENVI User’s Guide Generating Test Data



124 Chapter 2: File Management
Generating Gaussian Images

To generate an 2D Gaussian Point Spread Function image:

1. In the Generate Image Parameters dialog select the Gaussian PSF exclusive 
button. 

2. Enter the desired minimum value to occur in the image in the text box labeled 
Min Value and the desired maximum value in the text box labeled Max Value.

3. Enter the standard deviation to be used for the function in the text box labeled 
Sigma.
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Using the Data Viewer

Use Data Viewer to examine data files at the byte level, which allows you to view 
file structure, to identify unknown file types, and to determine the “offset” to data 
when an embedded image header is present in the data. 

1. Select File → Data Viewer.

2. When the Data Viewer Input File dialog appears, select a file.

3. Click OK.

The Data Viewer dialog appears with the file name and number of total bytes 
in the window banner and the actual data values (in hexadecimal format, by 
default) in the window displayed.

Figure 2-11: Data Viewer Dialog
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The first column lists the byte count (the starting byte of the listed row). The 
next 16 columns (for hexadecimal and byte data) list the values for 16 bytes of 
data, and the final column lists the ASCII equivalent of the values. 

Note
If the data does not have any embedded ASCII characters, the ASCII 
equivalents will be totally random. If there is embedded ASCII data, the data 
will be readable as text.

4. Select from the following options:

• To select the starting byte to view from the file, enter the byte number in 
the Byte Offset text box.

• To move the data view forward or backward one page respectively, use the 
Next Page and Prev Page buttons.

• If you suspect that the data may be in something other than byte format, 
select a data format (Hexadecimal, Byte, Unsigned Integer, Integer, 
Long Integer, Unsigned Long Integer, or Floating Point) from the 
View_Format menu. The number of columns of data values and the 
representation of the listed data change accordingly.

• To open and view a different file, select File → Open New File.

• To exit the function, select File → Cancel.

• To evaluate swapping of bytes between Intel and IEEE formats for data 
types with more than one byte per value (integer, long integer, and floating 
point), select from the Byte_Swap menu: None (no swapping), Short 
Word (swapping two bytes for an integer), or Long Word (swapping byte 
pairs for long integer and floating point data).
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Saving Files

Use Save File As to create a new standard ENVI disk file or an ENVI Meta File from 
bands contained in the Available Bands List and to output image data to various 
image processing formats. You can output your data to image processing formats 
such as ArcView Raster (.bil), ER Mapper, ERDAS (.lan), NITF (.ntf), PCI 
(.pix), TIFF (including GeoTIFF and TIFF world files [.tfw]), and JPEG2000 files 
(.jp2). In addition, you can output your image to an ASCII (.txt) file.

Note
New files can only be created from bands that have the same spatial dimensions. 
Use ENVI’s integral subsetting capabilities to choose individual bands and to 
perform on-the-fly subsetting of files to the correct dimensions. For instructions, 
see “Selecting a Spatial Subset” on page 35 and “Selecting a Spectral Subset” on 
page 40.

Saving Files as Standard ENVI Files

Use ENVI Standard to create disk files from a combination of ENVI files, external 
(foreign) files, or memory items.

1. Select File → Save File As → ENVI Standard.

The New File Builder dialog appears.

Figure 2-12: New File Builder Dialog
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2. In the New File Builder dialog, click Import File. The Create New File Input 
File dialog appears.

3. Select files by clicking on the file names.

Note
If the file to be included is not listed, click Open File and select the input file.

4. Spatially or spectrally subset the file as desired (see “Selecting a Spatial 
Subset” on page 35 or “Selecting a Spectral Subset” on page 40).

Tip
You can spatially or spectrally subset a group of files if they are the same 
size. The subset will be applied to each file.

5. Repeat the file selection using the Import ENVI File button for each input file 
to be included in the new file. Input files are listed in the Selected ENVI Files 
for New File list.

• To delete a file from the list in the New File Builder dialog, click on the 
filename and click Delete.

• To change the order in which the files and/or bands are imported, see 
“Reordering Files” below.

6. Select output to File or Memory.

7. Click OK to build the new file.

The file will be output as a band sequential (BSQ) format.

Reordering Files

1. In the New File Builder dialog, click the Reorder Files button. The Reorder 
Files dialog appears.

2. Click on a filename or bandname and drag it to the desired position in the list.

3. Repeat for as many filenames or bandnames as needed. 

4. Click OK.
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Removing Superfluous Files

When you create a standard file, use this procedure to remove the bands used to 
create it.

To remove the component files, use the arrow toggle button to select Yes (remove 
files), or No, next to the text label Remove Superfluous Files?. 

Warning
This function physically removes the files from the Available Bands List and the 
disk:

If memory items are to be transferred to the new file and Remove Superfluous 
Files? is selected, they are deleted from memory when the new file is created.

If all of the bands from a disk file are to be transferred to the new file and Remove 
Superfluous Files? is selected, the original disk file is physically deleted from the 
disk when the new file (either memory or disk file) is created.

Saving Files as ENVI Meta Files

A meta file is a virtual file structure, in which no new disk file is actually created. 
Instead, selected files or image bands are associated through the use of a small text 
file containing the names of the files that are to be treated as a virtual file. When this 
file is later selected for input or processing, ENVI gets the image data from the 
individual disk files and treats them as if they were actually in the same input file for 
processing. ENVI meta files can contain images with different data types (byte, 
integer, floating point, etc.), which allows you to combine processing of diverse data 
sets. No file conversions are required, and no intermediate processing files are 
created.

Note
Files to be included in Meta Files must reside on disk as ENVI format files. Convert 
foreign files imported to ENVI (e.g., TIFF files) or files/bands created as memory 
items within ENVI to ENVI disk files prior to creating the meta file.

1. Select File → Save File As → ENVI Meta.

2. When the New File Builder dialog appears, click Import File. The Create New 
File Input File dialog appears.

3. Select files by clicking on the file name(s). If the file to be included is not 
listed, click Open File and select the desired input file.
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Tip
You can spatially or spectrally subset a group of files if they are the same 
size. The subset will be applied to each file.

4. Spatially or spectrally subset the file as desired (see “Selecting a Spatial 
Subset” on page 35 or “Selecting a Spectral Subset” on page 40).

5. Repeat the file selection using the Import ENVI File button for each input file 
to be included in the new file.

• To delete a file from the list in the New File Builder dialog, click on the 
filename and click Delete.

• To change the order in which the files and/or bands are imported, see 
“Reordering Files” on page 128.

6. In the Enter Output Filename text box, enter a filename or click Choose and 
select an output filename.

7. Click OK to build the new file.

The bands in the meta file appear in the Available Bands List. The actual meta file, on 
disk, is a text file that only contains the names of the imported files.

Saving Files as ASCII Files

ASCII (.txt) output files will contain the DN values for every pixel. You may select 
the output format of the DN values (field size, including decimal point and white 
spaces, and number of decimal places). If you output multiple bands, the file 
interleave (BSQ, BIL, BIP) will be the same as the input file. The format of the 
ASCII file is that of a two-dimensional array.

Note
If your output file contains three asterisks (***), then your ASCII output format is 
incorrect for the data type of your DN values.

1. Select File → Save File As → ASCII.

2. When the Output File to ASCII Input Filename dialog appears, select a file and 
perform any subsetting.

3. Click OK.
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4. When the Output to ASCII Parameters dialog appears, select from the 
following options.

• To set the field size, click on the arrow buttons next to the Total Field Size 
label to select a number, or type a number into the box.

• To set the number of digits that will follow the decimal point in the output 
data, click on the arrow buttons next to the Decimal Precision label to 
select a number, or type a number into the box.

5. Enter an output filename, or click the Choose button to select a filename.

6. Click OK.

The output ASCII file is created and can be viewed using any text editor.

Saving Files as ArcView Raster Files

To output data to an ArcView raster (.bil) format file (including .hdr and .stx 
files):

1. Select File → Save File As → ArcView Raster (.bil).

2. When the Output ArcView Input Filename dialog appears, select the desired 
file and perform any subsetting (see “Selecting a Spatial Subset” on page 35 or 
“Selecting a Spectral Subset” on page 40).

3. When the Output File to ArcView dialog appears, enter the desired output 
filename and click OK.

ENVI creates the.bil, .hdr, and .stx ArcView raster output files.

Note
The resulting ArcView file does not contain datum and ellipsoid information.
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Saving Files as ER Mapper Files

To output data to an ER Mapper format file:

1. Select File → Save File As → ER Mapper File.

2. When the Output ER Mapper Input Filename dialog appears, select the input 
file and perform any subsetting.

3. When the Output File to ER Mapper dialog appears, enter an output filename 
and click OK.

ENVI creates an ER Mapper output file.

Saving Files as ERDAS Files

To output data to an ERDAS (.lan) format file:

1. Select File → Save File As → ERDAS (.lan) File.

2. When the Output ERDAS Input Filename dialog appears, select the input file 
and perform any subsetting.

3. When the Output File to ERDAS dialog appears, enter an output filename and 
click OK.

ENVI creates an ERDAS .lan output file.

Saving Files as JPEG2000 Files

To output to a JPEG2000 file:

1. Select File → Save File As → JPEG2000.

2. When the file selection dialog appears, select an input filename and perform 
any subsetting, then click OK. The Output File to JPEG2000 dialog appears.

3. Use the textbox or the Choose button to enter an output filename.

4. Use the button menu to specify the type of compression used to save this data 
as a JPEG2000 file.
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The button menu contains the following choices:

• Lossless Compression (default) — a completely reversible compression 
that produces a high quality result, but less data content is compressed than 
with Low Compression or High Compression.

• Low Compression — a non-reversible compression that retains nearly all 
the original data content while maintaining moderate compression.

• High Compression — a non-reversible compression that provides the 
highest level of data content compression, but could produce in a lower 
quality result.

5. Click OK to start the output processing.

ENVI creates a JPEG2000 (.jp2) output file.

Saving Files as NITF Files

To output data, including any geographic information, to a National Imagery 
Transmission Format (NITF) version 02.00 (MIL-STD-2500A), or any geographic or 
UTM georeferencing information to 02.10 (MIL-STD-2500B) format file:

Note
Currently ENVI’s NITF output uses a default Compliance Level of 99 and is not 
certified.

1. Select File → Save File As → NITF.

2. When the NITF Output File dialog appears, select the output file and perform 
any subsetting.

3. When the NITF Output Parameters dialog appears, select the NITF output 
version from the button menu.

• To enter additional parameters such as originator information or header 
details, click the Additional Settings button and enter the additional 
information in the NITF Additional Parameters dialog.

4. In the NITF Output Parameters dialog, enter an output filename and click OK.

Note
ENVI does not support blocked NITF output.
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Saving Files as PCI Files

To output data to a PCI(.pix) format file:

1. Select File → Save File As → PCI File.

2. When the Output PCI Input Filename dialog appears, select the input file and 
perform any subsetting.

3. When the Output File to PCI dialog appears, enter an output filename and click 
OK.

ENVI creates a .pix PCI output file.

Saving Files as TIFF Files

To output to a TIFF file:

1. Select File → Save File As → TIFF.

2. When the file selection dialog appears, select an input filename and perform 
any subsetting.

3. When the Output File to TIFF dialog appears, enter or choose an output 
filename and click OK to start the output processing.

ENVI creates a TIFF output file.

Note
If you selected a georeferenced file as the input file, the output file will be a 
GeoTIFF file with an associated TIFF world file (.tfw).
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Importing IDL Variables

Use Import IDL Variables to import IDL variables into ENVI. The variables must 
be defined on the ENVI command line. See the ENVI Programmer’s Guide for 
details. The Import IDL Variables function is not available in ENVI RT (run-time 
version).

1. Select File → Import IDL Variables.

The Import IDL Variables dialog appears with a list of all defined variables.

2. Select the desired variable names to import by clicking in the check box next to 
the name.

• To add a range of variable names, enter the starting and ending variable 
numbers and click the Add Range button.

• To select all the variable names, click on the Select All button.

• To clear the selected variable names, click on the Clear button.

3. To save a copy of the data in IDL, use the arrow toggle button to select Yes. 

Note
If you select No, the data will be imported into ENVI and deleted from IDL.

4. Click OK to import the selected variables.

All one-dimensional variables are placed in a plot window; the two- and three-
dimensional variables appear in the Available Band List as memory items.
ENVI User’s Guide Importing IDL Variables



136 Chapter 2: File Management
Exporting to IDL Variables

Use Export to an IDL Variable to export and/or subset an ENVI band or file to an 
IDL variable on the ENVI command line.

Tip
If the ENVI command line is not visible in the IDL window, select Window → 
Command Input in the IDL window (Export to an IDL Variable is not available 
in ENVI RT (run-time version)).

1. Select File → Export to an IDL Variable.

2. When the file selection dialog appears (see “Selecting Files in ENVI” on 
page 32), select the band or file and perform any subsetting.

3. In the Export Variable Name dialog, select one of the following options:

• If the variable has been previously defined, click on the name of the 
variable in the displayed list.

• In the New Variable Name text box, enter the name of an undefined IDL 
variable.

4. Press the Enter key on your keyboard.

The exported data will be available to use at the ENVI command line.

Figure 2-13: Export Variable Name Dialog
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Compiling IDL Code

Use Compile IDL Module if you have written your own IDL code to use in ENVI. 
Every time you change the code you will need to compile it unless the code is in the 
save-add directory and ENVI has been restarted (see “Compiling” in Chapter 1 of the 
ENVI Programmer’s Guide manual).

1. Select File → Compile IDL Module.

2. When the Enter Module Filename file selection dialog appears, select your 
module filename and click OK. 

Any compile errors are shown in the main IDL window.
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IDL CPU Parameters

In IDL, certain routines are multi-threaded. Multi-threading is used to increase the 
speed of numeric computations by using multiple system processors to 
simultaneously carry out different parts of the computation. When an ENVI operation 
uses a multi-threaded IDL routine, the ENVI operation will exhibit improved 
performance.

Note
Only ENVI operations that utilize multi-threaded IDL routines are affected. For 
more information, see the IDL documentation.

You can change the settings for how ENVI will use IDL’s thread pool during an 
ENVI session by selecting File → IDL CPU Parameters. The IDL CPU Parameters 
dialog displays.

• Thread Pool number of Processors — The number of threads that IDL will 
use in thread pool computations. The default value is equal to the value of the 
number of CPUs on your system, so that each thread will have the potential to 
run in parallel with the others. Note that there is no benefit to using more 
threads than your system has CPUs. However, depending on the size of the 
problem and the number of other programs running on the system, there may 
be a performance advantage to using fewer CPUs.

• Thread Pool Minimum Elements — The number of data elements (each 
element being a single data value of a particular data type) in a computation 
that are necessary before IDL will use the thread pool. If the number of 

Figure 2-14: IDL CPU Parameters Dialog
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elements is less than the number you specify, ENVI will perform the 
computation without using the thread pool. Use this parameter to prevent 
ENVI from using the thread pool on tasks that are too small to benefit from it. 
The default is 100000.

• Thread Pool Maximum Elements — The maximum number of elements in a 
computation that will be processed using the thread pool. Computations with 
more than this number of elements will not use the IDL thread pool. Set this 
parameter if large jobs are causing virtual memory paging on your system. 
Setting this value to 0 removes any limit on maximum number of elements. 
The default is 0.

Set the Thread Pool Number of Processors, Thread Pool Minimum Elements, 
and Thread Pool Maximum Elements and click OK.

Note
Changing the multi-threading options using the IDL CPU Parameters dialog will 
only change the options for the current session. The settings will not be saved in the 
envi.cfg file. For more information on how to change the settings in the 
envi.cfg file, see “The ENVI Configuration File” in Appendix A.

Optimizing the CPU Parameter and Tile Size 
Parameter Settings

An issue related to the Thread Pool Minimum Elements parameter is the tile size 
preferences setting (under File → Preferences → Memory Usage). The tile size 
listed here refers to the size of the tiles used during spatial processing of images in 
ENVI. If the tile size is such that each image tile has fewer array elements than the 
Thread Pool Minimum Elements value, then ENVI will not tile the process even if 
the image itself is relatively large. In this situation, you can simply set the Image Tile 
Size preference to a larger value, so that the tiles are large enough to exceed the 
Thread Pool Minimum Elements. In general, the larger the Image Tile Size, the 
more memory is required for processing, but the larger the potential performance 
from multi-threaded processing.

Correctly setting ENVI’s Image Tile Size parameter (File → Preferences → 
Memory Usage) is a very important consideration in optimizing the performance 
gains from multi-threading. Tile size is the size of the pieces into which ENVI breaks 
large datasets so that certain processes can occur on machines with finite resources. 
The default value for this parameter is 1 MB. On conventional (i.e., 1 processor) 
machines, the tile size has little to no impact on processing speed. Having it set to a 
relatively small value (such as 1 MB) can help ensure that ENVI does not run out of 
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memory, especially if other applications are running on the same machine. Setting it 
to more than 5 MB or so on most conventional machines is not recommended. 
However, on a multi-processor machine, it’s possible for a small tile size setting to 
result in undesirable consequences for multi-threading.

For example, a tile size setting of 1 MB, applied to an image containing double 
precision complex data (16 bytes per array element) will produce input arrays for 
spatially tiled processes of 62,500 elements, which would fall quite short of the 
default 100,000 element minimum required for multi-threading. Furthermore, multi-
threading performance gains are generally much better with larger input array sizes. 
An unnecessarily small tile size might needlessly limit the benefits of multi-
threading.

While not all processes in ENVI are tiled and not all processes in IDL are multi-
threaded, it’s best to set the tile size parameter on multi-processor machines with 
multi-threading in mind so as to take full advantage of this feature.

Warning
Do not just set the tile size to a large portion of your RAM. If the tile size parameter 
is set to an amount greater than the amount of actually available memory (memory 
still free after the operating system and any other applications have claimed what 
they need) and ENVI is asked to use the full tile size for a large process, any number 
of system and/or application errors could result.

The tile size should be set to a value less than the smallest amount of free memory 
that can be expected on the machine where ENVI is installed, giving due 
consideration to the memory demands of other applications and users at any given 
time. Depending on how much memory the machine in question has and what 
demands are placed on it, a safe tile size setting may in fact be significantly larger 
than the 1 MB default value.
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Tape Utilities

Use Tape Utilities to read MSS, TM, SPOT, AVHRR, AVIRIS, NLAPS, and CEOS 
format radar data (including SIR-C/X-SAR, RADARSAT and ERS-1) from a variety 
of computer compatible tape (CCT) formats and to read U.S. Geological Survey 
DEMs and DLGs (Optional Format only). Also, use the tape utilities to read BSQ, 
BIP, or BIL data directly from tape and to control SCSI tape drives (9 track, 8 mm, 
and 4 mm media) at the file and record levels.

Flexible tape tools are included with the tape utilities for inputting other data types, 
even when a specific format is not directly supported. Also included is a special tape 
output utility for writing ENVI files to tape, which preserves header information and 
file structure. A corresponding tape input utility is also available for reading ENVI 
formatted tapes. Use the tape scan and dump utilities to diagnose tape structures, 
build scripts for commonly used tape types, and dump tapes to disk.

Note
Tape functions are automatically supported on UNIX. To install SCSI tape support 
for Microsoft Windows 98, Windows 2000, Windows NT, and Windows XP 
platforms, open the aspi_v470.exe self-extracting archive in the \tape32 
directory on the ENVI for Windows installation CD. Please see the included 
README.DOC file for installation instructions.

Figure 2-15: ENVI Tape Utilities Menu
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Understanding Tape Device Names

On PC platforms, ENVI uses a tape device name based on the adaptor, target, and 
unit number. On UNIX platforms, ENVI uses the standard UNIX tape device naming 
conventions.

On PCs With Microsoft Windows

The tape devices on the PCs must be ASPI compatible SCSI tape drives. The tape 
device name on the PC is referenced by the adapter number (a#), target id (t#) and 
logical unit (l#). Most PCs have only one adapter and the logical unit number for the 
tape is 0. The target number is the SCSI id of the device. For external devices this is 
the pinwheel setting on the back of the drive. Internal devices use jumpers to set the 
SCSI id. In either case your SCSI adapter should list the target numbers of your tape 
drives during bootup. For example, your Tape device name for a tape drive with SCSI 
id 4 would be /dev/a0t4l0 (assuming only one adapter). If your tape drive is 
attached to your second SCSI adapter then you would use /dev/a1t4l0 as the Tape 
device.

On UNIX Platforms

The tape devices on UNIX platforms are specified as the name of the tape device in 
the /dev directory. For example, to specify device Øb in the /dev/rmt directory, use 
the name /dev/rmt/Øb as the ENVI Tape Device.

Reading Known Tape Formats

Use Read Known Tape Formats to read standard file formats from tape. Supported 
formats include Landsat MSS, Landsat TM, AVHRR, SPOT, AVIRIS, USGS DEM, 
USGS DLG, NLAPS, SIR-C CEOS, RADARSAT CEOS, and Generic CEOS. 

Reading Landsat MSS Tapes

ENVI reads two types of Landsat MSS tapes. MSS CCT-X format is typical of early 
MSS data recorded in the BIP2 (BIPP) format. These data consist of strips of MSS 
data for all 4 MSS bands in pixel pairs (See MSS documentation available from data 
center and other sources). Landsat MSS data has been distributed in MSS EDIPS 
format since 1979. ENVI automatically identifies both MSS CCT-X or EDIPS 
formats by scanning the tape headers. The data can be subset directly from tape.
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1. Select File → Tape Utilities → Read Known Tape Formats → Landsat 
MSS. The Landsat MSS – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Tip
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape header. If MSS format data are 
identified, the MSS Tape Output Parameter dialog appears. 

• To subset the image being read from tape, enter the starting and ending 
lines and/or samples in the text boxes labeled Samples...To and/or 
Lines...To respectively. 

4. Select bands to be read by clicking on the toggle buttons next to the desired 
band names.

Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.

5. Select output to File or to Memory. 

Note
File output is recommended. 

6. Click OK to start the tape processing. 

A status window informs you of the tape format and processing progress.
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Reading Landsat TM Tapes

ENVI reads Landsat TM tapes of these formats: full scene CCT-AT and CCT-PT 
data, TIPS (Quad) format, LGSOWG, and FAST Format. ENVI identifies the file 
type automatically by scanning the tape headers. The CCT-AT and CCT-PT data 
formats are full-scene formats that were used for early (pre-1984) TM data and are 
typically are on two (AT) or three (PT) 6250 bpi tapes. The TM TIPS format is 
typical of most historical TM data recorded in the BSQ format from 1984 through 
approximately 1991. These data consist of TM data organized by “Quadrangle” (see 
TM documentation available from EROS data center and other sources). TM data are 
currently distributed using the FAST format. For FAST format TM data that are 
georeferenced with a UTM projection, ENVI reads all of the necessary information 
and places it in the ENVI header. For Landsat data in NLAPS format, use the NLAPS 
tape reader (see “Reading NLAPS Tapes” on page 151). The data can be subset 
directly from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → Landsat 
TM. The Landsat TM-Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape header. If TM format data are identified, 
the TM Tape Output Parameters dialog appears. 

Note
To subset the image being read from tape, enter the starting and ending lines 
and/or samples in the text boxes labeled Samples...To and/or Lines...To 
respectively. 

4. Select bands to be read by clicking on the toggle buttons next to the desired 
band names.
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Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.

5. Select output to File or to Memory.

Note
File output is recommended.

6. Click OK to start the tape processing. 

A status window informs you of the tape format and processing progress.

Reading AVHRR Tapes

ENVI reads both AVHRR LAC (HRPT) and GAC (in Level 1b format) data as 
provided by NOAA. The data can be subset directly from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → AVHRR.

The AVHRR Format – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Tip
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. In the File text box, enter the file number to retrieve from the tape. 

4. Click OK to scan the tape header. If AVHRR format data are identified, the 
AVHRR Tape Output Parameters dialog appears and the bands available on 
tape are listed. 

Note
To subset the image being read from tape, enter the starting and ending lines 
and/or samples in the text boxes labeled Samples...To and/or Lines...To 
respectively. 
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5. Select bands to be read by clicking on the toggle buttons next to the desired 
band names.

Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.

6. Select output to File or to Memory. 

Note
File output is recommended.

7. Click OK to start the tape processing. A status window informs you of the tape 
format and processing progress.

Reading SPOT Tapes

ENVI automatically reads two types of SPOT data tapes: SPOT panchromatic data 
(PAN) and SPOT multispectral data (XS). The data can be subset directly from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → Spot. The 
SPOT – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Tip
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape header. If the data are identified as one 
of the supported SPOT data formats, the SPOT Tape Output Parameters dialog 
will appear. 

Note
To subset the image being read from tape, enter the starting and ending lines 
and/or samples in the text boxes labeled Samples...To and/or Lines...To 
respectively. 
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4. Select the bands to be read by clicking the toggle buttons next to the band 
names. If SPOT PAN data are identified, one band is listed in the Select 
Output Bands list. If SPOT XS data are identified, three bands are listed.

Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.

5. Select output to File or to Memory. 

Note
File output is recommended. 

6. Click OK to start the tape processing.

Reading AVIRIS Tapes

ENVI reads 1992 to 1996 NASA/JPL Airborne Visible/Infrared Spectrometer 
(AVIRIS) data tapes. These tapes are in BIL format and have a 1000 byte header, 
which ENVI automatically scans to identify the data and to extract key image 
parameters. The data can be subset directly from tape.

Tip
The 1997 and later AVIRIS tapes are in UNIX tar format and ENVI cannot read 
them directly. To read these tapes, dump the tape using tar and use File → Open 
Image File to read the data into an ENVI file.

1. Select File → Tape Utilities → Read Known Tape Formats → AVIRIS. The 
AVIRIS – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI read the AVIRIS wavelength file and scan the AVIRIS 
image header. If the data are identified as AVIRIS data, the AVIRIS Tape 
Output Parameters dialog appears.
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Note
To subset the image being read from tape, enter the starting and ending lines 
and/or samples in the text boxes labeled Samples...To and/or Lines...To 
respectively. 

4. Choose the bands (and their corresponding wavelengths) to be read by clicking 
the toggle buttons next to the band names.

Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.

5. Select output to File or to Memory. 

Note
File output is recommended. 

6. Click OK to start the tape processing.

A status window informs you of the tape format and processing progress.

Reading USGS DEM Tapes

ENVI reads both 1:24,000 (7 1/2’) and 1:250,000 (3 arc second) digital elevation 
model data in standard USGS format. You must know which files on the tape 
correspond to the input DEMs prior to starting this function (this information is 
usually on the tape label or in documentation provided by the USGS with the tape). 
The UTM, geographic, or state plane projection information is read from the tape and 
placed in the ENVI header. Multiple DEMs can be automatically mosaicked together 
from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → USGS DEM. 

2. When the DEM Tape Reader Input Parameters Dialog appears, enter the file 
number of each DEM to be read into the Tape File: text box and press the 
Return key. The file numbers to be read appear in a list under the box. 
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3. Enter a root file name to be used for DEM output. Each individual output file is 
assigned the root name with the file number appended. For example, if you 
assign the root test then file 2 will be named test_2. 

• To have ENVI automatically mosaic files together, check the Yes button.

• To have the numbered temp files that are created during the mosaic process 
automatically deleted after mosaicking, check Yes next to the Delete temp 
files when done? question.

4. Click OK. The USGS DEM Format – Load Tape Dialog appears.

5. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

6. Click OK to read the DEM data. ENVI scans the data file to determine critical 
format and location information and automatically identifies and reads the 
data.

7. Select output to File or to Memory. 

Note
File output is recommended.

8. Click OK to start the tape processing.

A status window informs you of the tape format and processing progress.
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Reading USGS DLG Tapes

ENVI reads 1:24,000 (7 1/2’) or 1:100,000 digital line graph data in the USGS 
Optional format. You must know which files on the tape correspond to the desired 
DLGs prior to starting this function (this information is usually on the tape label or in 
documentation provided with the tape by the USGS). The UTM projection 
information and Albers Equal Area projection information are read from the tape, 
placed in the .evf output file, and used as the vector projection.

1. Select File → Tape Utilities → Read Known Tape Formats → USGS DEM.

2. When the DEM Tape Reader Input Parameters dialog appears, enter the file 
number of each DLG to be read into the Tape File: text box and press the 
Return key. The file numbers to be read appear in a list under the box.

3. Enter a root filename to be used for DLG output. Each individual output file is 
assigned the root name with the file number appended. For example, if you 
enter the root filename test, then file two will be named test_2. 

4. Click OK to continue. The USGS DLG Format – Load Tape dialog appears.

5. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

6. Click OK to read the DLG data.

ENVI scans the data file to determine critical format and location information, 
automatically identifies and reads the data, and places it in the Available Vectors List 
(see “The Available Vectors List” on page 212).
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Reading NLAPS Tapes

ENVI reads National Landsat Archive Production System (NLAPS) tapes. ENVI 
reads only the first image from the tape (TM, MSS, or DEM) and currently does not 
read the optional DEM that follows a TM or MSS image. These optional DEM files 
can be read by using the ENVI dump tape utility (see “Dumping Tape Data” on 
page 165). ENVI currently only reads UTM projection information from the header 
file on tape. The data can be subset directly from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → NLAPS. The 
NLAPS – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape header. If NLAPS format data are 
identified, the Landsat NLAPS Tape Output Parameters dialog appears.

Note
To subset the image being read from tape, enter the starting and ending lines 
and/or samples in the text boxes labeled Samples...To and/or Lines...To 
respectively. 

4. Select bands to be read by clicking on the toggle buttons next to the desired 
band names.

Note
To designate a range of bands, enter the beginning and ending band numbers 
in the text boxes next to the Add Range button. Click Add Range.
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5. Select output to File or Memory. 

Note
File output is recommended. 

6. Click OK to start the tape processing.

A status window informs you of the tape format and processing progress.

Reading SIR-C CEOS Tapes

On UNIX and Windows platforms, use Read SIR-C CEOS Tape to read SIR-C 
tapes as distributed by JPS or EROS Data Center in CEOS format. Supported formats 
include Single Look Complex (SLC), Multilook Complex (MLC), and Multilook 
Ground Detected (MGD). You can subset all data types directly from tape to conserve 
disk space. In addition, SLC data sets can be multilooked from tape with integer or 
non-integer number of looks. 

Note
Depending on the data type, the size of the SIR-C data scene, and the number of 
data sets selected, the tape reading and processing could take from less than one 
hour to several hours to complete.

1. Select File → Tape Utilities → Read Known Tape Formats → SIR-C 
CEOS. The SIR-C Format – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.
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3. Click OK to have ENVI scan the tape for standard format SIR-C data. When 
the tape scan is completed, the SIR-C Tape File Selection dialog appears. A list 
of the SIR-C data files on the tape appears in the Select Output Files list. 

4. Click on the box next to one or more of the desired data sets to choose the data 
to be read from the tape.

Note
To designate a range of data, enter the beginning and ending numbers in the 
text boxes next to the Add Range button. Click Add Range.

5. Click OK. The SIR-C Tape Parameters dialog appears. The SIR-C data sets 
selected in the previous dialog are listed in the Selected SIR-C Tape Files: 
list. 

Figure 2-16: SIR-C Tape File Selection Dialog
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SIR-C Tape Options

Use the SIR-C Tape Parameters dialog to select spatial subsetting from tape, assign 
output file names, and choose multilooking from tape if desired. Each data set will be 
independently named and processed. 

Subsetting SIR-C Data

1. In the SIR-C Tape Parameters dialog, click on a data set.

2. Click the Spatial Subset button.

3. Use standard ENVI spatial subsetting to subset the data. For instructions, see 
“Selecting a Spatial Subset” on page 35.

Note
Image subsetting is not available because an image has not been synthesized at this 
stage.

Multilooking SIR-C Data from Tape

Multilooking from tape can take a long time because of the start-stop tape movement 
caused by processing data between tape reads. 

Note
Only select this option if insufficient disk space is available to read the entire data 
set. Multilooking on disk is much more efficient and is the preferred processing 
option (see “Multilooking SIR-C Compressed Data” in Chapter 13). 

1. In the SIRC Tape Parameters dialog, click on a data set.

2. Click the Multi-Look button. The SIR-C Multilook Parameters dialog 
appears.
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3. Enter the multilooking parameters by selecting one of the following options:

• In the Looks text boxes, enter the desired number of looks in the range 
(samples) and azimuth (lines) directions.

Both integer and floating point number of looks are supported.

• In the Pixels text boxes, enter the output number of pixels.

• In the Pixel Size text boxes, enter the output pixel size in meters. 

Note
When one of the parameters is entered, the others are automatically 
calculated to match. For example, if you enter the Pixel Size as 30 m, the 
corresponding number of pixels and the looks are calculated and change in 
the corresponding text boxes. Both integer and floating point number of 
looks are supported.

4. Click OK to return to the SIR-C Tape Parameters dialog.

5. Repeat the multi-look process for each data set listed in the dialog.

Entering Output Filenames

1. In the SIR-C Tape Parameters dialog, click on a data set name in Selected 
SIR-C Tape Files list. 

2. In the Enter Output Filename [.cdp] text box, enter an output filename.

By convention, filenames should take the form filename_c.cdp and 
filename_l.cdp.

3. Repeat steps 1 and 2 for each data set.

Figure 2-17: SIR-C Multilook Parameters Dialog
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Note
One compressed scattering matrix output file is created for each data set 
selected.

4. Click OK to begin reading the tape and processing the data.

Reading RADARSAT CEOS Tapes

Use Read RADARSAT CEOS Tape to read RADARSAT CEOS data tapes onto 
disk if you are running ENVI on UNIX and Windows platforms.

1. Select File → Tape Utilities → Read Known Tape Formats → RADARSAT 
CEOS. The RADARSAT – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape for standard format RADARSAT data.

Note
When the tape scan is completed, the RADARSAT Tape File Selection dialog 
appears. A list of the RADARSAT data files on the tape appear in the Select 
Output Files list.

4. Click on the box next to the data set(s) to be read from the tape. 

Note
To designate a range of files, enter the beginning and ending numbers in the 
text boxes next to the Add Range button. Click Add Range.

5. Click OK. The RADARSAT Tape Parameters dialog appears. The 
RADARSAT data sets that were selected in the RADARSAT Tape File 
Selection dialog are listed in the Selected RADARSAT Tape Files list. 
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RADARSAT Tape Options

Use the RADARSAT Tape Parameters dialog to select spatial subsetting from tape 
and to assign output file names. Each data set will be independently named and 
processed.

Subsetting RADARSAT Data 

1. In the RADARSAT Tape Parameters dialog, click on a data set.

2. Click the Spatial Subset button.

3. Use standard ENVI spatial subsetting to subset the data. For instructions, see 
“Selecting a Spatial Subset” on page 35.

4. Click OK to return to the RADARSAT Tape Parameters dialog. 

5. Repeat steps 1 through 3 each data set listed in the dialog.

Entering RADARSAT Output Filenames

1. In the RADARSAT Tape Parameters dialog, click on a data set in the Selected 
RADARSAT Tape Files list.

2. In the Enter Output Filename text box, enter a filename.

3. Repeat steps 1 and 2 for each data set listed in the dialog.

Note
One image output file is created for each data set selected.

4. Click OK to begin reading the tape and processing the data.

The processed images appear in the Available Bands List and can be displayed and 
processed using standard ENVI procedures.

Reading Generic CEOS Tapes

Use Read Generic CEOS Tape to read a variety of SAR data tapes in CEOS format. 
It is a flexible CEOS-format tape reader for UNIX and Windows platforms. Use this 
routine to read ERS-1, JERS-1, and X-SAR (MLD) data. CEOS information is used 
directly to minimize user interaction and simplify creation of files for viewing and 
analysis in ENVI. 
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Note
The generic CEOS reader does not dump data files that are complex (e.g., SLC, 
MLC, etc.). Instead, use the specific SIR-C or RADARSAT tape tool or dump the 
tape using ENVI’s Scanning Tapes and Customizing Dumps utility. Once the 
complex files are on disk, they can be opened using the Open External File menu 
or synthesized into images using ENVI’s radar tools. For more information, see 
“Scanning Tapes and Customizing Dumps” on page 163 in this chapter, and 
Chapter 13, “Radar Tools”.

Tip
To conserve disk space, subset the data directly from tape.

1. Select File → Tape Utilities → Read Known Tape Formats → Read 
Generic CEOS. The CEOS Format – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape for standard format CEOS data.

Note
When the tape scan is completed, the CEOS Tape File Selection dialog 
appears. The CEOS-format data files on the tape appear in the Select Output 
Files list.

4. Click on the box next to one or more of the desired data sets to be read from 
the tape.

Note
To designate a range files, enter the beginning and ending numbers in the text 
boxes next to the Add Range button. Click Add Range.

5. Click OK. 
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The CEOS Tape Parameters dialog appears.The CEOS data sets that were selected in 
the CEOS Tape File Selection dialog appear in the Selected CEOS Tape Files list.

CEOS Tape Options

Use the CEOS Tape Parameters dialog to select spatial subsetting from tape and to 
assign output file names. Each data set will be independently named and processed. 

Subsetting CEOS Data

1. In the CEOS Tape Parameters dialog, click on a data set name.

2. Click the Spatial Subset button.

3. Use standard ENVI spatial subsetting to subset the data. For instructions, see 
“Selecting a Spatial Subset” on page 35.

4. Repeat steps 1 through 3 for each data set listed in the dialog.

5. Click OK to return to the CEOS Tape Parameters dialog.

Entering CEOS Output Filenames

1. In the CEOS Tape Parameters dialog, click on a data set name in the Selected 
CEOS Tape Files list.

2. In the text box labeled Enter Output Filename, enter a filename.

3. Repeat steps 1 and 2 for each data set listed in the dialog.

Note
One image output file is created for each data set selected.

4. Click OK to begin reading the tape and processing the data. 

The processed images appear in the Available Bands List and can be displayed and 
processed using standard ENVI procedures.
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Reading and Writing ENVI Tapes

Use Read/Write ENVI Tape to read and write ENVI-formatted tapes. The ENVI 
tape output utility writes image data to tape while preserving the ENVI file structure 
and header configuration. A corresponding utility reads these tapes.

ENVI Tape Format Information

ENVI tapes are written in a standard format to simplify reading of image data while 
maintaining key image characteristics found in the image headers. As a result, the 
ENVI format uses several header records and files. See the following table for 
descriptions.

File ID Rec ID
Data 
Type Information

1 1 ASCII 1024 bytes, ID String “ENVI TAPE FORMAT”, 
and string “NUM_ENVI_FILES= N” (where N 
is the total number of ENVI image files on the 
tape.

2 ASCII 1024 bytes, Key word strings containing 
required information for the first ENVI image 
file on the tape. Keywords are NL (number of 
lines), NS (number of samples), NB (number of 
bands), INTERLEAVE (BSQ, BIL, or BIP), 
DATA TYPE (byte, signed and unsigned integer, 
long integer, 64-bit integer, unsigned 64-bit 
integer, floating point, double precision complex 
and double complex), ENVI_TYPE (0 is ENVI 
image file), NAME (image name), and 
DESCRIPT (image description string).

3 ASCII Same as above for 2nd ENVI file

4 thru 
N+1

ASCII Same as above for 3rd through Nth ENVI file

2 ASCII Header for Image 1 (variable length)

3 BINARY Image 1 (Record length is number of samples)

Table 2-3: ENVI Format Tape Structure
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Reading ENVI Tapes

Use Read ENVI Tape to read ENVI format tapes that were written using the Write 
ENVI Tape function.

1. Select File → Tape Utilities → Read/Write ENVI Tapes → Read ENVI 
Tape. The ENVI Format – Load Tape dialog appears.

2. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

3. Click OK to have ENVI scan the tape header. 

Note
If the data are identified as ENVI format data, the ENVI Tape Files dialog 
appears, listing the names of the ENVI files on the tape.

4. Select files to be read by selecting the toggle buttons next to the desired file 
names.

Note
To select ranges of files, enter the beginning and ending files in the text boxes 
next to the Add Range button. Click Add Range.

4 ASCII Header for Image 2 (variable length)

5 BINARY Image 2 (Record length is number of samples)

6 thru 
N+1

Pairs of ASCII header files and binary image 
files up to N+1 as specified in the first header 
record

File ID Rec ID Data 
Type Information

Table 2-3: ENVI Format Tape Structure (Continued)
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5. Click OK. The ENVI Tape to Output File dialog appears for each selected file 
to be read.

6. In the ENVI Tape to Output File dialog, select either File or Memory output.

7. Click OK to start the tape processing. 

A status window informs you of tape processing progress for each image file. The 
bands in each file are added to the Available Bands List as the files are read.

Writing ENVI Files to Tape

Use Write ENVI File to Tape to write ENVI format files to tape while preserving 
their file structure and header information. The function requires the ENVI files are 
currently shown in the Available Bands List. If the files are not open, open them (see 
“Opening Image Files” on page 61).

1. Select File → Tape Utilities → Read/Write ENVI Tapes → Write ENVI 
File to Tape. The Output ENVI Files to Tape dialog appears.

2. Click Import ENVI File.

3. When the standard input file selection dialog appears, select a file and perform 
any spatial and/or spectral subsetting.

4. Click OK. The selected files appear in the Select ENVI Files to Output to 
Tape list in the Output ENVI Files to Tape window.

Note
To select additional files, repeat steps 2 and 3.

5. To designate a different tape device, enter the device name in the Tape Device 
text box.

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

6. Click Accept. The ENVI Format - Load Tape window appears.

7. Select from the following options:

• To designate a different tape device, enter or choose a device.

• To change the tape record size, enter the values into the MaxRecsize text 
boxes. 
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Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

8. Click OK to have ENVI sequentially output the selected files to tape in 
standard ENVI tape format. 

A status window lists the progress as each file is written. The tape is rewound at the 
end of the processing.

Scanning Tapes and Customizing Dumps

Use Scan Tape and Customize Dump to scan a tape, to select files from tape, and to 
build a tape script that describes the tape contents. Use the script as is, edit it to 
combine specific tape records or files, and/or save the script for future use on 
identical tapes.

1. Select File → Tape Utilities → Scan Tape and Customize Dump. When the 
ENVI Tape Dump Utility dialog appears, the default tape device is 
automatically listed in the Tape Device text box at the top of the window. To 
designate a different tape device, enter the device name in the Tape Device text 
box.

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

2. In the ENVI Tape Dump Utility window, select Options → Scan Tape. The 
ENVI Tape Information Scan window appears as the tape is scanned and the 
current file number and the total number of bytes scanned on the tape are 
listed. As each file is completed, the tape information is shown in the ENVI 
Tape Dump Utility dialog. 

Note
To interrupt the tape scan at any time, click Interrupt Tape Scan at the 
bottom of the window (the interrupt may take a few seconds to register with 
the system). If the tape scan is interrupted, the information up to that point is 
shown and the tape is automatically rewound. In either case, the file number, 
the number of records, and the number of bytes per record are listed.
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3. In the ENVI Tape Dump Utility dialog, select from the following options to 
select records and bytes and to edit their values:

• To edit values, click on an item in the list. Change the values as they 
appear in the corresponding text boxes and press the Enter key.

This allows combining files/records and selecting subsets of bytes to be 
read.

• To add new items to the dump list, enter new values in the text boxes and 
click the Add Entry button.

• To delete an entry from the list, click on the entry in the list and click 
Delete Entry.

• To clear the list, select Clear Entries.

• To recall data from the previous scan, select Options → Restore Prev 
Scan.

• To save the Tape Script to an ASCII text file, select File → Save Format 
and enter the desired filename. The default file extension is .fmt. (See 
“Tape Script Format (.fmt)” in Appendix B).

• To recall previously saved Tape Scripts, select File → Restore Format 
and select the desired file. 

4. In the ENVI Tape Dump Utility dialog, select Options → Dump Tape to read 
the tape. The Tape Dump Output Parameters dialog appears.

5. Use the arrow toggle button to select either Dump tape records to a single 
output file or Dump each item to a separate output file.

6. Enter an output filename and click OK.

Note
If separate output files is selected, the output filename entered will be used as 
a base filename and the file number that is dumped is appended to the base 
filename. For example, if a filename of test is entered and files 2 and 3 are 
dumped, they will be output as test_2 and test_3.

As the tape is dumped, the status is displayed in the ENVI Dump Tape to Output File 
window. 

Note
To interrupt the tape dump, click Interrupt Tape Dump.
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Dumping Tape Data

To perform binary dumps of tapes to disk:

1. Select File → Tape Utilities → Dump Tape.

2. When the Dump Tape dialog appears, the default tape device is automatically 
listed in the Tape Device text box at the top of the window. The starting and 
ending file numbers to dump from the tape are listed in the text boxes next to 
the Dump Files text label.

3. To change the active tape device, enter the device name in the Tape Device text 
box. 

Note
If you designate a different tape device, allow your operating system enough 
time to register the new device before proceeding.

4. Select output to a single output file or to separate files by clicking the 
appropriate toggle button.

5. Enter an output filename and click OK.

Note
If you select output to separate files, the output filename you enter is used as 
a base filename and the file number that is dumped is appended to the base 
filename. For example, if a filename of test is entered and files 2 and 3 are 
dumped, they would be output as test_2 and test_3.

As the tape is dumped, the status is displayed in the ENVI Dump Tape to Output File 
window. 

Note
To interrupt the tape dump, click Interrupt Tape Dump.
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The Scan Directory List 

Use Scan Directory List to scan directories to locate and open files. ENVI provides 
recursive directory scanning, and allows you to select multiple files for opening. The 
geo-browser option allows map browsing of the locations of georeferenced images 
and opening of files based on their geographic location (see “Opening Files with the 
Geo-Browser” on page 168).

Entering Directories into the Scan Directory List

1. Select File → Scan Directory List. 

2. When the Directory Scan Dialog appears, enter a directory name or use the 
Choose button to select a directory. 

• To add the selected directory to the Selected Directories List, click Add.

• To add the directory and all its sub-directories to the Selected Directories 
List, click Add Recursively. (A + (plus sign) appears before the name of 
all directories that will be scanned recursively.) 

• To remove a directory from the Selected Directories List, highlight a 
directory name in the list and click Delete. 

• To clear the directory list, click Clear.

Figure 2-18: Directory Scan Dialog
The Scan Directory List ENVI User’s Guide



Chapter 2: File Management 167
3. After ENVI lists all the directories to be scanned, click OK. The Scanned 
ENVI Files dialog appears, containing a list of all the ENVI files found with 
the listed directories. You may open multiple files using the Scanned ENVI 
Files dialog.

Note
If a header does not match its ENVI file, ENVI displays a warning message. The 
Header Info: dialog appears so that you may enter the correct information. To 
ignore the file with the warning, click Cancel.

Managing Files in the Scanned ENVI Files List

In the Scanned ENVI Files dialog, use the File and Options menus to manage the 
Scanned ENVI Files List.

Opening Files

To open the file and place the image bands in the Available Bands List:

1. Click on a file name.

2. Select File → Open File.

Figure 2-19: Scanned ENVI Files List
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Removing Files

To remove a single file from the list:

1. Click on a file name.

2. Select File → Remove File.

To remove all files from the list:

1. Click on a file name.

2. Select File → Remove All Files.

Adding New Directories

1. To add a new directory and allow yourself to select files from within that 
directory, select Options → Scan New Directory List.

2. The Directory Scan dialog appears.

Opening Files with the Geo-Browser

Use Geo Browser to scan files and open them based on their geographic location. 
ENVI’s Geo-Browser allows map browsing of the locations of georeferenced images.

1. From within the Scanned ENVI Files dialog, select Options → Geo-Browser. 
ENVI plots a world map with continent and country outlines. Within the 
United States, state outlines also appear. The locations of georeferenced 
images (the location of the reference pixel designated in the ENVI header) are 
plotted on the world map as flags. For multiple files with the same location, 
ENVI plots a different colored flag, with a number next to it showing the 
number of files at that location. 

Note
The mouse cursor’s latitude and longitude appear in the upper left corner of 
the map. 

2. Select from the following options:

• To change the size of the window, grab and drag one of the window 
corners. 

• To center the map on a point, click the left mouse button.

• To zoom in on the map area, hold and drag the middle mouse button. 
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• To zoom back out, click the middle mouse button. 

• To identify the file corresponding to a flag, click the right mouse button 
near a flag.

3. ENVI highlights the corresponding file in the Located Files List.

Note
For sites with multiple files, click the right mouse button multiple times to 
highlight each corresponding file. 

4. After you have selected a file by highlighting it, select File → Open File to 
open it.

Figure 2-20: ENVI’s Geo-Browser Zoomed on the United States
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Working With Files and Scripts

Changing Output Directories

To change the output default directory:

1. Select File → Change Output Directory.

2. When the Change Output Directory dialog appears, enter the full path of the 
directory to which you want ENVI to send its output.

3. Click OK to change the current output directory to the new path.

Saving Sessions to Scripts

Use Save Session to Script to save currently open image files, image displays, and 
their bands to an ENVI startup script. To execute this startup file see “Executing 
Startup Scripts” on page 170. 

1. Select File → Save Session to Script.

2. When the Output ENVI Script Filename dialog appears, enter the startup 
filename (typically with the extension .ini).

Executing Startup Scripts

Use Execute Startup Script to open image files, load bands into displays, open 
vector files, and open ROI files when starting ENVI. This script is automatically 
executed when ENVI is started if a filename is set in the envi.cfg file. It can also be 
executed at any time using the following procedure. A description of the ENVI 
startup script commands is given in “ENVI Startup Script” in Appendix A.

1. Select File → Execute Startup Script.

2. Select the startup script filename and click OK.
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Restoring Display Groups

Use Restore Display Group to restore display groups that have been saved to a text 
file. For detailed instructions, see “Restoring Saved Display Groups” in Chapter 4. 

Closing all Files

1. When you have finished working with your files in ENVI, close them by 
selecting File → Close All Files. 

Note
ENVI closes all disk files and removes all items from memory. Be sure to 
save all your important memory items to disk before using this procedure.

2. A warning message appears asking for confirmation. Click Yes.
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Using the ENVI Queue Manager

Use the ENVI Queue Manager to execute functions that have been queued (see 
“Placing Un-executed Functions in Queue” on page 45).

Note
Results from one queued function (procedure) cannot be used as input into another.

1. Ensure that all of the files needed to run the queued functions (procedures) are 
opened and are listed in the Available Bands List.

2. From the ENVI main menu, select File → ENVI Queue Manager. The ENVI 
Queue Manager dialog displays a list of all queued functions (procedures).

3. In the Queued Procedures List, select by highlighting one or more 
procedures.

• To view information about a procedure in the Procedure Information 
field, click on the procedure name.

• To select all of the procedures, click Select All.

• To deselect all of the procedures, click Clear All.

• To delete a procedure, highlight it and click the Remove Selected button.

4. Click the Execute Selected button.

The executed function names are removed from the list. The resulting filenames 
appear in the Available Bands List.

Figure 2-21:  ENVI Queue Manager
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Logging Processing Information

Use the ENVI Log Manager to save an ASCII log of all file-to-file processing. The 
log file contains all the function parameters and file names used and can be 
selectively turned on and off. See “Using ENVI Recording to Write Batch Code” in 
Chapter 3 of the ENVI Programmer’s Guide manual for information on using the log 
script for batch processing.

1. Select File → ENVI Log Manager. The ENVI Log Manager dialog appears.

2. Click the On toggle button to start the logging. To turn off the logging, select 
the Off button.

3. Enter the output log filename or use the Choose button to select a filename.

Note
If the same name as a previous file name is used, the log will be appended to 
the bottom of the file.

4. Click OK to start the logging.
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Setting ENVI Preferences

Use Preferences to view information about the current configuration of ENVI or to 
change the current configuration. The Edit System Preferences dialog lists all of the 
values contained in the envi.cfg file. Most entries are self-explanatory. For a 
complete description of each parameter, see “The ENVI Configuration File” in 
Appendix A.

1. Select File → Preferences. The System Preferences dialog appears with the 
parameters to be set under various category tabs. 

2. Click on the tab of the preference category that you want to change. A different 
dialog appears depending on the which preference category you select.

Figure 2-22: Edit Configuration Values Dialog
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• Use the User Defined Files tab to set user graphics colors file, color table 
file, menu files, map projection file, previous files filename, tape device 
name, the startup script filename, useradd text file, math expression file, 
user-defined move routine, and user-defined motion routine.

• Use the Default Directories tab to set the data, temporary, output, 
save_add, spectral library, and alternative header default directories. 

• Use the Display Defaults tab to set the display window sizes, turn on/off 
image and zoom window scroll bars, set the zoom factor increment, zoom 
window interpolation, select which combination of windows to use, 
scroll/zoom graphics color, display default stretch, display retain value, set 
the scroll/zoom window position, and the 8-bit color division preferences. 
You can also change the system graphics colors and system color tables 
from this dialog. For more information, see “Editing System Color Tables” 
on page 177.

• Use the Plot Defaults tab to set the background and foreground colors, 
fonts, character size, axis thickness, the number of minor tick marks and 
length, window size, and margin sizes used in ENVI plot windows.

• Use the Grid Line Defaults tab to set the colors, fonts, character size, line 
thickness, and labels used in grid line plotting.

• Use the Previous Files List tab to edit the previous files list. Mark files as 
sticky by clicking on the filename and clicking the “Stick” On button. 
Sticky files remain at the top of the previous files list and do not fall off as 
other files are opened. The curly bracketed symbol {S} appears to the left 
of the filename when a file is set as a sticky file. To remove the sticky file 
designation, highlight the sticky file (the file with the {S} marker) and 
click the “Stick” Off button. You can delete a file from the previous files 
list by highlighting the filename and selecting the Delete button. Use the 
Reset button to reset the previous files list and remove all editing entries.

• Use the Miscellaneous tab to set the configuration name, the main menu 
orientation, maximum number of multilist items, maximum histogram 
bins, number of pull-down menu items, maximum vertices in memory, 
post script output parameters, turn on/off IDL command line blocking, set 
whether to exit IDL upon exit of ENVI, set whether to show a status 
window for input, set the auto apply option for interactive stretching, set 
whether to automatically append default extensions to filenames, set 
whether to automatically load default bands, set whether to open 
applicable files to memory, and set memory usage parameters. 
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See “The ENVI Configuration File” in Appendix A for a complete description 
of each parameter. 

3. In the preference dialog, edit the parameters to suit your needs.

4. Click OK to save the changes for the current ENVI session. 

5. At this point ENVI asks if you want to save the preferences to a file. To save 
the new preferences, click Yes. 

6. To overwrite the current envi.cfg file, click OK without entering a new 
filename; otherwise, enter the new configuration filename and click OK. 

Editing System Graphic Colors

Use the Edit System Graphics Colors button in the Preferences dialog Display 
Defaults tab to edit the current colors that ENVI uses for graphics. The colors are 
stored in the menu directory in the ASCII text file colors.txt. ENVI uses this file 
unless a default graphic colors file is entered in the envi.cfg file.

Tip
To add new colors to the graphic colors file, use a text editor to append the colors to 
the end of the file (see “ENVI Graphic Colors File” in Appendix B). 

1. Select File → Preferences to bring up the System Preferences dialog. In the 
System Preferences dialog, click on the Display Defaults tab and click the 
Edit System Graphics Colors button. The Edit Graphic Colors dialog 
appears.

2. In the Graphic Colors: list box, click on the color to be edited. 

Warning
It is not advised to change any of the first 5 colors (black, white, red, green, 
blue) because they are used in the ENVI system. Changing graphic colors 
may affect previously saved graphic overlays.

• To change the color name, enter the name in the Color Name text box. 

• To change the color, select a color system from the button menu and use 
the slider bars to adjust the variables. 

• To reset all colors to their original values, click Reset.

• To exit the function without applying the changes, click Cancel. 

3. Click OK to apply the changes. 
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4. When the prompt appears, select one of the following options. 

• To permanently apply the color changes, select Yes.

• To change the colors for the current ENVI session only, select No. 

Editing System Color Tables

Use the Edit System Color Tables button on the Preferences dialog Display 
Defaults tab to define new color tables, save them to ENVI’s current list of color 
tables, and delete color tables from the current list. You can work in RGB (red-green-
blue), HLS (hue-lightness-saturation), or HSV (hue-saturation-value) color spaces 
and define tables using user-defined interpolation paths. In addition, you can choose 
specific colors from a color palette for defined regions of the color table or make a 
ramp to fill the color table. 

Tip
Editing Color Tables works best when your monitor display is set to 16-bit or higher 
color mode (it will function in 8-bit color mode, but the colors will not appear as 
exact).

1. To ensure that all colors are available, close all display and plot windows.

2. Select File → Preferences to bring up the System Preferences dialog. 

3. In the System Preferences dialog, click on the Display Defaults tab and click 
the Edit System Color Tables button. The ENVI Color Table Editor dialog 
appears.

The current color table is displayed as a narrow gradiated color bar on the left 
side of the dialog. A white positioning arrow appears at the far left and far right 
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ends of the color bar next to the color palette. The current system colors are 
displayed in the Color Palette Selection widget. 

4. Select a color system (RGB, HLS, HSV) from the button labeled System. The 
color palette and color bar reflect the system change.

5. Select from the following options when defining the color table.

• To keep one color or element constant (i.e., red in RGB or lightness in 
HLS), click on the toggle button next to the slider bar of that value. The 
two remaining colors represent the horizontal and vertical axes of the color 
palette.

• To move points on the interpolation line, click on a point on the line with 
the left mouse button and drag to the new position.

• To add points to the interpolation path through the colors, click on a 
position in the color palette with the middle mouse button.

• To remove points from the interpolation line, click the right mouse button 
on the square interpolation points.

Figure 2-23: ENVI Color Table Editor Dialog
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• To designate whether the color table automatically reflects the changes 
made as you move the interpolation line, select On or Off using the 
Update Color Table arrow toggle button.

• To see the values of a specific color, click on the color with the left mouse 
button. The circle cursor jumps to that location on the palette and the slider 
bars show the new values.

• To identify the color represented by a combination of values, move the 
slider bars of the values or use the arrow increment buttons to change 
them. The circle cursor moves to the corresponding location on the color 
palette.

Defining Colors and Making Ramps

To define colors or make a color ramp for specific ranges of the output color table, do 
the following:

1. Click on the left positioning arrow (the white arrow at the far left corner of the 
gradiated color bar) of the color table and drag it to the new lower location, or 
enter the lower value in the Pos1 text box.

2. Select the color to be the lower value by clicking with the left mouse button on 
the color in the color palette.

3. Click Replace. 

4. Click on the right positioning arrow on the color table and drag it to the new 
upper location, or enter the upper value in the Pos2 text box.

5. Select the color to be the upper value by clicking with the left mouse button on 
the color in the color palette. You may select the same color as the upper and 
lower value.

6. Click the Interp button to fill in the colors between the new values. 

• Click Reset to reset the color table to a grayscale image.

• To clear the positioning arrows, click Clear.

Adding Color Tables to ENVI

To add the new color table to the current list of ENVI color tables:

1. In the ENVI Color Table Editor, click Add Current as New Color Table. 

2. When the Add Color Table dialog appears, enter a name into the text box and 
click OK.
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Tip
If you do not have permission to write to the colors1.tbl file, you will be 
prompted to enter a new color table filename. 

Setting a New Color Table File

To use the new color table file in ENVI:

1. Select File → Preferences to bring up the System Preferences dialog. 

2. In the System Preferences dialog, click the User Defined Files tab.

3. In the Color Table File text box, enter the new color table filename.

4. Click OK.

Deleting Existing Color Tables

To delete existing color tables from the color table list:

1. In the ENVI Color Table Editor, click Delete Existing Color Tables. The 
Delete Existing Color Tables dialog appears with a list of all the system color 
tables.

2. Click on the color table names that you want to remove. 

Note
To select multiple color tables from the list, see “Selecting Multiple Items in 
Lists” on page 43).

3. Click OK.

Note
If you do not have permission to write to the colors1.tbl file, you will be 
prompted to enter a new color table filename. 

Importing Color Tables from ASCII Files

1. In the ENVI Color Table Editor, click Import Color Table from ASCII.

2. Select an input filename.

Note
The input file must be an ASCII file containing 256 lines, each containing 3 
columns of red, green, and blue values.
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The Window Menu

Use the Window menu to control ENVI display and plot windows, including starting 
new windows, maximizing window sizes, linking display windows, and closing 
windows. Use it to access the Available Bands List and the Available Vectors List to 
display bands and vector layers. Also use the Window menu to view display 
information, to view cursor locations and pixel values for displayed images, to collect 
points from display windows, and to open the Window Finder.

Figure 3-1: Window Menu
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Using the Window Finder

Use the Window Finder to manage active ENVI windows and dialogs and to bring 
windows that have been iconized or buried under other windows to the foreground. 
The list contains the names of major active windows in the order that they were 
opened. The list includes display window groups (Main, Scroll, Zoom), plot 
windows, scatter plots, ROI definition windows, etc.

1. Select Window → Window Finder. The ENVI Window Finder appears with 
the names of opened windows displayed in a list.

2. To call a window to the foreground of your desktop, click on the name of a 
window.

• Clicking on the name of a specific display number brings the Main Image 
window and its associated Scroll and Zoom windows to the front. 

• Clicking on any other window name brings that window to the front.

• If you click on the name of an overlay dialog (Annotation, ROI, Density 
Slice, etc.) that was hidden using Overlay → Hide Layer, double-clicking 
the dialog name hides the dialog again. For details about hiding dialogs, 
(see “Showing and Hiding Overlay Dialogs and Layers” in Chapter 4).

Note
The ENVI Window Finder always moves to the front of the display if 
bringing an ENVI window forward causes it to be covered. If the ENVI 
Window Finder is lost behind another window, select Window → Window 
Finder to bring it to the front again.

3. Close the ENVI Window Finder by selecting File → Cancel.

Figure 3-2: Window Finder
ENVI User’s Guide Using the Window Finder



184 Chapter 3: Display Management
Starting New Displays

To start a new, independent image display window:

• select Window → Start New Display Window from the Display menu or 
from the ENVI main menu.

Each window started is numbered sequentially starting with Display #1. Display 
windows may also be started using the New Display option in the Available Bands 
List (see “Selecting the Active Display” on page 190).

Starting New Vector Windows

To start a new and independent Vector window:

• select Window → Start New Vector Window.

Each window is numbered sequentially starting with Vector Window #1. New vector 
windows may also be started using the Options menu in the Available Vectors List 
(see “Opening New Vector Windows” on page 214).

Starting New Plot Windows

To start a new and independent plot window:

• select Window → Start New Plot Window.

New plots may also be started using the Options menu in any plot window (see 
“Creating New Plot Windows” in Chapter 4).
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The Available Files List

Use the Available Files List to get information about the files that are currently open 
in ENVI and stored in memory. Also, use the Available Files List to open new files, 
close files, save memory items to disk, and edit ENVI headers. 

Tip
Use the Available Files List on a regular basis to remove memory-only calculations 
from system memory.

To display a list of all the currently open image files:

• Select Window → Available Files List.

Obtaining File Information

Use this procedure to view important information about each file. In the Available 
Files List, click on a filename.

Figure 3-3: Available Files List
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ENVI displays information and parameters from the ENVI header file, including the 
full path and image name; the number of lines, samples, and bands (Dims); the file 
size; the interleave (BSQ, BIL, BIP); the data type (byte, integer, etc.); the file type; 
the byte order of the data (Host or Network); and whether or not the data is 
georeferenced and if any wavelengths are associated with the bands.

Options in the Available Files List

Use the Options menu to edit file headers (see “Editing ENVI Headers” on page 104 
for details).

1. From within the Available Files List, click on the filename.

2. Select Options → Edit Header.

3. When the Header Info: dialog appears, change parameters and click OK to 
save the changes.

Managing Files from the Available Files List

Use the File menu options to open new files, close files, add files to memory, delete 
memory items, delete files from disk, and save memory items to disk.

Figure 3-4: Available Files List File Menu Selections
The Available Files List ENVI User’s Guide



Chapter 3: Display Management 187
Opening New Files

1. From within the Available Files List, select File → Open New File.

2. When the file selection dialog appears, select the file and click OK. 

• To select a group of files that are listed consecutively, click on the first file 
in the group, press and hold the Shift key, and click the last file in the 
group. Or, click and drag with the left mouse button to select the desired 
group.

• To select multiple files that are not listed consecutively, press and hold the 
Ctrl key on your keyboard and click on each desired file.

ENVI opens the file and adds it to the Available Files List. The file information 
appears in the right side of the dialog.

Closing all Files

To close all files (including memory items, which are automatically deleted):

• Select File → Close All Files from within the Available Files List.

Deleting Memory Items

To remove files that exist only in memory without closing open disk files:

• Select File → Delete All Memory Items from within the Available Files List.

Warning
Memory items removed in this fashion are not recoverable.

Storing Files in Memory

Image files can be stored as an in-memory item for faster processing of large images. 

Note
This option is dependent on the amount of RAM available on your system.

1. From the main ENVI menu bar, select Window → Available Files List.

2. In the Available Files List, click on a filename to select it. You can Shift-click 
to select multiple filenames inclusively, or Ctrl-click to select discontiguous 
filenames in the Available Files List.

3. Next, select File → Add Selected Files to Memory. 
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All selected image files, including their parameters, will be added as in-memory 
items to the Available Bands List. 

Saving Memory Files to Disk

1. In the Available Files List, click on the item to be saved.

2. In the Available Files List, select File → Save Selected File to Disk.

3. When the Memory to File Storage dialog box appears, enter an output filename 
and click OK. 

Deleting Files from Disk

1. In the Available Files List, click on the item to be deleted.

2. Select File → Delete Selected File from Disk. Because this is a permanent 
action, a warning message appears to verify that you want to permanently 
delete the file. 

3. Click Yes to delete the file.

Closing Selected Files

1. In the Available Files List, click on the item to be closed.

2. Select File → Close Selected File. 

Note
If a warning box appears, it means that one or more bands from the file are 
currently displayed in one of the active display windows. Select Yes to close 
the file and to remove the associated bands from the display.

If the file is a memory item, it is removed from memory and any associated 
displays are closed.

Closing the Available Files List

To close the Available Files List:

• Select File → Cancel.
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The Available Bands List

Use Available Bands List to open the Available Bands List. Use the Available Bands 
List to access the files and the individual bands of each image file that has been 
opened during the current session. From the Available Bands List, display grayscale 
and color images, start new display windows, open new files, close files, view meta 
file components, and view displayed band information.

When you open a file for the first time during a session, ENVI automatically places 
the filename, with all of its bands listed beneath it, into the Available Bands List 
(Figure 3-5). If multiple files are opened, all of the files with all of the bands appear 
in the Available Bands List sequentially, with the most recently opened file at the top 
of the list. The bands of the files can be folded back into the filename to shorten the 
list.
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To make the Available Bands List active, select Window → Available Bands List.

Selecting the Active Display

ENVI allows you to have multiple display windows open, with any combination of 
grayscale and color images displayed. When you load images, you can select an 
existing display or a new display to use for displaying your new images. The selected 
display is called the active display.

Figure 3-5: Available Bands List: Grayscale Band; RGB Bands
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When no display window is open, the button at the bottom of the Available Bands 
List reads No Display. The first image loaded automatically appears in a new 
window. 

1. In the Available Bands List, click on the Display #X button menu (where X is 
the number corresponding to the number in a display window’s title bar) and 
select the display from the list. 

2. To start a new display, select New Display from the button menu. 

3. Click Load Band or Load RGB to load the selected bands into the active 
display.

Displaying Color Composite Images

Note
If default bands to load have been set in the image header (.hdr) file, you do not 
need to use the Available Bands List—the color image will be automatically loaded 
into a display group as soon as the file is opened. For details, see “Setting Default 
Bands to Load” on page 110.

1. In the Available Bands List, select the RGB Color toggle button.

2. Click in sequence on the red, green, and blue bands to be displayed (or on 
individual R, G, or B bands using the toggle buttons). If necessary, change the 
active display (see “Selecting the Active Display” on page 190).

3. Once the band names have been loaded into the text boxes labeled R, G, and B, 
click the Load RGB button to load the bands into the current active image 
display (see “Selecting the Active Display” on page 190).

Tip
You can also load the image by double-clicking the blue bandname in the list 
of available bands, or by using the shortcut menu (see “Available Bands List 
Shortcut Menu” on page 192).

A status window displays the progress of the operation.

Note
To cancel loading the bands into a display, click the Cancel button in the 
status window. The display window will be blank.

After the bands are successfully loaded, a Main Image window, Zoom window, and 
Scroll window (for large images) appears. ENVI displays all images with a default 
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2% linear stretch. You may change the default stretch in the envi.cfg file (see “The 
ENVI Configuration File” in Appendix A), or by setting a default stretch in the image 
header file. 

Available Bands List Shortcut Menu

The Available Bands List has a shortcut menu for easy access to common Available 
Bands List functions. For descriptions of the individual functions, see the following 
sections.

1. To use the shortcut menu, right-click on any filename, bandname, or map info 
label. The shortcut menu items differ depending on which item in the Available 
Bands List is used to initiate the shortcut menu.

2. From the shortcut menu that appears, select a menu command.

Figure 3-6: Available Bands List: File and Band Shortcut Menus
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Editing a Header File Using the Shortcut Menu

To view or edit the header associated with a file, right-click on the filename in the 
Available Bands List and select Edit Header from the shortcut menu.

Editing Map Information

If a file has map information associated with it, you can view or edit this information.

To view or edit the map information associated with a file, right-click on the Map 
Info label in the Available Bands List and select Edit Map Information from the 
shortcut menu.

Displaying True Color or Color Infrared Images

If a file has wavelengths for each band stored in the header and that file contains 
bands in the needed wavelength ranges, you can automatically display a true color 
image or a color infrared image directly from the Available Bands List without 
having to designate the individual bands for red, green, and blue. 

Note
If your data does not have bands in the needed wavelengths, the bands nearest to the 
wavelengths will be used. This may produce a grayscale image if red, green, and 
blue are set to the same band. 

The true color image is made by displaying the band in the red wavelength region 
(0.6-0.7 µm) in red, the band in the green region (0.5-0.6 µm) in green, and the band 
in the blue region (0.4-0.5 µm) in blue. The color infrared (CIR) image is made by 
displaying the band in the near infrared wavelength region (0.76-0.9 µm) in red, the 
band in the red region in green, and the band in the green region in blue.

To automatically display a true color or color infrared image in the current display 
window, right-click on a filename in the Available Bands List.

• Select Load True Color to <current> or Load CIR to <current> from the 
shortcut menu. 

To automatically display a true color or color infrared image in a new display 
window, right-click on a filename in the Available Bands List.

• Select Load True Color to <new> or Load CIR to <new> from the shortcut 
menu. 
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Displaying Grayscale Images

Note
If default bands to load have been set in the image header (.hdr) file, you do not 
need to use the Available Bands List to initiate a display — the grayscale image will 
be automatically loaded into a display group as soon as the file is opened. For 
details, see “Setting Default Bands to Load” on page 110.

1. In the Available Bands List, select the Grayscale toggle button.

2. Click on the input band name. The band name appears in a small text box 
labeled Selected Band. 

Note
If necessary, change the active display (see “Selecting the Active Display” on 
page 190).

3. Click Load Band to load the band into a new or current display.

Tip
You can also load the grayscale image by double-clicking the bandname.

A status window displays the progress of the operation.

Note
To cancel loading the band into a display, click the Cancel button in the 
status window. The display window will be blank.

After the band is successfully loaded, a Main Image window, Zoom window, and/or 
Scroll window (for large images) appears depending on your default display window 
style. ENVI displays all images with a default 2% linear stretch. You may change the 
default stretch in the envi.cfg file, or by setting a default stretch in the image 
header file (see “Editing ENVI Headers” on page 104). 
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Options in the Available Bands List

Use the Options menu in the Available Bands List to select a band by wavelength to 
display information about displayed bands, and to fold, all bands of each data set into 
single layers in the Available Bands List.

Locating Bands by Wavelength

For files with associated wavelength values in the file header, use the Wavelength 
Locator to locate the band that contains a desired wavelength.

1. From the Available Bands List, select Options → Wavelength Locator. 

2. When the Wavelength Locator dialog appears, enter the wavelength you want 
to locate and click Apply.

The band containing that wavelength is highlighted in the Available Bands List. 

Note
To close the Wavelength Locator dialog, click the Cancel button. 

Showing Displayed Band Information

To display the names and wavelengths of the bands being used in an image display:

1. In the Available Bands List, select the display from the Display #n button 
menu.

2. Select Options → Show Current Displayed Bands.

The band information appears in the R, G, and B, or Selected Band (for grayscale) 
text boxes. 

Folding Bands

In the Available Bands List and other band selection dialogs, there may be many 
bands listed, especially when using hyperspectral data. You can fold or hide all of the 
bands of a data set so that they appear on only one line. This keeps the lists shorter 
and easier to work with.

Note
If a band is currently displayed in either a grayscale or RGB image, an asterisk ( * ) 
appears next to the filename when it is folded.
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Folding a Single Data Set

Data sets are loaded into the Available Bands List and other band selection dialogs in 
an unfolded state by default. The names of unfolded data sets appear in this format: 

-<filename>
Band
Band

• To fold a data set, click on the filename of the data set. All of the bands of the 
data set are compressed and the data set appears in the list in this format:

+<filename>[number of bands]

• To unfold a data set and make it available for display, simply click the folded 
filename.

Folding all Data Sets

• In the Available Bands List, select Options → Fold All Files, or right-click 
and use the shortcut menu. All of the bands of all of the data sets are 
compressed and each data set appears in the list in this format: 

+<filename>[number of bands].

• To unfold a data set, click on the folded filename.
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• To unfold all data sets, right click in the list of files and select Unfold All 
Files from the shortcut menu.

Managing Image Files from the Available Bands List

Use the File menu in the Available Bands List to open new image files, list open files, 
and close files.

Opening Files

To select a new file to open, do the following: 

1. In the Available Bands List, select File → Open Image File. 

2. When the Enter Data Filename dialog opens, select your new file. 

Note
To display a list of all open files use the Available Bands List to select File → 
Available Files List (see “The Available Files List” on page 185). 

Figure 3-7: Available Bands List with Folded and Unfolded Data Files
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Closing Files

Use Close Selected File or Close All Files to remove memory files or to close disk 
files from the Available Bands List.

Closing Selected Files

To close the file associated with the bands currently displayed in the Selected Band 
text box or in the R, G, and B text boxes:

• Select File → Close Selected File from the Available Bands List menu; or

• Right-click in the displayed file list and select Close Selected File.

Tip
If you close one band from a disk file, ENVI closes the entire file and all of 
the bands in the file disappear from the Available Bands List. However, the 
file still exists on disk, and you can reopen it using File → Open Image File.

Closing All Files

To close all files in the Available Bands List and delete any items in memory:

1. Select File → Close All Files. A warning dialog appears. 

Note
Once a memory file is deleted, there is no way to recover the image. 

2. In the warning dialog, click Yes.

Hiding the Available Bands List

To remove the Available Bands List from view while keeping the files it contains 
open and the bands available:

• Select File → Cancel.

To recall the Available Bands List at any time:

• Select Window → Available Bands List from the ENVI main menu. 
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ENVI Image Display Windows

When you display an image file, it is placed in an ENVI image display group, which 
consists of a Main Image window, a Zoom window, and/or a Scroll window (Scroll 
windows for larger images only). The windows included in the default display group 
are controlled by the Display Window Style option in the preferences (see “Display 
Window Shortcut Menu” on page 210). Multiple image display groups can be on the 
screen at once, but only one display group is active (see “Selecting the Active 
Display” on page 190).

Note
Mouse functions change within each type of window. Mouse button function 
descriptions for each window type are included in the following sections.

The Main Image Window

The Main Image window displays a portion of an image at full resolution. The 
window is automatically created the first time you open an image.

To open a new display group, select from the following options:

• In a Main Image window or from the ENVI main menu, select Window → 
Start New Display.

• In the Available Bands List, click New Display (see “Selecting the Active 
Display” on page 190).
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Resizing the Main Image Window

Select one of the following options to change the size of the Main Image window:

• Dynamically resize the Main Image window up to available screen size by 
grabbing one of the corners and dragging to the desired image size.

• In the Main Image window, select File → Preferences and enter the size in the 
Display Defaults dialog (see “Resizing Windows” in Chapter 4).

• Change the default window size parameters set in the envi.cfg configuration 
file (see Appendix A, “Installing and Customizing ENVI”). 

Figure 3-8: Main Image Window for Display #1 with Zoom Window Indicator
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Displaying Image Window Scroll Bars

Use the scroll bars in the border of the Main Image window to move around the 
image. When you move the scroll bars, the graphic box in the Scroll window moves 
to show you what part of the whole image you are in. There are three ways to display 
the Image window scroll bars: 

Displaying Scroll Bars at all Times

1. Select File → Preferences.

2. In the Edit System Preferences window, select the Display Defaults tab.

The Preferences: Display Defaults dialog box appears.

3. Click the Image Window Scroll Bars arrow toggle button to select Yes.

4. Click OK. 

5. In the Edit System Preferences window, select File → Save Configuration.

Note
To exit without saving, select File → Cancel.

6. Enter an output filename and click OK.

Turning Display Scroll Bars On/Off

1. Right-click in the Main Image window and select Toggle → Display Scroll 
Bars or in the Main Image window, select File → Preferences. The Display 
Preferences dialog appears.

2. In the Image Window section of the dialog, click the Scroll Bars arrow toggle 
button to select Yes or No.

3. Click OK.
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Controlling the Zoom Window from the Main Image Window

In the Main Image window, the Zoom Window Indicator box outlines the area that is 
displayed in the associated Zoom window.

• To change the region defined by the zoom box, click-and-drag the box (the 
Zoom Window Indicator) around the Main Image window.

• Use the arrow keys on the keyboard to move the zoom window pixel-by-pixel 
in the direction of the arrow. Use Shift + arrow to move the image window five 
pixels in the direction of the arrow.

Note
Some interactive processes change the mouse functions listed in the following table. 
These processes include defining Regions-Of-Interest (ROIs), Annotation, Vector 
Overlay, and Dynamic Overlay. These functions may be turned off to restore the 
mouse buttons to their normal operation. To see which function has control of the 
mouse, see “Displaying Mouse Button Descriptions” on page 224.

The Display Menu

Use the Display menu bar in the Main Image window to select common interactive 
display functions. When a function is selected from one of the Display menus, the 
function applies only to the active display (see “The Display Menu Bar” on 
page 230).

Tip
You can access many Display menu interactive functions from the Main Image and 
Zoom window shortcut menu. For details, see “Display Window Shortcut Menu” on 
page 231.
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Mouse Button Functions in the Main Image Window

The Zoom Window

The Zoom window is a small image display window that displays a portion of the 
image at a user-defined zoom factor. The Zoom window provides you with virtually 
unlimited zoom capabilities such as zooming in or out and panning. 

Tip
You can access many Zoom window and Main Image Display menu functions from 
the Zoom window shortcut menu. For details, see “Display Window Shortcut 
Menu” on page 231.

The Display Menu

Use the Display menu bar in the Zoom window to select common interactive display 
functions. When a function is selected from one of the Display menus, the function 
applies only to the active display (see “The Display Menu Bar” on page 230).

Mouse Button Function

Left Button • Click inside the Zoom window indicator and drag it to a 
new location. The Zoom window updates when the button 
is released.

• Click to center the Zoom window indicator over the current 
pixel position. Continue to hold the button and drag to 
continuously update the Zoom window.

• Double-click in the Main Image window to display the 
Cursor Location/Value dialog.

Middle Button No function.

Right Button Click to display the shortcut menu.

Table 3-1: Functions of the Mouse Buttons in the Main Image Window
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Resizing the Zoom Window

To resize the Zoom window, select from the following options:

• Dynamically resize the Zoom window by grabbing one of the corners and 
dragging it to the desired image size. The corresponding Zoom window 
indicator box in the Main Image window automatically changes its size and 
shape to match the displayed Zoom window.

• In the Display menu, select File → Preferences and enter the size in the 
Display Preferences dialog (see “Resizing Windows” on page 236).

• Change the default Zoom window size parameters set in the envi.cfg 
configuration file (see Appendix A, “Installing and Customizing ENVI”).

Scrolling the Zoom Window

• Use the arrow keys on the keyboard to move the Zoom window by one pixel in 
the direction of the arrow. 

• Use Shift + arrow to move the Zoom window by five pixels in the direction of 
the arrow.

Displaying Zoom Window Scroll Bars

Use the scroll bars in the border of the Zoom window to move around the image. 
When you move the scroll bars, the graphic box in the Scroll window moves to show 
you what part of the whole image you are in. There are three ways to display the 
Zoom window scroll bars: 

Displaying Scroll Bars at all Times

1. Select File → Preferences.

2. In the Edit System Preferences window, select the Display Defaults tab.

The Preferences: Display Defaults dialog box appears.

3. Click the Zoom Scroll Bars arrow toggle button to select Yes.

4. Click OK. 

5. In the Edit System Preferences window, select File → Save Configuration.

Note
To exit without saving, select File → Cancel.

6. Enter an output filename and click OK.
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Turning Display Scroll Bars On/Off

1. Right-click in the Zoom window and select Toggle → Display Scroll Bars or 
in the Zoom window, select File → Preferences. The Display Preferences 
dialog appears.

2. In the Zoom Window section of the dialog, click the Scroll Bars arrow toggle 
button to select Yes or No.

3. Click OK.

Controlling the Zoom Factor of the Zoom Window

The current zoom factor is displayed as a number in parentheses in the Zoom window 
title bar. The default zoom factor is 4.

Use the different mouse buttons and the Symbol boxes in the Zoom window to 
change the zoom factor and to turn the display crosshairs on and off in both the Zoom 

Figure 3-9: ENVI Zoom window with Symbol Boxes

Zoom Out Zoom In Turn Crosshairs On/Off
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and Main Image windows. The following table describes the Zoom window’s symbol 
functions and associated mouse button descriptions.

Zoom Window 
Symbol Function

Plus Click with left mouse button to increase zoom factor by 1. 

Click with middle mouse button to double the zoom 
factor with each click (i.e., 2, 4, 8, 16...). 

Click with right button to return to the default zoom factor 
of 4.

Minus Click with left mouse button to decrease zoom factor by 1.

Click with middle mouse button to decrease zoom factor 
by half.

Click with right mouse button to return to the default 
zoom factor of 4.

Crosshair Box Click with left mouse button to toggle crosshairs on and 
off in Zoom window.

Click with middle mouse button to toggle crosshairs on 
and off in the Main Image window.

Click with right mouse button to toggle the zoom box and 
crosshairs in the Main Image window on and off.

Table 3-2: The Zoom Window Symbol Functions with Mouse Button 
Descriptions
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Mouse Button Functions in the Zoom Window

In addition to the mouse button functions associated with the Zoom window symbol 
boxes and controlling the zoom factor, the left and right mouse buttons perform 
differently when clicked anywhere else inside the Zoom window (not on the symbol 
boxes). The following table describes those functions.

Controlling Zoom Window Interpolation

You can set your preference for what kind of interpolation is used in the Zoom 
window. The default setting is pixel replication, also known as nearest neighbor. Set 
the interpolation by clicking the right mouse button in the Zoom window and making 
a selection from the Zoom Interpolation menu or set it through the System 
Preferences dialog as follows: 

1. In the Display menu, select File → Preferences. 

2. From the Zoom Interp button menu, select the interpolation method: Nearest 
Neighbor, Bilinear, Bicubic, or Optimized Bicubic.

Note
Nearest neighbor uses pixel replication; bilinear does a linear interpolation 
using 4 pixels; bicubic uses 16 pixels for the interpolation; optimized bicubic 
provides the best interpolation.

Mouse Button Function

Left Button Click on desired pixel to center the Zoom window 
on that pixel.

or:

Click and hold to pan from the center of the 
window in the direction of the cursor location. (The 
speed of the pan varies with the cursor’s distance 
from the center of the Zoom window — the closer 
the cursor is to the center, the slower the pan.)

Middle Button No function.

Right Button Click to display the shortcut menu.

Table 3-3:  Mouse Button Functions Inside the Zoom Window
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Note
When you use the Cursor Location/Value window to view values in the Zoom 
window, the values you see reported are from the original data, not the interpolated 
data.

The Scroll Window

The Scroll window is a small image display window that appears when the display 
window style is set to Scroll/Zoom or Scroll/Image/Zoom and the main image is 
larger than can be displayed in the Main Image window at full resolution. The image 
in the Scroll window is displayed at subsampled resolution. The resampling factor 
appears in parenthesis in the title bar. The Main Image window indicator appears as a 
box within the scroll window and outlines the area that is displayed in full resolution 
in the Main Image window.

Resizing the Scroll Window

To resize the Scroll window, select one of the following options:

• Dynamically resize the Scroll window by grabbing a corner and dragging to 
the desired image size. The resampling factor changes to reflect the new size of 
the scroll window.

• In the Display menu window, select File → Preferences and enter the size in 
the Display Preferences dialog (see “Resizing Windows” on page 236).

• Change the default Scroll window size using the parameters set in the 
envi.cfg configuration file (see Appendix A, “Installing and Customizing 
ENVI”).

Controlling the Main Image Window from the Scroll Window

The size of the Main Window Indicator box in the Scroll window is directly linked to 
the size of the Main Image window. If you change the size of the Main Image 
window, the Main Image window indicator will also change sizes. If you have the 
display window style set to Scroll/Image/Zoom and you resize the Main Image 
window so that the entire image appears at full resolution, the Scroll window will 
disappear because it is no longer needed. If you subsequently resize the Main Image 
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window so that the full image cannot be shown at full resolution, the Scroll window 
automatically reappears.

• Use the arrow keys on the keyboard to move the image window by one scroll 
pixel in the direction of the arrow. Use Shift + arrow to move the image 
window in larger increments in the direction of the arrow.

• To control the location of the Main Image window indicator, follow the 
directions given in “Mouse Button Functions in the Scroll Window” on 
page 210.

Scroll Window Meta Zoom

When very large images are displayed, the Scroll window image may be subsampled 
so much that it is difficult to see image features. The Scroll window Meta Zoom 
capability allows you to zoom into an area and reduce the subsampling factor in the 
Scroll window. The zoomed area replaces the full image in the Scroll window and 
scroll bars appear. The original Scroll window image can be re-displayed with a 
mouse click (see “Mouse Button Functions in the Scroll Window” on page 210 for 
mouse button functions).

Note
The Scroll window meta zoom will not zoom if the area selected is smaller than the 
current Main Image window size.

Figure 3-10: Scroll Window with Main Image Window Indicator Box
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To zoom in the Scroll window:

• Click and drag using the middle mouse button to draw the meta zoom indicator 
box around the desired area. This area replaces the image in the Scroll window.

To display the original full image in the Scroll window:

• Click the right mouse button in the Scroll window and select Reset Scroll 
Range from the shortcut menu.

Mouse Button Functions in the Scroll Window

The following table outlines the mouse button functions in the Scroll window.

Display Window Shortcut Menu

Use the shortcut menu in any of the three display windows to quickly access Display 
window options. 

1. To use the shortcut menu, right-click anywhere in any of the three display 
windows.

2. Select from the following options: 

• Use Display Window Style to select which of the three display windows 
(Image, Scroll, and Zoom) are shown. 

Mouse Button Function

Left Button Click anywhere outside the Main Image window indicator box 
in the Scroll window and drag. The Zoom and Main Image 
windows update continuously.

Click, drag, and release the Main Window indicator box to 
reposition the Main Image. The Zoom and Main Image 
windows update when you release the mouse button.

or:

Click to center the Main Image indicator box and Main Image 
display over the selected pixel.

Middle Button Click and drag meta zoom box.

Right Button Click to display the shortcut menu.

Table 3-4:  Mouse Buttons Functions Inside the Scroll Window
ENVI Image Display Windows ENVI User’s Guide



Chapter 3: Display Management 211
• Use Scroll/Zoom Position to place the Scroll and Zoom windows in the 
desired position with respect to the Image window and to turn the Auto 
Placement option off or on.

• Use <Find Display> to locate the closed display windows associated with 
the current display window. 

Positioning the Zoom and Scroll Windows 

To position the Zoom and Scroll windows with respect to the Main Image window:

• Select Scroll/Zoom Position from the shortcut menu. 

To position the Zoom or Scroll window:

• Click the title bar and drag the window while holding the left mouse button.

To group the Zoom and Scroll windows to move with the Main Image window:

• Deselect the Scroll/Zoom Position → Auto Placement Off option in the 
shortcut menu. To ungroup the window, set Scroll/Zoom Position → Auto 
Placement Off in the shortcut menu.

Locking Window Placement

To ensure that windows remain where they are placed:

• Select Scroll/Zoom Position → Auto Placement Off.

The windows will remain in place until you move them again.

Hiding Scroll/Zoom Windows

To hide only the Zoom and/or Scroll windows on Microsoft Windows platforms, 
click the  button in the right corner of the window.

Unhiding Scroll/Zoom Windows

Right-click in the Image, Zoom or Scroll window and click <Find Display> to bring 
up the associated hidden Zoom and/or Scroll windows.
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The Available Vectors List

Use the Available Vectors List to load vectors into a Vector window or to overlay 
them on a displayed image. You can simultaneously overlay vector layers of different 
projection types or overlay vector layers that have projection types different than the 
image. The image or the first vector layer displayed sets the projection type and all 
other layers are automatically converted to that projection type.

When you load a vector file into memory for the first time during an ENVI session, 
ENVI places the vector layers into the Available Vectors List automatically. Data files 
that will appear in the Available Vectors List include ENVI Vector Files, DLG, 
Microstation DGN, MapInfo, SDTS, DXF, ARC/INFO Interchange, and ArcView 
Shapefiles. If multiple vector files are opened, all of the layers for all of the files 
appear in the Available Vectors List sequentially.

From the Available Vectors List, select vector files to display as an overlay on an 
image or in a separate Vector window.

To stretch and resize the Available Vectors List, click on any corner of the dialog with 
the left mouse button and drag to the desired size and/or shape.

Figure 3-11: Available Vectors List
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Loading Vectors for Display

Follow these steps to display vector files in ENVI:

1. From the ENVI main menu, select Window → Available Vectors List. All 
open vector layers appear in the Available Vectors List.

2. Click on the layer name.

• To select all of the layers, click on Select All Layers.

• To clear all of the layers, click on Deselect All Layers.

• To remove a layer from the list, click on the name and click Remove 
Selected.

3. Click on Load Selected in the Available Vectors List to load the vectors to a 
vector or display window.

4. When the Load Vector Layers dialog appears, select a vector destination 
display window by clicking on a window name.

• If any image display windows are open, the display names (i.e. Display #1) 
appear in the list. Click on the desired display window name to plot the 
vectors over the displayed image.

• If any vector windows are open, the vector window names (i.e. Vector 
Window #1) appear in the list. Click on the desired Vector window name to 
plot the vectors in that window.

• To plot the vectors in a new Vector window, select New Vector Window.

5. Click OK.

The Vector window appears with the selected vectors displayed (see “Vector 
Options” on page 222).
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Options in the Available Vectors List

Use the Options menu in the Available Vectors List to start a new Vector window, 
remove all the vector layers from memory, edit the layer names, change projection 
types, convert layers from one projection type to another, create various world 
boundaries vectors, and create new empty vector layers.

Opening New Vector Windows

To start a new empty Vector window and an associated parameters dialog:

• Select Options → Start New Vector Window.

Deleting Layers from Memory

To delete all the vector layers from memory:

• Select Options → Remove All Layers.

Note
Once vectors are deleted from memory, the only way to recover the layers is to read 
them from disk again. 

Editing Layer Names

1. Select Options → Edit Layer Names.

2. When the Edit Layer Names dialog appears, click on the name of the layer that 
you want to change. The name appears in the Edit Selected Item text box.

3. Edit the name in the text box. To return the layer to its unedited name, click 
Reset.

4. Click OK.

Changing Projection Types

1. Select Options → Edit Layer Projection.

2. When the Edit Layer Projection dialog appears, select a new projection type by 
clicking on it (see “Selecting Map Projection Types” on page 922).

3. Click OK.
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Note
Changing the projection type does not affect any data points; it only changes the 
projection name. 

To convert between projections, see the following section. For more map projection 
information, see Chapter 10, “Map Tools”. 

Converting Layer Projections

Use Convert Layer Projection to convert layers from one projection type to another.

1. Click on the layer name in the Available Vectors List.

2. Select Options → Convert Layer Projection.

3. When the Convert Layer Projection dialog appears, select a projection type 
from the list (see “Selecting Map Projection Types” on page 922).

4. Enter a new layer name, if desired.

5. Select output to File or Memory.

6. Click OK.

For more information on converting projections, see “Converting Map Projections” in 
Chapter 10.

Creating Buffer Zone Images for Vectors

Use Calculate Buffer Zone to calculate a buffer zone image in which the value of 
every pixel is defined as the distance from that pixel to the selected vector layers, in 
units of pixels. If your vectors are overlaid on a display window, the displayed image 
is used to create the output buffer zone image. If the vectors are displayed in a Vector 
window, you must select an associated file to use for the calculation. You designate a 
maximum distance value and the result is that any pixels with a distance larger than 
that value are set to the maximum distance value +1.

1. In the Available Vectors List, click on the names of the vectors to use in the 
buffer zone image. 

Note
If you select more than one layer, the distance will be from the pixel to any of 
the selected layers.

2. Select Options → Calculate Buffer Zone.
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3. When the Select Associated Data File dialog appears, select the file associated 
with your vectors. The Buffer Zone Image Parameters dialog appears.

4. Click the Maximum Distance arrow increment buttons to set the maximum 
distance to measure, or type the value (in pixels) into the corresponding text 
box. Any pixels with a distance larger than this value will be set to the 
maximum distance value +1. 

5. From the Distance Kernel button menu, select Floating Point or Integer 
output.

6. Select output to File or Memory.

7. Click OK.

Creating World Boundary Layers

From the Available Bands List, use Create World Boundaries to create layers of 
various world boundaries (including political boundaries, coastlines, rivers, and USA 
states) from either a high resolution or a low resolution database.

1. Select Options → Create World Boundaries. The Create Boundaries dialog 
appears.

Note
You can also create world boundaries by selecting Vector → Create World 
Boundaries from the ENVI main menu.

2. Select the layers by clicking the check box next to their names.

• To select a range of layers, enter the starting and ending numbers and click 
Add Range.

• To select all the layers, click Select All.

• To clear all the layers, click Clear.

3. Select one of the following options:

• To create world boundary layers for a specific area, enter the latitude and 
longitude coordinates in the corresponding text boxes.

• To create world boundary layers for the entire world, do not enter latitude 
and longitude coordinates.

4. Select output to File or Memory. One output .evf file is created for every 
selected layer and named with a layer abbreviation appended to the root 
filename. The high resolution layers are named with a _hp, _hc, or _hr for the 
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political boundaries, the coastlines, or the rivers, respectively. The low 
resolution layers are named similarly but with an _lp, etc. The USA States 
layer have _usa appended to the root name.

Note
Building layers from the high resolution database creates very large output 
files (~20 MB each).

5. Click OK to build the vector layers.

The selected layers appear in the Available Vectors List.

Creating New Layers

Use Create New Vector Layer to create a new empty vector layer so you can enter 
your own vector layers of polygons, lines, or points and attributes. These vector 
layers can have the same projection and geographic boundaries (size) as existing 
vector layers, georeferenced raster images, or can be based on user-defined input. An 
empty vector layer can also be created from non-georeferenced raster images for 
drawing vectors over those images.

Tip
You can also create vector layers by selecting Vector → Create New Vector Layer 
from the ENVI main menu (see “Creating Vector Layers” in Chapter 11).

From Existing Layers

1. Select Options → Create New Vector Layer → Using Existing Vector 
Layer.

2. When the New Vector Layer Parameters dialog appears, click on the name of 
the vector layer to use to set the projection and size boundaries.

3. When the New Vector Layer Parameters dialog appears, enter a layer name, 
and select File or Memory output.

From Projection and Boundaries of a Raster Image

1. Select Options → Create New Vector Layer → Using Raster Image File.

2. When the Select Image File for New Vector Layer dialog appears, select the 
image file and click OK.

3. When the New Vector Layer Parameters dialog appears, enter a layer name, 
and select File or Memory output.
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From User-Defined Parameters

1. Select Options → Create New Vector Layer → Using User Defined 
Parameters.

2. When the New Vector Layer Parameters dialog appears, select the desired 
projection type and enter a Zone number if needed (see “Selecting Map 
Projection Types” in Chapter 10).

3. Enter the bounding box coordinates in the selected projection units in the 
X/Ymin and X/Ymax text boxes.

4. Enter a layer name and select File or Memory output.

The new layer is listed in the Available Vectors List. From the Available Vectors List, 
you can load the layer into a Vector window and draw vectors and add attributes to it 
(“Working with Vector Layers” in Chapter 4).

Managing Vector Files from the Available Vectors List

Use the File pull-down menu in the Available Vectors List to open new vector files, 
export vector layers to a region of interest (ROI) or ArcView file, and to save layers 
from memory to a file. 

Tip
ENVI vector files can be converted to DXF using Vector → Convert EVF to DXF 
(see “Converting EVFs to DXF Files” in Chapter 11).

Opening Files

1. In the Available Vectors List, select File → Open Vector File → vector file 
type.

2. When the standard file selection dialog appears, select the file (see “Opening 
Vector Files” in Chapter 2 for details).

Exporting Vector Layers to a Region of Interest (ROI)

When exporting vector layers to Regions of Interest (ROIs), you can choose to create 
one ROI containing all of the vectors, or create one ROI for each vector.

1. Choose one of the following options:

• From within the Available Vectors list, select File → Export Layers to 
ROI.
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• From within the Vector Parameters window, select File → Export Active 
Layer to ROIs.

2. When the Export Vector Data to ROI dialog appears, select either the Convert 
all vectors to one ROI or Convert each vector to a new ROI option.

Warning
Vector layers exported as ROIs can create very large ROIs.

Exporting Vector Layers to a Shapefile

Use this procedure to export vector layers to an ArcView-compatible fileset, which 
includes a Shapefile (.shp), an index file (.shx), and a database file (.dbf).

1. In the Available Vectors List, select the vectors to export by clicking on their 
names.

• To export all of the layers, click Select All Layers.

• To select multiple layers, but not all layers, click on each layer that you 
want to export while holding down the Ctrl key on your keyboard.

2. Select File → Export Layers to Shapefile.

Note
If you decide to not load any vectors from the Available Vectors List, select 
File → Cancel to exit it without removing the loaded vectors from memory. 

3. When the Output Layer to the Shapefile dialog appears, enter the desired 
output filename and click OK. This dialog appears for each layer selected.

Each ArcView vector file can contain only one type of vector (polygon, point, etc.), 
so ENVI uses a base name and appends extensions to the base name for each vector 
type. The extensions used are .pg for the polygons, .pl for the polylines, and .pt 
for the points.

Saving Vector Layers

Vector layers listed in the Available Vectors List are currently in memory. Use this 
procedure to save them to a file.

1. In the Available Vectors List, select the layer by clicking on the name.

2. Select File → Save Memory Layers to File.

3. Enter an output filename.
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ENVI Vector Windows

ENVI provides a stand-alone GIS plot window for displaying vector data and 
composing simple vector-only maps. ENVI also provides vector overlays on standard 
ENVI displays that include true vectorization of overlays in all windows, including 
the Zoom window. Full precision of vector data is maintained and pixellation is 
avoided. Vectors can be read from a variety of input files and new vector layers can be 
created and drawn in a Vector window or over images. Latitude/longitude and map 
coordinate information can be displayed while interactively tracking vectors. A 
Vector Information window allows display of attribute information in real-time as the 
cursor tracks each vector. You can query vector GIS attribute information directly to 
generate new layers of selected information with attributes. You can create ArcView 
Shape Files and associated .dbf attribute files and indexes, or DXF files from 
internal ENVI .evf format. New vector layers generated using ENVI’s robust image 
processing capabilities, and changes made to vector layers in ENVI are easily 
exported to industry standard GIS formats.

ENVI Vector windows provide you with a way to view vector data such as USGS 
Digital Line Graphs (DLG), USGS DLGs in Spatial Data Transfer Standard (SDTS) 
format, DXF files, ARC/INFO Interchange files, and ArcView Shape files. You can 
view, edit, and query attributes associated with ArcView Shape files and can also 
create your own vector files and attributes. An ENVI Vector window consists of a 
vector display window or image window and a #N Vector Parameters dialog that 
controls the appearance of the vectors and interaction with the vector attributes.

Cursor Functions in Vector Windows

Cursor and mouse functions in vector windows work differently than they do in 
ENVI display windows. Cursor functions in the vector windows change depending 
on the mode selected. The following table lists the functions of the mouse buttons 
when you place the cursor in a Vector window and the Cursor Query mode is active. 
See “Controlling Cursor Modes” in Chapter 4 for cursor functions in the other modes. 
More detail on these functions can be found in the following sections.
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Use Help → Mouse Button Descriptions to bring up a dialog description of each 
mouse button. 

Zooming in Vector Windows

Use this procedure to zoom in on a section of the Vector window.

1. Press and hold the middle mouse button at one corner of a box defining the 
magnify region and drag the corner to make the region the desired size. 

Note
Click the middle mouse button while holding down the Shift key to zoom 
into the display centered on the cursor.

2. Release the middle mouse button. ENVI redraws the enlarged zoom region in 
the Vector window. 

Mouse Button Function

Left Button When layer is active (indicated by a check mark next to the 
layer name under Select Active Layer in the shortcut menu) 
— Snap to a near active vector and track map coordinates 
and Latitude/Longitude. (The coordinates are shown at the 
bottom of the Vector window.)

When layer is not active (no check mark appears next to the 
layer name under Select Active Layer in the shortcut menu) 
— Pan the display by clicking at the edge of the window. 
(The Mode label at the bottom of the Vector window will 
display Pan with the direction of the pan when the mouse is 
near the edge of the Vector window.) 

Middle Button Zoom into an area by clicking and dragging to form a zoom 
box inside the Vector window. Decrease zoom factor with 
single click inside the window. Click while holding down the 
Shift key to zoom into the display centered on the cursor. 

Right Button Click to display the shortcut menu.

Table 3-5:  Function of Mouse Buttons in the Vector Window
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3. To zoom out use one of the following methods.

• Using the mouse — Click the middle mouse button inside the zoomed 
region. The vector display steps backward through the previous zoom 
levels with one step per click.

• Using a shortcut menu — Click the right mouse button inside the Vector 
window and select Previous Range from the shortcut menu. The vector 
display steps backward through the previous zoom levels. 

• Select Reset Range from the shortcut menu to reset all zooming and set 
the vector display back to the original range.

Panning in Vector Windows

To pan to another region in the Vector window, click the left mouse button near the 
edge of the Vector window. The Mode label at the bottom of the Vector window will 
display Pan and the direction of the pan when the mouse is near the edge of the 
Vector window. 

Cursor Tracking in Vector Windows

If you are attempting image-to-map registration (see “Registration” in Chapter 10), 
you need to find the location of your cursor. If vectors are displayed in an image 
window, ENVI reports the position of the cursor by displaying it in the Location text 
box of that window’s associated Vector Parameters dialog. If vectors are displayed in 
a Vector window, ENVI reports the position of the cursor in the bottom-left text box 
in the Vector window.

An check mark next to the layer name under Select Active Layer in the shortcut 
menu of the Vector window indicates that a layer is active. When active, the vector 
cursor snaps to the nearest vector in that layer. When not active, no snap is applied 
and the cursor freely tracks position anywhere in the window. In either case, clicking 
and dragging using the left mouse button in the Vector window causes the map 
coordinates of the cursor’s location to be listed in Easting, Northing order in the 
lower right corner of the Vector window. Latitude and longitude are listed directly 
under the map coordinates.

Vector Options

Vector data often consist of multiple layers of vector data. For example, the following 
figure shows that the available vector layers include Cities, Counties, Roads, and 
States. Use the Vector options, which appears with a Vector window, to control the 
appearance of vector layers, to add new vectors, export vector layer coordinates for 
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use in image-to-map registration, and to view, edit, and query vector attributes (see 
“Working with Vector Layers” in Chapter 4 for details).

Vector Attributes

Vector layers may have attributes associated with them. ENVI can read Shapefile 
attributes and interact with them. You can use the cursor to select vectors in the 
Vector window and highlight the associated attributes or select an attribute and 
highlight the associated vector. You can do a vector attribute query to create new 
vector layers with attributes selected using simple mathematical and logical 
operators. ENVI also allows you to edit the existing attributes or to add new attributes 
to vectors. Point attribute names can be plotted in the Vector window and point 
symbol sizes associated with attribute values (see “Vector Attributes” in Chapter 4 for 
instructions).

Note
Currently ENVI only reads Shapefile attributes or attributes added using ENVI 
functions.

Figure 3-12: Vector Window
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Tools for Maintaining Your Display

ENVI provides the following tools for maintaining your display:

• mouse button descriptions

• display information at the current cursor position

• data information at the current cursor position

• point collection

• maximum display resizing

• display linking

• the ability to close all display and plot windows

Displaying Mouse Button Descriptions

Use Mouse Button Descriptions to view the functionality of the mouse buttons for 
the window in which the cursor is located. As the cursor is moved from window to 
window, the mouse button descriptions are updated. The displayed information 
includes the window type (e.g., display, plot), the function that has the cursor control 
(e.g., ROIs, Dynamic Overlay), and the actions for each mouse button (MB1: left 
mouse button, MB2: middle mouse button; MB3: right mouse button).

Note
If the mouse buttons are not responding as you expect, display the mouse button 
descriptions to check which function is in control of the cursor.

To display the mouse button description dialog, select one of the following options:

• From the ENVI main menu, select Window → Mouse Button Descriptions 
or Help → Mouse Button Descriptions.

• From the ENVI main menu, click on Display → Window → Mouse Button 
Descriptions.
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For either case, the Mouse Button Descriptions dialog appears.

Showing Display Information

Use Display Information to view information about the display window in which the 
cursor is currently located. The information is updated as you move the cursor 
between the open display windows. The displayed information includes the display 
number, number of colors used, bands displayed, the type of stretch currently applied 
to each band, and the sizes and pixel ranges of the image, zoom, and scroll windows.

• From the ENVI main menu or the Main Image window, click on Window → 
Display Information.

The Display Information window appears.

Figure 3-13: Mouse Button Descriptions Dialog

Figure 3-14: Display Information Window
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Displaying Cursor Location/Value

Use Cursor Location/Value in any image window to display the sample (horizontal, 
X) and line (vertical, Y) coordinates, the data value of the pixel under the cursor, and 
the geographic coordinates (for georeferenced data) of the pixel under the cursor.

Select one of the following options to open the Cursor Location/Value window:

• In the Main Image window, double-click with the left mouse button.

• From the Main Image window, select Tools → Cursor Location/Value.

• From the ENVI main menu or the Main Image window, select Window → 
Cursor Location/Value. For detailed information, see “Viewing Cursor 
Location and Value” in Chapter 4.

Collecting Points

Use Point Collection to collects points (both pixel locations and map locations) from 
display windows. The points are displayed in a table in the ENVI Point Collection 
window.

• From the ENVI main menu, select Window → Point Collection, or from the 
Main Image window, select Tools → Point Collection.

For detailed information and instructions, see “Collecting Points” in Chapter 4.

Maximizing Open Displays

To resize all display windows to fit the available screen space, select either:

• Window → Maximize Display Windows from the Main Image window, or

• Window → Maximize Open Displays from the ENVI main menu.

For example, if four displays are open, each display will be resized to fill one-fourth 
of the available screen. 
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Linking Displays

Use display linking to link multiple displays so that all actions in one display are 
mirrored in the others. Dynamic overlays are active when displays are linked 
(“Working with Multiple Dynamic Overlays” in Chapter 4).

To link displays:

• select Window → Link Displays from the ENVI main menu, or

• select Tools → Link → Link Displays from the Main Image window.

Displays may also be linked using the Tools menu in any display or by using the 
shortcut menus (see “Linking Images” in Chapter 4 and “Display Window Shortcut 
Menu” in Chapter 4).

Closing all Display Windows

To close all open image displays:

• Select Window → Close All Display Windows from the Display menu or 
from the ENVI main menu.

Closing all Plot Windows

To close all open plot windows:

• Select Window → Close All Plot Windows.
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The Display Menu Bar

Five menus appear in the Main Image window: File, Overlay, Enhance, Tools and 
Window. These menus are collectively titled the Display menu bar. Use the Display 
menu bar to access common display operations and interactive functions. 

Operations and functions include linking image windows; producing X, Y, Z 
(spectral), and arbitrary profiles; contrast stretching; color mapping; ROI selection, 
cursor position and values, two-dimensional scatter plots, surface plotting 
(perspectives and draping), and polarization signatures; various overlays including 
annotation, pixel-based and georeferenced grid lines, image contouring, and vector 
layers; image animation, changing display window characteristics; printing and 
outputting images (PostScript, Image [RGB], BMP, HDF, JPEG, JPEG2000, PICT, 
SRF, TIFF, or XWD formats). 

Figure 4-1: The Display Menu Bar
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Display Window Shortcut Menu

You can access many Display menu bar interactive functions from the shortcut menu 
in any of the three display windows. Descriptions of the available functions are 
provided in “ENVI Image Display Windows” in Chapter 3 and in this chapter.

1. To use the new shortcut menu, right-click anywhere in a display window.

2. From the menu that appears, select an option.

Note
The shortcut menu displays different options depending on whether interactive 
linking is on or off. In the following figure, the shortcut menu on the left is shown 
with interactive linking off; on the right, with interactive linking on.

Figure 4-2: The Zoom and Main Image Window Shortcut Menus 
ENVI User’s Guide The Display Menu Bar



232 Chapter 4: Interactive Display Functions
Display Functions

Use the File menu on the Display menu bar to create vector layers for the displayed 
image, save display groups to a file, open saved display groups, output images to 
various formats, print display images, and set preferences for your image displays.

Figure 4-3: File Menu Options Available From the Display Menu Bar
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Creating Vector Layers

Use Create New Vector Layer from the File menu on the Display menu bar to create 
a new vector layer that is associated with the displayed image.

Note
You can also create vector layers from within the Available Vectors List or from the 
Vector menu on the ENVI main menu. For detailed instructions, see “Creating New 
Layers” on page 217 and “Creating Vector Layers” on page 966.

1. Select File → Create New Vector Layer from the Display menu bar.

2. Enter a layer name and select output to File or Memory. The Vector 
Parameters window appears.

Note
To draw new vectors, select Mode → Add New [Type] from the Vector 
Parameters dialog.

For detailed information, see “Working with Vector Layers” on page 327.
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Saving Display Groups

Use Save as Display Group to save a given display group, in its present state, to a 
file. When a display group is saved, the displayed bands, the window sizes and 
positions, the stretch, the displayed overlays, any open profiles, and any two-
dimensional scatter plots associated with the display are all saved in a text file.

1. From the Display menu bar, select File → Save As Display Group.

2. Enter or choose an output filename.

3. Click OK.

The default extension .grp is automatically appended to the filename.

Restoring Saved Display Groups

Use Restore Display Group to restore a saved display group.

Note
Files that were not saved to disk (e.g., only in memory) and files that cannot be 
opened directly using ENVI’s Open Image File function will not be restored.

1. Select one of the following options:

• From the ENVI main menu, select File → Restore Display Group.

• From the Display menu bar, select File → Restore Display Group.

Note
If you restore a saved display group from the ENVI main menu, it will be 
placed in a new display group. If you restore a saved display group from the 
Display menu bar, it will replace the current display.

2. In the file selection dialog, select the .grp file.

The display group and its associated windows are displayed.
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Setting Display Preferences

Use Preferences to add virtual borders to an image, to edit the characteristics of the 
border, to change the size of the Main Image, Zoom, or Scroll windows, and to 
change the color of the Zoom/Scroll window indicator boxes. For a complete 
overview of ENVI Image Display windows, see “ENVI Image Display Windows” in 
Chapter 3.

Setting Virtual Border Characteristics

To append a virtual border to the image display:

1. From the Display menu bar, select File → Preferences.

2. When the Display Parameters dialog appears, select from the following 
options:

• To set the default so that each time an image is loaded a virtual border is 
used, enter the size of the border in pixels in the appropriately positioned 
text box. 

The left box controls the left border, the right the right border, the top the 
top border, and the bottom the bottom border. 

• To change the default border color, select the desired color from the 
Border Color button menu.

3. Click OK.

Turning Image Window Scroll Bars On/Off

Use the scroll bars in the border of the Main Image window to move around the 
image.

1. Double-click the Zoom window cross-hair box with the right mouse button or 
in the open display, select File → Preferences. The Display Parameters dialog 
appears.

2. Click the Scroll Bars arrow toggle button to select Yes or No.

3. Click OK.
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Resizing Windows

1. In the open display, select File → Preferences. The Display Parameters dialog 
appears.

2. Select from the following options:

• To set the size of the Image, Scroll, and/or Zoom windows, enter the size 
(in pixels) in the corresponding text boxes.

• To enter a resize factor for the Scroll window, enter it into the Resize 
Factor text box.

• To set the zoom factor for the Zoom window, enter it into the Zoom 
Factor text box.

3. Click OK.

For additional resizing techniques, see “Resizing the Main Image Window” on 
page 200, “Resizing the Zoom Window” on page 204, and “Resizing the Scroll 
Window” on page 208.

Changing Zoom Window Properties

To change the x or y size (in pixels) of the Zoom window, the zoom factor of the 
Zoom window, or the interpolation method used:

1. In the open display, select File → Preferences. The Display Parameters dialog 
appears.

2. Select from the following options:

• To change the size of the Zoom window, enter the corresponding x and y 
dimensions (in pixels) in the xsize and ysize text boxes.

• To change the zoom factor, use the arrow increment buttons.

• To change the interpolation method use the Zoom Interp button menu in 
the Zoom window to select from Nearest Neighbor, Bilinear, Bicubic, or 
Optimized Bicubic methods.

3. Click OK.
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Changing Indicator Box Colors

To change the displayed color of the Zoom Window Indicator box, the Main Image 
Window Indicator box, and the Zoom window crosshairs:

1. In the open display, select File → Preferences. The Display Parameters dialog 
appears.

2. Select a color by using one of the following options:

• From the Zoom/Scroll Color button menu, select a color.

• Click on the colored box with the left mouse button to cycle through the 
color choices.

Note
To cycle backwards, click on the colored box with the middle mouse button.

3. Click OK.
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Overlays

Use Overlay to place annotation (text, polygons, symbols, etc.), classifications, 
density slices, pixel and map grids, contour lines, regions of interest (ROIs) or vector 
layers over an image or plot.

Tip
Use ENVI’s QuickMap feature to quickly overlay grid lines, titles, declination 
diagrams, North arrows, and borders on georeferenced images. For details, see 
“Creating QuickMaps” on page 320.

Figure 4-4: Image Overlay Options From the Overlay Menu
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Showing and Hiding Overlay Dialogs and Layers

When working with overlays (annotation, regions of interest, contours, grid lines, 
density slices, and vector layers), you can hide the control dialog (e.g., the ROI Tool 
dialog, the Density Slice dialog, etc.) without erasing the corresponding overlays 
from your image. When the dialog is hidden, you can hide the associated layers 
without erasing them.

Hiding Overlay Dialogs

To remove the overlay control dialog from the screen or hide it without erasing 
overlays from your image, select one of the following options:

• In the overlay control dialog, select Options → Hide Window.

• In the Window Finder, double-click on the window name.

Showing Hidden Overlay Dialogs

To unhide the overlay control dialog, select one of the following options:

• In the Window Finder (see “Using the Window Finder” on page 183), click on 
the window name.

• From the Display menu bar, select Overlay → [overlay type].

Hiding Layers

When an overlay control dialog is hidden, you can show or hide the displayed layers.

To hide layers:

• Select Overlay → [overlay type...] Hide Layer. All of the layers of the 
selected overlay type are hidden.

To unhide layers:

• Select Overlay → [overlay type...] Show Layer.
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Annotating Images

Use Annotation to add text, symbols, polygons, lines, polylines, shapes, map 
information, and grayscale or color bars to images and plots. For classification 
images, add class keys. Annotation options are similar for images, plots or surface 
views. Annotations can be saved to files and included in output options.

Annotation can be placed in the Main Image window, the Scroll window, the Zoom 
window, or the virtual borders of an image.

Tip
Use ENVI’s QuickMap feature to quickly overlay grid lines, titles, declination 
diagrams, North arrows, and borders on georeferenced images. For details, see 
“Creating QuickMaps” on page 320.

Figure 4-5: Example Annotation in an ENVI Display Group
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Note
To use virtual borders, append the border to the image prior to annotating the image 
(see “Setting Virtual Display Borders” on page 243).

1. Select one of the following options:

• From the Display menu bar select Overlay → Annotation.

• In any plot, including surface plots and X, Y, or Z profiles, select 
Options → Annotation.

2. When the #n Annotation dialog appears (where n is the display being 
annotated), select Object → the desired annotation type. 

Note
Text annotation is the default mode.

The functionality of each annotation type is described in the following sections.

Positioning Annotations

1. In the Annotation dialog, select the Main, Scroll, or Zoom window toggle 
button.

Note
Normal mouse operations in the selected window are disabled. However, 
normal mouse operations still apply in the other windows. To temporarily 
suspended annotation, select the Off toggle button. All normal mouse 
operations are again possible in all windows.

2. Position annotation objects by clicking the left mouse button at the desired site 
on the image. Refer to the following table for specific mouse button and 
positioning functions.

3. Use the colored diamond-shaped handle to place the annotation at the desired 
location. (The handle appears on all annotation types.)
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4. After the annotation is positioned, click the right mouse button to fix the object 
at that location on the image. The diamond-shaped handle disappears after the 
annotation is fixed.

Tip
The text box at the top of the Annotation dialog describes the mouse button 
functions for the current annotation mode. MB1 is the left mouse button, 
MB2 is the middle mouse button, and MB3 is the right mouse button.

Action Mouse 
Button

Interaction Where

Position current
annotation

Left Click and 
Release

At desired location 

Move current annotation Left Click, hold 
and Drag 
Handle

Throughout image

Delete current annotation Middle Click and 
Release

Anywhere in image

Fix current annotation
and proceed to the next
annotation operation

Right Click and 
Release

Anywhere in image

Prepare to reselect fixed
annotation

Left Click and pull 
down menu

Object → 
Selection/Edit 

Reselect annotation Left Click and drag 
to draw box

Around annotation 
object corners

Suspend annotation (all
normal functions are
returned)

Left Click Off toggle button

Resume annotation
(normal functions
suspended)

Left Click Image, Scroll, or 
Zoom toggle button

Table 4-1: Mouse Button Assignments for Annotation
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Setting Virtual Display Borders

Use Set Display Borders to append a virtual border to an image. You can place any 
type of annotation object in the border.

1. Select Options → Display Borders.

2. When the Display Borders dialog appears, enter the desired border width (in 
pixels) for the left, top, right, and bottom image border in the text boxes with 
the same relative position. 

The image is re-displayed with the designated virtual border.

Note
You can also add Virtual Borders using the Available Bands List (see “Options in 
the Available Bands List” on page 195).

Changing Snap Factors

In the Annotation dialog, set the snap factor to use for placing your annotations. The 
snap factor causes any annotation located within the specified snap distance (in 
pixels) to snap to the same pixel location. A snap factor of 1 (the default) causes 
annotation to be placed exactly at the location selected.

1. In the Annotation dialog, select Options → Set Snap Value.

2. In the Set Snap Value dialog, use the increment arrows to select a value or enter 
the value in the Snap text box.

3. Click OK.

Burning Annotation into Images

To burn the annotation into an image once it has been placed: 

1. In the Annotation dialog, select the Off toggle button. 

2. From the Display menu bar, select File → Save Image As → Postscript File 
(see “Display Output Options” on page 446).
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Selecting Annotation Object Types

In the Annotation dialog, use the Object pull-down menu to select from the various 
annotation object types. Text, symbols, shapes, map information, and color ramps are 
available as annotation objects. Each object has its own annotation options and are 
described in more detail below.

Working with Text Annotation

1. In the Annotation dialog, select Object → Text. 

2. Enter text by typing it in the text box at the bottom of the window.

More than one line of text may be entered at once.

3. Select from the following specific options to change the text characteristics.

Note
The text characteristics will not change in the dialog. To see the changes, 
click in the image window, but do not fix the annotation in place until you are 
satisfied with the appearance of the text.

• To change text color, click on the Color button menu and select the desired 
color.

• To place the text on a solid colored background, use the Back button menu 
to select a color; to place the text directly on the image without a 
background (this is the default), select Off.

• To adjust the thickness of the text, enter a new thickness value in the Thick 
textbox or use the increment arrows to change the value in the Thick 
parameter box. 

• To change the text font, click the Font button menu and select a font. 

• To change the size of the text (in pixels), change the value or use the arrow 
increment buttons in the Size parameter box. 

• To change the orientation of the text on the screen (the angle at which it is 
written), enter the value of the angle in degrees (counterclockwise, with 
respect to the horizontal [0 degrees]) in the Orien parameter box or toggle 
the arrow increment buttons.

• To center the text or justify it left or right, choose the appropriate option 
under the Align button menu. 
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4. Position and fix the annotation as described in “Positioning Annotations” on 
page 241.

A Note About Fonts

Several font types are available from the Fonts button menu in the Text Annotation 
window, including special ENVI fonts. Use the ENVI Symbols font type to place 
mining and cartographic symbols, and ENVI and IDL logos.

ENVI offers the flexibility of allowing you to use any text- or symbol-based 
TrueType font when creating annotations. After you download a TrueType font, you 
can install it so that it is available to ENVI. 

Installing TrueType Fonts for ENVI

IDL and ENVI provide access to TrueType fonts through the resource file, 
ttfont.map, located in the IDL resource/fonts/tt subdirectory of your IDL 
installation. The ttfont.map file contains a listing of available font files. The 
following figure contains an example of the font resource file. 

Field descriptions within this resource file are described in the following table.

Figure 4-6: Sample ttfont.map File

Field Description

Fontname This column contains the name of the font that is available 
when working with features such a QuickMap.

Filename This column contains the TrueType font filename.

Table 4-2: Field Descriptions of the Font Resource File
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Note
For more information on scaling factors, see the “Fonts” Appendix in the IDL 
Reference Guide.

How to Install TrueType Fonts

To install TrueType fonts for use with ENVI, complete the following steps:

1. Copy the font file, which will have a .ttf extension, to the 
resource/fonts/tt subdirectory of your IDL installation directory.

Note
On Windows, you can install the font file in your operating system’s Fonts 
folder. In this case, you do not need to copy the file to the 
resource/fonts/tt subdirectory.

Note
Before you modify the ttfont.map file, create a backup copy so you can 
restore the defaults if necessary. Note also that applications that use text may 
appear different on different platforms if the scale entries in the ttfont.map 
file are altered.

2. Modify the ttfont.map file using any plain text editor, listing the new font 
that you have added. Include the fields listed in the previous table, separating 
each field using white space (spaces or tabs).

Note
If you installed the font in your operating system’s Fonts folder, it is not 
necessary to list the newly installed font in the ttfont.map file on the 
Windows platform.

Direct This column indicates the Direct Graphics scale, a correction 
factor that is applied when rendering the font on a Direct 
Graphics device.

Object This column indicates the Object Graphics scale, a correction 
factor that is applied when rendering the font on an Object 
Graphics device. 

Field Description

Table 4-2: Field Descriptions of the Font Resource File
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3. Save the modified font resource file. 

The font is now available for use with ENVI functions.

Working with Symbol Annotation

1. In the Annotation dialog, select Object → Symbol. The available symbols are 
displayed in the selected font in the window at the bottom of the dialog. 
Individual characters in text fonts can also be selected using the Symbol 
option. 

2. Select the desired font or symbol set from the Font menu.

Note
The fonts labeled Misc, Special, and Math show some of the standard 
symbols available in IDL.

3. Click the left mouse button on the desired symbol. When selected, the symbol 
is highlighted in red. 

4. Select from the options described in “Working with Text Annotation” to 
change the color, line thickness, etc.

5. Position and fix the annotation as described in “Positioning Annotations” on 
page 241.

Working with Polygon Annotation

1. In the Annotation dialog, select Object → Polygon.

2. Choose from the methods below to draw the polygon.

• Use the left mouse button (see the following table) to set the vertices of the 
polygon. Line segments (polygon sides) are drawn between the selected 
points. Or, draw the polygon by holding down the left mouse button while 
drawing.

• To delete the last segment drawn, press the middle mouse button.
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• To close the polygon, press the right mouse button. A handle (a small 
diamond) appears.

3. Select from the following options to change or adjust the polygon attributes. 

• To change the polygon color, select from the Color menu. 

• To change the thickness of the polygon border (and fill if line-fill is 
chosen), enter a value in the Thick parameter box.

• To change the outline line style (solid, dashed, dotted, etc.), click the Line 
Style menu and select the desired style. 

• To change the orientation of the polygon on the screen, enter the angle in 
degrees (counterclockwise) at which to display the polygon with respect to 
horizontal (0 degrees) in the Rotation parameter box. The Rotation value 
is always reset to 0 after it has been changed.

Action
Mouse 
Button Interaction Where

Choose Polygon
vertices

Left Click and 
Release

At desired 
location

Delete Polygon
vertices (while
drawing)

Middle Click and 
Release

Anywhere in 
image

Close Polygon Right Click and 
Release

Anywhere in 
image

Position
completed
polygon

Left Click and drag On the handle

Move polygon
vertices 

Left Click and drag Near or on 
vertex

Delete polygon Middle Click and 
Release

Anywhere in 
image

Fix current
annotation

Right Click and 
Release

Anywhere in 
image

Table 4-3: Polygon Annotation
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4. Use the Fill button menu to set the fill attributes. 

• To leave the polygon unfilled, select None.

• To fill the polygon with the polygon color, select Solid.

• To fill the polygon with equally spaced lines, select line, dashed, dotted, 
etc.

• To change the orientation of the fill lines, enter the value of the angle in 
degrees (counterclockwise, with respect to the horizontal [0 degrees]), in 
the Orien parameter box. 

• To change the spacing of the lines, enter a value in the Spc parameter box.

5. Position and fix the annotation as described in “Positioning Annotations” on 
page 241.

Working with Polyline Annotation

1. In the Annotation dialog, select Object → Polyline.

2. Use the methods described in “Working with Polygon Annotation” on 
page 247 to draw polylines.

Note
The right mouse button is used complete a line, but does not close line 
segments into a polygon.

3. Select from the options described in “Working with Polygon Annotation” on 
page 247 to change polyline attributes. The options color, line style, 
thickness, and rotation are available.

4. Position and fix the annotation as described in “Positioning Annotations” on 
page 241.

Working with Shape Annotation

Use Rectangle or Ellipse to annotate with geometric shapes.

1. From within the Annotation dialog, select Object → Rectangle or Ellipse.

2. Click and drag with the left mouse button to draw the shape.

• To draw a circle, hold down the control key while drawing an ellipse, or 
draw the circle using the middle mouse button. 

• To draw a square, hold down the control key on the keyboard while 
drawing a rectangle, or draw the square using the middle mouse button.
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• To set or change the size of the shape, grab a corner, an edge, or an axis 
end point (ellipse) and press and hold down the left mouse button while 
dragging to the desired size. The size can also be explicitly changed by 
entering the desired X and Y sizes (in pixels) in the text boxes labeled 
xsize: and ysize:. 

• To delete the shape, press the middle button.

• To fix the object, press the right button as described in Table 4-3.

3. Select from the options described in “Working with Polygon Annotation” on 
page 247 to change shape attributes.

Working with Arrow Annotation

1. In the Annotation dialog, select Object → Arrow.

2. Select from the following steps to draw the arrow.

• To draw an arrow, click and drag with the left mouse button.

• To change the size and orientation, grab an end and press and hold down 
the left mouse button while dragging to the desired size. The size of the 
arrow head can also be changed by entering a new value into the Head 
Size parameter box. 

• To delete the arrow, press the middle mouse button. 

• To control the angle of the lines (in degrees) defining the arrow head, enter 
a value in the Head Angle parameter box. 

Note
Entering smaller angles makes a narrower arrow head and larger angles 
makes a wider head. 

3. Select from the options described in “Working with Polygon Annotation” on 
page 247 to change arrow attributes.

4. Press the right button to fix the location and characteristics of the arrow once it 
has been formatted.
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Working with Scale Bar Annotation

1. From within the Annotation dialog, select Object → Scale Bar.

Note
If the data is not georeferenced, enter a value when the Image Pixel Size 
dialog prompts you for the image pixel size in meters.

2. Select from the following steps and options to position and change the scale 
bar.

• To position a scale bar in the image, press the left mouse button.

• To delete a scale bar, press the middle mouse button.

• To select which units of the scale bar will be drawn, set the arrow toggle 
button to On when the desired units are shown in the Scale pull-down text 
box. A scale bar can be drawn in any combination kilometers, miles, 
meters, and feet.

• To change the spelling of the scale bar titles, click the Change Scale Bar 
Titles button and edit the spelling of the titles. 

Note
You can permanently change the spelling of the titles used for scale bar 
annotation by editing the envi.cfg file (see “The ENVI Configuration File” 
on page 1063).

Note
When more than one of the unit types is set to On, multiple scale bars will be 
drawn.

• To set the height of a scale bar, in pixels, enter the desired value in the 
Height parameter box. 

• To change the scale bar length, enter the desired length, in scale bar units, 
in the Length parameter box. 

• To change the number of increments shown on the scale bar, enter the 
number in the Inc parameter box and the number of sub-increments within 
the first main increment in the Sub Inc parameter box. The length, 
increment, and sub-increment parameters are formatted for each type of 
scale bar individually.
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3. Set the scale bar text attributes by selecting from the options described in 
“Working with Text Annotation” on page 244.

4. Press the right mouse button to fix the scale bar position and characteristics.

Working with Color Ramp and Grayscale Ramp Annotation

Use Color Ramp to place a wedge or color table on the image. The color table or 
wedge represents the currently applied ENVI color table. For a grayscale image the 
color ramp is a grayscale wedge from the minimum grayscale value to the maximum 
grayscale value. For a color image, the color ramp shows the distribution of the 
selected color palette. 

1. In the Annotation dialog, select Object → Color Ramp.

2. Select from the following steps and options to position the ramp.

• To position the color ramp, click the left mouse button at the desired 
location. 

• To delete the ramp, press the middle mouse button.

Figure 4-7: Scale Bar Annotation

Figure 4-8: A Grayscale Ramp Annotation.
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• To orient the ramp either horizontally or vertically, select from one of the 
following (A or B) by clicking on the pull-down menu initially labeled 
Horz →:

A. For horizontal orientation, select Horz → (horizontal from low values to 
high values left to right) or Horz ← (horizontal from high to low left to 
right).

B. For vertical options select Vert ← (vertical from high to low bottom to 
top) or Vert → (vertical from low to high bottom to top).

3. Select from the following options to change the color ramp characteristics. 

• To define the ramp width and length, enter the desired value in the 
parameter boxes labeled Width and Len. 

• To place labels on the ramp, enter the minimum and maximum values in 
the Min and Max parameter boxes. 

• To automatically enter minimum and maximum values calculated from the 
data into the Min and Max parameter boxes, click on the Calculate 
Min/Max button, then select the band from which to calculate the values. 
The minimum and maximum values will be entered into the parameter 
boxes and can be edited, if desired.

• To define the increment (number) of labels to place on the ramp, enter the 
value in the Inc parameter box.

• To set the label precision (the number of significant figures), enter the 
number in the Precision parameter box. For example, 0.25 is a precision of 
2, and .03 is a precision of 1. Labels are placed at the bottom of horizontal 
ramps and placed to the right of vertical ramps. Set Label attributes by 
selecting from the options described in “Working with Text Annotation” 
on page 244.

4. Press the right mouse button to fix the color ramp once it has been positioned 
and formatted.
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Working with Map Key, Class Key, and Vector Key Annotation

A map key consists of colored squares and corresponding labels for each map item or 
class in a classification image. Map keys can be defined interactively and are 
automatically created as class keys for classification images. Vector keys are 
automatically created for vector layers in the appropriate colors with the layer names 
as labels. Vector keys show the vector symbol used for points, a line for polylines, 
and a square outline for polygons. 

1. In the Annotation dialog, select Object → Map Key.

2. Click the left mouse button at the desired location to position the map key.

Note
To delete the map key, press the middle mouse button.

3. Click Edit Map Key Items to define or change items in the map key. 

Figure 4-9: The Edit Map Key Dialog
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4. When the Map Key Object Definition dialog appears, select from the list of 
Key items. 

• To add additional items to the list, click Add Item.

• To delete an item, highlight it in the list and click Delete Item. 

• To change the name of the item, enter the new name in the Object Name 
text box. 

• To define the color of the box, select the desired color using the Color 
menu. 

• To add additional colors, enter the DN values in the R, G, and B, text 
boxes for red, green, and blue respectively. The newly defined color 
appears as black in the image but will be correct upon output.

• To change the fill type in the box, use the Fill menu.

• To control the fill type, use the Orien and Spc parameter boxes.

• For vector keys, an Object Type button menu is included and has polygon, 
polyline, and point selections.

• For a vector polygon item, use the Fill button menu and Orien and Space 
parameter boxes to select the polygon fill type. 

• For a vector polyline item, use the Line Style button menu to select 
different line styles.

• For a vector point item, use the Symbol menu to select the symbol type to 
be shown in the key.

5. Follow these steps to change other parameters within the Annotation dialog.

• To set a background color select the desired color from the Back pull-
down menu in the Annotation dialog. 

• To change the text font for the key, the size, and the thickness of the letters, 
select from the options described in “Working with Text Annotation” on 
page 244.
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• To change class colors, see “Mapping Class Colors” on page 407 for 
detailed instructions.

Saving Map Key Annotation

1. In the Map Key Object Definition dialog, click the Save button.

2. At the prompt, enter an output file name.

ENVI writes the key to a file. Map key files should be saved with the file 
extension .key for consistency, but may be saved using other extensions at 
your discretion. 

Restoring Saved Map Key Files

1. In the Map Key Object Definition dialog, click the Restore button.

2. Select the desired input file.

Working with Declination Diagram Annotation

Use the Declination option to place a declination diagram on the image. The 
declination diagram includes any combination of arrows pointing to true north 
(shown with a star), grid north (GN), and magnetic north (MN). 

1. In the Annotation dialog, select Object → Declination.

2. Click the left mouse button at the desired location to position the declination 
diagram. 

Note
To delete the declination diagram, press the middle mouse button.

3. Select from the following steps to change the attributes of the declination 
diagram.

Figure 4-10: The Vector Key Annotation
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• To set the angle of the north arrows, enter the values in degrees in the True 
North, Grid North, and Magnetic North text boxes. 

The angles are not drawn to scale so that the arrows appear separated. 

• To set the arrow length in pixels, use the Length parameter box. 

• To change the color of the declination diagram, select from the Color 
button menu.

• To set the background color, select from the Back menu.

• To change the text font for the key, the size, and the thickness of the letters, 
select from the options described in “Working with Text Annotation” on 
page 244.

• To change the line and text thickness, enter a value in the Thick parameter 
box.

4. Press the right mouse button to fix the position and characteristics of the 
declination diagram once it has been formatted.

Figure 4-11: A Declination Diagram Annotation
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Working with Image Annotation

Use Image to place other images, such as imported logos or subsampled images, 
inside the current image. Do not confuse this option with mosaicking (see “Image 
Mosaicking” on page 888). 

Tip
Annotation needs to keep a copy of the image in memory so it is not advised to use 
large images.

1. In the Annotation dialog, select Object → Image.

2. Click Select New Image.

3. When the Annotation Image Input Bands dialog appears, select an RGB or 
grayscale file from the Available Bands List within the dialog. The R, G, and B 
text boxes are filled. 

• To select a grayscale image, click on the same file name for all three 
bands. 

• To select a spatial subset, click Spatial Subset.

• To perform spatial resampling of the data, enter a resize factor into the 
Resize Factor text box. 

• To clear the file names in the R, G, and B text boxes, click Reset.

4. Click OK to return to the Annotation dialog and position the image inset.

5. Click the left mouse button at the desired location to position the image.

• To delete the image, click the middle mouse button.

6. Click the right mouse button to fix the image at that location.

Working with Plot Annotation

Use Plot to overlay an ENVI plot on your image. 

1. Select Object → Plot.

2. Click Select New Plot.

Note
If only one plot window is open, that plot is automatically selected.
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3. When the Select Plot window appears, select the name of a plot by clicking on 
it. If you have multiple plot windows opened with the same name, they appear 
listed in the order in which they were opened.

4. Enter or select the xsize and ysize in the Select Plot window, if desired.

5. Click OK.

6. Place the plot on the image by clicking with the left mouse button, dragging to 
the desired location, and clicking the right mouse button to fix the annotation 
in place.

The annotation appears in the image as a red box of the correct size entitled Plot as 
shown in the following figure, but the plot annotation appears correctly in the output 
file.

The plots remain as vectors when burned in to the image if you output it to postscript 
or a printer.

Note
Plot objects will not appear in the image if output to an image file.

Figure 4-12: Plot Annotation
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Annotating Multiple Plots

Use a test image to annotate and output multiple plots on a single page. 

1. From the ENVI main menu, select File → Generate Test Data and create a 
blank white image (see “Generating Test Data” on page 122 for further 
details). 

2. Place the plot annotation on the blank image using standard annotation 
procedures. 

The plot colors are automatically reversed to black on white for output.

Working in Selection Mode

Use Selection to move and change the attributes of annotation objects that have been 
fixed in the image.

1. Select Object → Selection/Edit.

2. Select Options → Show Object Corners.

3. Click and drag with the left mouse button to draw a box around the corner of 
the object in order to select it. 

4. Click the left mouse button on the handle and drag the object to a new location.

5. Change the object’s attributes by entering the new parameters in the 
Annotation dialog. 

Selection options are:

• To select multiple objects at once, press and drag a box around the objects with 
the left mouse button.

• When more than one object is selected the previously selected objects remain 
active.

• When many objects are selected, using a handle to move one moves them all; 
changing attributes change all the selected objects’ attributes. 

• To edit selected vector objects (rectangle, ellipse, polygon, polyline, arrow), 
click the left mouse button on a vertex and drag it to the desired location. 

• To deselect an object, click the middle mouse button on the handle of the 
object.

• To deselect multiple objects, press and drag with the middle mouse button to 
draw a box around the objects. 
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• To deselect all of the annotation objects within an image, click the right mouse 
button within the image. 

• To select only those objects and deselect any previously active objects, press 
and drag with the right mouse button to draw a box around objects. 

Additional options are available for selected annotation objects under the Selected 
menu (see “Annotation Options” on page 261).

Annotation Options

In the Annotation dialog, use the Selected or the Options menu to access annotation 
options. Options available when working with annotation objects include undoing the 
last action, joining polygons, swapping the positions of overlapping objects, 
duplicating or deleting annotation objects, adding virtual borders to an image, turning 
annotation mirroring on and off, and showing or hiding annotation object corners.

Selecting All Annotation Objects

To select all annotation objects, select Selected → Select All.

Figure 4-13: The Annotation Dialog
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Joining Polygons

Use the Join option to join the overlapping parts of two polygons. 

1. Select two polygons to be joined.

2. In the Annotation dialog, choose Selected.

3. Next choose Join.

The underlying polygon’s vertices are changed to match those of the overlying 
polygon. 

Tip
Better results are obtained for polygons that have many vertices (for example, those 
drawn while holding down the left mouse button). Use the Swap option (see the 
next section) to bring a polygon to the top.

Swapping Annotation Objects

Use Swap to bring an underlying object to the top.

1. Select the objects to be swapped.

2. Select Selected → Swap.

Duplicating Annotation Objects

Use Duplicate to duplicate existing Annotation objects instead of re-creating them.

1. Select the objects to be duplicated. 

2. Select Selected → Duplicate.

3. Position the duplicate objects by dragging the handle to the desired location 
with the left mouse button. 

Deleting Annotation Objects

To delete selected objects:

• Select Selected → Delete. 

To delete all of the annotation objects within the image:

• Select Selected → Delete All.
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Undoing Annotation Changes

To undo the changes made to a selected objects:

• Select Selected → Undo.

The undo applies only to the last change made. After a new change is applied, 
selecting Undo applies to the latest change, etc.

Mirroring Annotation

Use mirroring with rectangles, ellipses, polygons, and polylines only. It is primarily 
designed for you to build custom filters for FFT filtering (see “Defining FFT Filters” 
on page 738).

To mirror shapes and polygons around the center of the image:

• Select Options → Turn Mirror On.

To turn off the mirroring:

• Select Options → Turn Mirror Off.

Showing Object Corners

Use object corners to make it easier to include corners in the selection box while in 
Selection mode. Object corners can be shown around all annotation objects except the 
vectors (rectangle, ellipse, polygon, polyline, and arrow). The corners are plotted as 
small asterisks around the annotation object.

To show object corners:

• Select Options → Show Object Corners.

To hide object corners:

• Select Options → Hide Object Corners.
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Managing Annotation Files

Use the File menu in the Annotation dialog to save and restore annotation files.

Saving Annotations to Files

1. In the Annotation dialog, select File → Save Annotation.

2. When the new dialog appears, enter the output file name in the text box, or 
click Choose and enter or select a filename. 

3. Select OK to save the annotation to an output file. 

Annotation files are saved with the file extension .ann for consistency, unless 
changed to other extensions at your discretion.

Restoring Saved Annotation Files

1. Select File → Restore Annotation.

2. When the file selection window appears with all .ann files listed by default, 
select the appropriate annotation file. ENVI loads and displays the selected 
file.

Hiding the Annotation Dialog

To hide or show the Annotation dialog without erasing your annotations, see 
“Showing and Hiding Overlay Dialogs and Layers” on page 239.

Closing the Annotation Dialog

To close the annotation dialog and remove all the annotation objects from the display:

• Select File → Cancel.

If the annotations in the display have not been saved, an ENVI question dialog 
appears asking you if you want to save the file.
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Overlaying Classes

Use Classification to overlay classes on a grayscale or color image in a display 
window, control which classes are displayed, collect statistics, edit the class colors 
and names, merge classes, and edit classes by adding, deleting, or moving pixels 
between classes.

Note
A classification image must be generated prior to using this function (see Chapter 6, 
“Classification”).

1. In the display window of the image you want to overlay the classification 
results on, select Overlay → Classification. The Interactive Class Tool dialog 
appears. It lists all the classes and shows their colors and names. The active 
class is displayed at the top of the dialog. The active class is the class to which 
any operations (i.e., statistics, editing) are applied.

2. Select from the following options to edit and apply classes to your image.

• To resize the dialog, click on a corner and drag.

• To change the active class, click on the colored box next to the class name. 

Figure 4-14: The Interactive Class Tool Dialog
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• To display a class on the image click in the On check box next to the class 
name. Any number of classes can be displayed at once.

• To turn on and display a single class while turning all others off, double-
click with the left mouse button on the colored box next to class to be 
displayed. 

• To turn it off and display all the other classes, double-click with the left 
mouse button on that class again.

• To turn all classes off, click the right mouse button on a colored box. 

• To turn all the classes on, click again with the right mouse button on any 
colored box.

Editing Classes

Use the Edit menu to edit classes by adding, deleting, or moving pixels between 
classes and by drawing polygons, rectangles, or ellipses.

Tip
Save your changes often by selecting File → Save so if you make a mistake you 
don’t have to recreate everything!

Selecting the Active Class

In the Interactive Class Tool dialog, make sure the active class is the class you want to 
edit.

To change the active class:

• Click on the colored box next to the desired class name.

If you are editing a class:

• Choose which window to draw in by clicking on the Image, Scroll, or Zoom 
toggle button.

Setting Mouse Functions to Normal

To set the mouse button functions to normal display mode:

• Select Edit → Mode: No Editing. 
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Drawing Polygons to Add Pixels

To draw polygons in the selected image and add pixels from the polygon to the 
selected class: 

1. Select Edit → Mode: Polygon Add to Class.

2. Select the desired class to which to add pixels.

3. Draw a polygon on the image using the left mouse button.

• To close the polygon, click the right mouse button. 

• To accept the polygon, click the right mouse button again.

The new pixels change to the active class color.

Note
When moving pixels into another class, you will not see changes to the new class 
color until you turn the class on.

Drawing Polygons to Delete Pixels

To delete pixels from the active class by drawing polygons: 

1. Select Edit → Mode: Polygon Delete from Class.

2. Select Edit → Set delete class value. 

3. In the dialog, select a class to which the deleted pixels will be assigned.

4. Draw polygons on the image to remove those pixels from the active class.

Setting Polygon Colors

The drawing color is the color used to outline your polygon while drawing. It is not 
the color the polygon is filled with once it is set. The fill color is the color defined for 
the class.

To set the drawing color of a polygon: 

1. Select Edit → Set polygon draw color.

2. From the Polygon Color menu button, select a color.

3. Click OK.
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Selecting Polygon Types

To select what type of polygon you draw:

• Select Edit → Polygon Type: the desired type.

Saving Changes

To save changes:

• Select File → Save.

Undoing Class Changes

To undo all unsaved changes: 

1. Select Edit → Undo Changes.

2. In the question dialog, click Yes.

Class Options

Use the Options menu to obtain statistics for classes and to change class colors and 
names.

Viewing Class Distributions

To produce a report showing the number of pixels and percentage of pixels in each 
class, select Options → Class distributions. 

The report is processed and displayed in the Classification Distribution window. The 
report is automatically updated as pixels are added or removed from classes during 
editing.

Editing Class Names and Colors

To change class colors and/or class names, select Options → Edit class 
colors/names. 

The Class Color Map Editing dialog appears. See “Mapping Class Colors” on 
page 407 for detailed instructions.
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Merging Classes

To merge one or more classes into a selected base class:

1. In the Interactive Class Tool dialog, select Options → Merge classes.

The Interactive Merge Classes dialog box appears.

2. Select the base class by clicking on the desired class name.

3. Select the classes to merge into the base class by clicking on the desired class 
names.

4. Click OK.

The next time you open the Class Distributions dialog, it will be updated.

Plotting Mean Spectra 

To plot a mean spectrum for the active class:

• Select Options → Mean for active class. If the Input File Associated with 
Classification Image dialog appears, select the input file to calculate the 
statistics from and click OK. The dialog appears only if an input file hasn’t 
been set previously.

To plot the mean spectrum for all classes:

• Select Options → Mean for all classes. 

ENVI computes the statistics and displays the mean spectra in a Class Means plot 
window.

Plotting Statistics

To plot the statistics for the active class:

• Select Options → Stats for active class. If the Input File Associated with 
Classification Image dialog appears, select the input file to calculate the 
statistics from. The dialog appears only if an input file hasn’t been set 
previously.
ENVI User’s Guide Overlaying Classes



270 Chapter 4: Interactive Display Functions
To plot the statistics for all classes:

• Select Options → Stats for all classes. ENVI computes the statistics and 
displays a plot window. The mean spectrum is in white, the +/– one standard 
deviation is in green, and the minimum and maximum spectra are in red.

Tip
To get a text report and more detailed statistics for your classes, select 
Classification → Post Classification → Class Statistics.

Changing the Statistics File

To change the statistics data file associated with the statistics: 

1. Select Options → Associated stats data file.

2. In the Input File Associated with Classification Image dialog, select the 
filename. Click OK.

Setting Class Transparency

To set a class transparency factor that allows the underlying image to show through 
the overlying classes perform the following steps.

Note
This option is only available in 24-bit color mode.

1. Select Options → Class Transparency.

2. Enter a transparency factor and click OK.

A transparency factor of 0 allows no underlying image to show through the classes; 
the classes are opaque. A transparency factor of 100 shows only the underlying image 
with no overlying classes. A transparency factor of 50 shows half underlying image 
and half overlying classes.
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Saving Classification Images

1. In the Interactive Class Tool dialog, select File → Save Changes to File.

Note
Selecting Yes in the next step will write over the existing classification file.

2. In the question dialog, click Yes.

The current filename is written over by the changed file.

Saving Classification Displays as Images

To output the image with the classes overlaid:

• Select File → Save Image As → the desired output.

To print the image with the classes overlaid:

• Select File → Print.

Note
Only the classes that are turned on appear in the output. 

The classification overlay will be listed in the Graphics Overlay Selections list of 
the Change Graphics Overlay Options dialog as <Displayed Class Overlay>. For 
more information, see “Setting Graphics Overlay Options” on page 455.

Hiding the Interactive Class Tool

To hide or show the Interactive Class Tool dialog without erasing your classes, see 
“Showing and Hiding Overlay Dialogs and Layers” on page 239.

Closing the Interactive Class Tool

To close the Interactive Class Tool and quit the function:

• Select File → Cancel. 
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Plotting Contour Lines

Use the Contour Lines option to overlay contour lines on an image. You can 
generate contour lines from a displayed image or from a different image. For 
example, you can extract contour lines from a digital elevation model and overlay 
them on another co-registered displayed image.

1. From the Display menu bar, select Overlay → Contour Lines.

2. When the Input Contour Band dialog appears, click on the band from which 
the contours will be generated.

Note
Only bands that are the same size as the displayed image are available.

3. Once the contour source image has been defined, the #n Contour Plot dialog 
appears (where n is the originating display number). Eight default contour 
levels are listed under Defined Contour Levels. These levels are defined using 
a minimum and maximum data value calculated using the Scroll window and 
shown in the Min and Max text boxes. 

Figure 4-15: DEM Contours Overlain on a Landsat TM Image
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4. Enter the desired minimum and maximum values in the appropriate text boxes. 

Note
Clicking Reset returns the range to its initial values.

5. Next to the Window label, select the Image and/or Scroll check boxes to 
designate the window where the contours will be plotted. 

6. Click Apply to plot the contours.

Editing Contour Levels

To edit individual contour levels perform the following steps.

1. In the Contour Plot dialog, click on a specific contour in the Defined 
Contours Levels list.

2. Click Edit Level.

3. Change the value to be contoured by entering the desired value in the Level 
text box. 

Figure 4-16: The Display Contour Plot Dialog
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4. Assign a label to be plotted with the contour by entering the desired text in the 
Label text box. 

5. Specify the color for the selected contour, the line style, and the thickness by 
choosing the desired parameter and changing the value. 

6. Click OK to make the changes to the levels in the Defined Contour Levels 
list.

7. Click Apply to replot the contours on the image.

To add new levels or set default levels, see “Contour Level Options” on page 274.

Removing Levels 

To remove a level from the Defined Contours List: 

1. Click on a specific contour level to select it. 

2. Click Delete Level.

3. Click Apply to replot the contours. 

Clearing Levels

To clear all the levels from the Defined Contours List, click Clear Levels. 

Contour Level Options

Use the Options pull-down menu to add new levels, set default levels, and change the 
contour band.

Contour Overlay Labeling

You can label all of the contour lines overlaid on a DEM with a simple procedure:

1. In the menu of a DEM display, select Overlay → Contour Lines. 

2. When the Contour Plot dialog appears, select Options → Label Contours 
with Level Value.

3. Click Apply.

Each contour is labeled with its elevation value, and the labels are added to the image 
display.
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Removing Contour Labels

You can remove the contour labels by doing the following:

Warning
This action clears the labels associated with the contours. This action cannot be 
undone.

1. Select Options → Reset Contour Labels.

2. Click Apply.

Adding Contour Levels

1. In the Contour Plot dialog, select Options → Add New Levels.

2. When the Add Contour Levels dialog appears, enter an individual contour or 
ranges of contours by specifying a value in the Start Level text box.

3. Specify the increment between contours by entering a value in the Level Inc 
parameter box.

4. Enter a value in the # parameter box to specify the number of contours.

5. Select from the following steps to set the attributes of the contour.

• To change the thickness, select from the Thick menu.

• To change the line style, select from the Style menu.

Figure 4-17: Add Contour Levels Dialog
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• To change the color, select from the Color menu. 

• Click on the arrow toggle button to change the contour colors from Use 
same color for each level, which plots all the contours in the same color, 
to Increment colors for each level, which plots each contour level in a 
different color. The different colors of contour levels will follow the list of 
graphic colors. 

6. Click OK to enter the new contours into the Defined Contour Levels list. 

7. Click Apply to plot the contours.

Selecting New Contour Sources

Specify a new image from which to generate levels by selecting the New Contour 
Band option:

1. Select Options → New Contour Band.

2. When the standard ENVI file selection dialog appears, select the desired file or 
band name from which to generate the new levels.

Setting the Number of Default Levels

1. Select Options → Set Number of Default Levels.

2. Enter the desired number of default contour levels.

Applying Default Levels (Single Color)

Use Apply Default Levels (same color) to reset the Defined Contour Levels list to 
the default levels determined by the Min and Max values and the number of default 
levels. When you select this option, all levels are plotted in a single color. 

1. Select Options → Apply Default Levels (same color).

2. Click Apply to plot the contours.

Applying Default Levels (Multi Colors)

Use Apply Default Levels (multi color) to reset the Defined Contour Levels list to 
the default levels determined by the Min and Max values and the number of default 
levels. When you select this option, the contours are plotted in multiple colors: 

1. Select Options → Apply Default Levels (multi color).

2. Click Apply to plot the contours.
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Managing Contour Files

Use the File menu to save defined contour levels, restore previously saved levels, 
export the contours to ENVI Vector Files (.evf), and to close the dialog. 

Saving Contour Levels to Files

1. In the Contour Plot dialog, select File → Save Levels. 

2. Enter an output filename with the default filename extension of .lev for 
consistency. 

Restoring Saved Contour Levels

1. Select File → Restore Levels. 

2. When the standard ENVI file selection dialog appears with all files with the 
.lev extension listed by default, select the desired file name. 

Exporting Contours to ENVI Vector Files (.evf)

When exporting contour lines to an EVF file, you can export the elevation values and 
the contour labels as attributes. As attributes, they will appear in the Layer Attributes 
table for the EVF file.

1. From within the Contour Plot dialog, select File → Output Contours to 
EVFs.

2. When the Output Contours to EVF Parameters dialog appears, select from the 
following new options:

• To output the elevation values as an attribute of the EVF file, select Yes 
next to the Output Elevation as Attribute? label.

• To output the contour labels as an attribute of the EVF file, select Yes next 
to the Output Labels as Attribute? label.

The elevation values are output as double-precision numeric and the labels are output 
as text.
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The output EVFs appear in the Available Vectors List.

Note
If your file is larger than the tile size, then it is subsampled to fit within a single tile 
(see “Image Tile Size” on page 1074). For example, if your image is 2048 x 2048 
pixels and the tile size is set to 1 Mbyte, that image is subsampled to 1024 x 1024 
pixels and the contours are calculated and then output. Therefore the resolution of 
the output EVF may not be the same as the contour overlay.

Hiding the Contour Plot Dialog

To hide or show the Contour Plot dialog without erasing your contours, see “Showing 
and Hiding Overlay Dialogs and Layers” on page 239.

Closing the Contour Plot Dialog

To close the Contour Plot dialog and remove the contours from the image:

• Select File → Cancel.
Plotting Contour Lines ENVI User’s Guide



Chapter 4: Interactive Display Functions 279
Interactive Density Slicing

Use Density Slice to select data ranges and colors for highlighting areas in your 
grayscale image. The data ranges used in the density slice coloring can be from the 
displayed image or from another image of the same size.

1. From the Display menu bar, select or Overlay → Density Slice or 
Tools → Color Mapping → Density Slice. The Density Slice Band Choice 
dialog appears. It lists all of the bands that have the same spatial size as the 
image in the display window.

2. Select the band to use for the density slice data ranges by clicking on the 
bandname. The #n Density Slice dialog (where n is the display number used to 
start the function) appears with eight default ranges listed under Defined 
Density Slice Ranges. The ranges are defined using a minimum and maximum 
data value calculated from the Scroll window and shown in the Min and Max 
text boxes.

3. Enter the desired minimum and maximum values in the appropriate text boxes 
to change the density slice range. To reset the data range to the initial values, 
click Reset.

Figure 4-18: The Density Slice Dialog
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4. Select whether the density slice colors are applied to the image window, scroll 
window, or both windows by selecting the desired check boxes next to 
Windows at the bottom of the dialog.

5. Click Apply to apply the selected ranges and colors to the image.

• To remove a range from the list, select the data range and click Delete 
Range. 

• To clear the list of density slice ranges, click Clear Ranges.

Editing Data Ranges

To change the range values or color of a density slice:

1. In the Density Slice dialog, highlight a data range and click Edit Range. The 
Edit Density Slice Range dialog appears. The dialog choices are different 
depending on whether you are using a 24-bit or 8-bit display.

2. Select one of the following options:

• If you have an 8-bit display, enter the desired minimum and maximum 
values and select a color from the Colors menu. 

• If you have a 24-bit display, select RGB, HLS, or HSV as your color 
system from the System button menu. Use the slider bars or the arrow 
increment buttons to set you own color definitions.

3. Click OK to make the changes to the range in the Defined Density Slice 
Ranges list. 

4. Click Apply to apply the new ranges and colors to the image.
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Density Slice Options

Use the Options menu to add new ranges, set default ranges, and set the number of 
default ranges to be used. 

Adding Ranges

To add new ranges to the list in the Density Slice dialog: 

1. Select Options → Add New Ranges.

2. When the Add Density Slice Ranges dialog appears, enter the Range Start 
value, Range End, and Number of Ranges desired in the appropriate text 
boxes. 

3. Choose the starting color from the Colors menu. The colors of multiple ranges 
will follow the list of graphics colors. 

4. Click OK to return to the Density Slice dialog. The determined ranges are 
listed in the dialog and can be edited as desired. 

5. Click Apply to apply the density slicing colors to the image.

Changing Bands

1. In the Density Slice dialog, select Options → Change Density Slice Band. 
The Density Slice Band Choice dialog appears.

2. Change the band used for the density slice data ranges by clicking on the 
bandname.

The new density slice coloring is automatically applied.

Setting Defaults

To enter the desired number of default ranges used:

• Select Options → Set Number of Default Ranges and enter the desired 
value. 

Resetting Defaults

To reset the Defined Density Slice Ranges list to the default ranges and colors 
determined by the Min and Max values and number of set default ranges:

1. Select Options → Apply Default Ranges. 

2. Click Apply to apply these ranges and colors to the display.
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Managing Density Slice Files

Use the File pull-down menu to save density slices, restore density slices, export 
density slice ranges to vector files, or export density slice ranges to a class image.

Saving Density Slices

To save the current list of density slice ranges and colors to a file: 

1. In the Density Slice dialog, select File → Save Ranges. 

2. Enter an output filename with a default extension of .dsr for consistency. 

Restoring Saved Density Slices

To restore previously saved density slice ranges and colors: 

1. Select File → Restore Ranges.

2. Select the desired input file.

Exporting Density Slice Ranges to a Vector File

To export density slice ranges to an ENVI Vector File (.evf):

1. From the Density Slice dialog, select File → Output Ranges to EVFs. The 
Output Ranges to EVFs dialog appears. This dialog contains the following 
items.

• Select Ranges for EVFs — This list contains the possible ranges that are 
available for exporting. Highlight one or more ranges to select them for 
export.

• Select All Items and Clear All Items — These buttons allow you to select 
or deselect all the ranges in the list.
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• Output — This toggle button allows you to specify that the ranges are to 
be exported as a single vector layer (Single Layer), or as separate layers 
(One Layer per Range), one per range.

• Output Result to — These radio buttons are used to specify how the 
exported data is stored. If File is selected, the output vectors are stored on 
disk in an ENVI vector file. You must specify a filename for the saved 
output in the Enter Output Filename text box. The default file extension 
for the ENVI Vector File format is .evf. If Memory is selected, the 
output vectors are stored in memory.

2. When you are satisfied with your selections, click OK in the dialog to export 
the density slice ranges to an ENVI Vector File (.evf).

Exporting Density Slice Ranges to a Class Image

To export density slice ranges to an ENVI classification image (class image):

1. From the Density Slice dialog, select File → Output Ranges to Class Image. 
The Output Ranges to Class Image dialog appears.

2. In the following Output Result to section, choose either File or Memory. If 
File is selected, the output image is stored on disk in an ENVI image file. You 
must specify a filename for the saved output in the Enter Output Filename 
text box. If Memory is selected the output image is stored in memory.

3. When you are satisfied with your selection, click OK in the dialog to export 
the ranges to an ENVI classification image (class image).

Hiding the Density Slice Dialog

To hide or show the Density Slice dialog without erasing your color tables, see 
“Showing and Hiding Overlay Dialogs and Layers” on page 239.

Closing the Density Slice Dialog

To close the Density Slice dialog and reset the original color table:

• Select File → Cancel.
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Grid Lines

Use Grid Lines to overlay one or more grids on an image. Grids can be pixel-based 
or map-coordinate and/or latitude/longitude based (for georeferenced images). Each 
image display can have its own set of grids, which are displayed in the Main Image, 
Scroll, and Zoom windows.

Tip
Use ENVI’s QuickMap feature to quickly overlay grid lines, titles, declination 
diagrams, North arrows, and borders on georeferenced images. For details, see 
“Creating QuickMaps” on page 320.

Figure 4-19: A Pixel-based Image Grid
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Pixel-Based Image Grids

Images that have not been referenced to map coordinates can only have pixel-based 
grids. In this case, the grid spacing is specified in pixels (from (1, 1) in the upper left 
corner) and the grid lines are labeled with the pixel coordinates.

Figure 4-20:  Multiple Grid (Pixel, Map, Geographic) Coordinates on a 
Georeferenced Image
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Georeferenced Image Grids

Georeferenced images have grids that are based on map coordinates or geographic 
coordinates (latitude/longitude). The image is assumed to already be in the 
appropriate map projection prior to displaying the grid. The grid spacing is specified 
in projection units (normally meters), based on the reference pixel given in the image 
header file. The grid coordinates are labeled with the appropriate map coordinates.

Overlaying Grid Lines

1. Select Overlay → Grid Lines. The Grid Line Parameters dialog appears and 
the image is re-displayed with a virtual border if one is not already applied.

2. Select the desired check boxes next to the Window label at the bottom of the 
dialog to plot the grid lines in the Image window and/or the Scroll window.

3. To select the grids to be displayed, click the On/Off arrow toggle buttons next 
to the labels Pixel Grid, Map Grid, and Geographic Grid.

If the image is not georeferenced, then the Map and Geographic coordinate 
grids will not be available. If your image is georeferenced, both the Map and 
Geographic grids are turned on initially.

Note
To hide or show the Grid Line Parameters dialog without erasing your classes, see 
“Showing and Hiding Overlay Dialogs and Layers” on page 239.

Setting Pixel and Map Grid Spacing

Grid spacing is in number of pixels for pixel-based grids and in meters for map 
coordinate grids.

• In the Grid Line Parameters dialog, enter values into the text boxes labeled 
Grid Spacing. 

Setting Geographic Grid Spacing

1. In the Grid Line Parameters dialog, click on the DMS ↔ DD button to change 
between degrees-minutes-seconds and decimal-degrees for the geographic 
grids.

2. In the Spacing text boxes, enter the desired spacing in degrees-minutes-
seconds or decimal-degrees. 

3. Click Apply to plot the grids on the image.
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Grid Line Options

Use the Options menu in the Grid Line Parameters dialog to change the 
characteristics of all three grids and to change the display borders.

Changing Borders

To change the display borders size and color: 

1. Select Options → Set Display Borders.

2. Enter the desired border size for the left, top, right and bottom in pixels.

3. Select the desired color from the Border Color menu.

Editing Grid Characteristics

To change colors, label size and font, and other grid characteristics:

1. Within the Grid Line Parameters dialog, select Options → Edit 
Pixel/Map/Geographic Grid Attributes. 

2. When the Edit Map Attributes dialog appears, select from the following steps 
to change the characteristics of the labels, lines, box, and corners. 

• To turn on and off the plotting of the specific grid elements on the 
displayed image, toggle the On/Off arrow toggle buttons next to each 
element name.

• To plot grid labels outside the image in the virtual border, turn on Labels. 

Ticks are also placed along the edges of the image adjacent to the labels.

• To change the color, click Colors and select a color.

• To change the thickness of the label, enter a value in the Thick text box. 

• To change the font of the labels, select from the Font menu. 

• To change the size, enter a value in the Charsize text box. 

• To control the distance of the labels from the edge of the image for each 
grid type, use the Dist parameter. Larger numbers are farther from the 
edge. 

• The X-axis Labels and Y-axis Labels arrow toggle buttons toggle 
between horizontal (H) or vertical (V) display of labels for both the X and 
Y grid axes independently. 

• To plot X and Y grid lines, turn on the Lines option. 
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• To draw a Neat Line box around the image, turn on the Box option. 

• To plot tick marks at each grid intersection, turn on Corners. 

• To set the line type for the grid and box lines (solid, dotted, dashed, etc.), 
select from the Style menu. 

• To set the thickness of the items, enter the value in the Thick parameter 
box. 

3. Click OK when the grid line attributes are set. 

4. Click Apply to plot the grid lines on the image.

Managing Grid Files

Use the File pull-down menu to save and restore grid setups.

Saving Grid Parameters

To save the grid parameter settings to a file: 

1. Select File → Save Setup. 

2. When the Output Grid Parameters dialog appears, enter an output filename. 

Note
Grid setup files should be saved with the file extension .grd for consistency, 
but may be saved using other extensions. 

Restoring Saved Grid Setups

1. Select File → Restore Setup. 

2. When the file selection window appears with all .grd files listed by default, 
select the grid file.

3. Click OK.

Saving Grid Lines

See “Display Output Options” on page 446 for instructions to burn Grid Lines into 
images. The virtual border is automatically added to the image and the grid labels are 
burned in around the outside of the image.
Grid Lines ENVI User’s Guide



Chapter 4: Interactive Display Functions 289
Defining Regions of Interest

Regions of interest (ROIs) are portions of images, either selected graphically or 
selected by other means such as thresholding. The regions can be irregularly-shaped 
and are typically used to extract statistics for classification, masking, and other 
operations. ENVI allows selection of any combination of polygons, points, or vectors 
as a region of interest. Multiple regions of interest can be defined and drawn in any of 
the Main Image, Scroll, or Zoom Windows. Regions of Interest can be grown to 
adjacent pixels that fall within a specified pixel value threshold.

Figure 4-21: Polygon, Polyline, and Rectangle ROIs in the Three Display 
Windows
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Note
ROIs are explicitly related to the spatial size of the image in which they are defined. 
If you open, or have opened, images of equal spatial size with their associated ROI 
Tool dialogs, ROIs drawn in one image will be displayed in all other image displays 
of the same spatial size. You can edit or delete shared ROIs from within any of the 
ROI Tools dialogs.

1. Select one of the following options:

• From the Display menu bar of the image that you want to add ROIs to, 
select Overlay → Region of Interest or Tools → Region of Interest → 
ROI Tool.

• Make the display group of the image you want to add ROIs to active and 
select Basic Tools → Region of Interest → ROI Tool from the ENVI 
main menu.

2. The #n ROI Tool dialog appears, where n is equal to the display number.

3. Select whether ROI definition will take place in the Main Image window, the 
Scroll window, or the Zoom window of the selected display by selecting the 
Image, Scroll, or Zoom toggle button.

4. Draw ROIs as described in “Drawing ROIs” on page 291.

You can also add, edit, and create additional ROIs as described in the following 
sections.

Figure 4-22: The ROI Tool Dialog
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Turning off ROI Definition

When the ROI Definition function is enabled, actions such as zooming, panning and 
other display operations are not enabled. 

To enable these interactive mouse operated functions without leaving ROI Definition, 
click the Off toggle button in the ROI Tool dialog.

Drawing ROIs

The following ROI types are available in ENVI:

• Polygon

• Polyline

• Point

• Rectangle

• Ellipse

• Multi-Part (donut)

A single region can contain any combination of the six ROI types. Each type has a 
different set of mouse button assignments.

The mouse assignments and drawing options are explained in the following sections 
and summarized in the following table.

ROI Type Action Mouse 
Button Interaction

Polygon or 
Polyline

Define endpoints Left Click or Press and drag

Remove last endpoint Middle Click

Delete entire 
polygon/polyline

Middle Click on defined 
polygon/polyline

Close polygon or end 
polyline

Right Click

Accept polygon or 
polyline

Right Click

Table 4-4: ROI Mouse Operations
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Note
If you have multiple images of the same size displayed and their associated ROI 
Tools dialogs open at the same time, any ROIs drawn in one image display will also 
be displayed in the others.

Drawing Polygons

The polygon mode is the default method for ROI definition. Use polygons to outline a 
region of interest with connected line segments.

1. In the ROI Tool dialog, select ROI_Type → Polygon.

2. Click the left mouse button in the active window to establish an initial endpoint 
for an outlining segment. As the mouse is moved to select another endpoint, a 
line is shown to exactly indicate the position of the current segment. 

3. Click the left mouse button again to define the segment, which is drawn in the 
selected color. 

Note
For continuous drawing, hold the left mouse button down and move the 
cursor.

Point Select point Left Click on pixel

Delete point Middle Click on pixel

Delete all points in ROI Right Click

Rectangle or 
Ellipse

Define shape Left Press and drag

Delete shape Middle Click within shape

Accept shape Right Click

Multi Part Accept multi part ROI Right Click three times after 
the ROI_Type → Multi 
Part: On option is set.

ROI Type Action Mouse 
Button Interaction

Table 4-4: ROI Mouse Operations (Continued)
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4. Choose additional segments in the same manner until the entire region of 
interest is outlined. 

Note
To erase the last segment defined at any point during the segment selection 
process, click the middle mouse button.

5. Click the right mouse button to draw the last segment and automatically close 
the polygon.

6. Move the polygon to the desired location by clicking on the diamond-shaped 
handle and dragging with the left mouse button. 

7. Click the right mouse button to accept the polygon. As the polygon is 
completed, the total number of pixels contained in the ROI is listed in the ROI 
Tool table (along with other ROI properties). For more information on the ROI 
Tool table, see “Editing ROI Attributes” on page 296.

Note
You may draw multiple polygons for each ROI. Each successive polygon is 
drawn as above and its pixels added to the total for the region. When 
completed, the polygon is filled with a solid color by default.

8. To delete entire polygons from the ROI at any time, click the middle mouse 
button while the cursor is on the desired polygon.

9. When you are satisfied with the new ROI, select File → Cancel to dismiss the 
ROI Tool dialog or click the New Region button to define another region of 
interest.

Drawing Polylines

The polyline mode is similar to the polygon mode except that a multi-segment vector 
is drawn rather than a closed polygon. The regions enclosed by the defined line 
segments are not selected and filled upon completion. Only the pixels comprising the 
line segments themselves are selected.

1. In the ROI Tool dialog, select ROI_Type → Polyline.

2. Click the left mouse button to define the endpoints of connected line segments. 

• To remove the previous segment, click the middle mouse button.

• For continuous drawing hold down the left mouse button while drawing.

3. Click the right mouse button to end the process of defining a polyline. 
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4. Use the handle on the polyline to move the line.

Note
To erase the entire polyline, click the middle mouse button on any pixel of a 
previously-defined polyline.

5. Click the right mouse button to accept the polyline. 

6. When you are satisfied with the new ROI, select File → Cancel to dismiss the 
ROI Tool dialog or click the New Region button to define another region of 
interest.

Drawing Points

Use the point mode to select or delete individual pixels under the cursor. 

Tip
For best results, add Point ROIs in the Zoom window.

1. In the ROI Tool dialog, select ROI_Type → Point.

2. Click the left mouse button to add the pixel currently under the cursor to the 
ROI. 

• To delete a previously-selected pixel (currently under the cursor) from the 
ROI, click the middle mouse button.

• To delete all pixels in the currently-selected point mode ROI, click the 
right mouse button.

3. When you are satisfied with the new ROI, select File → Cancel to dismiss the 
ROI Tool dialog or click the New Region button to define another region of 
interest.

Drawing Rectangles and Ellipses

Use the rectangle and ellipse modes to draw rectangles and ellipses as ROIs.

1. In the ROI Tool dialog, select ROI_Type → Rectangle or Ellipse.

2. Click the left mouse button and drag the cursor to the desired size of the 
rectangle or the ellipse. 

Note
To draw a square or circle, click and drag while holding the middle mouse 
button. 
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3. Grab the diamond-shaped handle in the rectangle or ellipse and move the shape 
to the desired location. 

Note
To delete the shape, click the middle mouse button on the rectangle or ellipse. 

4. Click the right mouse button to accept the shape into the ROI.

5. When you are satisfied with the new ROI, select File → Cancel to dismiss the 
ROI Tool dialog or click the New Region button to define another region of 
interest.

Drawing Multi Part ROIs

Use multi part mode to draw ROIs with holes in them, or donut ROIs.

1. Select ROI_Type → Polygon, Rectangle, or Ellipse.

Note
You cannot draw Multi Part ROIs using point or polyline ROIs.

2. Select ROI_Type → Multi Part:On.

3. Draw the base ROI using the drawing methods for the specific ROI type as 
described in the previous sections.

Note
The ROI does not become filled in until you click the right mouse button a 
second time.

4. Draw any number of additional ROIs or parts within the first ROI to create 
holes. Again, the ROIs do not become filled in when you click the right mouse 
button the second time.

Note
Holes cannot cross the path of any other polygon within its group.

5. After adding parts to the ROI, click the right mouse button a third time to 
accept the multi part ROI.

The base ROI becomes filled in, and the parts are removed to reveal holes in the base 
ROI.
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Editing ROI Attributes

You can view or edit any ROI properties with the Available Regions of Interest table 
in the ROI Tool dialog. The table contains the following columns:

• Current Selection — This column uses an asterisk to signify the currently 
active ROI. You can specify the currently active ROI in this column by clicking 
in the cell of the desired ROI’s row.

• ROI Name — This column contains the name of each ROI. The ROI names 
can be edited by clicking in the cells of this column.

• Color — This column contains the color assigned to each ROI. You can use 
any of the following methods to change the color of an ROI.

• Right-click in its cell to display the color shortcut menu.

• Left-click in its cell to enter a valid ENVI graphics color name. All of the 
valid color names are provided in the color shortcut menu. If the color 
entered in the cell is not valid, it is replaced by a default color.

• Left-click in its cell to enter an RGB triplet (such as 255, 0, 0 for red). If an 
RGB triplet is provided, the closest valid ENVI graphics color is used.

You can also set the default ENVI colors for all the ROIs by right-clicking in 
the Color column title and selecting the Assign default colors option from the 
resulting shortcut menu. This shortcut menu can also be used to set all the 
ROIs to the same color.

• Pixels — This column displays the total number of image pixels for each ROI. 
The values in this column cannot be edited.

• Polygons, Polylines, and Points — These columns display the total number of 
ROI types and the number of pixels in each ROI type. The values in these 
columns cannot be edited.
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• Fill — This column specifies the fill pattern for each polygon ROI. You can 
change the fill pattern of a polygon ROI by right-clicking in the cell of the fill 
pattern to be changed. This action displays the fill pattern shortcut menu. You 
can set the same fill pattern for all of the polygon ROIs by right-clicking in the 
column title.

• Orien and Space — These columns display the orientation and spacing of 
stripes in non-solid filled polygon ROIs. If the fill pattern for polygon ROIs 
exists and is non-solid, you can change these values by right-clicking in these 
cells to display their shortcut menus. You can set the same value for all of the 
non-solid filled polygon ROIs by right-clicking in the column title for each 
property.

Creating New Regions

You can draw multiple regions of interest in any image display window. 

Note
If you have multiple images of the same size displayed and their associated ROI 
Tools dialogs open at the same time, any ROIs drawn in one image display will also 
be displayed in the others.

1. To start a new ROI, click New Region in the ROI Tool dialog. A new name 
appears in the Available Regions of Interest table. The new region uses the next 
color in the graphics colors list by default.

2. Select the ROI type and draw the ROI.

3. Edit the ROI as needed.
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ROI Options

In the ROI Tool dialog, you have many options to choose from when working with 
ROIs: inputting ASCII points into an ROI, creating multiple regions of interest, 
reporting ROI statistics, measuring distances and area, reporting the areas of the 
ROIs, loading, erasing, deleting, plotting means, merging regions, reconciling ROIs, 
and performing band thresholds to ROIs.

Note
If the ROI is displayed in more than one image (of the same spatial size), any edits 
will be reflected in all of those images.

Hiding and Showing ROIs

Hiding an ROI removes it from the display, but the region of interest is still defined.

To hide a selected ROI overlay from the selected image:

• Select one or more ROIs in the Available Regions of Interest table and then 
click Hide ROIs. To re-display these ROIs on the image, click Show ROIs. 
The Show ROIs dialog appears. This dialog enables you to select which ROIs 
are re-displayed on the image and in the table.

To hide all ROI overlays from the current display:

• Click Select All and then click Hide ROIs.

Deleting ROIs

Use the Tools menu in the Main Image display, the Delete button in the ROI Tool 
dialog, or the Basic Tools menu on the ENVI main menu to delete ROIs. 

Warning
If the ROI to be deleted is displayed in more than one image (for images of the same 
spatial size), deleting it from one deletes it from all. Once the ROIs are deleted, they 
cannot be recovered unless they have been saved to a file.

Deleting ROIs from the ROI Tool dialog

• To delete a selected ROI, select one or more ROIs in the Available Regions of 
Interest table and then click Delete.

• To delete all ROIs listed in the ROI Tool dialog and remove them from the 
system, click Select All and then click Delete.
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Note
The ROIs are deleted from all displays of the same spatial size and from their 
associated ROI Tools dialogs.

The unsaved ROIs are erased from the displays and deleted from the system. The 
ROIs do not appear in the ROI Tool dialogs after being deleted.

Deleting Saved ROIs 

To delete regions that are not currently displayed:

1. Select one of the following options:

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Delete ROIs.

• From the Display menu bar, select Tools → Region of Interest → Delete 
ROIs.

2. When the Delete Regions dialog appears, click on the names of the regions to 
be deleted.

3. Click OK to permanently delete those ROIs. 

Locating Defined ROIs

To center the zoom window over the first pixel defined in an ROI:

1. In the ROI Tool dialog, select an ROI in the Available Regions of Interest table 
and click Goto.

2. Continue clicking on Goto to move the zoom window over each pixel 
contained in that ROI.

Displaying ROI Statistics

1. In the ROI Tool dialog, select one or more ROIs in the Available Regions of 
Interest table.

2. Click the Stats button.

The ROI Statistics Results dialog appears. This dialog is very similar to the Statistics 
Results dialog (see “Producing Statistics Reports” in Chapter 5) and contains the 
same functionality. However, the ROI Statistics Results dialog also contains 
additional sections for reporting multiple instances of statistical information:
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The File pull-down menu contains the following additional options:

• Save current ROI result to ENVI stats file... — This option enables you to 
save the statistics report for the ROI specified in the Stats for section of the 
ROI Statistics Results dialog to an ENVI statistics file. When this option is 
selected, the Save Current ROI Result to ENVI Stats File dialog appears. In the 
Enter Output Stats Filename[.sta] section of this dialog, use either the text 
box or the Choose button to specify the name of the statistics file. The default 
file extension for ENVI statistics files is .sta. The statistics report is saved to 
the specified file when you click the OK button.

• Save current ROI result to text file... — This option enables you to save the 
statistics report for the ROI specified in the Stats for section of the ROI 
Statistics Results dialog to a text file. When this option is selected, the Save 
Current ROI Result to Text File dialog appears. In the Enter Output Text 
Filename[.txt] section of this dialog, use either the text box or the Choose 
button to specify the name of the text file. The statistics report is saved to the 
specified file when you click the OK button.

Tip
The resulting text file is tab-delimited for easy import into external 
spreadsheet programs, such as Excel.

• Save all ROI results to ENVI stats files... — This option enables you to save 
the statistics reports for all the ROIs to separate ENVI statistics files. When 
this option is selected, the Save All ROI Results to ENVI Stats Files dialog 
appears. In the Enter Output Root Filename section of this dialog, use either 
the text box or the Choose button to specify the root name of the statistics files. 
The default file extension for statistics files is .sta. The statistics report for 
each class or region is saved to individual files when you click the OK button. 
The individual files have the same root name that you specified and are 
appended with their appropriate ROI number.

• Save all ROI results to text file... — This option enables you to save the 
statistics report for all the ROIs to a text file. When this option is selected, the 
Save All ROI Results to Text File dialog appears. In the Enter Output Text 
Filename[.txt] section of this dialog, use either the text box or the Choose 
button to specify the name of the text file. The statistics report is saved to the 
specified file when you click the OK button.
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Tip
The resulting text file is tab-delimited for easy import into external 
spreadsheet programs, such as Excel.

This Stats for pull-down menu button contains a list of the available ROIs. The ROI 
Statistics Results dialog reports the calculated statistics (in both the plot and text 
sections) of the ROI specified by this menu. To compare statistics for different ROIs 
with the current ROI shown in the Statistics Results dialog, use the Options → Copy 
results to new window option to create a copy of the ROI Statistics Results dialog 
for the current ROI, then use the Stats for menu to display a different ROI in the 
newly created dialog.

The Select Plot pull-down button also contains the following additional options:

• Mean for all ROIs — This option displays a plot of the means of all the ROIs.

• Stdev for all ROIs — This option displays a plot of the standard deviations of 
all the ROIs.

• Eigenvalues for all ROIs — This option displays a plot of the eigenvalues of 
all the ROIs.

• Histogram for all ROIs — This option and its submenu display a plot of the 
histogram of all ROIs for a chosen band of data.

Displaying ROI Statistics for All Regions

To display the statistics for all defined regions of interest, choose Select All and then 
click Stats in the ROI Tool dialog. An ROI Statistics Results dialog containing the 
statistics for all the ROIs appears.

Growing ROIs

You can grow regions of interest to neighboring pixels using a specified threshold. 
The threshold is determined by specifying a number of standard deviations away 
from the mean of the drawn region. You can use either 4 or 8 neighboring pixels to 
determine the growth pattern. It is calculated using the displayed band for a grayscale 
display, or the red band for a color display. 

Note
All grown regions of interest are output as points, regardless of the starting ROI 
type.

1. In the Available Regions of Interest list, click on the name of the ROI to be 
grown.
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Note
Within the current image window, neighboring pixels that fall within the 
standard deviation threshold will be included in the grown region. Adjacent 
pixels outside the current image window, regardless of pixel value, will not 
be included in the ROI.

2. Click the Grow button. The new grown ROI is shown in the display window. A 
prompt asks if you want to keep the resulting grown ROI.

3. Select Yes to grow the ROI with all of the points shown. Select No to return the 
ROI to its original size. If No is selected, the Region Growing dialog appears.

• In the Region Growing dialog, change the values of the standard deviation 
multiplier and the number of neighbors, if desired, and click OK to grow 
the ROI with the new parameters.

• Click on Cancel in the Region Growing dialog to exit the growing option 
without changing the original ROI.

Converting Shape-Based ROIs to Raster

Use the Pixel button to convert polygons, ellipses, rectangles, and polylines to a 
collection of editable points. This allows you to remove single points from polygons, 
rectangles, etc.

1. Draw a polygon or other ROI shape, or select an existing ROI to be converted 
into a collection of points.

2. Click the Pixel button in the ROI Tool dialog.

3. Select ROI_Type → Point from the ROI Tool dialog menu bar.

You can now edit individual pixels within the ROI using standard point editing 
techniques with the mouse.

Inputting ASCII Data into ROIs

You can input ASCII data points into a new or an existing ROI, select the ROI type, 
and select the associated map projection information if needed.

Tip
To input the ASCII data points into a new region, click New Region before 
completing the following procedure.

1. In the ROI Tool dialog, select ROI_Type → Input Points from ASCII.
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2. When the Enter ASCII Points Filename dialog appears, select an input ASCII 
filename.

3. When the Input ASCII File dialog appears, enter the column numbers for the X 
and Y point coordinates.

4. Select the type of ROI that the points define by clicking on the button menu 
next to the These points comprise label.

Note
For polygon and polyline ROIs, the ASCII points define the vertices of the 
ROI.

5. Select whether the input coordinates are Pixel Based or Map Based.

Note
If you select Map Based, select the projection type and enter the zone and 
datum information as necessary by clicking on the Zone... and Datum... 
buttons.

6. Click OK.

Loading all Regions

To load all regions currently defined for all images with the same spatial dimensions 
as the currently selected display as shown in the Display # field, select Options → 
Load All Regions. 

Merging Regions

To merge multiple defined regions of interest into one:

1. Select Options → Merge Regions.

The Merge ROIs dialog appears with two lists of all defined regions. 

2. Under Choose Base ROI to Merge, click on the name of a region.

3. Under the Choose ROIs to Merge list, select the names of the regions to 
merge into the base region.
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4. Click the arrow toggle button next to Delete Merged ROIs? label to select 
whether or not you want the individual regions being merged to be deleted 
after they are merged. The color of the other ROIs change to that of the base 
ROI and the other names are removed from the Available Regions of Interest 
list.

5. Click OK.

Intersecting Regions

Use Intersect Regions to create a point type region of interest that contains only the 
points where two or more ROIs intersect in an image.

1. In the ROI Tool dialog, select Options → Intersect Regions.

2. In the ROI Intersection dialog, click on the names of the intersecting ROIs to 
be included in the new ROI, then click OK.

Note
In the ROI Intersection dialog, only select regions that intersect. If a non-
intersecting ROI is selected, an error will occur.

The new ROI appears in the Available Regions of Interest list. It is a point type 
ROI and is displayed under any overlying polygon ROIs.

Tip
If you can’t see the new point ROI in the image display, erase all other ROIs and re-
display the new ROI.

Note
You can calculate ROI intersections on-the-fly and use them when building a mask. 
For more information, see “Including ROI Intersections” on page 531.
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Reporting ROI Areas

To get a report of the area covered by each ROI in one of these units: meters, 
kilometers, feet, yards, miles or nautical miles:

1. In the ROI Tool dialog, select Options → Report Area of ROIs → desired 
units.

2. If the pixel size of the image is not stored in the header, a dialog will appear. 
Enter the X and Y pixel size in meters. 

The ROI Area Info dialog appears, listing each ROI name and corresponding area. To 
save ROI Area Information to an ASCII File, perform the following steps.

1. In the ROI Area Info dialog, select File → Save Text to ASCII.

2. Enter a filename.

Reporting ROI Measurements

Use the ROI Measurement Tool to produce a report on the distance between points in 
a polygon or polyline, and to get perimeter and area measures for polygons, 
rectangles, and ellipses. 

Note
To take measurements of an image without using the ROI functions, see “Using the 
Measurement Tool” on page 497.

Figure 4-23: The ROI Measurement Report Dialog
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1. In the ROI Tool dialog, select Options → Measurement Report. The ROI 
Measurement Report dialog appears with the measurements reported. The 
measurements differ depending on the active ROI type. 

2. Draw the ROIs as described in “Drawing ROIs” on page 291 for specific ROI 
types. 

• For Polygon mode, the distance between the vertices are listed and the 
perimeter and total area are reported when the polygon is closed. 

• For Polylines, the distance between the vertices are listed and the total 
distance is given when the polyline is completed.

• No distance measures are given when in Point mode.

• In Rectangle mode, the lengths of the sides, the perimeter, and total area 
are reported.

• In Ellipse mode, the circumference and total area are reported.

Selecting Measurement Units

In the ROI Measurement Report dialog, use the Units menu to select the unit the ROI 
is measured in. The choices are pixels, meters, kilometers, feet, yards, miles, and 
nautical miles.

1. Select Units → the desired unit.

2. If the pixel size of the image is not stored in the header, and you select any unit 
except pixel, complete these steps when the Input Display Pixel Size dialog 
box appears.

A. In the X Pixel Size and Y Pixel Size text boxes, type the size of the pixels 
in your image. 

B. From the Units button menu, select the unit type. Click OK.

Measuring ROI Area

In the ROI Measurement Report dialog, use the Area menu to measure the area of the 
ROI in acres, hectares, or units2 (e.g., meters2).

• Select Area → Acres or Hectares.

ROI Measurement Options

In the ROI Measurement Report dialog, use the Options menu to select whether the 
measurement information is reported as line segments (the default) or as point 
coordinates.
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To get a listing of the vertices coordinates:

• Select Options → Report as Points. The coordinates will be reported as a 
pixel location (Pixel (x,y)).

To get a listing of the line segment distances:

• Select Options → Report as Segments.

For images that are georeferenced, you may list the coordinates as map coordinates or 
as latitude and longitude coordinates by selecting Options → Georef Map (x,y) or 
Georef (Lat/Lon).

To output the list of coordinates to a file:

• Select File → Save Points to ASCII.

Saving Measurement Reports

In the ROI Measurement Report dialog, use the File menu to save the ROI 
measurement report to an ASCII file and to close the dialog.

To save the measurement report:

1. In the ROI Measurement Report dialog, select File → Save Points to ASCII.

2. Enter an output filename.

Reconciling ROIs

In the ROI Tool dialog, use Reconcile ROIs to apply ROIs defined in one image size 
to different sized images.

Note
Using Reconcile ROIs, ROIs can only be reconciled to images with the same pixel 
size as the original image. To reconcile ROIs to an image with a different pixel size, 
use Reconcile ROIs via Map.

1. Select one of the following options:

• In the ROI Tool dialog, select Options → Reconcile ROIs.

• From the Display menu bar, select Tools → Region of Interest → 
Reconcile ROIs.
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• From the ENVI main menu, select Basic Tools → Region of Interest → 
Reconcile ROIs.

2. When the Reconcile ROIs Parameters dialog appears, choose the ROIs to be 
reconciled by selecting from the following options:

3. To manually designate the spatial dimensions for the new ROIs:

A. Enter the difference in pixels between the origin of the image where the 
ROIs were drawn and the origin of the new image into the xoffset and 
yoffset text boxes.

B. Enter the number of samples and lines in the new image into the 
appropriate text boxes.

4. To have ENVI calculate the x and y offsets and the number of samples and 
lines automatically:

A. Click Set Values from Source/Destination Files.

B. When the file selection dialog appears, choose the file where the ROI was 
originally drawn and click OK.

C. When the next file selection dialog appears, select a destination file for the 
ROIs and click OK.

Figure 4-24: The Reconcile ROIs Parameters Dialog
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5. In the Reconcile ROIs Parameters dialog, click OK.

The ROIs are listed in the ROI Tool dialog and are automatically loaded onto the new 
image.

Reconciling ROIs via Map

Use Reconcile ROIs via Map to use ROIs defined in one georeferenced image in 
another overlapping georeferenced image, regardless of differences in image or pixel 
sizes between the two images.

1. Select one of the following options:

• In the ROI Tool dialog, select Options → Reconcile ROIs via Map.

• From the Display menu bar, select Tools → Region of Interest → 
Reconcile ROIs via Map.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Reconcile ROIs via Map.

2. When the Reconcile ROIs via Map Parameters dialog appears, select the 
desired ROIs by clicking on the names.

3. Click OK.

4. Select the georeferenced file to which you want the ROIs reconciled and click 
OK.

The ROIs are listed in the ROI Tool dialog and automatically loaded onto the new 
image.

Converting Band Values to ROIs

Use Band Threshold to ROI to convert specific image values and ranges of values to 
Regions of Interest. 

1. Select one of the following options:

• In the ROI Tool dialog, select Options → Band Threshold to ROI.

• From the Display menu bar, select Tools → Region of Interest → Band 
Threshold to ROI.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Band Threshold to ROI.

2. When the Band Threshold to ROI Input Band dialog appears, select a band to 
threshold. 
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3. When the Band Threshold to ROI Parameters dialog appears, select from the 
following options.

• To make an ROI using those pixels greater than or equal to the entered 
minimum value, enter only the Min Thresh Value. 

• To select those pixels less than or equal to the entered maximum value, 
enter only the Max Thresh Value.

• To select pixels that fall within a specified range of values, enter both a 
minimum and a maximum threshold value.

• To assign an ROI name, edit the ROI Name text entry. 

• To change the color of the ROI, select the desired color from ROI Color 
menu. 

4. Click OK to extract the thresholded pixels. A warning dialog appears and list 
the number of pixels that satisfy the threshold criteria. 

5. Click OK to accept and load the ROI.

The region is listed in the ROI Tool dialog as a Thresh Bandname, where Bandname 
is the name of the band used to extract the ROI. The number of pixels in the region 
are also listed.

Calculating Buffer Zone Images for ROIs

Use Calculate Buffer Zone to calculate a buffer zone image from the original image. 
In the resulting buffer zone image, every pixel has a floating point or integer value 
that is defined as the distance from that pixel to the nearest pixel of the selected ROI. 
You designate a maximum distance value and the result is that any pixels with a 
distance larger than that value are set to the maximum distance value +1. 

1. In the ROI Tool dialog, select Options → Calculate Buffer Zone. The Buffer 
Zone Image Parameters dialog appears.

Note
If the image has more than one ROI associated with it, the Input Buffer Zone 
ROIs dialog appears. Click on the names of the ROIs to be included in the 
buffer zone image calculation and click OK.

Note
If you select more than one ROI, the distance calculated will be from the 
pixel to the nearest selected ROI.
Defining Regions of Interest ENVI User’s Guide



Chapter 4: Interactive Display Functions 311
2. Click the Maximum Distance arrow increment buttons to set the maximum 
distance to measure, or type the value (in pixels) into the corresponding text 
box.

Note
Any pixels with a distance larger than this value will be set to the maximum 
distance value +1. 

3. From the Distance Kernel button menu, select either Floating Point or 
Integer output.

4. Select output to File or Memory.

5. Click OK.

Creating Class Images from ROIs

Use Create Class Image from ROIs to convert selected ROIs into an ENVI 
classification image. The class colors will be the same as the ROI colors.

1. Select one of the following options:

• From the Display menu bar, select Tools → Regions of Interest → Create 
Class Image from ROIs.

• In the ROI Tools dialog, select Options → Create Class Image from 
ROIs.

• From the ENVI main menu, select Classification → Create Class Image 
from ROIs.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Create Class Image from ROIs.

2. The Classification Image from ROIs dialog appears.

3. In the list of ROIs, select the ROIs to use by clicking on the ROI names.

4. Click OK. The Classification Image from ROIs Parameters dialog appears.

Note
To change the output classification image DN (Digital Number) value of an 
ROI, click on the ROI and use the arrow toggle buttons to enter a new DN 
value.

5. Enter an output filename and click OK.

The resulting classification image filename appears in the Available Bands List.
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Computing ROI Separability

The Compute ROI Separability option computes the spectral separability between 
selected ROI pairs for a given input file. Both the Jeffries-Matusita and Transformed 
Divergence separability measures are reported. These values range from 0 to 2.0 and 
indicate how well the selected ROI pairs are statistically separate. Values greater than 
1.9 indicate that the ROI pairs have good separability. For ROI pairs with lower 
separability values, you should attempt to improve the separability by editing the 
ROIs or by selecting new ROIs. For ROI pairs with very low separability values (less 
than 1), you might want to combine them into a single ROI. For more information, 
see the following reference:

J.A. Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, 
Berlin, p. 240.

The following steps show how you can use the Compute ROI Separability option to 
compute the spectral separability between selected ROI pairs.

1. Select one of the following options:

• In the ROI Tools dialog, select Options → Compute ROI Separability.

• From the Display menu bar, select Tools → Regions of Interest → 
Compute ROI Separability.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Compute ROI Separability.

2. When the file selection dialog appears, select the input file and perform any 
spectral subsetting. The ROI Separability Calculation dialog appears.

3. In the dialog, select ROIs for the separability calculation.

4. Click OK. The separabilities are calculated and reported in a report dialog. 
Both the Jeffries-Matusita and Transformed Divergence values are reported for 
every ROI pair. The bottom of the report shows the ROI pair separability 
values listed from the least separable pair to the most separable. 

5. To save the report to an ASCII file, select File → Save Text to ASCII.
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Managing ROI Files

Use the File menu in the ROI Tool dialog to save and restore ROI information to an 
ENVI ROI file (default file extension .roi) and to export ROIs to ENVI vector files 
(.evf).

Saving ROIs to Files

To save regions of interest currently in memory to a file:

1. Select one of the following options:

• In the ROI Tool dialog, select File → Save ROIs. 

• From the Display menu bar, select Tools → Region of Interest → Save 
ROIs to File.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Save ROIs to File.

2. When the Save ROIs to File dialog appears, click on the desired ROI names in 
the scrollable list with the left mouse button.

Note
Only ROIs that were defined in images with the same dimensions as those in 
the current display appear in the ROI list. ROIs of other dimensions remain in 
memory.

3. Enter a filename or choose an existing output filename (with the extension 
.roi for consistency).

4. Click OK to save the ROI file.

Restoring Saved ROIs

1. To restore all of the saved ROIs, select one of the following options:

• In the ROI Tool dialog, select File → Restore ROIs. 

• From the Display menu bar, select Tools → Region of Interest → Restore 
Saved ROI File.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Restore Saved ROI File.
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2. When the file selection dialog appears, select the ROI file.

The ROI is loaded into the display group and ROI Tool dialog of every image of the 
same spatial size.

Selecting Multiple ROIs for Restoration

You can restore multiple selected regions of interest from the Enter ROIs Filenames 
dialog when restoring saved ROIs.

1. Select one of the following options:

• In the ROI Tool dialog, select File → Restore ROIs.

• From the Display menu bar, select Tools → Region of Interest → Restore 
Saved ROI File.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Restore Saved ROI File.

2. When the file selection dialog appears, choose from the following options to 
select multiple ROIs.

• To select a group of files that are listed consecutively, click on the first file 
in the group, press and hold the Shift key, and click the last file in the 
group. Or, click and drag the cursor over the group of items with the left 
mouse button. The items are selected when they are highlighted.

• To select multiple files that are not listed consecutively, press and hold the 
Ctrl key on your keyboard and click on each desired file.

The selected ROIs are loaded into the display group and ROI Tool dialog of every 
image of the same spatial size.

Subsetting Data via ROIs

To subset an image file based on the bounding box (i.e., the area encompassing) an 
ROI or group of ROIs currently drawn on an image, follow these steps:

1. In the ROI Tool dialog, select File → Subset Data via ROIs.

2. When the Input File selection dialog appears, select the file to be subset.
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The Spatial Subset via ROI Parameters dialog appears.

Note
To apply spectral subsetting to the input file, click Spectral Subset and use 
standard ENVI methods.

3. Select the input ROIs by clicking on the ROI names.

4. Use the arrow toggle button to select whether or not to mask pixels that do not 
fall within the ROI. If you select Yes, enter a background value.

5. Select output to File or Memory. 

6. Click OK.

The resulting subsetted file is listed in the Available Bands List.

Figure 4-25: The Spatial Subset via ROI Parameters Dialog
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Exporting ROIs to ENVI Vector Files

Use Export ROIs to EVF to export ROIs to ENVI vector files (.evf). All of the 
ROIs selected are exported as separate records in a single layer. If the file associated 
with the ROI is georeferenced, the vector layer will be in the same projection. 

1. Select one of the following options:

• In the ROI Tool dialog, select File → Export ROIs to EVF. 

• From the Display menu bar, select Tools → Region of Interest → Export 
ROIs to EVF.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Export ROIs to EVF.

2. When the Export Regions to EVF dialog appears, select the desired ROIs to 
export by clicking on the ROI names. 

3. Select how ROI points should be treated—each point as a separate vector 
record or with all points as one vector record.

4. Enter the desired layer name in the Layer Name text box.

5. Select output to File or Memory.

Exporting ROIs to the n-D Visualizer

Use Export ROIs to n-D Visualizer to export selected ROIs to the n-D Visualizer so 
you can see the distribution of the points within your ROIs and between your ROIs. 
This option is very useful for checking the separability of your classes when you use 
ROIs as input into supervised classifications.

1. Select one of the following options:

• In the ROI Tools dialog, select File → Export ROIs to n-D Visualizer.

• From the ENVI main menu, select Basic Tools → Regions of Interest → 
Export ROIs to n-D Visualizer.

2. When the Select Input Data File dialog appears, select the input file that the 
ROIs are associated with and click OK. The n-D Visualizer Input ROIs dialog 
appears.

3. Select a ROI to export by clicking on the ROI name. To select all of the ROIs, 
click Select All Items.

4. Click OK. An n-D Visualizer window and n-D Controls dialog appear.

5. Click on the band numbers to select those bands for rotation.
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6. Click Start. The pixels for the selected ROIs appear in the n-D Visualizer 
window in the same colors as the ROIs. 

Note
For good classification results using these ROIs, the groups of pixels for the 
different ROIs should be separate from each other and should not overlap.

Note
If the pixels overlap, edit the groups of pixels by selecting the appropriate 
colors from the Class menu to add pixels to an ROI or by selecting White to 
remove pixels from an ROI.

7. Select Options → Export Class or Export All to export the colored pixels 
back to the ROI Tool dialog so they can be imported into classifications.

For more information and detailed instructions for the n-D Visualizer, see “The n-
Dimensional Visualizer” on page 763.

Exporting ROIs to ASCII

Use Output ROIs to ASCII to output ROIs to an ASCII text file. You can edit the 
ASCII file format prior to output by selecting the parameters to include in the file. 

You can also output map information, latitude and longitudes, and band data values 
for every ROI location. Prior to output, you can select which parameters to include in 
the ASCII file. The output is formatted into columns for easy input into spread sheets. 
For an example of an ROI ASCII file, see “Example of ASCII Output” on page 319.

1. Select one of the following options:

• In the ROI Tool dialog, select File → Output ROIs to ASCII. 

• From the Display menu bar, select Tools → Region of Interest → Output 
ROIs to ASCII.

• From the ENVI main menu, select Basic Tools → Region of Interest → 
Output ROIs to ASCII.

2. When the file selection dialog appears, select the input file and perform any 
spectral subsetting.

3. Click OK.

4. Select the ROIs to output.
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Note
To select which parameters to output, see the following section.

5. Enter or choose an output filename and click OK.

Editing ASCII Output Format

You can specify which parameters are included in the ASCII output.

1. In the Output ROIs to ASCII Parameters dialog, click the Edit Output ASCII 
Form button. The Output ROI Values to ASCII dialog appears. By default, all 
parameters are selected for output.

2. Set parameters by selecting/deselecting the corresponding check box:

• To include a label with the output, leave the Point # check box selected.

• To include the ROI location information in the output, leave the ROI 
Location check box selected. Use the ROI Location arrow toggle button 
to select whether the ROI location is output by one-dimensional locations 
or by sample/line. Pointers to each of the pixels contained in the selected 
ROIs are output to the ASCII file. The pointers are the one-dimensional 
addresses to the pixel locations in the file where a one-dimensional address 
equals the line number times the number of samples plus the sample 
number.

• To include geographic location information for georeferenced data, leave 
the Map Location check box selected. Use the Map Location arrow 
toggle button to designate output of the geographic locations in normal or 
scientific notation. Use the arrow increment buttons to set the number of 
significant digits.

• To include geographic (lat/lon) location information for georeferenced 
data, leave the Geo Location check box selected. Use the Geo Location 
arrow toggle button to designate output of the geographic locations in 
normal or scientific notation. Use the arrow increment buttons to set the 
number of significant digits.

Note
Map and Geo are not available for non-georeferenced data.

• To include the band DN values for all input bands, leave the Bands check 
box selected. Each band value will fall in its own column in the output 
ASCII file.
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Example of ASCII Output

Here is an example of ROIs output to an ASCII file:

;ENVI Output of ROIs (3.4) [Mon Apr 17 17:00:26 2000]
;Number of ROIs: 1
;File Dimension: 512 x 512
;
; ROI name: Region #1
; ROI rgb value: {255, 0, 0}
; ROI npts: 409
; ID X    Y      Map X       Map Y        Lat          Lon  B1  B2  B3  B4  B5  B6
1  179  243  282977.65  4899997.33  44.222839  -107.716970  11  10   9  46  16  10
2  180  243  283006.15  4899997.33  44.222848  -107.716614   9  10   8  47  15   7
3  178  243  282949.15  4899997.33  44.222831  -107.717327  10  10   8  48  14   8
4  178  244  282949.15  4899968.83  44.222574  -107.717315  10  10   8  48  13   6
5  179  244  282977.65  4899968.83  44.222583  -107.716959  10  11  10  46  16   8
6  177  244  282920.65  4899968.83  44.222566  -107.717671  10  10   8  47  13   6
7  180  244  283006.15  4899968.83  44.222591  -107.716602  10   9   8  48  14   6
8  181  244  283034.65  4899968.83  44.222600  -107.716246   9   9   7  48  12   6
9  182  244  283063.15  4899968.83  44.222608  -107.715889  10  10   8  47  14   7
10  183  244  283091.65  4899968.83  44.222617  -107.715533   9  10   7  49  14   6
11  184  244  283120.15  4899968.83  44.222625  -107.715177   9   9   6  50  12   4
12  176  245  282892.15  4899940.33  44.222301  -107.718016  10  10   8  47  15   8
13  177  245  282920.65  4899940.33  44.222310  -107.717660  10  10   8  46  14   8
14  178  245  282949.15  4899940.33  44.222318  -107.717303  10  10   7  48  13   6
15  179  245  282977.65  4899940.33  44.222327  -107.716947  10  10   8  47  15   8

Hiding the ROI Tool Dialog

To hide or show the ROI Tool dialog without erasing your ROIs, see “Showing and 
Hiding Overlay Dialogs and Layers” on page 239.

Closing the ROI Tool Dialog

To close the ROI Tool dialog and quit the function:

• Select File → Cancel.

Note
Newly-created regions of interest are retained in memory even after the ROI Tool 
dialog is dismissed (unless regions were specifically deleted using the Delete 
button).
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Creating QuickMaps

Use the QuickMap feature to simplify the process of creating a map product in 
ENVI. You can quickly add grid lines, scale bars, titles, north arrows, declination 
diagrams, and logos to your image to make a quick output map. Once you have set all 
of your parameters, you can save the settings as a QuickMap template that you can 
use on other images. After the output map is created, you can make additional 
changes with the Main Image interactive overlay capabilities (e.g, annotation) and 
you can output the map to Postscript or to a standard printer.

The following figure show an example QuickMap display.

Figure 4-26: A QuickMap Image
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Note
Extremely small images may result in QuickMap displays too small to 
accommodate multiple annotation objects.

1. From the Available Bands List, display a georeferenced image.

Note
To use the QuickMap feature, you must have a georeferenced image 
displayed.

2. From the Display menu bar, select File → QuickMap → New QuickMap.

3. When the QuickMap Default Layout dialog appears, enter the page size, select 
Portrait or Landscape page orientation, and enter your desired output map 
scale. 

Note
To change the map scale, enter a new value in the Scale text box, or use the 
arrow increment buttons.

4. Click OK. The QuickMap Image Selection window appears. 

5. Select from the following options to select the image subset to be used in the 
QuickMap:

• Resize and move the red box outline (drag from a corner to resize, click 
and drag the middle of the box to move).

• Enter x and y sizes, in inches, in the Image Size text boxes, or use the 
arrow increment buttons to select dimensions.

• Click the Spatial Subset button and use standard ENVI spatial subset 
methods.

Note
You cannot enlarge the red box to a size that causes the output image size to 
be larger than what will fit on the selected page size at the selected map scale.

6. Click OK.
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The #n QuickMap Parameters dialog appears, where n is the number of the associated 
display group.

Setting QuickMap Parameters

1. When the QuickMap Parameters dialog appears, select from the following 
options: 

• To add a title to the top of the map, type the text in the Main Title text box.

• To add text to the lower left or lower right corners of the map, type the text 
into the corresponding text boxes.

• To automatically load the map projection information from the ENVI 
header into either the Lower Left or Lower Right text boxes, right-click 
in the text box and select Load Projection Info.

• To change the font used for any title, select a new font from the 
corresponding button menu and enter or select the point size.

Figure 4-27: QuickMap Parameters Dialog
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• To set the justification for any title, select from the corresponding button 
menu. Center is the default.

• To change the grid line parameters (thickness, style, color, etc.), click the 
Additional Properties button.

• To add scale bars and grid lines, leave the corresponding check boxes 
selected and edit the parameters as needed.

• To add a logo and adjust its placement, click the Edit Logo Files and 
Placements button. Locate the file containing the logo (the file must 
contain three bands of byte data: red, green, and blue). Use the QuickMap 
Logo File Parameters dialog to change the logo size and position. Click 
OK to return to the QuickMap Parameters dialog.

• To add a North arrow, leave the corresponding check box selected and 
select an arrow type from the North Arrow Type button menu.

• To add a declination diagram, click the Declination Values button. In the 
Declination Diagram Values dialog, enter the values and click OK.

• To return to the QuickMap Image Selection window and edit the image 
subset or map scale, click the Change Mapping Parameters button.

2. In the QuickMap Parameters dialog, click Apply. ENVI automatically adds a 
virtual border to your QuickMap image, places your selected titles and 
annotation onto your image, and produces a map, which is displayed as a new 
standard ENVI Display Group. The QuickMap Parameters dialog remains 
open.

Note
If you added a logo, it will appear as a red box with an RGB label on the 
map, but will appear correctly when printed.

3. Use the QuickMap Parameters dialog to edit the map. Click Apply to view the 
changes.

Note
To edit the borders, add more annotation or overlay elements, or edit the 
existing map elements, use standard ENVI interactive display functions as 
described in this chapter.
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Printing QuickMaps

QuickMaps can be easily printed:

• In the QuickMap Main Image window, select File → Print, choose Output 
QuickMap to Printer or Standard Printing, and click OK.

The Output QuickMap printing will scale the output correctly for the parameters that 
you entered at the start of QuickMap. Standard printing does not take into 
consideration the page size and map scale you entered when you created the 
QuickMap.

Note
If you selected a large page size during QuickMap setup, you might first test the 
output on a small scale by using the standard printing option, then use the 
QuickMap printing option to print to a larger page.

Additional QuickMap Output Options

To output the map directly to an image or Postscript file, select the corresponding 
command from the File menu in the map Main Image window as described later in 
this chapter.

QuickMap Templates

After creating a QuickMap, you can save the parameters in a template file to be used 
on other georeferenced images of the same dimension and pixel size. 

• In the QuickMap Parameters dialog, click Save Template, enter a filename 
(ENVI will add a .qm extension), and click OK.

Note
Use QuickMap templates only on images of the same dimension and pixel 
size of the image from which the template was created.

To open and apply an existing map template:

1. From the georeferenced image, select File → QuickMap → from Previous 
Template or click the Restore Template button in the QuickMap Parameters 
dialog, and then click Apply to apply the QuickMap to the image.

To edit template parameters, see “Setting QuickMap Parameters” on page 322.
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Overlaying Vectors

Use ENVI Vector Tools to view vector data such as USGS Digital Line Graphs 
(DLG), USGS DLGs in Spatial Data Transfer Standard (SDTS) format, DXF files, 
ARC/INFO Interchange files, and Shapefiles. ENVI provides two ways of displaying 
and working with vectors: 

• Using the menu selections in the Image display group and the Vector 
Parameters dialog (shown in the following figure).

Figure 4-28: Image Display Group (left) and Vector Parameters Dialog (right)
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• Using the vectors by themselves in a Vector window with the same menu bar 
as the Vector Parameters dialog and the new shortcut menu selections (see 
“Working with the Vector Window” in Chapter 11 for more details).

Figure 4-29: The Vector Window with Menu Bar
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The method for overlaying vectors onto an image display is discussed in the sections 
that follow.

Tip
The Mouse Button Descriptions window is useful when working with vectors 
because it provides information about the function of each mouse button at any 
given cursor location. 

Use Vectors to overlay vector layers on an image, to control the appearance of the 
vectors, and to interact with the vector attributes. Also ENVI’s interactive vector 
functions can be used to edit and query attributes associated with shapefiles and to 
create your own vector files and attributes. 

Opening Vector Layers

Each image display can have its own vectors, which are displayed in the Main Image, 
Scroll, and/or Zoom windows. 

• To read vector data from disk files, see “Opening Vector Files” on page 63.

• To read USGS DLG files from tape, see “Reading USGS DLG Tapes” on 
page 150.

• To open vector layers from the Available Vectors List, see “The Available 
Vectors List” on page 212.

Working with Vector Layers

In the Main Image window, select Overlay → Vectors to bring up the Vector 
Parameters dialog. When vectors are overlaid on an image display they can be plotted 
in the Image window and/or Scroll and Zoom windows. You can use the Vector 
Parameters dialog to:

• Control the appearance of vector layers

• Add new vectors

• Export vector layer coordinates for use in image-to-map registration

• View, edit, and query vector attributes.

Vector data often consist of multiple layers of vector data.
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For example, the following figure shows that the available vector layers include 
Roads and Trails, Hydrography, Pipe & Trans Lines, and Railroads.

Selecting Image Display Windows for Vectors

When you overlay vectors on an image, they can be plotted in the Image window, 
Zoom window, and/or Scroll window. You can also edit existing vectors or add new 
vectors in any of the three display windows.

• To select which window is used for editing or adding vectors, click on the 
Window: radio button at the top of the Vector Parameters dialog for the 
desired display window type.

• To select the image display windows to plot the vectors in, click in the desired 
Image, Scroll, or Zoom check boxes at the bottom of the Vector Parameters 
dialog.

Figure 4-30: Vector Parameters Dialog
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Using Vector Options in the Shortcut Menu

Display windows with vector overlays have many options which can be accessed by 
right-clicking in the display window chosen for the overlay (Image, Scroll, or Zoom) 
and selecting from the shortcut menu that appears. The options available in the 
shortcut menu will change depending on the cursor mode selected (see “Controlling 
Cursor Modes” on page 335 for more information). 

If you have many display windows open and the Vector Parameters dialog associated 
with the current display window is hidden behind other windows, you can use the 
display window shortcut menu to find its Vector Parameters dialog and bring it to the 
front.

To do this, right-click anywhere in the display window and select <Find Vector 
Parameters> from the shortcut menu.

Figure 4-31: Display Window With Vector Overlay Shortcut Menu
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Using the Available Vector Layers List

The Available Vector Layers list in the Vector Parameters dialog contains the vector 
layers currently available for display. Use the Available Vector Layers list to interact 
with all of your individual vector layers. If your overlaid vectors are displayed in a 
Vector window, the active/available layers are viewable under the Vector window 
shortcut menu.

Selecting the Active Vector Layer

The active vector layer is the layer to which all editing or queries are performed.

To select the active vector layer from the Main Image window:

• Click the right mouse button inside the Main Image window to bring up the 
shortcut menu and select which layer is active by choosing Select Active 
Layer → desired layer name from the Main Image window shortcut menu.

To select the active vector layer from the Vector Parameter dialog:

• Click on the layer name in the Available Vector Layers list to highlight it and 
make it active.

Figure 4-32: Main Image Window Shortcut Menu for Active Layer
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Turning Layers On/Off

In the Vector Parameters dialog, an asterisk next to a layer name indicates that the 
layer is On, which means it will be plotted when the Apply button is clicked. If an 
asterisk is not next to a layer name, then the layer is Off. The default for each layer is 
On.

To turn layers on and off:

• Double-click the left mouse button on the layer name in the Available Vector 
Layer list.

Or you can use a shortcut menu to turn layers on and off:

1. Click on the layer name in the Available Vector Layers list to highlight it, and 
then right-click to bring up the shortcut menu. 

2. In the shortcut menu, use the Select Active Layer option and click on a layer 
to make it the active layer. 

3. Right-click again to bring up the shortcut menu, and select the Active Layer 
Off/On.

Setting the Current Layer Color

The color shown next to Current Layer in the Vector Parameters dialog is the color 
of the currently selected layer.

• To cycle forward through the available colors, click on the colored box with 
the middle mouse button.

• To cycle backwards through the color selections, click on the colored box with 
the left mouse button.

• To select the color from a list, click on the colored box with the right mouse 
button and select a color table from which to choose the color.

• To apply the selected color to the selected vector, click Apply.

• If your vectors are displayed in a Vector window, use Edit → Edit Layer 
Properties to change the color (see “Changing Vector Layer Display 
Properties” on page 333).
ENVI User’s Guide Overlaying Vectors



332 Chapter 4: Interactive Display Functions
Setting the Current Highlight Color

The color shown in Current Highlight box is the color that will be used to highlight 
a vector when it is clicked on in a vector attributes table (see “Vector Attributes” on 
page 346) or to highlight an existing vector when it is edited (see “Controlling Cursor 
Modes” on page 335). 

• To cycle forward through the available colors, click on the colored box with 
the middle mouse button.

• To cycle backwards through the color selections, click on the colored box with 
the left mouse button.

• To select the color from a list, click the right mouse button and select the 
desired color.

Exporting Vector Coordinates

To export the current vector cursor coordinates to the image-to-map registration 
function:

• Click the Export button in the Vector Parameters dialog.

Note
The Export button only works if the image is registered to a map.
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Changing Vector Layer Display Properties 

Use the options in the Edit Vector Layers dialog to change the appearance of vector 
layers.

1. Select Edit → Edit Layer Properties in the Vector Parameters dialog. The 
Edit Vector Layers dialog appears/

2. When the Edit Vector Layers dialog appears, select the vector to edit by 
clicking on its name in the Layer Names list.

• To edit the layer color, linestyle, and line thickness, click on the 
appropriate button menu and select from the different options.

Figure 4-33: The Edit Vector Layers Dialog
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• To change the polygon fill type and style, click on the Polygon Fill button 
menu select from the options shown in the following table.

• To select the symbol used to plot points, click on the Point Symbol button 
menu and select a symbol type.

• To designate the size of the symbol, enter a size into the Symbol Size text 
box.

Plotting Attribute Names

To plot attribute names with the vector points and to associate attribute names with 
symbols:

1. In the Edit Vector Layers dialog, select the layer name and click on the 
Advanced button. The Point Attribute Relationships dialog appears.

2. Click in the Associate attribute name with symbol check box.

3. Use the Attribute button menu to select the desired column name to plot from 
the attribute table.

4. Select left, middle, or right alignment, font type, text size and orientation using 
the appropriate parameters.

5. Click OK to return to the Edit Vector Layers dialog.

For more information about attributes, see “Vector Attributes” on page 346.

Option Description

None Leave the polygon unfilled.

Solid Fill the polygon with the polygon color.

line, dashed, 
dotted, etc.

Fill the polygon with equally spaced lines.

Orien Change the orientation of the fill lines, enter 
the value of the angle in degrees 
(counterclockwise, with respect to the 
horizontal [0 degrees]) in the provided 
parameter box.

Spc Change the spacing of the lines, enter a value 
in the provided parameter box

Table 4-5: Polygon Fill Options
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Plotting Vector Points Based on Attribute Values

To plot vector points with different symbol sizes based on attribute values: 

1. In the Edit Vector Layers dialog, select the point layer name and click on the 
Advanced button. The Point Attribute Relationships dialog appears.

2. Click in the Associate attribute value with symbol size check box.

3. From the Attribute button menu, select the name of the attribute table column 
that contains the data to be used to scale the symbol size.

Note
The attribute table column must contain numeric values.

4. Select the minimum and maximum symbol size to use.

5. Click OK to return to the Edit Vector Layers dialog.

Applying Vector Layer Edits

After selecting from the options in the Edit Vector Layers dialog, apply the changes 
to the vectors and exit the dialog by clicking OK.

Controlling Cursor Modes

Use the Mode menu in the Vector Parameters dialog to control the cursor mode in a 
Main Image window. Use the cursor mode to select vectors and to highlight their 
corresponding attributes in the attribute table, to edit existing vectors, to add new 
vectors, to input vector points from an ASCII file, or to delete vectors. Cursor modes 
include Cursor Query, Edit Existing Vectors, and Add New Vectors.

Select the cursor mode using Mode → cursor mode from the Vector Parameters 
dialog, or choose Select Mode → cursor mode using the Main Image window 
shortcut menu.

Tip
Use Help → Mouse Button Descriptions to bring up a dialog that describes each 
mouse button function in each cursor mode. 
ENVI User’s Guide Overlaying Vectors



336 Chapter 4: Interactive Display Functions
Selecting Vectors

To use the cursor to select a vector and to see the corresponding vector attribute 
information:

1. Click on the desired vector layer in the Available Vector Layers list to make it 
active.

2. In the Vector Parameters dialog, select Options → Vector Information or 
Edit → View/Edit Attributes, then select Mode → Cursor Query.

3. Click with the left mouse button on the desired vectors in the Main Image 
display. The attributes associated with the selected vectors are displayed in the 
Vector Information dialog and highlighted in the vector attributes table.

Editing, Adding, and Removing Vector Nodes 

Use these options to change the location of vector nodes, to add vector nodes to 
existing vectors, and to remove vector nodes.

1. In the Available Vector Layers list, click on the vector layer to be edited.

2. Select Mode → Edit Existing Vectors in the Vector Parameters dialog.

3. Click on a vector with the left mouse button to highlight it (see “Setting the 
Current Highlight Color” on page 332).

4. To change the location of existing vector nodes, click and drag the diamond 
shaped handles using the left mouse button.

Note
To undo all changes, click with the middle mouse button.

5. To add vector nodes to the existing layer, click with the right mouse button on 
the location of the new node, then select Add Node [1] from the Vector 
window shortcut menu. 

• A new node appears. You cam left-click and drag the new node to move it 
to the desired location.
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• To change the number of nodes added, right-click and select Number of 
Nodes to Add from the Vector window shortcut menu. Enter the desired 
number of nodes to be added in the text box and click OK. 

• To add the nodes specified, position the cursor at the desired location and 
right-click the mouse to bring up the shortcut menu. From the shortcut 
menu, select Add Nodes [N], where N is the number specified previously. 
when the selection is made, the N nodes are placed in the Vector window.

6. To delete an existing vector node, click on the node with the right mouse 
button and select Delete Node from the shortcut menu. The selected node is 
removed and the two nearest nodes are connected. 

• To delete a range of nodes at once, right-click on one node and select 
Mark Node from the shortcut menu. Perform the same step to mark the 
node at the other end of the range, and all nodes in between are selected as 
well. Right-click again, and choose Delete Marked Nodes from the 
shortcut menu. 

Note
To clear marked nodes, select Clear Marked Nodes from the shortcut menu.

7. Select Accept Changes from the shortcut menu to save the changes to the 
vector file. These changes can be undone by selecting Edit → Undo Last 
Edit. 

Splitting and Joining Polyline Vectors

To split or join polyline vectors, do the following:

1. Click on the vector layer name containing the polylines in the Available 
Vector Layers list of the Vector Parameters dialog.

2. In the Vector Parameters dialog, select Mode → Edit Existing Vectors.

3. Select the polyline vector by clicking on it with the left mouse button. The 
vector is highlighted and the nodes are shown with diamond shaped handles.

4. To split the polyline vector, right-click on a node and select Mark Node from 
the shortcut menu. Right-click again and select Split Vector from the shortcut 
menu and the marked node becomes two nodes. These nodes are the endpoints 
of the two newly split polylines. They can now be separated and moved by 
clicking and dragging with the left mouse button.

5. To join polyline vectors, select one polyline vector in the active layer by left-
clicking on it. Select a second polyline vector by left-clicking on it. Now right-
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click to bring up the shortcut menu and choose Join Vectors. The highlighted 
polylines are joined into a single vector.

6. To save your changes to the vector file, right-click and select Accept Changes 
from the shortcut menu.

Note
Accepted changes can be undone by selecting Undo Last Edit from the 
shortcut menu. 

Deleting Vectors from Layers

1. Select the vector layer from which the vector will be deleted, either by 
highlighting it in the Available Vector Layers list or by right-clicking in the 
Main Image window to bring up the shortcut menu and then choosing Select 
Active Layer → layer name.

2. Select Mode → Edit Existing Vectors in the Vector Parameters dialog. 

3. Click on the vector to delete using the left mouse button. The vector is 
highlighted.

4. Select Delete Selected Vector from the Main Image window shortcut menu.

Note
The deleted vectors can be returned by selecting Undo Last Edit from the 
shortcut menu.

Undoing Vector Changes

To undo the last edit, addition, or deletion:

• Select Edit → Undo Last Edit in the Vector Parameters dialog. 

To undo all edits, additions, or deletions:

• Select Edit → Undo All Edits in the Vector Parameters dialog. 

Saving Changes

To save changes made to vectors:

• Select Edit → Save Changes Made to Layer in the Vector Parameters dialog.

Note
Saved changes cannot be undone.
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Adding New Vectors

To add new vectors to an existing layer: 

1. In the Available Vector Layers list, click on the vector layer to which the 
vectors will be added.

2. In the Vector Parameters dialog, select Mode → Add New Vectors.

3. Specify the vector type: polygon, polyline, rectangle, ellipse, or point by 
choosing one of the following options:

• Select Mode → vector type

• Select the vector type from the shortcut menu in the Vector window. 

Note
To draw donut polygons (polygons with holes in them), select 
Mode → Multi Part: On.

4. Left-click to define points, polygon or polyline vertices; or click and drag to 
draw rectangles or ellipses.

Note
To undo only the last point added, click once with the middle mouse button.

5. Right-click to get a diamond-shaped handle which can be used to move the 
vector position.

Note
To delete the highlighted or selected vector, click the middle mouse button.

6. Right-click to access the shortcut menu, then select Accept New Polygon to 
add the new vector.

• To remove the new vector, select Remove New Polygon from the shortcut 
menu.
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• To turn on the node handles for editing purposes, select Node Handles On 
from the shortcut menu.

• If you are defining new points, you can either accept them as individual 
points by choosing Accept as Individual Points, or as multiple points in a 
single record by choosing Accept as Multi Point from the shortcut menu. 

Note
The newly added vectors can be removed by selecting Edit → Undo Last 
Edit.

Adding ASCII Points to Vector Layers

To read points from an ASCII file (e.g., GPS points) and add them to a vector layer: 

1. Select the vector layer to which the points will be added from either the 
Available Vector Layers list, or by right-clicking and choosing Select Active 
Layer → layer name in the shortcut menu.

2. In the Vector Parameters dialog, select Mode → Add New Vectors.

3. Right-click in the Main Image window and select Input Points from ASCII 
from the shortcut menu.

4. When the Input ASCII File dialog appears, select the x and y column numbers.

5. In the Input ASCII File dialog, use the These points comprise menu button to 
select the type of vector the points define, a polygon, polyline, group of points 
(as one vector), or individual points.

6. If your vectors are georeferenced, select the projection of the ASCII points.

7. Click OK to add the points to the vector layer.
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Vector Layer Options

Use the Options menu in the Vector Parameters dialog to import additional vector 
layers, arrange the display order of the layers, place annotation in the vector window, 
change the plot parameters, get vector information, and to undo and save changes to 
vector layers.

Toggle On/Off Crosshair Cursor

Use Toggle Cursor On when in Cursor Query mode to leave the crosshair cursor on 
the display. This toggle feature can be accessed using either one of the following 
methods.

• Select Options → Toggle Cursor On/Off to turn on or turn off the crosshair 
cursor in the display.

• Select Mode → Cursor Query, then right-click in the Main Image window 
and select Toggle Cursor On/Off in the shortcut menu.

Loading Additional Vectors

Use this procedure to load additional vectors from files that are already open in the 
Available Vectors List. 

1. In the Vector Parameters dialog, select Options → Import Layers.

2. When the Import Vector Layers dialog appears, select the vector files to be 
imported by clicking on the desired filenames.

3. Click OK.

The selected layers appear in the Available Vector Layers list of the Vector 
Parameters dialog and are displayed automatically.

Select Active Layer

Use Select Active Layer to select which of the vector layers you are working on. 
This can be accessed using any of the following methods.

• From the Vector Parameters dialog, click on the desired layer name in the 
Available Vector Layers list.

• From the Main Image window shortcut menu, choose Select Active Layer → 
desired layer name. 
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Changing Layer Display Order

All vectors are drawn in the order that they are listed in the Available Vector Layers 
list. Use this procedure to change that order.

1. In the Vector Parameter dialog, select Options → Arrange Layer Order.

2. When the Vector Layer Ordering dialog appears, click on a layer name and 
drag it to the desired plot order precedence.

3. Click OK.

4. In the Vector Parameters dialog, click Apply.

The vector layers are redrawn using the new display order. 

Removing Vector Layers

To remove vector layers using the Vector Parameter dialog:

• Select Options → Remove Layers, then choose which layers to remove by 
clicking on the layer names and click OK.

From the Main Image window shortcut menu:

• Choose Remove Layers and select which layers to remove by clicking on the 
layer names. To remove only the active layer, select Remove Active Layer 
from the Main Image window shortcut menu.

Vector Information

Use Options → Vector Information from the Vector Parameter dialog to view 
vector attributes. For more details, see “Viewing Vector Attributes” on page 346.

Calculating Areas under Vectors

To calculate an area under a vector:

1. Select a vector in the Available Vector Layers list.

2. Choose an area unit in the Options → Report Area of EVFs submenu. If the 
pixel size is unknown, the Input Display Pixel Size dialog appears.Use this 
dialog to provide the x and y pixel sizes (for the units specified) and then click 
OK. 

The calculated area for all EVFs is displayed in the EVF Area Info dialog. You can 
save the information in this dialog to an ASCII text file or exit out of the dialog 
through its File menu
Overlaying Vectors ENVI User’s Guide



Chapter 4: Interactive Display Functions 343
Adding Annotation to Vector Displays

To add annotation for vectors overlaid on an image display:

• Select Overlay → Annotation from the Display window menu bar.

Managing Vector Layer Files

From the Vector Parameters dialog, use the selections found under the File menu to 
open new vector files, save and restore vector template files, export vector layers to 
ROIs or to a Shapefile, and output the vector display window.

Opening Additional Vector Files

1. From the Vector Parameters dialog, select File → Open Vector File → vector 
file type.

2. When the standard file selection dialog appears, select the vector file (see 
“Opening Vector Files” on page 63 for details). 

Creating Empty Vector Layers

Use Create New Layer to create a new and empty layer. 

1. Select File → Create New Layer.

2. When the New Vector Layer Parameters dialog appears, enter a layer name and 
select output to File or Memory. If you select File, you must enter an output 
file name.

3. Click OK.

The layer name appears in the Available Vector Layers list. 

Saving Vectors to Template Files

You can save the current vector setup to a template file for repeated use. 

1. In the Vector Parameters dialog, select File → Save Layers to Template.

2. Enter an output template filename with the extension .vec for consistency.

ENVI saves your current vector setup, including the loaded vectors, colors, 
linestyle and thicknesses, to a file with the extension .vec. 
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Restoring Layers from Saved Templates

1. Select File → Restore Layers from Template in the Vector Parameter dialog.

2. Select a .vec file.

The associated vector files are automatically opened, if needed. 

Note
Vectors maintained only in memory cannot be saved and restored.

Exporting Vector Locations to GCPs

If you have a vector file for the area of an image to be map-registered, you can extract 
the map coordinates directly from the vector data and load them into the Ground 
Control Points (GCP) Selection dialog by clicking with the left mouse button on a 
location and selecting Export Map Location from the Main Image window shortcut 
menu. For details, see “Entering Map GCPs from Vector Windows” on page 869.

Exporting Vector Layers to ROIs

When exporting vector layers to Regions of Interest (ROIs), you can choose to create 
one ROI containing all of the vectors, or create one ROI for each vector.

Warning
Exporting layers to ROIs can create very large ROIs.

1. Choose one of the following options:

• From the Available Vectors list, select File → Export Layers to ROI.

• From the Vector Parameters window, select File → Export Active Layer 
to ROIs.

2. When the Export Vector Data to ROI dialog appears, select either the Convert 
all vectors to one ROI or Convert each vector to a new ROI option.
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Exporting Vector Layers to Shapefiles

Use Export Active Layer to Shapefile to export vector layers to a shapefile (.shp), 
an index file (.shx), and a data base file (.dbf):

1. Select the vector layer to be exported by choosing Select Active Layer and 
clicking on the layer name in the Available Vector Layers list in the Vector 
Parameters dialog.

2. Select File → Export Active Layer to Shapefile in the Vector Parameters 
dialog.

3. When the Output Layer to Shapefile dialog appears, enter the desired output 
filename and click OK.

Note
Each shapefile can contain only one type of vector (polygon, point, etc.). If 
multiple vector types are present in the layer being exported, you are 
prompted to provide different output filenames for each vector type. 

Calculating Buffer Zone Images for Vectors

Use Calculate Buffer Zone to calculate a buffer zone image in which the value of 
every pixel is defined as the distance from that pixel to the selected vector layers, in 
units of pixels. If your vectors are overlaid on a display window, the displayed image 
is used to create the output buffer zone image. If the vectors are displayed in a vector 
window, you must select an associated file to use for the calculation. You can specify 
a maximum distance value. Any resulting pixels with a distance larger than that value 
are set to the maximum distance value +1.

1. In the Vector Parameters dialog, select File → Calculate Buffer Zone.

• If you have more than one vector layer open, the Buffer Zone Input Layers 
dialog appears. Click on the names of the layers to be included in the 
buffer zone image and click OK. The Buffer Zone Image Parameters 
dialog appears.

Note
If you select more than one layer, the distance will be calculated from the 
pixel to the nearest selected layer.

2. Click the Maximum Distance arrow increment buttons to set the maximum 
distance to measure, or type the value (in pixels) into the corresponding text 
box.
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Note
Any pixels with a distance larger than this value will be set to the maximum 
distance value +1. 

3. From the Distance Kernel button menu, select Floating Point or Integer 
output.

4. Select output to File or Memory. If you select File, you must enter an output 
file name.

5. Click OK.

Vector Attributes

Vector layers may have attributes associated with them. ENVI reads shapefile and 
MapInfo Interchange file attributes. The attributes are stored in a dBASE II table 
(.dbf) for shapefiles and in a .mid file for MapInfo.

Use the ENVI attribute table to view, edit, sort, and save vector attribute data. Use the 
Vector Attribute functions to create new vector layers based on attribute values, to 
add new attributes to vectors, to plot point attribute names in vector windows, and to 
associate point symbol sizes with attribute values (see “Changing Vector Layer 
Display Properties” on page 333).

Viewing Vector Attributes 

1. In the Vector Parameters dialog, select the vector layer by clicking on the layer 
name in the Available Vector Layers list.

2. In Vector Parameters, make sure Mode → Cursor Query is selected.

3. In Vector Parameters, select Options → Vector Information. The Vector 
Information dialog appears.

4. In the Main Image window, left-click on the desired vectors. The associated 
attributes are displayed in the Vector Information dialog.

Creating New Vector Layers from Attributes

To make a new vector layer using a simple mathematical and logical attribute query 
expression perform the following steps:

1. Select the vector layer by clicking on the layer name in the Available Vector 
Layers list in the Vector Parameters dialog.

2. In the Vector Parameters dialog, select Edit → Query Attributes. The Layer 
Attribute Query dialog appears.
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3. Click the Start button. The Query Condition dialog appears and allows you to 
enter a query expression.

4. Select the attribute item to query by using the attributes name pull-down menu.

5. Select one of the following mathematical expressions from the pull-down 
menu:

6. Enter a query value in the text box. The value can be a string (case sensitive) or 
numeric value depending on the attribute type.

7. To make a more complicated query expression using logical operators, choose 
from the following options:

• Click AND and follow steps 4 through 6 to do a query that must satisfy 
both entered mathematical expressions.

• Click OR and follow steps 4 through 6 to do a query that must satisfy one 
of the entered mathematical expressions.

• Click Delete to delete the last lines of the query expression entered.

• Click Clear to clear the entire query expression.

8. Enter a query layer name in the appropriate text box.

9. Select output to File or Memory. If you select File, you must enter an output 
file name.

10. Click OK. 

The new layer appears in the Available Vector Layers list of the Vector Parameters 
dialog.

Expression Description

> greater than

>= greater than or equal

< less than

<= less than or equal

== equals

!= not equals

Table 4-6: Mathematical Expression Options
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Adding Attributes to Vectors

To add attributes to a vector layer that does not have any: 

1. Select the vector layer by clicking on the layer name in the Available Vector 
Layers list of the Vector Parameters dialog.

2. Select Edit → Add Attributes in the Vector Parameters dialog. The Attribute 
Initialization dialog appears with one field defined.

3. Select from the following options to edit, add, or delete field parameters.

• Change the field name using the Name text box.

• Select the field type from the Type pull-down menu.

Available types include character, numeric, logical, and date. The logical 
field contains a single character, either a Y or N, T or F, or ?.

• Enter the width of the field in the table in the Width box.

• Enter the number of digits to the right of the decimal in the Decimal 
Count box for a numeric field.

• Click on Add Field to add a new field to the Defined Attribute Fields list.

• Select a field name from the Defined Attribute Fields list and click Delete 
Field to remove the field from the list.

4. Click OK.
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The Attribute Table

Use the attribute table to view, edit, sort, and save vector attribute data. The attributes 
table shows the attribute names at the top of each column and the attribute record 
number at the left of each row. The attribute table has two pull-down menus, File and 
Options.

Highlighting Attribute Data

To select data in the attribute table:

1. Select the vector layer by clicking on the layer name in the Available Vector 
Layers list in the Vector Parameters dialog.

2. Select Edit → View/Edit/Query Attributes in the Vector Parameters dialog. 

The attributes table appears.

3. Click with the left mouse button on the desired vectors in the Main Image 
window.

Figure 4-34: A Vector Attribute Table
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The associated attributes are highlighted in the attribute table.

Highlighting Vectors

To highlight the vector that corresponds to a selected attribute record:

• Click on the attribute record number. The Main Image window centers on the 
corresponding vector and it is highlighted in the Current Highlight color.

To highlight vectors that correspond to multiple attribute records:

• Hold down the Shift or Ctrl key while clicking on the attribute record 
numbers. All the selected vectors will be highlighted in the Current Highlight 
color.

Highlighting based on Layer Query

To highlight items in both the attributes table and the corresponding vectors based on 
a query for the current vector layer:

1. From the Layer Attributes dialog, select Options → Query Layer.

2. Click on the Start button.

3. Follow the directions for the query expression given in “Creating New Vector 
Layers from Attributes” on page 346.

Items in the attributes table that satisfy the query are highlighted and the 
corresponding vectors are highlighted.

Note
The results from the vector query can be saved to a new vector layer, see “Saving 
Selected Records to a New Vector Layer” on page 352.

Editing Single Attribute Values

To edit a single attribute value, double-click in the desired attribute field and enter the 
new value.

Adding New Attribute Columns

To add new columns to the attribute table:

• Select Options → Add Record Columns. In the resulting Attribute 
Initialization dialog, enter the new attribute information.
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Deleting Attribute Columns

To delete an attribute column from the table: 

• Click on the column name to highlight the column and select Options → 
Delete Record Column.

Sorting Table Information

Sort the attribute table using the values or strings in a column (in a forward, reverse, 
or original order). 

1. Click on the column name to sort.

2. Select Options → Sort by selected column forward, Sort by selected 
column reverse, or Sort by original order.

Replacing Attributes with a Single Value

To replace cells in the same column with a single value: 

1. Select one of the following options:

• To replace the entire column, click on the column name.

• To replace specific selected cells, click and drag with the cursor to 
highlight the specific cells.

2. Select Options → Replace selected cells with value.

3. When the Replace Table Cells with Value dialog appears, enter the desired 
string or numeric value and click OK.

Replacing Attributes with ASCII Data

To replace cells in the same column with values from an ASCII file: 

1. Select one of the following options:

• To replace the entire column, click on the column name.

• To replace specific selected cells, click and drag with the cursor to 
highlight the specific cells.

2. Select Options → Replace selected cells with ASCII values.

3. Select the desired input ASCII filename.

4. When the Input ASCII File dialog appears, select the desired column number 
(strings can only have one column), and starting and ending row numbers.
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5. Click OK to enter the data into the attribute table.

Saving Selected Records to a New Vector Layer

To save the selected records or query results to a new vector layer:

1. In the Layer Attributes dialog, select File → Save Selected Records to new 
Layer.

2. Enter a layer name and an output filename and click OK.

Saving Selected Records to an ASCII file

To save the selected records or query results to an ASCII file:

1. From the Layer Attributes dialog, select File → Save Selected Records to ASCII.

2. Enter an output filename and click OK.

Saving Changes

To save changes made to the attribute table:

• Select File → Save Changes. 

Warning
Saving changes overwrites the existing attribute file.

Saving Attribute Tables to ASCII Files

1. In the Attribute Table, select File → Save Records to ASCII.

2. When the Output Records to ASCII dialog appears, enter an output filename.

Closing Attribute Tables

To close the attribute table:

• Select File → Cancel. 
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Hiding the Vector Parameters Dialog

When working with vectors in an Image display, to hide or show the Vector 
Parameters dialog without erasing your vector layers, see “Showing and Hiding 
Overlay Dialogs and Layers” on page 239.

Closing Vector Displays

To close the Vector Parameters dialog and to erase vectors from an image display, do 
the following:

• Select File → Cancel from the Vector Parameters dialog menu bar.
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Contrast Stretching and Quick Filtering

Use Enhance to perform quick contrast stretches, to perform interactive contrast 
stretching using histograms and to apply quick filter enhancements to displayed data. 
These enhancements are not applied to the data files. Use contrast stretching to adjust 
the color or grayscale range of a selected image so it fills the computer display’s 
dynamic range and improves the contrast in the image. Available stretching options 
allow you to do this using both linear and non-linear methods. 

When an image is first displayed, default stretch is determined in one of three ways:

• An ENVI look-up-table (LUT) is automatically applied to the data if a LUT 
was saved previously (see “Saving Stretch LUTs” on page 370).

• If a LUT does not exist for the displayed bands, the default stretch defined in 
the .hdr file is used (see “ENVI Header Format” on page 1077).

• If no default stretch is defined in the .hdr file, the default stretch defined in 
the envi.cfg file is applied (see “Configuration File Details” on page 1063).

ENVI provides both default quick stretching and interactive stretching.

Figure 4-35: Interactive Stretching and Filtering Options
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Applying Display Filters

Use Filter to choose sharpening, smoothing, and median filters. These filters are 
applied to the displayed data only and can be used to quickly enhance the displayed 
data.

To apply a filter to your displayed data:

• Select Enhance → Filter → filter type.

For more filtering functions and information, see Chapter 8, “Filters”.

Sharpening Filters

The sharpening filters perform a high pass convolution on the data in the image 
displays windows (Image, Scroll, and/or Zoom). Three types of sharpening filters are 
available, each one with a differing amount of data add-back. The number in brackets 
next to the Sharpen menu item is the kernel center value. Therefore, the sharpening 
filters with higher numbers in the brackets have a larger amount of the original data 
added back to the filtered image.

Note
When using the sharpening filters with unsigned integer data, the result may not be 
properly displayed due to the underflow of negative numbers. To avoid this, use 
Filter → Convolutions and Morphology from the ENVI main menu bar instead.

Smoothing Filters

The smoothing filters perform a low pass convolution on the data in the display 
windows. Two smoothing filters are available: the Smooth [3x3] filter uses a 3x3 
kernel size, and the Smooth [5x5] filter uses a 5x5 kernel size. The larger kernel size 
results in more smoothing.

Median Filters

The median filters replace the center pixel value with the median value in the kernel. 
Two median filters are available, with kernel sizes of 3x3 and 5x5. These filters can 
help reduce salt and pepper type noise or speckle.
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Applying Default (Quick) Stretches

Select from several default stretching options that use the data from the Main Image 
window, the subsampled Scroll window, or the Zoom window. 

From the Display menu bar, select Enhance → Linear, Linear 0–255, Linear 2%, 
Gaussian, Equalization, or Square Root to stretch the displayed image using 
statistics from the Main Image window [Image], the Scroll window subsampled data 
[Scroll], or the Zoom window data [Zoom].

Tip
You can also apply quick stretches from within the Interactive Contrast Stretching 
dialog (see “Stretch Types” on page 361.)

Quick Linear Stretch

The quick Linear stretch uses the data minimum and maximum to perform a linear 
contrast stretch (no clipping). This is particularly useful for displaying images with 
only a few data values, where clipping might saturate all of the values. 

Quick Linear 0–255 Stretch

The quick Linear 0–255 stretch does not actually stretch the data—it displays the 
actual DN values of the pixels as computer screen display values that range from 0 to 
255, where 0 indicates no brightness and 255 indicates maximum brightness. 

When you use the Linear 0–255 stretch, you will most likely produce an image that 
does not have many gray levels or colors because the data was not stretched to fill the 
display’s dynamic range.

Quick Linear 2% Stretch

The quick Linear 2% stretch applies a linear method with a 2% clip on both ends of 
the displayed data. 

Quick Gaussian Stretch

The quick Gaussian stretch applies a Gaussian method with a mean of DN 127 and 
the data values at ± 3 standard deviations set to 255 and 0, respectively.
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Quick Equalization Stretch

The quick Equalization stretch applies a histogram equalization method to the 
displayed data.

Quick Square Root Stretch

The quick Square Root stretch takes the square root of the input histogram and then 
applies a linear stretch.
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Matching Histograms

Use Histogram Matching to automatically match the histogram of one displayed 
image to another displayed image. This function makes the brightness distribution of 
the two images as close as possible. The resulting histogram of the display where the 
function was started is changed to match the current (source) histogram of the 
selected image display. The histogram source is selected as the input histogram. You 
can use this feature on both grayscale and color images.

Note
To perform Histogram Matching, you must have at least two images displayed.

1. Begin in the Main Image window of the histogram that you want to change. 
Select Enhance → Histogram Matching from the Main Image menu bar. The 
Histogram Matching Input Parameters dialog appears.

2. In the Match To list, select the display number of the image with the 
histogram you want to match to.

3. Under Input Histogram, select the source of the input histogram by selecting 
the appropriate toggle button: Image, Scroll (subsampled data), Zoom, Band 
(all pixels), or a ROI (region of interest). 

4. Click OK. 

The display stretch changes to match the selected histogram.

Note
To see how the histogram matched, select Enhance → Interactive 
Stretching in the image where you applied the histogram match.

The resulting dialog shows two histograms in the Output Histogram plot: the 
imported histogram in red and the matched output histogram in white.
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Using Interactive Stretching

Use Interactive Stretching to stretch your image data by interacting with 
histograms.

1. From the Display menu bar, select Enhance → Interactive Stretching. An 
Input and an Output histogram appear in the Interactive Contrast Stretching 
dialog. They show the current input data and applied stretch respectively. Two 
vertical dotted lines mark the current minimum and maximum values of the 
stretch. For color images, the color of the histogram matches the color of the 
selected band (the red band is displayed by default). At the bottom of the 
Interactive Histogram window, the stretch type and the histogram source are 
listed.

Note
To view the histogram for the green or blue bands of a color image, click the 
G or B toggle button.

2. You can choose to have stretching or histogram changes applied to your 
images automatically, by selecting Options → Auto Apply. To have changes 
applied to your image only when you click the Apply button, deselect the Auto 
Apply by clicking Options → Auto Apply and toggling the feature off.

See Setting Stretch Parameters for details on how to set the stretch parameters.

Viewing Data Details

To view the current DN, and the number of pixels, percentage, and cumulative 
percent of pixels for that specific DN, press and hold the left mouse button within the 
histogram and drag the resulting white cross-hair cursor.
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Setting Stretch Parameters

Use the Options menu and interactive mouse functions to set preferences for your 
stretch and to view details in the Interactive Histogram window.

Changing Min/Max Stretch Values

To change the minimum and maximum stretch values, click with the left mouse 
button on either of the dotted stretch bars and drag them to a new location. Or, enter 
the values in the text boxes at the top of the dialog.

Tip
When specifying the minimum and maximum parameters in the text boxes, enter 
either the actual values desired (for example, 37 for the minimum and 68 for the 
maximum) or a percentage of the data (for example, 2% for the minimum and 98% 
for the maximum). You can set the histogram values outside the data range but the 
stretch values can only fall within the values shown on the input histogram.

When the values are entered, the output histogram updates to reflect the changes 
made to the input histogram and shows the distribution of the data with the new 
stretch applied. 

Figure 4-36: The Interactive Contrast Stretching dialog.
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Locking Stretch Bars

1. To lock the distance between the minimum and maximum stretch bars, select 
Options → Stretch Bars:Locked. The distance between the stretch bars is 
locked and you can move the two bars as one.

2. To unlock the bars, select Options → Stretch Bars:Unlocked.

Stretch Types

Use the Stretch_Type menu in the Interactive Contrast Stretching dialog to select 
from a list of all available types of interactive stretches.

Applying Linear Contrast Stretches

Linear contrast stretching is the default interactive stretch. A linear stretch sets a 
minimum and maximum input value to 0 and 255 respectively and all other values in 
between are linearly aligned to intermediate output values. 

1. From within the Interactive Contrast Stretching dialog, select 
Stretch_Type → Linear Contrast Stretch.

2. To determine the minimum and maximum input value move the minimum and 
maximum vertical bars (dotted white lines) on the input histogram to the 
desired location using the left mouse button or enter the minimum and 
maximum input values by entering the desired DN values or a percentage of 
the data (for example, 5% for minimum and 95% for maximum) in the Stretch 
text boxes. 

Note
For information about interacting with the Interactive Histogram window, see 
“Plotting Histograms in an ENVI Plot Window” on page 369.

3. Click Apply to apply the stretch to the displayed data. To re-display the 
original stretch select Options → Reset Stretch. 

The selected stretch can also be permanently applied to the displayed image as 
described in “Converting Stretched Data” on page 369. 
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Applying Piecewise Linear Contrast Stretches

A piecewise linear contrast stretch can be interactively defined by using the mouse to 
position points in the input histogram. Linear segments connect the points to provide 
linear stretching between them.

1. Select Stretch_Type → Piecewise Linear. A transfer function is plotted on 
the input histogram. 

2. Click the middle mouse button anywhere in the Input Histogram plot to add a 
node to the transfer function. Line segments are plotted to connect the 
endpoints to the plotted node symbol.

• To move the position of a point, click the left mouse button on the symbol 
and drag it to a new position. 

• To delete points, click on the symbol with the right mouse button. 

• To enter input and output values manually, select Options → Edit 
Piecewise Linear.

3. The resulting histogram is plotted in the output display. The output histogram 
shows the distribution of data with the new stretch applied. 

4. Click Apply to apply the stretch to the displayed data.

For information about interacting with the Interactive Histogram window, see 
“Plotting Histograms in an ENVI Plot Window” on page 369).

Applying Gaussian Contrast Stretches

The default Gaussian stretch is centered at a mean DN of 127 with the data values 3 
standard deviations set to 0 and 255. 

1. Select Stretch_Type → Gaussian. 

2. Enter minimum and maximum values for the stretch. The output histogram 
shows the selected Gaussian function as a red curve. The stretched data 
distribution is shown superimposed in white on the red Gaussian function. To 
enter the desired number of standard deviations manually, select 
Options → Set Gaussian Stdv. 

3. Click Apply to apply the stretch to the displayed data. 
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Applying Histogram Equalization Contrast Stretches

To automatically scale the data to equalize the number of DNs in each histogram bin:

1. Select Stretch_Type → Equalization. The input histogram shows the 
unmodified data distribution. The output histogram shows the equalization 
function as a red curve, and the stretched data distribution is shown 
superimposed in white. 

2. Click Apply to apply the stretch to the displayed data. 

For information about interacting with the Interactive Histogram window, see 
“Plotting Histograms in an ENVI Plot Window” on page 369).

Applying Square Root Contrast Stretches

To take a square root of the input histogram and then apply a linear stretch:

1. Select Stretch_Type → Square Root. The input histogram shows the 
unmodified data distribution. The output histogram shows the square root 
function as a red curve, and the stretched data distribution is shown 
superimposed in white. 

2. Click Apply to apply the stretch to the displayed data.

Applying Arbitrary Contrast Stretching and Histogram 
Matching

Use Arbitrary to draw any shape histogram on top of the Output Histogram or 
match a histogram from another image.

1. Select Stretch_Type → Arbitrary. The Input Histogram shows the 
unmodified data distribution. 

2. Draw the output histogram in the Output Histogram window by clicking the 
left mouse button to draw segments of the output histogram, or by drawing 
with the left mouse button depressed. The arbitrary histogram appears in green. 
To erase the histogram, click the middle mouse button. 

3. Click the right mouse button to accept the output histogram and match the data 
statistics to the drawing. The output histogram shows your histogram in red 
and the matched data function as a white curve. 

4. Click Apply to apply the stretch to the displayed data.
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Matching Histograms

Also use the Arbitrary Contrast Stretching function to match a histogram from one 
image to the histogram of another. 

1. Grab either the input or output histogram from one plot by clicking on the 
Input Histogram or Output Histogram text label at the top of the plot using 
the left mouse button. 

2. Drag the name into the other output histogram and release the button. The 
imported histogram will be plotted in red and the output histogram will be 
stretched to match the imported histogram. 

3. Click Apply to apply the stretch to the displayed data.

Defining Look-Up-Tables

A user-defined look-up-table stretches each input DN to an output value. It can be 
restored (see “Restoring Stretch LUTs” on page 370) or defined interactively.

1. Select Stretch_Type → User Defined LUT. 

2. Select Options → Edit User Defined LUT. When the edit dialog appears, a 
list of the input DN values and their corresponding output stretch values is 
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shown under the Edit User Defined LUT label. These values reflect the 
current stretch.

3. Click on the value to be edited.

4. When it appears in the Edit Selected Item: text box, enter the desired value 
and press the Enter or Return key. To reset the look-up-table to the values it 
had when the function was initiated, click Reset.

5. Click OK.

6. Click Apply to apply the stretch to the displayed data.

Figure 4-37: The Edit User-Defined LUT dialog
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Defining Histogram Source Information

Input histogram information can be extracted from the Main Image window, from the 
Scroll window (subsampled), from the Zoom window, from the entire image band (all 
pixels of the data), or from a user defined region-of-interest (ROI).

• Select Histogram_Source → desired input data source.

The output histogram, and thus the resulting stretch, changes based upon the source 
of the input histogram. 

Using Zoom Window Data

When the Zoom window is selected as the data input source choose from the 
following additional options:

To view histograms for different portions of the image:

• Moving the zoom box in the Main Image window:

To view Histograms for the Zoom window in real time.

• Click and hold the left mouse button inside the zoom box in the Main Image 
window and drag the box to a new location. The input and output histograms 
are automatically updated as the box moves. Changing the size of the zoom 
box changes the pixels displayed, which also changes the histograms.

Setting Histogram Parameters

Use the Histogram Parameters dialog and interactive mouse functions to set 
preferences for your histograms.

Changing Histogram Vertical Scale

To change the vertical scale of the histograms:

• Click the middle mouse button at the desired maximum Y value anywhere 
within the plot to be scaled. 

To reset the vertical scale to the original Y value:

• Click the middle mouse button below the X axis of the plot to be reset. 
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Changing Histogram Min/Max

The input histogram minimum and maximum values can be changed. Values can be 
selected either inside or outside the actual data range. Any subsequent clipping using 
histogram percentages will consider the histogram using the new minimum and 
maximum data values.

1. In the Interactive Histogram window, select Options → Histogram 
Parameters. The #n Histogram Parameters dialog appears (where n designates 
the number of the source display).

2. Enter minimum and maximum values for the histogram.

3. Press the Enter or Return key. To restore the original range, click the Reset 
Histogram button.

Setting the Number of Bins

1. In the Interactive Histogram window, select Options → Histogram 
Parameters. The #n Histogram Parameters dialog appears (where n is the 
number of the source display).

2. In the Maximum Bins text box, enter the maximum limit for the number of 
bins used in the histogram.

Using the Same Range with New Data

To set your preference for whether the range you entered is retained when new data is 
loaded:

• Select Options → Auto Reset Histogram On or Auto Reset Histogram Off.

Or in the Interactive Histogram window:

• Select Options → Histogram Parameters. The #n Histogram Parameters 
dialog appears (where n is the number of the source display), then click the 
Auto Reset Histogram arrow toggle button to select Yes or No.
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Interactive Stretching Options

Options when working with interactive stretching include setting the floating point 
precision, resetting the stretch parameters to the original settings, and applying 
stretches.

Setting Floating Point Precision

If your data is floating point, you can set the number of significant digits to display:

1. In the Interactive Histogram window, select Options → Set Floating Point 
Precision.

2. In the dialog, use the arrow buttons to change the number of digits of precision 
or enter a number into the text box.

3. Click OK.

Resetting Stretches

To reset the stretch to what it was initially:

• Select Options → Reset Stretch.

Applying Stretches

If you selected Options → Auto Apply:Off:

• Click Apply to apply the stretch parameters.

Note
You can also set the Interactive Stretch Auto Apply option in the ENVI main 
preferences file. For information, see the description of Miscellaneous preferences 
under “Setting ENVI Preferences” in Chapter 2.
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Managing Interactive Stretches

Use the File menu in the Interactive Histogram window to output histograms, save 
and restore LUTs, convert stretched data, and to plot histograms in an ENVI plot 
window.

Converting Stretched Data

Use Export Stretch to convert data from one type to any other ENVI-supported data 
type (for example, byte to floating point, integer to byte, etc.) and to save the 
displayed data (with the current stretch applied) as an output file.

1. In the Interactive Contrast Stretching dialog, select File → Export Stretch.

2. When the Output Stretch Parameters dialog appears, select a spatial subset if 
desired.

3. Select the desired output data type from the Output Data Type button menu.

4. Enter the output data range (minimum and maximum) in the appropriate text 
boxes.

5. Click File or Memory to select either output to file or memory. 

If you choose File, enter an output file name.

6. Click OK.

A status box indicates the processing progress.

Plotting Histograms in an ENVI Plot Window

Use this procedure to plot a histogram in a new ENVI plot window. When the 
histogram is plotted in a new window, you can apply ENVI’s interactive plot 
functions, such as saving and annotation (see “Using Interactive Plot Functions” on 
page 387 for instructions). 

1. From the ENVI main menu bar, select Window → Start New Plot Window 
(see “Starting New Displays” on page 184). 

2. Grab the Input Histogram or Output Histogram text label at the top of the 
plot with the left mouse button and drag the name into the new plot window.
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Saving Histograms

Standard ENVI output options include Image, PostScript, BMP, HDF, JPEG, PICT, 
SRF, TIFF, and XWD formats.

• Select File → Save Plot As → Postscript or Image File. To print the 
Interactive Histogram window, select File → Print.

The interaction is similar to that for saving plots, but no annotation is allowed. For 
instructions, see “Display Output Options” on page 446.

Saving Stretch LUTs

Stretch Look-up-Tables (LUTs) can be saved to either an ASCII format file or an 
ENVI format file. 

To save a LUT, select File → Save Stretch to LUT → ASCII LUT or ENVI 
Default LUT in the Interactive Contrast Stretching dialog.

• Choosing ASCII LUT saves the look-up-table to a file as a single column of 
ASCII data with the parameters Binsize and Data Min at the top of the file. The 
first value in the data column corresponds to the LUT value for the input data 
minimum. The next value is the LUT value for the input data minimum plus 
the binsize and the remaining values in the column are saved in the same 
manner up to the input data maximum value.

• Choosing ENVI Default LUT saves the LUT to an ENVI binary format file. 
This file is automatically named with the input filename and a .lut extension 
and saved in the same directory as the input file (or in the alternate header 
directory). When the data band is displayed in ENVI, this LUT will be 
automatically used as the default stretch.

Restoring Stretch LUTs

1. To restore a previously saved LUT, select File → Restore LUT Stretch in the 
Interactive Contrast Stretching dialog. 

2. If no default .lut file exists for the band displayed, select either an ENVI 
binary LUT file or an ASCII LUT file containing one column of look-up-table 
data when the standard ENVI input file selection dialog appears. 

If no Binsize or Data Min parameters are contained in the file, it is assumed that the 
binsize equals one and the data minimum is zero.
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Interactive Analysis Tools

Use the Tools menu to access ENVI’s interactive analysis tools. ENVI interactive 
analysis tools are generally related to a specific display or require significant 
interaction. Use the tools to link image displays, extract Z profiles and spectral plots, 
extract polarization signatures, draw Regions of Interest, apply color maps and 
density slices, edit pixels interactively, extract measurement, calculate line of sight, 
create animations, form two-dimensional scatter plots, and view three-dimensional 
surface plots.

Figure 4-38: Interactive Analysis Tools in the Tools Menu
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Display Linking and Dynamic Overlays

Use image linking and dynamic overlays to overlay portions of multiple images 
simultaneously (or flicker images) and to perform identical operations on multiple 
images from within a single image window. 

Linking Images

Use Link to link and unlink images. When images are linked, actions such as moving 
the zoom box, the scroll box, changing the zoom factor, or resizing one image 
window are mirrored in all other linked image windows. Ideally, images should only 
be linked when they are the same size or when one image is a subset of the other 
image. However, ENVI allows you to specify the link pixel regardless of the 
relationship between images.

1. From the Display menu bar, select Tools → Link → Link Displays.

Note
To use the link function, you must have at least two image windows open. 
The Link option is not available when only one image is displayed. 

2. When the Link Displays dialog appears, select from the list of available 
displays by using the arrow toggle button for each available display to select 
Yes or No.

3. Specify the link pixel for each image by specifying the Link xoff (x offset) and 
yoff (y offset) parameters in pixels measured from the upper left (1,1) corner of 
each image. 

4. Select the base image for the link by choosing the appropriate display from the 
Link Size/Position menu.

5. Toggle the Dynamic Overlay to be On or Off for your linked images. When 
Dynamic Overlay is On, clicking the left mouse button in one display 
overlays the image from the linked display.

6. You can set the Transparency level of the overlay in the Link Displays dialog 
from 0 to 100%. In this case, 0% results in the second display completely 
masking the display in which the mouse button was clicked, and 100% results 
in a completely transparent overlay. A transparency factor of 50 shows half 
underlying image and half dynamic overlay.

7. Click OK to execute the link settings. All other images are sized and 
positioned to correspond to the base image.
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If you already have images linked and want to link another image:

• Open the Link Displays dialog and select Yes for that display using the arrow 
toggle button. 

To remove a single display window from the link:

• Select Tools → Link → Unlink Display in that image window. The other 
windows remain linked.

Working with Multiple Dynamic Overlays

Use Dynamic Overlays for real-time overlay and toggling (flickering) of multiple 
grayscale or color images. By default, dynamic overlays are activated automatically 
when two or more windows are first linked. Multiple overlays are active in all linked 
image windows simultaneously and in each Zoom window.

Note
Dynamic Overlays do not work with Geographic Link or with an image that is 
georeferenced with non-zero rotation.

Figure 4-39: Example of Dynamic Overlays
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The following steps show how to use dynamic overlays.

1. From the Display menu bar, select Tools → Link → Link Displays. The Link 
Displays dialog appears.

2. The displays to be linked are toggle-selected in this dialog. Select OK to apply 
the link. 

3. When the displays are linked, the Dynamic Overlay can be toggled On and 
Off using the following Display menu selections:

• Select Tools → Link → Dynamic Overlay On, or 

• Select Tools → Link → Dynamic Overlay Off. 

4. Select from the following options and see “Mouse Actions with Dynamic 
Overlays On” on page 375 for a summary of mouse button functions when 
dynamic overlays are on and “Mouse Actions with Dynamic Overlays Off” on 
page 375 for a summary of mouse button functions when two images are 
linked but dynamic overlays are turned off.

To show a second linked image (the overlay) in the first image (the base):

• Click the left mouse button in any of the linked images.

To cause the multiple overlays to cycle, successively displaying each linked image as 
an overlay on the base image:

• Hold down the left mouse button and simultaneously click the middle 
mouse button. You can also cycle through all the linked images by holding 
down the left mouse button and pressing the n key on your keyboard.

To move the overlays around inside a specific image and compare the two images:

• Click and hold the left mouse button and move the cursor in the image (see 
“Mouse Actions with Dynamic Overlays On” on page 375). 

To change the size of the overlay:

• Press the middle mouse button and drag the corner of the overlay and 
release the button. After resizing, use the left mouse button to reposition 
the overlay. 

To do a quick comparison of the images:

• Repeatedly click and release the left mouse button to activate the overlay 
effect. Select Tools → Link → Dynamic Overlay Off to turn off the 
flickering feature (see “Mouse Actions with Dynamic Overlays Off” on 
page 375).
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When displays are linked, the Zoom window can still be repositioned by clicking and 
dragging using the left mouse button when the cursor is within the zoom box outline 
in the Main Image window (see “Mouse Actions with Dynamic Overlays Off” on 
page 375).

To save to memory the image in the Image Window display with the dynamic overlay 
shown:

• Press the p key on your keyboard while holding down the left mouse 
button. The resulting image appears in the Available Bands List.

Mouse Actions with Dynamic Overlays On

The following table specifies the mouse actions for when dynamic overlay is on.

Mouse Actions with Dynamic Overlays Off

The following table specifies the mouse actions for linked images when dynamic 
overlay is off.

Mouse Button Action

Left Click and drag the overlay (exception - the zoom box 
functions as shown in the following table).

Middle Resize the overlay.

Right Click to display the shortcut menu.

Left + Middle Cycle multiple overlays.

Table 4-7: Mouse Functions for Linked Images with Dynamic Overlays

Mouse Button Action

Left Clicking and dragging inside the zoom window box 
causes repositioning of the selected zoom window. The 
portion of the image displayed in the zoom window is 
updated when released.

Middle Position the current pixel at the center of the zoom 
window.

Right Click to display the shortcut menu.

Table 4-8: Mouse Functions for Linked Images without Dynamic Overlays
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Linking Multi-Resolution Georeferenced Images

Use Geographic Link to link display windows and vector windows containing 
georeferenced data. When linked, all displayed georeferenced images and Vector 
windows update to the current cursor map location when you move the cursor. This 
function works regardless of the projection, pixel size, and rotation factor of each 
data set.

Note
This function does not provide any on-the-fly re-projection, resampling, or dynamic 
overlay. To re-project and resample data sets to the same projection and resolution, 
see “Layer Stacking” on page 470.

To create a geographic link:

1. Select Tools → Link → Geographic Link from the Main Image Display 
menu bar.

2. In the Geographic Link dialog, select the displays to link and click the arrow 
buttons beside the display to select On for the displays to be linked.

3. Click OK. When you move the cursor in one georeferenced Image or Vector 
window, the cursor in all other georeferenced images and vector windows will 
move to the same map location.

To turn a geographic link off:

1. Select Tools → Link → Geographic Link.

2. Click the arrow buttons beside the display names to select Off for the displays 
to be unlinked.

3. Click OK.
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Interactive Profiles and Spectral Plots

ENVI allows extraction of horizontal (X), vertical (Y), spectral (Z for individual 
pixels), and arbitrary profiles. 

The profiles are displayed in separate plot windows and the X, Y, and Z profiles can 
be active simultaneously. The mouse is used to move a crosshair and select the 
profiles interactively. The profiles are standard ENVI plots and have associated 
controls and options described in detail in “Using Interactive Plot Functions” on 
page 387.

ENVI’s Z profile capabilities provide integral spectrum analysis. Spectra can be 
extracted from any multispectral data set including MSS, TM, GEOSCAN (24 
bands), GERIS (63 bands), and AVIRIS (224 bands).

Tip
To show the entire data range, you should turn the Auto Scale Y-Axis on when 
plotting profiles (select Options → Auto Scale Y-Axis On).

See the following sections for detailed instructions.

Extracting X and Y (Horizontal and Vertical) Profiles

The X profile is automatically extracted for pixels that fall along the horizontal cursor 
line, while a Y profile is extracted for pixels that fall along the vertical cursor line. 

If a color composite image is displayed, X and Y profiles are plotted for all three 
images in their corresponding colors (RGB). If only one band is displayed, the profile 
of that band will be plotted in white. A vertical line is used to mark the current line or 
sample location of the crosshair in the X or Y profile respectively. 

1. From the Display menu bar, select Tools →  Profiles →  X Profile or Y 
Profile.

A crosshair appears in the Main Image and Zoom windows at the current pixel 
and a plot window appears with a profile for the current horizontal or vertical 
crosshair. 

2. Click the left mouse button on another pixel to extract a new profile. The 
horizontal, vertical, and spectral profiles are updated continuously as the 
current pixel location is moved. 
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Note
To activate continuous real-time browsing, click and hold the middle mouse 
button in the Main Image window and drag the zoom box to the desired 
location.

3. Once the X or Y profile has been extracted, click and hold the left mouse 
button in the profile plot and drag the cursor to mark the current position on the 
profile with cross-hair cursor in the image. The zoom box crosshair 
concurrently tracks the location in the profile on the Scroll, Main and Zoom 
window and the Main and Zoom images are updated to match the position of 
the cursor along the profile.

Extracting Z Profiles

Use ENVI’s Z profiles to interactively plot the spectrum (all bands) for the pixel 
under the cursor. Spectra can be extracted from any multispectral data set including 
MSS, TM, and higher spectral dimension data such as GEOSCAN (24 bands), 
GERIS (63 bands), and AVIRIS (224 bands).

Vertical Plot bars in the Z Profile window show which band or RGB bands are 
currently displayed in the display window. The bands shown in the display window 
can be interactively changed by moving the plot bars to new band positions.

For data sets with fewer than approximately 50 spectral bands, the extraction and 
plotting of spectra are fast enough that a BSQ data file can be used. For higher 
spectral dimension data sets such as hyperspectral data, use of a BIL or BIP file 

Figure 4-40: X and Y Profiles
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allows real-time extraction of spectra (see “Converting Data (BSQ, BIL, BIP)” on 
page 472). 

Note
Use of the BIL data format is recommended for hyperspectral data sets because it 
produces a response similar to the BIP data for spectral plotting and browsing and 
yet is much faster than BIP format for image display.

1. From the Display menu bar, select Tools → Profiles → Z Profile (Spectrum).

2. Select a pixel in either the Main Image window or the Zoom window to plot 
the corresponding spectrum in the plot window. A vertical line (plot bar) on the 
plot marks the wavelength position of the currently displayed band. If a color 
composite image is displayed, three colored lines appear, one for each 
displayed band in the band’s respective color (RGB).

Changing the Displayed Bands

Use this procedure to change the currently displayed bands in the image display 
window.

1. Change the plot bars to the desired bands by clicking and dragging the plot 
bars with the left mouse button.

2. Double-click the left mouse button within the Z Profile plot window to load the 
new bands into the display window.

Figure 4-41: Z (spectral) Profile Plots (left) Landsat Thematic Mapper (Right) 
AVIRIS
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Browsing Spectra

To perform spectral browsing:

• Click the middle mouse button in the zoom box, then hold left mouse button 
down and drag the box across the image. 

Plotting Average Spectra

Use this procedure to plot an average spectrum calculated from a box of pixels 
around the cursor.

1. Select Options → Set Z Profile Avg window.

2. Enter the desired box size, in pixels, in the Window Size text boxes.

The average box size can also be set in the ENVI file header (see “Editing ENVI 
Headers” on page 104).

Plotting Multiple Spectra

To plot multiple Z profiles (spectra) over each other in the Spectral Profile plot 
window:

• Select Options → Collect Spectra. 

See “Using Interactive Plot Functions” on page 387 for a description of the other plot 
options.

Extracting Additional Z Profiles

A Z profile for the pixel under the cursor in the display window can be extracted from 
an additional file and plotted in a new plot window. After an additional Z profile input 
file is selected, the spectra are plotted as you are spectral browsing in the display 
window just like the data Z profile. See “Extracting Z Profiles” on page 378 for 
details about Z profile interactions.

1. From the Display menu bar, select Tools → Profiles → Additional Z Profile.

2. Select the desired input file name for the additional Z profile.
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3. Select a pixel in either the Main Image window or the Zoom window to plot 
the spectrum for the additional file in a new plot window. 

Note
An additional Z profile filename can be set in the data header file so that 
every time the Z profile function is started, both the data Z profile and 
additional Z profile will be plotted. The two plot windows will appear with 
one on top of the other so you will have to move one window.

Creating Arbitrary Profiles (Transects)

Use this procedure to specify or create transects along which arbitrary profiles will be 
drawn on the Main Image Display, Scroll, or Zoom windows. Multiple, simultaneous 
arbitrary profiles are supported. The arbitrary profiles will be numbered and color 
coded on the display. 

1. From the Display menu bar, select Tools → Profiles → Arbitrary Profile 
(Transect).

2. When the #n Spatial Profile Tool dialog appears, click on the Image, Scroll, or 
Zoom toggle button to designate which window to extract the profile from. 

3. Click the left mouse button in the image to start the transect in the selected 
window.

4. Click the left mouse button again at each new vertex of the profile. 

Note
To start over, click the middle mouse button to delete the entire transect prior 
to completion. 

5. Click the right mouse button to select the final vertex and complete the 
transect. A handle (color diamond shape) is placed on the drawn transect. 

• To move the transect, click and drag the handle with the left mouse button.

• To delete the transect, click the middle mouse button.
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6. To extract and display the profile in a plot window, click the right mouse 
button. 

Note
If the transect is extracted from a three band color composite image, then 
three profiles will be displayed in the plot window. The red band profile will 
be a solid line, the green band profile will be a dotted line, and the blue band 
profile will be a dash-dot line. 

7. Click the left mouse button in the profile plot window and move the cursor to 
mark the current position on the profile with a cross-hair cursor in the image. 

Note
The zoom box concurrently tracks the location in the profile on the Scroll, 
Main and Zoom windows, and the Main and Zoom images will be updated to 
match the position of the cursor along the profile.

8. To define another arbitrary profile, click the left mouse button in the Main 
Image, Scroll, or Zoom window again to define the new vertices. The new 
profile will be drawn and plotted in a new color in a new plot window.

Saving Transects to an Annotation Files

Use this procedure to save arbitrary profile lines drawn on the image to an annotation 
file.

1. From the Spatial Profile Tool menu, select File → Save Annotation.

2. When the file selection dialog appears, enter a filename.

Saving Spatial Profile Information to an ASCII File

All of the information associated with each spatial profile can be saved to an ASCII 
file. To save the points of the transect from a specified spatial profile to an ASCII data 
file, perform the following steps:

1. In the Extracted Profiles: section of any Spatial Profile Tool, click on the 
spatial profile whose transect points you want to save to an ASCII file.

2. Select File → Save Transect Points to ASCII....

The Save Transect Points to ASCII dialog appears. This dialog contains the 
following items:

• Select Bands to Save — This list contains the bands of the image. The 
spatial profile values from the selected bands will be saved with the 
Interactive Profiles and Spectral Plots ENVI User’s Guide



Chapter 4: Interactive Display Functions 383
transect point locations to the ASCII file. Highlight one or more bands to 
select them to be saved.

• Select All Items — This button allows you to select all the bands in the list 
at the same time.

• Clear All Items — This button allows you to deselect any/all bands 
currently selected in the list.

• Enter Output Filename — This text box and its Choose button are used 
to provide the name of the output file for the transect points and their 
related band profile values. You can either enter a filename in the text box 
or use the Choose button to browse for an existing directory or file. 
Regardless, a filename must be specified in the Enter Output Filename 
text box for the transect points to be saved to an output file.

3. When you are satisfied with your selections, click OK to save the transect 
points to the specified ASCII file.

The resulting text file contains the following information.

• Point Column — The index number describing the location of the point within 
the transect.

• X and Y Columns — The point location in pixel values.

• Distance Column — This is a value describing the distance of each point with 
respect to the beginning point of the transect. The distance for the last point is 
equal to the length of the transect.

• Band Columns — These columns contain the pixel values at each point in the 
transect for each band selected.

If the image contains georeferencing information, the text file also includes the 
following projection information.

• Map X and Map Y Columns — The point location in map projection units.

• Latitude and Longitude Columns — The point location in geographic latitude 
and longitude coordinates in decimal degrees.

• The rest of the columns contain the pixel values at each point in the transect for 
each band selected.
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Activating the Measurement Tool

1. From the Spatial Profile Tool menu, select Options → Measurement Report. 
The Profile Measurement Report dialog appears with a list of the distances 
between the vertices and the total distance when the profile is completed. 

2. Choose from options under the Units, Area, and Options pull-down menus in 
the Profile Measurement Report dialog to change the units used to report the 
distances and areas, or select whether to report the segment distances or the 
point coordinates. See “Reporting ROI Measurements” on page 305 for more 
details.

3. Select File → Save Points to ASCII to save the measurement information to a 
file.

Creating a Transect from Polyline Vectors

Polyline vectors from the Available Vectors List can now be used with the Spatial 
Profile Tool; polygon and point vectors are not accepted. To create a transect from 
vectors opened in ENVI, do the following.

1. In the Spatial Profile Tool, select Options → Create Transect from Vector. 
The Import Vector Layers dialog appears. This dialog contains the following 
items:

• Select Vector Layers to Import — This list contains the possible vector 
layers that are available for import. The vector layers available for import 
are derived from the open vector layers in the Available Vectors List. 
Highlight one or more vector layers to select them for import. The number 
corresponding to the vector layers selected is shown in the Number of 
selected items: field.

• Select All Items — This button allows you to select all the vector layers in 
the list.

• Clear All Items — This button allows you to deselect all the vector layers 
currently selected in the list.

2. When you are satisfied with your selections, click OK to create transects from 
the selected vector layers.

The transects produce spatial profiles listed in the Extracted Profiles: section of the 
Spatial Profile Tool. The resulting spatial profiles are individually displayed in new 
plot windows.
Interactive Profiles and Spectral Plots ENVI User’s Guide



Chapter 4: Interactive Display Functions 385
Creating a Transect from Map-Based or Pixel-Based Endpoints

In addition to selecting transect endpoints by clicking on the image, you can specify 
the starting and ending points of a transect using text boxes in a dialog. If your image 
data does not contain any associated map information, the endpoints are specified as 
paired x and y pixel locations. If the image data contains map information, the 
endpoints are specified based on map (UTM, geographic, or other projection) 
locations.

To create a transect from endpoints using the Spatial Profile Tool, perform the 
following steps:

1. Select Options → Create Transect from Endpoints.

If your image has no associated map information, the Enter Transect Endpoints 
dialog appears with the following items:

• Start X — The x pixel location for the starting point of the transect.

• Start Y — The y pixel location for the starting point of the transect.

• End X — The x pixel location for the ending point of the transect.

• End Y — The y pixel location for the ending point of the transect.

If there is map information associated with your image, a different Enter 
Transect Endpoints dialog appears with the following sections:

• Data Points — This toggle button allows you to provide the endpoints as 
map-based (with map projection coordinates) or pixel-based (with pixel 
locations). Selecting the pixel-based option initiates the Enter Transect 
Endpoints dialog. When map information is available for the image, the 
default setting is map-based.

• First Map Coordinate — The starting geographic or map-based 
coordinate of the transect.

• Second Map Coordinate — The ending geographic or map-based 
coordinate of the transect.

2. When you are satisfied with your selections, click OK to create a transect from 
the specified endpoints.

The transect produces a spatial profile that is listed in the Extracted Profiles: section 
of the Spatial Profile Tool dialog. The resulting spatial profile is displayed in a new 
plot window.
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Creating a Transect from ASCII Files

The Spatial Profile Tool can also accept and use transect data from an ASCII data file. 
To access this functionality, perform the following steps from the Spatial Profile Tool 
dialog.

1. Select Options → Create Transect from ASCII Data.

2. Use the Enter ASCII Points Filename dialog to open an ASCII data file. The 
Input ASCII File dialog appears.

3. Use the Input ASCII File dialog to specify the parameters of the input ASCII 
file.

If you are creating a transect from an ASCII file previously saved using the 
File → Save Transect Points to ASCII option in the Spatial Profile Tool, see 
“Saving Spatial Profile Information to an ASCII File” on page 382 for more 
information on the format of this file.

4. Click OK to create a transect from data imported from the ASCII file.

The transect produces a spatial profile, which is listed in the Extracted Profiles: 
section of the Spatial Profile Tool. The resulting spatial profile is displayed in a new 
plot window.
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Using Interactive Plot Functions

Plot windows in general provide several interactive analysis capabilities including 
moving plots between windows, data input and output, plot output, editing, 
annotation, and other options.

Mouse Button Functions in Plot Windows

The following table shows the mouse button functions available in ENVI plot 
windows.

Action
Mouse 
Button Interaction Where

Display line-cursor, data 
point location and X, Y 
values

Left Click and 
hold, drag

Inside plot window 
over data plot

Resize plot window Left Click and drag Corner of plot 
window

Move plots to new window Left Click and drag 
to new 
window

On plot label

Rescale X, Y plot ranges Middle Click and drag From any point 
inside the plot frame 
diagonally to form 
box containing 
desired subset

Reset to previous X, Y plot 
ranges

Middle Click Inside plot window

Set Y Axis to Data Range Middle Click Left of plot frame

Toggle plot name labels Right Click Inside plot window

Delete specific data plot Right Click On plot label

Table 4-9: Mouse Button Functions in ENVI Plot Windows
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Displaying an X-Y Cursor

To display an X-Y line-cursor:

• Click and hold the left mouse button within the plot. The line cursor snaps to 
the closest data point when multiple plots are displayed. The X and Y values of 
the point will be listed in the lower left corner of the plot in the color 
corresponding to the selected data set. 

To continuously display the line-cursor, data marker, and data values:

• Move the cursor with the left mouse button depressed.

Displaying Plot Data Labels

To toggle data labels on and off:

• Click the right mouse button within the plot to display the shortcut menu and 
select Plot Key. 

To edit the plot data label see “Editing Y Plot Data Values” on page 396.

To delete a plot from the plot window:

• Click the right mouse button on that data label to display the shortcut menu 
and select Remove plot name.

Note
You cannot delete the plot for the active cursor; e.g., the X profile, the Y profile or 
the Z profile in their respective windows.

Moving Plots to Another Plot Window

To move plot labels and their associated data plots from one plot window to another:

• Click and hold the left mouse button on the plot label and drag it into a 
different plot window and release the mouse button.
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Rescaling Plots (Magnify)

To rescale the x and y plot ranges within the plot: 

1. Select the new region to display within the plot window by pressing and 
holding the middle mouse button at one corner of a box to define the 
magnification region.

To reset the profile to each of the previous regions, click the middle button 
within the plot to back-stepping through the previous scalings.

2. Drag the corner to define the box.

3. Release the mouse button to redraw the enlarged profile subset. To set the Y 
plot range to encompass the full range of all plotted data, click the middle 
mouse button to the left of the plot frame.

Figure 4-42: Magnify Box in Horizontal Profile
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Plot Window Shortcut Menu

Use the plot window shortcut menu to access plot options such as turning the plot key 
on or off, stacking and unstacking plots, scaling the plot range, and to clearing the 
plot window. 

To access the shortcut menu:

• Right-click in the plot window. 

For detailed descriptions of the menu options, see “Plot Window Options” on 
page 397.

Importing Plot Data

Use the File menu in a plot window to input into the window. Data input formats 
include ASCII and ENVI spectral library.

Importing ASCII Spectra Data

Use this procedure to load ASCII data or other (x, y) data to be plotted in a plot 
window. ENVI reads ASCII data that has multiple columns separated by commas or 
white space. Lines beginning with text or semicolons at the top of the file are ignored. 

1. Within the plot window, select File → Input Data → ASCII. 

2. When the ASCII Plot Filename dialog appears, select a filename. 

3. When the Input ASCII File dialog appears, select from the following options:

• To select the X values to be read into the plot window, enter the number of 
the column containing the X values into the text box labeled X Axis 
Column (usually column 1).

• To select the Y values to be read into the plot window, click on a single 
column in the Select Y Axis Columns list to select just one column, or 
press the Ctrl (or Shift) key and click to select multiple columns.
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• To apply a scale factor to each Y value, enter the desired multiplicative 
factor into the text boxes labeled Y Scale Factor.

4. Click OK to load the spectrum or other (x, y) plot into the plot window. 

Once loaded, all of the other plot options are available.

Importing Spectral Library Data

1. Select File → Input Data → Spectral Library. 

2. When the standard ENVI input selection dialog appears, highlight the name of 
a currently-open spectral library file or a new file. 

3. Click OK.

Figure 4-43: The Input ASCII File Dialog
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4. When the Input Spectral Library dialog appears, select spectra by clicking on 
the spectrum names.

5. Click OK to load the spectra into the plot window.

Figure 4-44: Input Spectral Library Dialog
Using Interactive Plot Functions ENVI User’s Guide



Chapter 4: Interactive Display Functions 393
Editing in Plot Windows

Use the Edit pull-down menu to control data and plot parameters and to edit plot 
data. Data parameters control the line types, colors, and other attributes of plotted 
data. Plot parameters control the axes, titles, and data ranges plotted.

Editing Data Parameters

1. In the plot window, select Edit → Data Parameters.

2. When the Data Parameters dialog appears, click on the name of the plot to edit 
and select from the following options. To change the name of the data label, 
type the new name in the Name text box and press the Enter or Return key.

• To change the color of the plotted line, select from the Colors menu.

• To select the style of the line (e.g., dotted, dashed, solid), choose from 
Line Style menu. 

• To set the thickness of the line, use the Thick parameter box to adjust the 
value or enter a new value. 

• To set the number of points to average in the X direction (smoothing) when 
plotting the data, enter the value in the text box labeled Nsum and press 
the Return key. 

• To select the symbol type, select from the Symbol menu.

Figure 4-45: The Data Parameters Dialog
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• To control the size of the displayed symbols, use the SymSize text box.

• To display the line along with the selected symbols or display only the 
symbols, use the arrow toggle buttons Symbol & Line or Symbol Only.

• Click Apply when all parameters have been set to the desired values and 
Cancel when you wish to close the dialog.

Editing Plot Parameters

1. Select Edit → Plot Parameters. The Plot Parameters dialog appears.

2. To set parameters for all axes, select from the following options:

• To change the plot title, edit it in the Plot Title text box.

• To change the foreground and background colors click on the Foreground 
and Background color swatches. Left-click on the swatch to cycle through 

Figure 4-46: Plot Parameters Dialog
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the colors available; middle button clicks cycle in the reverse direction; 
right-clicks bring up the color table list shortcut menu from which to 
choose your colors.

• To change the font used for plot labels, select from the Font button menu.

• To change the character size used for plot labels, click the Charsize arrow 
increment buttons.

• To allow masking of Y values outside the specified ranges (useful for 
masking bad data points), enter values in the Min Val and Max Val text 
boxes at the bottom of the dialog.

Note
Data values less than the entered minimum value and greater than the entered 
maximum value are not plotted.

3. To set parameters for the x or y-axis, click the X-Axis and Y-Axis toggle 
button.

4. Choose from the following options:

• To change the title of the axis, enter the title in the Axis Title text box and 
press the Enter or Return key. 

• To change the thickness, enter a new value (1 is normal thickness) in the 
Thick text box. 

• To position the minimum and maximum values of the full data range 
exactly at the ends of the axis, click the Style Exact check box.

• To offset the values slightly offset from the ends of the axis, click the Style 
Extend checkbox. 

• To turn off the selected axis entirely, click the Style Off checkbox. 

• To turn off the top X axis or the right Y axis, depending on which axis is 
selected, click the Style No Box checkbox.

• To change the axis data range to be displayed, type in the respective 
minimum and maximum into the text boxes labeled Range and To and 
press the Return key. (For spectral plots, the plot range for the Y axis can 
also be set in the .hdr file by entering the values for the Z Plot Range 
parameter. See “ENVI Header Format” on page 1077).

• To plot the tick marks on the inside or outside of the axis, click the Tick 
Style In or Out toggle button.
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• To plot a continuous line across the entire plot at the location of each major 
tick mark click the Tick Style Grid toggle button.

• To turn off the tick marks entirely, click Tick Style Off. 

• To change the length of the major tick marks when they are present, enter a 
value between 0 and 0.5 in the parameter box labeled Tick Length, and 
the number of minor tick marks in the Minor Ticks textbox. Lengths are 
measured as a ratio of the axis length normalized to 1.0. For example, a 
length of 0.02 results in ticks that are 2% of the length of the entire axis. A 
length of 0.5 results in lines drawn across 50% of the plot that meet in the 
middle (the equivalent of the grid option).

• Select either Auto or Fixed next to the label Tick Marks. The Auto option 
places a predetermined number of major and minor ticks on the axis. 
Major tick marks are labeled. The Fixed option allows you to enter the 
axis parameters. This includes the starting and ending major ticks, the tick 
increment between the major ticks, and the number of minor ticks between 
major ticks.

• To control the size of the margins around the plot axes, enter the margin 
size (in characters) in the Left Margin and Right Margin (for the X axis) 
and the Bottom Margin and Top Margin (for the Y axis) text boxes.

5. Click Apply when all parameters have been set to the desired values and 
Cancel when you wish to close the dialog.

Editing Y Plot Data Values

1. In the plot window, select Edit → Data Values.

2. When the Select Which Plot to Edit dialog appears, select the name of the plot 
data to edit.

3. When the Edit Plot dialog appears, containing a list of all x and y values as 
Xloc (x-value):yvalue, click the y-value to edit. It appears in the Edit Selected 
Item: text boxes. 

4. Change the y-value to the desired value and press the Enter or Return key to 
change that value in the list. 

5. Click OK to update the plot with the new values, or click Reset.
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Plot Window Options

Use the Options menu to create new plot windows, annotate plots, stack the data 
plots, apply automatic scaling to the Y-axis, clearing the plot window, and reset the 
plot data range.

Creating New Plot Windows

To create a new, blank window:

• Select Options → New Window: Blank. 

To create a copy of the current plot window including the data within it:

• Select Options → New Window: with Plots.

Note
New plot windows can be set up as data collectors to hold useful plots from profiles 
and other plot windows.

To move plots and plot labels between windows, see “Moving Plots to Another Plot 
Window” on page 388.

For using Annotate Plot to annotate the x, y, and z profiles and other plots, see 
“Annotating Images” on page 240). 

Tip
Resize both plot and image windows to their final desired size prior to annotation. If 
the plot window is resized after annotation, the annotated objects will be offset from 
their correct positions.

Displaying Plot Keys

To turn plot key labels on or off:

• Select Options → Plot Key in the plot window or Plot Key from the shortcut 
menu.
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Stacking Plot Data

To offset all plots within the window so there are no overlapping data plots:

• Select Options → Stack Data.

Setting Stack Offset

To set the amount of offset between each stacked plot:

1. Select Options → Set Stack Offset. 

2. Enter the desired value, in percent of data range, in the Plot Stack Offset text 
box. 

Unstacking Plot Data

To replot the data without stacking:

• Select Options → Unstack Data.

Note
Unstack Data appears in the Options menu only if the data has been stacked.

Displaying Profiles of Entire Bands

To show the X or Y profile for the entire band instead of just the part of the band that 
is displayed in the Main Image window:

• Select Options → Profile: Full Band.

To show the X or Y profile only for the part of the band that is displayed in the Main 
Image window:

• Select Options → Profile: Image Window.

Automatically Scaling the Y-Axis

To automatically rescale the Y-Axis to the data minimum and maximum when adding 
or updating plots:

• Select Options → Auto Scale Y-Axis On.

To leave the current Y-Axis range set:

• Select Options → Auto Scale Y-Axis Off. 
Using Interactive Plot Functions ENVI User’s Guide



Chapter 4: Interactive Display Functions 399
Note
If auto scaling is off and a plot is added outside the y-axis range set, that plot 
will not be visible until the y-axis is rescaled.

Clearing Plots

The Clear Plot selection appears under the Options menu in plot windows if they 
were created using ENVI spectral library functions or using New Window. 

To clear all of the displayed plots within one of these windows:

• Select Options → Clear Plot. 

Note
Profiles can not be cleared because they contain the profile for the current 
pixel.

Resetting Plot Ranges

To reset the x and y plot axes to their default data ranges or minimum and maximum 
values:

• Select Options → Reset Range or click the middle mouse button to the left of 
the y-axis.

Note
This option always resets the range to its original values even if it was reset 
using the Plot Parameters option or using the middle mouse button to zoom 
into a part of the plot.

Plotting an Average Z Profile Spectrum

The Set Z Profile Avg Window selection appears under the Options menu in Z 
profile plot windows. Use it to plot an average spectrum calculated using a box 
around the cursor:

1. Select Options → Set Z Profile Avg Window.

2. Enter the desired box size, in pixels, in the Window Size text boxes. 

The average box size can also be set in the ENVI file header (see “Editing ENVI 
Headers” on page 104).
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Collecting and Replacing Spectra

To plot multiple Z profile spectra:

• Select Options → Collect Spectra.

To replace the current Z profile with the new profile spectrum:

• Select Options → Replace Spectrum.

Additional Functions in Plot Windows

Select from the following additional plot functions. These functions are accessed 
through the plot window Plot_Function menu.

To plot the band number (or other index number) on the X axis:

• Select Plot_Function → X Axis:Index.

For plots of images with wavelengths in the image header, plot the wavelength on the 
X axis:

• Select Plot_Function → X Axis:Wavelength.

For plots of images with wavelengths in the image header, plot the wave number 
(1/wavelength) on the X axis:

• Select Plot_Function → X Axis:1/Wavelength.

To replot the data displayed in the window with its continuum removed:

• Select Plot_Function →  Continuum Removed. The continuum is the 
convex hull that fits over the data and is divided into the original data values to 
produce the continuum removed values (see “Using Continuum Removal” on 
page 788 for details). The continuum is calculated using the first and last data 
points displayed in the plot, so for plots that have been zoomed, the continuum 
is calculated based on the displayed data range only. 

To replot the data displayed in the plot window as binary encoded plots (0s and 1s):

• Select Plot_Function →  Binary Encoding. Binary encoding replots the data 
as a spectrum of 0s and 1s. It calculates the mean of the data and encodes each 
value as a 0 if it is less than or equal to the mean and as a 1 if it is greater than 
the mean (see “Applying Binary Encoding Classification” on page 606 for 
details).
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To replot the original data values:

• Select Plot_Function → Normal. 

You can add your own IDL plot function to this menu by entering the name of the 
function into the useradd.txt file in the ENVI menu subdirectory (see “Plot 
Function” in the ENVI Programmer’s Guide manual) and adding a .pro or .sav file 
containing the function code to the ENVI save_add subdirectory.

Saving Plot Data

Use the File menu in plot windows to save plot data. You can save plot images or 
output data to ASCII files, spectral libraries, IDL variables, PostScript files, and 
image files.

Saving Plot Data to ASCII Files

1. Select File → Save Plot As → ASCII.

2. When the Output Plots to ASCII File dialog appears, select the data to save by 
clicking on the plot names in the Select Plots to Output list.

3. Click the arrow increment buttons to set the numeric precision for the X and Y 
output ASCII variables.

4. Click the arrow toggle button to select whether to save floating point data in 
Scientific or Normal format.

5. Enter the output name in the text box labeled Enter Output Filename or click 
the Choose button to select a filename. 

6. Click OK to save the selected spectra to the ASCII file. 

Saving Plot Data to Spectral Libraries

Use this procedure to build a standard ENVI spectral library file (spectral library 
image) from profiles and spectral plots. 

1. Select File → Save Plot As → Spectral Library.

2. When the Output Plots to Spectral Library dialog appears, choose the desired 
spectra by clicking on the spectrum name.

3. Select File or Memory output. If you choose File, enter an output filename.

4. Click OK to save the selected spectra to the Spectral Library.
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Exporting Plot Data to the IDL Command Line

Note
If the ENVI command line is not visible in the IDL window, select 
Window → Command Input in the IDL window.

1. From the plot window select File → Save Plot As → IDL Variable. The 
Export Plots to IDL Variable dialog appears.

2. Select the Plots to Export by clicking on the plot names.

3. Select one of the following options:

• In the New Variable Name dialog, enter the name of an undefined IDL 
variable.

• If previous variables have been defined, select the name of a variable to 
receive the report from the displayed list.

4. Press the Enter key on your keyboard.

The exported data will be available to use at the ENVI command line. If data from 
more than one plot is exported to a single variable, the data will be exported into a 
two-dimensional array that contains the x and y values for each plot. The first row, 
array [∗,0], contains the x values for the first plot, the second row, array [∗,1], 
contains the y values for the first plot, the third row, array [∗,2], contains the x values 
for the second plot, etc.

Saving Plots to Files and Printers

To save a plot and any associated annotation as a PostScript or other image format 
file:

• Select File → Save Plot As → PostScript or Image File.

To print the plot:

• Select File → Print.

For detailed instructions, see “Display Output Options” on page 446.
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Extracting Polarization Signatures

To extract and display polarization signatures from the current pixel for quad-
polarized radar data (AIRSAR and SIR-C):

1. From the Display menu bar, select Tools → Polarization 
Signatures → AIRSAR or SIR-C.

Note
The radar data does not have to be displayed. Any co-registered image data 
set can be used for pixel location.

2. When the Input Stokes Matrix Files dialog or the Input Scattering Matrix Files 
dialog appears, click Open File to select and open the appropriate radar data 
file. 

3. Click OK.

4. When the Polarization Signature Viewer appears, select Options → Extract 
Current Pixel to plot the polarization signature for the current pixel. 

For details about the Polarization Signature Viewer, see “Extracting Polarization 
Signatures from Single Pixels” on page 1037 and “Using the Polarization Signature 
Viewer” on page 1040.

Figure 4-47: The Current Pixel Polarization Signature
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Color Mapping

Use Color Mapping to apply color tables to images, create interactive density sliced 
images, control the RGB image planes and to change classification color mapping.

Note
A color image displayed using one of the methods outlined in this section can be 
saved to an RGB color image. For instructions, see “Saving to Image Files” on 
page 450.

Applying ENVI Color Tables and Density Slices

Use ENVI Color Tables to apply linear contrast stretching and standard color tables 
(density slices) to grayscale images. 

Note
To make your own color tables, see “Editing System Color Tables” on page 177.

1. From the Display menu bar, select Tools → Color Mapping → ENVI Color 
Tables. 

The ENVI Color Tables dialog appears, where you may adjust the screen color 
tables using the default color tables.

Figure 4-48: ENVI Color Tables Dialog
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The dialog contains a grayscale wedge (or color wedge if a color table is 
applied) and two sliders to control the contrast stretch. It also has two pull-
down menus, File and Options.

2. Select any of the following options:

• To have any color table changes applied to your images automatically, 
select Options → Auto Apply: On.

• To have changes applied manually, select Options → Auto Apply: Off. 
After making changes, select Options → Apply.

Note
The Auto Apply option is automatically set in 8-bit mode.

3. Move the sliders labeled Stretch Bottom and Stretch Top to control the 
minimum and maximum values to be displayed. Moving the Stretch Bottom 
slider to the right causes bright areas of the image to become darker, while 
moving the Stretch Top slider to the left causes dark areas of the image to 
become brighter. The stretch can be inverted by moving the Stretch Bottom 
slider all the way to the right and the Stretch Top slider all the way to the left.

Note
If Auto Apply is on, the new contrast stretch is applied to the image 
immediately. 

4. Apply a selected color table automatically to the current image by clicking on 
the desired color table name. ENVI provides a number of pre-saved color 
tables. The B-W linear table provides a grayscale image. The RAINBOW 
color table provides a cool-to-hot density slice. Other color table options allow 
you to apply their preferred color scheme.

• To reset the original color tables and stretch, select Options → Reset 
Color Table. 

• To return to the main screen and retain the selected color table, select 
File → Cancel.

Saving Color Tables to ASCII Files 

1. In the ENVI Color Tables dialog, select File → Save Color Table to ASCII. 

2. Enter a filename and click OK.
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Using Interactive Density Slicing

Use Density Slice to select data ranges and colors for highlighting areas in your 
grayscale image. The data ranges used in the density slice coloring can be from the 
displayed image or from another image of the same size. For detailed instructions, see 
“Interactive Density Slicing” on page 279.

Controlling RGB Image Planes

Use Control RGB Image Planes to control the individual color planes (or channels) 
of an RGB or grayscale image. A standard RGB image uses the red, green, and blue 
guns of the display device to form a color additive representation of color. A 
grayscale image is a special case, where all three guns are assigned the same value for 
each pixel.

1. Select Tools → Color Mapping → Control RGB Image Planes. The #N 
RGB Channels dialog appears, where N is the display number used to start the 
function. When first started, all three image color channels are turned on.

2. Select one or more of the left arrow toggle buttons to turn off/on individual 
color planes. The button name will change to reflect the color plane setting 
(On or Off).

• To invert the current stretch (a low-to-high stretch becomes a high-to-low 
stretch and vice versa), select one or more of the right arrow toggle 
buttons. The button name changes to reflect the color plane setting 
(Normal or Inverse).

• To apply RGB Channel functions to all of the color planes simultaneously, 
select Options → Turn All Channels Off/On or Invert All Channels.

3. Select File → Cancel to exit the function.

Note that the color planes remain as set prior to exit.

Tip
For 24-bit color displays, color changes are not automatically applied. Select 
Options → Apply when a 24-bit color display is in use to display the color 
changes.
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Mapping Class Colors

Use Class Color Mapping to change classification image colors and class names for 
individual classes. The changes can be saved to the header file.

Tip
For class color changes to appear correctly on output, you must save the class color 
changes.

1. From the Display menu bar, select Tools → Color Mapping → Class Color 
Mapping.

Note
If your classification is overlaid on a base image, you can access the Class 
Color Mapping dialog from the Interactive Class Tool dialog by selecting 
Options → Edit class colors/names (see “Overlaying Classes” on 
page 265).

Figure 4-49: The RGB Channels Dialog
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The Class Color Mapping dialog appears.

2. In the Selected Classes list, click on the name of the class to be changed.

3. In the Class Name text box, change the name. 

4. From the System button menu, select a color system: RGB, HSV, HLS (see 
“Color Transforms” on page 695 for more information about color spaces).

5. Select one of the following options to set the values of the class colors:

• Select a color from the V menu.

• Move the three sliders (0-255 for the three colors in RGB). 

• Click the arrow increment buttons to change the values or enter new values 
into the text boxes and press Enter.

Figure 4-50: The Class Color Mapping Dialog
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6. Select Options → Save Changes to save the changed classification names and 
colors to the classified image header file.

Note
To reset the original class colors and names, select Options → Reset Color 
Mapping.

Note
Color changes on 24-bit color displays, are not automatically applied. 
Instead, select Options → Apply.
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Using the Pixel Locator

Use Pixel Locator to manually enter a sample and a line location for positioning at 
the center of the Zoom window.

1. From the Display menu bar, select Tools → Pixel Locator. The Pixel Locator 
dialog appears, pertaining to a specific display. You may have a Pixel Locator 
for each ENVI display group. Crosshairs are drawn in the zoom window 
outlining the center pixel.

2. Enter a Sample (horizontal) and Line (vertical) location into the 
corresponding text boxes. 

3. Select whether to use an image offset by selecting Options → Use Image 
Offset: Yes or No.

4. Click Apply and the zoom box jumps to the specified pixel location. 

Note
To move the center of the Zoom window one pixel in the direction of the arrow, 
click the arrow buttons at the bottom of the dialog.

Figure 4-51: The Pixel Locator Dialog: Pixel-Based Images, 
and Georeferenced Images
Using the Pixel Locator ENVI User’s Guide



Chapter 4: Interactive Display Functions 411
Using the Locator with Georeferenced Data

When georeferenced data is displayed in the Image window, the Pixel Locator can be 
used in either pixel or map coordinates. 

1. In the Pixel Locator dialog, select Options → Pixel Coordinates or Map 
Coordinates. 

2. In the Pixel Locator dialog, click the Proj arrow toggle button to toggle 
between map coordinates and geographic coordinates (latitude/longitude).

3. Enter the desired easting (E) and northing (N) (or latitude and longitude). The 
Zoom window is centered on the nearest pixel.

Tip
When ENVI’s image-to-map registration function is active, use the Export button 
in the Pixel Locator dialog to deliver map coordinates to the function (see “Entering 
Map GCPs from Vector Windows” on page 869). 

The Export button produces no effect if a registration session is not active.
ENVI User’s Guide Using the Pixel Locator



412 Chapter 4: Interactive Display Functions
Collecting Points

Use Point Collection to collect points (both pixel locations and map locations) from 
display windows. The points are displayed in a table in the ENVI Point Collection 
window. You can save points from various display windows in a single table and 
export them to the Ground Control Points (GCP) List, save them to ASCII or ENVI 
Vector Files (EVFs), and restore them from ASCII files. 

1. Select one of the following options to begin:

• From the Display menu bar, select Tools → Point Collection.

• From the ENVI main menu, select Window → Point Collection.

The ENVI Point Collection window appears.

2. Click the middle mouse button in a Main Image window or Zoom window to 
collect the point under the cursor.

The pixel locations appear in the table. If the data is georeferenced, map and 
geographic locations are also listed.

Changing the Table Sort Order

• To sort the points in the table by a particular value, click on the column 
heading of the value. To sort the points inversely by the same value, click on 
the column name again. The table is automatically updated.

• To reset the table to the original order, select Options → Reset Listing Order.

Figure 4-52: The Point Collection Window

Click on 
a column 
heading 
to resort 
the table.
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Changing Numeric Precision

To change the numeric precision of the data points:

1. Select Options → Set Report Precision. The Set Report Precision dialog 
appears.

2. Enter the desired number of significant figures shown after the decimal point 
in the text boxes.

Note
To change the report of latitude and longitude values between degrees, minutes, 
seconds (DMS) and decimal degrees (DD), click on the Lat/Lon Report arrow 
toggle button.

ENVI Point Collection Options

• To go to the location of a point, click on the point number (gray buttons, far left 
column) and click the Goto button. The Zoom window for the display 
containing the data moves so that it is centered over the selected pixel.

• To export map locations to the Ground Control Points Selection dialog, click 
on the point number (far left column) and click Export.

• To delete a point, click on the point number (far left column) and click Delete.

• To delete all the points, click Delete All.

Importing Points from ASCII Files

To import points from an ASCII file into the point collection table:

1. Select File → Import Points from ASCII and select the input filename.

2. In the Input ASCII FIle dialog, select which columns of data contain the 
Image X and Y pixel locations, the Map X and Y values and the Lat/Long 
values.

3. Select the projection type if you have map values.

4. From the Associated Image button menu, select the display number associated 
with the imported points. 

Note
If no display is associated with the points, select None.
ENVI User’s Guide Collecting Points



414 Chapter 4: Interactive Display Functions
5. Click OK. 

The points appear in the point collection dialog.

Saving Points to ASCII Files

To save points to an ASCII file:

1. Select File → Save Points As → ASCII.

2. Enter an output filename.

Note
If points from more than one projection are contained in the point collection table, 
multiple ASCII output files will be created with a _1, _2, etc. appended to the 
filename.

Saving Points to Vector Files

To save points to an ENVI vector file:

1. Select File → Save Points As → EVF layer.

2. Enter a layer name and an output file name.

3. Click OK.

The layer name appears in the Available Vectors List.

Tip
You can load these points on the image display or in a vector window and add 
attributes (see “Vector Attributes” on page 223).

Hiding the Point Collection Window

• To hide the window, select Options → Hide Window. When the ENVI Point 
Collection window is hidden, you can still collect points by clicking in an 
image window with the middle mouse button.

• To display the window again, click on the window name in the Window Finder, 
or select Window → Point Collection. 
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Building Masks

Use Build Masks to create image masks from specific data values (including the data 
ignore value), ranges of values, finite or infinite values, ROIs (Regions of Interest), 
ENVI vector files (EVFs), and annotation files. For detailed instructions, see 
“Building Masks” in Chapter 5.

Measurement Tool

Use Measurement Tool to get a report on the distance between points in a polygon 
or polyline, and to get perimeter and area measurements for polygons, rectangles, and 
ellipses. For detailed instructions, see “Using the Measurement Tool” in Chapter 5.

Note
To measure ROIs while using the ROI function, see “Reporting ROI 
Measurements” on page 305.
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Using the Line of Sight Calculator

Use the Line of Sight Calculator to calculate which pixels can be seen from a specific 
pixel within any file that has an associated DEM. The pixels that can be seen are 
output as an ROI. 

1. Select Tools → Line of Sight Calculator. The Line of Sight calculator dialog 
appears. The current pixel location is listed in the Sample and Line text boxes. 

2. In Zoom window, click on a pixel or enter the Sample and Line coordinates of 
the pixel for which you want the line of sight calculated.

• To select a different pixel, use the solid black arrow buttons to move the 
Zoom window crosshairs in single pixel increments in the corresponding 
direction.

• To designate whether or not to apply X and Y offsets for data that has 
offsets, select Options → Use Image Offset:Yes or No.

• To select pixels for georeferenced images, see “Selecting Pixels for 
Georeferenced Images” on page 417).

3. Click the Apply button. The Select Line of Sight Input DEM Band dialog 
appears.

Figure 4-53: The Line of Sight Calculator
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4. Select the file that contains the DEM that is associated with the displayed 
image and click OK. The Line of Sight Parameters dialog appears.

5. Enter the maximum distance (in meters) for the line of sight calculation. 

Note
To designate an elevation above the pixel, enter the value in the same units as 
the DEM.

6. Click OK.

An ROI is created that shows which pixels can be seen from the designated pixel. The 
ROI is labeled LOS in the ROI Tool dialog and is overlaid on your image.

Selecting Pixels for Georeferenced Images

1. In the Line of Sight Calculator, select Options → Map Coordinates.

2. Enter the map coordinates into the E and N text boxes, respectively.

• To enter the coordinates in latitude and longitude, click the arrow toggle 
button next to the map projection name and enter the values into the Lat 
and Long text boxes. Use negative (–) longitude for the western 
hemisphere and negative (–) latitude for the southern hemisphere.

• To change the latitude and longitude values between degrees, minutes, 
seconds, and decimal degrees, click on the DMS / DDEG button.

• To return to map projection coordinates, click the arrow toggle button. The 
corresponding map projection coordinates are calculated automatically.

Figure 4-54: The Line of Sight Parameters dialog.
ENVI User’s Guide Using the Line of Sight Calculator



418 Chapter 4: Interactive Display Functions
Using the Spatial Pixel Editor

Use Spatial Pixel Editor to display pixel values in a table and to interactively change 
the values of problem pixels. Individual pixel values or entire lines or columns can be 
replaced if you enter a different value or data mean, or if the averages of surrounding 
pixels, lines, or columns are used. The changes can be saved to the disk file.

Note
This function only works on ENVI format files.

From the Display menu bar, select Tools → Spatial Pixel Editor.

The Spatial Pixel Editor dialog appears with the pixel values for the Zoom window 
shown in a table. The sample and line numbers are shown around the top and side of 
the table. The location of the pixel highlighted in the table is shown by a green box in 
the zoom window.

Figure 4-55: The Spatial Pixel Editor Dialog
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Selecting Pixels

To select pixels and display their values in the Spatial Pixel Editor table:

In the Main Image window, move the Zoom window by clicking and dragging with 
the left mouse button or click the middle mouse button on a pixel to place it in the 
center of the Zoom window.

Changing Pixel Values

Select from the following options to change pixel values:

• To enter a new value for a single pixel, click on the pixel value in the table, use 
the backspace key to erase the current value, enter the desired value, and press 
return.

• To replace the value of a single pixel with the average of the four or eight 
surrounding pixels, click on the pixel value in the table and select 
Options → Replace cell with 4 pixel average or Replace cell with 8 pixel 
average. 

• To enter a new value for a group of pixels:

A. Select the pixel values in the table by clicking and dragging or by clicking 
on a column or line number.

B. Select Options → Replace selected cells with value. Enter the desired 
value and click OK.

• To replace the value of a group of pixels with the group mean, select the pixel 
values in the table by clicking and dragging or by clicking on a column or line 
number and select Options → Replace selected cells with mean. 

• To replace a column or line (across the whole image) with the average of 
surrounding columns or lines, click on the column or line number around the 
table and select Options → Replace selected column/line with average. 

• To designate the number of columns or lines surrounding the selected pixel to 
be used in calculating the average:

A. Select Options → Set # of lines for averaging. 

B. Enter the desired number of columns or lines to use on each side of the 
selected one to calculate the average. 
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Undoing Changes

• To undo all changes in pixel values, select Options → Undo all changes.

Saving Pixels to Files

• Save the pixel value changes to a file by selecting File → Save changes to file.

Closing the Spatial Pixel Editor

• To exit the Spatial Pixel Editor, select File → Cancel.
Using the Spatial Pixel Editor ENVI User’s Guide



Chapter 4: Interactive Display Functions 421
Using the Spectral Pixel Editor

Use Spectral Pixel Editor to replace the current pixel across all spectral bands in 
multispectral and hyperspectral data. You can replace pixels with an average of 
surrounding pixels or with another spectrum entered through a plot window. 

1. From the Display menu bar, select Tools → Spectral Pixel Editor. An empty 
plot window appears.

2. In the Spectral Pixel Editor plot window, select from the following options.

• To plot the current spectrum, select Edit → Extract Current Spectrum. 

• To plot an average spectrum calculated from the 8 (4 or 2) pixels 
surrounding the current pixel, select Edit → Extract 8 (4 or 2) pixel 
average. 

• To input a spectrum from an ASCII file or spectral library, select 
File → Input.

• To import a spectrum from another window, click on the plot label name 
and drag it into the Pixel Editor Spectrum plot window. 

• To choose which spectrum to substitute for the current pixel’s spectrum, 
select Edit → Substitute Spectrum. 

Warning
This last step physically replaces the current spectrum values in the data file.
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Creating Animations

Use Animation to create a movie out of images from one or more open files.

Selecting Bands for Animation

1. From the Display menu bar, select Tools → Animation.

2. When the Animation Input Parameters dialog appears, choose from the 
following options. 

Note
All of the bands from the currently displayed image are selected for 
animation by default.

• To select additional bands from files of the same size, click on the bands 
with the left mouse button while pressing the Ctrl key on your keyboard.

• To clear individual bands from the list if they are already selected, click on 
the desired band with the left mouse button while pressing the Ctrl key on 
your keyboard. 
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• To use standard ENVI subsetting procedures to reduce the size of the 
image to be animated, click Spatial Subset.

3. Set the desired size of the animation display window by entering values in the 
boxes next to the Window Size text label.

Note
Note that the selected images are automatically resized to the selected 
window size. Reducing either the spatial subset to be animated and/or the 
size of the animation window enhances the speed of the animation. 

4. Select a resampling method by clicking the Aggregate or Nearest Neighbor 
button. Nearest neighbor resampling uses the nearest pixel value in the 
animation window and aggregate averages all the pixel values that contribute 
to the output animation pixel. For example, if your animation window size is 
half the size of the image, the nearest neighbor method will use every other 
pixel and every other line to create the image in the animation window and the 
aggregate method will average four pixels to create the output image.

5. Click OK to start the animation.

When the animation is activated, the individual selected bands are automatically 
subset, resampled, and loaded into the Animation widow. A status bar appears as 
each image is processed. 

Figure 4-56: The Animation Input Parameters Dialog
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After all of the selected images have been loaded, the animation starts automatically. 
Each selected band is displayed sequentially. 

Controlling Animation Characteristics

After the animation is loaded, you can specify the animation characteristics.

The following table describes the available options in the Animation window:

Figure 4-57: The Animation Window Menu Bar and Controls

Option Description

To set the animation speed, enter a number from 0 to 100 into 
the Speed text box, or use the arrow buttons to set the speed.

To turn the real-time frame number slider on and off, select 
Options → Update Slider:On/Off from the menu at the top 
of the Animation window.

Table 4-10: Animation Window Controls
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Saving Animations

You can save an animation as an MPEG (Moving Picture Experts Group) file.

Note
Saving an animation as an MPEG file requires a special license. For more 
information, contact your Research Systems sales representative or technical 
support. 

1. Select File → Save Animation as MPEG. The Output Sequence to MPEG 
Parameters dialog appears.

Click to display the animation from the highest frame to 
lowest. 

Click to display the animation from lowest frame to the 
highest.

Click to display the animation from the lowest frame to the 
highest frame and back again. 

Click to pause the animation at the current frame. 

Figure 4-58: The Output Sequence to MPEG Parameters

Option Description

Table 4-10: Animation Window Controls
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2. From the MPEG Frame Rate button menu, select a frame rate in frames per 
second.

3. In the MPEG Quality text box, enter a compression quality value between 0 
and 100, or use the arrow buttons to set the value.

The compression is a lossy compression where 0 is lowest quality and 100 is 
highest quality (no compression). Entering a compression quality factor less 
than 100 decreases the amount of disk space used to store the MPEG output.

Note
A duplication factor helps to make the MPEG output appear smoother. To 
duplicate frames in the MPEG output, enter or select a Duplicate frames 
number. 

4. Enter or choose an output filename and click OK.

Cancelling Animations

• To cancel the animation at any time, select File → Cancel from the Animation 
window menu.
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Using Two-Dimensional Scatter Plots

Use 2D Scatter Plots to interactively classify two bands of image data. If desired, 
multiple scatter plots can be active simultaneously. Two-dimensional scatter plots use 
only the data in the Main Image window so quick interactive response is provided. 
Regions of Interest can be selected in the scatter plots and saved for use in other full 
band processing techniques. Dancing Pixels show how the distribution of pixels 
under a box changes as it is moved interactively in both the scatter plot and image. 
The density distribution of the scatter plot can also be shown.

To compare the DNs in two selected bands as both a scatter plot and in terms of their 
spatial distribution in the image, proceed with the steps in the following sections. 

Selecting Bands for Scatter Plots

1. From the Display menu bar, select Tools → 2D Scatter Plots.

2. When the Scatter Plot Band Choice dialog appears, choose the X and Y axes 
for the scatter plot by clicking on the desired bands in the columns labeled 
Choose Band X and Choose Band Y.

3. Click OK to extract the two dimensional scatter plot from the two selected 
bands. 

Figure 4-59: The Scatter Plot Band Choice Dialog
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Depending upon the size of the image, there may be a brief delay while the DN 
values are extracted and tabulated. As soon as the scatter plot appears, the interactive 
scatter plot function is available for use.

Resizing Scatter Plot Windows

To resize a scatter plot window, grab the corner of the window and drag to the desired 
size.

Warning
Resizing the window requires more memory and may not be as efficient.

To reset the window to the default size, select Options → Reset Size.

Viewing Pixel Distribution of Scatter Plots

Use Dancing Pixels to interactively view, in the Image window, the distribution of 
points under a box drawn in the scatter plot. As the cursor moves, the spatial 
distribution of the corresponding pixels on the image changes accordingly.

1. Select Options → Scatter:Dance.

2. Place the cursor anywhere inside the scatter plot and click the middle mouse 
button to plot a colored box on the scatter plot. Simultaneously, all pixels on 
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the image that fall within the DN range of those selected in the scatter plot box 
are plotted in color in the Main Image window. 

3. Press and hold the middle mouse button while moving the cursor in the scatter 
plot to cause real-time Dancing Pixels to appear in the Main Image window. 

Viewing Pixel Distribution of Images

Use Scatter Plot Dancing Pixels to interactively view, in the scatter plot, the 
distribution of the points that are in highlighted in the image window.

1. Select Options → Image:Dance.

2. Place the cursor anywhere inside the Main Image window and click the left 
mouse button while the scatter plot is displayed to mark pixels in color on the 
scatter plot. 

This shows the DN distribution of pixels falling within a spatial box the same 
size as that used in the scatter plot (see “Setting Patch Sizes” on page 435). 
The box is not plotted on the Main Image display because of speed 
considerations. 

Figure 4-60: Selecting Pixels to Highlight in the Image Window
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3. Press and hold the left mouse button while moving the cursor in the Main 
Image window to highlight the pixels in the scatter plot in real time as Dancing 
Pixels.

Zooming in Scatter Plots

To zoom in on an area within a scatter plot:

1. Select Options → Scatter:Zoom.

2. In the Scatter Plot window, click with the middle mouse button and drag the 
box outline that appears.

Note
To return to normal viewing, click in the Scatter Plot window with the middle 
mouse button.

Figure 4-61: Dancing Pixels Displayed in the Plot Window
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Displaying Scatter Plot Density Distribution

Many image pixels can have the same DN values within bands and will lie in the 
same place in the scatter plot. The scatter plot density distribution is color coded 
using a rainbow color table from purple to red with purple indicating low density.

• To show the density distribution of the scatter plot, select Options → Density 
On or Off.

Note
If a Z profile is associated with the scatter plot, the density distribution is shown by 
clicking the right mouse button outside the plot axes.

Changing the Density Distribution Color Table

To change the color table used to define the density distribution colors:

1. Select Options → Select Density Lookup.

2. In the Select Density Lookup dialog, click on the desired color table name. The 
selected color table is applied automatically.

3. Designate the number value of the color that will be used to represent the 
lowest values in the scatter plot (color tables have 256 values) by clicking the 
Scaling Floor arrow increment buttons or by entering the value into the text 
box.

Note
For color tables that have black on the lower end, setting a higher color value 
to represent the lowest density points in the scatter plot applies more visible 
colors (instead of black) to those points so that all points in the scatter plot 
are visible.
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Drawing ROIs on Scatter Plots

ROIs can be drawn in the scatter plot to provide an interactive classification method.

Drawing a Single ROI 

1. In the Scatter Plot window, click the left mouse button at the vertices of a 
polygon enclosing the desired region.

2. Use the right mouse button to close the polygon and complete the selection. 
When the region is closed, all pixels in the image that fall within the DN range 
of those selected in the scatter plot are highlighted in color in the Main Image 
window. 

Drawing Multiple ROIs or Classes

1. In the Scatter Plot window, select Class → Items N:M for a color list from 
which to select another color.

2. Draw another ROI as described in the previous procedure.

The corresponding pixels in the image are highlighted in the new color.

Editing Classes

To remove pixels from an existing class:

1. In the Scatter Plot window, select Class → White.

2. Draw a polygon around the pixels to remove them. The deleted pixels return to 
white. 

Changing Class Colors

Use the Class menu to change the color of the scatter plot highlighting. Multiple 
ROIs or classes can be defined by selecting a new color for each class. The currently 
selected class corresponds with the color selected under the Class pull-down menu.

Deleting Classes

To completely delete the selected class polygon, click the middle mouse button 
outside the scatter plot axes.
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Options in Scatter Plot Windows

Use the Options menu on the scatter plot menu bar to choose functions that control 
the operation of the two-dimensional scatter plots. Options include controlling the 
image mode, clearing and exporting classes, calculating mean spectra, linking the 
scatter plot with a Z profile window, changing the patch size used for extracting 
dancing pixels, and changing the band selections.

Two-Dimensional Scatter Plot Shortcut Menu

Many options in the scatter plots can also be accessed by right-clicking in the scatter 
plot and selecting from the shortcut menu that appears.

Viewing Dancing Pixels

As described in “Viewing Pixel Distribution of Images” on page 429, you may link 
mouse movement in the image window to concurrent plotting of corresponding pixels 
as Dancing Pixels in the scatter plot for the selected patch size.

• Select Options → Image Dance.

Figure 4-62: The Scatter Plot Shortcut Menu
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Drawing ROIs in Images

Use the Image ROI option to draw ROIs in the image window using the standard 
polygon ROI procedures described in “Drawing ROIs” on page 291. The ROI pixels 
are highlighted in the scatter plot and all pixels with similar spectral characteristics in 
the two selected bands are plotted in color as an overlay on the displayed image.

• Select Options → Image ROI.

Turning Off Scatter Plot Mouse Functions

• To turn off the scatter plot mouse button functions in the image window and 
return them to their standard functionality, select Options → Off.

Clearing Classes

• To remove the ROIs and associated image window highlighted pixels from the 
scatter plot and image window for the selected class color, select 
Options → Clear Class.

• To remove all the ROIs and associated image window highlighted pixels from 
the scatter plot and image window for all the classes, select Options → Clear 
All.

Exporting Classes

Use Exporting Classes to export the highlighted image window pixels for the 
selected class color or for all of the classes to a standard ENVI ROI. You can use the 
exported ROI in other ENVI functions. 

• To export a selected class, select Options → Export Class. If the ROI 
Controls window is on the screen, the region is listed as a Scatter Plot Import. 
The class color and number of pixels in the region is also listed. 

Note
The ROIs are retained in memory even when the ROI Controls window is not 
on screen. The Scatter Plot Import region will be listed in the ROI window 
the next time it is started.

• To export the highlighted image window pixels for all of the classes, select 
Options → Export All.
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Calculating Mean Spectra

To calculate the mean spectrum for the selected class or for all the defined classes:

1. Select Options → Mean Class or Options → Mean All.

2. When the Input File Associated with 2D Scatter Plot dialog appears, select the 
corresponding input file.

The mean spectra are calculated and displayed in a plot window. If a Z Profile 
window associated with the scatter plot is open, the same data is automatically used 
to calculate the mean spectra.

Attaching Z Profiles

To associate a Z Profile window (spectral plot) with the Scatter Plot:

1. Select Options → Z Profile.

2. When the Input File Associated with 2D Scatter Plot dialog appears, select the 
corresponding input file.

3. Click the right mouse button inside the scatter plot to display the spectrum for 
the point nearest the cursor. 

See “Extracting Z Profiles” on page 378 for details on using Z Profiles.

Setting Patch Sizes

The patch size is the size of the box used for the Dancing Pixels options.

1. Select Options → Set Patch Size.

2. When the Scatter Plot Patch Size dialog appears, enter the number of pixels to 
use for the size of the patch (a square box) or use the increment arrows to set 
the desired size. 

For example, a patch size of 10 refers to a 10 x 10 pixel box in either the Image or the 
Scatter Plot.

Setting Axis Ranges

Use Set X/Y Axis Ranges to change the pixel value range of the X or Y axes.

1. In the Scatter Plot window, select Options → Set X/Y Axis Ranges.

The Set Scatter Plot Axis Ranges dialog appears.

2. In the Xrange and Yrange text boxes, enter the desired pixel value range.
ENVI User’s Guide Using Two-Dimensional Scatter Plots



436 Chapter 4: Interactive Display Functions
Note
To return the range values to the original minimum and maximum values, 
click the Reset Ranges button.

3. Click OK. The scatter plot will be rescaled to the new axes ranges.

Tip
To reset the axis ranges to the original minimum and maximum values, select 
Options → Reset Range in the Scatter Plot window.

Resetting the Plot Window Size

If you have resized the scatter plot window, select Options → Reset Size to reset it to 
the default size.

Note
The default window size provides the most efficient interaction.

Changing Bands

Use Change Bands to change the bands used in the scatter plot and to plot previously 
defined classes on the new scatter plot. The corresponding image window pixels will 
be highlighted.

1. Select Options → Change Bands.

2. When the Scatter Plot Band Choice dialog appears, choose new X and Y axes 
for the scatter plot by clicking on the desired bands as described in “Selecting 
Bands for Scatter Plots” on page 427.
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Managing Scatter Plots

Use the File menu on the Scatter Plot menu bar to activate functions that control the 
input and output of the scatter plots. Functions include outputting the scatter plot, 
importing saved ROIs, and canceling the scatter plot function.

Starting New Scatter Plots

To start an additional scatter plot window that uses different bands:

1. Select one of the following options:

• In the Scatter Plot window, select File → New Scatter Plot.

• From the Display menu bar, select Tools → 2D Scatter Plot.

2. When the Scatter Plot Band Choice dialog appears, select the X and Y bands.

3. Click OK.

A new Scatter Plot window appears in addition to the initial scatter plot.

Outputting Scatter Plots

You can save scatter plot windows as PostScript files or image files (RGB binary 
file): BMP, HDF, JPEG, PICT, SRF, TIFF, or XWD files. 

• To save a Scatter Plot, select File → Save Plot As → Postscript or Image 
File. 

For detailed instructions, see “Display Output Options” on page 446.

Importing ROIs to Scatter Plots

To import previously saved Regions of Interest to the scatter plot:

1. Select File → Import ROIs.

2. When the Import ROIs to Scatter Plot dialog appears, select from the list of 
existing ROIs. 

The ROIs selected are plotted in the Image window and the corresponding points are 
highlighted in the Scatter Plot. Additional pixels that fall within the same Scatter Plot 
regions are highlighted in the Image window.
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Three-Dimensional Surface Views

Use ENVI’s 3D SurfaceView to fly-through your three-dimensional data sets. For 
detailed instructions, see “Using 3D SurfaceView” on page 993.
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Managing Displays

Use the Window menu to open, close, resize, and rearrange displays, and to extract 
information from the open displays.

Starting a New Display Group

To open an empty display group, select one of the following options:

• From the Display menu bar or from the ENVI main menu, select 
Window → Start New Display Window.

• In the Available Bands List, select New Display from the Display #N button 
menu (see “Selecting the Active Display” on page 190).

Figure 4-63: The Window Menu Options for Display Management
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Closing Display Groups

To close a display group select one of the following options:

• From the Display menu bar, select File → Cancel.

• In Microsoft Windows, click the  button in the Main Image window.

The display group and any associated dialogs are closed.

Tip
To save a display group and its associated windows to a file, see “Saving Display 
Groups” on page 234.

Closing All Displays

• To close all open Image displays, select Window → Close All Display 
Windows from the Display window or from the ENVI main menu.

Maximizing Open Displays

• To resize all display windows to fit the available screen space, select 
Window → Maximize Open Displays from the Display menu bar or from the 
ENVI main menu.

For example, if four displays are open, each display will be resized to fill one-fourth 
of the available screen. 

Viewing Cursor Location and Value

Use Cursor Location/Value in any image window to display the sample (horizontal, 
X) and line (vertical, Y) coordinates of the cursor along with the data value of the 
pixel at the cursor location. The position is continuously updated as you move the 
cursor around the image.

Note
In ENVI, pixel values always refer to the upper left corner of the pixel. Map 
coordinates also typically refer to the upper left corner of the pixel. However, if you 
entered image pixel coordinates in the map information in the ENVI header, the 
map coordinates would refer to the x,y coordinates entered (e.g., x=1.5, y=1.5 
would make the map coordinates refer to the center of the pixel).
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The same Cursor Location/Value window is used for all open displays. Both the 
Scrn: (stretched image) and the Data: (raw data) values are listed. If an RGB image 
is displayed, then the values for all three bands are listed. If an image is 
georeferenced, then the appropriate projection name and the map coordinates and 
latitude and longitude are also listed. If a Classification image is displayed, the class 
names will be reported along with the cursor location and value. When display 
windows are linked, the Cursor Location/Value dialog will display the data values for 
the current pixel for all the display windows included in the link. 

Select one of the following options to open the Cursor Location/Value window:

• In the Main Image window, double-click with the left mouse button.

• From the Display menu bar, select Tools → Cursor Location/Value.

• From the Display menu bar or from the ENVI main menu, select 
Window → Cursor Location/Value.

Figure 4-64: Cursor Location/Value Dialogs: Cursor Location (right) for a 
Georeferenced Image; UTM Coordinates (left) 
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Options in the Cursor Location/Value Window

Use the Options menu in the Cursor Location/Value window to report the cursor 
location in the Zoom window as an integer number or as a floating point number, to 
show fractions of a pixel, to change the displayed format of the latitude and longitude 
information, and to set the precision of the numbers reported. The upper left of a pixel 
is the position of the whole number coordinates and the X and Y values increase to 
the right and bottom of the pixel, respectively. The pixel fraction is shown 
proportional to the zoom factor. For example, at a zoom of 4x, the pixels are divided 
into fourths.

Viewing Floating Point Pixel Locations

To view floating point pixel image locations in the Zoom window, select Options → 
Floating Point Locations. 

Viewing Integer Pixel Locations

To view integer pixel image locations in the Zoom window, deselect Options → 
Floating Point Locations.

Viewing X and Y Offset Values

To view pixel locations, including the X and Y offset values read from the header, 
select Options → Use Image Offset. This is the default selection.

Viewing Lat/Lon Information

• To view latitude and longitude information in decimal degrees, deselect 
Options → Lat/Lon DDS (for georeferenced data sets). 

• To view latitude and longitude information in degrees, minutes, and seconds, 
select Options → Lat/Lon DMS (for georeferenced data sets). This is the 
default selection.

Bringing the Window to the Front

To set the default so that the Cursor Location/Value window pops up in front of all 
other windows when opened, select Options → Auto Raise Window. This is the 
default selection.
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Setting Numeric Precision

The numeric precision is the number of digits displayed after the decimal.

1. Select Options → Set Report Precision.

2. In the Set Report Precision dialog, use the arrow increment buttons to set the 
desired precision for the map, latitude and longitude, and data displays. 

• To set the precision used to display the map coordinates, enter the desired 
numeric precision or use the arrow increment buttons next to the Map 
Precision label.

• To set the precision of the display when Lat/Lon:DD is the selected option 
for georeferenced data sets, click the Lat/Lon Precision arrow button.

• To set the precision used to display the floating point data values, click the 
arrow button next to the Data Precision label. Any changes do not affect 
the display of byte and integer data.

• To select Scientific or Normal as the Floating Report format, click the 
arrow toggle button. A normal number is the number in decimal format 
(e.g., 25.88), whereas a scientific number shows a single digit, followed by 
a decimal, and e (exponential) power (e.g., 2.588e+001).

3. Click OK.

Viewing Display Information

Use Display Information to show information about the Display window in which 
the cursor is currently located. The information is updated as you move the cursor 
between the open Display windows. The displayed information includes the display 
number, number of colors used, bands displayed, the type of stretch currently applied 
to each band, and the sizes and pixel ranges of the Image, Zoom, and Scroll windows.

• In ENVI Main Image window or from the ENVI main menu, select 
Window → Display Information.
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The Display Information window appears.

Viewing Mouse Button Descriptions

Use Mouse Button Descriptions to display the functionality of the mouse buttons 
for the window in which the cursor is located. As the cursor is moved from window to 
window, the mouse button descriptions are updated. The displayed information 
includes the window type (e.g., display, plot), the function that has the cursor control 
(e.g., ROIs, Dynamic Overlay), and the actions for each mouse button (MB1: left 
mouse button, MB2: middle mouse button; MB3: right mouse button).

Note
If the mouse buttons are not responding as you expect, display the mouse button 
descriptions to check which function is in control of the cursor.

Select one of the following options to open the Mouse Button Descriptions window:

• From the Display menu bar or from the ENVI main menu, select 
Window → Mouse Button Descriptions.

• From the ENVI main menu select Help → Mouse Button Descriptions.

Figure 4-65: The Display Information Window

Figure 4-66: Mouse Button Descriptions.
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Positioning Zoom and Scroll Windows

To position the Zoom and Scroll windows with respect to the Main Image window, 
select Window → Scroll/Zoom Location → desired location.

Locking Window Placement

To lock the Scroll and Zoom windows in place after you position them anywhere on 
the screen, select Window → Scroll/Zoom Location → Auto Placement Off.

The windows will remain in place until you move them again.

Hiding Scroll/Zoom Windows

To hide the Zoom and/or Scroll windows, click the  button in the right corner of the 
window.

Unhiding 

To show the hidden Zoom and/or Scroll windows, select Window → Show Zoom 
Window or Show Scroll Window.

Note
The Show... menu selections are only available if the corresponding window is 
hidden.
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Display Output Options

ENVI Image displays, plots, or vector windows can be output to postscript files, 
image files, or directly to printers. All overlays (annotation, grid lines, vectors, etc.) 
can be included in (burned into) the output. 

• Postscript File

• Image Files: ENVI file (RGB binary image with an ASCII header file), BMP, 
HDF, JPEG, JPEG2000, PICT, PNG (Portable Network Graphics), SRF (Sun 
Raster File), TIFF (including GeoTIFF and TIFF World files [.tfw]), XWD 
(X-Windows Dump) Image Files, ERDAS (.lan), ER Mapper, PCI (.pix), 
and ArcView (.bil) Files

• Directly to a system printer.

Saving to Postscript Files

Use ENVI’s postscript output to scale an image, “burn in” graphic overlays, to output 
an encapsulated postscript file, and to select from other output options.

• To output a displayed image to a postscript file, select File → Save Image 
As → Postscript File from the Display menu bar. The Output Display to 
Postscript File dialog appears, where you may modify the output of images, 
plots, and vectors. The output page is shown schematically as a draw window 
in the upper right-hand corner of the dialog. See the following subsections for 
setting the output display parameters in the dialog.

• To output a plot or vector window to a postscript file, select File → Save Plot 
As → Postscript in the plot or vector window.
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Setting Page Size and Image Scaling

Set output page sizes and image placement in either inches or cm, as specified in the 
envi.cfg file. Precision scaling and multiple page output is available when 
outputting to postscript. Any ENVI image can be scaled to a specific map scale—the 
image size values change automatically based on the image pixel size. If the resulting 
image is larger than a single page as defined in the Page text box, ENVI automatically 
determines the number of pages required to output the image and shows the pages in 
the draw window in the upper right-hand corner of the dialog. Multiple page images 
cannot be repositioned with respect to the page layout specified by ENVI.

1. In the Output Display to Postscript File dialog, set the page size by entering the 
desired dimensions in the text boxes labeled Page. 

Figure 4-67: The Display to PostScript Parameters Dialog
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2. Set the output image size on the page by entering the desired values into the 
xsize and ysize labeled text boxes.

Note
To maintain the relative aspect between X and Y when one dimension is 
changed, select the Aspect check box.

3. Set the position of the image origin on the page (with respect to the lower left 
corner) using the xoff and yoff parameters. An outline of the image showing its 
relative size and position on the page appears within the draw window in the 
upper right of the dialog. 

• To position the image on the output page using your mouse, click and hold 
the left mouse button inside the image outline in the draw window and 
drag the image to a new position. 

• To center the image outline on the page using your mouse, click the right 
mouse button anywhere on the output page. 

4. Click on the arrow toggle button to select Landscape or Portrait as the page 
orientation.

5. Select from the following options.

• To scale an image to a specified map scale, enter the desired scale in the 
Map Scale 1: text box. The xsize and ysize values will change 
automatically based on the image pixel size (a default size of 30 meters is 
assumed if no pixel size is present in the header).

• To toggle color on or off, select or de-select the Color check box.

• To select encapsulated postscript output, click the Encapsulate check box.

• To select the number of output bits for the postscript image use the Bits 
pull-down menu.

Setting Graphics Overlay Options

Graphics options (annotations, grid lines, regions of interest, vectors, etc.) can be 
permanently incorporated in the saved PostScript file. All currently displayed valid 
ENVI graphics objects are automatically selected when the Output to PostScript File 
dialog is started. A border is automatically placed on the output image if grid lines are 
selected. The grid text-labels are placed exterior to the image. 
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Note
The grid must have been previously displayed and configured on the image by 
selecting using the Grid Lines overlay option (see “Grid Lines” on page 284 for 
further information).

1. In the Output Display to Postscript File dialog, click the Change Graphic 
Overlay Selections button. The Change Graphics Overlay Options dialog 
appears with a list of the currently displayed graphics objects.

2. Change the graphic overlay selections using the following options:

• To remove a graphics overlay, click on its name in the Currently Selected 
Options list.

• To add graphics overlays, select the desired overlay using the Add 
Graphics Option pull-down menu (with the exception of annotation, 
these overlays must be displayed on your image or plot).

• To add an annotation file that is not currently displayed to the graphics 
overlay, select Additional Annotation File from the Add Graphics 
Option pull-down menu and select the desired annotation filename.

3. Click OK to return to the Output to Postscript File dialog.

Note
To clip all graphics at the edge of the page when multiple pages of output are 
generated, select the Clip Graphics check box.

Subsetting and Resizing Output Images

• To select a spatial subset of the image to be output, click on the Spatial Subset 
button (see “Selecting a Spatial Subset” on page 35).

• To resize the image, enter a resize factor (less than 1 for subsampling) in the 
Input Image Resize Factor text box. 

Applying Masks

In the Output Display to Postscript File dialog, you have the option of applying a 
predefined mask to your output image. This means that if you want to apply a mask to 
the image, you do not need to do it before selecting the output options.

1. In the Output Display to Postscript File dialog, click the Select Mask button.

2. Select the input band for the mask.
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3. In the Background R, G, and B boxes, enter desired color values that you 
want to use where the mask is turned off.

4. Click OK.

Note
To clear the selected mask and output a complete image, click the Clear 
Mask button.

Saving Output Files

1. Enter the output filename or use the Choose button to select the output 
filename. 

2. Click OK when all options are correctly set. 

If the parameters you have chosen result in multiple page output, the filename is used 
as a root filename, and numbers designating the position of the multiple pages in the 
composite image are appended to the filename. For example, an image with 6 pages 
(3 columns by 2 rows), using the file root name test creates the output files 
test_11, test_12, test_21, test_22, test_31, and test_32, where the first 
appended number indicates the column, and the second appended number indicates 
the row.

Saving to Image Files

ENVI has many image output options for the Main Image display and the Zoom 
window. They include output to an ENVI format image file, and output to BMP, HDF, 
JPEG, JPEG2000, PICT, PNG, SRF, TIFF (including GeoTIFF), and XWD files. 
ENVI can also output to various image processing format files including ERDAS 
(.lan), ER Mapper, PCI (.pix), and ArcView (.bil) files. 

Note
Converting Main Image displays into generic image files is limited to data that fit 
entirely into system memory with the exception of TIFF, HDF, and BMP format 
images.

• To output a displayed image to an image file, select File → Save Image 
As → Image File from the Display menu bar. The Output Display to Image 
File dialog appears with options to select the type of output file, set the 
graphics overlay selections, select a spatial subset, resize the image, and 
change the border size. See the subsections below for details.
Display Output Options ENVI User’s Guide



Chapter 4: Interactive Display Functions 451
• To output the contents of the Zoom window to an image file, select File → 
Save Zoom As → Image from the Display menu, or right click on the image 
and select Save Image As from the context menu. The Output Zoom to Image 
File dialog appears with options to select the type of output file and graphic 
overlay selection. See the following sections for details.

• To output a plot or vector window to an image file, select File → Save Plot 
As → Image File in the plot or vector window. The Output Plot to Image file 
dialog appears with options to select the type of output file, set the graphics 
overlay selections, select a spatial subset, resize the image, and change the 
border size. 

Selecting Output File Types and Resolutions

ENVI’s output to image file supports many different output file types (listed above). 
Each file type has a selection of available output formats. These output formats 
(resolutions) include 8-bit grayscale, 8-bit with an associated color table, and 24-bit 
BSQ (band sequential), BIL (band interleaved by line), and BIP (band interleaved by 
pixel) formats.

• To select the desired output file type, use the Output File Type button menu.

Note
When you output a georeferenced image to a JPEG file, an associated .jgw 
file is also created to contain the TIFF World File information. When you 
open a JPEG file (using File → Open External File → Generic File 
Formats → JPEG) that has a .jgw file associated with it, ENVI reads the 
map information from .jgw file.

• Select the desired output format and resolution using the Resolution button 
menu.

Setting Graphics Overlay Options

Graphics options (annotations, grid lines, regions of interest, vectors, etc.) can be 
permanently incorporated in the output image file. All currently displayed valid 
ENVI graphics objects are automatically selected when the Output to Image File 
dialog is started. A border is automatically placed on the output image if grid lines are 
selected. The grid text-labels are placed exterior to the image. Note the grid must 
have been previously displayed and configured on the image using the Grid Lines 
option on the Display Menu (see “Grid Lines” on page 284).
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1. Click on the Change Graphic Overlay Selections button. The Change 
Graphics Overlay Options dialog appears with a list of the currently displayed 
graphics objects.

2. Change the graphic overlay selections using the following options:

• To remove a graphics overlay, click on its name in the Currently Selected 
Options list.

• To add graphics overlays, select the desired overlay using the Add 
Graphics Option pull-down menu (with the exception of annotation, 
these overlays must be displayed on your image or plot).

• To add an annotation file that is not currently displayed to the graphics 
overlay, select Additional Annotation File from the Add Graphics 
Option pull-down menu and select the desired annotation filename.

3. Click OK to return to the Output to Image File dialog. 

Changing Border Sizes and Colors

(This feature is not available from the Output Zoom to Image File dialog.)

To change the border size or color on the output image: 

1. Click on the Change Image Border Size button.

2. When the Change Image Border Size dialog appears, enter the desired border 
sizes in the top, right, bottom, and left text boxes.

3. Select the desired border color from the pull-down menu. The corresponding 
RGB values appear in the text boxes.

4. Click OK to return to the Output to Image File dialog.

Subsetting Output Images

In the Output Display to Image File dialog, you have the option of selecting a spatial 
subset or specifying a resize factor.

• To select a spatial subset of the image to be output, click the Spatial Subset 
button to perform typical ENVI subsetting (see “Selecting a Spatial Subset” on 
page 35). 

• To resize the input image, enter a resize factor (less than 1 for subsampling) in 
the Input Image Resize Factor text box. 
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• The Input Image Resize Factor text box. 

• In the Output Plot to Image File dialog, you have the option of specifying the 
xsize and ysize of the image. The default xsize and ysize values are the size of 
the plot window.

The output size of the image, in pixels, is shown in the Output Image Size text box.

Applying Masks

In the Output Display to Image File dialog, you have the option of applying a 
predefined mask to your output image. This means that if you want to apply a mask to 
the image, you do not need to do it before selecting the output options.

1. Click the Select Mask button.

2. Select the input band for the mask.

3. In the Background R, G, and B boxes, enter desired color values that you 
want to use where the mask is turned off.

4. Click OK.

Note
To clear the selected mask and output a complete image, click the Clear 
Mask button.

Saving Output Image Files

1. Select output to File or Memory and enter an output filename if needed. 

2. Click OK when all options are correctly set. 
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Printing

ENVI allows output of the image display, plot, and vector windows directly to system 
printers. You should be able to output to any of your system printers or plotters 
through your native system printer dialog. 

1. Select one of the following options:

• To output a displayed image to a system printer, select File → Print from 
the Display menu bar.

• To output a plot or vector window to a system printer, select File → Print 
in the plot or vector window.

2. When the Print setup dialog appears, set any options specific to your system 
and click OK.

3. When the Output Display to Printer dialog appears, you will have several 
options for setting the output display parameters. See the following 
subsections for detailed instructions.

4. After setting the parameters, click OK in the Output Display to Printer dialog 
to print the image or plot.

Selecting Output Print Sizes

You can set the output X or Y print size or set the desired output map scale if a 
georeferenced image is displayed. When a size is set, the other size parameters will 
change to preserve the aspect ratio of your image.

1. In the Output Display to Image File dialog, set the output image size on the 
page by entering the desired values into the xsize and ysize labeled text boxes. 

Note
To maintain the relative aspect between X and Y when one dimension is 
changed, select the Aspect check box.

2. Set the position of the image origin on the page (with respect to the lower left 
corner) using the xoff and yoff parameters. An outline of the image showing its 
relative size and position on the page appears within the draw window in the 
upper right of the dialog. 

• To position the image on the output page using your mouse, click and hold 
the left mouse button inside the image outline in the draw window and 
drag the image to a new position. 
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• To center the image outline on the page using your mouse, click the right 
mouse button anywhere on the output page. 

3. Click on the arrow toggle button to select Landscape or Portrait as the page 
orientation.

4. Select from the following options:

• To scale an image to a specified map scale, enter the desired scale in the 
Map Scale 1: text box. The xsize and ysize values change automatically 
based on the image pixel size (a default size of 30 meters is assumed if no 
pixel size is present in the header).

Subsetting and Resizing Output Images

• To select a spatial subset of the image to be output, click on the Spatial Subset 
button to perform typical ENVI subsetting (see “Selecting a Spatial Subset” on 
page 35).

• To resize the image, enter a resize factor (less than 1 for subsampling) in the 
Input Image Resize Factor text box. 

Setting Graphics Overlay Options

Graphics options (annotations, grid lines, regions of interest, vectors, etc.) can be 
permanently incorporated in the print. All currently displayed valid ENVI graphics 
objects are automatically selected when the Output Display to Printer dialog is 
started. A border is automatically placed on the output image if grid lines are 
selected. The grid text-labels are placed exterior to the image. Note the grid must 
have been previously displayed and configured on the image using the Grid Lines 
option on the Display Menu (see “Grid Lines” on page 284).

1. In the Output Display to Printer dialog, click on the Change Graphic Overlay 
Selections button. The Change Graphics Overlay Options dialog appears with 
a list of the currently displayed graphics objects.

2. Change the graphic overlay selections using the following options:

• To remove a graphics overlay, click on its name in the Currently Selected 
Options list.

• To add graphics overlays, select the desired overlay using the Add 
Graphics Option pull-down menu (with the exception of annotation, 
these overlays must be displayed on your image or plot).
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• To add an annotation file that is not currently displayed to the graphics 
overlay, select Additional Annotation File from the Add Graphics 
Option pull-down menu and select the desired annotation filename.

3. Click OK to return to the Output Display to Printer dialog.

Applying Masks

In the Output Display to Printer dialog, you have the option of applying a predefined 
mask to your output image. This means that if you want to apply a mask to the image, 
you do not need to do it before selecting the output options.

1. Click the Select Mask button.

2. Select the input band for the mask.

3. In the Background R, G, and B boxes, enter desired color values that you 
want to use where the mask is turned off.

4. Click OK.

Note
To clear the selected mask and output a complete image, click the Clear 
Mask button.
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Basic Tools
This chapter covers the following topics:
The Basic Tools Menu . . . . . . . . . . . . . . . .  458
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The Basic Tools Menu

Use the Basic Tools menu to access a variety of ENVI functions. The functions are 
generally useful regardless of the specific type of image data being analyzed. 
Functions such as Regions of Interest can be used across multiple displays while 
functions such as Band Math offer general image processing capabilities. The 
Stretch Data function is an example of a function that offers file-to-file contrast 
stretching.

Figure 5-1: ENVI Basic Tools Menu
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Resizing Data (Spatial/Spectral) 

To spatially resize an image and/or perform image spatial or spectral subsetting:

1. Select Basic Tools → Resize Data (Spatial/Spectral). The Resize Data Input 
File dialog appears. 

Note
To open a new file, click the Open New File button.

2. Select an input file by clicking on the file name in the column labeled Select 
Input File.

3. Select a subset using one of the methods described in the following sections.

Note
The methods described are standard ENVI subsetting techniques (for more 
information, see “Selecting a Spatial Subset” on page 35 and “Selecting a Spectral 
Subset” on page 40).

File information is listed in the right column of the window.

Figure 5-2: Resize Data Input File Dialog
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Spatially Subsetting

You can select a spatial subset by entering the numbers of samples/lines, by selecting 
the subset directly from the image, by using another file’s subset, by selecting map 
coordinates (for georeferenced images only), or by using the bounding box around a 
Regions of Interests.

Selecting by Samples/Lines

1. In the Resize Data Input File dialog, click Spatial Subset. The Select Spatial 
Subset dialog appears with the file information listed at the top of the window.

Note
To use the same spatial subset previously entered for a file with the same 
spatial size, click the Previous button.

2. Change the number of samples and/or lines for the output image by entering 
the starting and ending values into the text boxes labeled Sample and/or lines 
respectively or by entering the desired number of lines or pixels in the boxes 
labeled NS or NL respectively. The size of the original data set (in bytes) and 
the size of the subset are shown below the data entry text boxes.

3. Click OK.

4. After selecting and subsetting an input file, click OK in the Resize Data Input 
File dialog.

The Resize Data Parameters dialog appears with information about the input file 
listed at the top of the dialog. The output file dimensions specified by the subsetting 
procedure are also displayed.

Subsetting Interactively from the Image

Use interactive subsetting to select a subset directly from the image.

1. In the Resize Data Input File dialog, click Spatial Subset.

2. In the Select Spatial Subset dialog, click the Subset by Image button. The 
Subset Function window appears with the entire image displayed.

3. Change the size of the subset by clicking and dragging the corner of the red 
box to the desired size. 
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Note
To move the box around the image, click on the box and drag it to the desired 
location. Or, click with the middle mouse button to center the box on the 
cursor.

4. Click OK.

5. After selecting and subsetting an input file, click OK in the Resize Data Input 
File dialog.

The Resize Data Parameters dialog appears.

Subsetting by Map Coordinates

If your image is geo-referenced, you may select the subset by map coordinates or 
latitude/longitude coordinates: 

1. In the Resize Data Input File dialog, click Spatial Subset.

2. In the Select Spatial Subset dialog, click on the Subset By Map button. The 
Spatial Subset By Map Coordinates dialog appears.

3. Enter the upper left coordinate and lower right coordinate in the appropriate 
text boxes.

4. Use the arrow toggle buttons next to the map projection label to select the 
subset by map coordinates.

• For the UTM projection, indicate if the selected latitude is north (N) or 
south (S) of the equator by selecting the appropriate button (the zone is 
calculated automatically). 

• For other map projections, enter latitude and longitude. Negative (–) 
latitude indicates the Southern Hemisphere and negative (–) longitude 
indicates the Western Hemisphere. (Entering the UTM zone assigns the 
appropriate sign to the longitude.)

5. Click OK.

6. In the Select Spatial Subset dialog, click OK.

7. After selecting and subsetting an input file, click OK in the Resize Data Input 
File dialog.

The Resize Data Parameters dialog appears.
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Subsetting Using Another File’s Subset

There are two options for subsetting a file based on the subset area of a previously 
subset image: use the first option to subset your image based on a subset of an image 
that was originally the same size as the one you are subsetting; use the second to 
subset your image based on an image of the same or smaller size that was previously 
subset by map or pixel values.

Using the Subset of an Image of the Same Size 

To use the same spatial subset previously entered for a file with the same spatial size, 
click the Previous button. 

Using the Subset of an Image of the Same or Smaller Size 

1. In the Select Spatial Subset dialog, click the File button. 

2. In the file selection dialog, select the previously subsetted file (which must 
have originally been the same size as or smaller than the file you are currently 
subsetting).

Note
The input file will be subset based on the subset parameters of the file you 
select.

Subsetting Using ROIs

To subset a file using the bounding box (i.e., the area encompassing) an ROI or group 
of ROIs, follow these steps:

1. In the Select Spatial Subset dialog, click the ROI button.

Note
To make previously saved ROIs available for selection in the Subset Image 
by ROI Extent dialog, click the Restore ROIs button in the Select Spatial 
Subset dialog and select the ROI file in the subsequent file selection dialog.
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2. In the Subset Image by ROI Extent dialog, select the ROIs and click OK.

The file will be subset to the area encompassing the selected ROIs.

Spectrally Subsetting

1. In the Resize Data Input File dialog, click the Spectral Subset button. The 
standard File Spectral Subset dialog appears with the file information listed at 
the top of the window.

2. Select specific bands to include in the subset by clicking on the band names or 
by selecting ranges of bands.

Note
To select the same spectral subset used in a previous subsetting of a different 
file with the same number of spectral bands, click the Previous button.

3. Click OK.

4. After selecting and subsetting an input file, click OK in the Resize Data Input 
File dialog.

Figure 5-3: Subset Image by ROI Extent Dialog
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The Resize Data Parameters dialog appears with information about the input file 
listed at the top of the dialog. The output file dimensions specified by the subsetting 
procedure are also displayed.

Spectrally Subsetting from ASCII

Spectral subsetting from an ASCII file is useful if you have defined several special-
use spectral subsets for a file with a large number of bands. To spectrally subset your 
data using an ASCII file: 

1. In the File Spectral Subset dialog, click Import ASCII.

2. When the Enter ASCII Filename dialog appears, select the ASCII file.

Note
The format of the ASCII file must have the same number of lines in the file as 
the number of bands in the image. 

Figure 5-4: Resize Data Parameters Dialog
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3. Columns in the ASCII file define possible spectral subsets. Multiple columns 
can be entered to allow different band selections to be specified. For each 
column in the ASCII file a 0 indicates the band is not selected and a 1 indicates 
the band is selected. 

For instance, a 5-band AVHRR file could use an ASCII file with the following 
data:

0 1 1
0 0 1
0 1 1
1 0 0
1 1 0

Selecting column 1 deselects bands 1, 2 and 3, and selects bands 4 and 5.

Selecting column 2 selects bands 1, 3 and 5, and deselects bands 2 and 4.

Selecting column 3 selects bands 1, 2 and 3, and deselects bands 4 and 5.

Regardless of the number of rows in the ASCII file, only the top 5 bands are 
shown in the Input ASCII File dialog box.

Resizing File Parameters

In addition to subsetting, use the resize function to create new images of any size or 
aspect ratio:

1. In the Resize Data Parameters dialog, either enter the desired number of 
samples and lines in the corresponding text boxes, or enter the multiplicative X 
and Y enlargement or reduction factors in the xfac and yfac text boxes and 
press the Return key.

Tip
If your image contains map information, you can determine the number of 
output sample and lines base upon the desired output pixel size by clicking 
Set Output Dims by Pixel Size.

• If the xfac and yfac values are greater than or equal to 1, select Nearest 
Neighbor, Bilinear, or Cubic Convolution, from the Resampling button 
menu (see “Warping and Resampling” on page 870).

• If the xfac and yfac values are less than 1, select from Nearest Neighbor 
or Pixel Aggregate resampling only.
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Note
You can control X and Y scales independently. Enter values less than 1 to 
reduce the image and values greater than 1 to enlarge the image. The number 
of output samples and lines will be updated.

Note
Nearest neighbor resampling uses the nearest pixel value as the output pixel 
value and pixel aggregate averages all of the pixel values that contribute to 
the output pixel (e.g., if you enter .5 for both xfac and yfac, the output pixel 
values are calculated by averaging the four input pixel values).

2. Select either File or Memory output.

3. Click OK to start the operation. 

The Resize Data status window appears with the output filename listed and the 
percent completed displayed.
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Subsetting Data via ROIs

Use Subset Data via ROIs to subset your data into a rectangle that contains the 
selected ROIs. The rectangle is the smallest rectangle that will fit the ROI. You can 
mask the pixels in the rectangle that do not fall within the ROI.

1. Select Basic Tools → Subset Data via ROIs.

2. In the file selection dialog, select the input file and perform any spectral 
subsetting. The Spatial Subset via ROI Parameters dialog appears.

3. Select the input ROIs by clicking on the ROI names.

4. Use the arrow toggle button to select whether or not to mask pixels that do not 
fall within the ROI.

Note
If you select Yes, enter a background value.

5. Select output to File or Memory.

6. Click OK.

The resulting subset is listed in the Available Bands List.
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Rotating Images

Use Rotate/Flip Images to perform several standard image rotations. These include 
0, 90, 180, and 270 degrees with or without transposition. (Here, transpose means 
that the dimensions of the array are swapped.) Alternatively, you can specify the 
exact angle of the desired rotation. Rotating images is useful for orienting images 
prior to registration.

Tip
To flip an image vertically, where the pivot line is a horizontal running through the 
middle of the image, choose 270 degrees with transpose. To flip an image 
horizontally, where the pivot line is a vertical running through the middle of the 
image, choose 90 degrees with transpose.

1. Select Basic Tools → Rotate/Flip Images.

2. When the Rotation Input File dialog appears, select an input file and any 
subsetting using the standard ENVI file selection procedures (see “Selecting 
Files in ENVI” on page 32).

3. Click OK. The Rotation Parameters dialog appears. This dialog varies slightly 
depending on whether a standard IDL rotation or an arbitrary rotation angle is 
used.

Note
Initially, some letters and numbers are printed horizontally (normal text 
orientation) in the box in the upper right corner of the dialog. The orientation 
of the numbers shows schematically the orientation of the output image with 
the selected rotation and/or transpose applied.

4. Select from the following rotation options:

• To apply a standard rotation (0, 90, 180, or 270 degrees), click the 
appropriate toggle button.

• To flip the X and Y coordinates of the image, click Yes next to the 
Transpose label.
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• To specify the exact rotation angle desired, enter a value in the Angle text 
box (angles are measured clockwise from horizontal). Then select the 
resampling algorithm to be used to calculate the output image (nearest 
neighbor, bilinear interpolation, or cubic convolution) by clicking on the 
appropriate toggle button (see “Warping and Resampling” on page 870).

5. Select output to File or Memory.

6. Click OK to start rotation processing.

A status window appears with the percent complete displayed.

Figure 5-5: Rotation Parameters Dialog with Standard IDL Rotations and 
Transposes (left) and with Arbitrary Angle Rotations (right)
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Layer Stacking

Use Layer Stacking to build a new multiband file from georeferenced images of 
various pixel sizes, extents, and projections. The input bands will be resampled and 
re-projected to a common user-selected output projection and pixel size. The output 
file will have a geographic extent that either encompasses all of the input file extents 
or encompasses only the data extent where all of the files overlap.

1. Select one of the following options:

• From the ENVI main menu, select Basic Tools → Layer Stacking.

• From the ENVI main menu, select Map → Layer Stacking.

2. The Layer Stacking Parameters dialog appears.

3. Click on the Import File button. The Layer Stacking Input File dialog appears.

4. Select input files and perform any spatial or spectral subsetting using standard 
ENVI procedures.

Figure 5-6: Layer Stacking Parameters Dialog
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5. Repeat the file selection using the Import File button for each input file to be 
included in the new output file. Input files are listed in the Selected Files for 
Layer Stacking list. 

6. Click the Inclusive or Exclusive button to select the output file range.

Note
The Inclusive range will create an output file with a geographic extent that 
encompasses all the input file extents. The Exclusive range will create an 
output file that contains only the data extent where all the files overlap.

7. Select an output map projection from the list. 

8. From the Resampling button menu, select a resampling method.

9. Enter the desired x and y pixel sizes in the corresponding text boxes. 

Note
The pixel sizes should be entered in the units selected under the map 
projection section.

10. Select File or Memory output. 

11. Click OK.
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Converting Data (BSQ, BIL, BIP)

Use Convert Data (BSQ, BIL, BIP) to convert between common data storage 
conventions. Often, it is more efficient to use image data stored in a specific manner 
for specific processing operations or interactive analysis. For example, Band 
Sequential (BSQ) format data allow efficient image display, Band Interleaved by 
Pixel (BIP) format data provide efficient extraction of individual spectra and spectral 
averages, and Band Interleaved by Line (BIL) format provide a compromise between 
the previous two formats.

In BSQ (Band Sequential) format, each entire spatial band is followed by the next 
entire band for all bands. In BIL (Band Interleaved by Line) format, the first line of 
the first band is followed by the first line of the second band followed by the first line 
of the third band, etc. for all bands. Subsequent lines for each band are interleaved in 
similar fashion. In BIP (Band Interleaved by Pixel), the first pixel for each band is 
followed by the second pixel, etc. for all bands.

1. Select Basic Tools → Convert Data (BSQ, BIL, BIP).

2. When the Convert File Input File dialog appears, select the input file and 
perform any subsetting.

Note
After you have entered the information for the full image or the spatial and/or 
spectral subsets, the Convert File Parameters dialog appears. Input file 
information is displayed at the top of the window. 

3. Select the desired output data type by clicking the corresponding Output 
Interleave toggle button.

Note
ENVI automatically determines the format of the input file and offers 
conversion only to the other two formats.

4. Next to the Convert in Place label, select the Yes or No toggle button. To have 
the new format overwrite the existing file, select Yes. This option saves 
significant disk space, but the process is slower than writing to a separate file. 
To have the converted file written to a separate output file, select No.

Warning
If the overwrite function fails for any reason (i.e., due to a power outage), 
your data will be corrupted and the original file will not be recoverable.
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5. Enter the output file name.

6. Click the OK button to start conversion.

The File Conversion status window displays the output filename and the percent 
completed.
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Stretching Data

Use Stretch Data to perform file-to-file contrast stretching. The data stretching 
function is a flexible method for changing the data range of a given input file. You 
have full control over both the input and output histograms and the output data type 
(byte, integer, floating-point, etc.). For more information, see “Using Interactive 
Stretching” on page 359. 

1. Select Basic Tools → Stretch Data. The Data Stretching Input File dialog 
appears. 

2. In the list labeled Select Input File, select a filename. Details of the file 
characteristics are shown in the text widget labeled File Information.

3. Select spatial or spectral subsetting by clicking on the Spatial Subset or 
Spectral Subset button, respectively.

4. Click OK. The Data Stretching dialog appears. 

Figure 5-7: Data Stretching Dialog
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Note
To calculate the statistics based on a spatial subset or the area under an ROI, 
click the Stats Subset button. For instructions, see “Using Statistics Subset” 
on page 479.

5. Select the values by percent or by value using the buttons at the top of the 
window.

6. Enter the desired minimum and maximum values in the text boxes labeled Min 
and Max, respectively, to control the input data range.

7. Select the stretch types (Linear, Equalize (histogram equalized), Gaussian, 
and Square Root) by choosing the appropriate toggle button.

8. Set the output data range in the text widgets labeled Min and Max under the 
Output Data label. 

Note
The values entered here must match the ranges of the data type selected from 
the Data Type menu. If out-of-range values are entered, low values are 
automatically corrected to the minimum and high values are automatically 
corrected to the maximum of the selected data type.

9. From the Data Type menu, select the appropriate data type (byte, integer, 
unsigned integer, long integer, unsigned long integer, 64-bit integer and 
unsigned 64-bit integer, floating point, double precision, complex, or double 
complex).

10. Enter or choose an output filename. 

11. Click OK to start the processing.

If no statistics file exists for the selected input file, the image statistics are calculated 
prior to data stretching and a small window labeled Image Statistics shows the 
percent processing complete as a slider that moves from 0 to 100%. If a statistics file 
already exists (or once the image statistics have been calculated) another small 
window labeled Data Stretching shows the percentage of data stretching completed.
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Statistics

Use Statistics in the Basic Tools pull-down menu to generate statistical reports and 
display plots of histograms, mean spectra, eigenvalues, and other statistic information 
for image files.

Computing Statistics

Basic statistics and/or tabulated histogram information (frequency distributions) can 
be calculated for single-band or multi-band images. The minimum, maximum, and 
mean spectra can only be calculated for multi-band images. Similarly, covariance 
statistics, which include eigenvectors and a correlation matrix, can only be calculated 
for multi-band images. The statistics are calculated in double-precision.

1. Select Basic Tools → Statistics → Compute Statistics. The Calculate 
Statistics Input File dialog appears. 

2. In the Select Input File list, select the input file by clicking on the file name.

3. Select spatial or spectral subsetting by clicking on the Stats Subset or 
Spectral Subset button, respectively. For details about statistics subsetting, see 
“Using Statistics Subset” on page 479.

Note
To apply a mask to the data before calculating the statistics, click Mask 
Band and select the desired mask image.
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4. After the file has been selected, subsetted, and masked as desired, click OK. 
The Compute Statistics Parameters dialog appears.

This dialog contains the following selections:

• Basic Stats — This check box indicates basic statistics (the minimum, 
maximum, mean, and standard deviation for all bands) are calculated for 
your data. These basic statistics are always calculated. This option is 
always set.

Note
Statistics are not calculated for any bands specified as bad bands in the 
image’s ENVI header file.

• Histograms — Check this box to calculate the histogram of each band. 
The frequency distribution calculations also return the number of points, 
cumulative points, percent for each bin, and cumulative percentage for 
each DN (digital number) in the image histogram. The number of 
histogram bins used in the calculation is set in the ENVI Configuration 
File (see “Setting ENVI Preferences” in Chapter 2 for more information).

Figure 5-8: Compute Statistics Parameters Dialog
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• Covariance — Check this box to calculate the covariance matrix, the 
correlation matrix, eigenvalues, and eigenvectors. When this check box is 
selected, a Covariance Image check box also appears in the dialog. Select 
the Covariance Image check box to return the covariance and correlation 
matrices, and the eigenvectors as images in the Available Bands List. The 
dimensions of the resulting images are nb by nb, where nb is the number of 
bands of the input data. The eigenvectors are associated with the rows in 
the output eigenvector image.

• Samples Resize Factor and Lines Resize Factor — The values in these 
text boxes indicate the factors used for resizing the samples and the lines 
of the image while calculating the statistics. To improve the performance 
for larger images, specify a value of less than 1 to skip pixels. For example, 
a factor of 0.5 indicates only every other pixel is used to calculate the 
statistics.

• Output to the Screen — Check this box to display the statistics report on 
the screen. When this check box is selected, a Statistics Results dialog is 
used to display the resulting statistics. For more information on this dialog, 
see “Producing Statistics Reports” on page 480.

• Output to a Statistics File — Check this box to save the statistics report 
to an ENVI format statistics file. This file format is used by ENVI to 
improve the speed of some ENVI processes. When this check box is 
selected, the Enter Output Stats Filename section appears in the dialog. 
You can use either the text box or the Choose button in this section to 
specify the name of the statistics file. The default file extension for 
statistics files is .sta.

• Output to a Text Report File — Check this box to save the statistics 
report to a text file. When this check box is selected, the Enter Output 
Text Filename section appears in the dialog. You can use the text box or 
the Choose button of this section to specify the name of the text file.

• Queue — Select this button to place the statistics calculation process in 
the ENVI Queue Manager. See “Placing Un-executed Functions in Queue” 
in Chapter 1 for more information on the ENVI Queue Manager.

• Report Precision... — This button enables you to change the data 
precision displayed in the output statistics report. The Set Report Precision 
dialog appears when you click this button. You can use the Data Precision 
increment button to set the number of digits to be displayed after the 
decimal point, and the Floating Report toggle button to designate the 
format (Normal or Scientific) for the numbers in the ASCII report. A 
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Normal number is a number in decimal format (for example, 25.88), 
whereas a Scientific number is a single digit followed by a decimal value, 
the letter e, and the exponential power (for example, 2.588e+001).

Using Statistics Subset

Use the Stats Subset button in the input file selection dialog or Data Stretching 
dialog to calculate the statistics based on a spatial subset or the area under an ROI. 
The calculated statistics are applied to the entire file or to a spatial subset of the file. 
You can also use this function when doing file-to-file stretching. For details, see 
“Stretching Data” on page 474.

1. In the Input File selection dialog, click the Stats Subset button.

2. In the Select Statistics Subset dialog, select one of the following options:

• To select a standard image spatial subset, click the Calculate Stats On 
Image Subset button and subset using standard ENVI methods.

• To select an ROI or vector as the subset, click the Calculate Stats On 
ROI/EVF button to display a list of ROIs and vectors, then click on an 
ROI or vector name to select it.

Figure 5-9: Select Statistics Subset Dialog for Image Subset Calculation (left) 
and for ROI/EVF Calculation (right)
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Tip
To add a previously saved ROI or vector to the list, use the Open pull-down 
menu button in the Select Statistics Subset dialog to open either an ROI File 
or an EVF File.

Producing Statistics Reports

After setting the report parameters in the Compute Statistics Parameters dialog, 
calculate the statistics report by clicking OK to start the statistics calculations.

A progress window appears showing the percent of processing complete as a slider 
from 0 to 100%.

Once the statistics have been calculated, the Statistics Results dialog appears

Figure 5-10: Statistics Results Dialog
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The File pull-down menu in the Statistics Results dialog contains the following 
items:

• Save results to ENVI stats file... — This option enables you to save the 
statistics report to an ENVI format statistics file to speed processing for later 
use with ENVI functions. When this option is selected, the Save Results to 
ENVI Stats File dialog appears. In the Enter Output Stats Filename[.sta] 
section of this dialog, use either the text box or the Choose button to specify 
the name of the statistics file.

The default file extension for statistics files is .sta. The statistics report is 
saved to the specified file when you click the OK button.

• Save results to text file... — This option enables you to save the statistics 
report to a text file. When this option is selected, the Save Results to Text File 
dialog appears. In the Enter Output Text Filename[.txt] section of this 
dialog, use either the text box or the Choose button to specify the name of the 
text file. The statistics report is saved to the specified file when you click the 
OK button.

Tip
The resulting text file is tab-delimited for easy import into external 
spreadsheet programs, such as Excel.

• Save Current Covariance to Image — This option enables you to return the 
covariance and correlation matrices as well as the eigenvectors as images in the 
Available Bands List. The dimensions of the resulting images are nb by nb, 
where nb is the number of bands of the input data. The eigenvectors are 
associated with the rows in the output eigenvector image. 

Note
The Save Current Covariance to Image option is only available if the 
Covariance check box is selected in the previous Compute Statistics 
Parameters dialog. It is also only available when calculating the statistics for 
multiple classes or ROIs if the Options → Calculate Covariance with Stats 
option in either the Interactive Class Tool or the ROI Tool is selected.

• View Statistics Files... — This option enables you to open one or more ENVI 
statistics files (.sta) and display them in other Statistics Results dialogs. You 
can use this option to compare your current statistics with information in an 
existing ENVI statistics file.
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Note
Multiple ENVI statistics files can be opened only if they are related (such as 
files saved from a group of classes or ROIs with the same output root name).

The Options pull-down menu in the Statistics Results dialog contains the following 
items:

• Copy results to new window — This option enables you to compare statistics 
for different bands. When this option is selected, a copy of the Statistics 
Results dialog appears. You can use this copy to compare various statistics. For 
example, you can use the Select Plot button in one dialog to display the 
histogram of one band, and then use the Select Plot button in the copied dialog 
to display the histogram of a different band. Moreover, as with other ENVI plot 
windows, you can drag-and-drop a plot display from one window to another 
(see “Using Interactive Plot Functions” in Chapter 4 for more complete details 
on this options).

• Set Report Precision... — This option provides access to the Set Report 
Precision dialog to change the precision of the information displayed in the 
Statistics Results dialog.

Note
The Options → Set Report Precision... option does not affect histogram 
precision.

A Plot section of the Statistics Results dialog contains a window, which displays the 
plot currently selected in the Select Plot menu. In the plot window, mouse buttons 
allow you to perform the following tasks:

• Left Mouse Button (Mouse Button 1) — Click this button in the plot window 
to display a crosshair cursor on the nearest data point and report its (x, y) 
location.

• Middle Mouse Button (Mouse Button 2) — Click this button to zoom in or out 
of the plot.

• Right Mouse Button (Mouse Button 3) — Click this button to access a shortcut 
menu containing all the options associated with a regular plot window (see 
“Using Interactive Plot Functions” in Chapter 4 for more complete details on 
these options).
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The Plot section also contains the following items:

• Select Plot — This pull-down button enables you to change the current display 
in the plot window. When the Statistics Results dialog first appears, the plot 
window contains the minimum, maximum, and mean values for each band in 
the image. You can use the Select Plot menu to change the display to the 
standard deviation, eigenvalues (if the Covariance check box was selected in 
the previous Compute Statistics Parameters dialog), or histograms (if the 
Histograms check box was selected in the previous Compute Statistics 
Parameters dialog) for each or all bands.

• Clear Plot — This button enables you to clear the plot window.

A Text section containing the following items:

• Text Box — The text box contains the values of the calculated statistics in a 
table format. Each table in this box shows the resulting type of statistics (basic, 
covariance, eigenvalues, and histograms) calculated for each band in the 
image.

• Select Stat — This pull-down menu enables you to change the information 
displayed. At any point in the text, you can use the File Info option in the 
Select Stat menu to return to the file information section, which is at the 
beginning (top) of the text. You can also use the scroll bars to move around this 
text box.

The Text section shows the following information:

• File Information

• Basic Statistics

• Covariance (only available if the Covariance check box was selected in the 
previous Compute Statistics Parameters dialog)

• Correlation (only available if the Covariance check box was selected in the 
previous Compute Statistics Parameters dialog)

• Eigenvectors (only available if the Covariance check box was selected in the 
previous Compute Statistics Parameters dialog)

• Histograms for Each Band (only available if the Histograms check box was 
selected in the previous Compute Statistics Parameters dialog)
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Opening Statistics Files 

Use View Statistics File to view previously saved statistics files.

1. Select Basic Tools → Statistics → View Statistics File.

2. When the standard ENVI file input dialog appears, select a valid statistics file. 
The View Statistics File dialog appears.Use this dialog to select the type of 
reports to be generated. 

The options are similar to those described above for the Calculate Statistics 
Parameters Dialog. 

Note
The options available in the View Statistics File dialog are dependent on the type of 
statistics that were computed for the original file (e.g., if covariance statistics were 
not calculated for the original file, then covariance options will not be available in 
the View Statistics File dialog).

Summing Data Bands

Use Sum Data Bands to add all of the bands in an image together or to calculate 
spectral statistics for every pixel in an image. You can calculate up to 8 different 
statistics: sum, sum of squares, mean, standard deviation, variance, skewness, 
kurtosis, and mean absolute deviation. The various statistics are calculated as follows, 
where xj is the value of a pixel for band j and N = number of bands:

Note
The statistics calculated using Sum Data Bands are spectral, which means that the 
statistics are calculated using all of the bands for every pixel and that output images 
will result. The statistics calculated using the other statistics functions are spatial, 
which means that they are calculated using all pixels for every band.

1. Select Basic Tools → Statistics → Sum Data Bands.

2. In the file selection dialog, select an input file and perform any subsetting.

3. In the Sum Data Parameters dialog, click on the output bands to be calculated.

4. From the Output Data Type button menu, select the output data type. 
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Note
If the output data falls outside the data type range, the output data will be 
clipped to the highest or lowest data type value (i.e., byte output will have 
values only between 0-255 and all negative values will clip to 0).

5. Select output to File or Memory.

6. Click OK.

A status window displays the progress of the operation. The calculated bands are 
listed in the Available Bands List.
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Generating a Random Sample

It is often helpful to generate a random sampling of points from a classification result, 
or from Regions of Interest. Such samplings can be valuable in supporting 
classification accuracy assessments and field truthing expeditions.

ENVI offers three types of random samplings:

• Stratified Random. This technique, also called proportional or quota random 
sampling, involves dividing the population (the entire classification image or 
all of the ROIs) into homogeneous subgroups (the individual classes or ROIs) 
and then taking a simple random sample in each subgroup. Two types of 
Stratified Random sampling are available: proportionate and disproportionate. 
Proportionate sampling produces sample sizes that are directly related to the 
size of the classes (i.e., the larger the class, the more samples will be drawn 
from it). Disproportionate sampling allows the user to explicitly define each 
sample size.

• Equalized Random. This technique also divides the population into 
homogeneous subgroups (as in Stratified Random) but ensures that each class's 
(or ROI's) sample size is exactly the same. That is, the sample size remains 
fixed regardless of class size.

• Random. Random sampling does not divide the population into subgroups but 
instead simply draws a random sampling from the entire (heterogeneous) 
population. For large sample sizes, the distribution of classes (or ROIs) in the 
sample will approximate a Stratified Random sampling, but classes with small 
sizes may be missed altogether in the random sample. 

For detailed instructions, see “Generating a Random Sample” in Chapter 6.
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Change Detection Analysis

Change Detection Analysis encompasses a broad range of methods used to identify, 
describe, and quantify differences between images of the same scene at different 
times or under different conditions. Many of ENVI's tools (such as Band Math or 
Principle Components Analysis) can be used independently, or in combination, as 
part of a change detection analysis. In addition, the routines found under the Basic 
Tools → Change Detection menu offer a straightforward approach to measuring 
changes between a pair of images that represent an Initial State and Final State. Use 
Change Detection Statistics for classification images and Compute Difference 
Map for grayscale (single-band) images.

Compute Difference Map

The Compute Difference Map routine produces an ENVI Classification Image 
characterizing the differences between any pair of Initial State and Final State 
images. The input images may be single-band images of any data type. The 
difference is computed by subtracting the initial state image from the final state 
image (i.e., final – initial), and the classes are defined by change thresholds. A 
positive change identifies pixels that became brighter (final state brightness was 
greater than the initial state brightness), while a negative change identifies pixels that 
became dimmer (final state brightness was less than initial state brightness). As an 
optional pre-processing step, the input images can be normalized to a data range 
between zero and one, or standardized to a zero mean and unit variance. The input 
images must be co-registered or georeferenced. For the most accurate results, 
carefully co-register the images before processing. If the input images are not co-
registered, the Compute Difference Map routine uses the available map information 
to automatically co-register the images, using the Initial State image as the base if re-
projection or resampling is required.

Tips for Successful Analyses

When performing a change detection analysis on non-thematic images (grayscale 
data), it is important to consider all of the factors that can cause scenes of the same 
area to look different. The following list contains a few notable factors:

• Differences in the instrument or sensor. It is important to consider the 
similarity of the sensors that collected the images. Even bands collected in the 
same part of the spectrum (e.g., two red bands) may have different band center 
wavelengths, or different spectral response functions, which can lead to 
different pixel values for the same material.
ENVI User’s Guide Change Detection Analysis



488 Chapter 5: Basic Tools
• Differences in the collection date and time. Seasonal changes can impart big 
differences in scenes containing vegetation (due to plant senescence and 
canopy architecture development). Differences in the season and time of day 
will also affect the solar azimuth and elevation.

• Differences in Atmospheric Conditions. The dominant weather conditions 
can affect atmospheric transmission and scattering. Consistent differences in 
gross atmospheric conditions are often associated with seasonal changes. For 
example, differences in the predominant wind direction can be important 
(winds blowing in over the ocean contain different aerosols with different 
scattering properties from those blowing in over an urban area). Another 
common, yet consistent, atmospheric difference is the water content of the 
atmosphere. Summer atmospheres tend to be wetter than winter atmospheres. 
Atmospherically corrected images can reduce such influences.

• Differences in Image Calibrations. For the most accurate change detection 
results, it is important to work with images that have been calibrated into the 
same units. If a calibration into physical units (such as radiance) is not 
possible, a relative calibration may be better than none at all (especially if the 
instruments that collected the images have different dynamic ranges).

• Differences in Image Resolution. Differing pixel sizes can lead to spurious 
change detections. It is important that the original images (prior to resampling 
or re-projection) have the same pixel resolution. For scenes with large swaths 
(such as AVHRR, SeaWiFS, or MODIS) the actual pixel sizes differ across the 
scene. In such cases, differences in the sensor viewing geometry can also be 
important.

• Co-registration Accuracy. Accurately co-registered images are critical for 
change detection analyses. While the Compute Difference Map routine will 
automatically co-register the input images using the available map 
information, if the differences in the image geometry are substantial, it is well 
worth the effort to ensure that the co-registration is as accurate as possible 
before performing a change detection.

The Compute Difference Map routine does not compensate for any of these (or 
other) conditions. Its results are strictly dependent on pixel-for-pixel comparisons.
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Using the Compute Difference Map Routine

1. From the main ENVI menu select Basic Tools → Change 
Detection → Compute Difference Map.

Note
The input images must be georeferenced or co-registered. If the images are 
not co-registered, then the available map information will be used to 
automatically co-register the area common to both. 

2. In the first file selection dialog, select a single band image representing the 
Initial State and perform any spatial subsetting if desired.

3. In the second file selection dialog, select a single band image representing the 
Final State and perform any spatial subsetting if desired. 

The Compute Difference Map Input Parameters dialog appears.

4. Enter the number of classes you wish to use. 

Each class is defined by a difference threshold that represents a varying 
amount of change between the two images. The minimum number of classes is 
two. The default classification thresholds are evenly spaced between (-1) and 
(+1) for simple differences, and (-100%) and (+100%) for percent differences. 
The default class definitions attempt to produce symmetric classes, with an 
equal number of positive and negative change classes surrounding a No 
Change category. The order in which the classes are defined is as follows: For 
n classes, where n is odd, the first (n/2) classes represent positive changes, 
starting with the largest positive changes and ending with the smallest. The 
middle class, (n/2) + 1, represents no change. The last (n/2) classes represent 
negative changes, starting with the smallest negative changes end ending with 
the largest. For an even number of classes the definitions remain the same 
except that the number of negative classes is reduced by one. In short, the 
default class definitions range from positive to negative, with the magnitude of 
the change increasing with distance from the middle No Change class. 

5. To modify or view the classification thresholds, define names for the classes, 
or import classification thresholds from a previous result, click the Define 
Class Thresholds button. If the default thresholds are used, this step is 
unnecessary. 

The Define Class Thresholds dialog appears. Each class is defined by one line 
in the dialog.
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Note
While users are encouraged to customize the criteria used to define the 
change thresholds, it is recommended that the classes retain their default 
symmetrical property, with an equal number of positive and negative classes 
surrounding a No Change class. Retaining the default position (order) and 
type (negative or positive) of classes will make the results easier to interpret 
using the classification color assignments.

A. Defining Class Names — Place the cursor in the text box next to the class 
you wish to rename, and enter the new class name.

B. Modifying Class Thresholds — Select logical operators from the pull 
down menus and enter numeric values in the text boxes to define the 
thresholds for any selected class. When you click OK, you will be saving 
these changes. To further modify class thresholds, simply click the Define 
Class Thresholds button again. The first and last class have only one 
logical operator and are intended to be open-ended.

C. Applying the Defaults — To revert to the default classification thresholds, 
simply click the Apply Defaults button at the bottom of the dialog. The 
defaults that are applied are dependent on the Change Type selected in the 
Compute Difference Map Input Parameters dialog (the Change Type is 
also indicated by the title bar of the Define Class Thresholds dialog).

D. Undoing Changes — To undo changes made since the Define Class 
Thresholds dialog was last opened, click the Reset button. All changes 
made since the dialog was brought up will be removed.

E. Matching the Change Thresholds from a Previous Analysis

• To automatically set the classification change thresholds to match those 
used in a previous analysis, click the Match Previous Result button.

• In the file selection dialog, choose a Difference Map classification image 
produced previously using the Compute Difference Map routine that 
contains the thresholds you wish to reuse.

Note
If necessary, the number of classes for the current analysis will be reset to 
match the number of classes used in the previous analysis. 

6. Set the Change Type to Simple Difference or Percent Difference. 
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Note
The Simple Difference is computed by subtracting the Initial State image 
from the Final State image. The Percent Difference is the Simple 
Difference divided by the Initial State value. 

7. Select optional Data Pre-Processing. 

Only one type of pre-processing can be selected. Normalization is computed 
by subtracting the image minimum and dividing by the image data range: 
Normalization = (DN – min) / (max – min). Standardization is computed by 
subtracting the image mean and dividing by the standard deviation: 
Standardization = (DN – mean) / stdev.

8. Choose output to File or Memory for the Difference Map result. If you choose 
to output to File, you will need to enter an output filename.

9. If the input images require warping or resampling in order to produce a co-
registered pair, then the Compute Difference Map Input Parameters dialog will 
contain an extra section which allows the auto-co-registered images to be 
saved to File or Memory.

10. Click OK to start the processing. 

A status window displays the progress of the operation. The resulting 
Difference Map classification image is color coded to indicate the magnitude 
of the change between the two images. Positive changes are displayed in 
shades of red, grading from gray for no change to bright red for largest positive 
change. Negative changes are displayed in shades of blue, grading from gray 
for no change to bright blue for the largest negative change. 

Note
If the number of positive and negative change classes, or the order in which 
the classes are defined, has changed from the default settings, the 
interpretation of the color scheme may not match that described here. 
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Change Detection Statistics

The Change Detection Statistics routine is used to compile a detailed tabulation of 
changes between two Classification images. The changes detected using this routine 
differ significantly from a simple differencing of the two images. While the statistics 
report does include a class-for-class Image Difference, the analysis focuses primarily 
on the Initial State classification changes—that is, for each Initial State class, the 
analysis identifies the classes into which those pixels changed in the Final State 
image. Changes can be reported as pixel counts, percentages, and areas. In addition, a 
special type of mask image (classification masks) that provide a spatial context for 
the tabular report can be produced. The class masks are ENVI Classification images 
with class colors matching the Final State image, making it easy to identify not only 
where changes occurred but also the class into which the pixels changed. 

The input images must be co-registered or georeferenced. For the most accurate 
results, carefully co-register the images before processing. If the input images are not 
co-registered, the routine will use the available map information to automatically co-
register the images, using the Initial State image as the base if re-projection or 
resampling is required. 

1. From the main ENVI menu select Basic Tools → Change 
Detection → Change Detection Statistics, or Classification → Post 
Classification → Change Detection Statistics.

2. In the first file selection dialog, select a Classification image representing the 
Initial State and perform any spatial subsetting if desired.

3. In the second file selection dialog, select a Classification image representing 
the Final State and perform any spatial subsetting if desired. 

The Define Equivalent Classes dialog appears.

4. Match the classes from the Initial and Final State images by clicking on the 
matching names in the two lists and clicking the Add Pair button. 

Add only the classes you wish to include in the change detection analysis (it is 
not required to pair all classes). The class combinations are shown in a list at 
the bottom of the dialog. If the classes in each image have the same names, 
they are automatically paired.

• To remove a paired class from the list, click on the pair in the list at the 
bottom of the dialog and then click on the Remove Pair button. The two 
class names reappear in the lists at the top of the dialog.

• To remove all of the paired classes, simply click the Remove All button. 
All of the classes reappear in the lists at the top of the dialog.
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5. After all of your class pairings are made, click OK. 

The Change Detection Statistics Output dialog appears.

6. Next to the Report Type label, select the type of statistics report you want to 
generate. You may choose any combination of Pixels, Percent, and Area.

7. To output Class Masks, select Yes in the toggle button next to Output 
Classification Mask Images, then choose a destination for the mask images. If 
not outputting Class Masks, set the toggle button to No.

8. If the input images require warping or resampling in order to produce a co-
registered pair, then the Change Detection Statistics Output dialog will contain 
an extra section which allows the auto-co-registered images to be saved to File 
or Memory.

9. Click OK to start the processing. If an Area Report was requested but the 
Initial State image does not have pixel sizes defined, the Define Pixel Sizes for 
Area Statistics dialog is displayed. Enter the pixel sizes and click OK. If 
Cancel is selected, no Area Report will be computed.

A status window displays the progress of the operation.

The Change Detection Statistics Report

A single interactive report window contains all of the statistics tables that were 
selected, each under its own tab. The report window also contains a Reference tab, 
which includes additional information about the analysis, such as the names of the 
input images and the equivalent class pairings.

The following example will help to explain the various parts of the Change Detection 
Statistics table. Refer to “Sample Change Detection Statistics Report” on page 494 
for reference. 

Initial State 
Classes

Final State Classes Equivalent Class Pairings

urban urban urban = urban

forest mixed forest forest = mixed forest

agriculture irrigated vegetation agriculture = irrigated vegetation

grasses tall grass/prairie grasses = tall grass/prairie

Table 5-1: Classes for Example Change Detection Analysis
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Note that the Initial and Final State images do not have the same number of classes, 
and that only four of the five Initial State classes are included in the Equivalent Class 
Pairings list (lakes & ponds is not used). 

The statistics tables list the Initial State classes in the columns and the Final State 
classes in the rows. However, the columns include only the selected (paired) Initial 
State classes, while the rows contain all of the Final State classes. This is required for 
a complete accounting of the distribution of pixels that changed classes. For each 
Initial State class (i.e., each column), the table indicates how these pixels were 
classified in the Final State image. For example, in the sample report in the figure 
above, none of the pixels initially classified as urban changed classes, but 9523 pixels 
initially classified as forest changed into the urban class in the Final State image. 

lakes & ponds water

burn scar

Figure 5-11: Sample Change Detection Statistics Report

Initial State 
Classes Final State Classes Equivalent Class Pairings

Table 5-1: Classes for Example Change Detection Analysis
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The Class Total row indicates the total number of pixels in each Initial State Class, 
and the Class Total column indicates the total number of pixels in each Final State 
Class. Again, referring to the figure above, 13389 pixels were classified as urban in 
the Initial State image, while 25256 pixels were classified as urban in the Final State 
image. 

The Row Total column is simply a class-by-class summation of all Final State pixels 
that fell into the selected Initial State classes. Note that this may not be the same as 
the Final State Class Totals because it is not required that all Initial State classes be 
included in the analysis. For example, in the sample analysis presented in Table 5-1, 
the Initial State class lakes & ponds was not included in the analysis. The differences 
in the Row Total and Final State Class Total columns are due to those lakes & ponds 
pixels that changed into the various Final State classes (e.g., see the Row Total and 
Class Total for the Final State urban class: 5 Initial State lakes & ponds pixels were 
reclassified as urban in the Final State, accounting for the difference in these two 
columns). 

The Class Changes row indicates the total number of Initial State pixels that changed 
classes. In the table in Figure 5-11, the total Class Changes for forest is 45419 pixels. 
In other words, 45419 pixels that were initially classified as forest changed into Final 
State classes other than mixed forest (the equivalent class). To confirm that this is 
correct, subtract the forest column's mixed forest pixel count of 164893 from the 
forest Class Total of 210312. 

The Image Difference row is simply the difference in the total number of equivalently 
classed pixels in the two images, computed by subtracting the Initial State Class 
Totals from the Final State Class Totals. An Image Difference that is positive 
indicates that the class size increased. For example, in the sample analysis, even 
though no pixels classified as urban changed classes, the urban class grew 
significantly as its Image Difference value is 11867. 

The tabs along the top of the Change Detection Statistics dialog can be selected to 
show equivalent information for the class changes in terms of Percentage and Area. 
In the Percent report (not shown here) the increase in the size of the urban class 
corresponds to a growth of 88%:

(final state – initial state) / initial state = (25256 – 13389) / 13389 = 0.886
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Additional Features of the Change Detection Statistics Report

• To change the floating point precision displayed in the report, select 
Options → Set Report Precision. 

• To convert the units for the Area report, select Options → Convert Area 
Units.

• To save the statistics reports to an ASCII text file, select File → Save to Text 
File. In the Save Change Detection Stats to Text dialog, you can optionally add 
a descriptive line of header text to the file being written. The data is saved in a 
tab delimited format to facilitate importing into other software programs.

The Classification Mask Images

The classification masks complement the statistics tables by spatially identifying 
which Initial State pixels changed classes, and into which class they changed. 
Patterns of changes can often be seen by examining the masks. The masks can also 
help highlight co-registration errors. The class mask images are saved as a multi-band 
image with one mask for each paired class. To help identify the class into which a 
pixel changed, the masks are stored as ENVI Classification images with the class 
assignments (names, colors, and values) matching the Final State. A value of zero in 
the mask indicates that no change occurred from the Initial to the Final State; non-
zero values indicate a change. In order to differentiate pixels that did not change 
classes from those that changed into the Unclassified class (which typically has a 
classification value of zero), pixels that changed into the Unclassified class are 
assigned a value equal to the number of Final State classes plus one, and color coded 
white. For example, in the sample analysis described here, the Final State image 
contains 6 classes; therefore, any pixel in the mask that changed into the Unclassified 
class would be assigned a value of 7. 
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Using the Measurement Tool

Use Measurement Tool to get a report on the distance between points in a polygon 
or polyline, and to get perimeter and area measurements for polygons, rectangles, and 
ellipses.

Note
To measure ROIs while using the ROI function, see “Reporting ROI 
Measurements” on page 305.

1. Select one of the following options to begin:

• From the ENVI main menu, select Basic Tools → Measurement Tool.

• From the Display menu, select Tools → Measurement Tool.

2. The Display Measurement Tool dialog appears. In the Display text box, type 
the number of the display that you want to take measurements from.

3. Select the appropriate image window toggle button (Image, Scroll, Zoom).

Note
To disable the measurement function at any time, select the Off toggle 
button.

4. Select Type → the desired shape of the area you want to measure.

Figure 5-12: Display Measurement Tool Dialog
ENVI User’s Guide Using the Measurement Tool



498 Chapter 5: Basic Tools
5. Select Units → the desired measurement unit. If the pixel size of the image is 
not stored in the header, and you select any unit except pixel, complete these 
steps when the Input Display Pixel Size dialog box appears.

A. In the X Pixel Size and Y Pixel Size text boxes, type the size of the pixels 
in your image. 

B. From the Units button menu, select the unit type. Click OK.

6. In the image display, draw the desired shape by clicking with the left mouse 
button.

• In Rectangle or Ellipse mode, click with the left mouse button and drag the 
shape to the desired size. 

• To draw a square or circle, click and drag while holding the middle mouse 
button in Rectangle or Ellipse mode. 

7. Close the polygon or complete the line by clicking the right mouse button.

• For Polygon mode, the distance between the vertices are listed and the 
perimeter and total area are reported when the polygon is closed. 

• For Polylines, the distance between the vertices are listed and the total 
distance is given when the polyline is completed.

• In Rectangle mode, the lengths of the side segments, the perimeter, and the 
total area are reported.

• In Ellipse mode, the circumference and total area are reported.

Note
To erase the shape, click again with the right mouse button.

Selecting Measurement Units

In the Display Measurement Tool dialog, use the Units menu to select the unit the 
measurement is reported in. The choices are pixels, meters, kilometers, feet, yards, 
miles, and nautical miles.

Select Units → the desired unit. If the pixel size of the image is not stored in the 
header, and you select any unit except pixel, complete these steps when the Input 
Display Pixel Size dialog box appears.

1. In the X Pixel Size and Y Pixel Size text boxes, type the size of the pixels in 
your image. 

2. From the Units button menu, select the unit type. Click OK.
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Measuring Area

In the Display Measurement Tool dialog, use the Area menu to measure the area in 
units2 (e.g., meters2), acres, or hectares.

Select Area → Acres or Hectares.

Measurement Options

In the Display Measurement Tool dialog, use the Options menu to select whether the 
measurement information is reported as line segments (the default) or as point 
coordinates. 

• To get a listing of the vertices coordinates, select Options → Report as 
Points. The coordinates are reported as a pixel location (Pixel (x,y)).

• To get a listing of the line segment distances, select Options → Report as 
Segments.

• For images that are georeferenced, you may list the coordinates as map 
coordinates or as latitude and longitude coordinates by selecting Options → 
Georef Map (x,y) or Georef (Lat/Lon).

• To output the list of point coordinates to a file, select File → Save Points to 
ASCII.

Saving Measurement Reports

In the Display Measurement Tool dialog, use the File menu to save the measurement 
report to an ASCII file.

1. In the Display Measurement Tool dialog, select File → Save Points to ASCII.

2. In the Output Measurement Points dialog, enter an output filename. 

3. Click OK.

Closing the Measurement Tool Dialog

To close the Display Measurement Tool dialog, select File → Cancel.
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Band Math

The Band MathTM routine is a flexible image processing tool with many capabilities 
not available in any other image processing system. Because each ENVI user is likely 
to have unique needs, the Band Math tool allows you to define your own processing 
algorithms and apply them to bands or entire files opened in ENVI. Your custom 
processing may be as simple or complicated as you wish. For example, you could 
simply subtract one image band from another, or execute your own custom function 
written in the Interactive Data Language, IDL, the language in which ENVI itself was 
written. 

See “Band Math Basics” in Chapter 2 of the ENVI Programmer’s Guide for more 
information about writing Band Math functions in IDL.

Using the Band Math Tool in ENVI

To use the Band Math Tool in ENVI:

1. Select Basic Tools → Band Math. The Band Math dialog appears. It accepts 
any valid IDL expression, provided that the result of the operation is a two-
dimensional array of the same spatial dimensions as the input bands.

Figure 5-13: Band Math Dialog
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Note
Some common image summing operations are easier to perform using the 
Basic Tools → Statistics → Sum Data Bands selection (see “Summing 
Data Bands” on page 484).

2. Enter the IDL expression you wish to have evaluated in the Enter an 
expression text box. Use variables in place of band names or file names (the 
variables will be assigned in the next step). Variable names must begin with the 
character “b” or “B” followed by up to 5 numeric characters.

Note
For example, if you wanted to calculate the average of three bands, the 
mathematical equation: 

(float(b1)+float(b2)+float(b3))/3.0

could be entered into the text box. Three variables are used in this 
expression — b1 is one variable, b2 a second variable, and b3 a third 
variable. Note that, in this example, the IDL function float() is used to 
prevent byte overflow errors during calculation. For more details on 
Expressions, see “IDL Tips for Use in Band Math” on page 506 and “Sample 
Band Math Expressions” on page 512.

3. After a valid expression is entered, click OK. The Variable to Band Pairings 
dialog appears. See “Assigning Values to Variables” on page 502 for more 
information.

Using Previous Expressions

To reuse any previously applied math expressions:

1. In the Band Math dialog, click on any expression shown in the Previous Band 
Math Expressions list to load that expression into the Enter an expression 
field. If you have a Math Expression File defined in your preferences (see 
“Setting ENVI Preferences” on page 174) then these expressions will be listed 
by default every time you start Band Math.

2. Once loaded, click OK to apply the expression to a new set of bands. The 
Variable to Band Pairings dialog appears. See “Assigning Values to Variables” 
on page 502 for more information.
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Restoring Saved Expressions

To restore previously-saved expressions:

1. In the Band Math dialog, click Restore.

2. Select the appropriate filename from the Enter Expressions Filename dialog 
and click Open.

The expressions that are stored in the file you selected are displayed in the Previous 
Band Math Expressions list.

Deleting Expressions From the List

To delete a single expression from the list, click on it to highlight it and click the 
Delete button.

Adding Expressions to the List

To add an individual expression to the Previous Band/Spectral Math Expressions 
list, enter it in the Enter an Expression text box and click the Add to List button. 

Saving Expressions Without Running

You can save expressions to a file without having to run them through the Band or 
Spectral Math function first. To do this, give the current expression list a filename 
with a .exp extension, and click the Save button.

Assigning Values to Variables

Use the Variables to Bands Pairings dialog to assign bands from a list of input bands 
to the variables that were entered in the Enter an expression text box.

To assign a value to variable b1 from our previous example:
Band Math ENVI User’s Guide



Chapter 5: Basic Tools 503
1. In the Variables to Bands Pairings dialog, click on the variable B1 in the 
Variables used in expression text box.

2. Click on the desired band in the list labeled Available Bands List. Data sets 
appear expanded in the tree view by default. 

Note
Once the first band is selected, only those bands with the same spatial 
dimensions are shown in the band list.

3. Continue to assign a value to B2, B3, etc. in the same manner.

Figure 5-14: Variables to Bands Pairings Dialog
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Assigning Multiband Images as Variables

You can assign a multiband image as one or all of the variables (using an image file as 
a variable is considered File Math).

1. In the Variables to Bands Pairings dialog, click on a variable in the Variables 
used in expression text box.

2. Click the Map variable to Input file button.

3. Select a file in the Band Math Input File dialog and click OK.

4. Continue to assign a value to B2, B3, etc. in the same manner.

Note
If more than one file is used, they must have the same number of bands.

A multiband output image is produced for file math modified by the math expression.

Spatially Subsetting Input Images

To spatially subset the input image, click the Spatial Subset button after you have 
assigned values to all of the variables. The Select Spatial Subset dialog appears.

See “Selecting a Spectral Subset” on page 40 for detailed instructions on using the 
Select Spatial Subset dialog.

Outputting Band Math Results

To output the results to a file or memory, select the File or Memory radio button in 
the Variables to Bands Pairings dialog.

The resulting image is listed in the Available Bands List.

Saving Expressions

To save expressions to an output file:

1. In the Band Math dialog, click Save.

2. Enter an output filename in the Save Expression to File dialog using the file 
extension .exp for consistency.

All of the expressions in the Previous Band Math Expressions list will be saved to 
the file.

Clearing Expressions

To clear all expressions from the Previous Band Math Expressions list, click the 
Clear button in the Band Math dialog.
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Band Math Requirements

The Band Math routine has 4 basic requirements:

1. The Band Math expression must be a single IDL statement — The syntax 
for defining your processing algorithm, or Band Math expression, is that of 
IDL. As you will see, for simple Band Math expressions no prior knowledge of 
IDL is required. For those interested in more complex processing, it is 
recommended that you review the “IDL Tips for Use in Band Math” on 
page 506. 

Note
Band Math requires that your expression be a single IDL statement in the 
form of a function:

Band Math Result = Band_Math_Expression

In the Band Math dialog, enter only the Band_Math_Expression (i.e., the 
right-hand side of the equation). Your expression can include any valid IDL 
function, including those that you write yourself. If you are using your own 
custom IDL functions, be sure to properly compile the function before using 
it in Band Math (see “Using Your Own IDL Functions in Band Math” on 
page 514).

2. All input bands must have identical dimensions — The Band Math 
expression is applied on a simple pixel-for-pixel basis, therefore the input 
bands (to which your expression is applied) must all have the same spatial 
dimensions in samples and lines. Further, Band Math does not automatically 
co-register images that are georeferenced. To automatically co-register images 
prior to using Band Math, use the Basic Tools → Layer Stacking utility (see 
“Layer Stacking” on page 470 for more information).

3. All variables in the expression must be named Bn (or bn) — The variables 
in the Expression which represent input bands must begin with the character 
“b” or “B” followed by up to 5 numeric characters. For example, valid 
Expressions for adding 3 bands together could be written in any of the 
following ways:

b1 + b2 + b3
B1 + B11 + B111
B1 + b2 + B3
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4. The result must be a band of the same dimension as the input bands — 
The Band Math Expression must produce a result which has the same spatial 
dimensions in samples and lines as the input bands.

IDL Tips for Use in Band Math

The power of the Band Math routine is provided by the power, speed, and flexibility 
of IDL. However, you needn't be an expert IDL programmer to be successful with 
Band Math. The following tips will help you make the most of Band Math and avoid 
common problems.

Pay Attention to the Data Type

Doing arithmetic in IDL is a bit different than simply using a calculator. The data 
type of your input bands and any constants you use in your expression are very 
important. Each data type—especially the non-floating point integer data types— has 
a limited dynamic range, meaning that they can only represent a limited set of 
numbers. For example, a byte data type can only represent values between 0 and 255. 
If you were to add two byte bands together (b1 + b2) and the sum was greater than 
255, the result would not be what you expect. When a value becomes bigger than the 
data type can hold, it overflows and starts counting from the beginning again. For 
example, adding the bytes 250 + 10 would produce a result of 4. This situation is 
commonly encountered in Band Math because remote sensing images are frequently 
stored as bytes or integers. To avoid data type overflow, you should promote the data 
type of input bands using one of the IDL data type casting functions (see Table 5-2 
for a full list of these functions). For example, when adding two-byte image bands 
together (as above), you will get the correct answer if you promote the data type to an 
integer using the IDL function FIX().

fix(b1) + b2

Note
To find out the data type of your images, just highlight them in the Available Bands 
List and their data type will be listed in the DIMS box at the bottom of the dialog.

You might ask, why not just carry out all computations in a floating point data type 
since it can represent any value? The answer is disk space. The greater the dynamic 
range a data type can represent, the more disk space it consumes. For example, byte 
data types use only 1 byte for every pixel, integers use 2 bytes for every pixel, while 
floating point data types use 4 bytes for every pixel. Thus a floating point result will 
consume twice as much disk space as an integer result. See Table 5-2 to learn more 
about the disk space usage and dynamic ranges of the IDL data types.
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IDL is Dynamically Typed

Using the IDL data type casting functions, like fix(), is not the only way that the data 
type of your Band Math result can get promoted. This is because IDL is Dynamically 
Typed, which means that the data type of an IDL statement is automatically promoted 
to the largest data type it encounters in the expression. Because certain numbers (like 
small integers) can be represented by several different data types, IDL must apply 
some default rules about how these numbers are interpreted. For example, numbers 
without decimal points are always interpreted as integers, even if they are within the 
dynamic range of a byte data type. For example, if you wanted to add the value 5 to a 
byte image and you used the Band Math expression:

b1 + 5 

the number 5 is interpreted as a 2-byte integer, so the result would be promoted to an 
integer image (which uses twice as much disk space as a byte image). If you wanted 
to keep the result a byte image, you could either use the data type casting function 
byte():

b1 + byte(5)

or, use an IDL shortcut for casting an integer as a byte:

b1 + 5B

Adding a B (upper or lowercase) immediately following a number ensures that it is 
interpreted as a byte data type. There are several other shortcuts like this that are quite 
useful if you use constants in your Band Math expressions. See the following table 
for details.

Data Type
Casting 

Function Shortcut Dynamic Range
Bytes 

per Pixel

Byte byte() B 0 to 255 1

Integer fix() –32768 to + 32767 2

Unsigned Integer uint() U 0 to 65535 2

Long Integer long() L approximately
+/– 2 billion

4

Unsigned Long 
Integer

ulong() UL 0 to approximately 
4 billion

4

Table 5-2: Data Type Casting Shortcuts
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The Order of Operation is Important

Mathematical operators are not necessarily carried out in the order they appear in the 
expression, but instead according to a hierarchy of precedence. Using parentheses can 
change the order of operations, with the most deeply nested part of the expression 
being carried out first. The order of precedence for IDL operators is listed in Table 5-
3. Operators that have the same precedence will be carried out in the order they 
appear in the expression. For example, consider the following expressions (with 
constants used in place of bands):

The order of precedence combined with the dynamic typing can also change the 
outcome of your expression. Be sure to promote the data type in the proper place in 

64-bit Integer long64() LL approximately
+/– 9e18

8

64-bit Unsigned 
Integer

ulong64() ULL 0 to approximately 
2e19

8

Floating Point float() . (decimal 
point)

+/– 1e38 4

Double Precision double() D +/– 1e308 8

Complex 
Floating Point

complex() same as float 8

Complex Double 
Precision

dcomplex() same as double 16

5 + 3 * 2 Evaluates to 11 because the multiplication operator 
takes precedence

(5 + 3) * 2 Evaluates to 16 because the parentheses change the 
order of operation

Data Type Casting 
Function Shortcut Dynamic Range Bytes 

per Pixel

Table 5-2: Data Type Casting Shortcuts (Continued)
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the expression to avoid data type overflow or integer division errors. For example, 
consider the following case:

The following table describes the order of precedence for each operator:

Float(5) + 10 / 3 All of the constants are integers but the float() 
function promotes the result into a floating point 
data type. However, because the division operator 
has precedence over the addition, it is applied first 
and the division is carried out as integers, then 
added to 5 as a floating point operation. The result 
is 8.0 (instead of the expected 8.3). 

5 + 10 / float(3) If the data type promotion is moved to one of the 
division variables then the result is 8.3.

Order of 
Precedence Operator Description

First ( ) Parentheses to group expressions

Second ^ Exponents

Third * Multiplication

# and ## Matrix multiplication

/ Division

MOD Modulus (remainder)

Fourth + Addition

– Subtraction and negation

< Minimum

> Maximum

NOT Boolean negation

Table 5-3: Operator Precedence
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Avoid Using IDL Functions That Require All of the Image Data 
at Once

Like all other ENVI routines, the Band Math processing is tiled. This means that if 
the images being processed are larger than the tile size defined in your preferences 
(see “Setting ENVI Preferences” on page 174), which is set to 1 MB by default, then 
it will be broken into smaller pieces, each piece processed separately, then 
reassembled. This can cause problems if you use an IDL function that requires all of 
the image data at once, because the Band Math expression is applied individually to 
each tile of data. For example, consider using the IDL function MAX(), which 
determines the maximum value in an array:

b1 / max(b1)

If the Band Math processing is tiled, then each tile will be divided by the tile's 
maximum value, instead of the maximum value of the whole band. If you find that 
your Band Math result has broad horizontal stripes in it, tiling may be the cause of the 
problem (because the tiles are horizontal sections of the image). IDL functions to 
avoid include MAX, MIN, MEAN, MEDIAN, STDDEV, VARIANCE, and TOTAL. 
In most cases it is also difficult to use the BYTSCL function, but if you know 
beforehand the data range of your input bands then you can use BYTSCL as long as 
you include the MIN and MAX keywords.

Fifth EQ Equal

NE Not equal

LE Less than or equal

LT Less than

GE Greater than or equal

GT Greater than

Sixth AND Boolean AND

OR Boolean OR

XOR Boolean exclusive OR

Seventh ? : Conditional expression (rarely used in Band Math)

Order of 
Precedence Operator Description

Table 5-3: Operator Precedence (Continued)
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Take Advantage of IDL’s Powerful Array Operators

IDL’s array operators are very easy to use and enormously powerful for Band Math. 
They allow you to examine and treat every pixel in an image individually without 
having to do a FOR loop (which is not allowed in Band Math). The array operators 
include the relational operators (LT, LE, EQ, NE, GE, GT), the Boolean operators 
(AND, OR, NOT, XOR), and the minimum and maximum operators (<, >). These 
operators are special because they operate simultaneously on every pixel in an image, 
and thus return an image of the same dimensions as that passed into them (a Band 
Math requirement). For example, to find all pixels with a negative value and replace 
them with the value –999, you could use the following Band Math expression:

(b1 lt 0) * (-999)  +  (b1 ge 0) * b1

The relational operators return a one for true and a zero for false, so the portion of the 
expression that reads (b1 lt 0) will return an array of the same dimensions as b1 filled 
with ones where b1 was negative and zeros everywhere else. Multiplying this by the 
replacement value (-999) affects only those pixels that met the criterion of being 
negative. The second relational operator (b1 ge 0) is the complement to the first, 
finding all of the pixels that are positive or zero, which is multiplied by their original 
value and added to the replacement value array. Constructing Band Math expressions 
with array operators like this provides a great deal of flexibility. See “Sample Band 
Math Expressions” on page 512 for more examples.

The following table describes selected IDL array handling functions. For a complete 
listing, see the IDL Reference Guide.

Category Available Functions

Basic Arithmetic Addition (+), subtraction (–), multiplication (*), and 
division (/)

Trigonometric 
Functions

sin(x), cos(x), and tan(x)

Arcs — asin(x), acos(x), and atan(x)

Hyperbolics — sinh(x), cosh(x), and tanh(x)

Relational and Logical 
Operators

LT, LE, EQ NE, GE, GT

AND, OR, NOT, XOR

maximum (>) and minimum (<)

Table 5-4: IDL Array Handling Functions
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Sample Band Math Expressions

Avoiding Integer Division

When performing division on bands that are not a floating point data type, the results 
are not rounded up or down, but simply truncated (the part of the number following 
the decimal point is simply dropped). To avoid integer division, always promote the 
data type to a floating point. 

b1 / float(b2)

If you want to keep the results of the division as an integer, it is usually better to carry 
out the division as a floating point operation then convert the results back to your 
desired data type. For example, if your input bands are both byte data type and you 
want to round up the result and store it as an integer, use the following expression:

fix( ceil( b1/float(b2) ) )

Data Type Conversions See Table 5-2 in “IDL is Dynamically Typed” on 
page 507

Other Math Functions exponent (^) and natural exponent (exp(x))

Natural Logarithm — alog(x)

Log Base 10 — alog10(x)

Integer rounding — round(x), ceil(x), and floor(x)

Square Root — sqrt(x)

Absolute Value — abs(x)

Category Available Functions

Table 5-4: IDL Array Handling Functions (Continued)
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Avoiding Integer Overflow

Integers have a limited dynamic range. If the Band Math operation is likely to 
produce a number that is too large or small to be represented by the data type of your 
input bands, then be sure to promote the data type accordingly. For example, if bands 
b1 and b2 for this sample expression are byte data types, then the maximum possible 
result could be as large as (255 * 255) = 65,025. Because bytes can only represent 
values up to 255, the result should be promoted to an unsigned integer to ensure that 
the correct values are returned, otherwise values larger than 255 will overflow and be 
reported incorrectly. 

uint(b1) * b2

To learn more about the dynamic range of IDL data types, see Table 5-2 in “IDL is 
Dynamically Typed” on page 507.

Creating a Blended Image

Band Math is an easy way to experiment with blending multiple images together. For 
example, if b1 and b2 are both byte data types, the above expression will produce a 
new byte image that is weighted 80% by b2 and 20% by b1.

byte( round( (0.2 * b1) + (0.8 * b2) ) )

Using Array Operators to Selectively Modify an Image

Using IDL’s array operators its easy to selectively modify an image or combine data 
from multiple image sources. In the following example, two images are combined to 
remove clouds from a scene. Pixels in the image b1 with values greater than 200 are 
assumed to be clouds and are replaced by the corresponding pixels from image b2. 

(b1 gt 200)*b2 + (b1 le 200)*b1

The next example is a slightly more complicated expression but its use of array 
operators is quite similar to the previous example. This expression uses several 
criteria to create a binary mask identifying pixels that are predominantly clouds. This 
algorithm can actually be used to create cloud masks from calibrated daytime 
imagery from the Advanced Very High Resolution Radiometer (AVHRR) sensor. In 
the expression, b4 (a thermal band) must be negative or b2 (a reflectance band) must 
exceed 0.65 and the difference between bands b3 and b4 (a mid IR and thermal band) 
must exceed 15 degrees. Because relational operators return a one for true, the mask 
will have a value of one where there are clouds and zeros elsewhere.

(b4 lt 0) or ( b2 gt 0.65 AND (b3 - b4) gt 15 )
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Using the Maximum and Minimum Operators

The minimum and maximum operators are also array based operators, but unlike the 
relational or Boolean operators they do not return true or false, but instead the actual 
MAX or MIN value. In the following example, for every pixel in the image, the 
greater of zero, b2 or b3 is added to b1. This ensures that the value that is added to b1 
is always positive.

b1 + (0 > b2 > b3)

In the next example, the use of both the minimum and maximum operators clips the 
data values in b1 at zero and one — no value in b1 will exceed one or fall below zero. 

0 > b1 < 1

Using Your Own IDL Functions in Band Math

Since ENVI gives you access to IDL capabilities, you can use the power of built-in 
IDL features, IDL user functions, or your own routines to perform custom operations. 
The only requirement for these functions is that they accept one or more image arrays 
as input and that they output a single-band, two-dimensional array result of the same 
dimensions as the input bands. These functions need to be saved in a directory that is 
within the ENVI path so they will be automatically accessible (for example, the 
ENVI save_add directory). They can also be compiled using File → Compile IDL 
Module.

The following are some simple examples of user band math functions. Note that these 
examples are only intended to illustrate the process of executing your own custom 
functions. In most cases the algorithms could be applied directly in Band Math 
without the need to create a custom function. See “Band and Spectral Math 
Functions” in Chapter 2 of the ENVI Programmer’s Guide manual and “Introduction 
to ENVI User Functions” in the ENVI Tutorials manual for more information about 
using Band Math to implement user defined procedures.

Band Math Function 1

The following example is a very simple custom band math function that adds two 
bands together. The following program text can be entered into a text editor and saved 
with the filename user_bm1.pro:

FUNCTION user_bm1, b1, b2
    RETURN, b1 + b2
  END

Compile this function by selecting File → Compile IDL Module and selecting the 
filename.
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To call this function from the Band Math dialog, use the following syntax in the 
Enter an expression text box:

user_bm1(b1, b2)

Band Math Function 2

The following example is a custom band math function that converts the data type of 
a variable to byte and then inverts the values. The following program text can be 
entered into a text editor and saved with the filename user_bm2.pro:

FUNCTION user_bm2, b1
    lut = 255 - BINDGEN(256)
    b1 = BYTSCL(b1)
    b1 = lut[b1]
    RETURN, b1
  END

Compile this function by selecting File → Compile IDL Module and selecting the 
filename.

To call this function from the Band Math dialog, use the following syntax in the 
Enter an expression text box:

user_bm2(b1)

Band Math Function 3

The following example is a custom band math function that replaces variable b1 with 
the values of variable b2 at each b1 location that has a value of zero. This function is 
useful for taking a classification image and replacing the unclassified pixels with 
those of another classification image. The following program text can be entered into 
a text editor and saved with the filename user_bm3.pro:

FUNCTION user_bm3, b1, b2
    b1 = (b1 EQ 0)*b2 + (b1 NE 0)*b1
    RETURN, b1
  END

Compile this function by selecting File → Compile IDL Module and selecting the 
filename.

To call this function from the Band Math dialog, use the following syntax in the 
Enter an expression text box:

user_bm3(b1, b2)
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Band Math Function 4

The following example is a custom band math function that calculates the 
Normalized Difference Vegetation Index (NDVI) and scales it into the byte data 
range. Note that the MIN and MAX keywords are required in the function call to 
BYTSCL to ensure that the same minimum and maximum values are used for scaling 
all tiles of a tiled image (for more information, see “IDL Tips for Use in Band Math” 
on page 506).

An infrared image band near 0.8 µm should be used for the b1 variable while a red 
band near 0.6 µm should be used for the b2 variable. The following program text can 
be entered into a text editor and saved with the filename user_bm4.pro.

FUNCTION user_bm4, b1, b2
    NDVI_float = (float(b1) - b2) / (float(b1) + b2)
    b1 = BYTSCL(NDVI_float, min = -1.0, max = 1.0)
    RETURN, b1
  END

Compile this function by selecting File → Compile IDL Module and selecting the 
filename.

To call this function from the Band Math dialog, use the following syntax in the 
Enter an expression text box:

user_bm4(b1, b2)
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Spectral Math

Use Spectral Math™ to apply mathematical expressions or IDL procedures to 
spectra (and also to selected multiband images). The spectra can be from a multiband 
image (i.e., a Z profile), a spectral library, or an ASCII file. For more information and 
detailed instructions, see “Spectral Math” on page 833.
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Segmenting Images

Use Segmentation Image to segment an image into areas of connected pixels based 
on the pixel DN value. You can enter a single DN or a range of DN values to use in 
the segmentation. Either four or eight adjacent pixels are considered for the 
connectivity and you can specify the minimum number of pixels that must be 
contained in a region. Each connected region, or segment, is given a unique DN value 
in the output image.

1. Select Basic Tools → Segmentation Image.

2. In the file selection dialog, select an input band and click OK. The 
Segmentation Image Parameters dialog appears.

3. In the Min Thresh Value and Max Thresh Value threshold text boxes, enter a 
minimum and/or maximum threshold value in DN. 

Note
If only one value is entered, the data minimum or maximum is used as the 
other end of the threshold. 

Figure 5-15: Example of a Segmentation Image
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Note
To use a single DN value, enter that value in both the Min Thresh Value and 
Max Thresh Value threshold text boxes. Only pixels that fall within the 
entered DN range will be considered in making the segmentation image. All 
other pixels will have an output value of 0.

4. In the Population Minimum text box, enter the minimum number of pixels in 
a segment.

5. Use the arrow toggle button to select either 4 or 8 neighbors to be considered 
for the connectivity.

6. Select File or Memory output.

7. Click OK.

The resulting segmentation image filename appears in the Available Bands List.
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Regions of Interest

Use Region of Interest to access common ROI functions such as defining, saving, 
restoring, deleting, exporting, and reconciling ROIs. Also use it to create 
classification images from ROIs or to convert image values to ROIs.

Note
Each function described in this section can also be accessed from within the ROI 
Tool dialog or from the Display Tools menu. For detailed instructions, see 
“Defining Regions of Interest” on page 289.

Defining Regions of Interest

To begin ROI definition:

1. Select Basic Tools → Region of Interest → ROI Tool.

2. The ROI Definition dialog appears.

For detailed instructions, see “Defining Regions of Interest” on page 289.

Restoring Saved ROI Files

To restore previously saved ROI files:

1. Select Basic Tools → Region of Interest → Restore Saved ROI File.

2. Select the desired input file.

Saving ROIs to Files

1. To save regions of interest currently in memory to a file, select Basic 
Tools → Region of Interest → Save ROIs to File. 

2. Enter an output filename with the extension .roi for consistency.

Deleting ROIs

1. Select Basic Tools → Region of Interest → Delete ROIs.

2. When the Delete Regions dialog appears, click on the names of the regions to 
be deleted.

3. Click OK to permanently delete those ROIs. 
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Exporting ROIs to EVFs

Use Export ROIs to EVFs to export ROIs to ENVI vector files.

1. Select Basic Tools → Regions of Interest → Export ROIs to EVFs.

2. In the file selection dialog, select the input file associated with the ROIs.

The Export Region to EVF dialog appears.

For details, see “Exporting ROIs to ENVI Vector Files” on page 316.

Exporting ROIs to the n-D Visualizer

Use Export ROIs to n-D Visualizer to export selected ROIs to the n-D Visualizer so 
you can see the distribution of the points within your ROIs and between your ROIs. 
This option is very useful for checking the separability of your classes when you use 
ROIs as input into supervised classifications.

1. Select Basic Tools → Regions of Interest → Export ROIs to n-D Visualizer.

2. Select a ROI to export by clicking on the ROI name.

Note
To select all of the ROIs, click Select All Items.

3. Click OK.

An n-D Visualizer window and n-D Controls dialog appear.

For detailed instructions, see “Exporting ROIs to the n-D Visualizer” on page 316.

Saving ROIs to an ASCII File

Use Output ROIs to ASCII to output ROIs to an ASCII text file. You can output 
ROI locations in pixel or line values, or as one-dimensional pointers. You can also 
output map information, latitude and longitudes, and band data values for every ROI 
location. For detailed instructions, see “Exporting ROIs to ASCII” on page 317.

1. Select Basic Tools → Regions of Interest → Output ROIs to ASCII.

2. When the file selection dialog appears, select the input file and perform any 
spectral subsetting.

3. Click OK.
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4. Select the ROIs to output.

Note
To edit the ASCII output, see “Editing ASCII Output Format” on page 318.

5. Enter or choose an output filename and click OK.

Reconciling ROIs

Use Reconcile ROIs to apply ROIs defined in one image size to images of different 
sizes.

1. Select Basic Tools → Region of Interest → Reconcile ROIs.

2. When the Reconcile ROIs Parameters dialog appears, click on the ROIs to 
select them.

For detailed instructions, see “Reconciling ROIs” on page 307.

Figure 5-16: Reconcile ROIs Parameters Dialog
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Reconciling ROIs via Map

Use Reconcile ROIs via Map to apply ROIs defined in one georeferenced image to 
another, overlapping, georeferenced image.

1. Select Basic Tools → Reconcile ROIs via Map.

2. When the Reconcile ROIs via Map Parameters dialog appears, select the 
desired ROIs by clicking on the names.

3. Select the source file where the ROIs were drawn.

4. Select the georeferenced file that the ROIs will be reconciled to and click OK.

The ROIs are listed in the ROI Tool dialog.

For detailed instructions, see “Reconciling ROIs via Map” on page 309.

Converting Band Values to ROIs

Use Band Threshold to ROI to convert specific image values and ranges to Regions 
of Interest. 

1. Select Basic Tools → Region of Interest → Band Threshold to ROI.

2. When the Image Threshold to ROI Input Band dialog appears, select the input 
band for the thresholding.

For detailed instructions, see “Converting Band Values to ROIs” on page 309.

Creating Class Images from ROIs

Use Create Class Image from ROIs to convert selected ROIs into an ENVI 
classification image. The class colors will be the same as the ROI colors.

1. Select Basic Tools → Region of Interest → Create Class Image from ROIs.

The Classification Image from ROIs dialog appears.

2. In the list of ROIs, select ROIs to use by clicking on the ROI names.

3. Click OK.

The Classification Image from ROIs Parameters dialog appears.

For detailed instructions, see “Creating Class Images from ROIs” on page 311.
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Create Buffer Zone from ROIs

Use Create Buffer Zone from ROIs to create a buffer zone image in which every 
pixel has a floating point or integer value that is defined as the distance from that 
pixel to the nearest pixel of the selected ROI. 

1. Select Basic Tools → Region of Interest → Create Buffer Zone from ROIs.

The Classification Image from ROIs dialog appears.

2. In the list of ROIs, select ROIs to use by clicking on the ROI names.

3. Click OK.

The Classification Image from ROIs Parameters dialog appears.

For detailed instructions, see “Calculating Buffer Zone Images for ROIs” on 
page 310.

Compute ROI Separability

Use Compute ROI Separability to compute the separability between selected ROI 
pairs for a given input file.

1. Select Basic Tools → Region of Interest → Compute ROI Separability.

The Classification Image from ROIs dialog appears.

2. In the list of ROIs, select the pair of ROIs to use by clicking on the ROI names.

3. Click OK.

The Classification Image from ROIs Parameters dialog appears.

For detailed instructions, see “Computing ROI Separability” on page 312.

Hiding the ROI Tool Dialog

To remove the ROI dialog from the screen or hide it without erasing ROIs from your 
images, select one of the following options:

• In the ROI Tool dialog, select Options → Hide Window.

• In the Window Finder, double-click on the window name.
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Unhiding the ROI Tool Dialog

To unhide the ROI Tool dialog, select one of the following options:

• In the Window Finder, click on the window name.

• From the Display menu, select Overlay → Region of Interest.
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Mosaicking Images

Use Mosaicking to mosaic both pixel-based and georeferenced images. 

Note
You may also access this function from the Map menu. For details about using this 
function, see “Image Mosaicking” on page 888.

1. Select Basic Tools → Mosaicking → Pixel-Based or Georeferenced.

2. From the Import menu, select images for the mosaic. 

3. When the standard ENVI file selection dialog appears, select the desired file. 
Load as many files as desired for the mosaic.

4. Position each one in the output file by either entering the desired upper left 
corner coordinate or by clicking and dragging the schematic image outline for 
each image to the desired location (see “Image Mosaicking” on page 888 for a 
more detailed description).

5. Click OK to create the mosaic.
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Masking

Use masking to create image masks. A mask is a binary image that consists of values 
of 0 and 1. When a mask is used in a processing function, the areas with values of 1 
are processed and the masked 0 values are not included in the calculations. 

Masking is available for selected ENVI functions including statistics, classification, 
unmixing, matched filtering, continuum removal and spectral feature fitting.  

Building Masks

Use Build Mask to build image masks from specific data values (including the data 
ignore value), ranges of values, finite or infinite values, Regions of Interests (ROIs), 
ENVI vector files (EVFs), and annotation files. You can use any combination of input 
to define a mask and you can permanently apply a mask to an image. 

Note
Masks can be applied on-the-fly when using specific ENVI functions. These 
functions include statistics, classification, unmixing, matched filtering, continuum 
removal, and Spectral Feature Fitting.

Figure 5-17: Example Mask Image from a Data Range and Imported ROI
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Setting Mask Sizes

The size of the mask can be set to the same size as a displayed image or to the size 
parameters that you entered manually:

1. Select Basic Tools → Masking → Build Mask.

2. Select a display number or select No Display. The #n Mask Definition dialog 
appears. If a display number was selected, the number of samples and lines are 
automatically entered in the Samples and Lines parameters. 

Note
If no display windows are open, or if you selected No Display, the Mask 
Definition dialog appears directly and you must enter the desired number of 
samples and lines to define the size of the mask image.

Figure 5-18: Mask Definition Dialog
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Note
If the input file has a data ignore value, then the dialog opens with the value 
automatically added to the Selected Attributes for Mask list. The two numbers 
shown with the filename indicate the data ignore value in the file, and the bracketed 
word [All] refers to which bands in a multiband file must contain the data ignore 
value in order for a pixel to be masked.

Masking Options

Options in the Mask Definition dialog include importing data values, importing 
annotations, masking finite values, masking non-numbers and infinite data values, 
using ROIs and EVFs with the mask, and selecting areas for masking.

Importing Data Values and Ranges 

1. In the Mask Definition dialog, select Options → Import Data Range. The 
Select Input for Mask Data Range dialog appears.

2. Use this dialog, the select the input file for the data range. The Input for Data 
Range Mask dialog appears.

3. Click the Select New Input button if you need to change the input file.

4. Enter a minimum and/or maximum value in the Band Min Value and Band 
Max Value text boxes.

Note
If the input file has a data ignore value, then the dialog opens with the value 
automatically entered in the Band Min Value and Band Max Value text 
boxes.

5. Select either Mask pixel if ALL bands match range or Mask pixel if ANY 
bands match range. The ALL option includes all pixels that are in the data 
range for all bands (a logical AND operation). The ANY option includes all 
pixels that are in the data range for any band (a logical OR operation)

6. Click OK to enter the range into the mask definition list.

Note
If you enter only a minimum or maximum value and click OK, the data’s 
actual maximum or minimum, respectively, will be used as the other end 
value.
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Including Annotations

• To include an annotation file in the mask, select Options → Import 
Annotation and select the desired input file. 

• To include the currently displayed annotation shapes in the mask, select 
Options → Import Displayed Annotation.

Note
Only rectangles, ellipses, and polygons are imported into the mask definition.

Masking Finite Values

To build a mask of all finite data values:

1. Select Options → Mask Finite Values.

2. In the band selection dialog, select a band and click OK.

The band is listed in the Mask Definition dialog.

Masking Non-Numbers and Infinite Values

To produce a mask of all NaN (Not a Number) and Inf (Infinite) data values:

1. In the Mask Definition dialog, select Options → Mask “NaN”/ “Inf” Values.

2. In the band selection dialog, select a band and click OK.

The band is listed in the Mask Definition dialog.

Including Regions of Interest

Use Import ROIs or Import ROI Intersection to include Regions of Interest in a 
mask as described in the following sections:

Including Standard ROIs

1. In the Mask Definition dialog, select Options → Import ROIs.

2. When the Mask Definition Import ROI dialog appears, select the desired ROIs 
by clicking on the ROI names. 

3. Click OK.

Note
All imported ROIs are treated as a single mask layer.
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Including ROI Intersections

Use Import ROI Intersection to calculate the intersection of two or more ROIs on -
the-fly and include the result in a mask. When the intersection of the ROIs is 
calculated, a point type ROI is created from the intersecting points.

1. In the Mask Definition dialog, select Options → Import ROI Intersection.

2. In the Mask Input ROI Intersection dialog, click on the names of the 
intersecting regions, then click OK.

The new ROI is listed in the Mask Definition dialog.

Note
All of the selected regions must intersect.

Including ENVI Vector Files (EVFs)

1. In the Mask Definition dialog, select Options → Import EVFs.

2. When the Mask Definition Input EVFs dialog appears, select the desired 
vector file to input by clicking on the filename.

3. Click OK.

Selecting Areas

Select from the following options to define mask areas:

• To set the defined areas in the mask to 1 (On) or to 0 (Off), select Options → 
Selected Areas On/Off. The mask is built using a Logical OR or Logical 
AND operation between all of the items in the list. The default, Logical OR, 
uses all the defined areas to make the mask. Using the Logical AND masks 
only the areas where all of the defined areas overlap.

Note
Selected areas are those pixels that satisfy the masking criteria.

• To define the mask using only those areas where the listed data ranges, 
annotation shapes, and/or ROIs overlap, select Options → Selected 
Attributes [Logical AND].

• To use all the defined areas to make the mask, select Options → Selected 
Attributes [Logical OR].
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Deleting Attributes

To delete an item from the Select Attributes list in the Mask Definition dialog, 
highlight the item and click Delete Item.

Clearing the Attribute List

To remove all items from the Select Attributes list in the Mask Definition dialog, 
click the Clear All Items button.

Saving Masks

1. In the Mask Definition dialog, select output to File or Memory.

2. Click Apply.

Closing the Masking Dialog

To close the Mask Definition dialog, click Cancel.

Applying Masks

Use Apply Mask to permanently apply a mask to an image, giving that the masked 
out value is what you specify.

1. Select Basic Tools → Masking → Apply Mask.

2. When the Apply Mask Input File dialog appears, select the desired input file 
and any spatial or spectral subsets.

3. If needed, use the Mask Options pull-down button to create a mask. This 
menu contains the following options:

• Build Mask — Use this option to access the Mask Definition dialog, 
which is described in “Building Masks” on page 527.

• Mask Data Ignore Values [All Bands] — Choose this option to build a 
mask that includes all the pixels for which the data ignore value occurs in 
all bands (a logical AND operation).

• Mask Data Ignore Values [Any Band] — Choose this option to build a 
mask that includes all the pixels for which the data ignore value occurs in 
any band (a logical OR operation).

• Mask NaNs [All Bands] — Choose this option to build a mask that 
includes all pixels which have a value of NaN in all bands (a logical AND 
operation).
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• Mask NaNs [Any Band] — Choose this option to build a mask that 
includes all pixels which have a value of NaN in any band (a logical OR 
operation).

Note
NaN and Infinity values are treated the same in ENVI. Infinity values are 
masked along with NaNs. Moreover, the Mask NaNs options are only 
available for files containing floating point, double-precision floating, 
complex floating, or double-precision complex data types.

When one of the latter four mask options is chosen, the mask is automatically 
built and named either <basename>_iv_mask, or <basename>_nan_mask, 
where <basename> is the name of the selected input file and the mask is made 
from either ignore values (iv) or NaNs (nan). In the case where the selected 
input file is in memory, then the mask is assigned a temporary filename.

4. Specify the mask by clicking the Select Mask Band button and selecting the 
desired mask from the list of available bands. Only mask images that are the 
same size as the input band are available.

Note
To clear the selected mask band, select Mask Options → Clear Mask 
Band.

5. When the desired input is selected, click OK.

6. When the Apply Mask Parameters dialog appears, enter the desired value in 
the Mask Value text box.

Note
All areas in the input images where the mask equals zero are set to this mask 
value.

7. Enter an output filename or select output to memory.
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Calibration Utilities

Use Calibration Utilities to apply calibration factors to ASTER, AVHRR, MSS, 
QuickBird, TM and TIMS data, and to use a variety of atmospheric correction 
techniques.

ASTER Radiance Calibration

Use the ASTER Radiance calibration utility to extract ASTER 1A/1B radiometric 
calibration and apply calibration information from HDF attributes. For ASTER level 
1B data, the byte-scaled radiance data is converted into floating point radiance units. 
For ASTER level 1A data, a complete calibration to radiance is performed. For 
detailed instructions, see “ASTER Radiance Data” on page 558.

AVHRR Calibration

Use the AVHRR calibration utility to calibrate AVHRR data from the NOAA 12, 14, 
15, 16 and 17 satellites. Bands 1 and 2 are calibrated to percent reflectance and bands 
3, 4, and 5 are calibrated to brightness temperature, in degrees Kelvin. For detailed 
instructions, see “Calibrating AVHRR Data” on page 559.

Landsat MSS Calibration

Use Landsat MSS calibration to convert Landsat MSS digital numbers to radiance or 
exoatmospheric reflectance (reflectance above the atmosphere) using published post-
launch gains and offsets (see “Landsat TM Calibration” on page 535 for more 
details):

1. Select Basic Tools → Preprocessing → Calibration Utilities → Landsat 
MSS.

2. When the MSS Calibration Input File dialog appears, select the input file and 
perform any subsetting using the standard ENVI file selection procedures. 

3. Click OK. The MSS Calibration Parameters dialog appears.

4. From the Satellite button menu, select the satellite type.

5. Enter the data acquisition month, day, year, and sun angle into the appropriate 
text boxes.

6. Select the output type by clicking the Radiance or Reflectance toggle buttons.
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7. Select either File or Memory output.

8. Click OK to start the function.

The MSS Calibration Status window appears with the output filename listed and the 
percent completed displayed.

Landsat TM Calibration

Use Landsat TM calibration to convert Landsat TM or ETM digital numbers to 
radiance or exoatmospheric reflectance (reflectance above the atmosphere) using 
published post-launch gains and offsets (see http://landsat7.usgs.gov/cpf/cpf.php and 
http://edcftp.cr.usgs.gov/pub/metadata/satellite/landsat7.tar.gz).

The spectral radiance (Lλ) is calculated using the following equation:

where QCAL is the calibrated and quantized scaled radiance in units of digital 
numbers, LMINλ is the spectral radiance at QCAL = 0, LMAXλ is the spectral 
radiance at QCAL = QCALMAX, and QCALMAX is the range of the rescaled 
radiance in digital numbers. LMINλ and LMAXλ are derived from tables provided in 
the Landsat Technical Notes (August 1986) with the information provided through 
the TM Calibration Parameters dialog (Figure 5-19) in ENVI. QCALMAX is 255 for 
all TM data and 127 for all MSS data except Band 4 (0.8 to 1.1 µm), which is 63 for 
certain time periods (data acquired before February 1, 1979 for Landsat 1-3 and 
processed before October 22, 1982). The resulting radiance (Lλ) is in the units of 
milliwatts per square centimeter per steradian per micrometer (mW/(cm2*sr*µm)).

The exoatmospheric reflectance (ρp) is calculated using the following equation:

where Lλ is the spectral radiance, d is the Earth-Sun distance in astronomical units, 
ESUNλ is the mean solar exoatmospheric irradiance, and θs is the solar zenith angle 
in degrees. ESUNλ is derived from tables provided in the Landsat Technical Notes 
(August 1986). The resulting reflectance is unitless.

TM band 6, if present, is converted to temperature. If 7 bands are input, the 6th band 
is assumed to be the thermal infrared band. If only 6 bands are input, then it is 
assumed that there is no thermal infrared band.

Lλ LMINλ
LMAXλ LMINλ–

QCALMAX
---------------------------------------------- 

  QCAL+=

ρp
π Lλ d

2⋅ ⋅
ESUNλ θscos⋅
--------------------------------------=
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For Landsat 7 GeoTIFF files that do not contain calibration coefficients, you can use 
Landsat TM calibration to specify the calibration coefficients and other related 
parameters, or you can extract the parameters from a Web server. 

1. Choose one of the following options from the main ENVI menu bar:

• Select Basic Tools → Preprocessing → Calibration Utilities → Landsat 
TM , or 

• Select Basic Tools → Preprocessing → Data-Specific Utilities → 
Landsat TM → Landsat TM Calibration, or

• Select Spectral → Preprocessing → Calibration Utilities → Landsat 
TM, or

• Select Spectral → Preprocessing → Data-Specific Utilities → Landsat 
TM → Landsat TM Calibration.

2. When the TM Calibration Input File dialog appears, select the input file and 
perform any subsetting using the standard ENVI file selection procedures.

3. Click OK. The TM Calibration Parameters dialog appears. 

Figure 5-19: TM Calibration Parameters Dialog
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• For Landsat 7 HDF files, the data acquisition date information, gains and 
bias factors, and sun elevation and azimuth are automatically read from the 
header.

•  For Landsat 7 GeoTIFF files, these parameters can be obtained from the 
EROS Data Center as CPF files and MetaData files. They may also be 
acquired through the Get Calibration Parameters from Web button, 
which accesses the RSI web server for this information. The Earth-Sun 
distance used in the calibration is based on the data acquisition date and 
calculated from a table in the Landsat 7 User’s Guide dated 5/1/2001. 

Note
If the input filename does not follow the Landsat 7 file-naming convention, 
the data acquisition date information will default to January 1, 1984 and 
the sun elevation to 90 degrees.

4. Choose from the following options:

• Enter or change any of the parameters as necessary.

• To download the calibration parameters from the RSI Web server, click the 
Get Calibration Parameters from Web button.

Note
You must have an active internet connection to use this option. Moreover, 
you may not be able to access this site through a firewall or proxy server. In 
this case, your connection will be timed out within 15 seconds.

The information is obtained from the Web server and automatically 
entered into the corresponding fields.

• If you are using a file that does not follow the Landsat 7 file-naming 
convention, follow these steps:

A. When the warning dialog appears, click OK. 

The TM Web Calibration Parameters dialog appears. 

B. Enter the original filename, or select the Date/Path/Row/Band button and 
enter the corresponding information.

The date, path, row, and band information is used to derive a filename 
based on the Landsat 7 naming convention.

C. In the TM Web Calibration Parameters dialog, click OK.
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5. Select the desired output type using the Radiance and Reflectance toggle 
buttons.

6. Provide Scale: Min and Scale: Max values if these values are not provided by 
a header or the Web server.

The minimum scale and maximum scale values are satellite parameters set for 
each band. These values are used to derive the gains and offsets.

7. Choose either File or Memory output.

8. Click OK to perform the calibration.

The TM Calibration Status window displays the progress of the operation. When 
complete, the output file is listed in the Available Bands List.

QuickBird Radiance Calibration

DigitalGlobe’s QuickBird image data is typically distributed in relative radiance. Use 
the QuickBird Radiance calibration utility to convert the relative radiance into 

absolute radiance in units of [ ]. The calibration is performed 
using the calibration factors in the QuickBird metadata file (the absCalFactor in the 

.imd file). The units are converted from [ ] into [ ] 
using the following nominal bandpass widths:

The gain factors that were applied can be found in the ENVI Header file of the 
calibrated image.

To use the QuickBird Radiance calibration utility perform the following steps.

1. From the main ENVI menu, select Basic Tools → Preprocessing → 
Calibration Utilities → QuickBird Radiance.

2. In the file selection dialog, select the QuickBird image you wish to calibrate 
and perform any spatial or spectral subsetting. Select only an original 
unmodified QuickBird image product.

Pan band: 450 nm

Multispectral Band 1: 70 nm

Multispectral Band 2: 80 nm

Multispectral Band 3: 60 nm

Multispectral Band 4: 140 nm

µW( ) cm
2

nm str⋅ ⋅( )⁄
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2
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If ENVI is unable to locate the associated QuickBird Metadata file, you will be 
prompted to select it.

The QuickBird Calibration Parameters dialog appears.

3. To scale the calibrated result into unsigned integers set the Scale Output to 
Integers toggle button to Yes and enter a scale factor. To output the result in 
floating point set the toggle button to No.

Scaling the result into integers will produce a file that is half the size (in bytes) 
as the floating point result, however the precision is typically reduced to three 
digits. 

Note
The maximum value that an unsigned integer can hold is 65,535.

4. Choose output to File or Memory for the calibrated result.

5. Click OK to start the processing.

Using FLAASH in ENVI

If you have the FLAASH plug-in to ENVI, refer to the FLAASH User’s Guide for 
detailed information on the use of the FLAASH calibration utility.

Using ATREM in ENVI

You can operate the popular ATmosphere REMoval (ATREM) program directly from 
ENVI. ENVI simply provides an interface to the ATREM program. The executable 
code is not distributed with ENVI. ATREM was developed and distributed by the 
Center for the Study of Earth from Space (CSES), Cooperative Institute for the 
Research in Environmental Sciences (CIRES), University of Colorado, Boulder.

Note
The ATREM executable code is no longer available for distribution.

Use ATREM to calculate scaled surface reflectance values from hyperspectral 
radiance data using an approximate atmospheric radiative transfer modeling 
technique. Radiative transfer modeling is used to calculate the atmospheric 
transmittance of gases and molecular and aerosol scattering. The water vapor amount 
is derived on a pixel-by-pixel basis using the 0.94 µm and 1.14 µm water vapor bands 
and a three channel ratioing technique. For more detailed information see the 
ATmosphere REMoval Program User’s Guide.
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If you have the ATREM executable, place it in the ENVI \bin directory and ENVI 
will automatically use it. If it is located in another directory, a parameter can be set 
that points to the correct location (see “Setting ATREM Output Parameters” on 
page 543). When ATREM is executed using ENVI, the input information needed is 
generated and the ATREM process is spawned by ENVI automatically. The output 
from ATREM is automatically opened in ENVI and it appears in the Available Bands 
list upon completion.

Selecting Input Files

Note
If you want to use a subset, use Basic Tools → Resize Images before running 
ATREM.

1. Select Basic Tools → Preprocessing → Calibration Utilities → ATREM.

2. When the standard ENVI file selection dialog appears, select a file.

Supplying Wavelengths

Wavelengths are required to run ATREM. If your input data does not include 
wavelengths in the ENVI header, a prompt appears asking you to supply the 
wavelengths from an ASCII file: 

Select the column that contains the wavelengths and the column that contains full 
width half maximum (FWHM) values, if included.

The wavelengths and FWHM values must be in units of micrometers.

Inputting AVIRIS or HYDICE Data

If your input data is AVIRIS or HYDICE, select the scaled calibrated radiance image. 
See the ATREM User’s Guide for details.
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Setting ATREM Input Parameters

Use the ATREM Input Parameters dialog to select sensor types (AVIRIS, HYDICE, 
or User Defined) and to enter input data parameters.

1. When the ATREM Input Parameters dialog appears select the data sensor type 
from the Sensor button menu.

Note
If you select User Defined, select the file that contains the scale factors from 
the file selection dialog that appears. 

The user defined scale factor file must contain one scale factor for each band 
that is used to scale the input radiance data to units of 
microwatts/(cm2*nm*steradian) following the model of:

scale_factor * DN = 1 microwatt / (cm2 * nm * steradian)

The user defined scale factor file contains two columns of ASCII data, band 
number and scale factor for every band in the data file.

2. Enter the altitude of the sensor in kilometers.

3. Enter the spectral resolution of the input data in nanometers. 

Note
If your ENVI header file contains FWHM values, no value is required, the 
header values are used instead, and this dialog box does not appear. The 
FWHM values must be in units of micrometers.

4. Select the date and enter the time (in GMT) of the data overflight.

Note
For AVIRIS data, this information is read from the header if possible.

5. Enter the data scene center latitude and longitude. To change the latitude and 
longitude from degrees, minutes, seconds to decimal degrees, click on the 
DD<->DMS button. 

Note
Enter negative values to indicate south latitudes and west longitudes.
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Note
For AVIRIS data, this information is read from the header if possible.

6. Enter the channel ratio parameters or select from the default parameters used 
to derive the column water vapor amounts for every pixel in the data.

7. Enter the starting wavelength value and number of channels to average for the 
windows and water vapor absorption bands for both or either of the 0.94 µm 
and 1.14 µm water vapor bands.

The channel ratio parameters are used to derive the column water vapor 
amounts for every pixel in the data scene. The amount of water vapor is 
determined by using a three-channel ratio. Several bands in the water 
absorption feature are averaged and ratioed against two sets of averaged 
window channels adjacent to the water absorption feature. 

One or both of the water vapor absorption bands can be used to derive the 
amount of column water vapor. If both the 0.94 µm and the 1.14 µm water 
vapor absorption bands are used, the amount of column water vapor used is the 
average of the derived amount for each absorption band. 

In some cases only one of the water vapor absorption bands should be used. 
For example, if your site contains a large amount of iron-rich soils and 
minerals, only the 1.14 µm water vapor band should be used. 

• To use only one water vapor band, enter the same parameters into both the 
0.94 and 1.14 text boxes. 

• For the iron-rich example, enter the same wavelengths that are in the 1.14 
text boxes into the 0.94 text boxes.

• To use default channel ratio parameters, select from the Apply Defaults 
button menu. For more information, see the ATREM User’s Guide.

8. Select which of the seven atmospheric gases should be modeled and removed 
during the reflectance calculation by clicking in the check box next to the gas 
name.

Note
By default, all the gases are selected.

9. Select an aerosol model using the pull-down selections. 

10. Enter a visibility for the conditions during the overflight or click the arrow 
toggle button to enter an aerosol optical depth measured at the time of the 
overflight.
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11. Select a standard atmospheric model from the pull-down selections and enter a 
vertical column ozone amount in atm-cm units. Enter the average surface 
elevation of the data scene in kilometers.

12. Set the output parameters as described in the next section.

Setting ATREM Output Parameters

Use the ATREM Output Parameters dialog to change the output filenames, scale 
factor, output spectral resolution, and execution path string. The output ATREM 
parameters file contains the defined parameters in the necessary ATREM input 
format. ENVI automatically executes ATREM using this file as input. The output 
image file contains the output apparent reflectance data scaled by the output data 
scale factor into two-byte integers.

1. In the ATREM Input Parameters dialog, click the Edit Output Parameters 
button. The ATREM Output Parameters dialog appears.

2. Select from the following options:

• To change any of the default output filenames, enter the new filenames. 
The output ATREM parameters file contains the defined parameters in the 
necessary ATREM input format. ENVI automatically executes ATREM 
using this file as input. The output image file contains the output apparent 
reflectance data scaled by the output data scale factor into two-byte 
integers. The output water vapor image contains the total column water 
vapor amount for every pixel in cm * 1000 so it is two-byte integer data. 
The output transmission file is an ASCII file that contains 60 atmospheric 
transmittance spectra. For details on the file format, see the ATREM User’s 
Guide.

• Change the Output Data Scale Factor if desired. The ATREM output 
apparent reflectance values, between 0 and 1, are multiplied by the scale 
factor to make them into two-byte integer data.

• If desired, enter an output spectral resolution.

If no value is entered for this parameter, the output spectral resolution will 
be the same as the input. See the ATREM User’s Guide for more 
information.

• Enter the directory path and name of the ATREM executable. ENVI 
automatically spawns the executable.

3. In the Output Parameters dialog, click OK.
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Executing ATREM

After setting the ATREM input and output parameters, click OK in the Input 
Parameters dialog to start the ATREM process. 

ENVI generates the needed ATREM input file and spawns the ATREM process. A 
window appears displaying the line number that ATREM is working on. When the 
process is completed, ENVI opens the resulting files, and the water vapor image and 
the apparent reflectance bands are listed in the Available Bands List.

Flat Field Calibration

Use Flat Field calibration to normalize images to an area of known “flat” reflectance. 
This is particularly effective for reducing hyperspectral data to relative reflectance. 
The method requires that you select a Region Of Interest (ROI) prior to execution. 
The average spectrum from the ROI is used as the reference spectrum, which is then 
divided into the spectrum at each pixel of the image.

1. Define an ROI over a spectrally flat area (see “Drawing ROIs” on page 291).

2. Select Basic Tools → Preprocessing → Calibration Utilities → Flat Field.

3. When the Flat Field Calibration Input File dialog appears, select the input file 
and perform any subsetting.

4. Click OK.

5. When the Flat Field Calibration Parameters dialog appears, select the average 
spectrum to use for the flat field calibration by clicking on the desired ROI 
name in the column labeled Select Calibration from Regions. The selected 
ROI name appears at the bottom of the window in the text box labeled Selected 
Item.

6. Choose File or Memory output.

7. Click OK to start the calibration.
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IAR Reflectance Calibration

Use IAR Reflectance calibration (Internal Average Relative Reflectance) to 
normalize images to a scene average spectrum. This is particularly effective for 
reducing hyperspectral data to relative reflectance in an area where no ground 
measurements exist and little is known about the scene. It works best for arid areas 
with no vegetation. An average spectrum is calculated from the entire scene and is 
used as the reference spectrum, which is then divided into the spectrum at each pixel 
of the image.

1. Select Basic Tools → Preprocessing → Calibration Utilities → IAR 
Reflectance.

2. When the Calibration Input File dialog appears, select the input file and 
perform any subsetting. 

3. Click OK. 

4. When the IARR Calibration Parameters dialog appears, select output to File or 
Memory.

5. Click OK.

If a statistics file doesn’t exist, a processing status window appears while the statistics 
are calculated and another status window appears while the calibration is performed. 
The calibrated data are added to the Available Bands list when the calibration is 
complete.
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Empirical Line Calibration

Use Empirical Line calibration to force spectral data to match selected field 
reflectance spectra. A linear regression is used for each band to equate DN and 
reflectance. This is equivalent to removing the solar irradiance and the atmospheric 
path radiance. The following equation shows how the empirical line gain and offset 
values are calculated.

Reflectance (field spectrum) = gain x radiance (input data) + offset

ENVI’s empirical line calibration requires at least one field, laboratory, or other 
reference spectrum; these can come from spectral profiles or plots, spectral libraries, 
ROIs, statistics or from ASCII files. Input spectra will automatically be resampled to 
match the selected data wavelengths. If more than one spectrum is used, then the 
regression for each band will be calculated by fitting the regression line through all of 
the spectra. If only one spectrum is used, then the regression line will be assumed to 
pass through the origin (zero reflectance equals zero DN). The calibration can also be 
performed on a data set using existing factors.

Computing Factors and Calibrating

Typically, you should choose a dark and a bright region in the image for use in the 
empirical line calibration (providing that reference spectra are available for these 
regions). This provides a more accurate linear regression. Using as many paired 
data/field spectra as you can will also improve the calibration. At least one spectral 
pair is necessary. 

Note
To use spectra from ROIs, define the ROIs prior to running this function.

1. Select Basic Tools → Preprocessing → Calibration Utilities → Empirical 
Line → Compute Factors and Calibrate.

2. When the Empirical Line Input File dialog appears, select the input file and 
perform any subsetting.
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3. Click OK. The Empirical Line Spectra dialog appears.

4. Collect image spectra and reference spectra, and pair spectra using the 
procedures described in the following sections.

Collecting Data (Image) Spectra

Use the Data Spectra Collection dialog to collect the image spectra (un-calibrated 
spectra), which can come from a plot or profile, a spectral library, ROI, or ASCII 
spectrum. Use the Import menu and other interactive options to import and collect 
spectra.

1. In the Empirical Line Spectra dialog, click the Data Spectra Import Spectra 
button.

2. Collect spectra using the Import menu as described in “Importing Endmember 
Spectra” on page 583 or using the black draw widget at the top of the dialog as 
described in “By Dragging-and-Dropping Spectra” on page 582.

Figure 5-20: Empirical Line Spectra Dialog
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3. After the data spectra have been selected, click Apply. The spectra names are 
entered into the Empirical Line Spectra dialog.

4. Click Cancel to close the Data Spectra Collection dialog.

Collecting Field Spectra

After importing Data (image) spectra into the Empirical Line Spectra dialog, import 
the corresponding Field (reference) spectra.

1. In the Empirical Line Spectra dialog, click on the Field Spectra Import 
Spectra button.

2. Collect spectra using the Import menu as described in “Importing Endmember 
Spectra” on page 583 or using the black draw widget at the top of the dialog as 
described in “By Dragging-and-Dropping Spectra” on page 582.

3. Click Apply to enter the spectra names.

4. Click Cancel to close the Field Spectra Collection dialog.

Pairing Spectra

After importing Data and Field (reference) spectra into the Empirical Line Spectra 
dialog, use the following procedure to pair the Data and Field (reference) spectra for 
use in the regression.

1. In the Empirical Line Spectra dialog, click on the data spectrum name in the 
top list to select it. 

2. In the bottom list, click on the corresponding field spectrum name.

3. Click Enter Pair to associate the two spectra. The paired spectra are listed in 
the Selected Pairs text box.

4. Repeat the selection process for as many data and field spectra pairs as desired. 

5. Click OK.

The Empirical Line Calibration Parameters dialog appears.
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Completing the Calibration

1. After collecting and pairing spectra, choose File or Memory output in the 
Empirical Line Calibration Parameters dialog.

Note
To save the correction coefficients in an ASCII file, enter a second file name 
in the Output Calibration Filename text box.

The default extension for correction coefficients files is .cff.

2. Click OK to start the calibration. 

A processing status window appears while the calibration is performed. When the 
calibration is completed, the calibration factors are plotted in a standard ENVI plot 
window and the calibrated image data are added to the Available Bands list.

Calibrating Using Existing Factors

Use Calibrate Using Existing Factors to run Empirical Line Calibration using 
output correction factors that were saved during another calibration session.

1. Select Basic Tools → Preprocessing → Calibration Utilities → Empirical 
Line → Calibrate Using Existing Factors.

2. Select the input file and any spatial and spectral subsets using the standard 
ENVI file selection procedures. 

3. Click OK.

4. When the Enter Calibration Factors Filename dialog appears, choose a 
calibration factors file (.cff) created during a previous Empirical Line 
Calibration session. 

5. Click OK.

6. When the Empirical Line Calibration Parameters dialog appears, choose File 
or Memory output. 

7. Click OK to begin the calibration.
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Thermal Atmospheric Correction

Use Thermal Atm Correction to approximate and remove the atmospheric 
contributions to the thermal infrared data. For best results, perform this correction 
before converting your data to emissivity. The atmospheric correction algorithm used 
in ENVI is similar to the In-Scene Atmospheric Compensation algorithm, ISAC. For 
more detailed instructions, see “Thermal IR Utilities” on page 568.

TIMS Radiance Calibration

Use TIMS Radiance to calibrate raw data from the NASA Thermal Infrared 
Multispectral Scanner (TIMS) to radiance in units of W/m2/µm/sr. For detailed 
instructions, see “TIMS Utilities” on page 565.

Calculating Emissivity

Use Calculate Emissivity to use one of three techniques in ENVI to separate the 
emissivity and temperature information in radiance data measured with thermal 
infrared sensors. Both the Reference Channel and Emissivity Normalization 
techniques assume a fixed emissivity value and produce emissivity and temperature 
outputs. The Alpha Residuals technique does not provide temperature information.

Reference Channel Emissivity Calculation

Use Reference Channel to calculate emissivity and temperature values from thermal 
infrared radiance data. For detailed instructions, see “Using Reference Channel 
Emissivity” on page 572.

Emissivity Normalization

Use Emissivity Normalization to calculate emissivity and temperature values from 
thermal infrared radiance data. For detailed instructions, see “Using Emissivity 
Normalization” on page 573.

Alpha Residuals

Use Alpha Residuals to produce alpha residual spectra that approximate the shape of 
emissivity spectra from thermal infrared radiance data. For detailed instructions, see 
“Using Alpha Residuals” on page 574.
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General Purpose Utilities

Use General Purpose Utilities to replace bad lines with averages, perform dark 
subtractions, and to destripe data.

Replacing Bad Lines

Use Replace Bad Lines to replace bad data lines in image data. You must identify 
the position of the lines to replace before running the function by using the ENVI 
cursor position function (see “Viewing Cursor Location and Value” on page 440). 

Note
To interactively fix bad lines, see “Using the Spatial Pixel Editor” on page 418.

1. Select Basic Tools → Preprocessing → General Purpose Utilities → 
Replace Bad Lines. The Bad Lines Input File dialog appears.

2. Select an input file and perform any subsetting.

3. Click OK. The Bad Lines Parameters dialog appears.

Figure 5-21: Bad Lines Parameters Dialog
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4. In the Enter Bad Line text box, specify which bad lines to replace and press 
the Return or Enter key.

5. The line appears in the Selected Lines list. 

• To remove that line from the list, click on the line.

• To save the line coordinates to a file, click Save.

• To restore the coordinates from a previously saved file, click Restore.

• To clear the list of lines to be replaced, click Clear.

6. In the Half Width to Average text box, enter the number of adjacent lines to 
be used as an average for calculation of the replacement line.

Note
The value is symmetrical around the line to be replaced. For example, the 
value 2 means that two lines on either side of the selected line will be 
averaged to calculate the replacement. 

7. Click OK.

8. When the Bad Lines Output dialog appears, select output to File or Memory.

9. Click OK.

Using Dark Subtraction

Use Dark Subtract to apply atmospheric scattering corrections to the image data. 
The digital number to subtract from each band can be either the band minimum, an 
average based upon a user defined region of interest, or a specific value. 

1. Select Basic Tools → Preprocessing → General Purpose Utilities → Dark 
Subtract.

2. When the Dark Subtract Input File dialog appears, select an input file and 
perform any subsetting.

3. Click OK. The Dark Subtraction Values dialog appears.

4. Select a Subtraction method as described in the following sections.

5. In the Dark Subtraction Values dialog, click OK.

6. When the Dark Subtract Parameters dialog appears, select output to File or 
Memory.
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7. Click OK to start the operation.

Selecting Band Minimum Subtraction

To automatically use the minimum DN value of each spectral band for the dark 
subtraction:

1. In the Dark Subtraction Values dialog, select the Band Minimum toggle 
button.

2. Click OK.

Selecting Region of Interest Subtraction

To use the average of an ROI in each spectral band as the value for dark subtraction 
(ROIs must first be defined — see “Defining Regions of Interest” on page 289):

1. In the Dark Subtraction Values dialog, select the Region of Interest toggle 
button.

2. From the list of available regions, select an ROI and click OK.

Figure 5-22: Dark Subtraction Values Dialog
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Selecting User Value Subtraction

To enter a user-defined value to subtract from each band:

1. In the Dark Subtraction Values dialog, select the User Value toggle button. A 
list of the bands and a default value of 0.0000 appear under the Current 
Subtraction Values label. 

2. Click on one of the band names.

3. In the Edit Selected Item text box, enter the desired subtraction value. Press 
the Return or Enter key.

4. Edit the other band values as desired.

5. Click OK.

Applying Gain and Offset

Use Apply Gain and Offset to apply a simple gain and offset correction to a set of 
bands. ENVI multiplies the selected bands by an input gain value and adds an offset 
value that you define.

1. Select Basic Tools → Preprocessing → General Purpose Utilities → Apply 
Gain and Offset.

2. Select an input file and any spatial and/or spectral subsetting. The Gain and 
Offset Values dialog appears.

3. In the Gain Values list, click on a band name.

4. In the Edit Selected Item text box, edit the gain value of the item.

5. In the Offset Values list, click on a band name.

6. In the Edit Selected Item text box, edit the offset value of the item.

7. Repeat this selection and assignment of values for each band to be processed.

• To reset all of the bands to their original values, click Reset.

• To return to the main menu, click Cancel.

8. Click on the Output Data Type menu and select a data type for the output.

9. Select output to File or Memory.

10. Click OK.

A status window displays the status of the operation. The resulting bands are listed in 
the Available Bands List.
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Destriping Data

Use Destripe data to remove periodic scan line striping in image data. This type of 
striping is often seen in Landsat MSS data (every 6th line) and less commonly, in 
Landsat TM data (every 16th line). When destriping the data, ENVI calculates the 
mean of every nth line and normalizes each line to its respective mean. In order for 
destriping to function properly, the data must be in the acquired format (horizontal 
strips) and cannot be rotated or georeferenced.

1. Select Basic Tools → Preprocessing → General Purpose Utilities → 
Destripe.

2. When the Destriping Data Input File appears, select the input file and perform 
any subsetting. 

3. Click OK.

4. When the Destriping Parameters dialog appears, enter the number of detectors 
in the box labeled Number of Detectors. The number of detectors is the 
periodicity of the striping (e.g., for Landsat MSS, the value would be 6).

Note
If the file type has been set in the header, the default is set automatically. 

5. Select either File or Memory output. 

Note
To return to the main menu at any time, click Cancel.

6. Click OK to start the operation.
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Applying Cross-Track Illumination Corrections

Use Cross-Track Illumination Correction to remove variation in the cross-track 
illumination of an image. Cross track illumination variations may be due to 
vignetting effects, instrument scanning, or other non-uniform illumination effects. 
Along-track mean values are calculated and you can plot them to show the mean 
variation in the cross-track direction. A polynomial function, with the order defined 
by you, is fit to the means and used to remove the variation.

1. Select Basic Tools → Preprocessing → General Purpose Utilities → 
Cross-Track Illumination Correction.

2. When the Cross Track Illumination Input File dialog appears, select the input 
file and perform any spatial or spectral subsetting or masking. The Cross Track 
Illumination Correction Parameters dialog appears.

3. Select the cross track direction by clicking in the check box next to either 
Samples or Lines.

4. Select either an Additive or Multiplicative correction method. The Additive 
method will subtract the fitted polynomial from the data and the Multiplicative 
method will divide the data by the fitted polynomial.

5. Enter the desired polynomial order and click Plot Polynomial. A plot of the 
mean data values are displayed in red with the selected polynomial fit overlaid 
in white. It is best to use a low order polynomial so as not to remove the local 
variation in the data.

Note
You can change the polynomial order and plot it again.

6. Select output to Memory or File.

7. Click OK to start the processing.

Note
The Cross-Track Illumination Correction plot pull-down menus will not be 
active until you close the Cross Track Illumination Correction Parameters dialog.
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Converting Complex Data

Use Convert Complex Data to output selected images calculated from complex 
data. Image types included are: Real (real portion of number), Imaginary (imaginary 
portion), Power (log10 of magnitude), Magnitude (square root of sum of the squares 
of the real and imaginary), and Phase (arc tangent of imaginary divided by real).

1. Select Basic Tools → Preprocessing → General Purpose Utilities → 
Convert Complex Data.

2. Select an input data file and click OK.

3. When the Convert Complex Parameters dialog appears, select the output band 
functions by clicking in the check boxes next to the function names.

4. Select File or Memory output.

5. Click OK.

The calculated images appear in the Available Bands List.

Converting VAX to IEEE Data

Use the VAX to IEEE Converter to convert VAX floating point images to IEEE 
standard floating point. Most computers support the IEEE standard representation of 
floating point numbers, but DEC VAX computers still use their own internal floating 
point representation and some image data still are distributed in this format. 

1. Select Basic Tools → Preprocessing → General Purpose Utilities → 
Convert VAX to IEEE.

2. When the VAX Floating Point Input File dialog appears, choose the file to be 
converted from the list of available files.

3. Click OK.

4. When the VAX to IEEE Parameters dialog appears, enter the VAX header size 
(bytes).

5. Select one of the following options:

• To copy the header information into the output file as an embedded ENVI 
header, click Yes next to Copy Header.

• To copy only the data, click No. 

6. Enter an output file name.

7. Click OK to convert the file.
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Data-Specific Utilities

Use Data-Specific Utilities to apply data-specific functions that work specifically on 
your data type.

Displaying HDF Global Attributes

Use View HDF Global Attributes to create a text report of any global attribute 
values that are present in an HDF scientific data (SD) file.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → View HDF 
Global Attributes.

2. When the file selection dialog appears, select the desired HDF SD file.

Any global attributes contained in the HDF file appear on-screen in a text report.

Saving Reports to ASCII Files

1. In the Report window, select File → Save Text to ASCII.

2. Enter or choose an output filename and click OK.

Note
To exit the report without saving the information to a file, select File → Cancel.

ASTER Radiance Data

Use the ASTER 1A/1B radiometric calibration tools to extract and apply calibration 
information from HDF attributes. For ASTER level 1B data, the byte scaled radiance 
data is converted into floating point radiance units. For ASTER level 1A data, a 
complete calibration to radiance is performed. 

1. Select either Basic Tools → Preprocessing → Calibration Utilities → 
ASTER Radiance or, 

Basic Tools → Preprocessing → Data-Specific Utilities → ASTER → 
ASTER Radiance. 
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AVHRR Utilities

Use AVHRR Utilities to read and display information from the AVHRR header, 
calibrate AVHRR data to percent reflectance and brightness temperature, compute 
sea surface temperatures, and to use information in the data for georeferencing. The 
AVHRR utilities support NOAA-12 through 17.

For details, see the following references:

Di, L. and D. C. Rundquist, 1994. A one-step algorithm for correction and calibration 
of AVHRR Level 1b data, Photogrammetric Engineering & Remote Sensing, Vol. 60, 
No. 2, pp. 165-171.

Note
The calibration and sea surface temperatures should be calculated before 
georeferencing.

Displaying AVHRR Header Information

To display the header information from the AVHRR header:

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → 
AVHRR → Display Header Information.

2. Select the desired input AVHRR data file and click OK.

The AVHRR File Information dialog appears. The header information is displayed.

Saving Header Info to ASCII Files

To save the header information to an ASCII file, select from the AVHRR File 
Information dialog, File → Save Text to ASCII, and enter an output filename.

Calibrating AVHRR Data

Use Calibrate Data to calibrate AVHRR data from the NOAA 12 though 17 
satellites. Bands 1 and 2 are calibrated to percent reflectance and bands 3, 4, and 5 are 
calibrated to brightness temperature, in degrees Kelvin. 

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → 
AVHRR → Calibrate Data.

2. Select the desired input AVHRR data file and perform any spatial and spectral 
subsetting.
ENVI User’s Guide Data-Specific Utilities



560 Chapter 5: Basic Tools
Note
AVHRR data that has been scaled to 8-bit depth cannot be used to compute 
SSTs because NOAA does not modify the calibration coefficients stored in 
the file’s 1b header.

3. When the AVHRR Calibrate Parameters dialog appears, select the satellite 
number from the Satellite button menu.

4. Select either File or Memory output.

5. Click OK to start the calibration.

Output bands 1 and 2 are in % reflectance, and output bands 3, 4, and 5 are in 
brightness temperature, in degrees Kelvin.

Building AVHRR Geometry Files

Use AVHRR Build Geometry File to calculate the geometry values for each pixel. 
You may select which values to calculate: latitude, longitude, solar zenith, and/or 
sensor zenith angles.

For detailed instructions, see “Building AVHRR Geometry Files” on page 917.

Georeferencing AVHRR Data

The AVHRR data, calibration results, and sea surface temperature image can be 
georeferenced using information from the AVHRR data themselves. Each line of data 
has 51 latitude and longitude values that can be used in the georeferencing.

For detailed instructions, see “Georeferencing AVHRR Data” on page 918.

Computing Sea Surface Temperature

A sea surface temperature image, in degrees Celsius, is computed using AVHRR 
bands 3, 4, and 5. Currently, ENVI does not use a cloud or land mask in the sea 
surface temperature calculation. Four algorithms are available, one for daytime data 
and three for nighttime data: Day MCSST Split; Night MCSST Split; Night MCSST 
Dual; and Night MCSST Triple. These algorithms differ in which bands are used to 
correct for the atmosphere, Split-window uses bands 4 and 5, Dual-window uses 
bands 3 and 4, and Triple-window uses bands 3, 4 and 5. The coefficients used for the 
NOAA 12 and 14 satellites are based on March 1995 global drifting buoy and tropical 
Pacific fixed buoy matchups. The coefficients used for the NOAA 15, 16, and 17 
satellites are based on values provided in the NOAA KLM User’s Guide (see 
Appendix D in http://www2.ncdc.noaa.gov/docs/klm for more information).
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1. Select Basic Tools → Preprocessing → Data-Specific Utilities → 
AVHRR → Compute Sea Surface Temperature.

2. Select the desired input AVHRR data file and perform any spatial subsetting. 
The AVHRR Sea Surface Temperature Parameters dialog appears.

Note
The input file must contain AVHRR bands 3, 4, and 5.

3. From the Satellite button menu, select the satellite name.

4. From the SST Algorithm pull-down menu, select the desired algorithm.

5. Select either File or Memory output.

6. Click OK.

The output sea surface temperature image is in degrees Celsius.

ENVISAT Utilities

Use Georeference AATSR, Georeference ASAR, or Georeference MERIS to 
georeference your ENVISAT AATSR, ASAR, or MERIS data with the geolocation 
information included in the ENVISAT file. ENVISAT imagery contains geolocation 
tie points that correspond to specific pixels in the image. These tie points can be used 
to automatically georeference the ENVISAT data without building a geometry file. 
For detailed instructions, see “Georeference ENVISAT” on page 920.

IKONOS Utilities

Use Orthorectify IKONOS or Orthorectify IKONOS with Ground Control to 
orthorectify IKONOS data. For details, see “Orthorectification using RPCs” on 
page 881.
ENVI User’s Guide Data-Specific Utilities



562 Chapter 5: Basic Tools
Landsat MSS Utilities

Use Landsat MSS utilities to correct aspect ratios and to deskew Landsat 
Multispectral Scanner (MSS) data.

Deskewing Data

Landsat MSS image data processed prior to 1978 typically contains systematic 
distortions caused by earth rotation and scan skew. Use MSS Deskewing to remove 
the skew by offsetting groups of scan lines based on the relationship between the 
orbital characteristics and latitude-dependent earth rotation characteristics.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → Landsat 
MSS → Deskew.

2. When the Deskewing Input File dialog appears, select an input file and 
perform any spatial and spectral subsetting. 

3. Click OK.

4. When the Deskewing Parameters dialog appears, enter the latitude of the MSS 
scene center into the text boxes labeled Latitude Degrees, Latitude Minutes, 
and Latitude Seconds.

5. Select either File or Memory output. 

Note
To close the function at any time, click Cancel.

6. Click OK to start the function.

A status window appears with the output filename listed and the percent completed 
displayed. 

Correcting Aspect Ratio

Use MSS Aspect Ratio Correction to adjust the aspect ratio by applying nearest 
neighbor resampling to a regular grid. Landsat MSS image data typically contains 
geometric distortions caused by oversampling in the scan direction. The actual pixel 
sizes are approximately 79 x 79 meters, but the instrument samples at 57 meter 
intervals in the scan direction. Because of this oversampling, an adjustment of the 
aspect ratio by the factor 57/79=0.72 is required. 

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → Landsat 
MSS → Aspect.
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2. When the Aspect Correction Input File dialog appears, select the input file and 
perform any subsetting. 

3. Click OK. 

4. When the Aspect Correction Parameters dialog appears, select output to File or 
Memory.

5. Click OK to start the function.

No other interaction is required. The status window appears with the output filename 
listed and the percent completed displayed.

Landsat MSS Data Calibration

Use Landsat MSS Calibration to convert Landsat MSS digital numbers to radiance 
or exoatmospheric reflectance (reflectance above the atmosphere) using published 
post-launch gains and offsets. For detailed instructions, see “Landsat MSS 
Calibration” on page 534.

Landsat TM Utilities

Use Landsat TM Calibration to convert Landsat TM digital numbers to radiance or 
exoatmospheric reflectance (reflectance above the atmosphere) using published post-
launch gains and offsets. For detailed instructions, see “Landsat TM Calibration” on 
page 535.

MODIS 1B

Use Georeference Data to georeference your MODIS 1B data sets. ENVI 
extracts latitude and longitude values from the header information to 
georeference the data. For detailed instructions, see “Georeference MODIS 1B” 
on page 921.

OrbView-3 Utilities

Use Orthorectify OrbView-3 or Orthorectify OrbView-3 with Ground Control to 
orthorectify IKONOS data. For details, see “Orthorectification using RPCs” on 
page 881.
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QuickBird Utilities

Use the QuickBird Radiance utility to convert QuickBird relative radiance into 
absolute radiance in units of [ ]. For detailed instructions, see 
“QuickBird Radiance Calibration” on page 538.

Use the Orthorectify QuickBird or Orthorectify QuickBird with Ground Control 
to orthorectify QuickBird data. For details, see “Orthorectification using RPCs” on 
page 881.

SeaWiFS Utilities

Use SeaWiFS Utilities to calculate geometry information for and to georeference 
HDF and CEOS format SeaWiFS data. Geometry information includes latitude, 
longitude, sensor azimuth, sensor zenith, solar azimuth, solar zenith, and UTC time. 
The georeferencing function produces a full precision geocoding based on a complete 
geometry model of the earth and satellite orbits.

Build Geometry File

Use Build Geometry File to calculate the geometry for HDF and CEOS format 
SeaWiFS data. For detailed instructions see “Building SeaWiFS Geometry Files” on 
page 914.

Georeference SeaWiFS Data

Use Georeference Data to georeference your SeaWiFS data. For detailed 
instructions, see “Georeferencing SeaWiFS Data” on page 915.

Spot Utilities

Build Geometry File

Use Build Geometry File to build a SPOT geometry file to calculate the X and Y 
coordinates for each pixel. For detailed instructions, see “Building SPOT Geometry 
Files” on page 912.

Georeference SPOT Data

Use Georeference Data to georeference SPOT data based on header information. 
See “Georeferencing SPOT Data” on page 913.

µW( ) cm
2

nm str⋅ ⋅( )⁄
Data-Specific Utilities ENVI User’s Guide



Chapter 5: Basic Tools 565
Orthorectify SPOT Data

Use the Orthorectify SPOT or Orthorectify SPOT with Ground Control to 
orthorectify SPOT data. For details, see “Orthorectification using RPCs” on 
page 881.

TIMS Utilities

Thermal IR Atmospheric Correction

Use Thermal Atm Correction to approximate and remove the atmospheric 
contributions to thermal infrared data. TIMS data must be converted to radiance 
before performing the Thermal Atm Correction. ENVI provides a tool for converting 
TIMS data to radiance (see “Radiance Calibration” on page 567). For best results, 
perform this correction before converting your data to emissivity. The atmospheric 
correction algorithm used in ENVI is similar to the In-Scene Atmospheric 
Compensation algorithm, ISAC. This algorithm assumes that the atmosphere is 
uniform over the data scene and that there is an occurrence of a near-blackbody 
surface within the scene. The location of the blackbody surface is not required. A 
single layer approximation of the atmosphere is used and it is assumed that there is no 
reflected downwelling radiance.

The algorithm first determines the wavelength that most often exhibits the maximum 
brightness temperature. This wavelength is then used as the reference wavelength. 
Only spectra that have their brightest temperature at this wavelength are used to 
calculate the atmospheric compensation. At this point, for each wavelength, the 
reference blackbody radiance values are plotted against the measured radiances. A 
line is fitted to the highest points in these plotted data and the fit is weighted to assign 
more weight to regions with denser sampling. The compensation for this band is then 
applied as the slope and offset derived from the linear regression of these data with 
their computed blackbody radiances at the reference wavelength.

Upwelling atmospheric radiance and atmospheric transmission are approximated 
using the following method: first, the surface temperature of every pixel is estimated 
from the data and used to estimate the brightness temperature using the Planck 
function and assuming an emissivity of 1; next, a line is fitted, using one of two 
methods, to a scatterplot of radiance versus brightness temperature. The atmospheric 
upwelling and transmission are then derived from the slope and offset of this line.

Johnson, B. R. and S. J. Young, “In-Scene Atmospheric Compensation: Application 
to SEBASS Data Collected at the ARM Site”, Technical Report, Space and 
Environment Technology Center, The Aerospace Corporation, May 1998.
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Hernandez-Baquero, E., “Characterization of the Earths Surface and Atmosphere 
from Multispectral and Hyperspectral Thermal Imagery”, Ph.D. Dissertation, 
Rochester Institute of Technology, Chester F. Carlsom Center for Imaging Science, 
Rochester, NY, 2000.

1. Select one of the following paths:

• Basic Tools → Preprocessing → Calibration Utilities → 
Thermal Atm Correction, or 

• Basic Tools → Preprocessing → Data-Specific Utilities → Thermal 
IR → Thermal Atm Correction, or 

• Basic Tools → Preprocessing → Data-Specific Utilities → TIMS → 
Thermal Atm Correction.

2. Select the input file and perform any spatial or spectral subsetting, as desired.

The Thermal Atm Correction Parameters dialog appears.

3. Enter the Data Scale Factor needed to scale your data to units of W/m2/µm/sr.

4. Select the Wavelength Units from the pull-down menu button.

5. Use the arrow toggle button to select either All or Max Hit to determine which 
pixels are used in the surface temperature estimation regression.

Selecting All will estimate the surface temperature for each pixel by using the 
maximum value of the brightness temperatures found throughout the input 
wavelengths. Selecting Max Hit will estimate the surface temperature for only 
those pixels that have their maximum brightness temperatures at a particular 
wavelength. The wavelength used is the wavelength that has the largest number 
of pixels with a maximum brightness temperature value.

6. Use the arrow toggle button to select either Top of Bins or Normalized 
Regression for the scatter plot fitting technique.

Selecting Top of Bins will fit a line to the top of the scatter plot of radiance vs. 
brightness temperature. The top of the scatter plot corresponds to those pixels 
whose emissivity is closest to 1. This Top of Bins fit is achieved by doing a 
standard least squares regression on the top 5% of the data in the scatter plot. 

Note
This technique is susceptible to sensor noise which may occur at the top of 
the scatter plot.
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Selecting Normalized Regression will first fit a line to the scatter plot of 
radiance vs. brightness temperature by doing a standard least squares 
regression. The residuals of this fit are then compared to a normal probability 
plot. Another regression is done on the residuals in the normal plot. Points that 
are 3 times the noise equivalent sensor response (NESR) away from the 
regression line are deemed outliers and are removed. A final regression is done 
on the scatter plot using this reduced set of pixels. 

Note
This method uses all the points in the scatter plot that are not outliers and 
does not fit to only the top of the scatter plot where the emissivity values are 
closest to 1.

If you choose Normalized Regression, enter the Noise Equivalent Sensor 
Response in the text box.

7. Enter a gain and offset output filename, if desired.

8. Use the arrow toggle button to select whether to plot the resulting atmospheric 
transmission and upwelling spectra.

9. Enter an output filename and click OK.

The results will appear in the Available Bands List.

See the following references for more information.

Johnson, B. R. and S. J. Young, “In-Scene Atmospheric Compensation: Application 
to SEBASS Data Collected at the ARM Site”, Technical Report, Space and 
Environment Technology Center, The Aerospace Corporation, May 1998.

Hernandez-Baquero, E., “Characterization of the Earths Surface and Atmosphere 
from Multispectral and Hyperspectral Thermal Imagery”, Ph.D. Dissertation, 
Rochester Institute of Technology, Chester F. Carlsom Center for Imaging Science, 
Rochester, NY, 2000.

Radiance Calibration

Use Radiance Calibration to calibrate raw data from the NASA Thermal Infrared 
Multispectral Scanner (TIMS) to radiance in units of W/m2/µm/sr. Data from on-
board black bodies, and two internal reference sources, are stored within the first 60 
bytes of each image line. The reference data can be smoothed. Gain and offset values 
are calculated for each TIMS spectral band using Plank’s radiation law and the 
reference data and are used to calibrate the raw DN values to radiance. See the 
following reference for more information:
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Palluconi, F. D. and Meeks, G. R., 1985. “Thermal Infrared Multispectral Scanner 
(TIMS): An Investigator’s Guide to TIMS Data,” JPL Publication 85-32, p. 14.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → TIMS → 
Radiance Calibration, or

 Basic Tools → Preprocessing → Calibration Utilities → TIMS Radiance.

2. Select the desired TIMS input file (must contain the 60 bytes per line of 
reference information). The TIMS Calibration Parameters dialog appears.

3. Enter the number of lines of reference data to be smoothed.

4. Enter an output filename and click OK.

The resulting bands appear in the Available Bands List and contain radiance values in 
W/m2/µm/sr.

Thermal IR Utilities

Use Thermal IR utilities to apply an atmospheric correction, and to convert the data 
set from radiance to emissivity and temperature using one of three methods: 
Reference Channel Emissivity, Emissivity Normalization, and Alpha Residuals. 
Thermal image data must be converted to radiance before performing the atmospheric 
correction. Perform this correction before converting your data to emissivity for best 
results. 

Atmospheric Correction for Thermal IR Data

Use Thermal Atm Correction to approximate and remove the atmospheric 
contributions from thermal infrared radiance data. Thermal image data must be 
converted to radiance before performing the atmospheric correction. ASTER and 
TIMS data should be converted to radiance using ENVI’s ASTER Radiance tool or 
TIMS Radiance tool before performing the atmospheric correction. Both the ASTER 
Radiance and TIMS Radiance tools apply the correct band coefficients to convert to 
radiance in the appropriate units. No data scale factor is then required during the 
atmospheric correction. Perform the correction before converting your data to 
emissivity for the best results. 

Note
ENVI does not check to make sure the images are thermal infrared data. Be sure 
that your data wavelengths measure between 8 and 14 µm before applying this 
correction.
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The atmospheric correction algorithm used in ENVI is similar to the In-Scene 
Atmospheric Compensation algorithm, ISAC (see references at the end of this 
section). This algorithm assumes that the atmosphere is uniform over the data scene 
and that a near-blackbody surface exists within the scene. The location of the 
blackbody surface is not required for this correction. A single layer approximation of 
the atmosphere is used. No reflected downwelling radiance is also assumed. 

The algorithm first determines the wavelength that most often exhibits the maximum 
brightness temperature. This wavelength is then used as the reference wavelength. 
Only spectra that have their brightest temperature at this wavelength are used to 
calculate the atmospheric compensation. At this point, for each wavelength, the 
reference blackbody radiance values are plotted against the measured radiances. A 
line is fitted to the highest points in these plotted data and the fit is weighted to assign 
more weight to regions with denser sampling. The compensation for this band is then 
applied as the slope and offset derived from the linear regression of these data with 
their computed blackbody radiances at the reference wavelength.

Upwelling atmospheric radiance and atmospheric transmission are approximated 
using the following method. First, the surface temperature of every pixel is estimated 
from the data and used to approximate the brightness temperature using the Planck 
function and assuming an emissivity of 1. Next, a line is fitted (using one of two 
methods) to a scatter plot of radiance vs. brightness temperature. The atmospheric 
upwelling and transmission are then derived from the slope and offset of this line. 

1. Select one of the following paths:

• Basic Tools → Preprocessing → Calibration Utilities → 
Thermal Atm Correction, or 

• Basic Tools → Preprocessing → Data-Specific Utilities → Thermal 
IR → Thermal Atm Correction, or 

• Basic Tools → Preprocessing → Data-Specific Utilities → TIMS → 
Thermal Atm Correction.

2. Select the input file and perform any spatial or spectral subsetting, as desired.

The Thermal Atm Correction Parameters dialog appears.

3. Enter the Data Scale Factor needed to scale your data to units of W/m2/µm/sr.

Note
The image output from this atmospheric correction uses the same units as the 
input image. For example, if the results of the correction are used to calculate 
emissivity and temperature, then the same scale factor must be specified.
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4. Select the Wavelength Units from the pull-down menu button.

5. Use the arrow toggle button to select either All or Max Hit to determine which 
pixels are used in the surface temperature estimation regression.

Selecting All will estimate the surface temperature for each pixel by using the 
maximum value of the brightness temperatures found throughout the input 
wavelengths. Selecting Max Hit will estimate the surface temperature for only 
those pixels that have their maximum brightness temperatures at a particular 
wavelength. The wavelength used is the wavelength that has the largest number 
of pixels with a maximum brightness temperature value.

6. Use the arrow toggle button to select either Top of Bins or Normalized 
Regression for the scatter plot fitting technique.

Selecting Top of Bins will fit a line to the top of the scatter plot of radiance vs. 
brightness temperature. The top of the scatter plot corresponds to those pixels 
whose emissivity is closest to 1. This Top of Bins fit is achieved by doing a 
standard least squares regression on the top 5% of the data in the scatter plot. 

Note
This technique is susceptible to sensor noise which may occur at the top of 
the scatter plot.

Selecting Normalized Regression will first fit a line to the scatter plot of 
radiance vs. brightness temperature by doing a standard least squares 
regression. The residuals of this fit are then compared to a normal probability 
plot. Another regression is done on the residuals in the normal plot. Points that 
are 3 times the noise equivalent sensor response (NESR) away from the 
regression line are deemed outliers and are removed. A final regression is done 
on the scatter plot using this reduced set of pixels. 

Note
This method uses all the points in the scatter plot that are not outliers and 
does not fit to only the top of the scatter plot where the emissivity values are 
closest to 1.

If you choose Normalized Regression, enter the Noise Equivalent Sensor 
Response in the text box.

7. Enter a gain and offset output filename, if desired.
Data-Specific Utilities ENVI User’s Guide



Chapter 5: Basic Tools 571
8. Use the arrow toggle button to select whether to plot the resulting atmospheric 
transmission and upwelling spectra.

9. Enter an output filename and click OK.

The results will appear in the Available Bands List.

See the following references for more information.

Johnson, B. R. and S. J. Young, “In-Scene Atmospheric Compensation: Application 
to SEBASS Data Collected at the ARM Site”, Technical Report, Space and 
Environment Technology Center, The Aerospace Corporation, May 1998.

Hernandez-Baquero, E., “Characterization of the Earths Surface and Atmosphere 
from Multispectral and Hyperspectral Thermal Imagery”, Ph.D. Dissertation, 
Rochester Institute of Technology, Chester F. Carlsom Center for Imaging Science, 
Rochester, NY, 2000.

Converting to Emissivity and Temperature

The radiation emitted from a surface in the thermal infrared wavelengths is a function 
of both the surface temperature and emissivity. The emissivity relates to the 
composition of the surface and is often used for surface constituent mapping. 

ENVI has three techniques that are used to separate the emissivity and temperature 
information in radiance data measured with thermal infrared sensors. Both the 
Reference Channel Emissivity and Emissivity Normalization techniques assume a 
fixed emissivity value and produce emissivity and temperature outputs. The Alpha 
Residuals technique does not provide temperature information.

See the following references for more information:

Hook, S. J., A. R. Gabell, A. A. Green, and P. S. Kealy, 1992. A comparison of 
techniques for extracting emissivity information from thermal infrared data for 
geologic studies. Remote Sensing of Environment, Vol. 42, pp. 123-135.

Kealy, P. S. and S. J. Hook, 1993., Separating temperature and emissivity in thermal 
infrared multispectral scanner data: Implications for recovering land surface 
temperatures. IEEE Transactions on Geoscience and Remote Sensing, Vol. 31, No. 6, 
pp.1155-1164.
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Using Reference Channel Emissivity

Use Reference Channel Emissivity to calculate emissivity and temperature values 
from thermal infrared radiance data. The reference channel emissivity technique 
assumes that all the pixels in one channel (band) of the thermal infrared data have a 
constant emissivity. Using this constant emissivity, a temperature image is calculated 
and those temperatures are used to calculate the emissivity values in all the other 
bands using the Planck function. You can select the band to keep constant and enter 
the desired emissivity value for that band. See the previous references for more 
information.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → Thermal 
IR → Reference Channel Emissivity, or

Basic Tools → Preprocessing → Calibration Utilities → Calculate 
Emissivity → Reference Channel.

2. Select the input radiance data file and perform any subsetting. The Calculate 
Emissivity parameters dialog appears.

3. Enter a data scale factor, if needed, to scale the radiance values into the units of 
W/m2/µm/sr (for example, if your data is in microflicks (µW/cm2/µm/sr) enter 
a scale factor of .01).

4. Enter a wavelength scale factor, if needed, to scale the wavelengths that are 
read from the header into units of µm.

5. From the Emissivity Band pull-down list, select which band to set to a 
constant emissivity value.

6. In the Assumed Emissivity Value text box, enter the desired emissivity value 
for the constant band.

7. Click the Output Temperature Image? arrow toggle button to designate 
whether or not to output a temperature image. Enter an output filename if 
needed.

8. Enter an output filename for the emissivity data and click OK.

The temperature image (single band) and emissivity data cube (same number of 
bands as input radiance data) appear in the Available Bands List.
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Using Emissivity Normalization

Use Emissivity Normalization to calculate emissivity and temperature values from 
thermal infrared radiance data. The emissivity normalization technique calculates the 
temperature for every pixel and band in the data using a fixed emissivity value. The 
highest temperature for each pixel is used to calculate the emissivity values using the 
Planck function. You can enter the desired fixed emissivity value. See the references 
in the introduction to “Thermal IR Utilities” on page 568 for more information.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → Thermal 
IR → Emissivity Normalization or Basic Tools → Preprocessing → 
Calibration Utilities → Calculate Emissivity → Emissivity Normalization.

2. Select the input radiance data file and perform any subsetting.

The Calculate Emissivity parameters dialog appears.

3. Enter a data scale factor, if needed, to scale the radiance values into the units of 
W/m2/µm/sr (for example, if your data is in microflicks (µW/cm2/µm/sr) enter 
a scale factor of .01).

4. Enter a wavelength scale factor, if needed, to scale the wavelengths (read from 
the header) into units of µm. 

5. In the Assumed Emissivity Value text box, enter the desired fixed emissivity 
value to be used to calculate the temperatures.

6. Click the Output Temperature Image? arrow toggle button to designate 
whether or not to output a temperature image. Enter an output filename if 
needed. 

7. Enter an output filename for the emissivity data and click OK.

The temperature image (single band) and emissivity data cube (same number of 
bands as input radiance data) appear in the Available Bands List.
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Using Alpha Residuals

Use Alpha Residuals to produce alpha residual spectra that approximate the shape of 
emissivity spectra from thermal infrared radiance data. Wien’s approximation of the 
Planck function is used so the equation can be linearized with logarithms. The 
temperature and emissivity terms are separated and means are used to subtract the 
temperature term out. 

The alpha residual spectra are a function of emissivity only and have a similar shape 
as emissivity spectra but have a zero mean. Therefore emissivity spectra must be 
scaled for direct comparison to alpha residual spectra. Emissivity spectra can be 
calculated from alpha residual spectra using empirical data as described in the Kealy, 
1993 reference mentioned in the introduction to “Thermal IR Utilities” on page 568.

1. Select Basic Tools → Preprocessing → Data-Specific Utilities → Thermal 
IR → Alpha Residuals, or

 Basic Tools → Preprocessing → Calibration Utilities → Calculate 
Emissivity → Alpha Residuals.

2. Select the input radiance data file and perform any subsetting. The Calculate 
Emissivity parameters dialog appears.

3. Enter a data scale factor, if needed, to scale the radiance values into the units of 
W/m2/µm/sr (for example, if your data is in microflicks (µW/cm2/µm/sr) enter 
a scale factor of .01). 

4. Enter a wavelength scale factor, if needed, to scale the wavelengths (read from 
the header) into units of µm. 

5. Enter an output filename and click OK.

The alpha residual data cube (same number of bands as input radiance data) filename 
is listed in the Available Bands List.
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Classification
This chapter covers the following topics:
The Classification Menu  . . . . . . . . . . . . . .  576
Collecting Endmember Spectra . . . . . . . . .  577
Supervised Classification  . . . . . . . . . . . . .  594
Unsupervised Classification  . . . . . . . . . . .  611
Decision Tree Classifier  . . . . . . . . . . . . . .  617
Creating Class Images from ROIs . . . . . . .  627
Post Classification . . . . . . . . . . . . . . . . . . .  628
Changing Class Colors  . . . . . . . . . . . . . . .  628
Classifying from Rule Images . . . . . . . . . .  630
Calculating Class Statistics  . . . . . . . . . . . .  634

Calculating Confusion Matrices . . . . . . . .  636
Displaying ROC Curves . . . . . . . . . . . . . .  644
Majority/Minority Analysis  . . . . . . . . . . .  654
Clumping Classes . . . . . . . . . . . . . . . . . . .  655
Sieving Classes . . . . . . . . . . . . . . . . . . . . .  656
Combining Classes . . . . . . . . . . . . . . . . . .  657
Overlaying Classes . . . . . . . . . . . . . . . . . .  659
Calculating Buffer Zone Images  . . . . . . .  660
Creating Segmentation Images . . . . . . . . .  661
Exporting Classes To Vector Layers  . . . .  662
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The Classification Menu

Use the Classification menu to access ENVI’s classification functions. Functions 
include supervised and unsupervised classification, collecting endmembers, 
classifying previous rule images, calculating class statistics and confusion matrices, 
applying majority and minority analysis to classification images, clumping and 
sieving classes, combining classes, overlaying classes on grayscale images, 
calculating buffer zone images, calculating segmentation images, and exporting 
classes to vector layers.

Figure 6-1: Classification Menu
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Collecting Endmember Spectra

Use Endmember Collection to select endmember spectra from many sources for use 
in classification and advanced spectral analysis techniques. You can run all of the 
supervised classification techniques and many of the advanced spectral techniques 
from the Endmember Collection dialog. 

Note
You can run several classifications using the same endmembers or training classes 
as input by changing the algorithm technique.

1. Select Classification → Endmember Collection.

2. When the Classification Input File dialog appears, select the desired file, 
subset, and/or mask.

3. Click OK. The Endmember Collection dialog appears (see “The Endmember 
Collection Dialog” on page 578 for more information on this dialog).

4. Collect endmembers, select algorithm types, and manage endmembers using 
the procedures described in the following sections.

Figure 6-2: Endmember Collection Dialog
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The Endmember Collection Dialog

The Endmember Collection dialog contains the following sections:

• Input file information.

• A table to view and edit endmember properties. This table also allows you to 
collect and select endmembers.

• Buttons to view and maintain collected endmembers.

• Pull-down menus to import spectra from other sources, edit spectra names and 
colors, suppress backgrounds, select algorithms, and manage endmembers.

Input File Information

The following input file information is provided in the text at the top of the 
Endmember Collection dialog:

• File — The name of the input file and its selected spatial subset range. If the 
image is not spatially subset, the phrase Full Scene is displayed.

• Mask — The name of the mask associated with the input file.

• Wavelength —The wavelength range of the image data. The units of these 
wavelengths are derived from the header file of the input file. If the units 
cannot be derived from the header file, the phrase <unknown units> is 
displayed.

• Number and range of the bands in the spectral subset — The number of bands 
spectrally subsetted from the input file and the range of the subset. If the input 
file is not spectrally subsetted, the total number of bands in the input file and 
the entire range is displayed.

Endmember Spectra Table

The Endmember Collection dialog also contains the Endmember Spectra table. This 
table enables you to view and edit properties associated with any of the spectra listed 
in the table. The table contains the following columns:

• Row Number — This column contains the row number of each spectrum. You 
can select a specific spectrum by clicking on its row number, which highlights 
the entire row of that spectrum. You can also combine the Shift key with a 
click on a row number to select a range of spectra, or combine the Ctrl key 
with a click on a row number to select a group of spectra that are not adjacent 
in the table. The Select All button can be used to select all of the spectra in the 
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table. The Plot or Delete button can be used to plot or delete the selected 
spectra.

• Spectrum Name — This column contains the name of each spectrum. You can 
edit the name of a spectrum by clicking its cell in this column. You can also 
specify the spectrum names for all the spectra from an ASCII file by right-
clicking on the Spectrum Name column title and selecting the Import names 
from ASCII... option from the shortcut menu. This shortcut menu also 
contains a Reset names option to reset all the spectra to their original names. 
All of the options in this shortcut menu are also available in the Options pull-
down menu.

• Color — This column contains the color of each spectrum. You can use any of 
the following methods to change the color of a spectrum.

• Right-click in its cell to display the color shortcut menu.

• Left-click in its cell to enter a valid ENVI graphics color name. If a valid 
color is not provided, the color value is set to <none> by default.

• Left-click in its cell to enter an RGB triplet (such as 255, 0, 0 for red). If an 
RGB triplet is provided, the closest valid ENVI graphics color is used.

You can also set the default ENVI colors for all the spectra by right-clicking in 
the Color column title and selecting the Assign default colors to all option 
from the resulting shortcut menu. You can set all the spectra colors to <none> 
with the Assign default colors to undefined option. The shortcut menu also 
contains a Reset Colors option to reset all the spectra to their original colors. 
All of the options in this shortcut menu are also available in the Options pull-
down menu.

• Source — This column displays the source of each spectrum. The values in 
this column cannot be edited. The following list shows the possible sources for 
the spectra in the table.

• ASCII file — Spectrum imported from ASCII column data file.

• ASD file — Spectrum imported from ASD formatted file (which is output 
from the Analytical Spectral Devices spectrometers).

• Spec Lib — Spectrum imported from ENVI spectral library (.sli) file.

• ROI mean — Mean spectrum from either an ROI or a vector.

• Stats file — Spectrum imported from ENVI statistics (.sta) file.
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• Plot — Spectrum imported from a plot window. For more information on 
how to import from the plot window, see “From the Shortcut Menu” on 
page 581.

• Unknown — Spectrum retrieved from any other source.

• Bands — This column displays the number of spectral bands contained in each 
spectrum. The values in this column cannot be edited.

• Wavelength — This column contains the wavelength range of each spectrum. 
The wavelengths of the spectra are converted to the wavelengths of the image 
data (see “Input File Information” on page 578) when you click either the Plot 
or Apply button in the dialog. This conversion does not occur if the 
wavelength units of the spectra are unknown. You can change the wavelength 
units by right-clicking in the cell of the Wavelength column.

• Status — This column displays the status of each spectrum related to the input 
file. The values in this column cannot be edited. The following list shows the 
possible status values for the spectra in the table.

• Match — The wavelengths of the input file and the spectrum match 
exactly and no resampling is necessary when you click on either the Plot 
or Apply button.

• Resample — The wavelengths of the input file and the spectrum are 
different, but ENVI is able to resample the spectrum to the wavelength 
space of the input file when you click on either the Plot or Apply button in 
the dialog.

• Invalid — The wavelengths of the input file and the spectrum are different, 
but ENVI is not able to resample because the wavelength units of either the 
spectrum or the input file are unknown. If a spectrum is invalid, it cannot 
be plotted and is not used when you click the Apply button.

Note
An input file with unknown wavelength units can be changed to a file 
containing known wavelength units by using the File → Change input File... 
option in the dialog.
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Using the Endmember Spectra Table to Import Spectra

The Endmember Spectra table can also be used to import spectra from a display to 
the Endmember Collection dialog with either a shortcut menu or by dragging-and-
dropping the spectra.

From the Shortcut Menu

To derive spectra from a display and import them into the Endmember Spectra table, 
perform the following steps.

1. From the Display menu bar, select the Tools → Profiles → Z Profile 
(Spectrum)... option. The Spectral Profile plot window appears.

2. From the menu bar in the Spectral Profile plot window, select Options → 
Collect Spectra.

3. Click a couple times in various locations in the display to collect some spectra 
in the plot window.

4. Right-click in either the empty space or the upper-left corner of the table to 
access a shortcut menu This menu contains all the available spectra from every 
displayed plot window.

Figure 6-3: Shortcut Menu in the Endmember Spectra Table
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Note
If no spectrum was available in any plot window, the shortcut menu states 
that no spectrum is available and does not contain any other options.

5. Use the shortcut menu to import a spectrum from the Spectral Profile plot 
window into the Endmember Spectra table of the Endmember Collection 
dialog. The imported spectrum now appears in the table.

You can also use Import → from Plot Windows to import multiple spectra from a 
display. When this option is chosen, the Import from Plot Windows dialog appears. 
Use this dialog to select one or more spectra and then click OK. The selected spectra 
appear in the Endmember Collection dialog.

By Dragging-and-Dropping Spectra

You can also drag-and-drop a spectrum from the plot window key to the Endmember 
Spectra table to collect it in the Endmember Collection dialog.

1. In the Spectral Profile window, select Options → Plot Key. The key (legend) 
for the plot window appears to the right of the spectral plot.

2. Click and drag the key of a spectrum into the Endmember Spectra table. That 
spectrum now appears in the table.

Plotting Spectra

To plot a spectrum from the Endmember Spectra table, click in the Row Number 
column of that spectrum to select it and then click the Plot button. To plot multiple 
spectra, click with the Shift or Ctrl key in the Row Number column and then click 
Plot. You can plot all the spectra in the table by clicking the Select All button, and 
then clicking the Plot button.

Deleting Spectra

To delete a spectrum from the Endmember Spectra table, click in the Row Number 
column of that spectrum to select it and then click the Delete button. To delete 
multiple spectra, click with the Shift or Ctrl key in the Row Number column and 
then click Delete. You can delete all the spectra in the table by clicking the Select All 
button, and then clicking the Delete button.
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Importing Endmember Spectra

Use the Import menu to import spectra from other sources such as ASCII files, ROI 
and vector means, spectral libraries, or statistics files.

Note
When using the Mahalanobis Distance or Maximum Likelihood classifiers, the 
endmember spectra can only be imported from ROIs or statistics files because these 
classifications use the endmember covariance statistics.

Importing Spectra from ASCII Files

1. In the Endmember Collection dialog, select Import → from ASCII File.
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2. When the file selection dialog appears, select an ASCII file or a group of 
ASCII files of the same format.

Note
If you select a valid file (i.e., the file contains at least one column of ASCII 
numeric data), the ASCII Input dialog appears with a list of the number of 
columns and rows and the first few data values of each column of data.

3. Enter the column number that contains the X axis data in the X Axis Column 
text box.

4. Select endmember spectra by clicking on the desired column names.

Figure 6-4: Input ASCII File Dialog
Collecting Endmember Spectra ENVI User’s Guide



Chapter 6: Classification 585
5. Change the Wavelength Units and Y Scale Factor parameters if needed.

6. Click OK to enter the selected endmember spectra into the list on the 
Endmember Collection dialog. 

Importing Additional ASCII Files

To select another ASCII file and read the data using the parameters defined in the 
previous Input ASCII File dialog: 

1. Select Import → from ASCII file (previous template). 

2. Select the filename of an ASCII file.

This option reads the data directly into the Endmember Collection dialog without the 
intermediate parameter dialog.

Importing Spectra from ASD Binary Files

1. Select Import → From ASD Binary File.

2. In the Enter ASD Files to Import dialog, select the ASD file or files and click 
Open.

The file will be automatically resampled to match the wavelengths from a data file, 
ASCII File, or first imported spectrum as designated when the Spectral Library 
Builder function was started. If importing the ASD file from the Endmember 
Collection dialog, the file will be automatically resampled to the first input spectrum.

Note
If the range of the ASD file does not match the range of the input wavelengths, all 
zeroes will result.
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Importing Spectra from Spectral Libraries

1. Select Import → from Spectral Library.

2. When the Spectral Library Input File dialog appears, choose the spectral 
library name and click OK to open the library.

Note
If the desired spectral library has not been previously opened, select File → 
Open Spectral Library in the Library Input File dialog.

3. When the Input Spectral Library dialog appears, select endmember spectra by 
clicking on the desired spectrum names.

Figure 6-5:  Input Spectral Library Dialog
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4. Change the Wavelength Units and Y Scale Factor parameters if needed.

Note
If the Reflectance Scale Factor parameter is set in both the spectral library 
header and the image data header, then ENVI will automatically scale the 
library data to match the image data. If one of the two data sources has no 
scale factor in its header, then no scaling will be done.

5. Click OK to enter the selected spectra into the Endmember Spectra list.

Importing Spectra from ROIs and Vectors

You can import mean spectra from previously defined ROIs (regions of interest) or 
vectors open in the Available Vectors List. These ROIs and vectors can be associated 
with either the current input file or another file.

Importing ROIs and Vectors Associated with Current File

1. Select Import → from ROI/EVF from Input File.

2. When the Select Regions for Stats Calculation dialog appears, select 
endmember spectra (ROI or vector averages) by clicking on the ROI or vector 
names.

• To select all of the ROIs and vectors, click Select All Items.

• To de-select all of the ROIs and vectors, click Clear All Items.

• To open an ROI or EVF file, click the Open ROI/EVF file... button. The 
Enter ROI/EVF Filenames dialog appears. Use this dialog to select and 
open ROI and EVF files. The Select Regions for Stats Calculation dialog is 
updated with the ROIs and vectors from the open files.

Note
The Select Regions for Stats Calculation dialog is only provided if more than 
one ROI or vector is available.

3. Click OK to enter the ROI and vector means into the Endmember Spectra list.

Importing ROIs and Vectors Associated with Another File

1. Select Import → from ROI/EVF from Other File.

2. Select the desired input file from the Input File of associated ROI/EVF dialog.
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3. When the Select Regions for Stats Calculation dialog appears, select 
endmember spectra (ROI or vector averages) by clicking on the ROI or vector 
names.

• To select all of the ROIs and vectors, click Select All Items.

• To de-select all of the ROIs and vectors, click Clear All Items.

• To open an ROI or EVF file, click the Open ROI/EVF file... button. The 
Enter ROI/EVF Filenames dialog appears. Use this dialog to select and 
open ROI and EVF files. The Select Regions for Stats Calculation dialog is 
updated with the ROIs and vectors from the open files.

Note
The Select Regions for Stats Calculation dialog is only provided if more than 
one ROI or vector is available.

4. Click OK to enter the ROI and vector means into the Endmember Spectra list.

Importing Spectra from Statistics Files

Use from Stats file to import the mean spectrum from a previous classification result 
that was calculated using Basic Tools → Statistics.

1. Select Import → from Stats file.

2. When the Enter Statistics Filename dialog appears, select one or more statistics 
files and then click OK.

The mean spectrum from the statistics file is entered into the list on the Endmember 
Collection dialog.

Importing Spectra from Plot Windows

Use from Plot Windows to import multiple spectra from a plot window.

1. Select Import → from Plot Windows.

2. When the Import from Plot Windows dialog appears, select one or more 
spectra and then click OK.

The selected spectra appear in the Endmember Collection dialog.

Importing Spectra from Endmember Collection Files

Use from Endmember Collection file to import an Endmember Collection file (see 
“Saving Spectra to an Endmember Collection File” on page 593 for more information 
on the Endmember Collection file).
Collecting Endmember Spectra ENVI User’s Guide



Chapter 6: Classification 589
1. Select Import → from Endmember Collection file.

2. When the Select Endmember Collection File to Import dialog appears, select 
and open an Endmember Collection .txt file.

The Endmember Collection dialog is updated with the spectra from the specified file.

Endmember Options

Use the Options menu in the Endmember Collection dialog to edit the endmember 
names, edit the endmember colors, or suppress backgrounds (using BandMax).

Editing Endmember Names

To import spectrum names from an ASCII file:

1. In the Endmember Collection dialog, select Options → Import spectrum 
names from ASCII.

2. When the Select ASCII Filenames dialog appears, select and open the ASCII 
file that contains the spectrum names. The names of the spectra collected in the 
dialog are changed to the names from the ASCII file.

To reset the spectra to their initial names, select Options → Reset spectrum names.

Editing Endmember Colors

• To assign default colors to all of the endmember spectra, select Options → 
Assign default colors to all.

• To assign default colors to all of the undefined spectra colors (indicated by 
<none>), select Options → Assign default colors to undefined.

• To reset the spectra to their initial colors, select Options → Reset colors.

Suppressing Backgrounds with BandMax

You can select an optimal subset of input bands to differentiate one or more related 
target spectra from the spectra of other similar materials (backgrounds). The 
BandMax process isolates the bands that best distinguish selected targets from 
selected backgrounds. This optimal spectral subset generated with BandMax may 
increase the accuracy of the classification selected in the Endmember Collection 
dialog and speed processing.
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Note
You can also access BandMax in the SAM Target Finder with BandMax Wizard 
(see “Finding Targets with BandMax” in Chapter 9 for more information).

To use BandMax to calculate a subset of significant bands to suppress unwanted 
backgrounds, perform the following steps:

1. Select at least one spectrum (to represent a target) in the Endmember Spectra 
table of the Endmember Collection dialog.

2. Select Options → BandMax Background Suppression in the Endmember 
Collection dialog. The BandMax Background Suppression dialog appears. 
This dialog contains two sections. The Select Background section on the right 
side of the dialog enables you to collect spectra to be used as backgrounds in 
BandMax. The Significant Bands section on the left side of the dialog reports 
the results of BandMax and allows you to change these results by adjusting the 
threshold (or number of resulting bands).

3. Use the Select Background section of the dialog to collect any spectra you 
want to use as backgrounds. This section contains an embedded version of the 
Endmember Collection dialog. All the items in this section are the same as the 
items provided in the Endmember Collection dialog.

The BandMax significance values are calculated whenever a spectrum is added 
or deleted in the Select Background section. The results of BandMax are 
shown in the Significant Bands section.

The Significant Bands section contains the following items:

• Bands List — This list displays the bands that have been selected as 
significant by BandMax, based upon the established threshold. These 
significant bands form a spectral subset that is returned to the Endmember 
Collection dialog when you click OK in the BandMax Background 
Suppression dialog.

• Band Significance Threshold — This text box and arrow buttons enable 
you to change the threshold used to derive the list of significant bands. The 
threshold and the related significance values vary from 0 to 1. A value of 0 
indicates no significance, and a value of 1 indicates the most significance. 
The arrow buttons increase or decrease the threshold by no less than 0.01. 
The Significant Bands list and the Number of Significant Bands value is 
updated when you change the Band Significance Threshold value. The 
arrow buttons increase or decrease the number of bands by at least 1. If 2 
or more bands have the same significance value, a greater increment is 
used to include all of these bands.
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• Number of Significant Bands — This text box and arrow buttons enable 
you to change the number of significant bands resulting in the Significant 
Bands list relative to the Band Significance Threshold value. A decrease 
in the Number of Significant Bands value increases the Band 
Significance Threshold value. The arrow buttons increase or decrease the 
threshold by no less than 0.01, and continue to change the threshold until 
the number of bands is changed to the value specified. Thus, the threshold 
can be changed by an integer multiple of 0.01 and the number of selected 
bands either increases or decreases by more than one band (usually by two 
bands).

• Save Significant Bands to File... — This button enables you to save the 
band subset displayed in the Significant Bands list to an ASCII file. When 
you have derived the subset of bands that effectively detects your targets, 
you may want to use this same band subset to perform a series of 
classifications on a set of images. This output ASCII file can be used as 
input when spectrally subsetting a file.

When you are satisfied with the subset of significant bands, click OK. All the 
significant bands displayed in the Significant Bands section form the band subset 
that is used on the input data when you click Apply in the Endmember Collection 
dialog. If you click Cancel, no changes are made to the active bands in the 
Endmember Collection dialog.

Selecting Processing Techniques

Use the Algorithm menu in the Endmember Collection dialog to select a 
classification or advanced spectral processing method. The classification methods 
available are Parallelepiped, Minimum Distance, Mahalanobis Distance, Maximum 
Likelihood, Spectral Angle Mapper, and Binary Encoding. The advanced spectral 
processing methods available are Linear Spectral Unmixing, Matched Filtering, 
Mixture Tuned Matched Filtering, and Spectral Feature Fitting.

Note
When using the Mahalanobis Distance or Maximum Likelihood classifiers, the 
endmember spectra can only be imported from ROIs or statistic files because these 
classifications use the endmember covariance statistics. You must also have at least 
two endmembers.

1. In the Endmember Collection dialog, select Algorithm → method.
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Note
The classification methods can also be started from the Classification → 
Supervised menu and the advanced spectral processing methods can be 
started from the Spectral Tools menu.

2. Click Apply. 

3. When the Algorithm Parameters dialog appears, enter the selected algorithm’s 
needed parameters.

The parameters displayed are specific to the selected classification algorithm. For 
details about the different classification methods, see the following topics:

• “Applying Parallelepiped Classification” on page 597 

• “Applying Minimum Distance Classification” on page 598 

• “Applying Mahalanobis Distance Classification” on page 601 

• “Applying Maximum Likelihood Classification” on page 602 

• “Applying Spectral Angle Mapper Classification” on page 604 

• “Applying Binary Encoding Classification” on page 606

For details about the advanced processing methods, see the following topics:

• “Using Linear Spectral Unmixing” on page 780

• “Using Matched Filtering” on page 783

• “Using Mixture Tuned Matched Filtering” on page 785 

• “Using Spectral Feature Fitting” on page 789

Managing Endmember Spectra

Use the File menu in the Endmember Collection dialog to save endmember spectra to 
an ASCII file, as a spectral library, or as an Endmember Collection file. You can also 
use the File menu to change the input file or exit the dialog.

Saving Spectra to ASCII Files

1. In the Endmember Collection dialog, select File → Save Spectra As → 
ASCII.

2. When the Output Plots to ASCII File dialog appears, enter an output filename 
or use the Choose button to select an output filename.
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Saving Spectra to Spectral Libraries

To build a standard ENVI spectral library file from the endmember spectra: 

1. Select File → Save Spectra As → Spectral Library.

2. When the Output Plots to Spectral Library dialog appears, enter the output 
filename or use the Choose button to select an output filename.

Saving Spectra to an Endmember Collection File

An Endmember Collection file enables you to save and restore the current state of the 
Endmember Collection dialog to a text file. This Endmember Collection file contains 
all the current information that is provided for each spectrum in the Endmember 
Spectra table.

To save the current state of the spectra to an Endmember Collection file:

1. Select File → Save Spectra As → Endmember Collection File.

2. When the Output Endmember Collection to File dialog appears, enter the 
output filename or use the Choose button to select an output filename.

Changing the Input File

To change the input file but keep the selected endmembers:

1. Select File → Change Input File.

2. Select the desired input file and perform any desired subsetting. All the 
endmembers will be resampled to match the new input file.

Note
You can change the spectral or spatial subset of your input file by selecting File → 
Change Input File, selecting the same filename, and changing the spectral subset.

Closing the Dialog

To close the Endmember Collection dialog, select File → Cancel.
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Supervised Classification

Use Supervised classification to cluster pixels in a data set into classes 
corresponding to user-defined training classes. 

Training classes are groups of pixels (ROIs) or individual spectra. Select them as 
representative areas or materials that you want mapped in the output. You should try 
to select ROIs that are homogenous. You can examine the separability of your ROIs 
by exporting them to a n-D Visualizer and looking at the distribution of the points 
within each ROI (they should cluster tightly together) and looking for overlap 
between the classes (they should not overlap). For detailed instructions, see 
“Exporting ROIs to the n-D Visualizer” on page 316. You can also get a report of the 
separability values between ROI pairs. For detailed instructions, see “Computing ROI 
Separability” on page 312.

Supervised classification techniques include Parallelepiped, Minimum Distance, 
Mahalanobis Distance, Maximum Likelihood, Spectral Angle Mapper (SAM), and 
Binary Encoding.

For all supervised classification methods, you have an option to create rule images 
(which is recommended). Rule images show the classification results before final 
assignment of classes. For example, the pixel values in the rule images (one per class) 
for a minimum distance classification represent the distance between the class and 
each pixel. These rule images can be used in the rule classifier to adjust thresholds 
and generate new classification images (see “Classifying from Rule Images” on 
page 630).

Note
You must define training classes prior to performing supervised classification. You 
can define training classes in two ways: using the Endmember Collection dialog to 
select spectra (see “Collecting Endmember Spectra” on page 577) or by defining 
regions of interest (ROIs) (see “Defining Regions of Interest” on page 289). The 
training sites can be defined as multiple irregular polygons, vectors, and/or 
individual pixels.

Using the Endmember Collection option allows you to use the same training 
classes or endmembers for several classifications without reloading, thus 
simplifying comparison of classification results. 
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Use the following steps to perform a supervised classification:

1. Define training classes using the Endmember Collection dialog or Regions of 
Interest.

2. Select Classification → Supervised → the desired method, or initiate the 
classification from the Endmember Collection dialog (see “Selecting 
Processing Techniques” on page 591).

3. When the Classification Input File dialog appears, select an input file and any 
subsetting or masking as described in “Selecting Files in ENVI” on page 32. 
The Classification Parameters dialog appears. The dialog options vary 
depending on the type of classification selected.

Entering Classification Parameters

A specific Parameters dialog (the Classification Parameters dialog) appears for the 
type of classification you select. Options common to many of these dialogs include: 
selection of ROIs and vectors to be used for classification from the active ROI and 
vector list, disk file or memory output of the classification image, calculation of rule 
images with either file or memory output, and the ability to quickly preview the 
output classification image. The individual dialogs and parameters unique to each 
classification type are described in the following sections under the description of 
each classification method.

Selecting ROIs and Vectors

To select ROIs (regions of interest) and/or vectors as training classes, click on the 
desired ROI and vector names in the Select Classes from Regions: list. The ROIs 
listed are derived from the available ROIs in the ROI Tool dialog. The vectors listed 
are derived from the open vectors in the Available Vectors List.

Note
Maximum Likelihood and Minimum Distance both require at least two regions.

Calculating Rule Images

Use rule images to create intermediate classification image results before final 
assignment of classes. For example, rule images for the maximum likelihood 
classification will be the probability images themselves; one for each input ROI used 
in the classification. The rule image that has the highest probability for a pixel is the 
class to which that pixel is assigned. The probability values themselves are only 
retained in the rule images, not in the classified image. 
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To calculate an optional rule output image (or images — one for each class), enter a 
filename in the Enter Output Rule Filename text box.

Note
The rule images will not be saved if the Output Rule Images toggle button is set to 
No.

The images will appear in the Available Bands List at the end of the classification, 
and can be displayed and/or linked/overlaid in any display window and queried using 
ENVI’s Pixel Location/Value function.

Rule images can also be used later in the Rule Classifier to create a new classification 
image without actually having to recalculate the entire classification (see 
“Classifying from Rule Images” on page 630).

Previewing the Output Classification Image

The preview window allows you to quickly see a 256-by-256 spatial subset from the 
center of the output classification image. After adjusting your classification 
parameters, you can update the preview window to determine how these changes 
affect the resulting classification.

To access the preview window in any supervised classification tool, select the 
appropriate ROIs and/or vectors and then click the Preview button in the Select 
Classes from Regions: section of the Classification Parameters dialog. The preview 
window appears in the dialog.

The preview window contains a Change View... button and a label below the image 
describing the x and y pixel ranges of the spatial subset. The Change View... button 
initiates a Select Spatial Subset dialog allowing you to modify the location of the 
spatial subset interactively or by using a specified value. More information on the 
Select Spatial Subset dialog is provided in “Selecting a Spatial Subset” in Chapter 1.

Note
For SAM classification, the preview window is only available after you click the 
Apply button in the Endmember Collection dialog.
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Applying Parallelepiped Classification

Parallelepiped classification uses a simple decision rule to classify multispectral data. 
The decision boundaries form an n-dimensional parallelepiped in the image data 
space. The dimensions of the parallelepiped are defined based upon a standard 
deviation threshold from the mean of each selected class. If a pixel value lies above 
the low threshold and below the high threshold for all n bands being classified, it is 
assigned to that class. If the pixel value falls in multiple classes, ENVI assigns the 
pixel to the last class matched. Areas that do not fall within any of the parallelepipeds 
are designated as unclassified. For technical details, see the following reference:

J.A.Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, 
p. 240.

1. From the ENVI main menu, select Classification → Supervised → 
Parallelepiped; or, in the Endmember Collection dialog, select Algorithm → 
Parallelepiped (see “Collecting Endmember Spectra” on page 577).

2. When the Classification Input File dialog appears, select the input file. The 
Parallelepiped Parameters dialog appears.

3. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595.

4. Select a thresholding option:

• To use no standard deviation threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter a value in the Max stdev from Mean text box to designate the 
number of standard deviations to use around the mean.

• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.

B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value in the text box at the bottom of the dialog. Repeat for each class.

5. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.
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6. Click OK to start the classification.

A status window displays the progress of the operation. The pixel values of the 
resulting rule images range from 0 to n (where n is the number of bands) and 
represent the number of bands that satisfied the parallelepiped criteria. There is one 
rule image for each selected class. Areas that match all bands for a particular class are 
carried over as classified areas into the classified image. If more than one match 
occurs, the first class to be evaluated (the first ROI from the selected list) carries over 
into the classified image.

Applying Minimum Distance Classification

The minimum distance technique uses the mean vectors of each endmember and 
calculates the Euclidean distance from each unknown pixel to the mean vector for 
each class. All pixels are classified to the nearest class unless a standard deviation or 
distance threshold is specified, in which case some pixels may be unclassified if they 
do not meet the selected criteria. For technical details, see the following reference:

J.A.Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, 
p. 240.

1. Select Classification → Supervised → Minimum Distance; or, in the 
Endmember Collection dialog, select Algorithm → Minimum Distance (see 
“Collecting Endmember Spectra” on page 577).

Figure 6-6: Parallelepiped Parameters Dialog
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2. When the Classification Input File dialog appears, select the input file. The 
Minimum Distance Parameters dialog appears.

3. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595. 

4. To set threshold values based on standard deviations or maximum distance 
values, select from the following options in the Set Max stdev from Mean 
and/or Set Max Distance Error areas of the dialog:

Note
If you are running the Minimum Distance Classification from within the 
Endmember Collection dialog, the Max Stdev from Mean area is not 
available.

• To use no threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter a value in the Max stdev from Mean or Max Distance Error (in 
DN) text box. 

For Max stdev from Mean, enter the number of standard deviations to use 
around the mean. Pixels outside this range will not. For Max Distance 
Error, enter the value in DNs. Pixels at a distance greater than this value 
will not be classified.

• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.

B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value in the text box at the bottom of the dialog. Repeat for each class.

Note
If you set values for both Set Max stdev from Mean and Set Max Distance 
Error, the classification uses the smaller of the two to determine which 
pixels will be classified. If you select None for both parameters, then all 
pixels will be classified
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.

5. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.

6. Click OK to begin the classification.

A status window displays the progress of the operation. If output of rule images was 
selected, one is created for each class with the pixel values equal to the Euclidean 
distance from the class mean. Areas that satisfied the minimum distance criteria are 
carried over as classified areas into the classified image.

Figure 6-7: Minimum Distance Parameters Dialog
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Applying Mahalanobis Distance Classification

The Mahalanobis Distance classification is a direction-sensitive distance classifier 
that uses statistics for each class. It is similar to the Maximum Likelihood 
classification but assumes all class covariances are equal and therefore is a faster 
method. All pixels are classified to the closest ROI class unless you specify a distance 
threshold, in which case some pixels may be unclassified if they do not meet the 
threshold.

For technical details, see the following reference:

J.A.Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, 
p. 240.

1. Select Classification → Supervised → Mahalanobis Distance; or, in the 
Endmember Collection dialog, select Algorithm → Mahalanobis Distance 
(see “Collecting Endmember Spectra” on page 577).

2. When the Classification Input File dialog appears, select the input file. The 
Mahalanobis Distance Parameters dialog appears.

Note
Import (or re-import) the endmembers in the Endmember Collection dialog 
after selecting Mahalanobis as the classification method so that ENVI will 
import the endmember covariance information along with the endmember 
spectra.

3. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595.

4. Set a threshold based on a maximum distance in DNs by selecting one of the 
following options. The value of the maximum distance threshold will depend 
on the range of the input data. It is often useful to look at the histograms of the 
rule images for appropriate threshold values:

• To use no threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter a value, in DNs, in the Max Distance Threshold text box.

Pixels at a distance greater than this value will not be classified.

• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.
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B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value in the text box at the bottom of the dialog. Repeat for each class. 
Undefined thresholds are not allowed.

5. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.

6. Click OK to start the classification.

A status window displays the progress of the operation. If output of rule images was 
selected, one is created for each class with the pixel values equal to the distances from 
the class means. Areas that satisfied the minimum distance criteria are carried over as 
classified areas into the classified image. If a pixel falls into two or more classes, it 
will be classified into the class coinciding with the first-listed ROI.

Applying Maximum Likelihood Classification

Maximum likelihood classification assumes that the statistics for each class in each 
band are normally distributed and calculates the probability that a given pixel belongs 
to a specific class. Unless you select a probability threshold, all pixels are classified. 
Each pixel is assigned to the class that has the highest probability (i.e., the maximum 
likelihood). For technical details, see following reference:

J.A.Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, 
p. 240.

1. Select Classification → Supervised → Maximum Likelihood; or, in the 
Endmember Collection dialog, select Algorithm → Maximum Likelihood 
(see “Collecting Endmember Spectra” on page 577).

2. When the Classification Input File dialog appears, select the input file. The 
Maximum Likelihood Parameters dialog appears. 

Note
Import (or re-import) the endmembers in the Endmember Collection dialog 
after selecting Maximum Likelihood as the classification method so that 
ENVI will import the endmember covariance information along with the 
endmember spectra.
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3. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595.

4. Set a threshold based on probability by selecting one of the following options: 

• To use no threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter a value, between 0 and 1, in the Probability Threshold text box. 
Pixels with probabilities lower than this value will not be classified.

• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.

B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value in the text box at the bottom of the dialog. Repeat for each class.

5. Enter a Data Scale Factor.

The scale factor is a division factor used to convert integer scaled reflectance 
or radiance data into floating point values. For example, for reflectance data 
scaled into the range of zero to 10,000, set the scale factor to 10,000. For 
uncalibrated integer data, set the scale factor to the maximum value the 
instrument can measure 2n – 1, where n is the bit depth of the instrument). For 
example, for 8-bit instruments (such as Landsat 4) set the scale factor to 255, 
for 10-bit instruments (such as NOAA 12 AVHRR) set the scale factor to 1023, 
for 11-bit instruments (such as IKONOS) set the scale factor to 2047.

6. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.

7. Click OK to begin the classification.
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A status window displays the progress of the operation. The rule images, one per 
class, contain a maximum likelihood discriminant function with a modified Chi 
Squared probability distribution. Higher rule image values indicate higher 
probabilities. The final classification allocates each pixel to the class with the highest 
probability.

• To convert between the rule image’s data space and probability, use the Rule 
Classifier. For the classification threshold, enter the probability threshold used 
in the Maximum Likelihood classification as a percentage (e.g., 95%) (see 
“Classifying from Rule Images” on page 630 for more information). The Rule 
Classifier will automatically find the corresponding rule image Chi Squared 
value.

Applying Spectral Angle Mapper Classification

The Spectral Angle Mapper (SAM) is a physically-based spectral classification that 
uses an n-dimensional angle to match pixels to reference spectra. The algorithm 
determines the spectral similarity between two spectra by calculating the angle 
between the spectra, treating them as vectors in a space with dimensionality equal to 
the number of bands. This technique, when used on calibrated reflectance data, is 
relatively insensitive to illumination and albedo effects. Endmember spectra used by 
SAM can come from ASCII files, spectral libraries, or can be extracted directly from 
the image (as ROI average spectra). SAM compares the angle between the 
endmember spectrum vector and each pixel vector in n-dimensional space. Smaller 
angles represent closer matches to the reference spectrum. Pixels further away than 
the specified maximum angle threshold in radians are not classified.

Note
SAM classification assumes reflectance data. However, the error introduced by 
using radiance data is probably (in most cases) not prohibitively large because the 
origin will still be near zero (even if it is not at zero).

For additional information see the following reference:

Kruse, F. A., Lefkoff, A. B., Boardman, J. B., Heidebrecht, K. B., Shapiro, A. T., 
Barloon, P. J., and Goetz, A. F. H., 1993, “The Spectral Image Processing System 
(SIPS) - Interactive Visualization and Analysis of Imaging spectrometer Data”. 
Remote Sensing of Environment, v. 44, p. 145 - 163. 
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Note
You can use ENVI’s Spectral Hourglass Wizard to guide you step-by-step through 
the ENVI hourglass processing flow, including SAM Classification, to find and map 
image spectral endmembers from hyperspectral or multispectral data. For details, 
see “Spectral Hourglass Wizard” on page 809.

1. Select Classification → Supervised → Spectral Angle Mapper; or, in the 
Endmember Collection dialog, select Algorithm → Spectral Angle Mapper 
(see “Collecting Endmember Spectra” on page 577).

2. When the Classification Input File dialog appears, perform standard file 
selection and any subsetting and masking of the input file. The Endmember 
Collection: SAM dialog appears. 

Note
Spectra can be imported from ASCII files, spectral libraries, ROI means, or 
statistics files. 

3. From the Import menu, select endmember spectra from the variety of sources 
(see “Collecting Endmember Spectra” on page 577). 

Note
If desired, change the names of the spectra and plot the spectra.

4. After all endmember spectra are selected, click Apply. The Spectral Angle 
Mapper Parameters dialog appears.

5. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595. 

6. Set a threshold based on the spectral angle by selecting one of the following 
options: 

• To use no threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter a value, in radians, in the Maximum Angle text box. This is the 
maximum acceptable angle between the endmember spectrum vector and 
the pixel vector (in # of bands dimensional space). The default is 0.1 
radians. Pixels with an angle larger than this value will not be classified.
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• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.

B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value in the text box at the bottom of the dialog. Repeat for each class. 
Undefined thresholds are not allowed.

7. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.

8. Click OK to begin the SAM classification.

A status window displays the progress of the operation. The pixel values of the rule 
images represent the spectral angle in radians from the reference spectrum for each 
class. Lower spectral angles represent better match to the endmember spectra. Areas 
that satisfied the selected radian threshold criteria are carried over as classified areas 
into the classified image.

Applying Binary Encoding Classification

The binary encoding classification technique encodes the data and endmember 
spectra into 0s and 1s based on whether a band falls below or above the spectrum 
mean. An exclusive OR function is used to compare each encoded reference spectrum 
with the encoded data spectra and a classification image produced. All pixels are 
classified to the endmember with the greatest number of bands that match unless the 
user specifies a minimum match threshold, in which case some pixels may be 
unclassified if they do not meet the criteria. For details, see the following reference:

Mazer, A. S., Martin, M., Lee, M., and Solomon, J. E., 1988, “Image Processing 
Software for Imaging Spectrometry Analysis”, Remote Sensing of Environment, v. 
24, no. 1, p. 201 - 210.

1. Select Classification → Supervised → Binary Encoding; or, in the 
Endmember Collection dialog, select Algorithm → Binary Encoding (see 
“Collecting Endmember Spectra” on page 577).

2. When the Classification Input File dialog appears, perform standard file 
selection and any subsetting and masking of the input file. The Binary 
Encoding Parameters dialog appears. 
Supervised Classification ENVI User’s Guide



Chapter 6: Classification 607
3. Enter the general classification parameters as described in “Entering 
Classification Parameters” on page 595. 

4. Set a threshold based on the percentage of bands that match by selecting one of 
the following options: 

• To use no threshold, click the None button. 

• To use a single threshold for all classes, click the Single Value button and 
enter decimal percentage value, between 0 and 1, in the Minimum 
Encoding Threshold text box. The percentage value represents the 
number of bands that must match.

• To enter a different threshold for each class:

A. In the list of classes, click on the class or classes to which you want to 
assign different threshold values.

B. Click the Multiple Values button to select it.

C. Click the Assign Multiple Values button.

D. In the dialog that appears, click on a class to select it, then enter a threshold 
value, between 0 and, in the text box at the bottom of the dialog. Repeat for 
each class.

Note
If a minimum value is not entered, all pixels will be classified.

5. Click Preview to see a 256-by-256 spatial subset from the center of the output 
classification image (see “Previewing the Output Classification Image” on 
page 596 for more information about this class preview). If needed, modify 
your parameters and click Preview again to update the display.

6. Click OK to begin the classification.

A status window displays the progress of the operation. If a rule image was selected, 
one is created for each class with the pixel values equal to the percentage (0-100%) of 
bands that matched that class. Areas that satisfied the minimum threshold are carried 
over as classified areas into the classified image.
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Applying Neural Net Classification

Use Neural Net to apply a layered feed-forward neural network classification 
technique. The Neural Net technique uses standard backpropagation for supervised 
learning. You can select the number of hidden layers to use and you can choose 
between a logistic or hyperbolic activation function. Learning occurs by adjusting the 
weights in the node to minimize the difference between the output node activation 
and the desired output. The error is backpropagated through the network and weight 
adjustment is made using a recursive method. Neural Net classification can be used to 
perform non-linear classification. See the following references for more information:

J.A.Richards, 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, 
Berlin, p.240.

D. Rumelhart and J. Mc Clelland, 1987 Parallel Distributed Processing Vol. 1, MIT 
Press, Chp. 8 “Learning Internal Representation by Error Propagation”, Rumelhart, 
Hinton, and Williams.

Note
You must first have ROIs selected to use as training pixels for each class. The more 
pixels, the better the results will be.

1. Select Classification → Supervised → Neural Net.

2. When the file selection dialog appears, select the input file and any subsetting. 
The Neural Net Parameters dialog appears.

3. Select the classes to map by clicking on the ROI names in the Select Classes 
from Regions list.

4. Select the desired activation method by clicking on the corresponding toggle 
button. 

5. In the Training Threshold Contribution text box, enter a value from 0 to 1.0. 
The training threshold contribution determines the size of the contribution of 
the internal weight with respect to the activation level of the node. It is used to 
adjust the changes to a node’s internal weight. The training algorithm 
interactively adjusts the weights between nodes and optionally the node 
thresholds to minimize the error between the output layer and the desired 
response. Setting the Training Threshold Contribution to zero will not adjust 
the node’s internal weights. Adjustments of the nodes internal weights could 
lead to better classifications but too many weights could also lead to poor 
generalizations.
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6. In the Training Rate text box, enter a value from 0 to 1.0. The training rate 
determines the magnitude of the adjustment of the weights. A higher rate will 
speed up the training, but will also increase the risk of oscillations or non-
convergence of the training result.

7. In the Training Momentum text box, enter a value from 0 to 1.0. Entering a 
momentum rate greater than zero allows you to set a higher training rate 
without oscillations. A higher momentum rate trains with larger steps than a 
lower momentum rate. Its effect is to encourage weight changes along the 
current direction.

8. In the Training RMS Exit Criteria text box, enter the RMS error value at 
which the training should stop. 

Note
If the RMS error, which is shown in the plot during training, falls below the 
entered value, the training will stop, even if the number of iterations has not 
been met. The classification will then be executed.

9. In the Number of Hidden Layers text box, enter the number of hidden layers 
to use. For a linear classification, enter a value of 0. With no hidden layers the 
different input regions must be linearly separable with a single hyperplane. 
Non-linear classifications are performed by setting the Number of Hidden 
Layers to a value of 1 or greater. When the input regions are linearly 
inseparable and require two hyperplanes to separate the classes you must have 
a least one hidden layer to solve the problem. Two hidden layers are used to 
classify input space where the different elements are neither contiguous or 
connected.

10. In the Number of Training Iterations text box, enter the number of iterations 
for training.

Note
To enter a minimum output activation threshold, enter a value in the Min 
Output Activation Threshold text box. 

If the activation value of the pixel being classified is less than this threshold 
value, then that pixel will be labeled unclassified in the output.

11. Select output to File or Memory.

12. Select whether or not to output rule images by clicking the Output Rule 
Images toggle button to select Yes or No. If you select Yes, select output to 
File or Memory for the rule images.
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Note
If you output rule images, there is a rule image for every class. The rule 
image is the output activation value for every pixel in that class.

A status window displays the progress of the operation. During the training, a plot 
window appears showing the RMS error at each iteration. The error should decrease 
and approach a steady low value if proper training occurs. If the errors are oscillating 
and not converging, try using a lower training rate value or different ROIs. The 
resulting neural net classification image, and rule images if output, appear in the 
Available Bands List when processing is complete.
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Unsupervised Classification

Use Unsupervised classification to cluster pixels in a data set based on statistics only, 
without any user-defined training classes. The unsupervised classification techniques 
available are Isodata and K-Means.

Using Isodata Classification

Isodata unsupervised classification calculates class means evenly distributed in the 
data space and then iteratively clusters the remaining pixels using minimum distance 
techniques. Each iteration recalculates means and reclassifies pixels with respect to 
the new means. Iterative class splitting, merging, and deleting is done based on input 
threshold parameters. All pixels are classified to the nearest class unless a standard 
deviation or distance threshold is specified, in which case some pixels may be 
unclassified if they do not meet the selected criteria. This process continues until the 
number of pixels in each class changes by less than the selected pixel change 
threshold or the maximum number of iterations is reached. For technical details, see 
the following reference: 

Tou, J. T. and R. C. Gonzalez, 1974. Pattern Recognition Principles, Addison-Wesley 
Publishing Company, Reading, Massachusetts.

1. Select Classification → Unsupervised → Isodata.

2. When the Classification Input File dialog appears, perform standard file 
selection and any subsetting and masking of the input file. 

3. The ISODATA Parameters dialog appears. Options available in the ISODATA 
Parameters dialog include input of a range for the number of classes to be 
defined, the pixel change threshold (0 - 100%), the maximum number of 
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iterations to be used to separate the classes, splitting, merging, and deleting 
classes thresholds, and optional distance thresholds.

4. Enter the minimum and maximum number of classes to be defined. A range for 
the number of classes is used because the Isodata algorithm splits and merges 
classes based on input thresholds and does not keep a fixed number of classes.

5. Enter the maximum number of iterations and a change threshold (0-100%) in 
the appropriate text boxes. The change threshold is used to end the iterative 
process when the number of pixels in each class changes by less than the 
threshold. The classification will end when either this threshold is met or the 
maximum number of iterations has been reached.

6. Enter the minimum number of pixels needed to form a class in the appropriate 
text box. 

Note
If there are fewer than the minimum number of pixels in a class then that 
class will be deleted and the pixels placed in the class(es) nearest to them.

7. Enter the maximum class standard deviation (in DN) in the Maximum Class 
Stdv text box.

Figure 6-8: IsoData Parameters Dialog
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Note
If the standard deviation of a class is larger than this threshold then the class 
is split into two classes.

8. Enter the minimum distance (in DN) between class means and the maximum 
number of merge pairs in the appropriate text boxes.

Note
If the distance between class means is less than the minimum value entered, 
then the classes will be merged. The maximum number of class pairs to be 
merged is set by the maximum number of merge pairs parameter.

To set the optional standard deviation to use around the class mean and/or the 
maximum allowable distance error (in DN), enter the values in the 
Maximum Stdev From Mean: or Maximum Distance Error: text boxes, 
respectively. 

If both of these optional parameters are entered, the classification uses the 
smaller of the two to determine which pixels will be classified. If neither 
parameter is entered, then all pixels will be classified. 

9. Select output to File or Memory.

10. Click OK to start the Isodata classification.

Statistics are calculated for each band of the image, and a status window displays the 
progress of the operation. The status bar cycles from 0 to 100% for each iteration of 
the classifier.

Note
The statistics for the initial class seeds are computed with a skip factor of 2.5 for 
both the sample and line directions.
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Using K-Means Classification

K-Means unsupervised classification calculates initial class means evenly distributed 
in the data space and then iteratively clusters the pixels into the nearest class using a 
minimum distance technique. Each iteration recalculates class means and reclassifies 
pixels with respect to the new means. All pixels are classified to the nearest class 
unless a standard deviation or distance threshold is specified, in which case some 
pixels may be unclassified if they do not meet the selected criteria. This process 
continues until the number of pixels in each class changes by less than the selected 
pixel change threshold or the maximum number of iterations is reached. For technical 
details, see the following reference:

Tou, J. T. and R. C. Gonzalez, 1974. Pattern Recognition Principles, Addison-Wesley 
Publishing Company, Reading, Massachusetts.

1. Select Classification → Unsupervised → K-Means.

2. When the Classification Input File dialog appears, perform standard file 
selection and any subsetting and masking of the input file. 

3. The K-Means Parameters dialog appears. Options available in the K-Means 
Parameters dialog include selection of the number of classes to be defined by 
the clustering procedure, the pixel change threshold (0 - 100%), the maximum 
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number of iterations to be used to separate the classes and optional distance 
thresholds.

4. Enter the desired number of classes and maximum number of iterations in the 
appropriate text boxes.

5. Enter a change threshold (0-100%) which is used to end the iterative process 
when the number of pixels in each class changes by less than the threshold. 
The classification will end when either this threshold is met or the maximum 
number of iterations has been reached.

Note
To set the optional standard deviation to use around the class mean and/or the 
maximum allowable distance error (in DN), enter the values in the 
Maximum Stdev From Mean: or Maximum Distance Error: text boxes, 
respectively. 

If both of these optional parameters are entered, the classification uses the 
smaller of the two to determine which pixels will be classified. If neither 
parameter is entered, then all pixels will be classified. 

Figure 6-9: K-Means Parameters Dialog
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6. To select either disk file or memory output, select the File or Memory toggle 
button.

Note
If output to File is selected, enter an output filename.

7. Click OK to start the K-Means classification.

Statistics are calculated for each band of the image, and a status displays the progress 
of the operation. The status bar cycles from 0 to 100% for each iteration of the 
classifier.

Note
The statistics for the initial class seeds are computed with a skip factor of 2.5 for 
both the sample and line directions.
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Decision Tree Classifier

The Decision Tree classifier performs multistage classifications by using a series of 
binary decisions to place pixels into classes. Each decision divides the pixels in a set 
of images into two classes based on an expression. Each new class can be divided into 
two more classes based on another expression. As many decision nodes as needed can 
be defined. The results of the decisions are classes. Data from many different sources 
and files can be used together to make a single decision tree classifier. The decision 
trees can be “pruned” and edited interactively. The trees can be saved and applied to 
other data sets.

The following figure shows an example decision tree in ENVI.

Input data can be from various sources and data types. For example, multispectral 
data can be used in conjunction with digital elevation data to find pixels with low 
vegetation and high slopes. Georeferenced files that are in different projections with 
different pixel sizes can be used in a single decision tree and ENVI will reproject and 
resample them on-the-fly. Special variables, such as NDVI, can be calculated on-the-
fly and used in the expressions. The variables and expressions are described in the 
following section.

Note
In addition to the information provided in this section, see the Tutorial 5, “Decision 
Tree Classification” tutorial in the ENVI Tutorials for a step-by-step example.

Figure 6-10: ENVI Decision Tree
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Decision Tree Variables and Expressions

The expressions used in ENVI’s decision tree classifier are similar to those used in 
Band Math. They must produce single band output and have a binary result of 0 or 1. 
The 0 result is sent to the “No” branch and the 1 result is sent to the “Yes” branch of 
the decision tree.

The expressions can include math functions, relational operators, boolean operators, 
and other IDL functions as shown in Table 6-1.

The variables in ENVI’s decision tree classifier refer to a band of data or to a special 
function that acts on the data. The variable names must be within curly brackets, i.e. 
{variable name}, or be named bx, where x is a number, as in band math. If a variable 
is assigned to a multiband file, the variable must have a subscript, in square brackets, 
referring to a band number (band numbers are 1 to the number of bands). For 
example, {pc[2]} refers to band 2 of the file assigned to the variable pc.

Category Available Functions

Basic Arithmetic Addition (+), subtraction (–), multiplication (*), and division 
(/)

Trigonometric 
Functions 

sin(x), cos(x), and tan(x)

Arcs — asin(x), acos(x), and atan(x)

Hyperbolics — sinh(x), cosh(x), and tanh(x)

Relational and 
Logical Operators

LT, LE, EQ, NE, GE, GT 

AND, OR, NOT, XOR

maximum (>) and minimum (<)

Other Math 
Functions

exponent (^) and natural exponent

Natural Logarithm — alog(x)

Log Base 10 — alog10(x)

Integer rounding — round(x), ceil(x)

Square Root — sqrt(x)

Absolute Value — abs(x)

Table 6-1: IDL Array Handling Functions
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ENVI’s special variable names do calculations on-the-fly, and use the results in the 
expression. These special variable names must be within curly brackets and can have 
numbers or additional text after them. For example, {ndvi1} or {pc_can[1]} are 
allowed special variable names. The special variable names are listed here:

• {slope} — The slope calculated from a DEM file.

• {aspect} — The aspect calculated from a DEM file.

• {ndvi} — NDVI calculated from file. If the sensor type is set in the header, the 
bands used to calculate the NDVI are automatically found. If ENVI does not 
know which bands to use, it will prompt you to enter the band numbers.

• {tascap[n]} — Tasseled Cap Transform — The subscript, n, points to which 
tasseled cap result to use in the expression; for example, for TM data, 
{tascap[2]} will use the greenness band.

• {pc[n]} — Principal Components — The subscript, n, points to which PC 
band to use in the expression.

• {mnf[n]} — Minimum Noise Fraction — The subscript, n, points to which 
MNF band to use in the expression.

• {lpc[n]} — Local Principal Components — Uses only the surviving pixels in 
the calculations.

• {lmnf[n]} — Local Minimum Noise Fraction — Uses only the surviving 
pixels in the calculations.

• {mean[n]} — The mean for band n.

• {stdev[n]} — The standard deviation for band n.

• {min[n]} — The minimum of band n.

• {max[n]} — The maximum of band n.

• {lmean[n]} — Local Mean — The mean of only the surviving pixels.

• {lstdev[n]} — Local Standard Deviation — The standard deviation of only the 
surviving pixels.

• {lmin[n]} — Local Minimum — The minimum of only the surviving pixels.

• {lmax[n]} — Local Maximum — The maximum of only the surviving pixels.

The following examples show expressions that can be used in a decision node.

(b1 gt 20) and (b2 le 45)
{ndvi} ge 0.3
b1 gt ({mean[2]} + 2*{stdev[2]})
({slope} gt 15) and (({aspect} lt 90) or ({aspect} gt 270))
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Note
The local statistics variables can only be used on georeferenced files that have the 
same projection as the selected base file, otherwise statistics will be calculated 
using the entire band.

Using IDL Functions in Node Expressions

The Expression: text box also accepts user-defined functions written in IDL. These 
functions are derived and applied as expressions in the same manner as user-defined 
functions in the Band Math and Spectral Math tools. However, the result of the 
overall expression must still equal 0 or 1.

Because ENVI provides access to IDL’s capabilities (unless you are using ENVI-RT), 
you can use the power of built-in IDL features, IDL user functions, or write your own 
decision tree expressions to perform custom operations. These functions are required 
to accept one or more pixel variables as input. Moreover, the overall expression must 
equal 0, 1, or a binary array (of the same spatial size as the input data) in which each 
pixel value is 0 or 1. The functions need to be saved in a directory that is within the 
IDL path list (for example, the save_add directory in the ENVI distribution) so they 
are auto-compiled by ENVI.

Note
You can also compile the functions as described in “Compiling” in Chapter 1 of the 
ENVI Programmer’s Guide.

The following example demonstrates the creation and use of custom decision tree 
functions.

Example

This example function returns a mask (byte array) where the specified values in the 
input data are set to 1 and all other pixels are set to 0:

FUNCTION dt_choose_values, data, values

info = SIZE(data)
result = MAKE_ARRAY(/BYTE, SIZE = info)
FOR index = 0L, (N_ELEMENTS(values) - 1) DO $

result += (data EQ values[index])

RETURN, result
END
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To call this function from the Expression: text box to derive a mask for values of 20, 
22, 24, and 26 in the first band (b1) in the bhtmref.img file in the data directory of 
the ENVI distribution, use the following syntax:

dt_choose_values(b1, [20, 22, 24, 26])

Building a New Decision Tree

1. From the main ENVI menu bar, select Classification → Decision Tree → 
Build New Decision Tree.

The ENVI Decision Tree window appears with a single decision node and two 
classes (leaves).

2. in the Edit Decision Tree Properties dialog, click on the Node button and enter 
a node name and an expression (see “Decision Tree Variables and 
Expressions” on page 618). The Variable/File Pairings dialog appears.

The following figure shows the Edit Decision Tree Properties and Variable/File 
Pairings dialogs.

3. Click on the variable name and select the input file or band to associate to the 
variable.

4. Add a new node by right clicking on a Class button and selecting Add 
Children.

5. Click on the new node and enter an expression in the Edit Decision Properties 
dialog. Click OK.

6. Repeat steps 4 and 5, adding as many nodes as necessary.

7. When the tree is finished, select Options → Execute.

Figure 6-11: Edit Decision Properties (left) and Variable/File Pairings (right) 
Dialogs
ENVI User’s Guide Decision Tree Classifier



622 Chapter 6: Classification
Executing a Decision Tree

To interactively execute and edit a decision tree:

1. In the ENVI Decision Tree window, select Options → Execute.

2. When the Decision Tree Execution Parameters dialog appears, select a spatial 
subset, if desired, and enter an output filename.

• If your data are georeferenced, select which image to use as a base image, 
enter an output pixel size, and select the resampling method from the 
pulldown menu.

Each node will change to a green color while it is executing. The classification 
results appear in a new display window. A temporary file is saved for each 
node so the results do not need to be recalculated each time the decision tree is 
executed.

3. To see details about the number of pixels at each node, right-click in the 
background of the Decision Tree window and select Zoom In from the 
shortcut menu. Each node will list how many pixels survived to reach that 
node. The status bar also provides details when you position the cursor over 
the class.

4. Make any changes to the decision nodes by clicking on the node and changing 
the expression.

• You can change the output class color and name by clicking on the class 
node and entering the new name and color in the Edit Class Properties 
dialog.

Tip
For other interactive options, see the following “Decision Tree Options” 
section.

5. Execute the decision tree again and look at the results.

6. Repeat steps 3 and 4 until you are satisfied with the results.
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Decision Tree Options

Options in the decision tree dialog Options menu include rotating the decision tree 
graphics, zooming in and out of the decision tree, assigning default class values, 
hiding and showing the Variable/File Pairings dialog, changing the output 
parameters, and executing the decision tree. These options are also available from a 
shortcut menu, which you access by right-clicking in the background of the decision 
tree dialog window. 

Rotating the Decision Tree Graphics

Select Options → Rotate View to switch between viewing the decision tree graphics 
as either a vertical tree or a horizontal tree. 

Zooming In/Out of the Decision Tree

• Select Options → Zoom In to zoom into the decision tree. When fully 
zoomed in, the number of pixels that survive each node is shown on the node.

• Select Options → Zoom Out to zoom out of the decision tree. If you have a 
large tree, you can zoom out to see more of the tree in the window. The number 
of pixels surviving to each node will not be shown in the classes, but are visible 
in the status bar when you position the cursor over the class.

Assigning Default Class Values

Select Options → Assign Default Class Values to reassign the class numbers and 
colors in order from left to right in the decision tree.

Hiding/Showing the Variable/File Pairing dialog

Select Options → Hide/Show Variable/File Pairing to hide or show the dialog 
window.

Changing Output Parameters

To change the default output parameters used when executing a decision tree:

1. Select Options → Change Output Parameters.

2. When the Decision Tree Execution Parameters dialog appears, select a spatial 
subset, if desired, and enter an output filename.

• If your data are georeferenced, select which image to use as a base image, 
enter an output pixel size, and select the resampling method from the 
pulldown menu.
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3. Click OK.

These parameters will be automatically used when you edit and execute the decision 
tree.

Decision Tree Node Options

The decision nodes and class nodes have options that include pruning, restoring, 
deleting, and adding children nodes, editing the node properties, and saving the 
surviving pixels to a mask file. These options are selected by right-clicking on the 
node and selecting from the shortcut menu.

Pruning/Restoring Children

• To temporarily remove the children below a node and combine all their classes 
into a single class, right-click on a node to display the shortcut menu and select 
Prune Children.

• To restore pruned children, right-click on a node to display the shortcut menu 
and select Restore Pruned Children.

Deleting Children

Right-click on a node to display the shortcut menu and select Delete Children to 
permanently delete the children below the decision node and change the node into a 
class node.

Adding Children

Right-click on a class to display the shortcut menu and select Add Children to add 
children and change the class node into a decision node.

Editing Decision Node Properties

Right-click on a node to display the shortcut menu and select Edit Properties to 
change the node name and expression.

Editing Class Node Properties

Right-click on a class to display the shortcut menu and select Edit Properties to 
change the class name and color.

Saving Survivors to a Mask File

Right-click on a node or a class to display the shortcut menu and select Save 
Survivors to Mask. Enter a file name to save the surviving pixels to a mask file. 
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Managing Decision Tree Files

Use the options under the File menu to build a new decision tree, save a decision tree 
to an ASCII file, restore a saved decision tree, and to exit the function.

• Select File → New Tree to build a new decision tree.

• Select File → Save Tree and enter an output file name to save a decision tree 
to an ASCII file.

• Select File → Restore Tree and select an input file to restore a previously 
saved decision tree.

• Select File → Cancel to close the decision tree dialog.

Editing an Existing Decision Tree

Use Edit Existing Decision Tree to restore an existing decision tree file and edit it as 
desired.

1. From the main ENVI menu bar, select Classification → Decision Tree → 
Edit Existing Decision Tree.

2. Select the decision tree file to restore.

The selected decision tree appears in the Decision Tree dialog and you can edit it or 
execute it as desired.

Executing an Existing Decision Tree

Use Execute Existing Decision Tree to execute an existing decision tree file. You 
can change the input bands and edit the output parameters.

1. From the main ENVI menu bar, select Classification → Decision Tree → 
Execute Existing Decision Tree.

2. Select the decision tree file to execute.

The Variable/File Pairings dialog appears.

3. Assign the variables to files by clicking on the variable name and selecting a 
file.

4. Click OK.

The Decision Tree Execution Parameters dialog appears.
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5. Select a spatial subset, if desired, and enter an output filename.

• If your data are georeferenced, select which image to use as a base image, 
enter an output pixel size, and select the resampling method from the 
pulldown menu.

6. Click OK.

The results are listed in the Available Bands List.
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Creating Class Images from ROIs

Use Create Class Image from ROIs to convert selected ROIs into an ENVI 
classification image. 

For detailed instructions, see “Creating Class Images from ROIs” on page 311.
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Post Classification

Use Post Classification to classify rule images, to calculate class statistics and 
confusion matrices, to apply majority or minority analysis to a classification images, 
to clump, sieve, and combine classes, to overlay classes on an image, to calculate 
buffer zone images, to calculate segmentation images, and to output classes to vector 
layers.

Changing Class Colors

Use Class Color Mapping to change the colors of classes after a classified image is 
loaded into a display window. The color that a class is automatically displayed in 
corresponds to the color of the selected ROI for supervised classification and to pre-
selected class colors for unsupervised classification. Unclassified areas appear black 
on the images. 

Figure 6-12: Post Classification Menu
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1. Select Tools → Color Mapping → Class Color Mapping from the Display 
menu in the Main Image window. 

2. When the Classification Mapping dialog appears, select from the following 
options to change the class colors and/or names.

• To change the color system, select RGB, HLS, or HSV from the System 
button menu.

• To modify the class color, click on a class name in the Selected Classes 
list and either type new values into the text boxes and press Enter, or move 
the color adjustment slider bars, or click the arrow increment buttons to set 
the color values.

• To change the name of the selected class, edit it in the Class Name: text 
box.

• To reset the colors and names to their original values, select Options → 
Reset Color Mapping.

Figure 6-13: Class Color Mapping Option from Display Menu
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3. When you are finished with your color modifications, select File → Save 
Changes to retain the new colors.

4. Select File → Cancel to close the dialog.

For more information, see “Mapping Class Colors” on page 407 and “Editing 
Classification Info” on page 117.

Classifying from Rule Images

Use Rule Classifier to use previously saved rule images to generate new 
classification images from different thresholds. The previously saved rule images 
may contain the classification measures such as the number of matches, distance 
measures, or probabilities. A significant amount of the time required to run 
classification routines can be attributed to calculation of the classification measures. 
Classification itself doesn’t actually require extensive computation.

Note
To use the Rule Classifier, you must first generate rule images. For details, see 
“Supervised Classification” on page 594 and “Calculating Rule Images” on 
page 595.

1. Select Classification → Post Classification → Rule Classifier.
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2. In the file input dialog, select the input rule image file and perform any spatial 
subsetting. The Rule Image Classifier Tool dialog appears.

3. Click the Classify By arrow toggle button to select whether the image will be 
classified by Minimum or Maximum values.

4. Select one of the following options to set a threshold value:

• To enter the same threshold value for all classes, enter a value in the Set 
All Thresholds text box and click the Set All Thresholds button. The 
threshold value appears in the Thresh text box for each class.

• To enter a different threshold for each class, enter a value in the Thresh 
text box for each class.

• To enter a threshold value based on histogram percentage, enter the 
percent value (e.g. “5%”) in the Thresh text box.

Note
You can plot a histogram of a rule band to help you determine threshold 
values. For details, see “Plotting Histograms” on page 632.

Figure 6-14: Interactive Rule Image Classifier Tool
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Note
If using Maximum Likelihood rule images that were produced from ENVI 
3.6 or later, enter the threshold using a percentage (e.g., “95%”), and the 
corresponding Chi Square value will automatically be computed using the 
histogram of the rule image.

5. Click the Quick Apply button. A classification image based on the current 
settings is displayed in a new display window.

Note
To remove a class from the display, click in the On check box for that class to 
deselect it. To display that class again, click the On check box again.

6. Click the Quick Apply button to see how any of your changes affect the 
classification image.

Plotting Histograms

You can plot a histogram of a rule band to help you determine threshold values: 

Click the Hist button for that class.

A plot window is displayed with the histogram of the selected band.

For details about working with ENVI plots, see “Using Interactive Plot Functions” on 
page 387.

Options in the Rule Image Classifier Tool Dialog

Use the Rule Image Classifier Tool Options menu to change class names and/or 
colors, and to reorder classes. Use the Save to File button to save the classification 
image to a file. Use the File menu or the Cancel button to cancel the post 
classification process. Detailed instructions follow:

Changing Class Names and Colors

1. To change the class color or name select Options → Edit Class 
Colors/Names. The Class Color Map Editing dialog will appear.

2. Click on class name in the list to highlight it and select from the following 
options:

• To change the class name, enter the new name in the Class Name text box.

• To change the class color, select a color system and/or color using the 
button menus. To further adjust the color, use the slider bars.
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For detailed instructions about color selection, see “Mapping Class Colors” in 
Chapter 4.

Reordering Classes

If two classes have the same rule value, the first one in the list will be used to make 
the output classification image.

1. To reorder the classes, selecting Options → Reorder Classes. The Reorder 
Classes dialog appears with the class names displayed in a list.

2. Click on a class name and drag it to the desired location in the list.

3. Click OK.

Calculating Statistics

To calculate statistics for each On rule band, select Options → Stats for Selected 
Rule Bands.

The band minimum, maximum, mean, and standard deviation are displayed in the 
File Statistics Report window. 

Note
To save the report as an ASCII file, select File → Save Text to ASCII in the report 
window.

Turning Rule Bands On/Off

To turn all of the rule bands on or off without having to click each check box, select 
Options → Select All Rule Bands, or Options → Clear All Rule Bands.

Canceling the Classification

To cancel the Rule Image Classifier Tool at any time, click the Cancel button or 
select File → Cancel.

Warning
Any unsaved changes will be lost and the rule classification image will close.

Saving the Classification Image

To save the displayed classification image to a file, click the Save to File button and 
enter or choose an output filename.
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Calculating Class Statistics

Use Class Statistics to calculate statistics based upon classification results for any 
related input file. Basic statistics include the number of points in a class and 
minimum, maximum, mean, and standard deviation for each band for that class. 
Minimum, maximum, mean, and standard deviation plots can be plotted for each 
class. Histograms for each class can also be reported and plotted and the covariance 
matrix, correlation matrix, and eigenvalues and eigenvectors calculated. A summary 
report for all classes will also be displayed.

1. Select Classification → Post Classification → Class Statistics.

2. When the Classification Input File dialog appears, select a classified image and 
perform any spatial subsetting and/or spectral subsetting using the standard 
ENVI file selection procedures. Only classified images can be selected (based 
upon the file type described in the image’s header).

3. Click OK.

4. When the Statistics Input File dialog appears, select an input file from which to 
calculate the statistics. Select the file that will be used to calculate class 
statistics for the areas identified in the classification image (usually the data 
file). You can also apply a mask to the calculation through the Select Mask 
Band or Build Mask buttons on this dialog.

5. After the input data has been selected, click OK. The Class Selection dialog 
appears.

6. Select the classes that you want to calculate statistics for by clicking on the 
class names in the list.

7. Click OK. The Compute Statistics Parameters dialog appears. 

8. Select the desired statistics options by clicking in the check boxes. See 
“Computing Statistics” in Chapter 5 for detailed information about the options 
available in the Compute Statistics Parameters dialog.

9. Click OK. The class statistics are calculated and the Class Statistics Results 
dialog appears.

The Class Statistics Results dialog is very similar to the Statistics Results dialog (see 
“Producing Statistics Reports” in Chapter 5) and contains the same functionality. 
However, the Class Statistics Results dialog also contains additional sections for 
reporting multiple instances of statistical information.
Post Classification ENVI User’s Guide



Chapter 6: Classification 635
The File pull-down menu contains the following additional options:

• Save current Class result to ENVI stats file... — This option enables you to 
save the statistics report for the class specified in the Stats for section of the 
Class Statistics Results dialog to an ENVI statistics file. When this option is 
selected, the Save Current Class Result to ENVI Stats File dialog appears. In 
the Enter Output Stats Filename[.sta] section of this dialog, use either the 
text box or the Choose button to specify the name of the statistics file. The 
default file extension for ENVI statistics files is .sta. The statistics report is 
saved to the specified file when you click the OK button.

• Save current Class result to text file... — This option enables you to save the 
statistics report for the class specified in the Stats for section of the Class 
Statistics Results dialog to a text file. When this option is selected, the Save 
Current Class Result to Text File dialog appears. In the Enter Output Text 
Filename[.txt] section of this dialog, use either the text box or the Choose 
button to specify the name of the text file. The statistics report is saved to the 
specified file when you click the OK button.

Tip
The resulting text file is tab-delimited for easy import into external 
spreadsheet programs, such as Excel.

• Save all Class results to ENVI stats files... — This option enables you to save 
the statistics reports for all the classes to separate ENVI statistics files. When 
this option is selected, the Save All Class Results to ENVI Stats Files dialog 
appears. In the Enter Output Root Filename section of this dialog, use either 
the text box or the Choose button to specify the root name of the statistics files. 
The default file extension for statistics files is .sta. The statistics report for 
each class or region is saved to individual files when you click the OK button. 
The individual files have the same root name that you specified and are 
appended with their appropriate class or ROI number.

• Save all Class results to text file... — This option enables you to save the 
statistics report for all the classes to a text file. When this option is selected, the 
Save All Class Results to Text File dialog appears. In the Enter Output Text 
Filename[.txt] section of this dialog, use either the text box or the Choose 
button to specify the name of the text file. The statistics report is saved to the 
specified file when you click the OK button.
ENVI User’s Guide Post Classification



636 Chapter 6: Classification
Tip
The resulting text file is tab-delimited for easy import into external 
spreadsheet programs, such as Excel.

If the input file has an associated pixel size (via georeferencing or explicit setting of 
the size in the header file), the Class Summary Area Units submenu appears in the 
Options pull-down menu. This submenu enables you to specify the units of the 
reported area. The default area unit is Meter2. When a different unit is chosen, the 
Class Distribution Summary text section is updated to show this change.

The Stats for pull-down menu button contains a list of the available classes. The 
Class Statistics Results dialog reports the calculated statistics (in both the plot and 
text sections) of the class specified by this menu. To compare statistics for different 
classes with the current class shown in the Class Statistics Results dialog, use the 
Options → Copy results to new window option to create a copy of the Class 
Statistics Results for the current class, then use the Stats for menu to display a 
different class.

The Select Plot pull-down button also contains the following additional options:

• Mean for all Classes — This option displays a plot of the mean of all the 
classes.

• Stdev for all Classes — This option displays a plot of the standard deviation 
of all the classes.

• Eigenvalues for all Classes — This option displays a plot of the eigenvalues 
of all the classes.

• Histogram for all Classes — This option and its submenu display a plot of the 
histogram of all the classes for each band of data.

Calculating Confusion Matrices

Use Confusion Matrix to show the accuracy of a classification result by comparing a 
classification result with ground truth information. ENVI can calculate a confusion 
matrix (contingency matrix) using either a ground truth image or using ground truth 
regions of interest (ROIs). In each case, an overall accuracy, producer and user 
accuracies, kappa coefficient, confusion matrix, and errors of commission and 
omission are reported.
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Using Ground Truth Image

When using a ground truth image, you can also calculate error mask images for each 
class showing which pixels were incorrectly classified. For more information, see the 
following reference:

J. R. Jensen, 1986, Introductory Digital Image Processing, Prentice-Hall, Englewood 
Cliffs, New Jersey, p. 379.

1. Select Classification → Post Classification → Confusion Matrix → Using 
Ground Truth Image.

2. In the Classification Input File dialog, select the classification image and 
perform any spatial subsetting.

3. From the Ground Truth Input File dialog, select the ground truth image and 
perform any spatial subsetting. The Match Classes Parameters dialog appears.

4. Match the ground truth classes with the classification result classes by clicking 
on the matching names in the two lists and clicking Add Combination. The 
class combinations are shown in a list at the bottom of the dialog. If the ground 
truth and classification classes have the same names, they are automatically 
matched.

Note
To remove a class match from the list, click on the combination name. The 
two class names reappear in the lists at the top of the dialog.

5. After all of your class combinations are made, click OK. The Confusion 
Matrix Parameters dialog appears.

6. Next to the Output Confusion Matrix in label, select the Pixels and/or the 
Percent check boxes.

Note
If both are selected, they will be reported in the same window.

7. Next to the Report Accuracy Assessment label, select the Yes or No toggle.
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8. Next to Output Error Images label, click the arrow toggle button to select 
Yes or No.

Note
The output error images are mask images, one for each class, where all 
correctly classified pixels have a value of 0 and incorrectly classified pixels 
have a value of 1. The last error image band shows all the incorrectly 
classified pixels for all the classes combined.

9. Choose output to File or Memory. 

10. Click OK.

Figure 6-15: Confusion Matrix Report
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The report shows the overall accuracy, kappa coefficient, confusion matrix, errors of 
commission (percentage of extra pixels in class), errors of omission (percentage of 
pixels left out of class), producer accuracy, and user accuracy for each class. Producer 
accuracy is the probability that a pixel in the classification image is put into class X 
given the ground truth class is X. User Accuracy is the probability that the ground 
truth class is X given a pixel is put into class X in the classification image. The 
confusion matrix output shows how each of these accuracy assessments is calculated. 
For details, see “Confusion Matrix Example” on page 640. 

Using Ground Truth Regions of Interest

To display a confusion matrix report using regions of interest for ground truth:

1. Select Classification → Post Classification → Confusion Matrix → Using 
Ground Truth ROIs.

2. In the Classification Input File dialog, select the classification image and 
perform any spatial subsetting.

Note
The ground truth ROIs must be opened and associated with an image of the 
same size as the classification output image. The ROIs are automatically 
loaded into the Match Classes Parameters dialog. 

If the ground truth ROIs were defined on an image of a different size, you can 
use Basic Tools → Region of Interest → Reconcile ROIs to make them 
compatible with the classification (see “Reconciling ROIs” on page 307).

3. When the Match Classes Parameters dialog appears, match the ground truth 
ROIs with the classification result classes by clicking on the matching names 
in the two lists and clicking Add Combination. The class combinations are 
shown in a list at the bottom of the dialog. If the ground truth and classification 
classes have the same names, they are automatically matched.

Note
To remove a class match from the list, click on the combination name. The 
two class names reappear in the lists at the top of the dialog.

4. After all of your class combinations are made, click OK. The Confusion 
Matrix Parameters dialog appears.

5. Next to the Output Confusion Matrix in label, select the Pixels and/or the 
Percent check boxes.
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6. Next to the Report Accuracy Assessment label, click the Yes or No toggle.

7. Click OK.

The report shows the overall accuracy, kappa coefficient, confusion matrix, errors of 
commission (percentage of extra pixels in class), errors of omission (percentage of 
pixels left out of class), producer accuracy, and user accuracy for each class. Producer 
accuracy is the probability that a pixel in the classification image is put into class X 
given the ground truth class is X. User Accuracy is the probability that the ground 
truth class is X given a pixel is put into class X in the classification image. The 
confusion matrix output shows how the accuracy assessments are calculated.

Confusion Matrix Example

The following example explains the items calculated for the confusion matrix, 
including the overall accuracy, kappa coefficient, confusion (contingency) matrix, 
errors of commission, errors of omission, producer accuracy, and user accuracy. 
ENVI can calculate a confusion matrix using either a ground truth image or using 
ground truth regions of interest (ROIs) and both produce an output similar to the 
following example.

Confusion Matrix: {M6} (640x400x1) 

Overall Accuracy = (131003/256000)  51.1730%  

Kappa Coefficient = 0.2648

   

Ground Truth 
(Pixels) 

Class Unclassified Grass Forest Swamp Total 

Unclassified 43689 26949 40 18001 88679 

Grass 32835 64516 1741 3329 10242
1 

Forest 8202 7277 4096 654 20229 

Swamp 15227 10742 0 18702 44671 

Total 99953 109484 5877 40686 25600
0 
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Ground Truth 
(Percent) 

Class Unclassified Grass Forest Swamp Total 

Unclassifie
d

43.71 24.61 0.68 44.24 34.64 

Grass 32.85 58.93 29.62 8.18 40.01 

Forest 8.21 6.65 69.70 1.61 7.90  

Swamp 15.23 9.81 0.00 45.97 17.45 

Total 100.00 100.00 100.00 100.00 100.00

Class Commission Omission Commission Omission

(Percent) (Percent) (Pixels) (Pixels)

Unclassified 50.73 56.29 44990/8867
9

56264/999
53 

Grass 37.01 41.07 37905/1024
21

44968/109
44 

Forest 30.32 30.30 6133/20229 1781/5877 

Swamp 58.13 54.03 25969/4467
1

21984/406
86 

Class
Prod. 
Acc.

User Acc. Prod. Acc. User Acc.

(Percent
)

9(Percen
t)

(Pixels) (Pixels)

Unclassified 43.71 49.27 43689/99953 43689/88679

Grass 58.93 62.99 64516/10948
4

64516/10242
1

Forest 69.70 20.25 4096/5877 4096/20229

Swamp 45.97 41.87 18702/40686 18702/44671
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Overall Accuracy

The overall accuracy is calculated by summing the number of pixels classified 
correctly and dividing by the total number of pixels. The ground truth image or 
ground truth ROIs define the true class of the pixels. The pixels classified correctly 
are found along the diagonal of the confusion matrix table which lists the number of 
pixels that were classified into the correct ground truth class. The total number of 
pixels is the sum of all the pixels in all the ground truth classes.

Kappa Coefficient

The kappa coefficient (κ) is another measure of the accuracy of the classification. It is 
calculated by multiplying the total number of pixels in all the ground truth classes (N) 
by the sum of the confusion matrix diagonals (xkk), subtracting the sum of the ground 
truth pixels in a class times the sum of the classified pixels in that class summed over 
all classes ( ), and dividing by the total number of pixels squared minus the sum 
of the ground truth pixels in that class times the sum of the classified pixels in that 
class summed over all classes.

Confusion Matrix (Pixels)

The confusion matrix is calculated by comparing the location and class of each 
ground truth pixel with the corresponding location and class in the classification 
image. Each column of the confusion matrix represents a ground truth class and the 
values in the column correspond to the classification image’s labeling of the ground 
truth pixels. For example, look at the ground truth column for the Forest class in the 
Ground Truth (Pixels) table above. The ground truth shows 5,877 pixels in this class. 
The classification was able to classify 4,096 of these pixels properly but 40 pixels 
were Unclassified and 1,741 were classified as Grass.

Confusion Matrix (Percent)

The Ground Truth (Percent) table shows the class distribution in percent for each 
ground truth class. The values are calculated by dividing the pixel counts in each 
ground truth column by the total number of pixels in a given ground truth class. For 
example, in the Forest class the percent pixels classified correctly is 
4,096/5,877=0.697 or 69.7%.

xκΣxΣκ

κ
N xkk

k
∑ xkΣxΣk

k
∑–

N
2 xkΣxΣk

k
∑–

---------------------------------------------------=
Post Classification ENVI User’s Guide



Chapter 6: Classification 643
Commission

Errors of commission represent pixels that belong to another class that are labelled as 
belonging to the class of interest. The errors of commission are shown in the rows of 
the confusion matrix. In the confusion matrix example, the Grass class has a total of 
102,421 pixels where 64,516 pixels are classified correctly and 37,905 other pixels 
are classified incorrectly as Grass (37,905 is the sum of all the other classes in the 
Grass row of the confusion matrix). The ratio of the number of pixels classified 
incorrectly by the total number of pixels in the ground truth class forms an error of 
commission. For the Grass class the error of commission is 37,905/102,421 which 
equals 37%.

Omission

Errors of omission represent pixels that belong to the ground truth class but the 
classification technique has failed to classify them into the proper class. The errors of 
omission are shown in the columns of the confusion matrix. In the confusion matrix 
example, the Grass class has a total of 109,484 ground truth pixels where 64,516 
pixels are classified correctly and 44,968 Grass ground truth pixels are classified 
incorrectly (44,968 is the sum of all the other classes in the Grass column of the confusion 
matrix). The ratio of the number of pixels classified incorrectly by the total number of 
pixels in the ground truth class forms an error of omission. For the Grass class the 
error of omission is 44,968/109,484 which equals 41.1%.

Producer Accuracy

The producer accuracy is a measure indicating the probability that the classifier has 
labelled an image pixel into Class A given that the ground truth is Class A. In the 
confusion matrix example, the Grass class has a total of 109,484 ground truth pixels 
where 64,516 pixels are classified correctly. The producer accuracy is the ratio 
64,516/109,484 or 58.9%.

User Accuracy

The user accuracy is a measure indicating the probability that a pixel is Class A given 
that the classifier has labelled the pixel into Class A. In the confusion matrix 
example, the classifier has labelled 102,421 pixels as the Grass class and a total of 
64,516 pixels are classified correctly. The user accuracy is the ratio 64,516/102,421 or 
63.0%.
ENVI User’s Guide Post Classification



644 Chapter 6: Classification
Displaying ROC Curves

Use ROC Curves to use Receiver Operating Characteristic (ROC) Curves to 
visualize a classifier’s performance in order to select the proper decision threshold. 
The ROC Curves compare a series of rule image classification results for different 
threshold values with ground truth information. ENVI can calculate a ROC curve 
using either a ground truth image or using ground truth regions of interest (ROIs). A 
probability of detection (Pd) versus probability of false alarm (Pfa) curve and a Pd 
versus threshold curve are reported for each selected class (rule band).

For more information, see the following reference:

A. P. Bradley, 1997, “The use of the area under the ROC Curve in the evaluation of 
machine learning algorithms”, Pattern Recognition, V. 30, No.7, pp 1145-1159.

Using Ground Truth Image

To display a ROC Curve plot using a ground truth image:

1. Select Classification → Post Classification → ROC Curves → Using 
Ground Truth Image. The Rule Input File dialog appears.

2. From this dialog, choose the classification rule image and perform any spatial 
or spectral subsetting. Each band selected in the rule image is used to generate 
a ROC curve. Each rule band is mapped to a ground truth class.

3. From the Ground Truth Input File dialog, select the ground truth image and 
perform any spatial subsetting.

4. When the Match Classes Parameters dialog appears, match the ground truth 
classes with the rule image classes by clicking on the matching names in the 
two lists and clicking Add Combination. The class combinations are 
displayed in a list at the bottom of the dialog. If the ground truth and 
classification classes have the same names, they are matched automatically.

Note
To remove a class match from the list, click on the combination name. The 
two class names reappear in the lists at the top of the dialog.
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5. After all the combinations are made, click OK. The ROC Curve Parameters 
dialog appears.

6. Click the Classify by toggle button to select whether to classify the rule image 
by minimum value or maximum value. For example, if your rule images are 
from the Minimum distance or SAM classifier, classify by minimum value. If 
your rule images are from the Maximum Likelihood classifier, classify by 
maximum value.

7. In the Min and Max parameters text boxes, type minimum and maximum 
values for the ROC curve threshold range. Rule images are classified at N 
(specified by Points per ROC curve) evenly spaced thresholds between (and 
including) the Min and Max values. Each of these classifications is compared 
to the ground truth and becomes a single point on a ROC curve. For example, if 
your rule images are from the maximum likelihood classifier, the best choice is 
to enter a min value of 0 and max value of 1.

8. In the Points per ROC Curve text box, enter the number of points in the ROC 
curves.

9. In the ROC curve plots per window text box, enter the number of plots per 
window.

10. Select whether to output probability of detection versus threshold plot by 
selecting the Yes or No check box.

Figure 6-16: ROC Curve Parameters Dialog
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11. Click OK. The ROC curves and probability of detection curves appear in plot 
windows.

Figure 6-17: ROC Curves Plot Window
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Using Ground Truth Regions of Interest

To display a ROC curve using regions of interest for ground truth:

1. Select Classification → Post Classification → ROC Curves → Using 
Ground Truth ROIs.

2. From the Rule Input File dialog, choose the classification rule image and 
perform any spatial or spectral subsetting. Each band selected in the rule image 
will be used to generate a ROC curve. Each rule band is mapped to a ground 
truth ROI. The ground truth ROIs must be opened and associated with an 
image of the same size as the selected rule image. The ROIs will automatically 
be loaded into the Match Classes Parameters dialog. 

Note
If the ground truth ROIs were defined on an image of a different size, you can 
use Basic Tools → Region of Interest → Reconcile ROIs to make them 
compatible with your rule image (see “Reconciling ROIs” on page 307).

3. When the Match Classes Parameters dialog appears, match the ground truth 
classes with the rule image classes by clicking on the matching names in the 
two lists and clicking Add Combination.

The class combinations are displayed in a list at the bottom of the dialog. If the 
ground truth and classification classes have the same names, they are matched 
automatically.

Note
To remove a class match from the list, click on the combination name. The 
two class names reappear in the lists at the top of the dialog.

4. After all of your class combinations are made, click OK. The ROC Curve 
Parameters dialog appears.

5. Click the Classify by toggle button to select whether to classify the rule image 
by minimum value or maximum value. For example, if your rule images are 
from the Minimum distance or SAM classifier, classify by minimum value. If 
your rule images are from the Maximum Likelihood classifier, classify by 
maximum value.
ENVI User’s Guide Post Classification



648 Chapter 6: Classification
6. In the Min and Max parameters text boxes, type minimum and maximum 
values for the ROC curve threshold range. Rule images are classified at N 
(specified by Points per ROC curve) evenly spaced thresholds between (and 
including) the Min and Max values. Each of these classifications is compared 
to the ground truth and becomes a single point on a ROC curve. For example, if 
your rule images are from the maximum likelihood classifier, the best choice is 
to enter a min value of 0 and max value of 1.

7. In the Points per ROC Curve text box, enter the number of points in the ROC 
curves.

8. In the ROC curve plots per window text box, enter the number of plots per 
window.

9. Select whether to output probability of detection versus threshold plot by 
selecting the Yes or No check box.

10. Click OK. The ROC curves and probability of detection curves appear in plot 
windows.

Figure 6-18: ROC and Probability of Detection Curves
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Generating a Random Sample

It is often helpful to generate a random sampling of points from a classification result, 
or from Regions of Interest. Such samplings can be valuable in supporting 
classification accuracy assessments and field truthing expeditions.

ENVI offers three types of random samplings:

• Stratified Random. This technique, also called proportional or quota random 
sampling, involves dividing the population (the entire classification image or 
all of the ROIs) into homogeneous subgroups (the individual classes or ROIs) 
and then taking a simple random sample in each subgroup. Two types of 
Stratified Random sampling are available: proportionate and disproportionate. 
Proportionate sampling produces sample sizes that are directly related to the 
size of the classes (i.e., the larger the class, the more samples will be drawn 
from it). Disproportionate sampling allows the user to explicitly define each 
sample size.

• Equalized Random. This technique also divides the population into 
homogeneous subgroups (as in Stratified Random) but ensures that each 
class’s (or ROI’s) sample size is exactly the same. That is, the sample size 
remains fixed regardless of class size.

• Random. Random sampling does not divide the population into subgroups but 
instead simply draws a random sampling from the entire (heterogeneous) 
population. For large sample sizes, the distribution of classes (or ROIs) in the 
sample will approximate a Stratified Random sampling, but classes with small 
sizes may be missed altogether in the random sample.

Using the Generate Random Sample Routines

1. From the main ENVI menu select Classification  → Post Classification → 
Generate Random Sample → Using Ground Truth Image or Using 
Ground Truth ROIs. These routines are also found under Basic Tools → 
Statistics.

2. In the File Selection dialog choose either the Classification Image from which 
the sample should be drawn, or (for ROI sampling) the image associated with 
the ROIs. If sampling from a Classification Image, perform any spatial 
subsetting if desired. The class distributions are computed and the Generate 
Random Sample from Ground Truth dialog appears.
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Note
When sampling from a large Classification Image, it may take several 
seconds to compute the class distributions, and a status reporting dialog will 
be displayed.

3. In the dialog window, select the ground truth classes or ROIs you wish to 
include in the sampling and click OK. The Generate Random Sample Input 
Parameters dialog appears.

4. Select the sampling type from the pull-down menu.

For Proportionate Stratified Random Sampling:

• Set the Stratification type radio button to proportionate. 

• Enter the Minimum Sample Size in percent or pixels by clicking the toggle 
button. Entering a value for one will automatically update the value for the 
other, making it easy to see the relationship between the percentage sample 
size and the pixel sample size. The minimum size is one, to ensure that at least 
one pixel is included from the smallest class (or ROI).

• To view the proportionate class sample sizes for the current Minimum Sample 
Size Setting, click on the view class sample sizes button. The Proportionate 
Sample Sizes dialog must be closed before the Generate Random Sample Input 
Parameters dialog becomes active again.

Figure 6-19: Generate Random Sample from Ground Truth Dialog
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• The total sample size is displayed to the left of the view class sample sizes 
button and will update dynamically as new settings are entered.

For Disproportionate Stratified Random Sampling:

• Set the Stratification type radio button to disproportionate.

• To define the sample sizes, click on the set class sample sizes button. The 
Disproportionate Sample Sizes dialog appears.

Figure 6-20: Generate Random Sample Input Parameters Dialog for Stratified 
Random Proportionate Sampling

Figure 6-21: Disproportionate Sample Sizes Dialog
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• Select a class (or ROI) in the list at the top of the dialog. The class (or ROI) 
will show up in the text box at the bottom left of the dialog under the Edit 
Sample Size for Selected Class label.

• In the white box next to the class (or ROI) name at the bottom right of the 
dialog, enter a sample size in pixels. To set the sample size to a percent of 
the total class (or ROI) size, simply enter the percentage value (e.g., 15%) 
and then hit the Enter key on the keyboard. The sample size in pixels will 
automatically be calculated. 

• Click OK when you are finished defining all of the sample sizes.

• The total sample size is displayed to the right of the set class sample sizes 
button.

For Equalized Random Sampling:

• Set the Sample Size in pixels. The minimum value is one and the 
maximum value is equal to the smallest class size (or ROI) in the 
population.

• The total sample size is displayed beneath the Sample Size parameter and 
updates automatically when a new sample size is entered.

Figure 6-22: Generate Random Sample Input Parameters Dialog 
for Stratified Random Disproportionate Sampling
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For Random Sampling:

• Set the Sample Size in pixels or percent by clicking on the toggle button. 
Entering a value for one will automatically update the value for the other, 
making it easy to see the relationship between the percentage sample size 
and the pixel sample size.

• The total sample size is displayed beneath the Sample Size parameter and 
updates automatically when a new sample size is entered.

Figure 6-23: Dialog for Equalized Random Sampling

Figure 6-24: Dialog for Random Sampling
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1. Select output to a Single ROI or Multiple ROIs.

2. The output ROIs containing the random samplings will automatically be saved 
in the ENVI session’s memory. If you also wish to save the ROIs to a file, enter 
a filename.

3. Click OK to start the processing.

A status dialog will report the progress of the processing. If producing a 
Random sampling and some of the classes (or ROIs) are not included in the 
resulting sample, a warning message will be displayed.

Majority/Minority Analysis

Use Majority/Minority Analysis to apply majority or minority analysis to a 
classification image. Use majority analysis to change spurious pixels within a large 
single class to that class. You enter a kernel size and the center pixel in the kernel will 
be replaced with the class value that the majority of the pixels in the kernel has. If you 
select Minority analysis, then the center pixel in the kernel will be replaced with the 
class value that the minority of the pixels in the kernel has.

1. Select Classification → Post Classification → Majority/Minority Analysis.

2. When the file selection dialog appears, select the classification input file and 
any subsetting. The Majority/Minority Parameters dialog appears.

3. In the list of classes, click on the classes that you want to apply the analysis to.

Note
If the center pixel is from a class that was not selected in the Select Classes 
list, that pixel will not be changed. However, center pixels of selected classes 
can be changed into a class that is not selected if the unselected class is the 
majority class in the kernel.

4. Select the analysis method, by clicking the corresponding toggle button.

5. Enter or select a kernel size. Kernel sizes are odd and the kernels do not have to 
be square. Larger kernel sizes produce more smoothing of the classification 
image.
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Note
If you select Majority analysis, enter the Center Pixel Weight. The center 
pixel weight is the weight used to determine how many times the class of the 
center pixel is counted when determining which class is in the majority. For 
example, if you enter a weight of 1, ENVI will count the center pixel class 
only one time; if you enter 5, ENVI will count the center pixel class five 
times.

6. Select output to File or Memory.

7. Click OK.

The resulting file is listed in the Available Bands List.

Clumping Classes

Use Clump Classes to clump adjacent similar classified areas together using 
morphological operators. Classified images often suffer from a lack of spatial 
coherency (speckle or holes in classified areas). Low pass filtering could be used to 
smooth these images, but the class information would be contaminated by adjacent 
class codes. Clumping classes solves this problem. The selected classes are clumped 
together by first performing a dilate operation and then an erode operation on the 
classified image using a kernel of the size specified in the parameters dialog.

1. Select Classification → Post Classification → Clump Classes.

2. When the Classification Input File dialog appears, select a classified image and 
perform any spatial subsetting.

Note
Only classified images can be selected (based upon the file type described in 
the image’s header).

3. Click OK. The Clump Parameters dialog appears with all of the available 
classes in the image in the Select Classes list. 

4. Select the classes on which to perform clumping by clicking on the class 
names in the list.

5. Enter the desired morphological operator size in the Rows and Cols text boxes. 

6. Select output to File or Memory.

7. Click OK to start the processing.
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Sieving Classes

Use Sieve Classes to solve the problem of isolated pixels occurring in classification 
images. Sieving classes removes isolated classified pixels using blob grouping. 
Again, low pass or other types of filtering could be used to remove these areas, but 
the class information would be contaminated by adjacent class codes. The sieve 
classes method looks at the neighboring 4 or 8 pixels to determine if a pixel is 
grouped with pixels of the same class. If the number of pixels in a class that are 
grouped is less than the value that you enter, those pixels will be removed from the 
class. When pixels are removed from a class using sieving, black pixels (unclassified) 
will be left. 

Tip
Use the Clump Classes function (see “Clumping Classes” on page 655) after 
sieving to replace the black pixels. 

1. Select Classification → Post Classification → Sieve Classes.

2. When the Classification Input File dialog appears, select a classified image and 
perform any spatial subsetting using standardized ENVI procedures. 

Note
Only classified images can be selected (based upon the file type described in 
the image’s header). 

3. Click OK. The Sieve Parameters dialog appears with all of the available 
classes in the image listed in the Select Classes list. 

4. Select the classes on which to perform sieving by clicking on the class names 
in the list. 

Note
Any classes not selected for sieving will be passed to the output image 
unchanged.

5. Enter the minimum number of pixels contained in a class group in the Group 
Min Threshold text box.

Note
Any groups of pixels smaller than this value will be removed from the class.
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6. Use the arrow toggle button to select the number of neighboring pixels (4 or 8) 
to look at when determining the number of pixels in a class group. The four-
neighbor region around a pixel consists of the two adjacent horizontal and two 
adjacent vertical neighbors. The eight-neighbor region around a pixel consists 
of all the immediately adjacent pixels. 

7. Select output to File or Memory.

8. Click OK to start the processing.

Combining Classes

Use Combine Classes to selectively combine classes in classified images. You can 
also merge classes using Overlay → Classification from the Display menu in the 
Main Image window (see “Merging Classes” on page 269 for details).

Note
Combining classes or removing the unclassified class effectively deletes those 
individual classes. 

1. Select Classification → Post Classification → Combine Classes.

2. When the Classification Combine Classes dialog appears, select a classified 
image and perform and any spatial subsetting using standard ENVI 
procedures. 

3. After the input classification data has been selected, click OK. The Combine 
Classes Parameters dialog appears.

4. In the Combine Classes Parameters dialog, select a class for input by clicking 
on a name in the Input Classes list. The selected class name appears in the 
Input Class text box.

5. Select an output class by clicking on a class name in the Output Classes list.

6. When both the input and output classes have been selected, click Add 
Combination to finalize the selection. The new, combined class to be created 
are shown in the Combined Classes list at the bottom of the dialog. For 
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example, selecting region 1 as the input and region 3 as the output causes the 
string region 1 -> region 3 to appear in the Combined Classes list. 

Note
To deselect combined classes, click on the name in the Combined Classes 
list.

7. Click OK to combine the contents of the input class into the output class.

8. When the Combine Classes Output dialog appears, select output to File or 
Memory.

A status window appears while the classes are processed. The new classified image 
name is added to the Available Bands List where it can be displayed using standard 
ENVI procedures.

Figure 6-25: Combine Classes Dialog
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Overlaying Classes

Use Overlay Classes to produce an image map with a color composite or grayscale 
background image and the classes overlaid in color. It outputs a three-band RGB 
image that can be displayed using standard ENVI procedures. 

You can also overlay classes using the Overlay menu in the Main Image window. For 
details, see “Overlaying Classes” on page 265.

Note
Due to the nature of the classification overlay, the background image should be 
stretched and saved to byte output images prior to overlay.

1. Select Classification → Post Classification → Overlay Classes.

2. When the Classification Input File dialog appears, select the classification 
image and any spatial subsetting using the standardized ENVI spatial 
subsetting procedures.

3. When the Input Background RGB Input Bands dialog appears, click 
sequentially on the red, green, and blue bands to be used for the background 
image. The input files must be byte images (i.e., files containing values 
between 0 and 255).

Note
If a grayscale background is desired, click on the same spectral band for the 
RGB inputs. 

4. Click OK to continue.

5. When the Class Overlay to RGB Parameters dialog appears, select the desired 
classes to overlay on the background image by clicking on the toggle button 
associated with the class name in the list. 

6. Select output to File or Memory.

7. Click OK to create the class overlay image.

Note
If your display is set to 8-bit color, the class overlay image may appear incorrect 
when displayed due to the color quantization. However, on output, it will be correct.
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Calculating Buffer Zone Images

Use Buffer Zone Image to create a buffer zone image from a classified image. In the 
buffer zone image every pixel has a floating point or integer value that is defined as 
the distance from that pixel to the nearest pixel of the selected class or classes in units 
of pixels. You designate a maximum distance value and the result is that any pixels 
with a distance larger than that value will be set to the maximum distance value. An 
example of a buffer zone image is shown in the following figure.

1. Select Classification → Post Classification → Buffer Zone Image.

2. When the file selection dialog appears, select the input classification file and 
any spatial subsetting. The Buffer Zone Image Parameters dialog appears.

3. In the list of classes, click on the class names to select which class(es) to 
measure the distance to.

Note
If more than one class is selected, the distance will be from the pixel to the 
nearest class.

Figure 6-26: Example of a Buffer Zone Image
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4. Click the Maximum Distance arrow increment buttons to set the maximum 
distance to measure, or type the value (in pixels) into the corresponding text 
box.

Note
Any pixels with a distance larger than this value will be set to the maximum 
distance value. 

5. From the Distance Kernel button menu, select Floating Point or Integer 
output.

6. Select output to File or Memory.

7. Click OK.

Creating Segmentation Images

Use Segmentation Image to create a segmentation image from a classified image. 
Segmentation partitions a classified image into regions of connected pixels or blobs 
of pixels that are contained in the same class. Each connected region is given a 
unique DN value. You can specify the minimum number of pixels that must be 
contained in a region and you can select whether eight or four neighbors are 
considered for the connectivity.

1. Select Classification → Post Classification → Segmentation Image.

2. When the file selection dialog appears, select the input classification file and 
any spatial subsetting. The Segmentation Image Parameters dialog appears.

3. In the list of classes, click on the classes to be used for segmenting the image.

Note
 All the selected classes will be combined before segmenting.

4. In the Population Minimum text box, enter the minimum number of pixels 
that must be contained in a region for it to become a segment.

5. Use the arrow toggle button to designate whether to consider eight or four 
neighboring pixels for the connectivity.

6. Select output to File or Memory.

7. Click OK.

The results appear in the Available Vectors List with each segment having a unique 
DN value.
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Exporting Classes To Vector Layers

To export selected classification classes to vector layers:

1. Select Classification → Post Classification → Classification to Vector.

2. When the Raster to Vector Input Band dialog appears, select the desired input 
classification file and perform any subsetting.

3. When the Raster to Vector Parameters dialog appears, select the desired class 
names to convert to vector polygons by clicking on the class names.

4. Use the arrow toggle button to select whether to output each selected class to a 
separate vector layer or to output all of the classes to a single layer. 

Note
If you output all of the classes to a single layer, attributes that include the 
class number, polygon length, and area will be created for each polygon. 

5. Select output to File or Memory. 

6. Click OK to make a polygon vector layer for each class selected.

If you select to output each class to a separate layer, each selected class is saved to a 
separate vector file with an _1, _2, etc. appended to the root name.
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Transforms
This chapter covers the following topics:
The Transforms Menu . . . . . . . . . . . . . . . .  664
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Color Transforms . . . . . . . . . . . . . . . . . . . .  695

Applying Decorrelation Stretch . . . . . . . .  701
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The Transforms Menu

Use the Transforms menu to access transform functions. Transforms are image 
processing operations that change data to another data space, usually by applying a 
linear function. The goal of most transformations is to improve the presentation of 
information. Transformed images are often more easily interpreted than the original 
data.

Figure 7-1: Transforms Menu
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Image Sharpening

Use Image Sharpening tools to automatically merge a low-resolution color image 
with a high-resolution grayscale image (with resampling to the high-resolution pixel 
size). ENVI has two image sharpening techniques, using an HSV transform, and 
using a color normalization (Brovey) transform. The images must either be 
georeferenced or have the same image dimensions. The RGB input bands for the 
sharpening should be stretched byte data or selected from an open color display. 

Using HSV Sharpening

Use HSV sharpening to transform an RGB image to HSV color space, replace the 
value band with the high-resolution image, automatically resample the hue and 
saturation bands to the high-resolution pixel size using a nearest neighbor, bilinear, or 
cubic convolution technique, and finally transform the image back to RGB color 
space. The output RGB images will have the pixel size of the input high-resolution 
data.

1. Select Transforms → Image Sharpening → HSV.

2. Select the three color bands to transform from either an open color image 
display or from the Available Bands List (for detailed instructions, see “Color 
Transforms” on page 695).

3. When the High Resolution Input File dialog appears, select the high-resolution 
input image and perform any spatial subsetting.

4. Click OK. 

5. When the HSV Sharpening Parameters dialog appears, select the resampling 
method from the Resampling pull-down menu.

6. Select output to Memory or File.

7. Click OK to start the processing. 

The output bands appear in the Available Bands List.
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Using Color Normalized (Brovey) Sharpening

Use Color Normalized (Brovey) sharpening to apply a sharpening technique that 
uses a mathematical combination of the color image and high resolution data. Each 
band in the color image is multiplied by a ratio of the high resolution data divided by 
the sum of the color bands. The function automatically resamples the three color 
bands to the high-resolution pixel size using a nearest neighbor, bilinear, or cubic 
convolution technique. The output RGB images will have the pixel size of the input 
high-resolution data. See the following reference for details:

Vrabel, Jim, 1996, Multispectral Imagery Band Sharpening Study, Photogrammetric 
Engineering & Remote Sensing, Vol. 62, No. 9, pp. 1075-1083.

1. Select Transforms → Image Sharpening → Color Normalized (Brovey).

2. Select the three color bands to transform from either an open color image 
display or from the Available Bands List (for detailed instructions, see “Color 
Transforms” on page 695).

3. When the High Resolution Input File dialog appears, select the high-resolution 
input image and perform any spatial subsetting

4. Click OK.

5. When the Color Normalized Sharpening Parameters dialog appears, select the 
resampling method from the Resampling pull-down menu.

6. Select Memory or File output.

7. Click OK to start the processing. 

The output bands appear in the Available Bands List.

Using Gram-Schmidt Spectral Sharpening

Use Gram-Schmidt Spectral Sharpening to sharpen multispectral data using high 
spatial resolution data. First, a panchromatic band is simulated from the lower spatial 
resolution spectral bands. Second, a Gram-Schmidt transformation is performed on 
the simulated panchromatic band and the spectral bands, where the simulated 
panchromatic band is employed as the first band. Third, the high spatial resolution 
panchromatic band is swapped with the first Gram-Schmidt band. Finally, the inverse 
Gram-Schmidt transform is then applied to form the pan-sharpened spectral bands.

Laben et al., Process for Enhancing the Spatial Resolution of Multispectral Imagery 
Using Pan-Sharpening, US Patent 6,011,875.
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1. Select Transform → Image Sharpening → Gram-Schmidt Spectral 
Sharpening.

Note
The images used must either be georeferenced or have the same image dimensions. 
If the images are georeferenced, ENVI will coregister the images prior to 
performing the sharpening.

2. Select the low resolution, multispectral input file and perform any subsetting, 
as desired.

3. When the High Resolution Input File dialog appears, select the high-resolution 
input image and perform any spatial subsetting.

4. Choose one of the following methods for the low resolution pan:

• Average of Low Resolution Multispectral File — Choosing this method 
allows you to simulate a low resolution panchromatic image by using an 
average of the multispectral bands. When this method is chosen, ENVI 
simulates a panchromatic image for the corresponding sensor.

• Select Input File — This method enables you to choose an existing one-
band image with the spatial dimensions of the multispectral image.

• Create By Sensor Type — Choosing this method reveals a drop-list of all 
instrument-specific panchromatic and multispectral filter functions 
distributed with ENVI: IKONOS, IRS1, Landsat 7, QuickBird, SPOT 5. 
When this method is chosen, ENVI simulates a panchromatic image for 
the selected sensor. This option requires radiometrically calibrated data.

• User Defined Filter Function — Choosing this method opens a file 
selection dialog allowing you to choose a specific filter function to use. 
When this method is chosen, ENVI simulates a panchromatic image for 
the selected filter function. This option requires radiometrically calibrated 
data.

5. When the Gram-Schmidt Spectral Sharpen Parameters dialog appears, select 
the resampling method from the Resampling pull-down menu.

6. Enter an output filename and click OK.

The results will appear in the Available Bands List.
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Using PC Spectral Sharpening

Use PC Spectral Sharpening to sharpen spectral image data with high spatial 
resolution data. A principal components transformation is performed on the 
multispectral data. The PC band 1 is replaced with the high resolution band, which is 
scaled to match the PC band 1 so no distortion of the spectral information occurs. 
Then, an inverse transform is performed. The multispectral data is automatically 
resampled to the high resolution pixel size using a nearest neighbor, bilinear, or cubic 
convolution technique. See the following reference for more details.

Welch, R. and W. Ahlers, 1987. “Merging Multiresolution SPOT HRV and Landsat 
TM Data.” Photogrammetric Engineering & Remote Sensing, 53 (3), pp. 301-303.

1. Select Transform → Image Sharpening → PC Spectral Sharpening.

Note
The images used must either be georeferenced or have the same image dimensions. 
If the images are georeferenced, ENVI will coregister the images prior to 
performing the sharpening.

2. Select the low resolution, multispectral input file and perform any subsetting, 
as desired.

3. When the High Resolution Input File dialog appears, select the high-resolution 
input image and perform any spatial subsetting.

4. When the PC Spectral Sharpen Parameters dialog appears, select the 
resampling method from the Resampling pull-down menu.

5. Enter an output filename and click OK.

The results will appear in the Available Bands List. 
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CN Spectral Sharpening

CN Spectral Sharpening is an extension of the Color Normalized algorithm often 
used to pan sharpen 3-band RGB images. Unlike HSV or Brovey sharpening, CN 
Spectral Sharpening can be used to simultaneously sharpen any number of bands and 
will retain the Input Image’s original data type and dynamic range. For example, the 
CN Spectral Sharpening routine can be used to sharpen hyperspectral data using a 
multispectral image.

CN Spectral Sharpening’s Color Normalized algorithm, also referred to as the Energy 
Subdivision Transform, uses the higher spatial resolution (and lower spectral 
resolution) bands from a Sharpening Image to enhance the lower spatial resolution 
(but higher spectral resolution) bands of the Input Image. Input bands are sharpened 
only if they fall within the spectral range of one of the Sharpening Image’s bands, all 
other Input bands are output unchanged. The spectral range of the Sharpening bands 
are defined by the band center wavelength and full width-half maximum (FWHM) 
value, both obtained from the Sharpening Image’s ENVI header file.

The Input Image’s bands are grouped into spectral segments defined by the spectral 
range of the sharpening bands. The corresponding band segments are processed 
together in the following manner. Each Input band is multiplied by the Sharpening 
band, then normalized by dividing by the sum of the Input bands in the segment:

For additional details, please see the following references:

Vrabel, J., Doraiswamy, P., McMurtrey, J., and Stern, A (2002). 
“Demonstration of the Accuracy of Improved Resolution Hyperspectral 
Imagery”, SPIE Symposium Proceedings.

Vrabel, J., Doraiswamy, P., and Stern, A. (2002). “Application of 
Hyperspectral Imagery Resolution Improvement for Site-Specific Farming”, 
ASPRS 2002 Conference Proceedings.

CN_Sharpened_Band InputBand SharpeningBand Num_Bands_In_Segment( )××

Input_Bands_In_Segment∑( ) Num_Bands_In_Segment( )+
-------------------------------------------------------------------------------------------------------------------------------------------------=
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Input Requirements

• ENVI Header Spectral Information. The Input Image that is being sharpened 
must have wavelengths defined in its header, and the Sharpening Image must 
have both wavelengths and Full Width-Half Maximum (FWHM) defined. 
These spectral data are required because the sharpening can only be applied to 
low spatial resolution (Input) bands that are within the spectral range of the 
high spatial resolution (Sharpening) bands. To define spectral data for an ENVI 
file, use File → Edit ENVI Header → Edit Attributes.

• Coregistration or Georeferencing. Like any sharpening technique, successful 
results require accurate coregistration of the Input and Sharpening images. If 
the Input and Sharpening images are already coregistered then the Input (low 
spatial/high spectra resolution) image must have been resampled so that its 
pixel size matches the Sharpening Image. If the images are not coregistered but 
they are georeferenced, then the CN Sharpening routine will automatically 
coregister the two to use the area common to both, using the map projection of 
the Input Image and the pixel size of the Sharpening Image.

• Data Units. It is also required that the Input and Sharpening Images be in the 
same units (that is, both in reflectance, radiance, DN, and so on). If the 
Sharpening Image does not have the same scale factor as the Input Image, use 
the Sharpening Image Multiplicative Scale Factor box in the input 
parameters to adjust the scaling to match the Input Image.

Using the CN Spectral Sharpening Routine

1. From the main ENVI menu select Transform → Image Sharpening → CN 
Spectral Sharpening, or Spectral → CN Spectral Sharpening. 

Note
The input images must be georeferenced or coregistered, and should be in the 
same units (both in radiance, reflectance, DN, etc.).

2. In the first file selection dialog, select the low spatial resolution (high spectral 
resolution) image you want to sharpen, and perform any spatial subsetting if 
desired.

3. In the second file selection dialog, select the high spatial resolution (low 
spectral resolution) Sharpening Image, and perform any spatial subsetting if 
desired.

The CN Spectral Sharpening Parameters dialog appears.
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4. If necessary, enter a scale factor for the Sharpening Image in the box labeled 
Sharpening Image Multiplicative Scale Factor.

The Sharpening Image must be in the same units and have the same scale 
factor as the Input Image. For example, if the Input Image is an integer 
hyperspectral file calibrated into units of (reflectance * 10000), but the 
Sharpening Image is a floating point multispectral file calibrated into 
reflectance (zero to one), then enter a scale factor of 10,000. If the Input Image 
is in units of radiance of [µW/(cm2 • nm • sr)], but the Sharpening Image is in 
units of radiance of [µW/(cm2 • m • sr)], then enter a scale factor of 0.001.

5. If necessary, select an output interleave.

If the Input and Sharpening Images require resampling or warping to produce a 
coregistered pair, and the Input Image is BIL or BIP interleave, then the 
Output Interleave option will appear. (In all other cases the output interleave 
is the same as the Input Image interleave). Outputting to BSQ is faster, but is 
often inconvenient for further use of the sharpened image.

Note
All in-memory results must be BSQ interleave.

6. Choose output to File or Memory for the CN Sharpening result.

7. Click OK to start the processing.

A status window displays the progress of the operation. When the processing is 
complete the sharpened image appears in the Available Bands List. Bands that were 
sharpened are easily identified by their band names. The units, data type, dynamic 
range, and image geometry match that of the Input Image. The pixel size matches that 
of the Sharpening Image.
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Calculating Band Ratios

Use Band Ratios to enhance the spectral differences between bands and to reduce 
the effects of topography. Dividing one spectral band by another produces an image 
that provides relative band intensities. The image enhances the spectral differences 
between bands. ENVI can output band ratio images in either floating point (decimal) 
format or byte data format, where floating-point format is the default. You may 
combine three ratios into a color-ratio-composite (CRC) image to determine the 
approximate spectral shape for each pixel’s spectrum. 

To calculate band ratios, you must enter a Numerator band and a Denominator 
band. The band ratio is the numerator divided by the denominator. ENVI checks for 
division-by-zero errors and sets them to 0. ENVI also allows you to calculate 
multiple ratios and output them as multiple bands in one file.

1. Select Transforms → Band Ratios.

2. When the Band Ratio Entry dialog appears, select your numerator and 
denominator bands from the list of available bands. The first band you click on 
will be used as the numerator band. The second band you click on will be 
used as the denominator band. 

• To fold a data set, click on the filename of the data set. All of the bands of 
the data set are compressed and the data set appears in the list in this 
format:

+<filename>[number of bands]

• To “unfold” a data set and make its bands available for display, simply 
click the folded filename.
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• To change the bands you have selected, click Clear.

3. Once you have selected the two input bands, click Enter Pair to create a new 
band pair listed in the Selected Ratio Pairs list. Once you select the first pair, 
only bands with the same spatial size appear in the available bands list.

Note
Create as many ratio combinations as needed by entering additional band 
pairs. All ratios in the Selected Ratio Pairs list will be output as multiple 
bands in a single file.

4. Click OK. The Band Ratios Parameters dialog appears.

5. Select from the following options.

Figure 7-2: Band Ratio Input Bands Dialog
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• To select a spatial subset, click Spatial Subset and use the standard ENVI 
spatial subsetting procedures. 

• To output the ratio values as byte data (instead of the default floating-point 
type), select Byte from the Output Data Type button menu. ENVI will 
stretch the output ratio values by mapping the values entered in the Min 
and Max text boxes to 0 to 255.

• To change the byte stretching ratio data range, enter new Min and Max 
values. 

6. Select File or Memory output. 

7. Click OK.

As the ratios are calculated, a status message is displayed. 

When the ratio calculations have concluded, the ratio band names appear in the 
Available Bands List and are available for display.

Creating Complex Band Ratios

Also use Band Ratios to use band ratios in second-tier band ratio calculations.

1. Make the single band ratios as described “Calculating Band Ratios” on 
page 672.

2. Select Transforms → Band Ratios again. 

You may now use the previously-computed set of ratios in a new band ratio.

For example, if you are using Landsat TM data, you could first calculate the 
band 5/band 7 ratio and the band 3/band 1 ratio. ENVI would then allow you to 
calculate a complex ratio of 5/7 divided by 3/1 by selecting the 5/7 ratio from 
the Available Bands List as the numerator and the 3/1 ratio as the denominator. 

3. After selecting a new numerator and denominator, click Enter Pair.

4. Click OK to calculate a new complex ratio. 

The new result is loaded into the Available Bands list. Note that you can also use the 
Band Math function to calculate these kinds of ratios (see Chapter 5, “Basic Tools”).
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Principal Component Analysis

Use Principal Components to produce uncorrelated output bands, to segregate noise 
components, and to reduce the dimensionality of data sets. Because multispectral 
data bands are often highly correlated, the Principal Component (PC) Transformation 
is used to produce uncorrelated output bands. This is done by finding a new set of 
orthogonal axes that have their origin at the data mean and that are rotated so the data 
variance is maximized. 

PC bands are linear combinations of the original spectral bands and are uncorrelated. 
You can calculate the same number of output PC bands as input spectral bands. The 
first PC band contains the largest percentage of data variance and the second PC band 
contains the second largest data variance, and so on The last PC bands appear noisy 
because they contain very little variance, much of which is due to noise in the original 
spectral data. Principal Component bands produce more colorful color composite 
images than spectral color composite images because the data is uncorrelated. ENVI 
can complete forward and inverse PC rotations.

Richards, J.A., 1999. Remote Sensing Digital Image Analysis: An Introduction, 
Springer-Verlag, Berlin, Germany, p. 240.

Calculating Forward PC Rotations

The forward PC rotation uses a linear transform to maximize the variance of the data. 
When you use forward PC rotation, ENVI allows you to calculate new statistics or to 
rotate from existing statistics. The output of either can be saved as byte, floating 
point, integer, long integer, or double precision values. You also have the option to 
subset the output of the PC rotation based on eigenvalues, and to generate output of 
only the PC bands that you need. 

Computing New Statistics and Rotating

Use Compute New Statistics and Rotate to calculate the eigenvalue and covariance 
or correlation statistics for your data and to calculate the forward PC rotation 
transform.

1. Select Transforms → Principal Components → Forward PC Rotation → 
Compute New Statistics and Rotate.

2. When the Principal Components Input File dialog appears, select and subset 
your input file using standard ENVI file selection procedures. The Forward PC 
Rotation Parameters dialog appears.
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Note
Click the Stats Subset button to calculate the statistics based on a spatial 
subset or the area under an ROI. The calculated statistics are applied to the 
entire file or to a spatial subset of the file. For instructions, see “Using 
Statistics Subsetting” on page 678.

3. Enter resize factors less than 1 in the Stats X/Y Resize Factor text boxes to 
sub-sample the data when calculating the statistics.

Note
Enter a resize factor of less than 1 to increase the speed of the statistics 
calculations. For example, using a resize factor of 0.1 will use every 10th 
pixel in the statistics calculations.

4. Enter an output statistics filename, if needed.

5. Select whether to calculate the PCs based on the Covariance Matrix or 
Correlation Matrix using the arrow toggle button.

Note
Typically, use the covariance matrix when calculating the principal 
components. Use the correlation matrix when the data range differs greatly 
between bands and normalization is needed.

6. Select File or Memory output.

7. From the Output Data Type menu, select the desired data type of the output 
file.

8. Select the number of output PC bands. 

You can limit the number of output PC bands, by entering the desired number 
of output bands in the text box or by using the arrow increment button next to 
the Number of Output PC Bands label. The default number of output bands 
is equal to the number of input bands.

You can also select the number of output PC bands using the eigenvalues. To 
do this, perform the following steps.

A. Click the arrow toggle button next to the Select Subset from Eigenvalues 
label to select Yes. The statistics are calculated and the Select Output PC 
Bands dialog appears with each band listed with its corresponding 
eigenvalue. Also listed is the cumulative percentage of data variance 
contained in each PC band for all PC bands. 
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B. Select the number of bands to output by entering a number into the 
Number of Output PC Bands box or by clicking on the arrow buttons. 
PC Bands with large eigenvalues contain the largest amounts of data 
variance. Bands with lower eigenvalues contain less data information and 
more noise. Sometimes, it is best to output only those bands with large 
eigenvalues to save disk space. 

C. Click OK in the Select Output PC Bands dialog. The output PC rotation 
will contain only the number of bands that you selected. For example, if 
you chose “4” as the number of output bands, only the first four PC bands 
will appear in your output file.

9. In the Forward PC Rotation Parameters dialog, click OK.

When ENVI has finished processing, the PC EigenValues plot window appears and 
the PC bands are loaded into the Available Bands List where you may access them 
for display. For information on editing and other options in the eigenvalue plot 
window, see “Using Interactive Plot Functions” on page 387.

Figure 7-3: PC EigenValues Plot Window
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Using a PCA Output Mask

You can apply a mask band to your output results when performing a forward 
principal components (PC) rotation. If a mask is specified for the input file, you can 
select the output value that will be written to masked portions of the output image. 

1. From the main ENVI menu bar, select Transform → Principal 
Components → Forward PC Rotation → Compute New Statistics and 
Rotate.

2. When the file selection dialog appears, select the input file and apply a mask.

3. When the Forward PC Parameters dialog appears, enter a value for the output 
results in the Output Mask Value text box.

The mask is applied for the statistics calculation and the masked areas of the output 
data set are set to the entered mask value.

Using Statistics Subsetting

Use the Stats Subset button to calculate the statistics based on a spatial subset or the 
area under an ROI. The calculated statistics are applied to the entire file or to a spatial 
subset of the file. 

1. In the Forward PC Parameters dialog, click the Stats Subset button.

2. In the Select Statistics Subset dialog, select one of the following options:

• To select a standard image spatial subset, click the Calculate Stats On 
Image Subset button and subset using standard ENVI methods.

• To select a ROI as the subset, click the Calculate Stats On “ROI” button 
to display a list of ROIs, then click on the ROI name to select it.

Tip
To add a previously saved ROI to the list of ROIs, click the Restore ROIs button in 
the subset dialog, select the ROI file, then select the ROI.
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Rotating from Existing Statistics

If you have already calculated covariance and eigenvalue statistics for your data, you 
can use them as input into the PC Rotation. You can use any statistics file in the PC 
rotation that contains covariance and eigen statistics for the same number of bands as 
your input data. (You may have already calculated these statistics using the Basic 
Tools → Compute Statistics option or during a previous PC rotation session.)

Tip
If you need to prevent certain pixels from being used when computing the statistics 
for the Principal Components Analysis rotation, first make a mask of the bad pixels, 
then use Basic Tools → Statistics to compute the covariance statistics on the 
masked image. You can then use this statistics file to do the Principal Components 
Analysis.

1. Select Transforms → Principal Components → Forward PC Rotation → 
PC Rotation from Existing Stats.

Figure 7-4: Select Statistics Subset Dialog for Image Subset Calculation (left) 
and for ROI Calculation (right)
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2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset your input file using the standard ENVI file selection procedures. 
Another file selection dialog appears with all of the existing statistics files in 
the current input data directory listed. The statistics files appear with the 
default file extension .sta.

3. Select the statistics file with standard ENVI file selection procedures. 

4. Select File or Memory output. 

5. From the Output Data Type button menu, select the data type of the output 
file.

6. Select the number of output PC bands. 

You can limit the number of output PC bands, by entering the desired number 
of output bands in the text box or by using the arrow increment button next to 
the Number of Output PC Bands label. The default number of output bands 
is equal to the number of input bands.

You can also select the number of output PC bands using the eigenvalues. To 
do this, perform the following steps.

A. Click the arrow toggle button next to the Select Subset from Eigenvalues 
label to select Yes. The statistics will be calculated and the Select Output 
PC Bands dialog will appear with each band listed with its corresponding 
eigenvalue. Also listed will be the cumulative percentage of data variance 
contained in each PC band for all PC bands. 

B. Select the number of bands to output by entering a number into the 
Number of Output PC Bands box or by clicking on the arrow buttons. 
PC Bands with large eigenvalues contain the largest amounts of data 
variance. Bands with lower eigenvalues contain less data information and 
more noise. Sometimes only those bands with large eigenvalues are output 
to save disk space. 

C. In the Select Output PC Bands dialog, click OK. The output PC rotation 
will contain only the number of bands that you selected. For example, if 
you chose “4” as the number of output bands, only the first four PC bands 
will appear in your output file.

7. In the Forward PC Rotation Parameters dialog, click OK.

When ENVI has finished processing, the PC EigenValues plot window appears and 
the PC bands are loaded into the Available Bands List where you may access them 
for display. For information on editing and other options in the eigenvalue plot 
window, see “Using Interactive Plot Functions” on page 387.
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Inversing PC Rotations

Use Inverse PC Rotation to transform principal component images back into their 
original data space.

1. Select Transforms → Principal Components → Inverse PC Rotation.

2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset your input file using the standard ENVI file selection procedures. 
Another file selection dialog appears with all of the existing statistics files in 
the current input data directory listed. The statistics files appear with the 
default file extension .sta.

3. Select the statistics file saved from the forward PC rotation. 

Note
The statistics file must already exist prior to selecting the inverse PC rotation.

4. Next to the Calculate using label, select either Covariance Matrix or 
Correlation Matrix by clicking the arrow toggle button. 

Note
If you want to inverse the images back to their original data space, select the 
same Calculate... method that you used in the forward rotation. 

5. Select File or Memory output. 

6. From the Output Data Type button menu, select the data type of the output 
file.

7. Click OK to perform the inverse transform.

When ENVI has finished processing, the bands are loaded into the Available Bands 
List where they may be displayed using standard gray-scale or RGB color composite 
methods.
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Minimum Noise Fraction Transform

Use the MNF Rotation (minimum noise fraction) transforms to determine the 
inherent dimensionality of image data, to segregate noise in the data, and to reduce 
the computational requirements for subsequent processing (see Boardman and Kruse, 
1994). The MNF transform as modified from Green et al. (1988) and implemented in 
ENVI, is essentially two cascaded Principal Components transformations. The first 
transformation, based on an estimated noise covariance matrix, decorrelates and 
rescales the noise in the data. This first step results in transformed data in which the 
noise has unit variance and no band-to-band correlations. The second step is a 
standard Principal Components transformation of the noise-whitened data. For the 
purposes of further spectral processing, the inherent dimensionality of the data is 
determined by examination of the final eigenvalues and the associated images. The 
data space can be divided into two parts: one part associated with large eigenvalues 
and coherent eigenimages, and a complementary part with near-unity eigenvalues and 
noise-dominated images. By using only the coherent portions, the noise is separated 
from the data, thus improving spectral processing results. See the references at the 
end of this section for additional details.

Also, use the MNF Transform to remove noise from data by performing a forward 
transform, determining which bands contain the coherent images (by examining the 
images and eigenvalues), and running an inverse MNF transform using a spectral 
subset to include only the “good” bands, or smoothing the noisy bands before the 
inverse.

You have the option to subset the output of the MNF rotation based on eigenvalues, 
which means (with hyperspectral data) that you don’t have to generate an output cube 
of hundreds of bands (floating point) when you only need tens of bands.

ENVI also has the option of applying an MNF transform to individual spectra. This 
function is used to transform endmember spectra into MNF space for input into 
Mixture Tuned Matched Filtering (MTMF). For details see “Matched Filtering 
Results” on page 784.

Note
You can use ENVI’s Spectral Hourglass Wizard to guide you step-by-step through 
the ENVI hourglass processing flow, including MNF Transforms, to find and map 
image spectral endmembers from hyperspectral or multispectral data. For details, 
see “Spectral Hourglass Wizard” on page 809.

For more information about MNF transforms, see the following references:
Minimum Noise Fraction Transform ENVI User’s Guide



Chapter 7: Transforms 683
Green, A. A., Berman, M., Switzer, P., and Craig, M. D., 1988, A transformation for 
ordering multispectral data in terms of image quality with implications for noise 
removal: IEEE Transactions on Geoscience and Remote Sensing, v. 26, no. 1, p. 65-
74. 

Boardman, J. W., and Kruse, F. A., 1994, Automated spectral analysis: a geological 
example using AVIRIS data, north Grapevine Mountains, Nevada: in Proceedings, 
ERIM Tenth Thematic Conference on Geologic Remote Sensing, Environmental 
Research Institute of Michigan, Ann Arbor, MI, pp. I-407 - I-418.

Calculating Forward MNF Transforms

Use Forward MNF transforms to estimate the noise statistics used in the first 
rotation, including estimating the noise from the input data, using noise statistics that 
were calculated previously, or calculating the noise statistics from a dark image 
associated with the data set.

Estimating Noise Statistics from the Data

Use Estimate Noise Statistics From Data to estimate noise when you have no dark 
current image for your data, which is usually the case. ENVI assumes that each pixel 
contains both signal and noise, and that adjacent pixels contain the same signal but 
different noise. A shift difference is performed on the data by differencing adjacent 
pixels to the right and above each pixel and averaging the results to obtain the “noise” 
value to assign to the pixel being processed. The best noise estimate is gathered using 
the shift-difference statistics from a homogeneous area rather than from the whole 
image. ENVI allows you to select the subset for statistics extraction.

1. Select Transforms → MNF Rotation → Forward MNF → Estimate Noise 
Statistics From Data or Spectral → MNF Rotation → Forward MNF → 
Estimate Noise Statistics From Data.

2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset your input file using the standard ENVI file selection procedures. 
The Forward MNF Transform Parameters dialog appears.

Note
Click the Shift Diff Subset button to select a spatial subset or an area under 
an ROI on which to calculate the statistics. You can then apply the calculated 
results to the entire file (or to the file subset if you selected one when you 
selected the input file). For instructions, see “Using Statistics Subsetting” on 
page 686.
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3. In the Enter Output Noise Stats Filename [.sta] text box, enter a filename 
for the noise statistics.

Note
To select a homogeneous area for calculating the noise statistics, click the 
Spatial Subset button and use ENVI’s standard spatial subset procedures to 
either manually enter a subset or to graphically indicate the area for statistics 
extraction (see “Selecting a Spatial Subset” on page 35).

4. In the Enter Output MNF Stats Filename [.sta] text box, enter an output 
file for the MNF statistics.

Note
Be sure that the MNF and noise statistics files have different names.

5. Select File or Memory output. 

6. Select the number of output MNF bands by using one of the following options. 
To select the number of output MNF bands by examining the eigenvalues:

A. Click the arrow toggle button next to the Select Subset from Eigenvalues 
label to select Yes.

B. Click OK to calculate the noise statistics and the first rotation. The 
statistics are calculated and the Select Output MNF Bands dialog appears, 
with each band listed with its corresponding eigenvalue. Also listed is the 
cumulative percentage of data variance contained in each MNF band for 
all bands. 

C. Click the arrow buttons next to the Number of Output MNF Bands label 
to set your desired number of output bands, or enter the number into the 
box.

D. Click OK in the Select Output MNF Bands dialog to complete the 
rotation.

Note
For the best results, and to save disk space, output only those bands with high 
eigenvalues—images with eigenvalues close to 1 are mostly noise. 

Note
To limit the number of output MNF bands without selecting a subset from 
eigenvalues, enter the desired number of output bands or use the arrow 
increment buttons next to the Number of Output MNF Bands label.
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7. Click OK to start the processing.

When ENVI has finished processing, it loads the MNF bands into the Available 
Bands List and displays the MNF EigenValues Plot Window. The output only 
contains the number of bands you selected for output. For example, if your input data 
contained 224 bands, but you selected only 50 bands for output, your output will only 
contain the first 50 calculated MNF bands from you input file.

Bands with large eigenvalues (greater than one) contain data, and bands with 
eigenvalues near one contain noise. Display the EigenImages (MNF bands) from the 
Available Bands List and compare with the MNF EigenValue plot to determine which 
bands contain data and which bands contain predominantly noise. In subsequent 
processing of this data, spectrally subset the MNF bands to only include those bands 
where the images appear spatially coherent and the eigenvalues are above the break 
in slope of the MNF EigenValue plot. In the example shown in the following figure, 
you should only include the first ten to twelve MNF bands.

Figure 7-5: MNF EigenValues Plot Window
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Note
The MNF statistics file does not contain normal data statistics. Only the needed 
statistics are stored in MNF statistics file and the statistics labeled Covariance really 
contain the transpose of the composite transformation array. This produces 
incorrect values in the correlation matrix that should be ignored. The eigenvalues 
and eigenvectors are those for the noise-whitened data (for example, the second 
Principal Components Rotation Statistics from the file that are missing are reported 
as cell zeros).

Using Statistics Subsetting

Use the Shift Diff Subset button to calculate the statistics based on a spatial subset or 
the area under an ROI. The calculated statistics are applied to the entire file or to a 
spatial subset of the file. 

1. In the Forward MNF Transform Parameters dialog, click the Shift Diff Subset 
button. The standard ENVI Select Spatial Subset dialog appears.

2. Select a spatial subset using standard ENVI methods.

Figure 7-6: Forward MNF Transform Parameters Dialog (left) and Standard ENVI 
Spatial Subset Dialog (right)
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Estimating from Previous Noise Statistics

Use Previous Noise Statistics to use noise statistics calculated during a previous 
MNF transformation. This allows you to use noise statistics from one image with a 
second image. 

1. Select Transforms → MNF Rotation → Forward MNF → Previous Noise 
Statistics or Spectral → MNF Rotation → Forward MNF → Previous 
Noise Statistics.

2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset your input file using the standard ENVI file selection procedures. 
Another file selection dialog appears with all of the existing statistics files in 
the current input data directory listed. The statistics files appear with the 
default file extension .sta.

3. Select a noise statistics file from a previous MNF transform processing 
session.

4. The Forward MNF Transform Parameters dialog appears.

5. In the Enter Output MNF Stats Filename [.sta] text box, enter an output 
filename for the MNF statistics.

6. Select File or Memory output. 

7. Select the number of output MNF bands using one of the following options. To 
select the number of output MNF bands by examining the eigenvalues:

A. Click the arrow toggle button next to the Select Subset from Eigenvalues 
label to select Yes.

B. Click OK to calculate the noise statistics and the first rotation. The 
statistics are calculated and the Select Output MNF Bands dialog appears, 
with each band listed with its corresponding eigenvalue. Also listed is the 
cumulative percentage of data variance contained in each MNF band for 
all bands. 

C. Click the arrow buttons next to the Number of Output MNF Bands label 
to set your desired number of output bands, or enter the number into the 
box.

D. In the Select Output MNF Bands dialog, click OK.

E. Click OK to start the processing.
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Note
To limit the number of output MNF bands without selecting a subset from 
eigenvalues, enter the desired number of output bands or use the arrow 
increment buttons next to the Number of Output MNF Bands label:

Note
For the best results, and to save disk space, output only those bands with high 
eigenvalues—images with eigenvalues close to 1 are mostly noise. 

When ENVI has finished processing, the MNF bands are loaded into the Available 
Bands List and the MNF EigenValues Plot Window is displayed. The output only 
contains the number of bands you selected for output. For example, if your input data 
contained 224 bands, but you selected only 50 bands for output, your output will only 
contain the first 50 calculated MNF bands from you input file.

Bands with large eigenvalues (greater than one) contain data, and bands with 
eigenvalues near one contain noise. Display the EigenImages (MNF bands) from the 
Available Bands List and compare with the MNF EigenValue plot to determine which 
bands contain data and which bands contain predominantly noise. In subsequent 
processing of this data, spectrally subset the MNF bands to only include those bands 
where the images appear spatially coherent and the eigenvalues are above the break 
in slope of the MNF EigenValue plot. In the example shown in the following figure, 
you should only include the first ten to twelve MNF bands.

Figure 7-7: MNF EigenValues Plot Window
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Note
The MNF statistics file does not contain normal data statistics. Only the needed 
statistics are stored in MNF statistics file and the statistics labeled Covariance really 
contain the transpose of the composite transformation array. This produces 
incorrect values in the correlation matrix that should be ignored. The eigenvalues 
and eigenvectors are those for the noise-whitened data.

Estimating Noise Statistics from Dark Images

Use Noise Statistics from Dark Image to estimate noise statistics from a “dark 
image.” Some instruments collect a dark image as part of data calibration or 
collection. The dark image is the equivalent of a “photograph with the lens cap on.” 
In electronic instruments, there is still a signal that is actually the noise of the 
instrument. The dark image can be used to characterize the instrument noise.

1. Select Transforms → MNF Rotation → Forward MNF → Noise Statistics 
from Dark Image or Spectral → MNF Rotation → Forward MNF → Noise 
Statistics from Dark Image.

2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset your input file using the standard ENVI file selection procedures. 

3. When the Dark Current Input File dialog appears, select the dark current file 
and perform spatial subsetting as required. The noise statistics are calculated 
using the dark current input file. The Forward MNF Transform Parameters 
dialog appears.

4. In the Enter Output Noise Stats Filename [.sta] text box, enter an output 
file for the noise statistics.

5. In the Enter Output MNF Stats Filename [.sta] text box, enter an output 
file for the MNF statistics.

Warning
Be sure that the MNF and noise statistics files have different names.

6. Select File or Memory output. 
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7. Select the number of output MNF bands by using one of the following options. 
To select the number of output MNF bands by examining the eigenvalues:

A. Click the arrow toggle button next to the Select Subset from Eigenvalues 
label to select Yes.

B. Click OK to calculate the noise statistics and the first rotation. The 
statistics are calculated and the Select Output MNF Bands dialog appears 
with each band listed with its corresponding eigenvalue. Also listed is the 
cumulative percentage of data variance contained in each MNF band for 
all bands. 

C. Click the arrow buttons next to the Number of Output MNF Bands label 
to set your desired number of output bands, or enter the number into the 
box.

D. In the Select Output MNF Bands dialog, click OK.

E. Click OK to start the processing.

Note
To limit the number of output MNF bands without selecting a subset from 
eigenvalues, enter the desired number of output bands or use the arrow 
increment buttons next to the Number of Output MNF Bands label:

Note
For the best results, and to save disk space, output only those bands with high 
eigenvalues—images with eigenvalues close to 1 are mostly noise. 

The MNF EigenValues plot window appears. The output only contains the number of 
bands you selected for output. For example, if your input data contained 224 bands, 
but you selected only 50 bands for output, your output will only contain the first 50 
calculated MNF bands from you input file.
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Bands with large eigenvalues (greater than one) contain data, and bands with 
eigenvalues near one contain noise. Display the EigenImages (MNF bands) from the 
Available Bands List and compare with the MNF EigenValue plot to determine which 
bands contain data and which bands contain predominantly noise. In subsequent 
processing of this data, spectrally subset the MNF bands to only include those bands 
where the images appear spatially coherent and the eigenvalues are above the break 
in slope of the MNF EigenValue plot. In the example shown in the following figure, 
you should only include the first ten to twelve MNF bands.

Note
The MNF statistics file does not contain normal data statistics. Only the needed 
statistics are stored in MNF statistics file and the statistics labeled Covariance really 
contain the transpose of the composite transformation array. This produces 
incorrect values in the correlation matrix that should be ignored. The eigenvalues 
and eigenvectors are those for the noise-whitened data.

Figure 7-8: MNF EigenValues Plot Window
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Inversing MNF Transforms

Use Inverse MNF Transforms to transform the MNF bands back to their original 
data space. 

Tip
Smooth noise-dominated images (higher band numbers) before performing the 
inverse transform or eliminate the noisy bands during the inverse transform using 
spectral subsetting. Smoothing or eliminating noisy bands reduces the noise in the 
original data space. 

1. Select Transforms → MNF Rotation → Inverse MNF Transform or 
Spectral → MNF Rotation → Inverse MNF Transform.

2. When the standard ENVI file selection and subsetting dialogs appear, select 
and subset a previously calculated MNF transform image using the standard 
ENVI file selection procedures.

3. When the Enter Forward MNF Stats Filename dialog appears, enter the name 
of the forward MNF statistics file and click OK.

4. When the Inverse MNF Transform Parameters dialog appears, select File or 
Memory output. 

5. From the Output Data Type menu, select the data type (byte, integer, 
unsigned integer, long integer, unsigned long integer, floating point, double 
precision).

6. Click OK to start the processing. 

The inverse MNF results are loaded into the Available Bands List when the 
processing is complete.
Minimum Noise Fraction Transform ENVI User’s Guide



Chapter 7: Transforms 693
Applying Forward MNFs to Spectra

Use Apply Forward MNF to Spectra to transform endmember spectra into MNF 
space for use in Mixture Tuned Matched Filtering (see “Using Mixture Tuned 
Matched Filtering” on page 785). Use the MNF statistics from the Mixture Tuned 
Matched Filtering input data file for the transform. The spectra to be transformed can 
be collected from plot windows, spectral libraries, ASCII files, ROIs, and statistics 
files using a dialog similar to the endmember collection dialog.

1. Select Transforms → MNF Rotation → Apply Forward MNF to Spectra.

2. When the Forward MNF Statistics Filename dialog appears, select the MNF 
statistics filename that was calculated for the Mixture Tuned Matched Filtering 
input data file. The Forward MNF Convert Spectra dialog appears.

3. Import spectra into the dialog by using the Import menu selections, or by 
dragging and dropping the spectra into the black draw widget at the top of the 
dialog (for detailed instructions, see “By Dragging-and-Dropping Spectra” on 
page 582, “Importing Endmember Spectra” on page 583, and “Endmember 
Options” on page 589).

Note
If you are transforming library spectra into forward MNF space for use as 
endmembers in Mixture Tuned Matched Filtering, the input library spectra 
must be scaled identically to the image for which the MNF statistics are 
being used to do the forward transformation.

4. To delete a spectrum from the dialog, click on the spectrum and click Delete 
Spectrum.

5. Click Apply.

The transformed spectra appear in the Forward MNF Spectra plot window and can be 
input into the Mixture Tuned Matched Filtering Endmember Collection dialog.

Outputting Transformed Spectra

You can print transformed spectral plots or save them as ASCII files, spectral 
libraries, IDL variables, PostScript files, or image files.

• To output plot data, select File → Save Plot As → output type in the MNF plot 
window.

• To print, select File → Print.

For detailed instructions, see “Saving Plot Data” on page 401.
ENVI User’s Guide Minimum Noise Fraction Transform



694 Chapter 7: Transforms
Applying Inverse MNFs to Spectra

Use the Apply Inverse MNF to Spectra to transform MNF spectra back to the 
original data space. Forward MNF statistics from a data file are used for the 
transform. The spectra to be transformed can be collected from plot windows, 
spectral libraries, ASCII files, ROIs, and statistics files using a dialog similar to the 
endmember collection dialog.

1. Select Transforms → MNF Rotation → Apply Inverse MNF to Spectra.

2. When the Forward MNF Statistics Filename dialog appears, select the forward 
MNF statistics filename. The Inverse MNF Convert Spectra dialog appears.

3. Use the Import menu to import spectra into the dialog or by dragging and 
dropping the spectra into the black draw widget at the top of the dialog (for 
detailed instructions, see “By Dragging-and-Dropping Spectra” on page 582, 
“Importing Endmember Spectra” on page 583, and “Endmember Options” on 
page 589).

4. Click Apply.

The transformed spectra appear in the Inverse MNF Spectra plot window.

Outputting Transformed Spectra

You can print transformed spectral plots or save them as ASCII files, spectral 
libraries, IDL variables, PostScript files, or image files.

• To output plot data, select File → Save Plot As → output type in the MNF plot 
window.

• To print, select File → Print.

For detailed instructions, see “Saving Plot Data” on page 401.
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Color Transforms

Use Color Transforms to convert 3-band red, green, blue (RGB) images to one of 
several specific color spaces and from the selected color space back to RGB. 
Adjusting the contrast stretch between the two transforms, you can produce a color-
enhanced color composite image. Additionally, the value or lightness band can be 
replaced by another band (usually of higher spatial resolution) to produce an image 
that merges the color characteristics of one image with the spatial characteristics of 
another image. 

Note
This is done automatically in HSV Sharpening (see “Image Sharpening” on 
page 665).

The color spaces supported by ENVI include the Hue, Saturation, Value (HSV), the 
Hue, Lightness, Saturation (HLS) and the USGS Munsell.

The Munsell color system is used by soil scientists and geologists to characterize the 
color of soils and rocks. This color system has been modified by the U. S. Geological 
Survey to describe color in digital images. The transform converts RGB coordinates 
into the color coordinates Hue, Saturation, and Value (HSV). Hue ranges from 0-360, 
where 0 and 360 = blue, 120 = green, and 240 = red. Saturation ranges from 0 to 208 
with higher numbers representing more pure colors. Value ranges from 
approximately 0 to 512 with higher numbers representing brighter colors. For more 
details, see the following reference:

Kruse and Raines, A technique for enhancing digital color images by contrast 
stretching in Munsell color space, in Proceedings of the ERIM Third Thematic 
Conference, Environmental Research Institute of Michigan, Ann Arbor, MI, 1994: 
pp. 755-760.

Note
Color transforms require three bands for input. These bands should be stretched 
byte data or selected from an open color display. 
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Transforming RGB to HSV

Use RGB to HSV to transform an RGB image into the HSV (hue, saturation, and 
value) color space. The input RGB values must be byte data in the range 0 to 255. An 
input file with at least 3 bands or a color display must be open to execute this 
function. The stretch that is applied in the color display is applied to the input data. 
The hues produced are in the range of 0 to 360 degrees (where red is 0 degrees, green 
is 120 degrees, and blue is 240 degrees) and saturation and value in the range 0 to 1 
(floating-point).

1. Select Transforms → Color Transforms → RGB to HSV.

2. When the RGB to HSV Input dialog appears, select the three bands to 
transform from either a displayed color image or from the Available Bands 
List (for detailed instructions, see “Selecting Bands from Color Displays”). 
The RGB to HSV Parameters dialog appears.

3. Select File or Memory output. 

4. Click OK to start the processing.

A status window appears. When the forward transform is completed, the HSV names 
are entered into the Available Bands List where they can be displayed using standard 
ENVI gray-scale or RGB color composite methods. 

Selecting Bands from Color Displays

1. To select your bands from a color display and use the displayed stretch 
number, select a display number, such as Display #1, from the Input list.

2. To select a spatial subset, click the Spatial Subset button. 

When the Parameters dialog appears, ENVI automatically uses the RGB bands from 
the selected window and lists them in the Input RGB Bands list.

Selecting Bands from the Available Bands List

Note
If you select bands from the Available Bands List, no stretching will be applied and 
all data will be clipped to byte type.

1. In the Input dialog, click Available Bands List. The Input Bands dialog 
appears.

2. In the integrated Available Bands List, click on the three band names to use in 
the forward transform.

• To select a spatial subset, click the Spatial Subset button. 
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• To reset the selections, click Reset.

3. Click OK. The Parameters dialog appears.

Transforming RGB to HLS

Use RGB to HLS to transform an RGB image into the HLS (hue, lightness, 
saturation) color space. The hues produced are in the range of 0 to 360 degrees 
(where red is 0 degrees, green is 120 degrees, and blue is 240 degrees) and lightness 
and saturation in the range 0 to 1 (floating-point). An input file with at least 3 bands 
or a color display must be open to execute this function. The input RGB values must 
be byte data in the range 0 to 255.

1. Select Transforms → Color Transforms → RGB to HLS.

2. When the RGB to HLS Input dialog appears, select the three bands to 
transform from either a displayed color image or from the Available Bands 
List (for detailed instructions, see “Selecting Bands from Color Displays” on 
page 696).

3. Select File or Memory output. 

4. Click OK to start the processing.

A status window displays the progress of the operation. When the forward transform 
is complete, the HLS names are entered into the Available Bands List where they can 
be displayed using standard ENVI gray-scale or RGB color composite methods. 

Transforming RGB to USGS Munsell HSV

Use USGS Munsell RGB to HSV to transform an RGB image into the USGS 
Munsell HSV color space.

1. Select Transforms → Color Transforms → RGB to HSV (USGS Munsell).

Note
The ENVI user function MUNSELL.PRO is automatically loaded and 
executed.

2. When the USGS Munsell RGB to HSV Input File dialog appears, click 
sequentially on the three bands to load as RGB.

• To select a spatial subset, click the Spatial Subset button.

• To reset the selections, click Reset

3. Click OK to continue.
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4. When the Munsell HSV Output dialog appears, select File or Memory output.

5. Click OK to start the processing.

When the transform is complete, the bands appear in the Available Bands List.

Transforming HSV to RGB

Use HSV to RGB to transform an HSV image back to the RGB color space. The 
input H, S, and V bands must have the following data ranges: Hue = 0 to 360, where 
0 and 360 = blue, 120 = green, and 240 = red; saturation ranges from 0 to 208 with 
higher numbers representing more pure colors; value ranges from approximately 0 to 
512 with higher numbers representing brighter colors. The RGB values produced are 
byte data in the range 0 to 255. 

1. Select Transforms → Color Transforms → HSV to RGB.

2. When the HSV to RGB Input dialog appears, select bands to transform from 
the integral Available Bands List by clicking on appropriate band names. The 
names of the bands appear in the H, S, and V, text boxes for hue, saturation, 
and value.

Note
To spatially subset your data, click the Spatial Subset button.

3. Click OK.

4. When the HSV to RGB Parameters dialog appears, select File or Memory 
output.

5. Click OK.

A status window appears. When the reverse transform is complete, the RGB names 
appear in the Available Bands List. 
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Transforming HLS to RGB

Use the HLS to RGB to transform an HLS (hue, lightness, saturation) image back to 
the RGB color space. The input H, S, and L bands must have the following data 
ranges: hues in the range of 0 to 360 degrees (where red is 0 degrees, green is 120 
degrees, and blue is 240 degrees) and lightness and saturation in the range 0 to 1 
(floating-point). The RGB values produced are byte data in the range 0 to 255. 

1. Select Transforms → Color Transforms → HLS to RGB.

2. When the HLS to RGB Input dialog appears, select bands to transform by 
clicking on the appropriate band names. The names of the bands appear in the 
H, L, and S, text boxes for hue, lightness, and saturation.

Note
To spatially subset your data, click the Spatial Subset button. 

3. Click OK to continue.

4. When the HLS to RGB Parameters dialog appears, select File or Memory 
output. 

5. Click OK.

A status window appears. When the reverse transform is complete, the RGB names 
appear in the Available Bands List.
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Transforming USGS Munsell HSV to RGB

Use USGS Munsell HSV to RGB to transform a USGS Munsell HSV image into the 
RGB color space. The input H, S, and V bands must have the following data ranges: 
Hue = 0 to 360, where 0 and 360 = blue, 120 = green, and 240 = red; saturation 
ranges from 0 to 208 with higher numbers representing more pure colors; value 
ranges from approximately 0 to 512 with higher numbers representing brighter 
colors. The RGB values produced are byte data in the range 0 to 255.

1. Select Transforms → Color Transforms → HSV to RGB (USGS Munsell). 
The ENVI user function MUNSELL.PRO is automatically loaded and executed.

2. When the USGS Munsell HSV to RGB Input File dialog appears, click 
sequentially on the three bands to load as HSV.

• To spatially subset your data, click the Spatial Subset button. 

• To reset the selections, click the Reset button.

3. Click OK.

4. When the Munsell RGB Output dialog appears, select File or Memory output.

5. Click OK to start the processing.

When the transform is complete, the bands appear in the Available Bands List.
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Applying Decorrelation Stretch

Use Decorrelation Stretch to remove the high correlation commonly found in 
multispectral datasets and to produce a more colorful color composite image. The 
highly correlated data sets often produce quite bland color images. Decorrelation 
stretching requires three bands for input. These bands should be stretched byte data 
or may be selected from an open color display.

Note
Similar results to decorrelation can be obtained by using a sequence of forward 
Principal Components (PC), contrast stretching, and inverse PC transforms.

1. Select Transforms → Decorrelation Stretch.

2. When the Decorrelation Stretch Input dialog appears, select three bands for 
input from either an open color image display or from the Available Bands List 
(for detailed instructions, see page “Selecting Bands from Color Displays” on 
page 696). The Decorrelation Stretch Parameters dialog appears.

3. Select either File or Memory output. 

4. Click OK to start the decorrelation processing.

A status message appears while each band is calculated. When processing is 
complete, the decorrelation stretch names are entered into the Available Bands List.
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Applying Photographic Stretch

Use Photographic Stretch to enhance the color of a True Color input image to 
produce an RGB image that correspond well to the response of the human eye. These 
results look more like realistic color photos. The bands of the True Color input image 
are nonlinearly scaled and then co-added to produce this stretch.

1. Select Transform → Photographic Stretch.

2. When the Photographic Stretch Input dialog appears, select three bands for 
input from either an open color image display or from the Available Bands List 
(for detailed instructions, see page “Selecting Bands from Color Displays” on 
page 696). The Photographic Stretch Parameters dialog appears.

3. Select either File or Memory output. 

4. Click OK to start the decorrelation processing. A status message appears while 
each band is calculated. When processing is complete, the photographic stretch 
names are entered into the Available Bands List.

5. Show the resulting RGB bands in a new Display.
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Applying Saturation Stretch

Use Saturation Stretch to enhance the color of a 3-band input image by producing 
output bands that have more saturated colors. The input data are transformed from 
red, green, and blue (RGB) space to hue, saturation, and value (HSV) space. A 
gaussian stretch is performed on the saturation band so the data fills the entire 
saturation range. The HSV data are then automatically transformed back to RGB 
space.

Saturation stretching requires 3 bands for input. These bands should be stretched byte 
data or selected from an open color display.

1. Select Transforms → Saturation Stretch.

2. When the Saturation Stretch Input dialog appears, select three bands for input 
from an open color image display or from the Available Bands List (for 
detailed instructions, see “Selecting Bands from Color Displays” on page 696).

3. Select either File or Memory output. 

4. Click OK to start the decorrelation processing.

A status message appears while each band is calculated. When complete, the 
saturation stretch names are entered into the Available Bands List.
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Creating Synthetic Color Images

Use the Synthetic Color Image transform to transform a grayscale image into a 
synthetic color image. ENVI changes the grayscale image into a color image by 
applying high pass and low pass filters to the image to separate high and low 
frequency information. Low frequency information is assigned to the hue, and high 
frequency information is assigned to the value, and a fixed saturation level is used. 
These hue, saturation, and value (HSV) data are transformed into red, green, and blue 
(RGB) space, producing a color image.

This transform is often used with radar data to improve the display of subtle large-
scale features while retaining fine detail. It works best for areas with low to moderate 
topographical relief. In radar images, it is often difficult to see low frequency 
variations because of high frequency features from small scale topography. Low 
frequency information is usually due to surface scattering variations from lithology or 
vegetation. See the following reference for more information:

Daily, M., 1983, Hue-saturation-intensity split-spectrum processing of Seasat radar 
imagery, Photogrammetric Engineering and Remote Sensing, Vol. 49, No. 3, pp. 349-
355.

1. Select one of the following options:

• Select Transforms → Synthetic Color Image.

• Select Radar → Synthetic Color Image.

2. When the file selection dialog appears, select the input band and perform any 
spatial subsetting.

3. When the Synthetic Color Parameters dialog appears, select the kernel size for 
the high and low pass filters by using the arrow increment buttons next to the 
High Pass Kernel Size and Low Pass Kernel Size labels. The high pass 
kernel size should be the number of pixels corresponding to the size of the high 
frequency slope-dominated scattering. The low pass kernel size should be the 
number of pixels corresponding to the size of the low frequency diffuse 
scattering.

4. Enter a saturation value from 0 to 1. Higher saturation values will produce 
more saturated or pure colors.
Creating Synthetic Color Images ENVI User’s Guide



Chapter 7: Transforms 705
5. Select File or Memory output.

6. Click OK to start the transform.

The transform process is reported in the Synthetic Color Processing dialog and the 
resulting synthetic color image bands are available for display from the Available 
Bands List.
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Calculating Vegetation Indices

Use the NDVI and Tassled Cap transforms to calculate vegetation indices from data. 

Using NDVI

Use the NDVI (Vegetation Index) to transform multispectral data into a single image 
band representing vegetation distribution. The NDVI (Normalized Difference 
Vegetation Index) values indicate the amount of green vegetation present in the 
pixel—higher NDVI values indicate more green vegetation. ENVI’s NDVI uses the 
standard algorithm: 

Valid results fall between -1 and +1. ENVI has pre-set bands for AVHRR, Landsat 
MSS, Landsat TM, SPOT, or AVIRIS data or you can enter the bands to use for other 
data types. For more information, see the following reference: 

Jensen, J. R., 1986. Introductory Digital Image Processing, Prentice-Hall, New 
Jersey, p. 379.

1. Select Transforms → NDVI (Vegetation Index).

2. When the NDVI Calculation Input File window appears, select the input file 
and perform any subsetting. 

NDVI
NIR Red–
NIR Red+
--------------------------- 

 =
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3. Click OK.

4. In the NDVI Calculation Parameters dialog, specify the input file type (TM, 
MSS, AVHRR, and so on) from the Input File Type pull-down menu. The 
bands used to calculate the NDVI are automatically entered into the Red and 
Near IR text boxes.

Note
To calculate the NDVI for a sensor type not listed in the pull-down menu, 
enter the desired band numbers in the Red and Near IR text boxes.

5. From the Output Data Type button menu, select either Byte or Floating 
Point output. 

• If you select byte output, enter the minimum NDVI value. This value will 
be set to zero.

• If you select floating-point output, enter the maximum value. This value 
will be set to 255.

6. Select File or Memory output.

Figure 7-9: NDVI Calculation Parameters Dialog
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7. Click OK.

A status message appears while the transform is calculated. When complete, ENVI 
enters the NDVI band name into the Available Bands List. 

Using Tasseled Cap

Use Tassled Cap to transform Landsat MSS data, Landsat TM data, or Landsat 7 
ETM data. For Landsat MSS data, the tassled cap transform performs an orthogonal 
transformation of the original data into a new four-dimensional space consisting of 
the soil brightness index (SBI), the green vegetation index (GVI), the yellow stuff 
index (YVI), and a non-such index (NSI) associated with atmospheric effects. For 
Landsat TM data, the tasseled cap vegetation index consists of three factors: 
Brightness, Greenness, and Third. The Brightness and Greenness are equivalent to 
the MSS tasseled cap SBI and GVI indices and the third component is related to soil 
features, including moisture status. For Landsat 7 ETM data, the tasseled cap 
transformation produces 6 output bands: Brightness, Greenness, Wetness, Fourth 
(Haze), Fifth, Sixth. This type of transformation should be applied to calibrated 
reflectance data rather than applying to raw digital number imagery.

For more information, see the following references:

Jensen, J. R., 1986. Introductory Digital Image Processing, Prentice-Hall, New 
Jersey, p. 379.

Crist, E.P. and R.C. Cicone, 1984 “Application of the Tasseled Cap Concept to 
Simulated Thematic Mapper Data,” Photogrammetric Engineering and Remote 
Sensing, Vol. 50, pp. 343-352.

Kauth, R.J., P.F. Lambeck, W. Richardson, G.S. Thomas, and A.P. Pentland, 1979. 
“Feature Extraction Applied to Agricultural Crops as Seen by Landsat,” Proceedings, 
LACIE Symposium, Houston TX, NASA, pp. 705-721.

Huang, C., B. Wylie, L. Yang, C. Homer, and G. Zylstra. “Derivation of a Tasseled 
Cap Transformation Based on Landsat 7 At-Satellite Reflectance”. USGS EROS 
Data Center White Paper (http://landcover.usgs.gov/pdf/tasseled.pdf).

1. Select Transforms → Tassled Cap.

2. When the Tasseled Cap Transformation Input File dialog appears, select the 
input file and perform any subsetting.

3. Click OK. The Tasseled Cap Transform Parameters dialog appears.

4. From the Input File Type button menu, select Landsat TM, Landsat MSS, 
or Landsat 7 ETM.
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5. Select File or Memory output. 

6. Click OK.

A status message appears while the Tassled Cap transform is calculated. When 
complete, ENVI enters the tasseled cap band names into the Available Bands List.
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Filters
This chapter covers the following topics:
The Filter Menu . . . . . . . . . . . . . . . . . . . . .  712
Convolution Filters  . . . . . . . . . . . . . . . . . .  713
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Using Texture Filters  . . . . . . . . . . . . . . . .  723
Using Adaptive Filters  . . . . . . . . . . . . . . .  728
Using Frequency Filters (FFTs) . . . . . . . .  737
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The Filter Menu

Use the Filter menu to perform Convolution, Morphological, Texture, Adaptive, and 
FFT filtering. Filtering is typically used to enhance images by removing certain 
spatial frequencies. Spatial frequency describes the variation of brightness, or DN, 
with distance, and images contain many different spatial frequencies. For example, 
removing the high frequency variation in an image produces a smoother output 
image. 

Use Convolution filtering to filter your image in the spatial domain. Use 
Morphological filters to process your image on the basis of shape. Use texture filters 
to extract information about the textures in your image. Use Adaptive filters to reduce 
noise by smoothing while preserving sharp edges. Use Fourier Filtering to filter your 
data in the frequency domain. 

Figure 8-1: Filter Menu
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Convolution Filters

Use Convolutions and Morphology to apply convolution filters to image data. 
Convolution filter types in ENVI include the following: high pass, low pass, 
Laplacian, directional, Gaussian High Pass, Gaussian Low Pass, median, Sobel, 
Roberts, and user-defined. Each filter type is described in this section. For detailed 
instructions, see “Using Convolution Filters” on page 715.

High Pass Filters

High pass filtering removes the low frequency components of an image while 
retaining the high frequency (local variations). It can be used to enhance edges 
between different regions as well as to sharpen an image. This is accomplished using 
a kernel with a high central value, typically surrounded by negative weights. ENVI’s 
default high pass filter uses a 3 x 3 kernel with a value of 8 for the center pixel and 
values of -1 for the exterior pixels. High pass filters can only have odd kernel 
dimensions.

Low Pass Filters 

Low pass filtering preserves the low frequency components of an image, which 
smooths it. ENVI’s low pass filter contains the same weights in each kernel element, 
replacing the center pixel value with an average of the surrounding values. The 
default kernel size is 3 x 3.

Laplacian Filters

A Laplacian filter is a second derivative edge enhancement filter that operates without 
regard to edge direction. Laplacian filtering emphasizes maximum values within the 
image by using a kernel with a high central value typically surrounded by negative 
weights in the north-south and east-west directions and zero values at the kernel 
corners. ENVI’s default Laplacian filter uses a 3 x 3 kernel with a value of 4 for the 
center pixel and values of -1 for the north-south and east-west pixels. All Laplacian 
filters must have odd kernel sizes. 
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Directional Filters

A directional filter is a first derivative edge enhancement filter that selectively 
enhances image features having specific direction components (gradients). The sum 
of the directional filter kernel elements is zero. The result is that areas with uniform 
pixel values are zeroed in the output image, while those that are variable are 
presented as bright edges. 

Gaussian Filters

A Gaussian filter passes a Gaussian convolution function of specified size over the 
image. The default is a 3 x 3 kernel and kernel dimensions must be odd. 

Median Filters

Median filtering smooths an image, while preserving edges larger than the kernel 
dimensions (good for removing salt and pepper noise or speckle). ENVI’s Median 
filter replaces each center pixel with the median value (not to be confused with the 
average) within the neighborhood specified by the filter size. The default is a 3 x 3 
kernel. 

Sobel Filters

The Sobel filter is a non-linear edge enhancement, special case filter that uses an 
approximation of the true Sobel function, and is a preset 3 x 3, non-linear edge 
enhancement operator. The size of the filter cannot be changed and no kernel editing 
is possible.

Roberts Filters

The Roberts filter is a non-linear edge detector filter similar to the Sobel. It is a 
special case filter that uses a preset 2 x 2 approximation of the true Roberts function, 
a simple, two dimensional differencing method for edge-sharpening and isolation. 
The size of the filter cannot be changed and no kernel editing is possible. 

User-Defined Convolution Filters

You can define custom convolution kernels (including rectangular rather than square 
filters) by selecting and editing a user kernel.
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Using Convolution Filters

Convolution filters produce output images in which the brightness value at a given 
pixel is a function of some weighted average of the brightness of the surrounding 
pixels. Convolution of a user-selected kernel with the image array returns a new, 
spatially filtered image. You can select the kernel size and values, producing different 
types of filters. Standard filters include high pass, low pass, Laplacian, directional, 
Gaussian, median, Sobel, Roberts, and user-defined. For descriptions of each filter 
type, see “Convolution Filters” on page 713.

1. Select Filter → Convolutions and Morphology.

The Convolutions and Morphology Tool dialog appears (see Figure 8-2).

2. Select Convolutions → filter type (the filter types are described in 
“Convolution Filters” on page 713).

• If you select the Directional filter, enter the filter angle when the 
Directional Filter Angle dialog appears. 

North (up) is zero degrees and the other angles are measured in the 
counterclockwise direction.

3. Specify the kernel size by clicking the Kernel Size arrow increment buttons.

Note
Some specialized filters have default sizes that can not be changed. If you select 
filter types such as Sobel and Roberts, you cannot change the kernel size. 

The kernel sizes are in odd-number increments. Clicking with the left mouse 
button increases/decreases the value by 2, clicking with the middle mouse 
button increases/decreases value by 10, and clicking with the right mouse 
button sets the kernel size back to 3 x 3.

By default, the kernel size is set to a square kernel.

• To change to a non-square kernel, select Options → Square kernel:No.

Note
The Low Pass (average) and Median filters are always square.

• To edit individual kernels, see the next section.
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4. Enter an add back value in the Image Add Back (0-100%) text box. 

Adding back part of the original image to the convolution filter results helps 
preserve the spatial context and is typically done to sharpen an image. The 
Image Add Back value is the percentage of the original image that is included 
in the final output image. For example, if you enter 40%, then 40% of the 
original image is added to 60% of the convolution filter image to produce the 
final result.

5. Select an Apply method as described in “Applying Convolution and 
Morphology Filters” on page 721.

Figure 8-2: Convolution and Morphology Tool Dialog
Convolution Filters ENVI User’s Guide



Chapter 8: Filters 717
Editing Kernels

To edit the selected kernel and change any of the weight values:

1. In the Convolutions and Morphology Tool, double-click within the text box of 
the value to be edited.

The line cursor appears.

2. Highlight the value, enter a new value, and press the Return key.

Saving Kernels to Files

1. Select File → Save Kernel.

2. When the Output Kernel to File dialog appears, enter or select an output 
filename. Use the extension .ker.

3. Click OK.

Restoring Saved Kernel Files

1. Select File → Restore Kernel.

2. Select the saved kernel file.
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Morphology Filters

Use Convolutions and Morphology to apply morphological filters to image data. 
Morphology filter types in ENVI include the following: Erode, Dilate, Opening, and 
Closing. Each filter type is described in this section. For detailed instructions, see 
“Using Morphology Filters” on page 719.

Dilate Filters

Dilate filters, commonly known as fill, expand, or grow, fills holes smaller than the 
structural element (kernel) in a binary or grayscale image.

Erode Filters

The Erode filter, commonly known as shrink or reduce, removes islands of pixels 
smaller than the structural element (kernel) in a binary or grayscale image.

Opening Filters

Opening filters smooth the contours, break narrow isthmuses, and eliminate small 
islands and sharp peaks or capes in an image. The opening of an image is defined as 
the erosion of the image followed by subsequent dilation using the same structural 
element. 

Tip
Using the Erode filter followed by using the Dilate filter produces the same result as 
using an Opening filter.

Closing Filters

Closing filters smooth the contours, fuse narrow breaks and long thin gulfs, eliminate 
small holes, and fill gaps in the contours of an image. The closing of an image is 
defined as the dilation of the image followed by subsequent erosion using the same 
structural element.

Tip
Using the Dilate filter followed by using the Erode filter produces the same result as 
using the Closing filter.
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Using Morphology Filters

Mathematical morphology filtering is a non-linear method of processing digital 
images on the basis of shape. Its primary goal is the quantification of geometrical 
structures. A detailed discussion of this topic is beyond the scope of this manual. For 
additional information, see the following reference:

Haralick, Sternberg, and Zhuang, Image Analysis Using Mathematical Morphology, 
IEEE Transactions on Pattern Analysis and Machine Intelligence, Vol. PAMI-9, No. 
4, July 1987, pp. 532-550.

Morphology filter types include the following: Erode, Dilate, Opening, and Closing. 
For descriptions of each filter type, see “Morphology Filters” on page 718. There are 
several predefined morphological kernels.

Note
Morphological kernels used here are just the structuring element and should not to 
be confused with convolution kernels.

1. Select Filter → Convolutions and Morphology.

The Convolutions and Morphology Tool dialog appears (see Figure 8-3).

2. Select Morphology → filter type (the filter types are described beginning on 
page 718). 

3. Specify the kernel size by clicking the Kernel Size arrow increment buttons.

The kernel sizes are in odd-number increments. Clicking with the left mouse 
button increases/decreases the value by 2, clicking with the middle mouse 
button increases/decreases value by 10, and clicking with the right mouse 
button sets the kernel size back to 3 x 3.

By default, the kernel size is set to a square kernel.

• To change to a non-square kernel, select Options → Square kernel:No.

• To edit individual kernels, see “Editing Kernels” on page 717.

4. Select the number of iterations of the filter by clicking the Cycles arrow 
increment buttons.

5. Select a filter style of Binary, Gray, or Value.
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Binary produces output pixels in either black or white. Gray preserves 
gradients. Value allows the kernel value to be either added (dilate) or 
subtracted (erode) from the selected pixels.

6. Select an Apply method as described in “Applying Convolution and 
Morphology Filters” on page 721.

A status message appears. If no image tiling is required, the status message does not 
advance gradually. It goes abruptly from 0 to 100% after a short wait because the 
operation is being performed on the entire image array. When completed, the filtered 
image is added to the top of the Available Bands List and can be displayed using 
standard ENVI procedures.

Figure 8-3: Convolutions and Morphology Tool Dialog
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Applying Convolution and Morphology Filters

You can apply your filter results to a temporary display or to an existing file. Use the 
Quick Apply method to try different filter parameters and to view the filter results 
quickly; use the Apply to File method to apply the final result to a specific image file 
and to output the result.

Viewing Filter Results Quickly

In the Convolutions and Morphology Tool dialog, use the Quick Apply button to 
examine the results of the filter quickly. You can make changes if needed and re-
display the image.

1. Click the Quick Apply button to apply the selected filter to a single image 
band.

2. In the Convolution Quick-Apply Input Band dialog, select the input band and 
any subsetting.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

The resulting file appears in a display window. The file displayed is a 
temporary file placed in the default temporary ENVI directory (see “Setting 
ENVI Preferences” on page 174). The display window and the file are 
automatically deleted when the Convolutions and Morphology Tool dialog is 
closed.

• If you change any parameters in the Convolutions and Morphology Tool 
dialog, click the Quick Apply button again.

The new parameters overwrite the existing results.
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Changing the Quick Apply Input Band

To change the band used for the Quick Apply output:

1. In the Convolutions and Morphology Tool dialog, select Options → Change 
Quick-Apply Input Band.

2. In the file selection dialog, select the input band and any subsetting.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

Saving Quick Apply Results

To save the Quick Apply image result to a file:

1. Select File → Save Quick Result to File.

2. When the Output Convolution Filename dialog appears, enter an output 
filename.

3. Click OK.

Applying Filters to Files

In the Convolutions and Morphology Tool dialog, use the Apply to File button to 
apply the current filter to a file and to output the results. 

1. Click the Apply to File button.

2. When the file selection dialog appears, select the input file and any subsetting.

3. Click OK.

The Convolution Parameters dialog appears.

4. Select output to File or Memory.

The resulting file is listed in the Available Bands List.
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Using Texture Filters

Use Texture to apply occurrence- or co-occurrence-based texture filters. Many 
images contain regions characterized by variation in brightness rather than any 
unique value of brightness. Texture refers to the spatial variation of image tone as a 
function of scale. To be defined as a distinct textural area, the gray levels within the 
area must be more homogeneous as a unit than areas having a different texture. ENVI 
supports several textural filters based on either occurrence measures or co-occurrence 
measures. 

Applying Occurrence-Based Filters

Use Occurrence Measures to apply any of five different texture filters that are based 
on occurrence measures. The occurrence filters available are data range, mean, 
variance, entropy, and skewness. Occurrence measures use the number of 
occurrences of each gray level within the processing window for the texture 
calculations. See the following reference for more information:

Anys, H., A. Bannari, D. C. He, and D. Morin, 1994. “Texture analysis for the 
mapping of urban areas using airborne MEIS-II images”, Proceedings of the First 
International Airborne Remote Sensing Conference and Exhibition, Strasbourg, 
France, Vol. 3, pp. 231-245.

1. Select Filter → Texture → Occurrence Measures.

The Texture Input File dialog appears.

2. Select an input file or band (see “Selecting Bands or Files for Processing” on 
page 33).

• To select a subset, click the Spatial Subset or Spectral Subset buttons 
and use standard subsetting procedures (see “Selecting a Spatial Subset” 
on page 35 or “Selecting a Spectral Subset” on page 40).

Note
If you select a band for input, spectral subsetting is not available. 

3. After the input data has been selected, click OK.

The Occurrence Texture Parameters dialog appears.

4. Select texture images to be created by clicking on the check boxes next to the 
texture type in the Textures to Compute portion of the dialog.
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5. Enter the size of the processing window in the Rows (Y) and Cols (X) text 
boxes to set the area to be considered for the texture evaluation.

6. Select output to File or Memory.

7. Click OK to start the processing.

The texture images selected are calculated and placed in the Available Bands List.

Figure 8-4: Occurrence Texture Parameters Dialog
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Applying Co-occurrence-Based Filters

Use Co-Occurrence Measures to apply any of eight texture filters that are based on 
the co-occurrence matrix. These filters include mean, variance, homogeneity, 
contrast, dissimilarity, entropy, second moment, and correlation. Co-occurrence 
measures use a gray-tone spatial dependence matrix to calculate texture values. This 
is a matrix of relative frequencies with which pixel values occur in two neighboring 
processing windows separated by a specified distance and direction. It shows the 
number of occurrences of the relationship between a pixel and its specified neighbor. 
For example, the co-occurrence matrix shown below was produced using each pixel 
and its horizontal neighbor (shift values of X=1, Y=0) for a 3 x 3 window. The pixels 
in the 3 x 3 base window and the pixels in a 3 x 3 window that was shifted by 1 pixel 
are used to create the co-occurrence matrix. See the following references for more 
information.

Haralick, R. M., Shanmugan, K., and Dinstein, I., 1973, “Textural Features for Image 
Classification,” IEEE Transactions on Systems, Man, and Cybernetics, Vol. 3, No. 6, 
pp. 610-621.

Anys, H., A. Bannari, D. C. He, and D. Morin, 1994. “Texture analysis for the 
mapping of urban areas using airborne MEIS-II images”, Proceedings of the First 
International Airborne Remote Sensing Conference and Exhibition, Strasbourg, 
France, Vol. 3, pp. 231-245.

Figure 8-5: Co-occurrence Matrix
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1. Select Filter → Texture → Co-occurrence Measures. 

The Texture Input File dialog appears.

2. Select an input file or band (see “Selecting Bands or Files for Processing” on 
page 33).

• To select a subset, click the Spatial Subset or Spectral Subset buttons 
and use standard subsetting procedures (see “Selecting a Spatial Subset” 
on page 35 or “Selecting a Spectral Subset” on page 40).

Note
If you select a band for input, spectral subsetting is not available. 

3. After the input data has been selected, click OK.

The Co-occurrence Texture Parameters dialog appears.

Figure 8-6: Co-occurrence Texture Parameters Dialog
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4. Select the texture images to be created by clicking on the check boxes next to 
the texture types in the Textures to Compute portion of the dialog. 

5. Enter the size of the processing window in the Rows (Y) and Cols (X) text 
boxes.

6. Enter the X and Y shift values used to calculate the co-occurrence matrix (see 
above for example).

7. Select output to File or Memory.

8. Click OK to start the processing.

The texture images selected are calculated and placed in the Available Bands List.
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Using Adaptive Filters

Use Adaptive filters to apply various adaptive type filters. Adaptive filtering uses the 
standard deviation of those pixels within a local box surrounding each pixel to 
calculate a new pixel value. Typically, the original pixel value is replaced with a new 
value calculated based on the surrounding valid pixels (those that satisfy the standard 
deviation criteria). Unlike a typical low-pass smoothing filter, the adaptive filters 
preserve image sharpness and detail while suppressing noise. 

Note
These filters can be slow to execute.

Applying Lee Filters

Use Lee filters to smooth noisy (speckled) data that have an intensity related to the 
image scene and that also have an additive and/or multiplicative component. Lee 
filtering is a standard deviation based (sigma) filter that filters data based on statistics 
calculated within individual filter windows. Unlike a typical low-pass smoothing 
filter, the Lee filter and other similar sigma filters preserve image sharpness and detail 
while suppressing noise. The pixel being filtered is replaced by a value calculated 
using the surrounding pixels. See the following reference for details:

Figure 8-7: Adaptive Filters Cascading Menu
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Lee, Jong-Sen, “Digital Image Enhancement and Noise Filtering by Use of Local 
Statistics”, IEEE Transactions on Pattern Analysis and Machine Intelligence, Vol 
PAMI-2, No.2, March 1980, pp. 165-168.

1. Select Filter → Adaptive → Lee. 

The Input File dialog appears.

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

4. When the Lee Filter Parameters dialog appears, enter the desired filter size in 
the Filter Size text box.

5. Select the desired noise model by clicking the toggle buttons next to the labels 
Additive, Multiplicative, or Both.

Typically, speckle in radar images is multiplicative.

6. Select from the following options:

• To change the Additive Noise Mean and Multiplicative Noise Mean” 
default values of 0.0 and 1.0, respectively (the typical noise means), enter 
values in the appropriate text boxes. 

Larger noise mean values will produce less smoothing.

• To change the Noise Variance value, enter a new value in the text box.

The Noise Variance parameter is set to the additive noise variance when 
Additive and Both noise models are chosen. It is set to the multiplicative 
noise when the Multiplicative noise model is chosen.

Tip
An estimate of the noise variance can be obtained by calculating the data 
variance over a flat area, such as a lake or smooth playa, in the image. For 
multiplicative noise in radar data, the noise variance can be estimated by 
1/(number of looks).

7. Select output to Memory or File.

8. Click OK to start the processing.
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Applying Enhanced Lee Filters

Use Enhanced Lee filters to reduce speckle in radar imagery while simultaneously 
preserving texture information. The Enhanced Lee filter is an adaptation of the Lee 
filter and similarly uses local statistics (coefficient of variation) within individual 
filter windows. Each pixel is put into one of three classes: homogeneous; 
heterogeneous; or point target. 

Each class type is treated differently. For the homogeneous class, the pixel value is 
replaced by the average of the filter window. For the heterogeneous class, the pixel 
value is replaced by a weighted average. For the point target class, the pixel value is 
not changed. See the following reference for more details.

Lopes, A., R. Touzi, and E. Nezry, 1990. “Adaptive Speckle Filters and Scene 
Heterogeneity”, IEEE Transactions on Geoscience and Remote Sensing, Vol. 28, No. 
6, pp. 992-1000.

1. Select Filter → Adaptive → Enhanced Lee.

2. Select an input file and perform any subsetting, if desired. The Enhanced Lee 
Filter Parameters dialog appears.

3. Enter the desired filter size in the Filter Size text box.

4. Enter a damping factor that inversely defines the extent of the exponential 
damping in the weighted average for the heterogeneous class. A larger 
damping factor produces less averaging.

5. Enter values that define the class cutoffs for the homogeneous (coefficient of 
variation ≤ Cu), heterogeneous (Cu < coefficient of variation < C max), and 
point target (coefficient of variation ≥ Cmax) classes.

The cutoff values can be estimated based on the number of looks (L) of the 
radar image.

6. Enter an output filename and click OK.

The results will appear in the Available Bands List.

Cu
0.523

L
-------------   and   Cmax 1 2

L
---+≅≅
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Applying Frost Filters

Use Frost filters to reduce speckle while preserving edges in radar images. The Frost 
filter is an exponentially damped circularly symmetric filter that uses local statistics. 
The pixel being filtered is replaced with a value calculated based on the distance from 
the filter center, the damping factor, and the local variance. See the following 
reference for more information:

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters,” 
Proceedings of IGARSS 94, August 8-12, 1994, pp. 2129-2133.

1. Select Filter → Adaptive → Frost.

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

Figure 8-8: Lee Filter Parameters Dialog
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4. When the Frost Filter Parameters dialog appears, enter the desired filter size in 
the Filter Size text box.

5. Enter the desired value in the Damping Factor text box. 

The Damping Factor determines the amount of exponential damping and the 
default value of 1 is sufficient for most radar images. Larger damping values 
preserve edges better but smooth less, and smaller values smooth more. A 
damping value of 0 results in the same output as a low pass filter.

6. Select output to File or Memory.

7. Click OK to execute the filter.

A status window displays the progress of the operation.

Applying Enhanced Frost Filters

Use Enhanced Frost filters to reduce speckle in radar imagery while simultaneously 
preserving texture information. The Enhanced Frost filter is an adaptation of the Frost 
filter and similarly uses local statistics (coefficient of variation) within individual 
filter windows. Each pixel is put into one of three classes: homogeneous; 
heterogeneous; or point target. 

Each class type is treated differently. For the homogeneous class, the pixel value is 
replaced by the average of the filter window. For the heterogeneous class, an impulse 
response is used as a convolution kernel to determine the pixel value. For the point 
target class, the pixel value is not changed. See the following reference for more 
details.

Lopes, A., R. Touzi, and E. Nezry, 1990. “Adaptive Speckle Filters and Scene 
Heterogeneity”, IEEE Transactions on Geoscience and Remote Sensing, Vol. 28, No. 
6, pp. 992-1000.

1. Select Filter → Adaptive → Enhanced Frost. 

2. Select an input file and perform any subsetting, if desired. The Enhanced frost 
Filter Parameters dialog appears.

3. Enter the desired filter size in the Filter Size text box.

4. Enter a damping factor that inversely defines the extent of the exponential 
damping in the weighted average for the heterogeneous class. A larger 
damping factor produces less averaging.

5. Enter values that define the class cutoffs for the homogeneous (coefficient of 
variation ≤ Cu), heterogeneous (Cu < coefficient of variation < C max), and 
point target (coefficient of variation ≥ Cmax) classes.
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The cutoff values can be estimated based on the number of looks (L) of the 
radar image.

6. Enter an output filename and click OK.

The results will appear in the Available Bands List.

Applying Gamma Filters

Use Gamma filters to reduce speckle while preserving edges in radar images. The 
Gamma filter is similar to the Kuan filter but assumes that the data is gamma 
distributed (see “Applying Kuan Filters” on page 734). The pixel being filtered is 
replaced with a value calculated based on the local statistics. See the following 
reference for more information:

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters”, 
Proceedings of IGRASS 94, August 8-12, 1994, pp. 2129-2133.

1. Select Filter → Adaptive → Gamma.

2. When the file selection dialog appears, select a file or band and any spectral 
and/or spatial subsetting as described in “Applying Lee Filters” on page 728.

3. Click OK.

4. When the Gamma Filter Parameters dialog appears, enter the desired filter size 
in the Filter Size text box.

5. Enter the number of looks in the appropriate text box.

The Number of Looks parameter is used to calculate the noise variance by 
1/(number of looks).

6. Select output to File or Memory.

7. Click OK to execute the filter.

A status window displays the progress of the operation.

Cu
0.523

L
-------------   and   Cmax 1 2

L
---+≅≅
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Applying Kuan Filters

Use Kuan filters to reduce speckle while preserving edges in radar images. It 
transforms the multiplicative noise model into an additive noise model. This filter is 
similar to the Lee filter but uses a different weighting function. The pixel being 
filtered is replaced with a value calculated based on the local statistics. See the 
following reference for more information:

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters”, 
Proceedings of IGARSS 94, August 8-12, 1994, pp. 2129-2133.

1. Select Filter → Adaptive → Kuan.

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

4. When the Kuan Filter Parameters dialog appears, enter the filter size in the 
Filter Size text box.

5. Enter the number of looks in the appropriate text box.

The Number of Looks parameter is used to calculate the noise variance by 
1/(number of looks).

6. Select output to File or Memory.

7. Click OK to execute the filter.

A status window displays the progress of the operation.

Applying Local Sigma Filters

Use Local Sigma filters to preserve fine detail (even in low contrast areas) and to 
reduce speckle significantly. The Local Sigma filter uses the local standard deviation 
computed for the filter box to determine valid pixels within the filter window. It 
replaces the pixel being filtered with the mean calculated using only the valid pixels 
within the filter box. See the following reference for more information:

Eliason, Eric M. and McEwen, Alfred S., “Adaptive Box Filters for Removal of 
Random Noise from Digital Images”, Photogrammetric Engineering & Remote 
Sensing, April, 1990, V56 No. 4, p. 453.
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1. Select Filter → Adaptive → Local Sigma.

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available.

3. Click OK.

4. When the Localized Sigma Filter Parameters dialog appears, enter the filter 
size in pixels.

5. Enter the number of standard deviations to consider valid in the Sigma Factor 
text box.

The Sigma Factor is used to determine which pixels are valid by calculating a 
minimum and maximum pixel value based on the number of standard 
deviations (sigma) entered and the local statistics.

The pixel being filtered will be replaced by the average of surrounding valid 
pixels

6. Select output to File or Memory.

7. Click OK to execute the filter.

A status window displays the progress of the operation.

Applying Bit Error Filters

Use Bit Error filters to remove bit-error noise, which is usually the result of spikes in 
the data caused by isolated pixels that have extreme values unrelated to the image 
scene. The noise typically gives the image a salt-and-pepper appearance. Bit-error 
removal in ENVI uses an adaptive algorithm to replace spike pixels with the average 
of neighboring pixels. The local statistics (mean and standard deviation) within the 
filter box are used to set a threshold for valid pixels. See the following reference for 
more information:

Eliason, Eric M. and McEwen, Alfred S., “Adaptive Box Filters for Removal of 
Random Noise from Digital Images”, Photogrammetric Engineering & Remote 
Sensing, April, 1990, V56 No. 4, p. 453.
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1. Select Filter → Adaptive → Bit Errors.

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.

4. When the Bit Error Removal Parameters dialog appears, enter the filter size in 
pixels.

5. Enter a Sigma Factor for the number of standard deviations to be used for 
determining valid pixels.

6. Enter a tolerance (in data values). 

Pixels are only considered bad if they have a value greater than the tolerance. 
A pixel is classified as a bit error when the pixel value minus the filter box 
mean is greater than the Sigma Factor times the localized standard deviation 
and greater than the tolerance. The bad pixels will be replaced by the average 
of surrounding valid pixels by default. 

7. To set bad pixels to zero instead of replacing them with an average, click Yes 
next to the Zero Bit Errors? text label. 

8. Optionally, enter the minimum and maximum values to be considered as valid 
data for the mean determination in the Valid Data Min and Valid Data Max” 
text boxes.

9. Select File or Memory output.

10. Click OK to execute the filter.

A status window displays the progress of the operation.
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Using Frequency Filters (FFTs)

Use FFT Filtering (Fast Fourier Transform filtering) to transform image data into a 
complex output image showing its various spatial frequency components, 
interactively build a frequency filter, apply the filter to the transformed data, and 
inverse FFT transform the filtered data to the original data space. Presently, FFT 
processing does not use the ENVI tiling procedures, so the size image that can be 
processed is limited by the available system memory.

Note
FFT images, which are Complex data type, use eight times the memory of a byte 
image of similar size.

Applying Forward FFT Filters

Use Forward FFT filters to produce an image that shows both the horizontal and 
vertical spatial frequency components. The average brightness value of the image 
(zero frequency component) is shown in the center of the transformed image. Pixels 
away from the center represent increasing spatial frequency components of the 
image. You can design a filter that will remove particular frequency components and 
apply the filter to the forward FFT data, then perform an inverse transform back to the 
original data space to remove those frequency components from the image (see 
“Defining FFT Filters” on page 738).

Note
If your input data has an odd number of samples and/or lines, the forward FFT 
output will not include the Nyquist frequency, which means it cannot be correctly 
inversed.

1. Select Filter → FFT Filtering → Forward FFT.

The Forward FFT Input File dialog appears. The file selection dialog allows 
selection of either an input file or a single input band (unlike most other ENVI 
File Selection dialogs).

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 
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3. Click OK.

4. When the Forward FFT Parameters dialog appears, select output to 
File or Memory.

Note
The file output option is strongly recommended. 

5. Click OK to start the FFT calculation.

A status window displays the progress of the operation. Currently, the entire FFT is 
done without tiling, so processing is limited by system memory and the status goes 
abruptly from 0 to 100%. When the transform is done, all bands in the output file are 
added to the Available Bands List. Display the resulting images using standard ENVI 
procedures. 

Note
When you display a forward FFT image, the power component of the complex data 
is displayed by default (see “Using the Complex Lookup Function” on page 120).

Defining FFT Filters

Use Filter Definition to interactively define FFT filters directly or to draw the filter 
on a displayed forward transformed image. Filter types include circular pass and cut, 
band pass and cut, and user-drawn pass and cut. Use ENVI’s Annotation function to 
define user-drawn filters.

1. Select Filter → FFT Filtering → Filter Definition.

The Filter Definition selection dialog appears.

2. Select one of the following options:

• If an FFT image is displayed, select the display number containing the 
FFT image or select No Display to indicate that the filters will not be 
associated with a particular display.

• If no image is displayed, specify the desired filter size by entering values 
into the Samples and Lines text boxes.

3. In the Filter Definition dialog, select Filter_Type → filter type.
Using Frequency Filters (FFTs) ENVI User’s Guide



Chapter 8: Filters 739
4. Select from the following options to set the filter parameters (depending upon 
the type of filter selected): 

• For Circular Pass or Circular Cut filters (low pass or high pass filters, 
respectively), enter a filter radius, in pixels, in the Radius text box.

• For Band Pass or Band Cut filters, enter values, in pixels, in the Inner 
Radius and Outer Radius text boxes. 

• For User Defined Pass and User Defined Cut filters, you can load ENVI 
annotation (polygons and shapes only) into the filter (see “Loading 
Annotation into User-Defined Filters” on page 741).

5. Click the arrow buttons to select the Number of Border Pixels used to taper 
the filter (smooth the edges of the filter). 

A value of zero indicates no smoothing. 

Figure 8-9: Filter Definition Dialog
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6. Select output to File or Memory.

7. Click Apply to build the FFT filter.

8. Click Cancel to close the Filter Definition dialog.

The filter is a single band image of the specified dimensions. It appears in the 
Available Bands List. It can be displayed using standard ENVI procedures prior to 
application to the images.

Tip
Because of the limited range of the filter DN values (0 or 1), a contrast stretch 
without histogram clipping (for example, a quick linear stretch) must be used to 
properly display the filter image.

Figure 8-10: From left to right: Circular Pass (low pass), Circular Cut (high pass), 
Band Pass, Band Cut, and User Defined Filters
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Loading Annotation into User-Defined Filters

If you select User Defined Cut or User Defined Pass filters in the Filter Definition 
Dialog, you can load ENVI annotation into the filter using the following procedure:

Note
The default is set to use the annotation on the current display (typically the FFT 
image) to build the filter.

1. Display the forward transformed FFT image.

2. Select Overlay → Annotation from the image window (see “Annotating 
Images” on page 240).

3. Draw either polygons or shapes on the FFT image that outline specific noise 
occurrences (typically, bright spots, lines, or wedges on the FFT image may 
represent noise).

4. To build a proper symmetric FFT filter, select Options → Turn Mirror On in 
the Annotation window.

The displayed annotation will be used as the filter definition.

• To restore a filter from a previously saved annotation file, click Ann File 
and select an input annotation file.

Applying Inverse FFT Transforms

The ENVI Inverse FFT procedure is actually a two step operation that applies both a 
filter in the FFT domain, and inverts the FFT image back to the original data space.

1. Select Filter → FFT Filtering → Inverse FFT.

The Inverse FFT Input File dialog appears. The file selection dialog allows 
selection of either an input file or a single input band (unlike most other ENVI 
File Selection dialogs).

2. Select an input file or band and any spatial/spectral subsetting as described in 
“Selecting Bands or Files for Processing” on page 33.

Note
If you select a band for input, spectral subsetting is not available. 

3. Click OK.
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4. When the Inverse FFT Filter File dialog appears, select the filter image to 
apply. 

Note
The filter image must have been generated previously using the filter 
definition procedures described in “Defining FFT Filters” on page 738. 

5. Click OK.

6. When the Inverse FFT Parameters window appears, with the input file 
characteristics listed, select either output to File or Memory.

7. Select the output data type (byte, integer, floating point, etc.) from the 
appropriate pull-down menu.

8. Click OK to process the image. 

The FFT-filtered image can be displayed using standard ENVI procedures.
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The Spectral Menu

Use the Spectral menu to access specialized tools for analyzing multispectral and 
hyperspectral images and other spectral data types. The tools include building, 
resampling, and viewing spectral libraries; extracting spectral slices; performing 
spectral math; determining spectral endmembers; visualizing spectral data in n-
dimensions; spectral classification; linear spectral unmixing; matched filtering; 
continuum removal; and Spectral Feature Fitting.

See the following ENVI Tutorials for further step-by-step descriptions for using some 
of the ENVI hyperspectral tools:

• Introduction to Hyperspectral Data and Analysis

• Basic Hyperspectral Analysis

• Selected Mapping Methods Using Hyperspectral Data

• Advanced Hyperspectral Analysis

• Hyperspectral Signatures and Spectral Resolution

Figure 9-1: Spectral Menu
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• Geologic Hyperspectral Analysis Case History

• Archaeology Hyperspectral Analysis Case History

• Vegetation Hyperspectral Analysis Case History

• Near-Shore Marine Hyperspectral Case History

• Multispectral Data and ENVI's Hyperspectral Tools
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Spectral Libraries

Use Spectral Libraries to build and maintain personalized libraries of material 
spectra, and to access several public domain spectral libraries that are included with 
ENVI. Spectral libraries developed at Jet Propulsion Laboratory contain spectra for 
three different grain sizes of approximately 160 “pure” minerals from 0.4 to 2.5 µm. 
The public domain U. S. Geological Survey Spectral library contains nearly 500 
spectra of well-characterized minerals and a few vegetation spectra. These data are 
provided in ENVI for the 0.4 to 2.5 µm range. Spectral libraries from Johns Hopkins 
University contain spectra for materials from 0.4 to 14 µm. The IGCP 264 spectral 
libraries were collected as part of IGCP Project 264 during 1990. They consist of five 
libraries measured on five different spectrometers for 26 well-characterized samples. 
Spectral libraries of vegetation spectra were provided by Chris Elvidge, DRI 
measured from 0.4 to 2.5 µm. See Appendix C, “ENVI Spectral Libraries” for more 
information and references regarding the spectral libraries available in ENVI.

ENVI spectral libraries are stored in ENVI “image” format, with each line of the 
image corresponding to an individual spectrum and each sample of the image 
corresponding to an individual spectral measurement at a specific wavelength (see 
“ENVI Spectral Library Files” on page 1089). The ENVI spectral libraries can be 
displayed and/or enhanced using the standard ENVI image display and analysis 
routines.

Opening Spectral Libraries

Use Spectral Library Viewer to open and view the contents of a spectral library and 
to plot individual library spectra.

1. Select Spectral → Spectral Libraries → Spectral Library Viewer.

The Spectral Library Input File dialog appears. Use this dialog to select the 
library to view. 

• If a spectral library has been opened previously, it is in the Select Input 
File list.

• If the library has not been opened, click Open Spectral Library and 
select the spectral library file to open. This will make it available for 
selection in the Spectral Library Input File dialog.

2. Click the name of a spectral library and click OK.

The Spectral Library Viewer dialog appears for selection and plotting of individual 
library spectra.
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Tip
The Spectral Library Viewer may also be opened from the context menu of a 
spectral library shown in the Available Bands List.

Plotting Library Spectra

After opening spectral libraries, use the Spectral Library Viewer dialog to plot the 
spectra.

• To plot a spectrum in the Spectral Library Viewer plot window, click on an 
individual spectrum name in the Spectral Library Viewer dialog (Figure 9-2).

A plot window appears with a plot of that spectrum.

• To plot multiple spectra at the same time, click on multiple spectrum names. 

Each new spectrum is plotted in the same plot window in a new color. 

• To show the names and colors of the plotted spectra, click the right mouse 
button inside the plot window and select Plot Key in the context menu. 

• To scale the library spectra by a constant, select Options → Edit (x,y) Scale 
Factors, enter a value into the Scale Factor text box. The spectral library 
spectra are multiplied by that value.

Scale factors are used for comparison of library spectra to image spectra that 
have been scaled into integers, or for converting wavelength units between 
microns and nanometers.

Plotting Other Spectra

To plot spectra from other plot windows with the spectral library entries: 

1. Click the right mouse button inside the plot window nd select Plot Key from 
the context menu to show the plot names. 
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2. Click and hold the left mouse button on the plot name and drag the plot name 
to the Spectral Library Viewer plot window and release the left mouse button 
(see “Moving Plots to Another Plot Window” on page 388).

Editing and Managing Spectral Library Plots 

To interact with and edit spectral library plots, use the same standard procedures 
described in “Using Interactive Plot Functions” on page 387.

The options include input and output of plot values to ASCII or new spectral 
libraries, setting data plot characteristics such as line color and type, changing plot 
characteristics such as data range and titles, stacking data plots, editing data values, 
creating ASCII and PostScript output, printing plots, annotating plots, and removing 
continuums. 

Closing the Dialog

• To exit the Spectral Library Viewer dialog, select File → Cancel.

Figure 9-2: The Spectral Library Viewer Dialog (left) Showing Individual Spectra 
and The Spectral Library Viewer Plot Window (right)
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Resampling Spectral Libraries

Use Spectral Library Resampling to resample spectral libraries to match either the 
response of a known instrument (for example, TM, MSS, AVIRIS) or a user-defined 
filter function; an ASCII wavelength file (with or without full width half maximum 
[FWHM] information) or the wavelengths of a specific image input file. The 
resampling method used 

depends on the input information. If only wavelengths (band centers) are provided, 
ENVI assumes critical sampling and uses a gaussian model with a FWHM equal to 
the band spacings. If wavelengths and FWHM information are provided, a gaussian 
model using the FWHM spacings is used. If a filter function is provided, ENVI uses 
that for the resampling.

1. Select Spectral → Spectral Libraries → Spectral Library Resampling.

The Spectral Resampling Input File dialog appears. Use this dialog to select a 
library to resample.

• If a spectral library has already been opened, its name is in the Select 
Input File list.

• If the library has not been opened, click Open Spec Lib and select the 
spectral library file to open. This makes it available for selection in the 
Spectral Resampling Input File dialog.

2. Click the name of a spectral library and click OK.

Selecting Resampling Types

Use the Spectral Library Resampling Parameters dialog to select the type of 
resampling to perform.

1. Select the appropriate Resample Wavelength to toggle button. 

2. Enter a value in the Set Bad Values to textbox. 

Bands that fall outside the input wavelength range are considered bad values 
and the entered value will be used for these bands. No extrapolation is done. 
For example, if your input data ranges from .4 to 2.4 µm and you resample to 
.3-2.5 µm, the bands between .3 to .4 and 2.4 to 2.5 µm will contain the “Set 
Bad Values To” value. 

3. Select output to File or Memory and click OK.

An additional dialog may appear depending on the type of resampling selected.
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Resampling from Data Files

If you select Input Data File as the resampling method in the Spectral Resampling 
Parameters dialog, the File Containing Output Wavelength dialog appears.

1. In the File Containing Output Wavelength dialog, click on the desired 
filename.

2. Click OK to start the resampling process.

Note
The data file must contain wavelength values used for the resampling in its 
associated header. If FWHM values are present in the file header, they are also used 
in the resampling.

The resulting library appears in the Available Bands List.

Resampling from ASCII Files

If you select Input ASCII File as the resampling method in the Spectral Resampling 
Parameters dialog, an input file selection dialog appears.

1. In the File Containing Output Wavelength, select the ASCII wavelength file.

2. When the Input ASCII File dialog appears, select the wavelength data column. 

• If the units of the wavelengths contained in the file are known, they can be 
specified in the Wavelength Units menu.

• If the ASCII file also contains full-width-half-maximum (FWHM) values, 
enter the FWHM column number.

3. Click OK to start the resampling.

4. If the input and output wavelength ranges do not overlap completely, and you 
did not specify output wavelength units, you will be prompted to specify the 
output wavelength units so that conversion may be performed.

The resulting library appears in the Available Bands List.

Resampling from User-Defined Filter Functions

If you select User Defined Filter Function as the resampling method in the Spectral 
Resampling Parameters dialog, the Input Filter Function Spectral Library dialog 
appears.

The user-defined filter function must take the form of an ENVI spectral library with 
each sample of the image representing a wavelength value and each line of the image 
representing an individual filter function. The value at each wavelength must be a 
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weight between 0 and 1, which is used as a multiplicative factor when applied to the 
library being resampled. For an example of a filter function file, open the Landsat TM 
file, tm.sli (in the ENVI Filter Function directory), as a spectral library file and plot 
the filter functions.

1. In the Input Filter Function Spectral Library dialog, select the desired filter 
function.

2. Click OK.

The resulting library appears in the Available Bands List.

Warning
It is not recommended to resample from a low resolution to a high resolution 
spectrum. If you do this, the results may be spurious.

Resampling from Pre-Defined Filter Functions

If you select Pre-Defined Filter Function as the resampling method in the Spectral 
Resampling Parameters dialog, a button menu appears.

1. From the button menu that appears, select a supported sensor type (for 
example, ASTER, AVHRR).

The resulting library appears in the Available Bands List.

Building Spectral Libraries

Use Spectral Library Builder to create ENVI spectral libraries from a variety of 
spectra sources including ASCII files, spectral files produced by ASD spectrometers, 
other spectral libraries, ROI means, and spectral profiles and plots. The collected 
spectra are automatically resampled to an input wavelength space using full-width-
half-maximum (FWHM) information, if available.

Inputting Wavelength Data

1. Select Spectral → Spectral Libraries → Spectral Library Builder.

2. When the Spectral Library Builder dialog appears, select the wavelength set 
for the new library from either an Input Data File (ENVI image file) or from 
an Input ASCII File. 

3. When the File Containing Output Wavelength dialog appears, select the input 
file containing the wavelengths and optional FWHM values using standard 
selection procedures.
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• If you select Input Data File, the wavelengths and FWHM values (if 
present) are read from the ENVI header file.

• If you select Input ASCII File, the column that contains the wavelength 
values and FWHM values (if present) must be selected.

4. Click OK.

The Spectral Library Builder dialog appears. 

Collecting Spectra

Use the Spectral Library Builder dialog (Figure 9-3) to collect endmember spectra 
from a variety of sources. All spectra are automatically resampled to the selected 
wavelengths.

The methods for collecting spectra in the Spectral Library Builder dialog are the 
same as those for collecting spectra in the Endmember Collection dialog. For detailed 
instructions, see “By Dragging-and-Dropping Spectra” on page 582, “Importing 
Endmember Spectra” on page 583, “Endmember Options” on page 589 and 
“Managing Endmember Spectra” on page 592).

Figure 9-3: The Spectral Library Builder Dialog

Drag-and-Drop 
Window
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Writing Spectral Libraries

After collecting your spectra, select an output option to build the spectral library. 

• To create an ASCII file containing all of the spectra, select File → Save 
Spectra As → ASCII in the Spectral Library Builder dialog. 

• To create an ENVI spectral library either as an output file or in memory, select 
File → Save Spectra As → Spectral Library.

Figure 9-4: A Plot of All Endmember Spectra
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Spectral Slices

Use Spectral Slices to extract a combined spatial/spectral profile from a multiband 
image. Slices in ENVI are saved as grayscale images, with the line direction (Y) 
corresponding to the spatial dimension of the image being sliced (horizontal, 
vertical, or arbitrary), the sample direction (X) corresponding to the spectral 
dimension (the number of bands in the sliced image), and the grayscale (DN level) 
showing the spectral intensity (reflectance, radiance, and so on) depending on the 
calibration of the data.

You can slice images in either the horizontal direction (all of the bands for a single 
line of the image), along the vertical direction (all of the bands for a singe pixel 
column of the image), or in an arbitrary direction that you define using ROI polyline 
selection (see “Drawing ROIs” on page 291). The resulting slice is an ENVI image 
with the number of samples equal to the number of spectral bands and the number of 
lines equal to the number of samples (for a horizontal slice), number of lines (for a 
vertical slice), or total number of pixels along the ROI polyline (for an arbitrary 
slice).

Figure 9-5: A Vertical Spectral Slice
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Extracting Horizontal Slices

Use Horizontal Slice to show the image spectra for all of the pixels in a line of the 
input image data. The position for the slice can be pre-determined using the Cursor 
Location/Value function in the image window (see “Viewing Cursor Location and 
Value” on page 440). 

1. Select Spectral → Spectral Slices → Horizontal Slice.

2. When the Spectral Slice Input File dialog appears, select an input file and any 
spectral subsetting. 

3. When the Spectral Slice Parameters dialog appears, enter the line number for 
the horizontal slice in the Line text box.

4. Select either File or Memory output.

5. After all of the parameters have been entered, click OK to continue.

The horizontal spectral slice image is added to the Available Bands List and can be 
viewed and processed using standard ENVI functions.

Extracting Vertical Slices

Use Vertical Slice to show the image spectra for a single column of input image data. 
The position for the slice can be pre-determined using the Cursor Location/Value 
function in the image window (see “Viewing Cursor Location and Value” on 
page 440).

1. Select Spectral → Spectral Slice → Vertical Slice.

2. When the Spectral Slice Input File dialog appears, select an input file and any 
spectral subsetting. 

3. When the Spectral Slice Parameters dialog appears, enter the sample number 
for the vertical slice in the Sample text box. 

4. Select either File or Memory output.

5. After all of the parameters have been entered, click OK to continue. 

The vertical spectral slice image is added to the Available Bands List and can be 
viewed and processed using standard ENVI functions.
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Extracting Arbitrary Slices

Use Arbitrary Slice to show the image spectra for a user-defined region of interest 
(ROI). ROIs must be defined using ENVI’s standard ROI selection procedures prior 
to executing the arbitrary slice function. Typically, the arbitrary slice is defined using 
the Polyline option for defining ROIs (see “Drawing Polylines” on page 293), 
however, polygons or points can also be used. All the pixels included in the ROI are 
used to make the spectral slice.

1. Select Spectral → Spectral Slice → Arbitrary Slice.

2. When the Spectral Slice Input File dialog appears, select an input file and any 
spectral subsetting. 

The Spectral Slice Parameters dialog appears with the file characteristics and 
processing options listed. 

• If only one ROI is currently defined, it is automatically used for the arbitrary 
slice.

• If more than one ROI exists, you can select the ROI to be used for the slice by 
clicking on the name of the desired region in the Select Region for Spectral 
Slice list.

3. Select either File or Memory output.

4. Once all of the parameters have been entered, click OK to continue.

The arbitrary spectral slice image is added to the Available Bands List and can be 
viewed and processed using standard ENVI functions.
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MNF Rotations

Use the MNF Rotation (minimum noise fraction) transforms to determine the 
inherent dimensionality of image data, to segregate noise in the data, and to reduce 
the computational requirements for subsequent processing. For a detailed explanation 
and instructions, see “Minimum Noise Fraction Transform” on page 682.
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Pixel Purity Index

Use Pixel Purity IndexTM (PPITM) to find the most spectrally pure (extreme) pixels 
in multispectral and hyperspectral images. The most spectrally pure pixels typically 
correspond to mixing endmembers. The Pixel Purity Index is computed by repeatedly 
projecting n-dimensional scatterplots onto a random unit vector. The extreme pixels 
in each projection—those pixels that fall onto the ends of the unit vector—are 
recorded and the total number of times each pixel is marked as extreme is noted. A 
Pixel Purity Image is created in which the DN of each pixel corresponds to the 
number of times that pixel was recorded as extreme. See “Spectral Tools References” 
on page 849 for more details. For examples on using the PPI results, see the 
Advanced Hyperspectral Analysis ENVI Tutorial.

The Pixel Purity Index function can create a new output band or continue its 
iterations and add the results to an existing output band. The PPI is typically run on a 
Minimum Noise Fraction (MNF) transform result excluding the noise bands (see 
“Minimum Noise Fraction Transform” on page 682). The results of the PPI are 
usually used as input into ENVI’s n-D Visualizer (see “The n-Dimensional 
Visualizer” on page 763). 

Note
You can use ENVI’s Spectral Hourglass Wizard to guide you step-by-step through 
the ENVI “hourglass” processing flow, including the Pixel Purity Index, to find and 
map image spectral endmembers from hyperspectral or multispectral data. For 
details, see “Spectral Hourglass Wizard” on page 809.

FAST Pixel Purity Index

You have the choice of a disk-based PPI method and a FAST PPI method. The FAST 
PPI places the image data into memory and performs the computations in memory, 
which is much faster than the disk-based PPI method, but requires adequate memory 
space. Use spatial and spectral subsetting or a sparser array of the data (subsampled 
resolution) to help fit the image data into memory. ENVI informs you of the amount 
of memory necessary to perform the fast PPI and prompts you for continuation. 
When using FAST PPI, you also have the options of creating a new output file and of 
adding to an existing output band.
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Selecting Input Files

Use New Output Band the first time you run the Pixel Purity Index. An output band 
containing the number of times each pixel was found to be extreme (pure) is created 
and used as input into ENVI’s n-D visualizer (see “The n-Dimensional Visualizer” on 
page 763).

1. Select Spectral → Pixel Purity Index → New Output Band or [FAST] New 
Output Band.

2. When the Pixel Purity Index Input File dialog appears, select an input file and 
any subsetting using standard ENVI procedures.

Tip
Typically, run the PPI on an MNF transform result, and use spectral 
subsetting to exclude noise bands based on the eigenimages and eigenvalue 
plot (see “Calculating Forward MNF Transforms” on page 683).

3. Click OK to continue. 

The Pixel Purity Index Parameters dialog appears.

Figure 9-6: The Pixel Purity Index Parameters Dialog
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Setting the Number of Iterations

• In the Pixel Purity Index Parameters dialog, designate the number of times the 
data will be projected onto the random vector by entering a number into the 
“Number of Iterations” text box. 

The more iterations run, the better job ENVI does of finding the extreme 
pixels. Balance the number of iterations against the time available, as each 
iteration can take some time depending on the CPU and system load. Typically 
thousands of iterations are required for imaging hyperspectral data. The 
number of iterations run is listed in the description line of the image header 
file.

Setting the Threshold Factor

• In the Threshold Factor text box, enter a threshold value in data units for 
extreme pixel selection.

For example, a threshold of 2 marks all pixels greater than two digital numbers 
(DN) from the extreme pixels (both high and low) as being extreme. This 
threshold selects the pixels on the ends of the projected vector. The threshold 
should be approximately 2-3 times the noise level in the data. For example, for 
TM data, which typically has less than 1 DN noise, a threshold of 2 or 3 works 
well. When using MNF data, which normalizes the noise, a DN is equivalent to 
1 standard deviation and, again, a threshold value of 2 or 3 works well. Larger 
thresholds cause the PPI to find more extreme pixels but they are less likely to 
be “pure” endmembers.

Subsampling the Data

• To subsample the data to help it fit in memory, enter a X and Y resize factor 
less than 1 (that is, a resize factor of .5 will use every other pixel). 

It is not recommended to subsample by less than .25 (every fourth pixel) 
because extreme pixels may be thrown out.

Starting the Processing

1. In the Pixel Purity Index Parameters dialog, select File or Memory output.

2. Click OK to start the processing. 

• To interrupt PPI processing, click Cancel in the processing status window. 
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• To restart at the same place, select Spectral → Pixel Purity Index → 
Existing Output Band as described in “Restarting or Continuing PPI” on 
page 761.

If you are using the FAST PPI, a window indicating the amount of memory needed 
appears and prompts you to continue if that amount of memory is acceptable.

A processing status window appears with the Pixel Purity Index plot. This plot shows 
the total number of extreme pixels satisfying the threshold criterion found by the PPI 
processing as a function of the number of iterations. It should asymptotically 
approach a flat line (zero slope) when all of the extreme pixels have been found.

Restarting or Continuing PPI 

Use Existing Output Band or [FAST] Existing Output Band if you clicked Cancel 
and PPI was interrupted during processing, or use either option if you want to 
continue additional iterations on a PPI result. 

1. Select Spectral → Pixel Purity Index → Existing Output Band or [FAST] 
Existing Output Band.

2. Select an input file (a spectrally subsetted MNF is recommended).

3. Click OK.

4. When the Pixel Purity Index Previous Result dialog appears, select a previous 
PPI image as the input file and click OK.

Figure 9-7: The Pixel Purity Index Plot
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5. When the Pixel Purity Index Parameters dialog appears, select the number of 
iterations and threshold as described in the previous sections.

• For FAST PPI, enter a X and Y Resize Factor if desired.

6. Click OK to start the processing.

A processing status window and the Pixel Purity Index plot appear. The PPI image 
appears in the Available Bands List when the processing is completed. 

Using PPI Images for Endmember Selection

After the PPI is processed, the PPI image appears in the Available Bands List:

1. Display the image using standardized ENVI display procedures.

Brighter pixels represent more spectrally extreme “hits” and indicate pixels 
that are more spectrally pure. Darker pixels are less spectrally pure.

2. Select Window → Cursor Location/Value on the ENVI main menu or Tools 
→ Cursor Location/Value from the Display menu to determine the range of 
values present in the image.

Tip
Use interactive density slicing to get a better visual representation of the high 
values.

3. In the image window, select Overlay → Region of Interest → Image 
Threshold to ROI to create an ROI containing only the pixels with high PPI 
values (see “Converting Band Values to ROIs” on page 309)

Typically, use a minimum threshold. For example, a minimum of 10 will include all 
of those pixels with PPI values greater than 10 in the ROI. However, if bad data 
points exist in the PPI image, both a minimum and maximum threshold can be used.

Once an ROI has been created containing the high PPI values, you can use the n-
Dimensional Visualizer (see the following section) to interactively define the image 
endmembers.
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The n-Dimensional Visualizer

Use the n-D VisualizerTM in conjunction with the Minimum Noise Fraction 
Transform (MNF) and Pixel Purity Index (PPI) results to locate, identify, and cluster 
the purest pixels and most extreme spectral responses in a data set (see “Spectral 
Tools References” on page 849 for more details). You can also use the n-D Visualizer 
to check the separability of your classes when you use ROIs as input into supervised 
classifications (see “Exporting ROIs to the n-D Visualizer” on page 316). The n-
Dimensional Visualizer is an interactive tool to use for selecting the endmembers in 
n-space. Spectra can be thought of as points in an n-dimensional scatterplot, where n 
is the number of bands. The coordinates of the points in n-space consist of “n” values 
that are simply the spectral radiance or reflectance values in each band for a given 
pixel. The distribution of these points in n-space can be used to estimate the number 
of spectral endmembers and their pure spectral signatures. See the Advanced 
Hyperspectral Analysis ENVI Tutorial for examples on using the n-D Visualizer. An 
option to start the n-D Visualizer with a pre-clustered result gives you a starting point 
for interactively rotating and refining the clusters of pixels into class groups.

When using the n-Dimensional Visualizer, you can interactively rotate data in n-D 
space, select groups of pixels into classes, and collapse classes to make additional 
class selections easier. The selected classes can be exported to Regions of Interest 
(ROIs) and used as input into classification, unmixing or matched filtering 
techniques.

Note
You can use ENVI’s Spectral Hourglass Wizard to guide you step-by-step through 
the ENVI hourglass processing flow, including the n-D Visualizer, to find and map 
image spectral endmembers from hyperspectral or multispectral data. For details, 
see “Spectral Hourglass Wizard” on page 809.

Starting the n-D Visualizer

The n-Dimensional Visualizer is usually used with Minimum Noise Fraction (MNF) 
data that have been spatially subset using only the purest pixels determined from the 
Pixel Purity Index. 

1. Select Spectral → n-Dimensional Visualizer → Visualize with New Data. 

• To restore a saved state, select Spectral → n-Dimensional Visualizer → 
Visualize with Previously Saved Data (see “Managing n-D Visualizer 
States” on page 776).
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The n-D Visualizer Input File dialog appears.

2. Select the file to extract the n-dimensional scatter plots from (usually this 
would be an MNF file).

• If the input file is an MNF result, spectrally subset the MNF data to 
exclude noise bands as determined by reviewing the eigenimages and 
eigenvalue plot (see “Minimum Noise Fraction Transform” on page 682).

3. Click OK to open the file and start the function.

For speed and clarity, an ROI is used to limit the number of pixels that are 
input into the n-D Visualizer. It is recommended that the ROI is computed as a 
threshold from the PPI results (see “Using PPI Images for Endmember 
Selection” on page 762). If only one ROI is present for the input image, it is 
automatically used as input to the n-D Visualizer. If, however, more than one 
ROI is present, the n-D Visualizer Input ROI dialog appears. 

4. Click on the ROI to be used in the n-Dimensional Visualizer.

A status box appears while the ROI is loaded. After the ROI is loaded, the n-D 
Controls dialog appears with the n-D Visualizer plot window.

Starting the n-D Visualizer with a Pre-clustered 
Result

Starting the n-D Visualizer with a pre-clustered result gives you a starting point for 
interactively rotating and refining the clusters of pixels into class groups. To use this 
feature, you must have MNF and PPI files for your data. The pre-clustered result is a 
“first cut” selection of potential endmembers that are shown as colored points in the 
data cloud. The pre-clustering operation attempts to find the corners of the data cloud 
in n-dimensions based on the shape of the scatter plot and the related PPI scores of 
the pixels. Since the purest pixels are at the convex corners of the data cloud, based 
on the linear mixed pixel model, these are the pixels you want to identify and group 
together. The algorithm first finds the pixel with the highest PPI score, using it as the 
seed for the first cluster. Then it iteratively creates more clusters until either the 
number of clusters is one more than the number of MNF bands used or the inherent 
dimensionality of the data is reached. A second phase of clustering groups pixels that 
are near these corner points, reconciles clusters that may need to be joined, and 
checks the dimensionality of the simplex formed by the cluster means.

While pre-clustering is a useful tool, it cannot outperform a skilled human willing to 
take the time to understand the data, interactively explore it, and define corner 
clusters manually. As such, the results of the pre-clustering should be seen as a 
starting point for interactive validation, editing and modification. Rotate the data 
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cloud in the n-D Visualizer and modify the endmembers, as needed, using the tools 
described in “The n-Dimensional Visualizer” on page 763.

Warning
The pre-clustering result is only a first cut attempt at selecting endmembers. You 
should examine the data cloud and modify the endmember selections as needed. 

1. From the ENVI main menu, select Spectral → n-Dimensional Visualizer → 
Auto Cluster.

2. In the input file selection dialog, select the MNF input file.

3. In the next input file selection dialog, select the PPI input file.

4. In the n-D Precluster Parameters dialog, enter the maximum number of input 
pixels to use in the n-D Visualizer. 

Smaller numbers animate in the n-D Visualizer faster and show only the purest 
pixels; larger numbers give a better overall picture of the scatter plot, but 
animate more slowly and may make selection of the corners more difficult. A 
threshold is automatically applied to the PPI image to obtain the best PPI 
pixels to use in the n-D Visualizer without exceeding the selected maximum.

The n-D Visualizer plot window and Controls dialog appear. The precluster 
results are shown as colored pixels in the n-D Visualizer plot window.

5. Rotate the data cloud to assess the results and modify them as needed.

General n-D Visualizer Plot Window Functions

The n-D Visualizer is a plot window that shows an n-Dimensional scatterplot of data 
selected for visualization (Figure 9-8). It is a projection of the n-D data onto a two-
dimensional plane. 

• The n-D Visualizer can contain data (plotted as white pixels), axes, and color-
coded classes, depending on the options selected in the n-D Controls dialog 
below.

• Individual pixels and groups of pixels can be highlighted and grouped into a 
region of interest using standardized ENVI polygon drawing routines.

• Once the bands to plot are selected (see below), click in the window using the 
left mouse button to start the polygon, click using the left mouse button on 
each vertex of the polygon, and click the right mouse button to close the 
polygon.
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• The scatter plot can be rotated in “n” dimensions to isolate specific groups of 
pixels.

General n-D Controls Dialog Functions

After the ROI thresholded from the PPI image has been loaded, the n-D Controls 
dialog appears with the n-D Visualizer. The n-D Controls dialog contains 
representations of all of the bands that were selected during the file selection. The 
bands are represented by numbered boxes which initially appear black.

Tip
If you have more bands than the Visualizer can display, click the middle or right 
mouse button to toggle through groups containing those bands.

• Clicking on an individual box (band number) turns it white and toggles on 
display of the corresponding band pixel data in the n-D Visualizer as part of an 
n-dimensional scatterplot (at least 2 bands must be selected to view a 
scatterplot). 

• Clicking again on the same box (band number) turns the box black again and 
toggles off the band data in the n-D scatterplot.

Figure 9-8: The n-D Controls Dialog (right) and the n-D Visualizer (left)
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• Selecting two bands (by clicking on the associated numbered box) produces a 
two-dimensional scatterplot; clicking on three bands produces a three-
dimensional scatterplot, and so on

Any number combination of bands may be selected at once.

Selecting Dimensions and Rotating

Rotate data points by stepping between random projection views. You can control the 
speed and stop the rotation at any time. You can move forward and backward step-by 
step through the projection views, which allows you to step back to a desired 
projection view after passing it.

1. In the n-D Controls dialog, select bands (dimensions) for projection in the n-D 
Visualizer.

Note
If you select only two dimensions, rotation is not possible.

If you select three dimensions, you have the option of driving the axes, or 
initiating automatic rotation.

If you select more than three dimensions, only automatic random rotation is 
available. 

2. Select from the following options:

• To drive the axes, select Options → 3D:Drive Axes. Click and drag in the n-D 
Visualizer window to manually spin the axes of the three-dimensional 
scatterplot.

• To display the axes themselves, select Options → Axes:On.

• To start or stop the rotation, click Start or Stop.

• To control the rotation speed, enter a value in the Speed text box, or use the 
arrow increment buttons to increase or decrease the speed. Higher values cause 
faster rotation with fewer steps between views.

The information in the View status box tells you the number of steps you are 
moving through between the random projection views. 

• To move step-by-step through the projection views, click the <- button to go 
backward and the -> button to go forward.

• To display a new random projection view, click the New button.
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n-D Visualizer Shortcut Menu

Many options in the n-D Visualizer can also be accessed by right-clicking in the 
scatter plot and selecting from the shortcut menu that appears.

Defining Classes

Typically, classes are defined where groups of pixels stay together during rotation and 
are separated from the rest of the pixels. Multiple classes can be defined at once. Use 
the Z-Profile option to aid in defining classes (see “n-D Visualizer/Controls Options” 
on page 772).

1. Click the Stop button to stop the rotation when a group of pixels is isolated 
from the main body of pixels that are plotted in the n-D Visualizer. Or, use the 
arrow buttons to go to a particular projection view.

2. Highlight the desired pixels on the n-D Visualizer using standardized ENVI 
polygon selection procedures (left button to set a vertex, right mouse button to 
close the polygon).

• If a three-dimensional projection is selected, be sure to select Options → 
3D: ROI Definition.

3. From the Class menu, select a color for the class. 

• To automatically use the next available class color for the next ROI, select 
Class → New.

4. Click the Start button to rotate the scatterplot until additional groups of pixels 
are isolated and repeat the class definition process. 

Interacting with Classes

Use the n-D Class Controls dialog to interact with individual classes. The number of 
points in each defined class and the class color are listed in the dialog. You can 
change the symbol used, turn individual classes on and off, and select classes to use 
when collapsing classes. You can also plot the minimum, maximum, mean, and 
standard deviation spectra for a class, plot the mean for a class alone, and /or plot all 
the spectra within a class. Also, you can clear a class and export a class to an ROI.

1. In the n-D Controls dialog, select Options → Class Controls.

All of the defined classes appear in the dialog. The white class contains all of 
the unclustered or unassigned points. The number of points in each class is 
shown in the text boxes next to the colored squares.
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Turning Classes On/Off

• To turn a class off in the n-D Visualizer window, click the On check box for 
that class. Click again to turn it back on.

• To turn all but one of the classes off in the n-D Visualizer window, double-
click on the colored box of the class that you want to remain displayed. Double 
click again to turn the other classes back on.

Selecting the Active Class

• To designate a class as the active class, click on the colored square 
corresponding to that class.

The color appears next to the Active Class label and any functions executed 
from the Class Controls dialog affect only that class. 

Note
A class may be selected as the active class even though it is not turned on in the n-D 
Visualizer.

Changing Plot Symbols

• To change the plot symbol for the active class, select the desired symbol from 
the Symbol button menu.

Producing Spectral Plots

To produce spectral plots for the active class:

1. Click the Stats, Mean, or Plot buttons.

2. When the file selection dialog appears, select the input file that you want to 
calculate the spectra from.

• If you select a file with different spatial dimensions than the file you used 
as input into the n-D visualizer, enter the X and Y Offset values for the n-D 
subset when prompted.

Note
If you select Plot for a class that contains hundreds of points, the spectra for all the 
points will be plotted and the plot may be unreadable.

Clearing Classes

• To remove all points from a class, click the Clear button.
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Exporting Classes

• To export the points to an ROI, click Export.

Designating Classes to Collapse

• To include the statistics from a class when calculating the projection used to 
collapse the data, click in the Clp check box next to that class name. 

If the data is in a collapsed state, it will be recollapsed using the selected classes 
when you click in any of the Clp check boxes (see “Collapsing Classes”).

Collapsing Classes

In the n-D Visualizer use Collapse Classes by Means and Collapse Classes by 
Variance to make class definition easier when the dimensionality of a data set is 
higher than four or five. With more than four or five dimensions, it is often difficult to 
interactively identify and define many classes. Both collapsing methods involve an 
iterative collapsing of the data cloud based on the classes defined. To collapse the 
data, a projection is calculated (based either on class means or covariance) to 
minimize or hide the space spanned by the already defined classes and to maximize 
or enhance the remaining variation in the data set. The data are subjected to this 
special projection and replace the original data in the n-D Visualizer. Additionally, an 
eigenvalue plot is displayed showing the residual spectral dimension of the collapsed 
data. The collapsed classes should form a tight cluster so the remaining pixels can be 
more readily examined. The dimensionality of the data, shown by the eigenvalue plot, 
should drop with each collapse.

1. Select Options → Collapse Classes by Means or Collapse Classes by 
Variance (see the descriptions in the following sections).

An eigenvalue plot is displayed, showing the remaining dimensionality of the 
data and suggesting the number of remaining classes to be defined. The n-D 
Selected Bands widget changes color to red to indicate that collapsed data is 
being displayed in the n-D Visualizer.

2. Use the low number bands to rotate and to select additional classes.

3. Select Options → Collapse Classes by Means or Collapse Classes by 
Variance again to collapses all of the defined classes.

4. Repeat these steps until all of the desired classes have been selected.

Note
The data can be UnCollapsed to the original data at any time. 
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About Collapsing Classes by Means

You must have at least two classes defined before using this collapsing method. The 
space spanned by the spectral mean of each class is derived through a modified 
Gramm-Schmidt process. The complementary, or null, space is also calculated. The 
data set is projected onto the null space, exactly collapsing the class means to an 
identical point. A standard Principal Components transformation is performed, 
packing the remaining unexplained variance into the low numbered bands of the 
collapsed data. At each iterative collapsing, this process is repeated using all of the 
defined classes. The eigenvalue plot shows the dimensionality of the transformed 
data, suggesting the number of remaining classes that need to be defined.

About Collapsing Classes by Variance

The band-by-band covariance matrix of the defined classes is calculated and the 
eigenvectors and eigenvalues computed. The full set of data is projected onto the 
eigenvectors of the classified pixels. Each of these projected bands is divided by the 
square root of the associated eigenvalue. This transforms the classified data into a 
space where they have no covariance and a standard deviation of one. A standard 
Principal Components transformation is performed, packing the remaining 
unexplained variance into the low numbered bands of the collapsed data. At each 
iterative collapsing, this process is repeated using all of the defined classes. The 
eigenvalue plot shows the dimensionality of the transformed data, suggesting the 
number of remaining classes that need to be defined.

UnCollapsing Classes

• To uncollapse the data and return to the original data set, select Options → 
UnCollapse. 

All the defined classes are shown in the n-D Visualizer plot window and the n-D 
Selected Bands widget returns to a white color.
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n-D Visualizer/Controls Options

Use the Options menu in the n-D Controls dialog to access the n-D Class Controls 
dialog, annotate the n-D Visualizer, start a Z-profile plot window, import library 
spectra, collapse classes, clear classes, export classes to ROIs, calculate mean 
spectra, and turn the axes graphics on and off.

Opening the Class Controls Dialog

• To access the n-D Class Controls dialog, select Options → Class Controls 
(for details, see “Interacting with Classes” on page 768). 

Adding Annotation

• To add an annotation to the n-D Visualizer window, select Options → 
Annotate Plot.

Note
You cannot add borders to the n-D Visualizer window (see “Annotating Images” on 
page 240 for details). 

Plotting Z Profiles

• To open a plot window containing the spectrum of a point selected in the n-D 
Visualizer:

1. Select Options → Z Profile.

2. When the file selection dialog appears, select the data file associated with the 
n-D data.

Typically, this file is the reflectance or original data. 

• If you select an input file of different spatial dimensions than the file used 
for input into the n-D Visualizer, you will be prompted to enter the X and 
Y offsets that point to the n-D subset.

3. Select from the following options:

• To plot the Z profile for the point nearest the cursor, click the middle 
mouse button in the n-D plot window.

• To add plots to the Z profile plot window in the n-D Visualizer plot 
window, click the right mouse button in the n-D plot window.
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When the Z profile plot window is open, the selected file is automatically used 
to calculate the mean spectra when you select Options → Mean Class or 
Mean All.

Importing Spectra

To import spectra from other sources such as spectral libraries:

1. Select Options → Import Library Spectra.

The input spectra must be in the same space as the n-D input data (that is, 
MNF space). 

Tip
To convert the spectra to MNF, use the Transforms → MNF Rotation → 
Apply Forward MNF to Spectra function and use the statistics you saved 
when you ran the MNF on the original data (see “Minimum Noise Fraction 
Transform” on page 682).

2. When the n-D Visualizer Import Spectra dialog appears, drag spectra into the 
black draw widget or import spectra from a Spectral Library, ROI, or ASCII 
file using the Import menu. For detailed instructions, see “Collecting 
Endmember Spectra” on page 577 for details.

3. Click Apply.

4. When the Import Spectra Parameters dialog appears, select from the following 
options to set the spectra parameters.

• To edit a spectrum name, click on the spectrum and make any changes in 
the Name text box. 

• To edit the spectrum color, click on the name and select a color from the 
Color button menu.

• To plot the spectrum in the n-D Visualizer plot window, click in the Show 
Spectrum check box.

5. Click OK.

The spectra appear in the n-D Visualizer plot window as stars with the name 
labels next to them. Note that some spectra may fall outside the current 
projection and will not be visible until you rotate the data.
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Deleting Spectra

To delete imported library spectra from the n-D Visualizer: 

1. Select Options → Delete Library Spectra.

2. Select the spectra to delete and click OK.

Editing Spectra Parameters

To change the color or name of imported library spectra and to turn spectra on or off 
in the n-D Visualizer: 

1. Select Options → Edit Library Spectra.

2. In the Import Spectra Parameters dialog, select the spectra to edit by clicking 
on the names.

3. Edit the color, change the names, and turn the Show Spectrum check box on 
or off for the individual spectra and click OK.

Plotting Mean Spectra

• To plot a mean spectrum for the current class, select Options → Mean Class. 

A file selection dialog appears to select the file to use when calculating the 
mean. Typically, this file is the reflectance data.

• To plot the mean spectra for all the defined classes, select Options → Mean 
All. 

A dialog for selecting the reflectance file appears.

If a Z profile window is active (see “Plotting Z Profiles” on page 772), the mean 
spectra are automatically extracted from the file opened in the Z profile.

Clearing Classes

• To clear the currently selected class from the n-D Visualizer, select Options → 
Clear Class.

The currently selected class is defined by the selected color under the class 
menu items in the n-D Controls dialog.

• To clear all of the classes from the n-D Visualizer, select Options → Clear 
All. 
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Exporting Classes to ROIs

After you have defined all desired classes, you can export their image pixel locations 
to Regions of Interest (ROIs). These ROIs can then be used as input for 
classifications, unmixing, matched filtering, or other techniques. 

• To export the current class to a ROI, select Options → Export Class. 

• To export all of the classes defined in the n-D Visualizer to ROIs, select 
Options → Export All. 

A Region of Interest (ROI) is created to match the spatial location of the 
corresponding image pixels. These can be used with the original reflectance image 
for extraction of endmembers and classification.

Turning Axes On/Off

• To turn the axes on or off in the n-D Visualizer, select Options → Axes:On or 
Axes:Off. 

Warning
ENVI does not keep track of which classes have already been exported to ROIs. If a 
selected class is exported more than once, multiple (identical) ROIs will be created.

Changing Mouse Functions

• To change the active mouse function in the n-D Visualizer when rotating in 
three-dimensions, select Options → 3D:ROI Definition or 3D:Drive Axes. 
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Managing n-D Visualizer States

Use the File menu in the n-D Controls dialog to save and restore the state of the n-D 
Visualizer, including the highlighted groups of pixels. 

Outputting the n-D Visualizer

• To export the n-D Visualizer display to postscript or to an image, select File → 
Save Plot As → Postscript or Image.

• To print the n-D Visualizer window, select File → Print (see “Printing” on 
page 454 for details).

Saving States

• To save the n-D Visualizer state, select File → Save State and enter an output 
filename with the extension .ndv for consistency. 

Restoring Saved States

• To restore a previously saved state, select File → Restore State and select the 
appropriate file.

• You can also restore a previously saved state by selecting Spectral → n-
Dimensional Visualizer → Visualize with Previously Saved Data.

Closing the Dialog

• To exit the n-D Visualizer, select File → Cancel.
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Mapping Methods

ENVI has many spectral mapping methods which include binary encoding, spectral 
angle mapping, linear band prediction (LS-Fit), linear spectral unmixing, matched 
filtering, mixture tuned matched filtering, continuum removal, and spectral feature 
fitting.

Using Binary Encoding

The binary encoding classification technique encodes the data and endmember 
spectra into 0s and 1s based on whether a band falls below or above the spectrum 
mean. An exclusive OR function is used to compare each encoded reference 
spectrum with the encoded data spectra and a classification image produced. All 
pixels are classified to the endmember with the greatest number of bands that match 
unless you specify a minimum match threshold—in which case some pixels may be 
unclassified if they do not meet the criteria.

• Start the Binary Encoding classification by choosing Spectral → Mapping 
Methods → Binary Encoding. For details about the classification dialogs, see 
“Applying Binary Encoding Classification” on page 606.

Spectral Angle Mapper Classification

Use Spectral Angle Mapper (SAM) to match image spectra to reference spectra in 
n-dimensions using a physically-based spectral classification method. The reference 
endmember spectra used by SAM can come from ASCII files, spectral libraries, 
statistics files, or can be extracted directly from the image (as ROI average spectra). 
SAM compares the angle between the endmember spectrum (considered as a n-
dimensional vector, where n is the number of bands) and each pixel vector in n-
dimensional space. Smaller angles represent closer matches to the reference 
spectrum. This technique, when used on calibrated data, is relatively insensitive to 
illumination and albedo effects.

• Start the SAM classification by choosing Spectral → Mapping Methods → 
Spectral Angle Mapper. For details about the classification dialogs, see 
“Applying Spectral Angle Mapper Classification” on page 604.
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Using LS-Fit (Linear Band Prediction)

LS-Fit performs a linear band prediction using a least squares fitting technique. It can 
be used to find regions of anomalous spectral response in a data set. It calculates the 
covariance of the input data and uses it to predict the selected band as a linear 
combination of the predictor bands plus an offset. The difference (residual) between 
the actual band and the modeled band is calculated and output as an image. Pixels 
with a large residual (positive and negative) indicate the presence of a feature not 
predicted (that is an absorption band). The modeled band image is also included in 
the output. The predicted band can be calculated using existing statistics or from new 
statistics.

Predicting from New Statistics

To predict a band using new statistics:

1. Select Spectral → Mapping Methods → LS-Fit (Linear Band 
Prediction) → Predict with new Statistics.

2. Select the input file and perform any subsetting.

The LS-Fit Parameters dialog appears.

3. Select the bands to be used as predictor bands by clicking on the desired band 
names.

4. Select the band to be predicted by clicking on the band name in the Select the 
Model Band list.

If this band was selected as a predictor band, it will be deselected.

5. To subsample the data when calculating the statistics, enter a resize factor less 
than one in the Stats X/Y Resize Factor text boxes.

• Enter an output statistics filename, if desired.

6. Select output to Memory or File.

The output contains two bands, the modeled band and the residual image. The actual 
band and modeled band can be compared using dynamic overlays (see “Working with 
Multiple Dynamic Overlays” on page 373). Pixels in the residual image with large 
values, both positive and negative, show where the actual and modeled bands differ. 
These resulting bands appear in the Available Bands List when the function is 
completed.
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Predicting from Existing Statistics

Use Predict from Existing Stats to use an existing statistics file for band prediction. 
Only the bands with covariance values in the statistics file can be selected as predictor 
or model bands.

1. Select Spectral → Mapping Methods → LS-Fit (Linear Band Prediction) 
> Predict from Existing Stats.

2. Select the input file and perform any spatial subsetting.

3. Select the statistics file that corresponds with the input data file.

The LS-Fit Parameters dialog appears. Only the bands used in the statistics 
calculations are available to be selected as predictor or model bands.

4. Select the bands to be used as predictor bands by clicking on the desired band 
names.

5. Select the band to be predicted by clicking on the desired band name in the 
Select the Model Band list.

If this band was selected as a predictor band, it will be deselected.

6. Select output to Memory or File.

The output contains two bands, the modeled band and the residual image. The actual 
band and modeled band can be compared using dynamic overlays (see “Working with 
Multiple Dynamic Overlays” on page 373). Pixels in the residual image with large 
values, both positive and negative, show where the actual and modeled bands differ. 
These resulting bands appear in the Available Bands List when the function is 
completed.
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Using Linear Spectral Unmixing

Use Linear Spectral Unmixing to determine the relative abundances of materials 
that are depicted in multi- or hyper-spectral imagery based on the materials’ spectral 
characteristics. The reflectance at each pixel of the image is assumed to be a linear 
combination of the reflectance of each material (or endmember) present within the 
pixel. For example, if 25% of a pixel contains material A, 25% of the pixel contains 
material B, and 50% of the pixel contains material C, the spectrum for that pixel is a 
weighted average of 0.25 times the spectrum of material A plus 0.25 times the 
spectrum of material B plus 0.5 times the spectrum of material C. So given the 
resulting spectrum (the input data) and the endmember spectra, the linear unmixing is 
solving for the abundance values of each endmember for every pixel. The number of 
endmembers must be less than the number of spectral bands and all of the 
endmembers in the image must be used. Spectral unmixing results are highly 
dependent on the input endmembers and changing the endmembers changes the 
results. For additional information, see “Spectral Tools References” on page 849 and 
“Spectral Unmixing Results” on page 782.

ENVI linear spectral unmixing has two constraint options: unconstrained or a 
partially constrained unmixing. In the unconstrained method, abundances may 
assume negative values and are not constrained to sum to unity (one). ENVI also 
supports an optional, variable-weight, unit-sum constraint in the Linear Mixing 
algorithm. This was implemented to allow for user-defined weighting of a sum-to-
unity constraint on the abundance fractions. It also permits proper unmixing of MNF-
transform data, with zero-mean bands. The user picks a weight factor (default

value = 1), for the extra constraint equation. This weighted unit-sum constraint is 
then added to the system of simultaneous equations in the unmixing inversion 
process. Larger weights in relation to the variance of the data cause the unmixing to 
honor the unit-sum constraint more closely. To strictly honor the constraint, make the 
weight many times the spectral variance of the data.

Note
If not all endmembers are known or if you only want to map a few endmembers, use 
Matched Filtering or Mixture Tuned Matched Filtering (see “Using Matched 
Filtering” on page 783 and “Using Mixture Tuned Matched Filtering” on page 785).

1. Select Spectral → Mapping Methods → Linear Spectral Unmixing. 

2. When the Unmixing Input File dialog appears, select an input file and any 
subsetting or masking. 

3. Click OK to continue.
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The Unmixing Endmember Collection dialog appears (Figure 9-9).

Use the dialog (Figure 9-9) to select endmember spectra from a variety of sources 
(ASCII spectra, spectral libraries, spectral plots, statistics files, ROIs). Spectra from 
all sources are automatically resampled to match the wavelengths of the multiband 
image being unmixed.

For detailed instructions, see “By Dragging-and-Dropping Spectra” on page 582, 
“Importing Endmember Spectra” on page 583, “Endmember Options” on page 589 
and “Managing Endmember Spectra” on page 592).

4. When all of the desired endmembers have been collected, click Apply at the 
bottom of the Endmember Collection:Unmixing dialog. 

The Unmixing Parameters dialog appears.

5. If you want to apply a unit sum constraint in the unmixing, use the arrow 
toggle button to select Yes.

• If you select Yes, enter a weight in the appropriate text box.

Figure 9-9: The Unmixing Endmember Collection Dialog

Drag-and-Drop 
Window
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This weight is added to the system of simultaneous equations in the unmixing 
inversion process. Larger weights cause the unmixing to honor the unit-sum 
constraint more closely.

6. Select either output to Memory or File.

7. Click OK to begin the spectral unmixing.

A processing status window appears.

Spectral Unmixing Results

The results of spectral unmixing appear as a series of gray-scale images, one for each 
endmember, plus a root-mean-square (RMS) error image. Higher abundances (and 
higher errors for the RMS error image) are represented by brighter pixels (larger 
floating-point numbers). For example, in Figure 9-10, the brighter pixels represent 
abundances of kaolinite unmixed from the other components using an ROI spectrum 
and the linear spectral unmixing technique. The unmixing results should have a data 
range (representing endmember abundance) from 0-1. However, negative values and 
values greater than one are possible. Infeasible abundances indicate erroneous 
endmembers. The results are dependent on the input endmembers and will change if 
the endmembers are changed. View the RMS error image to help determine areas of 
missing or incorrect endmembers.

Figure 9-10: Image Resulting from Linear Spectral Unmixing
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Using Matched Filtering

Use Matched Filtering to find the abundances of user-defined endmembers using a 
partial unmixing. Not all of the endmembers in the image need to be known. This 
technique maximizes the response of the known endmember and suppresses the 
response of the composite unknown background, thus matching the known signature. 
It provides a rapid means of detecting specific materials based on matches to library 
or image endmember spectra and does not require knowledge of all the endmembers 
within an image scene. This technique may find some false positives for rare 
materials. See “Spectral Tools References” on page 849 and “Matched Filtering 
Results” on page 784 for additional information.

Tip
Mixture Tuned Matched Filtering can be used to reduce the number of false 
positives found.

1. Select Spectral → Mapping Methods → Matched Filtering. 

2. When the Matched Filter Input File selection dialog appears, select the input 
file and any spatial subsetting, spectral subsetting or masking. 

3. Click OK.

The Endmember Collection: Matched Filter dialog appears. 

4. Import spectra to be matched. 

For detailed instructions, see “By Dragging-and-Dropping Spectra” on 
page 582, “Importing Endmember Spectra” on page 583, “Endmember 
Options” on page 589 and “Managing Endmember Spectra” on page 592).

5. When all desired spectra are selected, click Apply.

The Matched Filter Parameters dialog appears.

6. Use the arrow toggle button to select Compute New Covariance Stats and 
enter an output statistics filename or toggle to Use Existing Stats File.

7. Choose output to Memory or File.

8. From the Output Data Type menu, select an output data type: floating point 
or byte. 

• If you select Byte, enter a minimum and maximum data value to stretch to.
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9. Click OK to start the processing.

• If you selected Use Existing Stats File, select the statistics file that 
corresponds to the input data file when the file selection dialog appears.

Note
This statistics file must contain both the mean and covariance statistics for 
the input data.

A processing status window appears.

Matched Filtering Results

The results of the matched filtering appear as a series of gray-scale images, one for 
each selected endmember. Floating point results provide a means of estimating 
relative degree of match to the reference spectrum and approximate sub-pixel 
abundance, where 1.0 is a perfect match.

• When the results are loaded into a display image you should stretch the image 
(see “Using Interactive Stretching” on page 359).

Note
If you select byte data type output, use the data in the upper tail of the 
histogram for the stretch.

The data histogram of the background material is centered around 0 and the 
target (endmember) appears in the upper tail of the histogram (see Figure 9-
11). Therefore, the data in the upper tail of the histogram should be stretched 
over the range from about 0.1 to about 0.65 to show only pixels containing the 
target material. Image values in the symmetric histogram distribution centered 
on 0 are background areas.

Tip
To set a default stretch range so that the data does not have to be stretched 
each time it is displayed, see “Editing ENVI Headers” on page 104.
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Using Mixture Tuned Matched Filtering

Use Mixture Tuned Matched FilteringTM (MTMFTM) to perform matched filtering 
that also adds an output Infeasibility image to the results. The infeasibility image is 
used to reduce the number of false positives that are sometimes found when using 
matched filtering. Pixels with a high infeasibility are likely to be matched filter false 
positives. Correctly mapped pixels will have a matched filter score above the 
background distribution around zero and a low infeasibility value. The infeasibility 
values are in noise sigma units which vary in DN scale with matched filter score (see 
Figure 9-12). For additional information, see “Mixture Tuned Matched Filtering 
Results” on page 787.

Note
The Mixture Tuned Matched Filter requires a minimum noise fraction (MNF) 
transformed input file, or other data with isotropic, unit variance noise (see 
“Applying Forward MNFs to Spectra” on page 693). You can use ENVI’s Spectral 
Hourglass Wizard to guide you step-by-step through the ENVI hourglass processing 
flow, including MNF Transforms and MTMF, to find and map image spectral 
endmembers from hyperspectral or multispectral data. For details, see “Spectral 
Hourglass Wizard” on page 809.

Figure 9-11: Histogram of a Matched Filter result.
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1. Select Spectral → Mapping Methods → Mixture Tuned Matched 
Filtering. 

2. When the Mixture Tuned Matched Filter Input File selection dialog appears, 
select the input MNF file and any spatial or spectral subsetting. 

3. Click OK.

The Endmember Collection:Mixture Tuned Matched Filter dialog appears. 

4. Import spectra (in MNF space) to be matched. 

For detailed instructions, see “By Dragging-and-Dropping Spectra” on 
page 582, “Importing Endmember Spectra” on page 583, “Endmember 
Options” on page 589 and “Managing Endmember Spectra” on page 592).

Figure 9-12: Diagram Showing Mixture Tuned Matched Filtering Technique
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The spectra must be in the MNF space. They can be calculated from ROIs 
found in the MNF input file or transformed into MNF space (see “Applying 
Forward MNFs to Spectra” on page 693).

Warning
The input spectra must be pure and spectrally extreme endmembers for the 
mixture tuned matched filtering to be interpretable. These types of 
endmembers can be found using ENVI’s PPI and n-D Visualizer (see the 
ENVI Advanced Hyperspectral Analysis Tutorial).

5. When all the desired spectra are selected, click Apply.

The Mixture Tuned Matched Filter Parameters dialog appears.

6. Use the arrow toggle button to select Compute New Covariance Stats or 
toggle to Use Existing Stats File.

7. Choose output to Memory or File.

8. From the Output Data Type menu, select an output data type: floating point 
or byte. 

• If you select Byte, enter a minimum and maximum data value to stretch to.

9. Click OK to start the processing.

• If you selected Use Existing Stats File, select the statistics file that 
corresponds to the input MNF data file when the file selection dialog 
appears.

A processing status window appears.

Mixture Tuned Matched Filtering Results

The results of the mixture tuned matched filtering appear as a series of gray-scale 
images (two for each selected endmember). The matched filtering floating point 
results provide a means of estimating the relative degree of match to the reference 
spectrum and the approximate sub-pixel abundance, where 1.0 is a perfect match. 
The infeasibility results are in noise sigma units and indicate the feasibility of the 
matched filter result. Correctly mapped pixels will have a matched filter score above 
the background distribution around zero and a low infeasibility value. Pixels with a 
high matched filter result and high infeasibility are “false positive” pixels and do not 
match the target. You can use two-dimensional scatter plotting to identify the pixels 
with low infeasibilities and high matched filter scores (see “Using Two-Dimensional 
Scatter Plots” on page 427). Interactive stretching should be used to stretch the upper 
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tail of the histogram when viewing the matched filter resulting bands to show only 
pixels containing the target material (see “Matched Filtering Results” on page 784).

Using Continuum Removal

Use Continuum Removal to normalize reflectance spectra to allow comparison of 
individual absorption features from a common baseline. The continuum is a convex 
hull fit over the top of a spectrum utilizing straight line segments that connect local 
spectra maxima. The first and last spectral data values are on the hull and therefore 
the first and last bands in the output continuum-removed data file are equal to 1.0.

Tip
Using different spectral subsets gives different results, so you should spectrally 
subset the data to the region containing the absorption features of interest.

The continuum is removed by dividing it into the actual spectrum for each 
pixel in the image. The resulting image spectra are equal to 1.0 where the 
continuum and the spectra match and less than 1.0 where absorption features 
occur. Continuum removal can be performed on data files or on individual 
spectra in a plot window. For references, see “Spectral Tools References” on 
page 849.

1. Select Spectral → Mapping Methods → Continuum Removal.

2. When the Continuum Removal Input File dialog appears, select the input file 
and any spatial subsetting, spectral subsetting, or masking.

Tip
For the best results, spectrally subset around the region containing the absorption 
features of interest.

3. Click OK.

4. When the Continuum Removal Parameters dialog appears, select output to 
Memory or File.

5. Click OK to begin processing. 

A processing status window appears. The results are listed in the Available Bands list.
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Using Spectral Feature Fitting

Use Spectral Feature FittingTM (SFFTM) to compare the fit of image spectra to 
selected reference spectra using a least-squares technique. SFF is an absorption-
feature-based methodology. The reference spectra are scaled to match the image 
spectra after continuum removal from both data sets.

A scale image is output for each reference spectrum and is a measure of absorption 
feature depth which is related to material abundance. The image and reference 
spectra are compared at each selected wavelength in a least-squares sense and the 
root mean square (rms) error is determined for each reference spectrum. For more 
information, see “Spectral Tools References” on page 849 and “Spectral Feature 
Fitting Results” on page 790.

1. Select Spectral → Mapping Methods → Spectral Feature Fitting.

2. When the Spectral Feature Fitting Input File dialog appears, select the input 
file and any spatial subsetting or masking.

If the selected input file is not continuum-removed, ENVI removes the 
continuum on-the-fly. However, this makes execution of the function 
considerably slower.

3. In the Spectrally Spectral Feature Fitting Input File dialog, click Spectral 
Subset to use the File Spectral Subset dialog to subset around the region 
containing the absorption features of interest.

4. After you select your subset and then click OK in the File Spectral Subset 
dialog, click OK in the Spectral Feature Fitting Input File dialog.

The Endmember Collection: Feature Fitting dialog appears. 

5. Import the reference spectra.

For detailed instructions, see “By Dragging-and-Dropping Spectra” on 
page 582, “Importing Endmember Spectra” on page 583, “Endmember 
Options” on page 589 and “Managing Endmember Spectra” on page 592).

6. Click Apply.

7. When the Spectral Feature Fitting Parameters dialog appears, use the toggle 
arrow button to select Output separate Scale and RMS Images or Output 
Combined (Scale/RMS) Image. For more information, see “Working with 
SFF Results” in the following section.

8. Select output to Memory or File.
ENVI User’s Guide Mapping Methods



790 Chapter 9: Spectral Tools
A processing status window appears. The resulting output bands are listed in the 
Available Bands list.

Spectral Feature Fitting Results

A scale image and RMS image or a combined “fit” (Scale/RMS) image will be output 
for each reference spectrum. The scale image is a measure of absorption feature 
depth which is related to material abundance. 

The brighter pixels in the scale image indicate a better match to the reference material 
in those pixels (for areas with low RMS error). However, a large scale value (>> 1) 
can result if incorrect reference endmembers are input or if the incorrect wavelength 
range is used. The image and reference spectra are compared at each wavelength in a 
least-squares sense and the root mean square (RMS) error is determined for each 
reference spectrum. Dark pixels in the RMS error image indicate a low error and 
combined with the scale image results can be used to locate the areas that best match 
the reference spectrum. 

Working with SFF Results

• To view areas in the image that best match the reference spectrum, use two-
dimensional scatterplots to plot the scale versus RMS. Draw an ROI over the 
scatterplot area that has low RMS and high scale values to highlight the pixels 
that best match the reference spectrum.

Another way to produce results that show the distribution of the reference 
material is to use the “fit” (Scale/RMS) image. Higher fit values indicate better 
matches to the reference spectrum. 

• To generate an output classification-like result image, select Classification → 
Rule Classifier on the ENVI main menu to threshold the output images using 
a maximum threshold value.

Using Multi Range Spectral Feature Fitting

Use Multi Range SFF to apply ENVI’s Spectral Feature Fitting function using 
multiple wavelength ranges for each endmember. Spectral signatures are typically 
characterized by multiple absorption features. The Multi Range SFF function allows 
you to define multiple and different wavelength ranges around each endmember’s 
absorption features. This spectral feature fitting uses the multiple ranges in its 
comparisons. Each spectral range is interactively defined and the continuum removed 
absorption feature is plotted. Optionally, weights can be applied to each spectral 
range so more important features can be emphasized. The defined wavelength ranges 
can be saved to a file for reuse.
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The Multi Range SFF executes more slowly than the single range SFF but is likely to 
produce more accurate results. Like the single range SFF, neither the input image nor 
the reference spectra need to be continuum removed before using the Multi Range 
SFF. However, you are not required to spectrally resample the reference spectra to 
match the wavelengths of the input image, or to scale the reference spectra into the 
same range as the input image before using the Multi Range SFF. The resulting 
images can be interpreted in the same manner as the single SFF results (see “Spectral 
Feature Fitting Results” on page 790 for more information).

Using New Spectral Ranges in Multi Range SFF

1. Select Spectral → Mapping Methods → Multi Range SFF → Use New 
Ranges.

Note
If you want to run the Multi Range SFF with previously defined spectral 
ranges see “Using Previously Defined Spectral Ranges in Multi Range SFF” 
on page 793.

2. Select the input file and perform any spectral or spatial subsetting or masking 
as desired.

The Select Input Spectral Library dialog appears.

3. Open or select the desired spectral library and click OK.

4. Select the desired endmember spectra from the spectral library by clicking on 
the spectrum name in the list. Use the Ctrl key to select multiple spectra. Click 
OK.

The Edit Multi Range SFF Endmember Ranges dialog appears with a list of 
the selected endmembers.

5. Click on an endmember name and its spectrum will appear.

6. Choose which spectral ranges to use in the SFF by clicking with the left mouse 
button on the plot. A marker appears. Click and drag with the left mouse 
button to position the marker on the starting wavelength. Click the right mouse 
button and select Set as Start Range. The wavelength value will appear in the 
Start Range text box. Click with the left mouse button and move the marker to 
the ending range wavelength position. Click the right mouse button and select 
Set as End Range.
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Note
Click and drag with the middle mouse button to zoom into the spectral plot. 
Use the shortcut menu to reset the zoom range.

• You can also enter the starting and ending wavelengths in the appropriate 
text boxes. The position of the markers can also be adjusted one 
wavelength increment at a time by clicking on the arrow increment button 
next to the starting or ending range.

Note
Pressing the Enter key after entering a wavelength value causes that value to 
jump to the nearest library spectrum wavelength value.

7. Click the Add Range button, or select Add Range from the shortcut menu, 
and that range will be listed and the continuum removed selected feature will 
be plotted. The number shown next to the feature is its depth measure. This is a 
ratio of feature depth divided by continuum level so lower values indicate a 
larger feature depth.

• To remove a spectral range, click the Remove button.

• To remove the colored continuum graphic from the plot, click in the Cont 
check box.

• To remove the continuum removed feature graphic from the plot, click in 
the CR check box.

• To weight one feature more than another for that endmember, enter the 
desired weight factors. The weight factors used are calculated by summing 
the total entered weights and dividing each weight by that sum.

8. Select other spectral ranges, if desired, for that endmember using the same 
methods.

9. Click on the next endmember and select its spectral ranges.

10. When all the spectral ranges are selected, save the ranges to a file by selecting 
Save Ranges and entering an output filename.

11. Click OK. The Multi Range SFF Parameters dialog appears.

12. Select whether to output separate or combined scale and RMS images using 
the arrow toggle button (see “Spectral Feature Fitting Results” on page 790 
that describes these outputs).
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13. Enter an output filename and click OK.

The results appear in the Available Bands List.

Using Previously Defined Spectral Ranges in Multi Range SFF

1. Select Spectral → Mapping Methods → Multi Range SFF → Use Previous 
Ranges.

2. Select the input file and perform any spectral or spatial subsetting or masking 
as desired.

3. Select the file containing the previously defined spectral ranges. 

The Select Endmembers dialog appears.

4. Select the desired endmembers to use by clicking on the endmember names 
and click OK. 

The Edit Multi Range SFF Endmember Ranges dialog appears. 

5. Edit any of the ranges as desired (see “Using New Spectral Ranges in Multi 
Range SFF” on page 791 for more details).

6. Click OK. The Multi Range SFF Parameters dialog appears. 

7. Select whether to output separate or combined scale and RMS images using 
the arrow toggle button (“Spectral Feature Fitting Results” on page 790 
describes these outputs).

8. Enter an output filename and click OK.

The results appear in the Available Bands List.
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Using Endmember Collection

Use Endmember Collection to collect spectral endmembers from a variety of 
sources to use in spectral processing techniques. Endmembers can be imported from 
ASCII files, ASD binary files, spectral libraries, statistics files, or from ROI means. 
Endmember Collection also allows you to select a classification algorithm or an 
advanced spectral processing technique from the dialog.

1. Select Spectral → Mapping Methods → Endmember Collection.

2. When the Classification Input File dialog appears, select an input file and any 
spatial subsetting, spectral subsetting, and masking.

3. When the Endmember Collection: Algorithm dialog appears, use the Import 
pull-down menu to import spectral endmembers.

For detailed instructions, see “By Dragging-and-Dropping Spectra” on page 582, 
“Importing Endmember Spectra” on page 583, “Endmember Options” on page 589 
and “Managing Endmember Spectra” on page 592.
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Finding Targets with BandMax

The SAM Target Finder with BandMax wizard is used to find targets with the SAM 
(Spectral Angle Mapper) classification and the BandMax algorithm. This wizard 
leads you through the process of finding targets in hyperspectral images. The 
BandMax part of the wizard increases classification accuracy by determining an 
optimal subset of bands to help you separate your targets from known background 
materials.

You can also directly access the BandMax algorithm in ENVI from the Endmember 
Collection dialog (see “Suppressing Backgrounds with BandMax” in Chapter 6) or 
programmatically with the ENVI_BANDMAX_SELECT_BANDS function.

Note
In addition to the information provided in this section, see the tutorial in Tutorial 18, 
“Target Finding With SAM and BandMax” for a step-by-step example. 

The BandMax algorithm is provided by the Galileo Group, Inc. The process is based 
on the United States patent application titled Spectral image processing system and 
method for target detection and identification. This document was submitted by 
Timothy J. Pachter and Daniel Matthew Puchalski to the United States Patent Office 
in 2002.

This wizard walks you through the following steps:

1. Input/Output File Selection — selection of the input file and the root name of 
the output files for the wizard.

2. Select Targets — selection of spectra to be used as targets.

3. Select Backgrounds — selection of backgrounds to be suppressed.

4. Calculate the Significant Bands with BandMax — identification of significant 
bands to be used in a SAM (Spectral Angle Mapper) analysis.

5. Select SAM Maximum Angle Threshold — definition of SAM maximum 
angle parameter.

6. Investigation of Mapping Results — SAM analysis and examination of results. 
You may exit the wizard at this time if the results are acceptable.
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If examining the results from this mapping process shows that the classification 
accuracy is not sufficient, the wizard returns you to Step 2, where you can refine your 
targets and backgrounds before running BandMax and the SAM analysis again. You 
may continue to iterate through the process of refining targets, selecting backgrounds, 
using BandMax to find the appropriate band subset, and re-classifying your input 
data with SAM. When your analysis is complete, you can save and view a report of 
the processing performed in the wizard. Images resulting from specific steps in the 
wizard appear in the ENVI Available Bands List. Just as with any image processing 
tool, poor results may occur if poor input data or inappropriate parameters are 
provided.

To access the SAM Target Finder with BandMax, select Spectral → SAM Target 
Finder with BandMax from the ENVI main menu. The SAM Target Finder with 
BandMax wizard appears.

The first panel of the wizard contains an introduction to the main workflow of the 
wizard. The other panels in the wizard present the remaining 6 possible steps of this 
process. These steps may occur multiple times in different order depending upon the 
your analysis path.

Figure 9-13: SAM Target Finder with BandMax
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The overall workflow of the wizard is shown in Figure 9-14.

These steps are described in more detail in the following sections.

Figure 9-14: Workflow Process for the SAM Target Finder with BandMax Wizard
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Working with the Display

The left part of each panel in the wizard shows a brief description of the step 
presented in that panel. This description contains the requirements of the step, 
background information of the process used in the step, and useful analysis 
techniques for the step. The right part of the panel contains an interface for providing 
or displaying the information related to the step.

You can hide the left part of a panel with the Hide Text button to only show the right 
part of the wizard. If the left part is hidden, the Show Text button can be used to re-
display it. Each panel also contains a Next button for continuing to the next step and 
a Prev button for reverting back to the previous step. The Next button is only enabled 
if you provide enough information to continue in the workflow. In some cases, a 
progress bar appears if the next process is performed before the next panel is 
initialized.

Figure 9-15: A Sample Panel from the SAM Target Finder with BandMax Wizard
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Unlike other wizards in ENVI, this wizard is not linear. It has conditional paths where 
your input may induce a different direction in the workflow. You can also use the 
Next and Prev button to loop back through the wizard to repeatedly go through a set 
of steps. The Prev button maintains a list of the steps that have been performed. This 
list enables the Prev button to still work even if you to go through a conditional step 
or a series of steps looping through the wizard.

You can exit the wizard at any time by clicking the Cancel button. If you are satisfied 
with the analysis results received during the examination step (see “Examining SAM 
Results” on page 806), click the Show Report... button to view and optionally save a 
report detailing the processing and output products before exiting the wizard with the 
Finish button.

Selecting an Input File

After you click Next in the Introduction panel, the Select Input/Output Files panel 
appears. This panel represents Step 1 in the workflow (Figure 9-14). It enables you to 
specify the input file and the root name of the output files for the wizard. The right 
part of this panel contains the following items:

• Select Input File... — This button initiates a file selection dialog that allows 
you to specify the input file for the wizard. When the input file is selected, its 
root name is automatically specified as the output root name. If you want to 
specify a different root name, click the Select Output Root Name... button.

Note
This wizard classifies possible targets with SAM (Spectral Angle Mapper), 
which usually assumes reflectance data. However, the error introduced by 
using radiance data is probably (in most cases) not prohibitively large 
because the origin will still be near zero (even if it is not at zero).

• Select Output Root Name... — This button initiates the Select Output Files 
Root Name dialog that allows you to specify the root name of the output files 
created during the overall process used in this wizard. You can use either the 
text box or the Choose button in the Enter Output Filename section of this 
dialog to specify the name (including its path).

Note
If files with the specified root name already exist, you are prompted to allow 
the wizard to delete these files and continue. The files will effectively be 
overwritten. If you do not want to overwrite the files, click No and specify a 
different root name in the Select Output Files Root Name dialog.
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Selecting Targets

After you click Next in the Select Input/Output Files panel or the Investigate SAM 
Results panel, the Target Selection panel appears.

This panel represents Step 2 in the workflow (Figure 9-14). It enables you to collect 
spectra to be used as targets. The right part of this panel contains the following items:

• Select Target Spectra — This section is an embedded version of the 
Endmember Collection dialog. It contains the following options:

• File — This pull-down button menu provides the Save spectra as 
submenu, which allows you to save a collected spectrum displayed in the 
Endmember Spectra table to either an ASCII, spectral library, or 
Endmember Collection file. Any spectra saved to these types of files can 
be imported back into the wizard with the Import pull-down menu.

Figure 9-16: Target Selection Panel of the SAM Target Finder with BandMax 
Wizard
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• Import — This pull-down button menu enables you to import spectra 
from ASCII, ASD, spectral library, ROI (Region of Interest), EVF (ENVI 
vector format), Stats, or Endmember Collection files.

• Options — This pull-down button menu enables you to modify the names 
and the colors of the spectra presented in the Endmember Spectra table.

• Endmember Spectra table and related buttons — The table displays the 
spectra you have collected. You can collect spectra by importing them with 
a shortcut menu for the table or by dragging-and-dropping them into the 
table (see “Using the Endmember Spectra Table to Import Spectra” in 
Chapter 6 for more information). To select a specific spectrum in the table, 
click its related row number in the column on the far left. You can select 
multiple spectra with a Shift-click or a Ctrl-click. You can select all the 
spectra in the table with the Select All button. The Plot button is used to 
display the selected spectra in a separate plot window. The Delete button is 
used to delete the selected spectra. The Help button provides the online 
help pages for the Endmember Collection dialog.

Note
In the Endmember Spectra Table, a spectrum is not selected if its entire row 
is not highlighted. You must click in the Row Number column of a spectrum 
to select it. A spectrum cannot be selected by clicking in its Spectrum Name 
column.

All the spectra selected in the Endmember Spectra table when you click the Next 
button are used as individual target spectra in the calculation of the significant bands 
(the BandMax algorithm). You must collect at least one spectrum to continue in the 
wizard.

Note
When the wizard determines the optimal band subset with BandMax, it considers 
all specified targets and backgrounds. The best results are usually achieved if one 
target is selected for each wizard session. In this case, BandMax is able to choose a 
band subset that is optimized for that individual target.
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Specifying Backgrounds

After you click Next in Target Selection panel, the Background Selection and 
Rejection panel appears. This panel represents Step 3 in the workflow (Figure 9-14). 
It enables you to specify background data to be suppressed (rejected) in the SAM 
analysis. Background data should be provided if false positives (data included in the 
resulting class that does not represent target) may occur in the SAM analysis.

If you do not want to specify any backgrounds, toggle the Select Backgrounds to 
Reject? button in the right part of the panel to No. Then, click the Next button and 
the wizard skips to the Select SAM Mapping Parameters panel, which represents 
Step 5 in the workflow (see “Defining the SAM Maximum Angle Threshold 
Parameter” on page 805).

To specify backgrounds, toggle the Select Backgrounds to Reject? button in the 
right part of the panel to Yes. The Select Background section appears in the right 
part of the panel. This section contains the same items as the right part of the panel in 
Step 2. All the spectra selected in the Endmember Spectra table of this section are 
used as backgrounds in the calculation of the significant bands (the BandMax 
algorithm), which is performed when you click the Next button. You must collect at 
least one spectrum to continue in the wizard.

Note
In the Endmember Spectra Table, a spectrum is not selected if its entire row is not 
highlighted. You must click in the Row Number column of a spectrum to select it. 
A spectrum cannot be selected by clicking in its Spectrum Name column.
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Calculating Significant Bands (BandMax)

If you click Next in the Background Selection and Rejection panel with the Select 
Backgrounds to Reject? button set to Yes, the Select Optimal Bands panel appears.

This panel represents Step 4 in the workflow (Figure 9-14). It enables you to 
customize the band subset used to suppress your backgrounds with the BandMax 
algorithm. The BandMax algorithm calculates a subset of significant bands that are 
used in the next SAM analysis. These significance computations are performed 
automatically when you click Next in the previous panel. The computations 
determine a band significance value for each band. This unitless value is then 
compared to a significance threshold to derive a list of bands based upon the current 
list of targets and backgrounds.

Figure 9-17: Select Optimal Bands Panel of the SAM Target Finder with 
BandMax Wizard
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The results of these computations are shown in the right part of the panel, which 
contains the following items:

• Significant Bands — This list displays the bands that have been selected as 
significant by the BandMax algorithm, based upon the established unitless 
threshold.

• Band Significance Threshold — This text box and arrow buttons enable you 
to change the threshold used to derive the list of significant bands. This 
threshold and the related significance values vary from 0 to 1. The arrow 
buttons increase or decrease the threshold by no less than 0.01. The 
Significant Bands list and the Number of Significant Bands value is updated 
when you change the Band Significance Threshold value. An increase in the 
Band Significance Threshold value decreases the Number of Significant 
Bands value. If a change of 0.01 is not enough to change the number of 
significant bands, the increment is increased until a change occurs in the 
number of significant bands.

• Number of Significant Bands — This text box and arrow buttons enable you 
to change the number of significant bands resulting in the Significant Bands 
list relative to the Band Significance Threshold value. A decrease in the 
Number of Significant Bands value increases the Band Significance 
Threshold value. The arrow buttons increase or decrease the number of bands 
by at least 1. If 2 or more bands have the same significance value, a greater 
increment is used to include all of these bands.

• Save Significant Bands to File... — This button enables you to output the 
band subset displayed in the Significant Bands list to an ASCII file. When you 
have derived the subset of bands that effectively detects your targets, you may 
want to use this same band subset to perform a series of classifications on a set 
of images from the same sensor. This output ASCII file can be used as input 
when spectrally subsetting a file.

All the significant bands shown in the Significant Bands list when you click the Next 
button form a band subset that is used as input data in next steps (the SAM analysis).
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Defining the SAM Maximum Angle Threshold Parameter

If you click Next in the Background Selection and Rejection panel with the Select 
Backgrounds to Reject? button set to No or you click Next in the Select Optimal 
Bands panel, the Select SAM Maximum Angle Threshold panel appears. This panel 
represents Step 5 in the workflow (Figure 9-14). It enables you to specify the 
maximum angle threshold for the SAM (Spectral Angle Mapper) analysis. The right 
part of this panel contains the SAM Maximum Angle text box and arrow buttons.

The default value for this angle is 0.10 radians and is shown in the text box. If 
desired, you can either enter a different maximum angle in the text box or use the 
arrow buttons to increment the value by 0.05 radians. The SAM analysis is performed 
when you click the Next button in this dialog. For more information on the SAM 
classification and its parameters, see “Supervised Classification” in Chapter 6 of the 
ENVI User’s Guide.
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Examining SAM Results

After you click Next in the Select SAM Maximum Angle Threshold panel, the 
Investigate SAM Results panel appears.

This panel represents Step 6 in the workflow (Figure 9-14). It enables you to display 
and examine the results of the SAM (Spectral Angle Mapper) analysis. The SAM 
analysis is performed in between the Select Mapping Parameters and the Investigate 
SAM Results panels.

Figure 9-18: Investigate SAM Results Panel of the SAM Target Finder with 
BandMax Wizard
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The right part of this panel contains the following items:

• Load SAM Class Result — This button displays the resulting class image 
from the SAM analysis.

• SAM Rule Images — This section displays a list of the targets. You can click 
on a target in the list to select it, and then click the Load SAM Rule Image 
button to display rule image resulting from the SAM analysis for that target. 
The rule image is displayed using an inverted color table. The display is also 
linearly stretched to a maximum value specified by the Default Stretch Max 
setting in the SAM Rule Images section. The initial value of this setting is 
0.10. A histogram of the image is also displayed in a separate interactive 
stretching dialog. This histogram explicitly shows the linear stretch applied to 
the display of the rule image. A flat line in the left portion of the histogram 
indicates a good separation of targets and backgrounds.

• Show Report... — This button enables you to report the results of the SAM 
Target Finder with BandMax wizard. When you click this button, the wizard 
skips to Step 7 in the workflow (Figure 9-14). This step reports the final results 
of the wizard. For more information about this step, see “Reporting the 
Results” below.

Note
No recalculation of SAM is performed if you clicked Prev to get back to this step.

If you are satisfied with these results, click Finish to exit the wizard. If you are not 
satisfied with these results, you can refine your targets, backgrounds, or both. The 
informational text in the left part of the panels provides tips on refining targets and 
backgrounds for better results. To return to Step 2 to repeat these steps, click Next.
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Reporting the Results

After you click Show Report... in the Investigate SAM Results panel, the SAM 
Target Finder with BandMax Summary Report text window appears. This text 
window reports the following results for the SAM Target Finder with BandMax 
wizard:

• Input file (and any spatial subset) for the wizard

• Specified targets

• Specified backgrounds

• Specified band significance threshold

• Resulting significant bands subset

• Output files of the SAM analysis

• Specified maximum angle parameter for the SAM analysis

You can use the File → Save Text to ASCII... option in the text window to save this 
information to a text file. When you choose this option, the Output Report Filename 
dialog appears. Use the Choose button or the text box in the Enter Output Filename 
section of this dialog to specify the name of the output text file. The information is 
saved to the specified file when you click the OK button in the dialog. You can exit 
out of this report by selecting the File → Cancel from the text window.
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Spectral Hourglass Wizard

Use the new Spectral Hourglass Wizard to guide you step-by-step through the ENVI 
hourglass processing flow (see Figure 9-19) to find and map image spectral 
endmembers from hyperspectral or multispectral data. The wizard is a unique ENVI 
feature in that it displays detailed instructions and useful information for each 
function on-screen. 

The hourglass processing flow uses the spectrally over-determined nature of 
hyperspectral data to find the most spectrally pure (or spectrally unique) pixels 
(called endmembers) within the data set and map their locations and sub-pixel 
abundances. This processing flow begins with reflectance or radiance input data and 

Figure 9-19: End-to-End Hyperspectral “Hourglass” Processing in ENVI
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aids you in spectrally and spatially subsetting the data. It helps you to visualize the 
data in n-dimensions and cluster the purest pixels into endmembers, and optionally 
allows you to supply your own endmembers. It also helps you map the distribution 
and abundance of the endmembers, use ENVI’s Spectral Analyst to aid you in 
identifying the endmembers, and aids you in reviewing the mapping results. 

Each step in the wizard executes a stand-alone ENVI function and all steps can be 
performed using the individual functions separately. Detailed documentation for the 
functions used in this wizard can be found in this manual under each separate 
function name (that is, Forward MNF Transform, n-Dimensional Visualizer, etc.). 
The name of the function executed in each step appears in the top panel of the screen. 
Results from specific steps are output to the Available Bands List and can be viewed 
using standard ENVI methods. Various plots appear to help assess results along the 
way.

Wizard Processing Flow

The Wizard has individual panels that take you through the following steps:, which 
are outlined further in Figure 9-20 and explained step-by-step in “Using the Spectral 
Hourglass Wizard” on page 813.

1. Introduction

2. Input/Output file selection

3. Minimum Noise Transform (MNF)

4. Review of MNF results

5. Data dimensionality determination

6. Derive endmembers from data or select user endmembers

7. Pixel Purity Index (PPI)

8. Examine PPI results

9. n-Dimensional Visualization and endmember selection

10. Option to input user supplied endmembers

11. Mapping with the Spectral Angle Mapper (SAM) and/or Mixture Tuned 
Matched Filtering (MTMF)

12. Investigate mapping results

13. Summary report.
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Figure 9-20: Each Step Within The Spectral Hourglass Wizard Flow Chart 
Represents a Panel in the Wizard
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Wizard Basics

To successfully use the Spectral Hourglass Wizard, familiarize yourself with the 
basic functions and concepts as shown in Figure 9-21 and as described following the 
figure:

• Text in the top panel of the Wizard provides background information and 
guidance for each step. It is very important that you read this information 
before proceeding with each step. Use the vertical and horizontal scroll bars to 
view all of the text.

Figure 9-21: The Spectral Hourglass Wizard Screen with the Select Input/Output Files 
Panels Displayed

Function Title

Use the scroll bars
to see all of the text
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Important Information
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bottom panel

Click here to close 
the wizard

Click these buttons to move backward 
and forward through the steps
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• Enter and select the parameters for that step using the buttons and text boxes in 
the bottom panel.

• Use the <-Prev and Next -> buttons to step through the wizard.

• Each processing step will execute when the Next -> button is selected.

• If the Next -> button is not available for selection make sure that all the 
necessary parameters have been set.

• Use the <-Prev button to go back to a previous step to modify parameters and 
run that step again.

• The results of the processing steps appear in the Available Bands List.

• You can examine the results of a function at any time during the wizard 
process using standard ENVI display functions.

• Various plots are displayed during processing and can be saved by selecting 
File → Save Plot As in the plot window.

• To display only the title of each panel and not the text, click with the right 
mouse button in the text and select Display Title Only from the shortcut 
menu. To redisplay the text, click the right mouse button and select Display 
Full Text from the shortcut menu.

Using the Spectral Hourglass Wizard

This section provides instructions for using the new Spectral Hourglass Wizard.

Warning
The Wizard can guide you through the steps involved in state-of-the-art 
hyperspectral processing, but it is no substitute for a firm foundation of remote 
sensing knowledge. Without such a foundation, it is possible to produce poor results 
despite the power of the algorithms involved.

1. Select Spectral → Spectral Hourglass Wizard.

The ENVI Spectral Hourglass Wizard window appears, displaying the 
Introduction panels.

2. After reading the introduction, click the Next -> button.

The Select Input/Output Files panel appears.

3. Select an input file and perform any subsetting using standard ENVI methods. 
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The Output Root Name defaults to the root name of the selected input file. 
For example, if the input file is boulder.img, then the output file for each 
process will be boulder appended with a function-dependent suffix (for 
example boulder.mnf).

• To change the output root name, click the Select Output Root Name 
button and enter or choose a different root name.

4. Click the Next -> button.

5. In the Forward MNF Transform panels, enter or select the number of output 
MNF bands.

Note
It is recommended that you use the default number of bands to preserve full 
data dimensionality.

• To use only a subset of a file to calculate noise statistics for the whole file, 
click the Shift Difference Spatial Subset button.

6. Click the Next -> button.

The Calculating Forward MNF panels appear and progress windows display 
the status of the MNF process.

After the processing is complete, the View MNF Results panels and an 
Eigenvalue plot window appear. 

7. Choose whether to load the MNF result into an ENVI display as an RGB 
image and/or load the MNF result as a grayscale animation.

Refer to the wizard text for descriptions of these two options. For details about 
ENVI animation, see “Creating Animations” on page 422.

8. After displaying and analyzing the MNF result, click the Next -> button in the 
wizard.

The Determine Data Dimensionality panels appear.

9. In the Calculate Dimensionality panels, refer to the wizard text for instructions 
before clicking the Calculate Dimensionality button or changing the Data 
Dimensionality value.

10. Click the Calculate Dimensionality button. 

The Spatial Coherence Threshold plot appears.

11. Evaluate the Spatial Coherence Threshold plot.
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• To calculate the data dimensionality using a different value, click Cancel 
in the plot window, enter a new value in the Data Dimensionality text box 
and click Calculate Dimensionality.

12. Click OK in the plot window, then click Next -> in the wizard.

The Derive or Select Endmember panels appear.

13. Select from the following options for selecting endmembers to be used in the 
classification and unmixing of the image:

• To derive endmembers from the input image, see “Deriving Endmembers 
from the Input Image”.

• To manually select endmembers from another source, such as a spectral 
library or an ROI, click the arrow button and select No. Click Next -> to 
display the User Supplied Endmember screen, then refer to “Manually 
Selecting Endmembers” on page 816 for instructions.

Deriving Endmembers from the Input Image

1. In the Derive or Select Endmember panels, select Yes and click Next ->.

The Pixel Purity Index panels appear.

2. Refer to the wizard text for information and instructions. 

• To change the number of iterations, the threshold value, or your system 
memory usage, enter or change the values in the corresponding text boxes.

3. Click the Next -> button.

The Calculating Pixel Purity Index panels appear and progress windows 
display the status of the operation.

4. Refer to the wizard text for information about how the Pixel Purity Index 
calculation works.

The Pixel Purity Index plot is displayed and the PPI Results screen appears.

5. Refer to the on-screen information and click Next ->.

The n-D Visualizer is displayed and the n-D Visualizer panels appear in the 
wizard.

6. Refer to the wizard text for information and instructions for retrieving 
endmembers from the n-D Visualizer.

• To plot endmembers once they are loaded into the wizard, click “Plot 
Endmembers.”
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• To use ENVI’s Spectral Analyst to aid you in identifying the endmembers, 
click on Start Spectral Analyst. Double-click with the left mouse button 
on the endmember name to identify in the Endmember List. For details 
about the Spectral Analyst see “Spectral Analyst” on page 820.

Note
For further details about the n-D Visualizer, see “The n-Dimensional 
Visualizer” on page 763.

7. Click the Next -> button.

The User Supplied Endmembers panels appear. 

8. Select from the following options:

• To manually supply the endmembers for mapping from another source, 
such as a spectral library or an ROI, see “Manually Selecting 
Endmembers”.

• To use endmembers for mapping from the image, click the arrow button to 
select No then click Next -> to display the Mapping Methods screen. 
Proceed to “Performing Classification, MTMF, and Spectral Unmixing” 
on page 817 for instructions.

Manually Selecting Endmembers

1. In the User Supplied Endmember panels, select Yes to manually extract 
endmembers from the data.

The Endmember Collection dialog and Endmember Collection panels appear.

2. Collect the endmembers using standard ENVI endmember collection methods 
(see“Collecting Endmember Spectra” on page 577) and follow the on-screen 
instruction for loading them into the wizard.

• To view a plot of the collected endmember spectra, click Plot 
Endmembers.

• To use ENVI’s Spectral Analyst to aid you in identifying the endmembers, 
click on Start Spectral Analyst. Double-click with the left mouse button 
on the endmember name to identify in the Endmember List. For details 
about the Spectral Analyst see “Spectral Analyst” on page 820.
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3. In the wizard, click the Next -> button.

The Mapping Methods panels appear. 

4. Proceed to the next section, “Performing Classification, MTMF, and Spectral 
Unmixing”, for instructions.

Performing Classification, MTMF, and Spectral Unmixing

1. In the Mapping Methods panel of the Spectral Hourglass Wizard, choose 
whether to perform a SAM classification, a Mixture-Tuned Matched Filtering 
(MTMF) operation, and/or spectral Unmixing.

Refer to the wizard text for descriptions of the three options.

2. Click the Next -> button.

3. Progress windows display the progress of the operations.

From the Examine Results For drop-down menu, choose SAM, MTMF, or 
Unmix.to switch between the Investigate SAM Results, Investigate MTMR 
Result, and Investigate Unmix Results panels.

4. Follow the wizard instructions for examining SAM, MTMF, or Unmixing 
results.

Tip
To load a SAM rule image, MTMF rule image, or Unmix Abundance image into a 
display, double-click on the image name in the list.

Summary Report

1. Click the Next -> button.

A Summary Report appears (see Figure 9-22).
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2. Follow the wizard instructions for saving and reviewing the summary report.

3. Click the Finish button to exit the wizard.

Automated Spectral Hourglass

Use Automated Spectral Hourglass to run Spectral Hourglass Wizard processing 
from a single screen (see Figure 9-23) without any intermediate user interaction. The 
steps include MNF, PPI, automatic endmember prediction from the n-Dimensional 
Visualizer, and SAM, MTMF, and Unmixing mapping methods. All the parameters 
needed for these functions are set in the Automated Hourglass Parameters dialog and 
each step runs without your interaction.

Figure 9-22: A Wizard Summary Report
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Output from all the intermediate steps appear in the Available Bands List, spectral 
libraries, and plot windows so you can investigate each step for correctness. Regions 
of Interest containing the pixels used in the mapping methods are output and the 
mean spectra used as endmembers are output to a text file and spectral library.

Warning
It is not recommended that you use this function unless you are very familiar with 
the Spectral Hourglass Wizard and appropriate parameters. You will most likely 
achieve better results if you run the Spectral Hourglass Wizard and interactively 
select your parameters and endmembers using the wizard guidelines.

The following steps show how to use this automated wizard:

1. From the main ENVI menu bar, select Spectral → Automated Spectral 
Hourglass. 

Default values for the parameters of the wizard are displayed in the Automated 
Hourglass Parameters dialog. 

2. Edit the values or accept the defaults.

Figure 9-23: The Automated Hourglass Parameters Dialog
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Spectral Analyst

Use ENVI’s Spectral AnalystTM to help identify materials based on their spectral 
characteristics. The Spectral Analyst uses ENVI techniques, such as binary encoding, 
Spectral Angle Mapper, and Spectral Feature Fitting to rank the match of an 
unknown spectrum to the materials in a spectral library (see “Using Binary 
Encoding” on page 777, “Spectral Angle Mapper Classification” on page 777, and 
“Using Spectral Feature Fitting” on page 789 for method descriptions). You can also 
define your own spectral similarity techniques and add them to the Spectral Analyst 
(see Spectral Analyst Functions in the ENVI Programmer’s Guide). The output of the 
Spectral Analyst is a list of the materials in the input spectral library ranked in order 
of best to worst match. An overall similarity score, and individual 0 to 1 scores for 
each method are reported. For more information, see “Tips for Successful Use of the 
Spectral Analyst” on page 823.

Warning
This function does not identify spectra, it just recommends likely candidates for 
identification. The results may change when the similarity methods used or weights 
are changed. It is still up to you to make the actual identification.

Opening the Spectral Analyst

Note
A plot window must be displayed.

1. Select Spectral → Spectral Analyst.

2. When the Spectrum Analyst Input Spectral Library dialog appears, select the 
spectral library to use for the comparisons and click OK.

The Edit Identify Methods Weighting dialog appears.

3. In the Weight text box for each similarity method, enter the desired weighting 
factors.

The weighting factors can have any value. A perfect match to a library 
spectrum would have an output Score of the sums of the weights.

Tip
A recommended starting point is to use a weight of 1.0 in Spectral Feature 
FittingTM.
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4. Edit the Min and Max factors for each method if desired.

Use the Min and Max factors to indicate which values are considered a perfect 
match by scaling them to 0 to 1 (or 1 to 0) scores. 

• For the Spectral Angle Mapper (SAM) method, enter the min and max 
values in radians. (The similarity to the library spectra are measured as an 
angle in radians.)

• For the Spectral Feature Fitting (SFF) method, enter the min and max 
values in RMS error units. (The similarity is measured using the RMS fit 
error.)

A SAM or SFF result less than or equal to the min value indicates a perfect 
match and gets a score of 1. A SAM or SFF result greater than or equal to 
the max value gets a score of 0. 

• For the binary encoding method, enter the min and max values as a 
percentage of bands correctly matched (0-1).

A binary encoding result less than or equal to the min value gets a score of 
0 and a result greater than or equal to the max value a gets a score of 1.

See “Spectral Angle Mapper Classification” on page 777, “Using Spectral 
Feature Fitting” on page 789, and “Using Binary Encoding” on page 777 for 
method descriptions.

5. In the Edit Identify Methods Weighting dialog, click OK.

6. The Spectral Analyst window appears. Use the Spectral Analyst window to 
open a new spectral library, edit the weights and min and max values, input x 
and y scale factors, and get input spectra from a Z-profile plot (see the 
following Spectral Analyst Options section) When a spectrum is displayed, the 
Spectral Analyst works over the range displayed in the plot being analyzed.

7. In the Spectral Analyst window, click Apply to load a spectrum.

• If one spectral plot is open, that spectrum is automatically entered into the 
Spectral Analyst.

• If more than one spectrum is plotted, select the desired spectrum name.

• Spectra can also be entered directly from a Z-profile window.

The results of the similarity measures are listed. ENVI resamples the spectral library 
to match the spectral resolution of the input spectrum.
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Spectral Analyst Options

Use the Spectral Analyst window to open a new spectral library, edit the weights and 
min and max values, input x and y scale factors, and get input spectra from a Z-
profile plot.

Setting Wavelength Ranges

To use a specific wavelength range:

1. In the plot window, use the middle mouse button to zoom to the desired 
wavelength range.

2. In the Spectral Analyst dialog, click Apply.

Displaying Library Spectra with Input Spectra

• To display the input spectrum and a selected library spectrum (with the 
continuum removed) in a plot together, double click with the left mouse button 
on the library name in the Spectral Analyst list.

Opening New Spectral Libraries

To open a new spectral library file to use in the comparisons:

1. In the Spectral Analyst window, select File → New Spectral Library File.

2. When the Spectral Analyst Input Spectral Library dialog appears, select the 
spectral library to use for the comparisons.

Editing Weighting Factors

To edit the methods’ weighting factors and min and max values:

1. In the Spectral Analyst window, select Options → Edit Method Weights.

2. When the Edit Identify Methods Weighting dialog appears, edit the weight 
factors and min and max.

Entering X and Y Scale Factors

To enter or edit X and Y scale factors used to scale the input spectrum into the same 
space as the spectral library:

1. Select Options → Edit (x,y) Scale Factors.

2. When the Edit (x,y) Scale Factors dialog appears, enter the desired X and Y 
scale factors.
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Entering Spectra from Z Profiles

To enter spectra directly from a Z-profile window:

1. Open a Z-profile plot (see “Extracting Z Profiles” on page 378). 

2. In the Spectral Analyst window, select Options → Auto Input via Z-profile.

3. In the Select Z Profiles dialog, click on a Z profile names.

4. Click OK.

5. In the Main Image or Zoom window, click on a pixel to be analyzed. 

The Z Profile is updated and the spectral comparison information appears in 
the Spectral Analyst window. As you move the zoom box or in the Main 
display, the information in the Spectral Analyst changes accordingly.

Tip
If you have two images displayed, you must select Options → Clear Auto Inputs 
before using the Spectral Analyst in the second display.

Understanding the Spectral Analyst Information

The output of the Spectral Analyst is a ranked or weighted score for each of the 
materials in the input spectral library. The highest score indicates the closest match 
and indicates higher confidence in the spectral similarity. Similar materials may have 
relatively high scores, but unrelated materials should have low scores. 

Tips for Successful Use of the Spectral Analyst

The Spectral Analyst is based on use of spectral matching techniques that have 
specific requirements for successful operation. The items in this section summarize 
some of factors needed to effectively use the Spectral Analyst.

Wavelength Ranges

Many materials are similar in one wavelength range, yet very different in another 
range. For best results, use the wavelength range that contains the diagnostic 
absorption features. When a spectrum is displayed, the Spectral Analyst works over 
the range displayed in the plot being analyzed. If a sub-range is desired, use the 
middle mouse button in the plot to zoom in on the desired wavelength range before 
clicking Apply in the Spectral Analyst.
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Methods

Determine whether materials have absorption features. If they do, Spectral Feature 
Fitting is probably the best method. Otherwise, Spectral Angle Mapper and/or Binary 
Encoding will give better results.

Absence of Materials in the Library (Similarity to other 
Materials)

Materials of interest in the image spectra that are not in the reference spectral library 
will not be identified. If a material is not in the reference spectral library, materials 
similar to it may score relatively high.

Multiple Materials (Mixtures)

High scores for multiple materials may indicate mixtures, particularly for minerals 
that have absorption features in different parts of the spectrum. Because of this, it is 
best to run the Spectral Analyst function on the results of endmember 
determination— the “pure” endmember spectra.

Score Magnitude and Score Separation

Higher scores indicate higher confidence, because more of the rules have been 
satisfied. Greater separation between adjacent scores indicates higher confidence in 
the similarity. For example a score of 0.98 for one material followed by a score of 
0.96 for another material indicates that the unknown is very similar to both sets of 
rules, whereas a score of 0.98 for one material and a score of 0.50 for another mineral 
indicates a high probability that the spectrum represents the first material.

Multiple Matches (same score)

In many cases, the Spectral Analyst may list multiple identical scores for different 
materials in the rule base. This indicates that the Analyst can not discriminate the two 
materials under the conditions being used for identification. In that case, try a 
different wavelength range or use the different weighted methods to produce a unique 
answer.
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No Match (Zero Score)

In some cases, the Spectral Analyst may list a score of 0.000 (no match) for all 
materials in the library. This is a good indication that the material is not in the 
spectral library used, as well as not similar to other materials in the library.

Context

Finally, examine the spectral ranking in the context of the image setting and known 
information. If a suggested identification seems invalid with respect to the known 
information, it is probably not the correct identification.

Spectral Analyst Caution

This tool is not foolproof. It is meant to be used as a starting point to put you on the 
right track towards identifying the materials in an image scene. Used properly and 
with a good spectral library, it can provide excellent suggestions for identification. 
Used blindly, it can produce totally erroneous results.

Figure 9-24: A Spectral Analyst Result
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Multi Range SFF

Use Multi Range SFF options to define or edit spectral ranges for use in ENVI’s 
Multi Range Spectral Feature Fitting mapping method. Spectral signatures are 
typically characterized by multiple absorption features. The Multi Range SFF 
function allows you to define multiple, and different, wavelength ranges around each 
endmember’s absorption features. Each spectral range is interactively defined and the 
continuum removed absorption feature is plotted. Optionally, weights can be applied 
to each spectral range so more important features can be emphasized. The defined 
wavelength ranges are saved to a file and can be used in ENVI’s Multi Range Spectral 
Feature Fitting mapping method (see “Using Multi Range Spectral Feature Fitting” 
on page 790 for more information).

Tip
To execute the Multi Range SFF function, select Spectral → Mapping 
Methods → Multi Range SFF.

Defining New Spectral Ranges

1. Select Spectral → Multi Range SFF → Define New Ranges.

2. Select the desired spectral library and click OK.

3. Select the desired endmember spectra from the spectral library by clicking on 
the spectrum name in the list. Use the Ctrl key to select multiple spectra. Click 
OK.

The Edit Multi Range SFF Endmember Ranges dialog appears with a list of 
the selected endmembers.

4. Click on an endmember name and its spectrum will appear.

5. Choose which spectral ranges to use in the SFF using methods described in 
“Using Multi Range Spectral Feature Fitting” on page 790.

6. Click OK and enter an output filename.

Use these spectral ranges in ENVI’s Multi Range SFF mapping method.
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Editing Previously Defined Ranges

1. Select Spectral → Multi Range SFF → Edit Previous Ranges.

2. Select the SFF parameters filename.

3. Click on an endmember name and its spectrum and the previously defined 
ranges will appear.

4. Edit the spectral ranges using methods described in “Using Multi Range 
Spectral Feature Fitting” on page 790.

5. Click OK to update the parameters file.

Use these spectral ranges in ENVI’s Multi Range SFF mapping method.
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Extracting Endmembers with SMACC

The Sequential Maximum Angle Convex Cone (SMACC) spectral tool finds spectral 
image endmembers and their abundances throughout an image. This tool is designed 
for use with previously calibrated hyperspectral data. In comparison to ENVI’s 
Spectral Hourglass Wizard, the SMACC tool provides a faster and more automated 
method for finding spectral endmembers, but it is more approximate and yields less 
precision.

Endmembers are spectra that are chosen to represent pure surface materials in a 
spectral image. Endmembers that represent radiance or reflectance spectra must 
satisfy a positivity constraint (containing no values less than zero). Other physically-
based constraints may be imposed, such as a sum to unity constraint (the pixels are 
weighted mixtures of the endmembers) or a sum to unity or less constraint (the pixels 
are weighted mixtures of the endmembers plus black). If the hyperspectral data are 
calibrated to either radiance or thermal IR emissivity, a sum to unity unmixing 
constraint should be used. If the data are calibrated to reflectance, either a positivity 
only or sum to unity or less constraint should be used. The SMACC tool allows 
selection of any of these constraints.

The SMACC method uses a convex cone model (also known as Residual 
Minimization) with these constraints to identify image endmember spectra. Extreme 
points are used to determine a convex cone, which defines the first endmember. A 
constrained oblique projection is then applied to the existing cone to derive the next 
endmember. The cone is increased to include the new endmember. The process is 
repeated until a projection derives an endmember that already exists within the 
convex cone (to a specified tolerance) or until the specified number of endmembers 
have been found.

In other words, the SMACC method first finds the brightest pixel in the image, then it 
finds the pixel most different from the brightest. Then, it finds the pixel most different 
from the first two. The process is repeated until the SMACC method finds a pixel 
already accounted for in the group of the previously found pixels or until the 
specified number of endmembers has been found. The spectra of pixels found by the 
SMACC method become the endmembers of the resulting spectral library.

Unlike convex methods that rely on a simplex analysis, the number of endmembers is 
not restricted by the number of spectral channels. Although endmembers derived 
with the SMACC method are unique, a one-to-one correspondence does not exist 
between the number of materials in an image and the number of endmembers. The 
SMACC method derives endmembers from pixels in an image. Each pixel may 
contain only one type of material or it may contain a high percentage of a single type 
of material with unique combinations of other types of material. Each material type 
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identified in an image is described by a subset spanning its spectral variability. The 
SMACC method provides an endmember basis that defines each of these material 
subsets. The SMACC method also provides abundance images to determine the 
fractions of the total spectrally-integrated radiance or reflectance of a pixel 
contributed by each resulting endmember.

Mathematically, the SMACC method uses the following convex cone expansion for 
each pixel spectrum (endmember), defined as H:

where:

• i is the pixel index;

• j and k are the endmember indices from 1 to the expansion length, N; 

• the R matrix contains the endmember spectra as columns; 

• c is the spectral channel index; and 

• the A matrix contains the fractional contribution (abundance) of each 
endmember j in each endmember k for each pixel.

The two-dimensional matrix representation of a spectral image is factored into a 
convex two-dimensional basis (a span of a vector space) times a matrix of positive 
coefficients. In the image matrix (R), the row elements represent individual pixels and 
each column represents the spectrum of that pixel. The coefficients in A are the 
fractional contributions or abundances of the basis members of the original matrix. 
The basis forms a multidimensional convex cone within its subset. The convex cone 
of the data is the set of all positive linear combinations of the data vectors, while the 
convex hull is the set of all weighted averages of the data. The factor matrices are 
then determined sequentially. At each step a new convex cone is formed by adding 
the selected vector from the original matrix that lies furthest from the cone defined by 
the existing basis.

Gruninger, J, A. J. Ratkowski and M. L. Hoke. “The Sequential Maximum Angle 
Convex Cone (SMACC) Endmember Model”. Proceedings SPIE, Algorithms for 
Multispectral and Hyper-spectral and Ultraspectral Imagery, Vol. 5425-1, Orlando 
FL, April, 2004.
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Using the SMACC Spectral Tool

The new SMACC spectral tool can be accessed from the ENVI main menu, or 
programmatically by using ENVI_SMACC_DOIT.

1. From the ENVI Main menu, select Spectral → SMACC Endmember 
Extraction.

2. In the Select Input Image dialog, open your input image or highlight an 
existing input image. 

3. Select OK.

The SMACC Endmember Extraction Parameters dialog appears. It contains 
the following items.

• Number of Endmembers — A value specifying the number of 
endmembers to be extracted from the image. This field only accepts 
positive integers. The default value is 30.

• RMS Error Tolerance — This value specifies the unmixing RMS error 
tolerance. If set, the process exits as soon as this value is met. It halts 
regardless of whether the number of endmembers has been reached or not. 
The recommended starting value is 0.01 for reflectance data and 1 for 
radiance data. The default value is 0, which returns all the requested 
endmembers.

• Data units should be considered when choosing the tolerance. For 
example, RMS errors for reflectance should be lower than for most 
radiance units.

• Unmixing Constraint for Endmember Abundances — One of three 
unmixing constraints will be applied for the endmember extraction.

A. Positivity Only — The best constraint for unmixing reflectance spectra 
under conditions of variable illumination. This setting is the default.

B. Sum to Unity or Less — Use this constraint when a strict physical 
interpretation of material and shadow fractions of the abundances of 
reflectance data is desired. If this constraint is used, the output abundance 
cube contains the Number of Endmembers+1 bands. The first resulting 
band is defined as Shadow Abundance.

C. Sum to Unity — Use this constraint when a zero endmember is not 
physically plausible or when you want to find very dark endmembers, such 
as shadow endmembers. This option is recommended for unmixing spectra 
such as radiance or thermal IR emissivity. 
Extracting Endmembers with SMACC ENVI User’s Guide



Chapter 9: Spectral Tools 831
• Coalesce Redundant Endmembers — Each reference spectrum is 
compared to all other reference spectra by taking all of the iterative dot 
products. Any group of spectra that have angles between them of less than 
the specified threshold (as determined by the dot product) are reduced to 
the spectrum that is determined to be the most extreme point in the convex 
hull. If this option is selected, you must enter a Spectral Angle Mapper 
(SAM) threshold value for spectral similarity. The SAM Coalesce Value 
default value is 0.100000.

• Endmember Location ROIs — If an output filename is entered, then an 
ROI file is generated with a single region corresponding to the location of 
each endmember pixel.

• Abundance Image — If Output Result to: File is selected, choose a 
filename. The resulting file is generated with a band for each endmember. 
If the Sum to Unity or Less option in the SMACC Endmember Extraction 
Parameters dialog is selected, the first band corresponds to the shadow 
endmember.

• Generating abundance images is an optional process. If Output Result to: 
File is selected but a filename is not entered, abundance images are not 
generated.

• Select Output Spectral Library — You can select the name of the file to 
which the output endmember spectral library will be saved, or specify for 
the output spectral library to go to Memory.

• If Output Result to: File is selected, you are required to enter an output 
filename.

• Queue — Clicking this button places the process in the ENVI Queue 
Manager. See “Placing Un-executed Functions in Queue” in Chapter 1 of 
the ENVI User’s Guide for more information on the ENVI Queue 
Manager.

4. When you are satisfied with your settings for the SMACC Endmember 
Extraction Parameters, click OK in the dialog to start the SMACC process.
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After the processing has completed, the spectral library file containing the resulting 
endmembers appears in the Available Bands List. Additionally, two ENVI Plot 
windows are opened: 

• Maximum Relative Error Plot Window — This window contains the RMS 
error of each respective endmember.

• Endmembers Spectral Library Plot Window — This plot shows the spectral 
signature of each of the endmembers resulting from the SMACC Endmember 
Extraction process. This collection of endmember spectra can be saved as a 
spectral library which can be used in other spectral analyses.
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Spectral Math

Use Spectral MathTM to apply mathematical expressions or IDL procedures to 
spectra (and to selected multiband images). The spectra can be either from a 
multiband image (that is, a Z profile), a spectral library, or an ASCII file (see 
“Extracting Z Profiles” on page 378, “Opening Spectral Libraries” on page 746, and 
“Importing Spectra from Spectral Libraries” on page 586). If one or more images are 
open and the number of bands matches the number of channels in one of the 
displayed spectra, those images will also be available for processing. Spectral math 
can be used to apply mathematical expressions to all of the bands of multiband 
images provided that the number of bands and number of spectral channels match. 

Note
To apply Spectral Math, at least one spectrum must be open and displayed in a plot 
window and each spectrum to be processed must be displayed. 

• Select Spectral → Spectral Math.

The Spectral Math dialog appears. The dialog accepts any valid IDL mathematical 
expression, function, or procedure provided that the result can be expressed as a 
vector (a one-dimensional array) if you are processing spectra or a two-dimensional 
array if you are processing images.

Figure 9-25: Spectral Math Dialog
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Note
When using expressions in Spectral Math, the operations are performed in the input 
data type (byte, integer, floating-point, etc.). Use the conversion functions in Table 
9-1 to explicitly set the desired data type of each input band.

Series and 
Scalar Math 

Trigonometric 
Functions Other Spectral Math Options

Addition (+) Sine (sin(x)) Relational Operators (EQ, NE, LE, 
LT, GE, GT)

Subtraction (–) Cosine (cos(x)) Boolean Operators (AND, OR, XOR, 
NOT)

Multiplication (*) Tangent (tan(x)) Type conversion functions (byte, fix, 
long, float, double, complex)

Division (/) ArcSine (asin(x)) IDL functions that return array results

Minimum 
operator (<)

ArcCosine (acos(x)) IDL procedures that return array 
results

Maximum 
operator (>)

ArcTangent 
(atan(x))

User IDL functions and procedures

Absolute Value 
(abs(x))

Hyperbolic Sine 
(sinh(x))

Square Root 
(sqrt(x))

Hyperbolic Cosine 
(cosh(x))

Exponent (^) Hyperbolic Tangent 
(tanh(x))

Natural Exponent 
(exp(x))

Natural 
Logarithm 
(alog(x))

Table 9-1: Functions and Operators (shown in parenthesis) 
Used in Spectral Math.
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Entering Mathematical Expressions

The table lists the types of functions and operators that can be used in Spectral Math 
expressions. For a description of how to use your own procedures and functions in 
spectral math, see “Using IDL Functions in Spectral Math” on page 838.

1. In the Spectral Math dialog, enter the desired mathematical expression, 
including variable names, into the text box labeled Enter an expression.

The expression will be assigned to the entire spectrum or image.

Variable names must begin with the character “s” or “S” followed by up to 5 
numeric characters. For example, if you wanted to calculate the average of six 
spectra, the mathematical equation (s1+s2+s3+s4+s5+s6)/6 could be entered 
into the text box (where “s1” is one spectrum, “s2” a second spectrum, and 
“s3” a third spectrum, and so on). Previously saved expressions can also be 
recalled from disk (see “Using Previous Expressions”).

2. After an acceptable expression is entered, click OK to continue.

The Variable/Spectra Pairings dialog appears (see “Assigning Spectra to Variables” 
on page 836). 

Using Previous Expressions

You can reuse, save, or recall any previously-applied math expressions. 

1. In the Spectral Math dialog, click on an expression in the Previous 
Expression list to enter it into the Enter an expression text box.

2. After it is entered, the expression can be applied to a new set of spectra by 
clicking OK and following the procedures described under “Assigning Spectra 
to Variables” on page 836.

Clearing Expressions

• To clear all expressions from the Previous Expressions list, click the Clear 
button.

Deleting Expressions From the List

• To delete a single expression from the list, click on it to highlight it and click 
the Delete button.
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Saving Expressions to Files

1. In the Spectral Math dialog, click the Save button.

2. Enter an output file name and click OK.

The output filename should be given the file extension .exp (both Band Math 
and Spectral Math functions can use these .exp files).

Restoring Saved Expressions

• To restore previously saved expressions, click Restore and select the desired 
file name.

Adding Expressions to the List

• To add an individual expression to the Previous Band/Spectral Math 
Expressions list, enter it in the Enter an Expression text box and click the 
Add to List button. 

Saving Expressions Without Running

You can save expressions to a file without having to first run them through the Band 
or Spectral Math function. 

• To do this, give the current expression list a filename with a .exp extension, 
and click the Save button.

Assigning Spectra to Variables

Use the Variable/Spectra Pairings dialog to assign spectra from a list of available 
input spectra (previously displayed spectra) to the variable names entered in the 
Enter an expression text box.

Continuing with our example from page 835 where the equation 
(s1+s2+s3+s4+s5+s6)/6 was entered:

1. In the Variables used in expression text box, click on the expression S1. 

2. In the Available Spectra List:, click on a spectrum.

The spectrum is paired with the selected variable.

3. Assign spectra to the other variables using the same steps.

• To clear the variable/spectra pairings, click Clear.
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4. After all variables have been paired with spectra, choose an output result.

• To plot the results into the same plot window as the input spectra, use the 
Output Result to arrow toggle button to select Same Window.

• To plot the results into a new plot window, use the Output Result to arrow 
toggle button to select New Window.

If spectra from two plot windows are used and you select output to the Same 
Window, the result is plotted in the same window as the first assigned 
spectrum.

5. To start the calculations, click OK.

When the processing is complete, the Spectral Math result spectrum is plotted in the 
chosen plot window. The plot is available for additional processing or saving to an 
output file using the standard plot functions (see “Using Interactive Plot Functions” 
on page 387).

Figure 9-26: Variable/Spectra Pairings Dialog Showing Variables in Unassigned 
States (left) and After Being Assigned to Spectra (right)
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Mapping Variables to Input Files

If an image file or image memory item is available, a Map Variable to Input File 
text box appears in the Variable/Spectrum Pairing dialog.

1. To select a single-band or multiband image for use in Spectral Math, click on a 
variable name and then click on Map Variable to Input File.

2. Select the desired input file and any spatial or spectral subsetting. 

3. Select output to File or Memory.

4. Click OK to start the processing. 

When an image is used in Spectral Math, the output is another image of the same 
spatial and spectral dimensions. 

Note
Mapping Variables to Input Files can be used to perform mathematical operations 
simultaneously on all bands of an image.

Using IDL Functions in Spectral Math

Because ENVI provides access to IDL’s capabilities (unless you are using ENVI-RT), 
you can use the power of built-in IDL features, IDL user functions, or write your own 
Spectral Math expressions to perform custom operations. The only requirement for 
these functions is that they accept one or more vectors (spectra) as input and that they 
output a vector result. These functions need to be saved in a directory that is within 
the IDL path list so they will auto-compile.

Note
You can also compile the functions as described in “Compiling IDL Code” on 
page 137. 

The following simple examples demonstrate the creation and use of custom Spectral 
Math functions (see Band Math Basics in the ENVI Programmer’s Guide for more 
information).
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Example: Spectral Math User Function 1

The following example is a simple custom spectral math function that adds two 
spectra. The following program text can be entered into a text editor and saved with 
the filename user_sm1.pro:

Example: 

FUNCTION user_sm1, s1, s2
RETURN, s1+s2
END

To call this function from the Enter an expression: box, use the syntax:

user_sm1(s1,s2)

Example: Spectral Math User Function 2

The following example is a simple custom spectrum math function that computes the 
average of 6 spectra. The following program text can be entered into a text editor and 
saved with the filename user_sm2.pro:

Example: 

FUNCTION user_sm2, s1, s2, s3, s4, s5, s6
average = (s1+s2+s3+s4+s5+s6)/6.
RETURN, average
END

To call this function from the Enter an expression: box, use the syntax:

user_sm2(s1,s2,s3,s4,s5,s6)
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Resampling Spectral Data Files

Use Spectral Resampling to resample spectral data files in ENVI. The data files can 
be resampled to match either the response of a known instrument (for example, TM, 
MSS, AVIRIS) or a user-defined filter function; an ASCII wavelength file (with or 
without full width half maximum [FWHM] information) or the wavelengths of a 
specific image input file. The resampling method depends on the input information. If 
only wavelengths (band centers) are provided, ENVI assumes critical sampling and 
uses a gaussian model with a FWHM equal to the band spacings. If wavelengths and 
FWHM information is provided, a gaussian model using the FWHM spacings is 
used. If a filter function is provided, ENVI uses that for the resampling.

1. Select Spectral → Spectral Resampling.

2. When the Spectral Resampling Input File dialog appears, select your input 
data file and any subsetting.

3. Click OK.

The Spectral Resampling Parameters dialog appears. For detailed instructions, see 
“Selecting Resampling Types” on page 749.

Gram-Schmidt Spectral Sharpening

Gram-Schmidt Spectral Sharpening pan-sharpens spectral image data. First, a 
panchromatic band is simulated from the lower spatial resolution spectral bands. 
Second, a Gram-Schmidt transformation is performed on the simulated panchromatic 
band and the spectral bands, where the simulated panchromatic band is employed as 
the first band. Third, the high spatial resolution panchromatic band is swapped with 
the first Gram-Schmidt band. Finally, the inverse Gram-Schmidt transform is then 
applied to form the pan-sharpened spectral bands. For more detailed instructions, see 
“Using Gram-Schmidt Spectral Sharpening” on page 666.
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PC Spectral Sharpening

PC Spectral Sharpening sharpens spectral image data with high spatial resolution 
data. A principal components transformation is performed on the multispectral data. 
The PC band 1 is replaced with the high resolution band, which is scaled to match the 
PC band 1 so no distortion of the spectral information occurs. Then, an inverse 
transform is performed. The multispectral data is automatically resampled to the high 
resolution pixel size using a nearest neighbor, bilinear, or cubic convolution 
technique. For more detailed instructions, see “Using PC Spectral Sharpening” on 
page 668.

CN Spectral Sharpening

CN Spectral Sharpening is an extension of the Color Normalized algorithm often 
used to pan sharpen 3-band RGB images. Unlike HSV or Brovey sharpening, CN 
Spectral Sharpening can be used to simultaneously sharpen any number of bands and 
will retain the Input Image’s original data type and dynamic range. For example, the 
CN Spectral Sharpening routine can be used to sharpen hyperspectral data using a 
multispectral image. For more detailed instructions, see “CN Spectral Sharpening” on 
page 669.
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EFFORT Polishing

Use Effort Polishing to execute Empirical Flat Field Optimal Reflectance 
TransformationTM (EFFORTTM) in order to determine and apply mild adjustments to 
ATREM apparent reflectance data so the spectra appear more like spectra of real 
materials.

Consistent noise or error features may appear in hyperspectral apparent reflectance 
data because of the limited accuracy of the standards, measurements, and models that 
were used and the limited accuracy of calibrations performed along the data signal 
processing chain. This cumulative error may be several percent in each spectral band, 
leading to apparent reflectance data with absolute accuracies far less than the actual 
precision of the original data. 

EFFORT searches for a mild linear correction—bootstrapped from the data 
themselves—that polishes out this error and attempts to improve the accuracy of the 
apparent reflectance data. The EFFORT correction applies statistically mild 
adjustments to every band (gains near one and offsets near zero) that make a visual 
improvement in the apparent reflectance spectra. This removal of the cumulative 
errors of calibration and atmospheric correction allows improved comparison of 
EFFORT corrected spectra to library spectra. For more information, see the following 
references:

Huntington, J. F. and Boardman, J. W., 1995, Semi-quantitative Mineralogical and 
geological mapping with 1995 AVIRIS data, Proc. Spectral Sensing Research ‘95, 
ISSSR, Published by the AGPS, 26 Nov - 1 Dec, 1995, Melbourne, Australia.

Boardman, J. W., 1997, Mineralogic and geochemical mapping at Virginia City, 
Nevada using 1995 AVIRIS data, in Proceedings of the Twelfth Thematic Conference 
on Geological Remote Sensing, Environmental Research Institute of Michigan, 
Denver, CO, pp. 21-28.

Boardman, J. W., 1998, Post-ATREM polishing of AVIRIS apparent reflectance data 
using EFFORT: a lesson in accuracy versus precision, in Summaries of the Seventh 
JPL Airborne Earth Science Workshop, Vol. 1, p. 53.

The EFFORT process is similar to the Empirical Line method of data calibration 
which matches data spectra to field measured spectra. EFFORT, however, uses no 
ground truth data, and the EFFORT-calculated gains and offsets are applied to 
ATREM or other atmospherically corrected apparent reflectance data. EFFORT uses 
the data themselves to generate “pseudo field” spectra by fitting each observed 
spectrum with a parametric model of Legendre polynomials optionally augmented 
with real spectra. Gains and offsets for every band are calculated by comparing the 
modeled spectra to the data spectra, for pixels that are well fit. A number of spectra 
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are used spanning the entire albedo range to give good leverage for the linear 
regression process, and the data values versus modeled values are fit with a line for 
every band. The slope and offset of this line are used to correct the apparent 
reflectance data for the error features. Gain-only corrections can be applied to fix the 
model-to-data offset to zero. 

One or more reality boost spectra (spectra from spectral libraries or field spectra) can 
be used to aid in the modeling. Using a few spectra that you know are characteristic 
of your area as reality boost spectra can produce better-fitting modeled spectra. The 
modeled spectra are created by a linear combination of the Legendre and reality boost 
spectra. Therefore, reality boost spectra that contain sharp features, such as the 
vegetation red edge, when used to augment the Legrendre basis set, can produce a 
better model, giving better EFFORT correction factors and/or offsets.

EFFORT works on one or more wavelength segments that you enter. Wavelengths 
ranges that contain only noise (for example, the 1.4 µm and 1.9 µm water vapor 
absorption bands) should not be used in the calculation. 

Typically three segments are defined around the two large water vapor bands; bands 
before the 1.4 µm water vapor band, bands between the 1.4 and 1.9 µm water vapor 
bands, and bands past the 1.9 µm water vapor band. Each segment must start and end 
with a valid band. Bands within a segment that contain large, known errors but that 
are critical to further analysis can be set as invalid and not used in the initial spectral 
modeling. 

Invalid bands may include overlapping spectral bands, bands with ringing around the 
0.94 and 1.14 µm water vapor bands, and O2 and CO2 under-corrected or over-
corrected bands. These invalid bands are not used in the modeling but will be 
corrected on output. The order of the Legendre polynomial that is used to model the 
spectra is set by you through trial and error (though the default value provided should 
work in most cases). Each segment can be modeled with a different order polynomial. 

Tip
Select a polynomial order that will fit the real data features without fitting the error 
features. Before running EFFORT, use spectral plots of the radiance data to select 
the wavelength segments and invalid bands to input into the EFFORT dialog. 
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Selecting EFFORT Input

1. Select Spectral Tools → Atmospheric Correction → EFFORT.

2. When a standard ENVI file selection dialog appears, select a file and perform 
any spatial subsetting.

3. When the EFFORT Input Parameters dialog appears, click on the Enter New 
Segment button. 

A segment appears in the Segment Information list. 

4. Click the Edit button next to the new segment.

5. Select the starting and ending bands for this segment by using the Add Range 
button, clicking and dragging over the list of bands, or clicking on the first 
band and holding down the Shift key and clicking on the last band. 

• To set bands contained within a segment to an Invalid state so that they 
will not be used in computing the EFFORT correction, press the Ctrl key 
and click on the bands with the left mouse button to toggle them off.

6. Click OK.

• To change the order of the Legendre polynomial used to fit this segment, 
enter the desired order in the Order text box next to the segment 
information.

A lower order polynomial produces a flatter spectrum, which gives more 
error suppression. However, it may also remove some actual reflectance 
features. A higher order polynomial produces a spectrum that fits the data 
better but that also may fit some error features, which leaves them in the 
resulting output. To find a polynomial order that fits only real data, use a 
trial and error method.

7. Enter new segments until all the spectral segments have been defined.

• To remove the last segment entered, click the Delete Last Segment button.

Note
Data that is not included between spectral segments will not be adjusted and will be 
set to 0. Invalid bands will not be used in the modeling but will be EFFORT 
adjusted.
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Inputting Reality Boost Spectra

To input reality boost spectra:

1. In the EFFORT Input Parameters dialog, click the Input Reality Boost 
Spectra button. 

An endmember collection dialog appears.

2. Import the desired spectra and click Apply.

For detailed instructions, see “By Dragging-and-Dropping Spectra” on 
page 582, “Importing Endmember Spectra” on page 583, “Endmember 
Options” on page 589 and “Managing Endmember Spectra” on page 592.

The Reality Spectra Options dialog appears.

3. Click on the arrow toggle button to select whether to use a continuum removal 
on the reality boost spectrum.

• To incorporate the spectral features and not the overall spectral shape, use 
continuum removal.

• If the overall shape of the spectrum is important, (that is, vegetation 
spectra), do not use continuum removal.

4. Click OK.

• Click on the Edit button to change the reality boost spectra options.

• Click on the Delete button to delete any of the input reality boost spectra.

Setting EFFORT Parameters

Use the EFFORT Input Parameters dialog to set parameters for the EFFORT 
processing before executing EFFORT.

1. In the Number of Points text box, enter the total number of spectra to use in 
the EFFORT process.

Note
We recommend using at least 1000 points, but no more than 10% of the total 
image size.

2. Enter the number of bins to divide the albedo range into and select spectra 
from.
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The number of spectra used in each albedo bin is the total number of points 
divided by the number of albedo bins. This insures that spectra with a range of 
albedo are used in the modeling.

3. Use the arrow toggle button to calculate gain and offset values or gain values 
only.

• To correct your data for gain values only, select Gain.

These include errors in the radiometric calibration, atmospheric 
transmittance model, and solar irradiance model.

• To correct your data for both gain error and offset error, which include 
errors in the dark current and path radiance model, select Gain and 
Offset.

• To save the gain and offset values to an ASCII file, enter an output 
filename in the appropriate dialog.

4. Click on the arrow toggle button to apply the calculated gain and offset values 
to the input data.

• If you select No, the gain and offset values will appear in a plot window 
and no other output will be generated.

• If you select Yes, enter an output filename. 

The gain and offset values will appear in a plot window and an EFFORT-
corrected apparent reflectance output file will be created.

• To write the EFFORT output over the input file, use the In Place? arrow 
toggle button to select Yes. 

Warning
The In Place? option will overwrite the input file and can not be interrupted 
without corrupting the original data file.

5. Click OK to start the EFFORT processing. 

The processing is done in three steps and three sequential status bars show the 
progress. When the process is complete, the output is listed in the Available Bands 
List and the gain and offset values appear in a plot window.
EFFORT Polishing ENVI User’s Guide



Chapter 9: Spectral Tools 847
Generating Image Cubes

Use the Build 3D Cube user function to take a multispectral file or hyperspectral file 
(which may be spatially and spectrally subsetted) and create an RGB image with the 
spectral slice of the top row and far right column in a perspective view (see Figure 9-
27). The spectral slices are stretched and a user-selected color table is applied. The 
final image is a 3D RGB color composite image cube. All the intermediate 
processing takes place file to file, or in memory depending on user selection of the 
final output file. (Temporary files created are deleted after they are used). The IDL 
code for this function CUBE_3D.PRO is included in the ENVI distribution and shows 
how to combine batch routines and widgets to build a user function. Programming 
details are discussed in see Chapter 4, “User Functions” in the ENVI Programmer’s 
Guide.

1. Select Spectral → Build 3D Cube.

2. Select an input file and any spatial and/or spectral subsetting.

3. Click OK.

4. When the 3D Cube RGB Face Input Bands dialog appears, select the RGB 
bands to be placed on the face of the image cube by clicking on the desired 
bands.

5. Click OK to complete the selection.

6. When the 3D Cube Parameters dialog appears, select the color table for the 
side and top of the 3D cube from the list of standard ENVI/IDL color tables by 
clicking on the desired choice.

7. Enter a value for the Spectral Scale to apply a multiplier to the pixel 
dimensions of the side and top.

Tip
A factor greater than 1.0 will exaggerate the side and top dimensions of the 
cube by replicating the spectral profiles. This is particularly useful for image 
cubes that contain a small number of spectral bands.

8. Enter a border value to modify the number of border (background) pixels 
surrounding the output image.
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9. Select File or Memory output.

• To quit, click Cancel.

10. Click OK to start the processing.

When the process is complete, the output is listed in the Available Bands List.

Figure 9-27: Three-Dimensional Image Cube
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Spectral Tools References
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Map Tools
This chapter covers the following topics:
The Map Menu  . . . . . . . . . . . . . . . . . . . . .  854
Registration  . . . . . . . . . . . . . . . . . . . . . . . .  855
Orthorectification . . . . . . . . . . . . . . . . . . . .  875
Image Mosaicking . . . . . . . . . . . . . . . . . . .  888
Georeferencing from Input Geometry . . . .  904
Georeferencing SPOT Data . . . . . . . . . . . .  912
Georeferencing SeaWiFS Data  . . . . . . . . .  914
Georeference AVHRR Data . . . . . . . . . . . .  917
Georeference MODIS 1B  . . . . . . . . . . . . .  921

Selecting Map Projection Types . . . . . . . .  922
Building Customized Map Projections  . .  923
Converting Map Projections . . . . . . . . . . .  927
Layer Stacking  . . . . . . . . . . . . . . . . . . . . .  929
Converting Map Coordinates . . . . . . . . . .  930
Converting ASCII Coordinates  . . . . . . . .  932
Merging Old Projection Files . . . . . . . . . .  934
Using GPS-Link . . . . . . . . . . . . . . . . . . . .  935
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The Map Menu

Use the Map menu to access ENVI’s image registration, orthorectification, geometric 
correction, and mosaicking utilities. Also use the Map menu to access tools used to 
convert map coordinates and map projections, to build customized projections, to 
convert ASCII coordinates, and to access a GPS-link utility.

Figure 10-1: Map Menu
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Registration

Use Registration to reference images to geographic coordinates and/or correct them 
to match base image geometry. Ground control points (GCPs) can be selected 
interactively from display windows and/or vector windows. Warping is performed 
using polynomial functions, Delaunay triangulation, or rotation, scaling, and 
translation (RST). Resampling methods include nearest neighbor, bilinear, and cubic 
convolution. Comparison of base and warped images using ENVI’s multiple 
Dynamic Overlay capabilities allows quick assessment of registration accuracy. For 
step-by-step image registration instructions, see the Image Georeferencing and 
Registration ENVI Tutorial.

Figure 10-2: Typical Layout of Registration Session
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Image-to-Image Ground Control Points 

Use Select GCPs:Image to Image to interactively select ground control points (GCP 
or Tie Points) to use in image-to-image registration. Use the Zoom windows of two 
displayed images (image-to-image registration requires that two images be displayed) 
to select the GCPs. When selecting GCPs, you can select sub-pixel (fractional) 
coordinates. Once enough points to define a warp polynomial have been selected, 
GCP locations in the warp image can be predicted. GCPs can be saved and restored 
to/from files and the color labels and ordering of the GCP markers can be changed. 
See “Warping and Resampling” on page 870 for descriptions of the warping methods.

Single band or multiband images can be warped. The GCP selection tool allows 
prototyping and testing of different GCPs and warp options. 

Opening and Displaying Images

Tip
To rotate or flip images prior to registration, use Basic Tools → Rotate/Flip 
Images (see “Rotating Images” on page 468).

1. Open the base image and warp image files and display them in two windows 
using the Available Bands list (see “Opening Image Files” on page 61 and 
“The Available Bands List” on page 189).

2. After the two images are displayed, choose Map → Registration → Select 
GCPs:Image to Image.

The Image to Image Registration dialog appears.

3. In the Base Image list, click on the base (reference) display.

4. In the Warp Image list click on the display containing the image to be warped.

5. Click OK.

The Ground Control Points Selection dialog (Figure 10-3) appears.

Tip
See the Image Georeferencing and Registration ENVI Tutorial for step-by-step 
descriptions of image registration. 

Collecting Ground Control Points (Image-to-Image)

Identify GCPs in the two displayed images by locating the pixels in the Zoom 
windows. The pixel information is loaded into the Ground Points Selection dialog. 
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The upper left of a pixel is the position of the whole number coordinates and the X 
and Y values increase to the right and bottom of the pixel, respectively. The pixel 
fraction available in the Zoom window is proportional to the zoom factor. For 
example, at a zoom of 4x, the pixels are divided into 4 sub-areas. At a zoom factor of 
10x, positioning is possible to 1/10th pixel. The GCP marker is placed showing the 
subpixel position in the zoom window. Subpixel locations are supplied to provide 
higher accuracy in selecting GCPs.

1. In the Main Image window of each image, position the Zoom box over the 
desired GCP area (see “Controlling the Zoom Window from the Main Image 
Window” on page 202).

2. In the zoom window, click the left mouse button on a specific pixel to position 
the cursor over that pixel or portion of that pixel (see “The Zoom Window” on 
page 203).

The coordinates of the selected location (in both images) are displayed in the 
Ground Control Points Selection dialog in sample, line order in the fields 
labeled Base X, Y and Warp X,Y respectively. Positioning in the Zoom 
window provides subpixel coordinates so floating point coordinate values are 
shown in the dialog.

Note
Select Tools → Pixel Locator from the Display menu to select the pixel 
positions and provide whole number GCP coordinates by clicking the 
Export button (see “Using the Pixel Locator” on page 410).

3. Once the desired pixel is selected in both images, click Add Point in the 
Ground Control Points Selection dialog to add the selected GCPs to the list of 
selected X, Y (sample, line) pairs. 

• To view the list of GCPs, click Show List. The Image to Image GCP List 
appears with the GCPs listed in a table. For a description of the GCP List, 
see “Using the GCP List” on page 859.

When the GCPs have been added to the list, a marker is placed in the image 
displays of both the base and warp images. The GCP marker in the image is the 
identifying number of the GCP displayed next to an encircled cross-hair. 

The marker indicates the selected pixel (or subpixel location); the center of the 
marker (located under the cross-hair) indicates the actual GCP location.

4. Add additional GCPs following the same procedure.
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When four or more GCPs have been selected, the predicted X, Y coordinates 
for the selected warp, the X and Y error, and the RMS error are listed in the 
GCP List table.

Tip
For the best results, attempt to minimize the RMS error by refining the positions of 
the pixels with the largest errors or by removing them (see “Minimizing RMS 
Error” on page 859). Errors can be reduced by using more points. If you only have a 
few points, place them near the image corners or widely scatter them in the image.

.

Figure 10-3: Ground Control Points Selection Dialog (top) and GCP List (bottom)
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Minimizing RMS Error

The number of GCPs selected is displayed in the Ground Control Points Selection 
dialog. After a number of GCPs sufficient enough to conduct a 1st degree polynomial 
warp have been selected, the total RMS error is displayed in the Ground Control 
Points Selection dialog and the RMS error for each point is listed in the GCP List 
table.

The degree of polynomial used for calculating the error is displayed in the Degree 
box in the Selection dialog and can be changed when a sufficient number of GCPs 
have been selected.

Tip
To see which points have the highest RMS errors, select Options → Order Points 
by Error in the Ground Control Points Selection dialog. The points in the CGP List 
are reordered so that those with the highest errors appear at the top of the list.

Ignoring GCPs

• To have GCPs selectively ignored during registration, click on the point to be 
ignored and click the On/Off button. 

The RMS error and the spatial transformation are recalculated without using 
the selected points. The + next the GCP number changes into a - in the GCP 
List and the color of the GCP marker changes. 

• To turn the GCP on again, click on the point in the list and click the On/Off 
button again.

Using the GCP List

Use the GCP List to edit and update positions, turn points on and off, delete selected 
points, and predict point locations (see Figure 10-3).

Hiding/Showing the GCP List

• To display the GCP list, click Show List in the Ground Control Points 
Selection dialog.

• To hide the GCP list, click Hide List in the Ground Control Points Selection 
dialog or select File → Cancel in the GCP List window.
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Positioning the Zoom Window

• To center the Zoom window over any of the selected GCPs, click on the 
desired GCP in the list and click Goto, or click on the GCP number in the GCP 
List.

The marker outlining the selected GCP is positioned at the center of the Zoom 
window for both the base and warp images. 

Editing GCP Locations

You can edit the location of a GCP by changing the X and/or Y values in the GCP 
List, or by interactively selecting new locations in the Zoom windows.

To change a GCP from the GCP List:

1. In the GCP List, double-click on the value to be edited.

2. Enter the new value and press Return key or enter a new value and click 
Update.

The changes are reflected in the GCP list and in the base and warp images.

Note
If several GCPs have already been selected, a significant delay may occur while the 
GCPs are redrawn and the error is recalculated. 

To interactively move a GCP: 

1. In the GCP List, click on the GCP to be moved. 

2. Center the Zoom boxes in the base and warp images over the new location.

3. In the GCP list, click the Update button.

The location of the selected GCP is replaced with the new pixel positions in the GCP 
List and in both images. The Zoom windows of both images are centered over the 
new location. 

Deleting GCPs

• To permanently remove any single control point from the list in the GCP List, 
click on the GCP to be removed and click Delete. 
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GCP Options

Use the Options menu in the Ground Control Points Selection dialog to control the 
ground control points’ labels, colors and ordering, to reverse the base and warp 
images, and to set other preferences. 

Reversing Base/Warp Images

Use this option to warp the base image to match the warp image.

• To reverse the positions of the base and warp GCPs, select Options → 
Reverse Base/Warp. 

Selecting RST Calculation

For 1st order polynomials, you have the option of selecting RST (Rotation, Scaling, 
and Translation) calculation of errors:

• In the Ground Control Points Selection dialog, select Options → 1st Degree 
(RST Only) Yes or No.

Predicting GCP Locations

To predict the location of a GCP in the warp image based on the warping determined 
by the current GCPs and the selected polynomial degree: 

1. In the base Zoom window, position the crosshairs over a pixel.

2. Click Predict. 

The warp image Zoom Window Indicator and the cross-hairs move to the 
predicted pixel. 

3. Refine the prediction by selecting the correct pixel in the warp image.

4. Click Add Point to enter the GCP.

Automatically Predicting GCP Locations

To have the GCP location in the warp image predicted automatically:

1. Select Options → Auto Predict On.

When you adjust the pixel location using the Zoom window or the Zoom 
Window Indicator box of the base image, the Zoom Window Indicator and 
cross-hairs of the warp Zoom window move to the predicted pixel location.

2. Click Add Point to enter the GCP.
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Turning Labels On/Off

• To turn the GCP labels off or on, select Options → Label GCPs Off or Label 
GCPs On.

Changing Label Colors

1. Select Options → Set Point Colors.

The GCP Colors dialog appears.

2. Select the color of the on GCP markers from the GCPs which are On button 
menu (initially labeled Red).

3. Select the color for the off GCP markers from the GCPs which are Off button 
menu (initially labeled Green).

Setting Ordering Preferences

• To select whether the GCP pairs are displayed in the list by their index ID# or 
by RMS Error, select Options → Order Points by Index or Order Points 
by Error.

Index ID order is the order in which they were selected. Error order lists those with 
the highest error first.

Clearing the GCP List

• To delete all of the GCPs listed in the GCP List, select Options → Clear All 
Points.

Warping Options

Use the Options menu in the Ground Control Points Selection dialog to warp from 
the currently displayed band or to warp from a file. You can also select image-to-map 
type warping if your base image is georeferenced. This allows you to change the 
output pixel size and projection type of the warped image.

• To use the GCPs to perform a standard registration, select either Options → 
Warp Displayed Band or Warp File.

• To select image-to-map type warping, if the base image is georeferenced, 
select Options → Warp Displayed Band (as Image to Map) or Warp File 
(as Image to Map).

The Registration Parameters dialog appears. The details of the various warp options 
available in ENVI are discussed in “Warping and Resampling” on page 870.
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Managing GCPs

Use the File menu in the Ground Control Points Selection dialog to save and restore 
ground control points files.

Saving GCPs to ASCII Files 

1. In the Ground Control Points Selection dialog or in the GCP List, select File 
→ Save GCPs to ASCII.

2. Enter an output filename with the .pts extension or use the Choose button to 
select an output filename.

3. Click OK (see “GCP File Format (.pts)” on page 1095 for information on the 
format).

Saving Coefficients to ASCII Files

To save the polynomial coefficients to an ASCII file:

1. In the Ground Control Points Selection dialog, select File → Save 
Coefficients to ASCII. 

2. In the Output Polynomial Coefficients dialog, enter or choose an output 
filename and click OK.

The ASCII file contains the polynomial degree and polynomial coefficients P and Q, 
where:

Where x′and y′ are the locations in the base image, x and y are the locations in the 
warp image, N is the polynomial degree, and P and Q are the polynomial coefficients. 
The P and Q polynomial coefficients matrices are written to the file by rows, one 

x′ a x y,( ) Pi j, x
j
yi

j 0=

N

∑
i 0=

N

∑= =

y′ b x y,( ) Qi j, xjyi

j 0=

N

∑
i 0=

N

∑= =
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element per line. For example, a 2 x 2 matrix of P and Q would be written in the 
following format:

P[0, 0] Q[0, 0]

P[0, 1] Q[0, 1]

P[1, 0] Q[1, 0]

P[1, 1] Q[1, 1]

Restoring Saved GCPs

1. Select File → Restore GCPs from ASCII. 

2. Enter the desired GCP .pts filename. 

Closing the Dialog

• To exit the Ground Control Points Selection dialog, select File → Cancel. 

Note
If the current points have not been saved to a file, a prompt appears.

Image-to-Map Ground Control Points

Use Select GCPs:Image-to-Map to select ground control points (GCPs) for Image-
to-Map registration. Use the Zoom window (image-to-map registration requires that 
at least one image is displayed) to select GCPs.When selecting GCPs, you can select 
subpixel coordinates. You enter corresponding map coordinates manually, from a 
vector window, or from GPS link. Once enough points to define a warp polynomial 
have been selected, GCP locations in the warp image can be predicted. GCPs can be 
saved and restored to/from files and the color labels and ordering of the GCP markers 
can be changed. See “Warping and Resampling” on page 870 for descriptions of the 
warping methods.

Opening and Displaying Images

1. Open the image file and display the desired band (see “Opening Image Files” 
on page 61 and “The Available Bands List” on page 189). 

2. Choose Map → Registration → Select GCPs:Image to Map. 

The Image to Map Registration dialog appears.

3. Choose the image to register to the map by clicking on the display name in the 
dialog. 
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Note
If only one image is displayed, it is selected automatically.

4. In the Select Registration Projection list, select the output projection by 
clicking on it, or click New to enter a custom project type (see “Selecting Map 
Projection Types” on page 922).

5. Click OK.

The Ground Control Points Selection dialog appears.

Tip
See the Tutorial 6, “Image Georeferencing and Registration” ENVI Tutorial for 
additional step-by-step descriptions of image registration.

Figure 10-4: Image to Map Registration Dialog
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Collecting Ground Control Points (Image-to-Map)

The procedure for selecting Ground Control Points (or Tie Points) is similar to that 
for image-to-image registration (see “Image-to-Image Ground Control Points” on 
page 856).

1. In the Main Image window, position the Zoom box over the desired GCP area 
(see “Controlling the Zoom Window from the Main Image Window” on 
page 202).

2. In the zoom window, click the left mouse button on a specific pixel to position 
the cursor over that pixel or portion of that pixel (see “The Zoom Window” on 
page 203).

The coordinates of the selected location appear in the Ground Control Points 
Selection dialog in the fields labeled Image X and Image Y. Subpixel 
coordinates are supplied to provide higher accuracy in selecting GCPs (see 
“Collecting Ground Control Points (Image-to-Image)” on page 856).

Note
Select Tools → Pixel Locator from the image window to select the pixel positions 
and provide whole number GCP coordinates by clicking the “Export” button (see 
“Using the Pixel Locator” on page 410).

3. Select common reference features in both the map and the image (for example 
a road intersection seen in both image and map) and select from the following 
options:

• To automatically enter map coordinates from vector data, see “Entering 
Map GCPs from Vector Windows” on page 869. 

• To automatically enter map coordinates from GPS locations, see “Using 
GPS-Link” on page 935.

• To enter the map coordinates from a paper map, enter the easting and 
northing (or lat/long) of the selected GCPs into E and N text boxes, 
respectively.

• To enter the map GCP location from a paper map in latitude and longitude, 
click the arrow toggle button next to the map projection name (“UTM” in 
Figure 10-5) and enter the values into the Lat and Long text boxes.

Use negative (–) longitude for the western hemisphere and negative (–) 
latitude for the southern hemisphere.
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• To change the latitude and longitude values between degrees, minutes, 
seconds, and decimal degrees, click on the DMS< - >DD button.

• To return to map projection coordinates, click the arrow toggle button. 

The corresponding map projection coordinates are calculated 
automatically.

4. Once the desired pixel is selected in the image and the map coordinates have 
been entered, click Add Point in the Ground Control Points Selection dialog to 
add the point to the list of GCPs.

• To view GCP List, click Show List.

The Image to Map GCP List appears with the GCPs listed in a table. For a 
description of the GCP List, see “Using the GCP List” on page 859.

When a GCP is added, a marker is placed in the image. The GCP marker in the 
image is the identifying number of the GCP displayed next to an encircled 
cross-hair. The marker indicates the selected pixel (or subpixel location); the 
center of the marker (located under the cross-hair) indicates the actual GCP 
location. 

Note
When GCPs are selected from a vector window, a marker is also placed in the 
vector window. The marker is the identifying number of the GCP displayed 
with a +.

5. Add additional GCPs using the same procedure.
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As soon as enough points have been entered, the predicted X,Y coordinates for 
the selected warp, the X,Y error, and the RMS error are listed in the GCP List.

The number of GCPs selected is displayed in the Ground Control Points Selection 
dialog. Once a sufficient number of GCPs have been selected to conduct a 1st degree 
polynomial warp, the total RMS error is also displayed.

Tip
For the best registration, attempt to minimize the RMS error by refining the 
positions of the pixels with the largest errors or by removing them (see “Minimizing 
RMS Error” on page 859). Errors can be reduced by using more points. If you only 
have a few points, place them near the image corners or widely scatter them in the 
image.

For details about editing, predicting, and positioning GCPs, see “GCP Options” on 
page 861. For details about managing GCPs, see “Managing GCPs” on page 863.

Figure 10-5: Image to Map Ground Control Points Selection Dialog
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Entering Map GCPs from Vector Windows

If you have a vector file for the area to be map-registered, you can extract the map 
coordinates directly from the vector data and load them into the Ground Control 
Points Selection dialog.

1. Select GCPs from the displayed image as described in “Collecting Ground 
Control Points (Image-to-Map)” on page 866. 

2. Load the vectors into a Vector Window and use the vector cursor positioning 
capabilities (left mouse button) to locate a feature corresponding to the feature 
selected on the image (See “Cursor Functions in Vector Windows” on 
page 220).

3. At the bottom of the Vector Window Parameters dialog, click Export to enter 
the map coordinates of the vector cursor directly into the Ground Control 
Points Selection dialog, or select Export Map Location from the Vector 
window shortcut menu.

4. In the Ground Control Points Selection dialog, click Add Point to enter the 
selected point into the registration.

Saving GCPs as Vector Files

To save the GCP points and all the associated information and attributes as an ENVI 
vector file:

• In the Available Vectors List, select the new registration’s GCP vector layer, 
and select File → Save Memory Layers to File. 

Warping Options

• To use the GCPs to perform a standard registration, select either Options → 
Warp Displayed Band or Warp File in the Ground control points selection 
dialog.

The Registration Parameters dialog appears. For details, see “Warping and 
Resampling”.
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Warping and Resampling

ENVI offers three warping options, RST (rotation, scaling and translation), 
polynomial and Delaunay triangulation. RST warping is the simplest method. To 
perform RST warping, three or more GCPs are needed. The type of polynomial 
warping available is 1st to nth degree. The degree available is dependent upon the 
number of GCPs selected where #GCPs > (degree + 1)2. Delaunay triangulation 
warping fits triangles to the irregularly spaced GCPs and interpolates values to the 
output grid.

The resampling methods available include nearest neighbor, bilinear, and cubic 
convolution. Nearest neighbor resampling uses the nearest pixel without any 
interpolation to create the warped image. Bilinear resampling does a linear 
interpolation using four pixels to resample the warped image. Cubic convolution uses 
16 pixels to approximate the sinc function using cubic polynomials to resample the 
image. Note that cubic convolution resampling is significantly slower than the other 
methods. For more information, see the following reference:

Richards, J. A., 1999, Remote Sensing Digital Image Analysis, Springer-Verlag, 
Berlin, p. 240.

1. Select the Ground Control Points (see “Image-to-Image Ground Control 
Points” on page 856).

2. In the Ground Control Points Selection dialog, select Options → warping 
method.

3. When the Registration Parameters dialog (Figure 10-6) appears, select the 
warping method from the Warp Method button menu.

The available warping methods are RST (rotation, scaling, and translation), 
Polynomial, and Triangulation.

4. Select from the following method-specific options:

• For polynomial warping, enter the desired polynomial degree in the 
Degree text box. The degree available is dependent on the number of 
GCPs defined where #GCPs > (degree + 1)2.

• To select whether you want a one-pixel border of background color at the 
edge of triangulation warp data, use the Zero Edge arrow toggle button to 
select Yes.
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By selecting this option, you will avoid a smearing effect which may 
appear at the edges of warped images and which is often seen when using 
ENVI’s data-specific georeferencing functions.

5. From the Resampling button menu, select the resampling method.

6. Set the Background Value (the DN value used to fill areas where no image 
data appears in the warped image) by entering the DN value in the 
Background Value text box.

The output image dimensions are automatically set to the size of the bounding 
rectangle that contains the warped input image. Therefore, the output warp 
image size is usually not the same size as the base image. The output size 
coordinates are determined in base image coordinates. Therefore, the upper 
left corner values are typically not (0,0) but indicate the x and y offset from the 
base image upper left corner. These offset values are stored in the header and 
allow for dynamic overlay of the base and warp images even when they are 
different sizes.

Figure 10-6: Registration Parameters and Image to Map Registration Dialogs
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7. Select from the following options to change the output parameters.

• To override the output dimensions, click Change Output Parameters and 
enter the desired values into the Output Image Size text boxes for image-
to-image registration. 

• To change the map coordinate or latitude/longitude information for the 
upper left coordinate of the pixel, or to change the pixel or image size, 
click the Change Output Parameters button and enter the new values 
into the Output Image Parameter dialog.

• To change the projection for the upper left coordinate of the pixel, click the 
Change Projection button in the Output Image Parameters dialog and 
enter the new projection in the Projection Selection dialog.

Note
Georeferenced coordinates are in degrees for Geographic projection. If your 
output projection is Geographic, the output pixel and image sizes need to be 
scaled to degree units using the Change Output Parameters dialog.

The output projection of the image was originally set when ground control 
points were selected.

8. Select output to File or Memory.

A status box appears while the warp is being calculated. When calculation is 
complete, the warped image name appears in the Available Bands list.
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Assessing Registration Accuracy

1. Use the Available Bands List to load the warped image into a new display 
window.

2. Link the display to the base image window (File → Link), and use dynamic 
overlays to flicker between the base and the warped images (see “Working 
with Multiple Dynamic Overlays” on page 373).

Saving Warped Images to Disk

To save a warped image in memory to disk:

• In the Open Files List, select File → Save Selected File to Disk. For 
instructions, see “The Available Files List” on page 185. 

Warping from Saved Image-to-Image GCPs

Use Warp from GCPs:Image to Image to perform image-to-image registration 
without having the images displayed. Instead, you use previously selected GCPs to 
perform the registration.

1. Select Map → Registration → Warp from GCPs:Image to Image. 

Note
The images do not have to be displayed.

2. When the file selection dialog appears, enter the GCP file name or choose the 
appropriate GCP input file from the list. 

3. When the Input Warp Image dialog appears, select the image to be warped and 
any spatial and spectral subsetting using standard ENVI procedures.

4. Click OK.

5. When the Input Base Image dialog appears, select the input base image. 

6. Click OK.

7. When the Registration Parameters dialog appears, follow instruction as 
described above (see “Warping and Resampling” on page 870).
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Warping from Saved Image-to-Map GCPs

Use Warp from GCPs:Image to Map to perform image-to-map registration without 
having the images displayed. Instead you use previously selected GCPs to perform 
the registration.

1. Select Map → Registration → Warp from GCPs:Image to Map.

2. When the Enter GCP Filename dialog appears, select the .pts file.

3. Click OK.

4. Select the projection type used when the ground control points were chosen 
and input the X and Y pixel size.

5. When the Input Warp Image dialog appears, select the image to be warped and 
any spatial and spectral subsetting using standard ENVI procedures. Click 
OK.

In this case, the geographic map coordinates act as the base rather than image 
pixel locations.

6. When the Registration Parameters dialog appears, follow instruction as 
described above (see “Warping and Resampling” on page 870).
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Orthorectification

Use Orthorectification to rectify aerial photographs using a DEM (digital elevation 
model), or rectify data (from IKONOS, OrbView-3, QuickBird, or SPOT sensors) 
using an RPC model. Aerial photograph orthorectification uses geometric projections 
to produce geometrically correct images for mapping and measurement. RPC 
orthorectification combines several sets of input data to place each pixel in the correct 
ground location (see “Orthorectification using RPCs” on page 881 for more 
information on RPC orthorectification).

Aerial Photograph Orthorectification

The aerial photograph orthorectification corrects for distortions introduced by the 
camera geometry, look angles, and topography using a single photo resection. 

The orthorectification is done in three steps. In the first step, you build the interior 
orientation using the camera model, fiducial marks, and image tie points. In the 
second step, you build the exterior orientation. The exterior orientation is used to tie 
the image to the surface of the earth using ground control points, map coordinates, 
and elevations. In the final step, you perform the orthorectification from the interior 
and exterior orientations and a DEM file.

For more details, see the following reference: 

Wolf, R., 1974. Elements of Photogrammetry (2nd ed.), McGraw-Hill Inc., New 
York.

Building Interior Orientations

Use Build Air Photo Interior Orientation to build the interior orientation, which 
establishes the relationship between the camera model and aerial photograph image. 
It uses tie points between the aerial photograph and camera fiducial marks (at least 
three) and the camera focal length. The aerial photograph must be displayed in an 
image window for selection of the fiducial mark locations.

1. Display the aerial photograph image.

2. Select Map → Orthorectification → Build Air Photo Interior Orientation.

3. If more than one image is displayed, select the display number containing the 
aerial photograph.

The Ortho: Build Interior Orientation dialog appears. 
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4. Select a fiducial mark location by centering the Zoom window crosshair over it 
and entering the fiducial location in camera units (mm) in the Fiducial X and 
Fiducial Y text boxes (obtain this information from the camera report).

5. Click on Add Point to add the location to the list of tie points.

The tie points are listed in the Ortho: Interior Orientation GCP List. 

• To display the Ortho: Interior Orientation GCP List, click Show List in the 
Ortho: Build Interior Orientation dialog.

The GCP List appears with the GCPs listed in a table with an identifying 
number, fiducial location, pixel location, and error shown. The total RMS error 
is shown in the “RMS Error” text box for each point. The errors are calculated 
based on a first order polynomial fit to the points and shown to indicate 
whether the points were entered correctly (if the error is large you may have a 
typo in a fiducial location). For details, of the GCP List, see “Using the GCP 
List” on page 859.

6. Continue selecting fiducial mark locations until three or more have been 
entered.

7. Select from the following options:

• To go to, edit, delete, update, and turn on and off points, see “Using the 
GCP List” on page 859. 

• To change the order and color of the labels and to turn point labels on and 
off, see “GCP Options” on page 861. 

Figure 10-7: Build Interior Orientation Dialog
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8. Select Options → Build Interior Orientation from the Ortho: Build Interior 
Orientation dialog.

9. Enter the camera focal length in mm (obtain this information from the camera 
report) and enter an output filename with an .ort extension for consistency.

The .ort file contains the fiducial tie point locations, affine transformation 
coefficients for both the camera coordinates to image pixels and image pixels 
to camera coordinates.

10. Save the points by selecting an option from the File menu as described in 
“Managing GCPs” on page 863.

11. Close the Ortho: Build Interior Orientation dialog by selecting File → Cancel.

Building Exterior Orientations

Use Build Air Photo Exterior Orientation to relate points in the aerial photograph 
to their known map coordinates and elevations. The exterior orientation is built by 
selecting ground control points and entering the corresponding map coordinates 
using methods similar to image-to-map registration.

Note
The aerial photograph must be displayed in an image window for selection of the 
ground control point locations.

1. Display the aerial photograph image.

2. Select Map → Orthorectification → Build Air Photo Exterior Orientation.

3. If more than one image is displayed, select the display number containing the 
aerial photograph.

4. In the Build Exterior Projection dialog, select the desired projection and enter a 
zone number if needed. For instructions, see “Selecting Map Projection Types” 
on page 922.

The selected projection will be used as the orthorectified output projection and 
does not need to be the same projection as the DEM file.

The Ortho: Build Exterior Orientation dialog appears. The dialog is similar to 
the image-to-map registration Ground Control Points Selection dialog.

5. Select a ground control point (GCP) by centering the Zoom window cross-hair 
over a pixel on the aerial photograph image and entering the corresponding 
map coordinates in the appropriate text boxes.

6. In the Elev text box, enter an elevation for the selected pixel.
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7. Click on Add Point to add the location to the list of GCPs.

• To display the Ortho: Exterior Orientation GCP List, click Show List in 
the Ortho: Build Exterior Orientation dialog.

The GCP List appears with the GCPs listed in a table with an identifying 
number, fiducial location, pixel location, and error displayed. The total 
RMS error is shown in the RMS Error text box for each point. The errors 
are calculated based on a first order polynomial fit to the points and shown 
to indicate whether the points were entered correctly (if the error is large 
you may have a typo in a fiducial location). For details, of the GCP List, 
see “Using the GCP List” on page 859.

8. Continue selecting ground control points until three or more are entered.

Note
It is recommended that you use as many GCPs as possible spread over the 
image, including into all four corners, for best results. Inadequate or 
inaccurate GCPs can result in failure of the exterior orientation model to 
converge or in a bad orthorectification output.

9. Select from the following options:

• To go to, edit, delete, update and turn on and off points, see “Using the 
GCP List” on page 859. 

• To change the order and color of the labels and to turn point labels on and 
off, see “GCP Options” on page 861. 

10. In the Ortho: Build Exterior Orientation dialog, select Options → Build 
Exterior Orientation.

11. Select the .ort parameters file created for the interior orientation.

12. Save the points by selecting an option from the File menu as described in 
“Managing GCPs” on page 863.

13. Close the Ortho: Build Exterior Orientation dialog by selecting File → 
Cancel.

The selected .ort file has the ground control points added to it.
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Orthorectifying Air Photos

Use Orthorectify Air Photo to orthorectify an aerial photograph using a digital 
elevation model (DEM) and the orientation file that was generated in “Building 
Exterior Orientations” on page 877.

1. Select Map → Orthorectification → Orthorectify Air Photo.

2. Select the input aerial photograph filename and any subsetting.

3. Select the input digital elevation model (DEM) filename.

4. Select the orientation parameters (.ort) filename that was created in the two 
previous procedures (“Building Interior Orientations” and “Building Exterior 
Orientations”).

5. When the Orthorectification Bounds dialog appears, enter or calculate the 
approximate minimum value contained in the DEM file:

• To calculate the minimum value from the DEM file:

A. To skip pixels and speed the statistics calculations, enter a value less than 
1.0 in the Stats X/Y Resize Factor text boxes.

B. If your DEM has a filler value for missing data, enter that value in the 
DEM Value to Ignore text box.

C. Click the Calculate Value From File button.

The Calculating Data Min/Max and Computing Statistics status dialogs 
appear. Once the statistics are calculated, the minimum DEM value is 
entered into the Minimum DEM Value text box.

This minimum value is used only in determining the output image size 
bounding box coordinates. If the default value of 0 is used and your DEM 
minimum value is larger, then the output image may have a larger black 
border than it would have if the proper value was entered.

6. In the Orthorectification Bounds dialog, click OK.

The Orthorectification Parameters dialog appears. Currently, only nearest 
neighbor resampling is available.

7. Enter the value to ignore (missing data) in the DEM in the appropriate text 
box.

8. Set the Background Value (the DN value used to fill areas where no image 
data appears in the warped image) by entering the DN value in the 
Background Value text box. 
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The output image dimensions are automatically set to the size of the bounding 
rectangle that contains the warped input image. Therefore, the output warp 
image size may not be the same size as the DEM image. The output size 
coordinates are determined in the exterior orientation projection coordinates. 

9. Change the map coordinate or latitude/longitude information for the upper left 
coordinate, pixel size, and image size by clicking Change Output 
Parameters and entering the desired values. 

Note
Since only nearest neighbor resampling is currently available, it is 
recommended that you set the pixel size to the resolution at which the photo 
was scanned.

Click the “Change Projection” button to change the projection of the upper 
left coordinate only. Use Build Exterior Orientation to set the output 
projection of the image.

10. Select output to File or Memory.

Figure 10-8: Orthorectification Parameters Dialog
Orthorectification ENVI User’s Guide



Chapter 10: Map Tools 881
11. Click OK to start the orthorectification.The following figure shows the 
Orthorectification Parameters dialog.

Orthorectification using RPCs

The RPC (Rational Polynomial Coefficients or Rapid Positioning Coordinates) 
sensor model is used to orthorectify data from the IKONOS, OrbView-3, QuickBird 
or SPOT sensors. The RPC orthorectification process combines several sets of input 
data to place each pixel in the correct ground location. The following inputs are 
required: the image to be rectified, the RPC model (not required for SPOT data), and 
elevation information. Furthermore, the offset between mean sea level and the 
gravitational potential surface known as the geoid is required so the elevation can be 
correctly interpreted. Finally, if the source image does not have approximate 
geolocation information available, the rough location of the image on the earth’s 

Figure 10-9: Orthorectification Parameters Dialog
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surface must be computed to provide a location base needed for the RPC 
transformation.

Jacek Grodecki and Gene Dial, “Block Adjustment of High-Resolution Satellite 
Images Described by Rational Polynomials”, Photogrammetric Engineering and 
Remote Sensing, 69(1):59-68

Note
A step-by-step example of this orthorectification process is provided in Tutorial 9, 
“Orthorectifying Imagery using RPCs” in the ENVI Tutorials.

1. Select from the following options:

• In the ENVI main menu, select one of the following options depending on 
your sensor type:

Map → Orthorectification → IKONOS → Orthorectify IKONOS,

Map → Orthorectification → OrbView-3 → Orthorectify OrbView-3,

Map → Orthorectification → QuickBird → Orthorectify 
QuickBird, or

Map → Orthorectification → SPOT → Orthorectify SPOT

• In the ENVI main menu, select one of the following options depending on 
your sensor type:

Basic Tools → Preprocessing → Data-Specific Utilities → IKONOS → 
Orthorectify IKONOS,

Basic Tools → Preprocessing → Data-Specific Utilities → 
OrbView-3 → Orthorectify OrbView-3,

Basic Tools → Preprocessing → Data-Specific Utilities → 
QuickBird → Orthorectify QuickBird, or

Basic Tools → Preprocessing → Data-Specific Utilities → SPOT → 
Orthorectify SPOT
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• In the ENVI main menu, select one of the following options depending on 
your sensor type:

Spectral → Preprocessing → Data-Specific Utilities → IKONOS → 
Orthorectify IKONOS,

Spectral → Preprocessing → Data-Specific Utilities → OrbView-3 → 
Orthorectify OrbView-3,

Spectral → Preprocessing → Data-Specific Utilities → QuickBird → 
Orthorectify QuickBird, or

Spectral → Preprocessing → Data-Specific Utilities → SPOT → 
Orthorectify SPOT

If your sensor type is different from any of the above options and you have 
a file containing RPC information, you can use the Generic RPC options 
(see “Orthorectifying with Generic RPC Models” on page 887 for more 
information).

2. In the file selection dialog select the image to be orthorectified. Click Open.

The input image must be linked to the RPC coefficients contained in an 
ancillary text file. These coefficients are required for the rational function 
expansion to convert ground coordinates into sensor coordinates. Once you 
select a file for input, ENVI searches for the RPC coefficients in one of the 
following locations:

• For IKONOS — ENVI looks for an RPC filename consisting of the root 
name of the source image plus _rpc.txt.

• For OrbView-3 — ENVI looks for an RPC filename consisting of the root 
name of the source data file, but without the _image prefix, and appended 
by _metadata.pvl.

• For QuickBird — ENVI looks for an RPC filename consisting of the root 
name of the source data file appended with the extension .rpb.

• For SPOT — ENVI derives the RPC model from geometric parameters 
stored in the standard metadata for the scene (no RPC file is required).
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Note
If ENVI cannot locate an associated file containing the RPCs, you are 
prompted to select the appropriate file. Once the RPC file is located, ENVI 
automatically associates this RPC model with the input file (see “Emulating 
an RPC Projection” in Chapter 2 for more information).

After you select an input file, the Enter Orthorectification Parameters dialog 
appears.

3. Designate the technique used for resampling by clicking the button next to the 
Image Resampling label and selecting Nearest Neighbor, Bilinear, or Cubic 
Convolution.

The selected resampling technique is used to determine the pixel values in the 
input image when it is converted from its current orientation into the new 
orientation. The default is Bilinear.

• To specify a value for pixels in the output image that are outside the 
bounds of the source image, enter a value in the Background text box.

Figure 10-10: Enter Orthorectification Parameters Dialog
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4. Specify how the elevation will be determined by clicking the arrow buttons and 
selecting Fixed or DEM.

• If you choose Fixed, enter a static elevation value to be used for each 
pixel.

• If you choose DEM, follow these steps:

Note
If the input image has an associated DEM file, then it is used as the default 
DEM for the orthorectification process. For more information on associating 
a DEM with an image, see “Associating a DEM to a File” in Chapter 2.

A. Click the Select DEM button and specify the location of the DEM file.

B. Click the button next to the DEM Resampling label to designate a 
resampling method for the DEM.

The DEM resampling technique is used to convert the DEM from the 
source coordinate system to Geographic, WGS-84, which is required for 
input into the RPC algorithm. A full projection is performed to convert 
each DEM coordinate into the correct coordinate system.

C. In the Geoid Offset text box, enter a value.

The Geoid offset is a constant value that is added to every value in the 
DEM to account for the difference between a spheroid mean sea level, 
used in most available DEM data, and the constant geopotential surface 
known as the GEOID. The RPC coefficients are created based on geoid 
height, and this information must be used to provide accurate 
orthorectification.

For example, if the geoid is 10 meters below the mean sea level at the 
location of your image, you would enter a value of -10.

Many institutions doing photogrammetric processing have their own 
software for geoid height determination. You can also obtain software 
from NGA, USGS, NOAA, and other sources. A geoid height calculation 
can currently be found at http://www.ngs.noaa.gov/cgi-
bin/GEOID_STUFF/geoid99_prompt1.prl.

D. Click the arrow button next to the Save Computed DEM? label and select 
Yes or No to designate whether to output the resampled DEM that was 
used in the georeferencing process. If you select Yes, select output to File 
or Memory.
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5. On the right side of the dialog, verify the parameters related to the extent and 
pixel size of the output image.

The default values are calculated from the original image’s georeferencing 
information. If the input image has no georeferencing information, ENVI 
estimates the extent of the image and a reasonable pixel size to derive the 
default values.

• To change the map projection, click the Change Proj button. 

• To change the pixel size or number of samples or lines, enter the 
information in the corresponding text boxes.

6. Select whether to output the orthorectified image to File or Memory.

7. Click OK to begin the orthorectification. 

The orthorectification process can take several minutes. When it is finished, the 
orthorectified image is listed in the Available Bands List.

Orthorectifying with Ground Control

Ground Control Points (GCPs) can be used to enhance the accuracy of the RPC 
orthorectification process. In this process, the GCPs you provide are used to correct 
the results of the RPC transformation to improve accuracy in the final result. The 
RPC transformation tends to have a high bias error and a much lower random error. 
Thus, selection of even a single GCP can provide a significant improvement in 
overall accuracy, although selection of multiple GCPs can further improve the results. 
This adjustment of the RPC orthorectification based upon GCP inputs is particularly 
important if you have other spatial data and you want your orthorectification results 
to be consistent with this other information.

To orthorectify your data with an RPC model and GCPs, perform the following steps:

1. Select one of the following options from the ENVI main menu depending on 
your sensor type:

• Map → Orthorectification → IKONOS → Orthorectify IKONOS with 
Ground Control for IKONOS data.

• Map → Orthorectification → OrbView-3 → Orthorectify OrbView-3 
with Ground Control for OrbView-3 data.

• Map → Orthorectification → QuickBird → Orthorectify QuickBird 
with Ground Control for QuickBird data.

• Map → Orthorectification → SPOT → Orthorectify SPOT with 
Ground Control for SPOT data.
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If your sensor type is different from any of the above options and you have a 
file containing RPC information, you can use the Generic RPC options (see 
“Orthorectifying with Generic RPC Models” on page 887 for more 
information).

Note
Your imagery must be displayed in ENVI to be able to use GCPs with an 
RPC model to orthorectify the data.

The standard Ground Control Points Selection dialog for ENVI appears.

2. Use the Ground Control Points Selection dialog to specify or restore one or 
more GCPs in the image display. For complete details on how to use the dialog 
to select GCPs, see “Collecting Ground Control Points (Image-to-Map)” on 
page 866.

Note
The Elev value specified in the Ground Control Points Selection dialog must 
be relative to the geoid height specified for the RPC orthorectification 
process.

3. When you are satisfied with your GCP selections, select Options → 
Orthorectify File in the Ground Control Points Selection dialog. This option 
prompts you to select an input file, and then the Enter Orthorectification 
Parameters dialog appears. This dialog allows you to customize the output 
parameters for the orthorectification process.

Orthorectifying with Generic RPC Models

If you have a custom RPC file, you can use the Orthorectification → Generic RPC 
option to orthorectify your data with this custom file. This option allows access to a 
user-defined function for reading the custom RPC file format. This user-defined 
function is placed in the save_add directory and associated with the Generic RPC 
option through the useradd.txt file in the menu directory. For more information on 
implementing this user-defined file, see “User Defined RPC Reader” in Chapter 6 of 
the ENVI Programmer’s Guide.
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Image Mosaicking

Use Mosaic Images to overlay two or more images that have overlapping areas 
(typically georeferenced) or to put together a variety of non-overlapping images 
and/or plots for presentation output (typically pixel-based). Individual bands, entire 
files, and multi-resolution georeferenced images can be mosaicked. You can use your 
mouse or pixel- or map-based coordinates to place images in mosaics and you can 
apply a feathering technique to blend image boundaries. You can save the mosaicked 
images as a Virtual Mosaic™ to avoid having to save an additional copy of the data to 
a disk file. Mosaic templates can also be saved and restored for other input files.

Building Pixel-Based Mosaics

• Select Map → Mosaicking → Pixel Based.

The Pixel-Based Mosaic window appears.

Importing Images

Use the Import menu to choose input bands for the mosaic. 

1. Select either Import → Import Files or Import → Import Files and Edit 
Properties. Use the second option if you want to enter a background see-
through value, perform feathering, position the image on input, select which 
bands will appear in the mosaic display, or perform color balancing.

2. When the Mosaic Input File dialog appears, select the file or files and perform 
any spatial and spectral subsetting.

Note
Individual bands or entire files can be mosaicked.

• To select individual bands, click the Select By arrow toggle button in the 
Mosaic Input File dialog to select Band.

3. Once you have selected the data to import, click OK.
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4. If you selected Import Files and Edit Properties, a dialog for each file 
selected appears that allows you to set the following parameters:

• Enter a background see-through value to make pixels with that value 
transparent so that the underlying image is visible. (Use for mosaicking of 
images with constant DN value borders).

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.

• Enter feathering parameters as needed (For more information, see 
“Feathering” on page 901).

• Enter the upper-left coordinates in the Xoffset and Yoffset text boxes, in 
pixels, to position the image in the mosaic, or optionally use the x/ystart 
values from the header to compose a relative start location.

Figure 10-11: Image Mosaicking Dialog for Pixel-Based Image Mosaics
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• Use the arrow toggle button to select whether to display a Gray Scale or 
RGB color image in the mosaicking window. Enter the desired band 
numbers to display in the appropriate text boxes. Select the linear stretch 
percentage for the displayed bands by entering a value or clicking on the 
appropriate arrow increment buttons.

• Select whether to apply color balancing to the images by clicking the No, 
Fixed, or Adjust button (see “Color Balancing Images” below).

5. The Select Mosaic Size dialog appears. Enter the desired output size of the 
mosaic image, in pixels, in the Mosaic X Size and Mosaic Y Size text boxes. 
A subsampled image will appear in the Mosaic window for each file imported.

6. Import other files as needed. Each image name and the outline color are listed 
below the mosaic image.

Positioning Images

The coordinates for the upper left corner of the input image are listed in the X0 Y0 
text boxes at the bottom of the Pixel Based Image Mosaicking dialog. Images with x 
start and y start values in their headers are automatically placed in the mosaic with the 
defined offset. Select from the following options:

• To enable editing of the position coordinates, click on any listed image and 
enter the desired upper left coordinates in the fields labeled X0 and Y0 and 
press the Enter key on your keyboard.

The number of the currently selected image is shown in the text box labeled #. 
Any changes to the X0, and Y0 fields will be applied to this item. 

• Images can also be positioned within the mosaic by clicking and holding the 
left mouse button on the appropriate image and dragging to the desired 
location.

• To automatically place the images into a grid, select Options → Position 
Entries into Grid. The Position Images dialog appears. Enter the number of 
grid columns and rows, enter the number of border pixels to place around the 
images and enter the number of separation pixels to places between the 
images. Click OK and the mosaic image will be resized to fit the grid.

• To center the images, keeping their relative positioning, within the defined 
mosaic size, select Options → Center Entries.

• To lock the relative positions of the images and move them as a group, select 
Options → Positioning Lock On. Now click and drag the images to the 
desired position.
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Color Balancing Images

Use Color Balancing to match the statistics from one image to another (or many 
others) to balance the data range between different images. Gains and offsets are 
calculated from the fixed image and applied to the adjusted images so the adjusted 
images end up with the same statistical range. Gains and offsets are calculated 
individually for each band in the file. The statistics can be obtained from entire 
images or only from overlapping areas. To apply color balancing to a mosaic do the 
following.

Note
If you have data values to ignore, you must set a Data value to ignore value in the 
Edit Entry dialog so they will not be included in the calculated statistics.

1. Right-click on one of the images and select Edit Entry from the shortcut menu 
that appears. 

2. Select the Fixed button under Color Balancing. This image will be used to 
calculate statistics only and will not be adjusted.

3. Click on the image to adjust and select Edit Entry from the shortcut menu.

4. Select the Adjust button under Color Balancing.

5. Select Fixed or Adjust for any other images, as desired.

6. Select File → Apply to apply the color balancing and mosaicking.

Note
Color balancing cannot be done when using Virtual Mosaics.

7. When the Mosaic Parameters dialog appears, use the arrow toggle button to 
select whether to use the entire image or to use only the overlapping areas for 
statistics calculations. When there is a significant area of overlap, the best 
results are usually achieved by choosing only the overlapping areas for 
statistics calculations.

8. Enter a background DN value.

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.
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9. When creating a mosaic of grayscale and RGB images, you can apply one 
band images as RGB. Doing this, in addition to color balancing creates an 
RGB mosaic where the grayscale images blend well with the color images.

10. Enter an output filename and click OK.

The resulting color balanced mosaic will appear in the Available Bands List.

The Mosaicking Shortcut Menu

Use the mosaicking shortcut menus to change the image layer levels, edit image 
parameters or to remove an image from the mosaic.

Note
Click with the right mouse button in the part of the mosaic window without an 
image to get a shortcut menu containing the Import and Options menu items.

Bringing an Image to the Front

To bring an image to the front of all other images in the mosaic:

1. Click on either the image name or on the image thumbnail.

2. Click the right mouse button and select Raise Image to Top from the shortcut 
menu.

Note
If the image is already on top, this Raise Image to Top option will not be 
available. You can raise or lower an image one level by selecting Raise 
Image One Position or Lower Image One Position from the shortcut menu.

Editing Image Entry Parameters

To edit the background see-through value, feathering parameters, positioning, or 
displayed band:

1. Click on either the image name or on the image thumbnail.

2. Click the right mouse button and select Edit Entry from the shortcut menu. 
For parameter descriptions see “Importing Images” on page 896.
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Removing an Image

To remove an image from the mosaic:

1. Click on either the image name or on the image thumbnail.

2. Click the right mouse button and select Remove Entry from the shortcut 
menu.

Pixel-Based Mosaicking Options

Use the Options menu to change mosaic size, select positioning options, turn on/off 
the image frame graphics, and to clear all the entries.

Changing the Mosaic Size

To enter a new size, in pixels, for the mosaic:

1. Select Options → Change Mosaic Size. The Mosaic Size dialog will appear.

2. Enter the desired size, in pixels, in the Xsize and Ysize text boxes.

Positioning Images

To place the images into a grid, center the images, or lock the image positions 
so they can be moved as a group, see “Positioning Images” on page 890.

Using Thumbnail Images

To turn on/off the thumbnail images displayed in the mosaic window, select 
Options → Use Thumbnail Images menu item.

Turning On/Off Image Frames

To turn the colored graphic frames around the images in the mosaic off or on, 
select Options → Image Frames.

Clearing Entries

To clear all the entries from the mosaic, select Options → Clear All Entries.
ENVI User’s Guide Image Mosaicking



894 Chapter 10: Map Tools
Creating Virtual Mosaics

It is not necessary to save the mosaic to an output file unless feathering or color 
balancing was used. Instead, you can save the mosaic to a Virtual Mosaic. ENVI 
uses a virtual mosaic file (saved mosaic template) like an image file. When a virtual 
mosaic template file is opened, ENVI opens the individual image files that make up 
the mosaic and puts them together on-the-fly. ENVI cannot do feathering or color 
balancing on-the-fly, however. The mosaic template file can be displayed in ENVI 
and annotated, stretched, etc., like any other image. Using a virtual mosaic prevents 
having multiple files containing the same images and therefore saves disk space.

1. In the Pixel Based Image Mosaicking dialog, select File → Save Template.

2. In the Output Mosaic Template dialog, enter an output filename with the 
extension .mos for consistency.

3. Choose whether to open the new virtual mosaic file.

The template file is a virtual mosaic file in ASCII format. It contains the mosaic size, 
file names, bands used, data dimensions, and mosaic information. The Info field has 
the X and Y offsets, edge feathering distance, cutline feathering distance, and data 
value to ignore. 

The mosaic template file appears in the Available Bands List and can be used as input 
for processing with other functions.

Note
The template file can be edited, using any text editor, to change the file or the bands 
used in the mosaic. 

Restoring Saved Templates

1. Select File → Restore Template.

2. When an ENVI file selection dialog appears, select the desired .mos filename 
to load into the mosaic.

• Replace the files with new images by using Options → Replace Entry or 
edit the filenames in the ASCII .mos file (see “Creating Virtual Mosaics” 
on page 894).

Opening Virtual Mosaics

To open a virtual mosaic (saved template):

1. From the ENVI main menu, select File → Open Image File.

2. In the file selection dialog, select the .mos file.
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The virtual mosaic file and the files that make up the Virtual Mosaic are listed in the 
Available Bands List.

Building Mosaics

Use Apply to build a mosaic after all of the images for the mosaic have been 
positioned. Building the mosaic outputs the mosaic to a file.

Note
It is not necessary to build the mosaic to an output file unless feathering was used. 
The mosaic can be saved as a virtual mosaic to save time and disk space (see 
“Creating Virtual Mosaics” on page 894).

1. Select File → Apply.

The Mosaic Parameters dialog appears:

2. Select output to File or Memory.

3. Select the desired background DN value (DN value for areas without image) 
for the output mosaic.

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.

4. If color balancing is selected, use the arrow toggle button to select whether to 
use the entire image or to use only the overlapping areas for statistic 
calculations.

5. Click OK to start the mosaicking operation.

A status window displays the percent complete while the mosaic is being built. The 
mosaic name appears in the Available Bands List upon completion.

Closing the Dialog

• To close the Pixel Based Mosaic dialog, select File → Cancel.
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Building Georeferenced Mosaics

Use Georeferenced Mosaicking to automatically overlay multiple georeferenced 
images. You can mosaic multi-resolution georeferenced images, apply feathering to 
the images, and import georeferenced images and non-georeferenced images into the 
same mosaic. 

• To build mosaics using georeferenced images, select Map → Mosaicking → 
Georeferenced.

The Map Based Mosaic dialog appears. Use the dialog to set the output mosaic 
parameters and to select images to mosaic.

Importing Images

Use the Import menu to select input files for the mosaic. The first image imported 
into the mosaic must be a georeferenced image. The mosaic size will be set to the 
georeferenced image size.

Figure 10-12: Image Mosaicking Dialog for Georeferenced Image Mosaics
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1. Select either Import → Import Files or Import → Import Files and Edit 
Properties. Use the second option if you wish to enter a transparent 
background value, perform feathering, select which bands will appear in the 
mosaic display, or to perform color balancing.

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.

2. When the Mosaic Input File appears, select a file or files and perform any 
spatial and spectral subsetting.

Note
Individual bands or entire files can be mosaicked.

• To select individual bands click the Select By arrow toggle button in the 
Mosaic Input File dialog to select Band.

Once you select the first input file for the mosaic, a thumbnail image will 
appear and the mosaic size is set.

3. If you selected Import Files and Edit Properties a dialog for each file 
selected appears that allows you to set the following parameters:

• Enter a transparent background value to make pixels with that value 
transparent so that the underlying image is visible (Use for mosaicking of 
images with constant DN value borders).

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.

• Enter feathering parameters as needed (For more information, see 
“Feathering” on page 901).

• Use the arrow toggle button to select whether to display a Gray Scale or 
RGB color image in the mosaicking window. Enter the desired band 
numbers to display in the appropriate text boxes. Select the linear stretch 
percentage for the displayed bands by entering a value or clicking on the 
appropriate arrow increment buttons.
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• Select whether to apply color balancing to the images by clicking the No, 
Fixed, or Adjust button (see “Color Balancing Images” on page 891).

4. Import additional georeferenced images to the mosaic as needed. 

Georeferenced images are automatically positioned within the output mosaic 
according to their geographic coordinates. New images are placed in front of 
the other images and the mosaic size is automatically adjusted to accommodate 
the new images. If a properly georeferenced image is imported with map 
coordinates that lay outside the current map extent of the mosaic, the mosaic 
size is automatically changed to include the new image location. 

For multi-resolution mosaicking, the output pixel size is entered on output and 
ENVI automatically resamples the lower resolution images to match.

5. Import additional non-georeferenced images as needed. These images can be 
positioned in the same manner as Pixel Based Mosaicking (for more 
information, see “Positioning Images” on page 890). Each image name and the 
outline color are listed below the mosaic image.

Note
You cannot adjust the mosaic positions of georeferenced images.

The Mosaicking Shortcut Menu

Use the mosaicking shortcut menus to change the image layer levels, edit image 
parameters or to remove an image from the mosaic (for more information, see “The 
Mosaicking Shortcut Menu” on page 892).

Tip
Click with the right mouse button in the part of the mosaic window without an 
image to get a shortcut menu containing Import and Options menu items.

Georeferenced Image Mosaicking Options

Use the Options menu to change the base projection, turn on/off the thumbnail 
images, turn on/off the colored image frame graphics, and to clear all the entries.

Note
The other unavailable options on this menu are used only in Pixel Based 
Mosaicking.
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Changing the Base Projection

To change the base projection of the images, select Options → Change Base 
Projection. Select the new projection and enter the necessary parameters (for more 
information, see “Selecting Map Projection Types” on page 922).

Using Thumbnail Images

To turn on/off the thumbnail images displayed in the mosaic window, select 
Options → Use Thumbnail Images menu item.

Turning On/Off Image Frames

To turn off or on the graphic frames around the images in the mosaic, select 
Options → Image Frames.

Clearing Entries

To clear all the entries from the mosaic, select Options → Clear All Entries.

Creating Virtual Mosaics

It is not necessary to save the mosaic to an output file unless feathering, multi-
resolution data, or color balancing were used. Instead, you can save the mosaic to a 
Virtual Mosaic. ENVI uses a virtual mosaic file (saved mosaic template) like an 
image file. When a virtual mosaic template file is opened, ENVI opens the individual 
image files that make up the mosaic and puts them together on-the-fly. ENVI cannot 
do feathering, multi-resolution resampling, or color balancing on-the-fly, however. 
The mosaic template file can be displayed in ENVI and annotated, stretched, etc., like 
any other image. Using a virtual mosaic prevents having multiple files containing the 
same images and therefore saves disk space.

1. In the Georeferenced Image Mosaicking dialog, select File → Save Template.

2. In the Output Mosaic Template dialog, enter an output filename with the 
extension .mos for consistency.

3. Choose whether to open the new virtual mosaic file.

The template file is a virtual mosaic file in ASCII format. It contains the mosaic size, 
file names, bands used, data dimensions, and mosaic information. The Info field has 
the X and Y offsets, edge feathering distance, cutline feathering distance, and data 
value to ignore.

The Virtual Mosaic appears in the Available Bands List and can be used as input for 
processing with other functions.
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Restoring Saved Templates

1. Select File → Restore Template.

2. When an ENVI file selection dialog appears with all the .mos files listed by 
default, select the desired filename to load that template into the mosaic.

Opening Virtual Mosaics

To open a virtual mosaic (saved template):

1. From the ENVI main menu, select File → Open Image File.

2. In the file selection dialog, select the .mos file.

The virtual mosaic file and the files that make up the virtual mosaic are listed in the 
Available Bands List.

Building Mosaics

Use Apply to build a mosaic after all of the images for the mosaic have been 
positioned. Building the mosaic outputs the mosaic to a file.

Note
It is not necessary to save the mosaic to an output file unless feathering, 
multiresolution data, or color balancing were used. The mosaic can be saved as a 
virtual mosaic file to save time and disk space (see “Creating Virtual Mosaics” on 
page 894).

1. Select File → Apply.

The Mosaic Parameters dialog appears with the output pixel size defaulted to 
the highest resolution of input images. ENVI automatically resamples lower 
resolution images to match. Non-georeferenced images in the mosaic are not 
resampled.

• To change the output pixel size, enter the desired size in map units (i.e. 
meters, degrees, etc.) in the appropriate text boxes.

2. Select the type of multi-resolution resampling (nearest neighbor, bilinear, or 
cubic convolution) from the Resampling menu. Nearest Neighbor resampling 
is recommended.

3. Select output to File or Memory.
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4. Enter desired background DN value for the output mosaic.

Note
The background value mask is built from the first band used in the file. If a 
pixel in the first band used contains this background value, then that pixel 
will be masked out for all bands in the mosaicking process.

5. If color balancing is selected, use the arrow toggle button to select whether to 
use the entire image or to use only the overlapping areas for statistics 
calculations.

6. Click OK to start the mosaicking operation.

A status window showing the percent complete appears while the mosaic is being 
built. The mosaic name will appear in the Available Bands List when completed.

Closing the Dialog

• To exit the Georeferenced Image Mosaicking dialog, select File → Cancel.

Feathering

Use Feathering to blend the edges of overlapping areas in input images for pixel-
based and georeferenced mosaicking. The two types of feathering in ENVI are edge 
feathering and cutline feathering.

Tip
To use feathering when mosaicking images, import the bottom image without 
feathering. Import the overlapping images with edge or cutline feathering as 
desired.

Using Edge Feathering

Use edge feathering to blend the edge of a top image with the bottom image based on 
a specified blending distance (see Figure 10-13). The distance specified is used to 
create a linear ramp that averages the two images across that distance. For example, if 
the specified distance is 20 pixels, 0% of the top image is used in the blending at its 
edge and 100% of the bottom image is used to make the output image. At the 
specified distance (20 pixels) into the image from the edge, 100% of the top image is 
used to make the output image and 0% of the bottom image is used. 50% of each 
image is used to make the output at 10 pixels in from the edge.
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1. In the mosaic dialog, select Import → Import Files and Edit Properties or 
right-click on the image and select Edit Entry from the shortcut menu. The 
Entry dialog appears.

2. In the Edge feathering distance (pixels) text box, enter the distance over 
which to blend the images.

Using Cutline Feathering

Use Cutline feathering to blend the boundary between two overlapping images based 
on a user-defined cutline. A specified blending distance is used to blend the images 
along the cutline (see Figure 10-14).

Note
Cutlines must be defined using the annotation tools prior to mosaicking. The 
annotation file must contain a polyline defining the cutline that is drawn from edge-
to-edge and a symbol placed in the region of the image that will be cut off (see 
“Annotating Images” on page 240).

Figure 10-13: Example of Edge Feathering
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The distance specified is used to create a linear ramp that averages the two images 
across that distance from the cutline outwards. For example, if the specified distance 
is 20 pixels, 100% of the top image is used in the blending at the cutline and 0% of 
the bottom image is used to make the output image. At the specified distance (20 
pixels) out from the cutline, 0% of the top image is used to make the output image 
and 100% of the bottom image is used. 50% of each image is used to make the output 
at 10 pixels out from the cutline.

1. In the mosaic dialog, select Import → Import Files and Edit Properties or 
right-click on the image and select Edit Entry from the shortcut menu.

2. When the Entry dialog appears, click the Select Cutline Annotation File 
button and select an annotation file. 

3. In the Feathering Distance text box that appears in the Cutline Feathering 
Frame, specify the distance used to blend the image boundaries.

The cutline will appear as a graphic overlaid on the image.

Figure 10-14: Example of Cutline Feathering
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Georeferencing from Input Geometry

Use Georeference from Input Geometry to georeference data that has an associated 
file containing map locations for every pixel. This is a very accurate method of 
georeferencing data because it places every pixel at its exact map location, avoiding 
using GCPs and polynomial warping. The map information, contained in an Input 
Geometry (IGM) files, is stored in two bands, one for X coordinates (e.g., longitude 
or northing) and one for Y coordinates (e.g., latitude or easting).

Many data sets include IGM files in their distribution and ENVI generates IGM files 
for various sensors such as SeaWiFS and AVHRR (see “Building SeaWiFS Geometry 
Files” on page 914 and “Building AVHRR Geometry Files” on page 917). The input 
geometry (IGM) file itself is not geocorrected, but does contain the geolocation 
information for each original raw pixel. The IGM file is used to create a geographic 
look-up table (GLT) file that contains the information about which original pixel 
occupies which output pixel in the final product. The GLT file can be used to 
geocorrect any band or derived product through a lookup table. The GLT file contains 
integer pixel location values which are sign-coded to indicate if a certain output pixel 
is “real” or a nearest-neighbor infill pixel. Positive GLT values indicate that an exact 
pixel location is used and negative GLT values indicate that the nearest neighbor pixel 
is used. The GLT file is a geocorrected product, with a fixed pixel size projected into 
a rotated UTM system. It uses 1-based coordinates (upper left pixel is located at 1,1). 

You can georeference your data directly from an IGM file or from a GLT file. When 
you georeference from an IGM file, the GLT file is built on-the-fly.

Note
Because the georeferenced images have null values around their edges that must be 
masked in processing and are often inflated in size by replicated pixels, it is 
suggested that you do all the data processing first, then apply the geocorrection to 
the derived final products. 

Building GLT Files

Use Build GLT to build a Geographic Lookup Table (GLT) file from input geometry. 
The two bands of the GLT file refer to the original sample number and the original 
line number, respectively. The sign of the value indicates whether the pixel is an 
actual image pixel, located at its proper position (indicated by a positive value) or a 
nearest-neighbor infill pixel placed to fill an undersampled image gap (indicated by a 
negative value). A zero value signifies that no input pixel corresponds to the output 
pixel.
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1. Select Map → Georeference from Input Geometry → Build GLT.

2. When the Input X Geometry Band selection dialog appears, select the band 
that contains the X geometry coordinates. Click OK.

3. When the Input Y Geometry Band selection dialog appears, select the band 
that contains the Y geometry coordinates. Click OK.

The Geometry Projection Information dialog appears.

4. In the Input Projection of Geometry Bands list, click on the projection type.

5. In the Output Projection for Georeferencing list, click on the projection for 
the georeferencing.

For instructions on selecting input and output projections, see “Selecting Map 
Projection Types” on page 922.

6. Click OK.

A default output pixel size and rotation angle is calculated and it appears in the 
Build Geometry Lookup File Parameters dialog.

The default output pixel size is calculated based on the map coordinates in 
output space. The default output rotation angle is used to minimize the output 
file size. If the rotation angle is set to 0 then north will be up in the output 
image. If it is set to another angle, then north will be at an angle and will not be 
“up” in the output image. The rotation angle is stored in the ENVI header and 
is used when overlaying grids, so the grid lines will appear at an angle.

• To change the output pixel size, replace the value in the Output Pixel Size 
text box.

• To change the output rotation angle, replace the value in the Output 
Rotation text box.

Note
If you change a non-zero rotation angle to 0 so north is up, your resulting image 
may contain a lot of background fill and may become very large.

The process runs in two parts and the output GLT filename appears in the Available 
Bands List.
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Georeferencing from GLT Files

Use Georeference from GLT to georeference image data or results using a 
Geographic Lookup Table GLT file.

1. Select Map → Georeference from Input Geometry → Georeference from 
GLT.

2. Select the geometry lookup table (GLT) file.

3. Select the data file to georeference and any spectral subsetting.

4. If you used a subset of the original data as the input file, select whether to 
output only the warped subset region or whether to output that subset warped 
within the entire output boundary by clicking the Subset to Output Image 
Boundary arrow toggle button to select Yes or No. 

5. Enter the DN value to use as the background value around the edges of the 
warped data.

6. Enter an output filename.

7. Click OK.

Georeferencing from IGM Files

Use Georeference from IGM to georeference image data or results using an Input 
Geometry IGM file. Optionally, a GLT file can be output.

1. Select Map → Georeference from Input Geometry → Georeference from 
IGM.

2. Select the input file to georeference and any spectral subsetting.

3. Select the band that contains the X geometry coordinates.

4. Select the band that contains the Y geometry coordinates.

The Geometry Projection Information dialog appears.

5. Select the input projection of the geometry coordinates.

6. Select the output projection for the georeferencing.

For instructions on selecting input and output projections, see “Selecting Map 
Projection Types” on page 922.

7. Click OK.
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A default output pixel size and rotation angle are calculated and appear in the 
Build Geometry Lookup File Parameters dialog. 

The default output pixel size is calculated based on the map coordinates in 
output space. The default output rotation angle is used to minimize the output 
file size. If the rotation angle is set to 0 then north will be up in the output 
image. If it is set to another angle, then north will be at an angle and will not be 
“up” in the output image. The rotation angle is stored in the ENVI header and 
is used when overlaying grids, so the grid lines will appear at an angle.

• To change the output pixel size, replace the value in the Output Pixel Size 
text box.

• To change the output rotation angle, replace the value in the Output 
Rotation text box.

Note
If you change a non-zero rotation angle to 0 so north is up, your resulting 
image may contain a lot of background fill and may become very large.

8. Enter the DN value to use as the background value around the edges of the 
georeferenced data.

9. Enter an output filename.

10. Click OK.
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Building Super GLT Files

Use Build Super GLT to build super GLT files from input geometry (IGM) files. The 
super GLT file is not an image file; it contains information about how many and 
which input pixels contribute to the output pixel. Using a super GLT file for 
georeferencing provides a more robust resampling method—a radial resampling 
method—but is a much slower process than regular GLT functions.

You’ll notice that the steps involved are basically the same as those for building 
regular GLT files, but the entire processing time is significantly longer. An outline of 
the procedure for building super GLT files follows.

Note
You can use Super Georeferencing from IGM to combine two steps—building the 
super GLT and georeferencing from it—into one step. For details, see “Super 
Georeferencing from IGM Files” on page 910.

1. From the ENVI main menu, select Map → Georeference from Input 
Geometry → Build Super GLT.

2. Select the input X and Y geometry bands, then select the input and output 
projections.

The process runs in two parts. The regular GLT filename appears in the Available 
Bands List, but the Super GLT filename does not.

Georeferencing from Super GLT Files

Use Georeference from Super GLT to georeference image data or results using a 
super GLT file. This function performs radial resampling to derive the output image 
using a specified kernel size. Each output pixel is calculated by weighting all the 
pixels in the kernel by the inverse of their radial distance to the center of the output 
pixel. You specify the kernel size and minimum number of pixels used in the 
resampling.

Warning
Because super GLT functions are slow, allow a significant amount of time for 
processing.
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1. Select Map → Georeference from Input Geometry → Georeference from 
Super GLT.

2. In the input file selection dialog, select the data file to georeference and 
perform any spectral subsetting.

3. In the next file selection dialog, select the super GLT file.

The Georeference from SGL Parameters dialog appears.

4. In the Background Pixel Value text box, enter the DN value to use as the 
background value around the edges of the warped data.

5. In the Kernel Size Min and Max text boxes, enter a minimum and maximum 
kernel size to use, or click the arrow buttons to set the values.

The minimum kernel size is used in the resampling unless fewer than the 
minimum number of pixels to resample, or valid pixels, are contained in the 
kernel. If fewer than the minimum number of valid pixels are contained in the 
kernel, the kernel size is increased until either the minimum number of valid 
pixels is met or the maximum kernel size is met. If there are fewer than the 
minimum number of valid pixels in the maximum kernel size then the output 
pixel value will be set to the background value.

6. Enter the minimum number of pixels to resample, or click the arrow buttons to 
set a value. 

If fewer than the minimum number of pixels are contained in the maximum 
kernel size then the output pixel value will be set to the background value.

Figure 10-15: Georeference from SGL Parameters Dialog
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7. Select File or Memory output.

8. Click OK.

The results appear in the Available Bands List.

Super Georeferencing from IGM Files

The Super Georeference from IGM function combines building a super GLT file 
and georeferencing from it into a single process. The process georeferences an image 
using an Input Geometry (IGM) file and uses radial resampling to derive the output 
image. Additionally, you have the option to output the super GLT that is built during 
this process.

You’ll notice that the initial steps for super georeferencing from IGM files are the 
same as those for regular georeferencing from IGM files. However, there are 
additional steps required for building and outputting the super GLT file.

1. Select Map → Georeference from Input Geometry → Super Georeference 
from IGM.

2. In the input file selection dialog, select the input file to georeference and 
perform any spectral subsetting.

3. In the subsequent dialogs, select the X and Y input geometry bands.

The Geometry Projection Information dialog appears.

4. Select the input and output projections and click OK.

A default output pixel size and rotation angle are calculated and appear in the 
Build Geometry Lookup File Parameters dialog.

5. In the Kernel Size Min and Max text boxes, enter a minimum and maximum 
kernel size to use, or click the arrow buttons to set the values.

The minimum kernel size is used in the resampling unless fewer than the 
minimum number of pixels to resample, or valid pixels, are contained in the 
kernel. If fewer than the minimum number of valid pixels are contained in the 
kernel, the kernel size is increased until either the minimum number of valid 
pixels is met or the maximum kernel size is met. If there are fewer than the 
minimum number of valid pixels in the maximum kernel size then the output 
pixel value will be set to the background value.

6. Enter the minimum number of pixels to resample, or click the arrow buttons to 
set a value. 
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If fewer than the minimum number of pixels are contained in the maximum 
kernel size then the output pixel value will be set to the background value.

7. Enter an output filename for the super GLT file, if desired.

8. In the Background Pixel Value text box, enter the DN value to use as the 
background value around the edges of the warped data.

9. Select File or Memory output.

• For File output, click the Compress check box if you want to compress the 
output file.

10. Click OK.

The results appear in the Available Bands List.
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Georeferencing SPOT Data

Use Georeference SPOT to build geometry files and to georeference Level 1A and 
1B CEOS and Dimap format SPOT data.

Building SPOT Geometry Files

Use Build Geometry File to build a SPOT geometry file to calculate the X and Y 
coordinates for each pixel. You may select the desired projection for the coordinates. 

You can georeference the SPOT data by using the results from this procedure as the 
IGM input file in the Georeferencing from Input Geometry function.

1. Select Map → Georeference SPOT → Build Geometry File.

2. When the file selection dialog appears, select the SPOT image file.

The Build IGM for SPOT Data dialog appears.

3. Select the desired map projection for the XY coordinates by clicking on a 
projection type in the list.

• To designate an average scene elevation, enter the value in the Avg Scene 
Elevation (Meters).

4. In the Number of Base Points: X and Y text boxes, enter the number of base 
points to use.

These values are the number of points that are calculated and all other X and Y 
coordinates are interpolated from these points. You may select a number of 
base points up to the number of samples and lines in your image. If you select 
fewer base points, they will be evenly spaced throughout the image.

Note
Using a large number of base points will increase the processing time 
considerably.

5. Select whether to output the result to file or memory by clicking the File or 
Memory button.

6. Enter or choose an output filename.

7. Click OK.

ENVI extracts the needed information from the SPOT leader file and places the 
output coordinate bands in the Available Bands List.
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Georeferencing SPOT Data

Use Georeference Data to georeference SPOT data based on header information. 
ENVI performs a precision geocoding of the SPOT image using a complete geometry 
model of the earth and satellite orbit.

1. Select Map → Georeference SPOT → Georeference Data.

2. When the file selection dialog appears, select the SPOT image file.

The Georeference SPOT Data dialog appears.

3. Select the desired output map projection by clicking on a projection type in the 
list.

By default, a UTM map projection is selected based on header information.

• To designate an average scene elevation, enter the value in the Avg Scene 
Elevation (Meters).

4. Enter the number of warp points to use. You may select a number of warp 
points up to the number of samples and lines in your image. If you select fewer 
warp points, they will be evenly spaced throughout the image.

• To save the warp points to a GCP file, enter or choose an output filename.

Note
Using a large number of warp points will increase the processing time 
considerably.

5. Click OK.

6. When the standard Registration Parameters dialog appears, select the warping 
and resampling methods and change the output dimensions, if desired (see 
“Warping and Resampling” on page 870 for details).The triangulation method 
is recommended to produce the most accurate results. Note, however, that it 
will be much slower than polynomial warping.

7. Enter or choose an output filename and click OK.
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Georeferencing SeaWiFS Data

Use Georeference SeaWifs to calculate geometry information for and to 
georeference HDF and CEOS format SeaWiFS data. Geometry information includes 
latitude, longitude, sensor azimuth, sensor zenith, solar azimuth, solar zenith, and 
UTC time. The georeferencing function produces a full precision geocoding based on 
a complete geometry model of the earth and satellite orbit.

Building SeaWiFS Geometry Files

Use Build Geometry File to calculate the geometry for HDF and CEOS format 
SeaWiFS data. When you select this function, ENVI extracts the header information 
and calculates the geometry values for each pixel. You can select which values to 
calculate: latitude, longitude, sensor azimuth and zenith angles, sun azimuth and 
zenith angles, and UTC time. The zenith angle is measured vertically from each pixel 
to the sensor or sun (straight above the pixel = 0 degrees) and the azimuth angle is the 
direction from each pixel to the sensor or sun with north = 0 degrees, and angles 
increasing clockwise (i.e., east = 90 degrees).

Tip
You can also georeference your SeaWiFS data by using the results from this 
procedure as the IGM input file in Georeferencing from Input Geometry (see 
“Georeferencing from IGM Files” on page 906).

1. Select one of the following options:

• Select Basic Tools → Preprocessing → Data-Specific Utilities → 
SeaWiFS → HDF Build Geometry File or CEOS Build Geometry File.

• Select Map → Georeference SeaWiFS → HDF Build Geometry File or 
CEOS Build Geometry File.

2. When the SeaWiFS Input File dialog appears, select an image file and perform 
any spatial or spectral subsetting.

3. If your input file is not in HDF or CEOS format, select the associated HDF or 
CEOS annotation file to read the header information from.

4. When the SeaWiFS Geometry Parameters dialog appears, select the values to 
be computed by selecting one of the options below:

• To select individual values, click in the check boxes next to the desired 
value.
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• To select a range of values, enter the beginning and ending numbers into 
the two text boxes next to the Add Range button and click Add Range.

• To select all values, click Select All.

• To de-select any selected items, click Clear.

5. Select File or Memory output.

6. From the Output Data Type button menu, select Double or Floating Point.

7. Click OK.

Georeferencing SeaWiFS Data

Use Georeference Data to georeference your HDF and CEOS format SeaWiFS data. 
ENVI extracts the header information for CEOS or HDF format SeaWiFS data and 
does a precision geocoding of the data based on a complete geometry model of the 
earth and satellite orbit.

Tip
We recommend that you use the more accurate technique, Georeference from 
Input Geometry (see “Georeferencing from Input Geometry” on page 904), 
instead of CEOS or HDF Georeference Data.

1. Select one of the following options:

• Select Basic Tools → Preprocessing → Data-Specific Utilities → 
SeaWiFS → HDF Georeference Data or CEOS Georeference Data.

• Select Map → Georeference SeaWiFS → HDF Georeference Data or 
CEOS Georeference Data.

2. When the SeaWiFS Input File dialog appears, select an image file and perform 
any spatial or spectral subsetting.

3. If your input file is not in HDF or CEOS format, select the associated HDF or 
CEOS annotation file to read the header information from.

4. When the Georeference SeaWiFS Parameters dialog appears, select the desired 
output map projection from the list (see “Selecting Map Projection Types” on 
page 922).

5. Enter the number of X and Y warp points to use in the corresponding X and Y 
text boxes.
ENVI User’s Guide Georeferencing SeaWiFS Data



916 Chapter 10: Map Tools
You may select a number of warp points up to the number of samples and lines 
in your image. If you select fewer warp points, they will be evenly spaced 
throughout the image. 

• To save the warp points to a GCP file, enter or choose an output filename.

Note
Using many warp points increases the warping time considerably, but can 
significantly increase the accuracy of the georeferencing.

6. Click OK.

7. When the standard Registration Parameters dialog appears, select the warping 
and resampling methods and change the output dimensions, if desired (see 
“Warping and Resampling” on page 870 for details).The triangulation method 
is recommended to produce the most accurate results. Note, however, that it 
will be much slower than polynomial warping.

8. Select either File or Memory output and click OK.
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Georeference AVHRR Data

Use Georeference AVHRR to build AVHRR geometry files and to georeference 
AVHRR data. 

Building AVHRR Geometry Files

Use AVHRR Build Geometry File to calculate the geometry values for each pixel. 
You may select which values to calculate: latitude, longitude, solar zenith, and/or 
sensor zenith angles.

Tip
You can also georeference your AVHRR data by using the results from this 
procedure as the IGM input file in Georeferencing from Input Geometry (see 
“Georeferencing from IGM Files” on page 906).

1. Select one of the following options:

• Select Map → Georeference AVHRR → Build Geometry File.

• Select Basic Tools → Preprocessing → Data-Specific Utilities → 
AVHRR → Build Geometry File. 

2. Select the original AVHRR file.

The AVHRR Image Geometry Parameters dialog appears.

3. Select which values to compute by clicking on them in the list. 

4. Select whether to output the zenith angles in degrees or radians by selecting the 
corresponding toggle button.

The zenith angle is measured vertically from each pixel to the sensor or sun 
(straight above the pixel = 0 degrees). 

5. Enter an output filename.

6. Select Double or Floating Point output data type from the Output Data Type 
button menu.

7. Click OK.

ENVI extracts the header information and calculates the geometry values for each 
pixel. 
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Georeferencing AVHRR Data

Use Georeference to georeference the AVHRR data, calibration results, and sea 
surface temperature image using information from original AVHRR data. Each line 
of data has 51 latitude and longitude values that can be used in the georeferencing. 

Note
After the original AVHRR data are georeferenced, the header information needed to 
calculate the calibration and sea surface temperatures is not in the new ENVI 
header. Therefore, georeferencing should not be done until the AVHRR data is 
calibrated and the sea surface temperatures are calculated (see “Calibrating AVHRR 
Data” on page 559 and “Computing Sea Surface Temperature” on page 560).

Tip
We recommend that you use the more accurate technique, (AVHRR) Build 
Geometry File and Georeference from Input Geometry (see “Georeferencing 
from Input Geometry” on page 904), instead of Georeference AVHRR Data.

1. Select Map → Georeference AVHRR → Georeference or Basic Tools → 
Data Specific Utilities → AVHRR → Georeference Data.

2. Select the input data file and perform any spatial and/or spectral subsetting.

• If the input data file is not the original AVHRR format file, another input 
file dialog appears for selection of the original AVHRR file.

The georeferencing information is extracted from the original AVHRR file.

3. When the Georeference AVHRR Parameters dialog appears, select the desired 
output map projection from the list and enter any necessary parameters (see 
“Selecting Map Projection Types” on page 922).

4. Enter the number of X and Y warp points to use in the corresponding X and Y 
text boxes.

Up to 51 points in the X direction and up to the number of lines in the Y 
direction can be used in the georeferencing. If fewer warp points are entered, 
they are evenly spaced throughout the image.

Note
Using many warp points increases the warping time considerably, but can 
significantly increase the accuracy of the georeferencing.

5. Click OK.
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The standard Registration Parameters dialog appears for you to select the 
warping and resampling methods and to change the output dimensions (see 
“Warping and Resampling” on page 870 for details).

6. Select either File or Memory output and click OK.
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Georeference ENVISAT

Use Georeference AATSR, Georeference ASAR, or Georeference MERIS to 
georeference your ENVISAT AATSR, ASAR, or MERIS data with the geolocation 
information included in the ENVISAT file. ENVISAT imagery contains geolocation 
tie points that correspond to specific pixels in the image. These tie points can be used 
to automatically georeference the ENVISAT data without building a geometry file.

1. Select one of the following menu options, depending on which type of 
ENVISAT imagery is being georeferenced:

• Basic Tools → Preprocessing → Data-Specific Utilities → 
ENVISAT → Georeference AATSR, or Georeference ASAR, or 
Georeference MERIS

• Spectral → Preprocessing → Data-Specific Utilities → ENVISAT → 
Georeference AATSR, or Georeference ASAR, or Georeference 
MERIS

• Map → Georeference ENVISAT → Georeference AATSR, or 
Georeference ASAR, or Georeference MERIS.

The Select ENVISAT File dialog appears.

2. Use the Select ENVISAT File dialog to select the input data file and to perform 
any desired spatial and/or spectral subsetting. The Select Output Projection 
dialog appears.

3. Select the desired output map projection from the list (see “Selecting Map 
Projection Types” on page 922 for more information) and enter any necessary 
parameters, and then click OK. The Registration Parameters dialog appears.

4. Select any necessary parameters (see “Warping and Resampling” on page 870 
for more information) and then click OK to run the georeferencing process.

The Image Registration status window then displays the progress of this process. 
When it is complete, the Image Registration window closes and the georeferenced 
results appear in the Available Bands List.
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Georeference MODIS 1B

Use Georeference MODIS 1B to georeference your MODIS 1B data sets. ENVI 
extracts latitude and longitude values from the header information that are used to 
georeference the data.

1. Select Map → Georeference MODIS or Basic Tools → Preprocessing → 
Data-Specific Utilities → MODIS 1B → Georeference Data.

2. Select the input data file and perform any spatial and/or spectral subsetting.

• If the input data file is not the original MODIS HDF file, another input file 
dialog appears for selection of the original MODIS file.

3. When the Georeference MODIS Parameters dialog appears, select the desired 
output map projection from the list and enter any necessary parameters (see 
“Selecting Map Projection Types” on page 922).

4. Enter the number of X and Y warp points to use in the corresponding X and Y 
text boxes.

When georeferencing MODIS data, the number of warp points can be up to 
1354 by 2050 points, depending on the size and stride of the latitude and 
longitude bands supplied with the data. If fewer warp points are entered, they 
are evenly spaced throughout the image.

Note
Using many warp points increases the warping time considerably, but can 
significantly increase the accuracy of the georeferencing.

5. Click OK.

The standard Registration Parameters dialog appears for you to select the 
warping and resampling methods and to change the output dimensions (see 
“Warping and Resampling” on page 870 for details).

6. Select either File or Memory output and click OK.
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Selecting Map Projection Types

Many functions require you to select an input and/or output map projection type for 
your data. Refer to the following procedure when projection selection is needed in 
any dialog. 

Note
For detailed information about map projections, see “Map Projections” on 
page 1111.

1. In the list of projection types, click on the name of the projection to select it.

• To build a customized map projection, click New and follow the 
instructions under “Building Customized Map Projections” on page 923.

Different parameters are available depending on the selected projection type.

2. Enter or select the corresponding secondary parameters for the selected 
projection type:

• If you select Arbitrary, select either Pixel Based or Map Based by 
clicking on the arrow toggle button next to the Coordinates label. 

Pixel-based uses the upper left corner as the origin and map-based uses the 
lower left corner as the origin. Either selection only affects the y 
coordinates.

• To change the datum for a projection type, click the Datum button and 
select a datum from the list in the Select Geographic Datum dialog.

The datum conversions are done using the Molodensky Transformation 
(see the web page http://www.connect.net/jbanta/).

• If you select UTM, click the N or S toggle button to indicate if the selected 
latitude is north (N) or south (S) of the equator. Enter a zone, or click the 
Set Zone button and enter the latitude and longitude values to 
automatically calculate the zone.

• If you select a State Plane... projection, enter the zone or click the Set 
Zone button and select the zone name from the list.

Both NOS and USGS zone numbers are shown next to the zone name.

• To designate the units for a projection type, click the Units button and 
select a unit type. Enter a pixel size (in the selected unit), if needed.
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Building Customized Map Projections

ENVI includes many standard map projections such as Universal Transverse 
Mercator (UTM) and Gauss-Kruger. For more information about ENVI’s supported 
map projections, see Appendix D, “ENVI Map Projections”. Use Customized Map 
Projection to enter other known map projections and to create your own customized 
map projections such as UTM projections with other datum or ellipsoids. You have 
complete control over all of the map projection parameters including projection type 
(Transverse Mercator, Lamberts Conformal Conic, Lambert Azimuthal Equal Area, 
Oblique Mercator (A and B), Stereographic, Albers Equal Area, Polyconic, and 
others), Ellipsoid, Datum, False Easting and Northing. Details of specific map 
projections can be found in Snyder, 1982, USGS Bulletin 1532, “Map Projections 
Used by the U. S. Geological Survey.” Details on datums can be found on the 
following internet web pages.

http://www.colorado.edu/geography/gcraft/notes/datum/datum_f.html and 
http://www.connect.net/jbanta/.

Note
ENVI’s UTM projection uses the North American 1927 datum and Clarke 1866 
ellipsoid.

1. Select Map → Customized Map Projection, or click the New button in any 
dialog where map projection selection is available.

2. When the Customized Map Projection Definition dialog appears, either enter a 
new projection name and parameters, or select Projection → Load Existing 
Projection to select from a list of “standard” projections contained in the file 
map_proj.txt located in the ENVI directory structure (see “ENVI Map 
Projections File” on page 1085). 

Once loaded, all of the parameters can be edited. 

3. Enter or modify the projection name in the Projection Name: text box, if 
desired.

4. Select the Projection Type from the list of supported projections (see “Map 
Projections” on page 1111).
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5. Click the arrow toggle button to select Projection Ellipsoid: or Projection 
Datum and select from the following options:

• If a different ellipsoid is desired:

A. Select User Defined from the list.

B. Enter the desired A and B values to define the ellipsoid (See Snyder, 
1982).

• To change the datum:

A. Select the desired datum from the scrolling list.

The ellipsoid that corresponds with the selected datum is shown next to the 
Ellipsoid label.

B. Toggle back to the Projection Ellipsoid list and select this ellipsoid. 

6. If a false easting and northing is desired (usually used to keep map coordinates 
from being negative), enter the values in the corresponding text boxes.

7. Enter the Projection Origin latitude and longitude in degrees, minutes, and 
seconds or select Options → DMS <−> DD and enter latitude and longitude in 
decimal-degrees. You can also select Options → Extract Projection Origin 
From Image to set the latitude/longitude to the center pixel location of an 
existing georeferenced image.
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8. Enter the projection-type-specific parameters in the available text boxes on the 
right side of the dialog.

The parameters vary depending upon the projection selected. For example, for 
transverse mercator, the central meridian and base latitude are required along 
with a scaling constant (this constant is the scale on the central meridian, used 
so that the mean scale of the entire map is more nearly correct). Polyconic 
requires the projection origin. Lamberts Conformal Conic and Albers Equal 
Area projections require the projection origin and two standard parallels. See 
Snyder, 1982 for details.

Figure 10-16: Customized Map Projection Definition Dialog
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9. Select Projection → Add New Projection to add the projection to the list of 
projections used by ENVI.

The available projections are modified for the current ENVI session and you 
will be asked if you want to save the changes to the map_proj.txt file when 
you close the dialog (see “ENVI Map Projections File” on page 1085).

• To save the new or modified projection information, select File → Save 
Projections.

The file map_proj.txt, located in the ENVI directory structure, is modified 
to contain the new projection. You can edit this file using any text editor as an 
alternate to the interactive definition above. 

10. Select File → Cancel to exit the function.
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Converting Map Projections

Use Convert Map Projection to convert your georeferenced files to another map 
projection. The conversion is done by warping the file into the new projection.

1. Select Map → Convert Map Projection.

2. Select the input georeferenced file and click OK.

The Convert Map Projection Parameters dialog appears with the input 
projection shown at the top of the dialog. The available output projections, 
from the map_proj.txt file are displayed in the Select Output Map Projection 
list (see “ENVI Map Projections File” on page 1085).

3. In the Select Output Map Projection list, select the output projection by 
clicking on the desired type and entering the necessary parameters (see 
“Selecting Map Projection Types” on page 922).

4. Click OK.

The map projection is converted by warping the file using a grid of control 
points.

5. In the Number of Warp Points X/Y text boxes, define the number of control 
points to be used in the X and Y directions.

Note
Using many warp points increases the warping time considerably, but can 
significantly increase the accuracy of the conversion.

6. Click OK.

The Convert Map Projection function uses the standard registration parameters 
dialog to perform the warping of the image to the new projection (see 
“Warping and Resampling” on page 870).

7. When the Registration Parameters dialog appears, select the warp method: 
RST, Polynomial, or Triangulation.

8. Select the resampling method: Nearest Neighbor, Bilinear, or Cubic 
Convolution.

9. Enter the output filename and select output to File or Memory.
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10. Click OK to convert your data to the new projection.

Figure 10-17: Convert Map Projection Dialog
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Layer Stacking

Use Layer Stacking to build a new multiband file from georeferenced images of 
various pixel sizes, extents, and projections. The input bands will be resampled and 
re-projected to a common output projection and pixel size. The output file will have a 
geographic extent that either encompasses all of the input file extents or encompasses 
only the data extent where all of the files overlap.

For detailed instructions, see “Layer Stacking” on page 470.
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Converting Map Coordinates

Use Map Coordinate Converter as a calculator to convert between latitude and 
longitude and corresponding map projection coordinates. 

1. Select Map → Map Coordinate Converter. 

The Map Coordinate Converter dialog appears.

2. In the First Coordinate section of the dialog, enter the coordinates of the 
known point.

• If the known point is in latitude and longitude, enter the coordinates in the 
appropriate text boxes.

• To enter latitude and longitude in degrees, minutes, seconds (DMS) or in 
decimal degrees (DDEG), click on the appropriate button.

• If the known point is in another projection, click on the arrow toggle 
button next to the Proj: Geographic Lat/Lon label and follow these steps.

A. Click Change Proj.

B. When the Projection Selection dialog appears, select the desired projection 
name by clicking on it.

C. Select from the following options depending on the projection type.

• To change the projection units, click the Units button and select the 
desired units.

• To change the datum, click the Datum button and select the desired datum.

• To calculate the zone number for a UTM projection, select the N or S 
toggle button and click the Set Zone button. Enter the latitude and 
longitude values.

• To select a zone number for a State Plane projection, click the Set Zone 
button and select the desired zone name. Both NOS and USGS zone 
numbers are shown next to the zone name.

D. Click OK.

3. In the Second Coordinate part of the dialog, click on the Change Proj button 
to select the output projection.

4. Select the projection parameters as described for the known point projection 
type.
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5. Select one of the following options:

• To convert the point in the First Coordinate projection into the Second 
Coordinate projection type, click the Forward button.

• To convert the point in the Second Coordinate projection into the First 
Coordinate projection type, click the Reverse button.

• To clear the coordinates, click the Reset button.

6. Click Cancel to close the function.

Figure 10-18: Map Coordinate Converter and Projection Selection Dialogs
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Converting ASCII Coordinates

Use ASCII Coordinate Conversions to convert ASCII coordinates in one projection 
and datum to another. The input ASCII file must contain columns of X, Y 
coordinates, and optional Z values (elevations). If no elevations are included in the 
input coordinates, then elevation values of 0 meters are assumed. The output file will 
also contain two columns of X, Y, (Z) coordinates in the new selected projection. You 
can output the coordinates to an ENVI ground control points (GCP) file.

1. Select Map → ASCII Coordinate Conversion. 

2. Select the input ASCII coordinates file.

• To add a file to the Selected Input Files list, click Input Additional File.

• To remove the file from the list, click on a filename in the Selected Input 
Files list and click Delete.

3. Enter an output filename or use the Choose button to select an output filename.

4. Click OK to continue.

5. When the ASCII Coordinate Conversion dialog appears, select the input 
projection type by clicking on the appropriate projection name from the Select 
Input Projection list (see “Selecting Map Projection Types” on page 922).

6. Select the desired output projection type by clicking on the projection name in 
the Select Output Projection list and choose the Coordinates, Datum, and 
Zone as appropriate for your selection (see “Selecting Map Projection Types” 
on page 922).

7. Enter the column numbers of the columns that contain the map information, Z 
elevation values (if any), and image values (if your input file is in ENVI GCP 
format) by entering a number or by using the arrow increment buttons next to 
the appropriate labels.

8. Select the numeric precision of the output data by using the arrow increment 
buttons or by entering a number next to the Precision label.
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9. Select one of the following output options:

• To output your converted coordinates and all other unchanged input 
columns of data, use the arrow toggle button next to the Output label to 
select All Input Columns.

• To output the converted coordinates and image values to an ENVI GCP 
(ground control points) file, use the arrow toggle button to select ENVI 
GCP File.

10. Click OK to convert the coordinates and write a new ASCII file containing the 
converted coordinates.
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Merging Old Projection Files

Use Merge Old “map_proj.txt” File to merge an old map_proj.txt file with the 
existing projection database, which means that projections you added in a previous 
release of ENVI will be merged with the new projection database.

1. Select Map → Merge Old “map_proj.txt” File.

2. When the Enter Old “map_proj.txt” Filename selection dialog appears, 
select the old projection file.

A prompt appears, telling you how many projections were added to the 
database.

3. Click Yes to save the changes to the current map_proj.txt file.

4. Enter or choose a new output filename, if desired, and click OK.
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Using GPS-Link

Use GPS-Link to read National Marine Electronics Association 0183 format 
(NMEA 0183) data directly from a GPS unit. The GPS must be manually set to the 
NMEA -0183 mode. ENVI supports a GPS-link on PCs running Microsoft Windows 
98, Windows NT, Windows 2000, or Windows XP. However, the SCSI tape support 
drivers are needed for the link to work on Windows. To install SCSI tape support for 
Microsoft Windows 98, Windows 2000, Windows NT, and Windows XP platforms, 
open the aspi_v470.exe self-extracting archive in the \tape32 directory on the 
ENVI for Windows installation CD. Please see the included README.DOC file for 
installation instructions.

Collecting GPS Locations

ENVI can automatically collect GPS locations at a user-specified time interval, 
collect single locations, and automatically follow the locations on a displayed image. 
The GPS points can be saved to an ASCII file, ENVI vector file (.evf), or exported 
to the registration Ground Control Points Selection dialog.

1. Select Map → GPS-Link. 

The GPS-Link Serial Parameters dialog appears.

2. From the Serial Port button menu, select the serial port that the GPS receiver 
is plugged into.

3. Select the appropriate GPS baud rate, data bits, stop bits, parity type, and 
parity enable from the corresponding button menus.

4. Click Select GPS Datum.

5. In the Select Datum dialog, select the datum type that your GPS unit is using to 
collect data. Click OK.

6. In the GPS-Link Serial Parameters dialog, click OK.

The ENVI GPS-Link dialog appears. 

7. Click Get Location to collect the current location.

The latitude, longitude, and time of collection appear in the dialog.

8. Click on the Get Location button again to collect another location.

The location appears in the dialog list.
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9. Select from the following options:

• To enter text about a location point:

A. In the list of locations, click on a location. Click Edit.

B. In the dialog that appears, enter the information. Click OK.

This text is output along with the point when it is saved to an ASCII file.

• To go to the location of a specific point in the associated displayed image, 
click on the desired location point in the list. Click Goto.

• To export a location point to an open Image-to-map registration Ground 
Control Points Selection dialog, click on the desired location point in the 
list. Click Export.

The location appears in the registration dialog (see “Image-to-Map Ground 
Control Points” on page 864).

• To delete a location point from the list, click on the location point and click 
Delete.

Attaching GPS Links to Displays

You can attach the GPS-Link to a display window that contains a georeferenced 
image. The position of the cursor in the display window follows the GPS locations.

1. Select Options → Attach to display.

The Attach GPS-Link to Display dialog appears. 

2. Select the desired display number and click OK.

As the GPS locations are updated, the center pixel in the zoom window moves 
to follow their locations.

GPS-Link Options

In the ENVI GPS-Link dialog, use the Options menu to clear points, collect points, 
set the display format (degrees) of the points.

• To erase all points in the list, select Options → Clear Points. 

• To turn the automatic collection of points at a set time interval on or off, select 
Options → Auto Update:On/Off. 

• To set the time interval between automatic point collection, select Options → 
Set Retrieval Rate. Enter the desired time interval in seconds. 
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• To turn the collection of points on and off, select Options → Collect 
Points:On/Off. 

• When in Auto Update mode, select Collect Points: On/Off to pause the 
collection of points. 

• To display the collected location in decimal degrees (DD) or in degrees, 
minutes, seconds, select Options → Display Points:DD/DMS. 

Managing GPS-Link Locations

In the ENVI GPS-Link dialog, use the File menu to save GPS locations.

Saving GPS Locations to ASCII Files

1. Select File → Save Points to ASCII.

2. Enter or choose an output filename.

The ASCII file contains the latitude, longitude, Julian time, and any associated 
text that was entered using the Edit button.

Saving GPS Locations to ENVI Vector Files

1. Select File → Save Points to EVF. 

The Save GPS Points to EVF dialog appears.

2. Select the appropriate button to save each point as a separate record, save all 
the points as one record, or to save all the points as a polyline.

3. Enter a layer name.

4. Select File or Memory output. 

5. Click OK.

Closing the Dialog

• To exit the ENVI GPS-Link dialog, select File → Cancel. 
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Chapter 11:

Vector Tools
This chapter covers the following topics:
The Vector Menu . . . . . . . . . . . . . . . . . . . .  940
Opening Vector Files . . . . . . . . . . . . . . . . .  941
The Available Vectors List . . . . . . . . . . . . .  942
Working with the Vector Window . . . . . . .  943
Creating Vector Layers  . . . . . . . . . . . . . . .  966
Creating World Boundary Layers  . . . . . . .  968

Converting Raster Images  . . . . . . . . . . . .  969
Converting Classification Images . . . . . . .  970
Rasterizing Point Data  . . . . . . . . . . . . . . .  971
Converting ROIs to DXF Files . . . . . . . . .  973
Converting Annotation Files to DXF Files  974
Converting EVFs to DXF Files  . . . . . . . .  975
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The Vector Menu

Use the Vector menu to open vector files, create vector files, manage vector files, 
convert raster images (including classification images) to ENVI vector layers, grid 
irregular points, and convert ENVI vector files (EVF), annotation files (ANN), and 
regions of interest (ROI) to DXF format.

Note
You can also access ENVI’s interactive vector tools from the Display menu. For 
additional information about additional vector functions and detailed instructions, 
see “Overlaying Vectors” on page 325.

Figure 11-1: Vector Menu
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Opening Vector Files

Use Open Vector File to open ARCView Shape files, ARC/INFO Interchange format 
files, DXF vector files, MapInfo Interchange format (.mif), Microstation DGN 
(.dgn), USGS DLG files, USGS SDTS files, and ENVI vector format (.evf) files. 

1. Select File → Open Vector File → the desired format.

2. When the standard file selection dialog appears, select a filename and click 
Open (see “Selecting Files in ENVI” on page 32).

For detailed instructions for each vector format, see the descriptions under “Opening 
Vector Files” on page 63.
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The Available Vectors List

Use the Available Vectors List to access the vector files and the individual layers of 
each vector file that have been opened during the current session. When you load a 
vector file into memory for the first time during an ENVI session, ENVI places the 
vector layers into the Available Vectors List automatically. Use the Available Vectors 
List to load the vector layers into a vector display window or overlay them on a 
displayed image. For a full description and instructions, see “The Available Vectors 
List” on page 212.
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Working with the Vector Window

Use ENVI Vector Tools to view vector data such as USGS Digital Line Graphs 
(DLG), USGS DLGs in Spatial Data Transfer Standard (SDTS) format, DXF files, 
ARC/INFO Interchange files, and shapefiles. ENVI provides two ways of displaying 
and working with vectors: 

• Using the menu selections in the Image display group and the Vector 
Parameters dialog (see “Overlaying Vectors” in Chapter 4 for more 
information).

• Using the vectors by themselves in a Vector window (shown in Figure 11-2) 
with the same menu bar as the Vector Parameters dialog and the new shortcut 
menu selections.

The Vector window method is discussed in the sections that follow.

Figure 11-2: Vector Window with Menu Bar Selections
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Tip
It is highly recommended that you use the Mouse Button Descriptions window 
while working with vectors. This window provides information about the function 
of each mouse button at any given cursor location. 

Working with Vector Layers

In the Vector window, use the menus at the top of the window or the shortcut menus 
to control the appearance of vector layers, to add new vectors, export vector layer 
coordinates for use in image-to-map registration, and view, edit, and query vector 
attributes.

Selecting the Active Vector Layer

The active vector layer is the layer to which all editing or queries are performed.

1. Click the right mouse button inside the Vector window to bring up the shortcut 
menu.

Figure 11-3: Vector Parameters Dialog
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2. To select which layer is active, choose Select Active Layer → desired layer 
name from the Vector window shortcut menu.

Vector Window — Right-click in the Vector window to bring up the shortcut menu.

1. In the shortcut menu, use the Select Active Layer option and click on a layer 
to make it the active layer.

2. Right-click again to bring up the shortcut menu, and select the Active Layer 
Off/On.

Exporting Vector Coordinates

To export the current vector cursor coordinates, select Export Map Location from the 
shortcut menu. This option only appears if you have a Registration window open.

Figure 11-4: Vector Window Shortcut Menu for Active Layer
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Changing Vector Layer Display Properties 

Use the options in the Edit Vector Layers dialog to change the appearance of vector 
layers.

1. Choose Edit Layer Properties from the Vector window shortcut menu. 

2. When the Edit Vector Layers dialog appears, select the vector to edit by 
clicking on its name in the Layer Names list.

• To edit the layer color, line style, and line thickness, click on the 
appropriate button menu and select from the different options.

• To change the polygon fill type and style, click on the Polygon Fill button 
menu select from the options shown in the following table.

• To select the symbol used to plot points, click on the Point Symbol button 
menu and select a symbol type.

• To designate the size of the symbol, enter a size into the Symbol Size text 
box.

Option Description

None Leave the polygon unfilled.

Solid Fill the polygon with the polygon color.

line, dashed, 
dotted, etc.

Fill the polygon with equally spaced lines.

Orien Change the orientation of the fill lines, enter 
the value of the angle in degrees 
(counterclockwise, with respect to the 
horizontal [0 degrees]) in the provided 
parameter box.

Spc Change the spacing of the lines, enter a value 
in the provided parameter box

Table 11-1: Polygon Fill Options
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Plotting Attribute Names

To plot attribute names with the vector points and to associate attribute names with 
symbols:

1. In the Edit Vector Layers dialog, select the layer name and click on the 
Advanced button.

The Point Attribute Relationships dialog appears.

2. Click in the Associate attribute name with symbol check box.

3. Use the Attribute button menu to select the desired column name to plot from 
the attribute table.

4. Select left, middle, or right alignment, font type, text size and orientation using 
the appropriate parameters.

5. Click OK to return to the Edit Vector Layers dialog.

Note
For more information about attributes, see “Vector Attributes” on page 959.

Plotting Vector Points Based on Attribute Values

To plot vector points with different symbol sizes based on attribute values: 

1. In the Edit Vector Layers dialog, select the point layer name and click on the 
Advanced button. The Point Attribute Relationships dialog appears.

2. Click in the Associate attribute value with symbol size check box.

3. From the Attribute button menu, select the name of the attribute table column 
that contains the data to be used to scale the symbol size.

Note
The column must contain numeric values.

4. Select the minimum and maximum symbol size to use.

5. Click OK to return to the Edit Vector Layers dialog.
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Applying Vector Layer Edits

After selecting from the options in the Edit Vector Layers dialog, apply the changes 
to the vectors:

• In the Edit Vector Layers dialog click OK to apply the changes and exit.

Controlling Cursor Modes

Use the Mode menu to control the cursor mode in a Vector window. Use the cursor 
mode to select vectors and to highlight their corresponding attributes in the attribute 
table, to edit existing vectors, to add new vectors, to input vector points from an 
ASCII file, or to delete vectors. Cursor modes include Cursor Query, Edit Existing 
Vectors, and Add New Vectors.

Figure 11-5: Edit Vector Layers Dialog
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Select the cursor mode using Mode → cursor mode from the Vector window, or 
choose Select Mode → cursor mode using the Vector window shortcut menu.

Tip
Use Help → Mouse Button Descriptions to bring up a dialog that describes each 
mouse button function in each cursor mode. 

Selecting Vectors

To use the cursor to select a vector and to see the corresponding vector attribute 
information:

1. Choose Select Active Layer from the Vector window shortcut menu.

2. Select Options → Vector Information or Edit → View/Edit Attributes.

3. Select Mode → Cursor Query.

4. Click with the left mouse button on the desired vectors in the Vector window.

The associated attributes are displayed in the Vector Information dialog or 
highlighted in the vector attributes table.

Editing, Adding, and Removing Vector Nodes 

Use these options to change the location of vector nodes, to add vector nodes to 
existing vectors, and to remove vector nodes.

Tip
To have the same mouse button functions when in the Edit Existing Vectors mode 
as those in the Cursor Query mode (zoom, pan, etc.), hold down the Ctrl key 
while clicking the mouse button.

1. Choose Select Active Layer from the Vector window shortcut menu and 
choose the vector layer to be edited.

2. Select Mode → Edit Existing Vectors.

3. Click on a vector with the left mouse button. It is highlighted (see “Setting the 
Current Highlight Color” in Chapter 4).

4. To change the location of existing vector nodes, click and drag the diamond 
shaped handles using the left mouse button to edit the vectors.

Note
To undo all changes, click with the middle mouse button.
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5. To add vector nodes to the existing layer, click with the right mouse button on 
the location of the new node and then select Add Node [1] from the Vector 
window shortcut menu. 

• A new node will appear. Left-click and drag the new node to move it to the 
desired location.

• To change the number of nodes added, right-click and select Number of 
Nodes to Add from the Vector window shortcut menu. Enter the desired 
number of nodes to be added in the text box and click OK. 

• To add the nodes specified, position the cursor at the desired location and 
right-click the mouse to bring up the shortcut menu. From the shortcut 
menu, select Add Nodes [N], where N is the number specified previously. 
when the selection is made, the N nodes are placed in the Vector window.

6. To delete an existing vector node, click on the node with the right mouse 
button and select Delete Node from the shortcut menu. The selected node is 
removed and the two nearest nodes are connected. 

• To delete a range of nodes at once, click on one node using the right mouse 
button, and select Mark Node from the shortcut menu. Mark the node at 
the other end of the range the same way, and all nodes in between are 
selected. Right-click again, and choose Delete Marked Nodes from the 
shortcut menu. 

Note
To clear marked nodes, select Clear Marked Nodes from the shortcut menu.

7. Select Accept Changes from the shortcut menu to save the changes to the 
vector file. These changes can be undone by selecting Undo All Edits from the 
Vector window menu bar.

Splitting and Joining Polyline Vectors

To split or join polyline vectors, do the following:

1. Choose Select Active Layer from the Vector window shortcut menu.

2. In the Vector window, select Mode → Edit Existing Vectors.

3. Select the polyline vector by clicking on it with the left mouse button. The 
vector is highlighted and the nodes are shown with diamond shaped handles.

4. To split the polyline vector, click on a node with the right mouse button, and 
select Mark Node from the shortcut menu. Right-click again and select Split 
Vector from the shortcut menu and the marked node becomes two nodes. 
Working with the Vector Window ENVI User’s Guide



Chapter 11: Vector Tools 951
These nodes are the endpoints of the two new split polylines. They can now be 
separated and moved by clicking and dragging with the left mouse button.

5. To join polyline vectors, select one polyline vector in the active layer by left-
clicking on it. Select a second polyline vector by left-clicking on it. Now right 
click to bring up the shortcut menu and choose Join Vectors. The highlighted 
polylines are joined into a single vector.

6. If you want to save your changes to the vector file, select Accept Changes 
from the shortcut menu. 

Note
Accepted changes can be undone by selecting Edit → Undo All Edits from 
the Vector window menu bar. 

Deleting Vectors from Layers

1. Select the vector layer from which the vector will be deleted, by selecting the 
layer from the Vector window shortcut menu. 

2. Select Mode → Edit Existing Vectors. 

3. Click on the vector to delete using the left mouse button. The vector is 
highlighted.

4. Select Delete Selected Vector from the Vector window shortcut menu.

Note
The deleted vectors can be returned by selecting Edit → Undo All Edits.

Undoing Vector Changes

Use the Undo options to undo changes that have not been saved.

• To undo the last edit, addition, or deletion, select Edit → Undo Last Edit. 

• To undo all edits, additions, or deletions, select Edit → Undo All Edits. 

Saving Changes

To save changes made to vectors, select Edit → Save Changes Made to Layer.

Note
You cannot undo saved changes.
ENVI User’s Guide Working with the Vector Window



952 Chapter 11: Vector Tools
Adding New Vectors

To add new vectors to an existing layer: 

1. Click on the vector layer to which the vectors will be added by using Select 
Active Layer from the Vector window shortcut menu.

2. Select Mode → Add New Vectors.

3. Select the vector type from the shortcut menu in the Vector window. 

Note
From the Vector window shortcut menu, choose Multi Part: On. See 
“Drawing Multi Part ROIs” in Chapter 4 for detailed instructions.

4. Click with the left mouse button to define points, polygon or polyline vertices. 
Click and drag to draw rectangles or ellipses.

Note
To undo the last point, click with the middle mouse button.

5. Click the right mouse button to get a diamond shaped handle which can be 
used to move the vector position.

Note
Click with the middle mouse button to delete the vector.

6. Click the right mouse button and select Accept New Polygon from the 
shortcut menu to add the new vector.

• To remove the new vector, select Remove New Polygon from the shortcut 
menu.

• To turn on the node handles for editing purposes, select Node Handles On 
from the shortcut menu.

• If you are defining new points, you can either accept them as individual 
points by choosing Accept as Individual Points, or as multiple points in a 
single record by choosing Accept as Multi Point from the shortcut menu. 

Note
The new vectors can be removed by selecting Undo All Edits from the 
Vector window menu bar.
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Adding ASCII Points to Vector Layers

To read points from an ASCII file (e.g., GPS points) and add them to a vector layer: 

1. Select the vector layer to which the points will be added from the Vector 
window shortcut menu.

2. Select Mode → Add New Vectors in the Vector Parameters dialog.

3. Select Input Points from ASCII from the shortcut menu.

4. When the Input ASCII file dialog appears, select the x and y column numbers.

5. Use the pull-down menu to select the type of vector the points define, a 
polygon, polyline, group of points (as one vector), or individual points.

6. If your vectors are georeferenced, select the projection of the ASCII points.

7. Click OK to add the points to the vector layer.

Vector Layer Options

Use the Options menu from the Vector window to import additional vector layers, 
arrange the display order of the layers, place annotation in the vector window, change 
the plot parameters, get vector information, and to undo and save changes to vector 
layers. 

Toggle On/Off Crosshair Cursor

Use Toggle Cursor On when in Cursor Query mode to leave the crosshair cursor on 
the display. This toggle feature can be accessed using the following method.

• Use the Toggle Cursor On/Off selection from the Vector window shortcut 
menu. 

Loading Additional Vectors

Use this procedure to load additional vectors from files that are already open in the 
Available Vectors List. 

1. From the Vector window shortcut menu, select Options → Import Layers.
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2. When the Import Vector Layers dialog appears, select the vector files to be 
imported by clicking on the desired filenames.

Note
To cancel the selection process, click Cancel. 

3. Click OK.

The selected layers appear in the shortcut menu and are displayed automatically.

Select Active Layer

Use Select Active Layer to select which of the vector layers you are working on. 
This can be accessed using any of the following methods.

• From the Vector window menu bar, select Options → Select Active Layer → 
desired layer name.

• From the Vector window shortcut menu, choose Select Active Layer → 
desired layer name. 

Changing Layer Display Order

All vectors are drawn in the order that they are listed in the Available Vector Layers 
list. Use this procedure to change that order.

1. In the Vector window, select Options → Arrange Layer Order.

2. When the Vector Layer Ordering dialog appears, click on a layer name and 
drag it to the desired plot order precedence.

3. Click OK.

The vector layers are redrawn using the new display order. 

Removing Vector Layers

You can remove layers by using the following method.

1. From the Vector window menu bar, select Options → Remove Layers.

2. Select which layers to remove by clicking on the layer names, and click OK.

Note
From the Vector window shortcut menu, choose Remove Layers and select 
which layers to remove by clicking on the layer names.
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Note
To remove only the active layer, select Remove Active Layer from the 
Vector window shortcut menu.

Vector Information

• Use Options → Vector Information to view vector attributes. 

For more details, see “Viewing Vector Attributes” on page 959.

Adding Annotation to Vector Displays

• To add annotation to vector displays or to add a vector key, select Options → 
Annotate Plot from the Vector window menu bar. For further instructions, see 
“Annotating Images” in Chapter 4. 

Changing the Vector Window Display Range

To change the area displayed in the Vector window (in projection coordinates): 

1. From the Vector window menu bar, select Options → Plot Parameters. The 
Vector Window Plot Parameters dialog appears.

2. Enter the desired values in the X/Ymin and X/Ymax text boxes in the data 
projection coordinates.

Note
To reset the data ranges to the size of the bounding box, click Reset Ranges.

3. Click Apply to apply the new data range to the vector window.

Adding Borders and Tick Marks

To add a border, tick marks, and tick labels to the vector window: 

1. From the Vector window menu bar, select Options → Plot Parameters. The 
Vector Window Plot Parameters dialog appears.

2. Enter the desired values (in pixels) in the four Plot Border Values text boxes, 
for the top, right, bottom, and left sides of the window.

3. Select the background color from the Background button menu.

4. Enter the number of X/Y tick intervals in the appropriate text boxes. Tick 
marks in vector projection units are plotted in all the borders and labels are 
displayed in the left and bottom borders.
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5. Click Apply to apply the border and ticks to the window.

Note
To reset the plot range in the vector window to the bounding box, select 
Options → Reset Plot Range. 

Managing Vector Layer Files

From the Vector window menu, use the selections found under the File menu to open 
new vector files, save and restore vector template files, export vector layers to ROIs 
or to a shapefile, and output the vector display window.

Opening Additional Vector Files

1. From the Vector window menu bar, select File → Open Vector File → vector 
file type.

2. When the standard file selection dialog appears, select the vector file (see 
“Opening Vector Files” on page 63 for details). 

Creating Empty Vector Layers

Use Create New Layer to create a new and empty layer. 

1. Select File → Create New Layer.

2. When the New Vector Layer Parameters dialog appears, enter a layer name and 
select output to File or Memory.

• If you select File, enter an output file name.

3. Click OK.

The layer name appears in the Available Vector Layers list. 

Saving Vectors to Template Files

You can save the current vector setup to a template file for repeated use. 

1. From the Vector window menu bar, select File → Save Layers to Template.

2. Enter an output template filename with the extension .vec for consistency.

ENVI saves your current vector setup, including the loaded vectors, colors, 
line style and thicknesses, to a file with the extension .vec. 
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Restoring Layers from Saved Templates

1. Select File → Restore Layers from Template.

2. Select a .vec file.

The associated vector files are automatically opened, if needed. 

Note
Vectors that are in memory only cannot be saved and restored.

Exporting Vector Locations to GCPs

If you have a vector file for the area of an image to be map-registered, you can extract 
the map coordinates directly from the vector data and load them into the Ground 
Control Points Selection dialog by clicking with the left mouse button on a location 
and selecting Export Map Location from the Vector window shortcut menu.

For details, see “Entering Map GCPs from Vector Windows” on page 869.

Exporting Vector Layers to ROIs

1. Select the layer to export by clicking on the layer name in the Vector window 
shortcut menu.

2. Select File → Export Active Layer to ROIs.

3. When the Select Data File to Associate with new ROIs dialog appears, select 
the desired data file. The ROI name appears in the ROI Tool dialog.

Warning
Exporting layers to ROIs can create very large ROIs.

Exporting Vector Layers to Shapefiles

Use Export Active Layer to Shapefile to export vector layers to a shapefile (.shp), 
an index file (.shx), and a data base file (.dbf):

1. Select the vector layer to be exported by choosing Select Active Layer and 
clicking on the layer name in the Vector window shortcut menu.

2. Select File → Export Active Layer to Shapefile in the Vector Parameters 
dialog.

3. When the Output Layer to Shapefile dialog appears, enter the desired output 
filename and click OK.
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Note
Each shapefile can contain only one type of vector (polygon, point, etc.). If 
multiple vector types are present in the layer being exported, you are 
prompted to provide different output filenames for each vector type. 

Calculating Buffer Zone Images for Vectors

Use Calculate Buffer Zone to calculate a buffer zone image in which the value of 
every pixel is defined as the distance from that pixel to the selected vector layers, in 
units of pixels. If your vectors are overlaid on a display window, the displayed image 
is used to create the output buffer zone image. If the vectors are displayed in a vector 
window, you must select an associated file to use for the calculation. You designate a 
maximum distance value and the result is that any pixels with a distance larger than 
that value are set to the maximum distance value +1.

1. From the Vector window pull-down menu, select File → Calculate Buffer 
Zone.

• If your vector layers are not overlaid on a displayed image, the Select 
Associated Data File dialog appears. Select the input image file and click 
OK.

• If you have more than one vector layer open, the Buffer Zone Input Layers 
dialog appears. Click on the names of the layers to be included in the 
buffer zone image and click OK. The Buffer Zone Image Parameters 
dialog appears.

Note
If you select more than one layer, the distance will be calculated from the 
pixel to the nearest selected layer.

2. Click the Maximum Distance arrow increment buttons to set the maximum 
distance to measure, or type the value (in pixels) into the corresponding text 
box.

Note
Any pixels with a distance larger than this value will be set to the maximum 
distance value +1. 

3. From the Distance Kernel button menu, select Floating Point or Integer 
output.
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4. Select output to File or Memory.

• If you select File, enter an output file name.

5. Click OK.

Saving Vector Displays

• To output the display shown in the Vector window, select File → Save Plot 
As → PostScript or Image File. 

• To print the vector display, select File → Print.

For detailed instructions, see “Display Output Options” in Chapter 4.

Vector Attributes

Vector layers may have attributes associated with them. ENVI reads shapefile and 
MapInfo Interchange file attributes. The attributes are stored in a dBASE II table 
(.dbf) for shapefiles and in a .mid file for MapInfo. 

Use the ENVI attribute table to view, edit, sort, and save vector attribute data. Use the 
Vector Attribute functions to create new vector layers based on attribute values, to 
add new attributes to vectors, to plot point attribute names in vector windows, and to 
associate point symbol sizes with attribute values (see “Changing Vector Layer 
Display Properties” on page 946).

Viewing Vector Attributes 

1. Select the vector layer by choosing Select Active Layer and clicking on the 
layer name in the Vector window shortcut menu.

2. Ensure that Mode → Cursor Query is selected.

3. Select Options → Vector Information. The Vector Information dialog 
appears.

4. Click with the left mouse button on the desired vectors in the Vector Window. 
The associated attributes are displayed in the Vector Information dialog.
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Creating New Vector Layers from Attributes

To make a new vector layer using a simple mathematical and logical attribute query 
expression:

1. Select the vector layer by choosing Select Active Layer and clicking on the 
layer name in the Vector window shortcut menu.

2. Select Edit → Query Attributes. The Layer Attribute Query dialog appears.

3. Click on the Start button. The Query Condition dialog appears and allows you 
to enter a query expression.

4. Select the attribute item to query by using the attributes name pull-down menu.

5. Select one of the following mathematical expressions from the pull-down 
menu:

6. Enter a query value in the text box. The value can be a string (case sensitive) or 
numeric value depending on the attribute type.

7. To make a more complicated query expression using logical operators, choose 
from the following options:

• Click AND and follow steps 4-7 to do a query that must satisfy both 
entered mathematical expressions.

• Click OR and follow steps 4-7 to do a query that must satisfy one of the 
entered mathematical expressions.

• Click Clear to clear the entire query expression.

• Click Delete to delete individual lines of the query expression.

8. Enter a query layer name in the appropriate text box.

9. Select output to File or Memory.

10. Click OK. 

> greater than <= less than or equal 

>= greater than or equal == equals 

< less than != not equals 
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Adding Attributes to Vectors

To add attributes to a vector layer that does not have any: 

1. Select the vector layer by choosing Select Active Layer and clicking on the 
layer name in the Vector window shortcut menu.

2. Select Edit → Add Attributes in the Vector window. The Attribute 
Initialization dialog appears with one field defined.

3. Select from the following options to edit, add, or delete field parameters.

• Change the field name using the Name text box.

• Select the field type from the Type pull-down menu.

Available types include character, numeric, logical, and date. The logical 
field contains a single character, either a Y or N, T or F, or ?.

• Enter the width of the field in the table in the Width box.

• Enter the number of digits to the right of the decimal in the Decimal 
Count box for a numeric field.

• Click on Add Field to add a new field to the Defined Attribute Fields list.

• Select a field name from the Defined Attribute Fields list and click Delete 
Field to remove the field from the list.

4. Click OK.

An attribute table is started (see “The Attribute Table” on page 962).
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The Attribute Table

Use the ENVI attribute table to view, edit, sort, and save vector attribute data. The 
attributes table shows the attribute names at the top of each column and the attribute 
record number at the left of each row. The attribute table has two pull-down menus, 
File and Options.

Highlighting Attribute Data

To select attribute data in the Attribute table:

1. Select the vector layer by choosing Select Active Layer and clicking on the 
layer name in the Vector window shortcut menu.

2. Select Edit → View/Edit Attributes. The ENVI Attributes table appears.

3. Click with the left mouse button on the desired vectors in the Vector window.

The associated attributes are highlighted in the ENVI Attribute table.

Highlighting Vectors

• To highlight the vector that corresponds to a selected attribute record, click on 
the attribute record number. 

The Vector window centers on the corresponding vector and the vector is 
highlighted in the Current Highlight color.

• To highlight vectors that correspond to multiple attribute records, use the 
SHIFT or CTRL key to select multiple attribute record numbers.

The selected vectors will be highlighted in the Current Highlight color.

Highlighting Based on Layer Query

To highlight both items in the Attributes table and the corresponding vectors based on 
a query for the current vector layer:

1. Select Options → Query Layer.

2. Click Start.

3. Follow the directions for the query expression given in “Creating New Vector 
Layers from Attributes” on page 960.
Working with the Vector Window ENVI User’s Guide



Chapter 11: Vector Tools 963
Items in the Attributes table that satisfy the query are highlighted and the 
corresponding vectors are highlighted.

Note
The results from the vector query can be saved to a new vector layer, see “Saving 
Selected Records to a new Vector Layer” on page 965.

Editing Single Attribute Values

To edit a single attribute value, double click in the desired attribute field and enter the 
new value.

The following figure shows the vector attribute table.

Adding New Attribute Columns

To add new columns to the Attribute Table:

1. In the Attribute Table, select Options → Add Record Columns. The Attribute 
Initialization dialog appears.

2. Enter the new attribute information.

Figure 11-6: Vector Attribute Table
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Deleting Attribute Columns

To delete an attribute column from the table: 

1. Click on the column name to highlight the column.

2. Select Options → Delete Record Column.

Sorting Table Information

Sort the attribute table using the values or strings in a column (in a forward, reverse, 
or original order). 

1. Click on the column name to sort.

2. Select Options → Sort by selected column forward, Sort by selected 
column reverse, or Sort by original order.

Replacing Attributes with a Single Value

To replace cells in the same column with a single value: 

1. Select one of the following options:

• To replace the entire column, click on the column name.

• To replace selected cells, click and drag with the cursor to highlight the 
cells.

2. Select Options → Replace selected cells with value.

3. When the Replace Table Cells with Value dialog appears, enter the desired 
string or numeric value and click OK.

Replacing Attributes with ASCII Data

To replace cells in the same column with values from an ASCII file: 

1. Select one of the following options:

• To replace the entire column, click on the column name.

• To replace selected cells, click and drag with the cursor to highlight the 
cells.

2. Select Options → Replace selected cells with ASCII values.

3. Select the desired input ASCII filename.
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4. When the Input ASCII File dialog appears, select the desired column number 
(strings can only have one column), and starting and ending row numbers.

5. Click OK to enter the data into the attribute table.

Saving Selected Records to a new Vector Layer

To save the selected records or query results to a new vector layer:

1. Select File → Save Selected Records to new Layer.

2. Enter a layer name and an output filename and click OK.

Saving Selected Records to an ASCII file

To save the selected records or query results to an ASCII file:

1. Select File → Save Selected Records to ASCII.

2. Enter an output filename and click OK.

Saving Changes

To save changes made to the attribute table, select File → Save Changes. 

Warning
This writes over the existing attribute file.

Saving Attribute Tables to ASCII Files

1. In the Attribute Table, select File → Save Records to ASCII.

2. When the Output Records to ASCII dialog appears, enter an output filename.

Closing Attribute Tables

To close the attribute table, select File → Cancel. 

If any changes are unsaved, ENVI asks if you want to save them.

Closing Vector Displays

From a Vector Window — To close a Vector display that is not overlaid on an image, 
do the following:

• Select File → Cancel from the Vector window menu bar.
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Creating Vector Layers

Use Create New Vector Layer to create a new vector window using the projection 
and boundaries from a variety of sources. A new empty vector layer can be created so 
you can enter your own vector layers of polygons, lines, or points and attributes. This 
vector layer can have the same projection and geographic boundaries (size) as 
existing vector layers, georeferenced raster images, or can be based on user-defined 
input. An empty vector layer can also be created from non-georeferenced raster 
images for drawing vectors over those images. After a new empty vector layer has 
been created, vector records can be added to the file using the Mode menu in the 
Vector Parameters dialog (see “Controlling Cursor Modes” on page 335).

Tip
You can also create vector layers by selecting Options → Create Vector New 
Layer in the Available Vectors List (see “Creating New Layers” on page 217).

Creating Layers from Existing Vector Layers

1. Select Vector → Create New Layer → Using Existing Vector Layer.

The New Vector Layer Parameters dialog appears.

• If you have more than one layer in the Available Vectors List, the dialog 
displays a list of sources. Select the source layer from the list.

2. Enter an output layer name and select output to File or Memory.

3. Click OK.

The layer name appears in the Available Vector Layers list.

Creating Layers from Raster Image Files

1. Select Vector → Create New Layer → Using Raster Image File.

2. When the file selection dialog appears, select the input image file and click 
OK.

3. When the New Vector Layer Parameters dialog appears, enter an output layer 
name and select output to File or Memory.

4. Click OK.

The layer name appears in the Available Vector Layers list.
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Creating Layers from User-Defined Parameters

1. Select Vector → Create New Layer → Using User Defined Parameters.

The New Vector Layer Parameters dialog appears.

2. Select a projection type and enter a Zone number if needed (see “Selecting 
Map Projection Types” on page 922).

3. Enter the bounding box coordinates in the selected projection units in the 
X/Ymin and X/Ymax text boxes.

4. Enter an output layer name and select output to File or Memory.

5. Click OK.

The layer name appears in the Available Vector Layers list.
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Creating World Boundary Layers

Use Create World Boundaries to create layers of various world boundaries 
(including political boundaries, coastlines, rivers, and USA states) from either the 
high resolution or low resolution database that is installed with ENVI.

1. Select Vector → Create World Boundaries.

Tip
You can also create world boundaries from within the Available Vectors List 
by selecting Options → Create World Boundaries.

The Create Boundaries dialog appears.

2. Select the layers by clicking the check box next to their names.

• To select a range of layers, enter the starting and ending numbers and click 
Add Range.

• To select all the layers, click Select All.

• To clear all the layers, click Clear.

3. Select one of the following options:

• To create world boundary layers for a specific area, enter the latitude and 
longitude coordinates in the corresponding text boxes.

• To create world boundary layers for the entire world, do not enter latitude 
and longitude coordinates.

4. Select output to File or Memory.

One output .evf file is created for every selected layer and named with a 
layer abbreviation appended to the root filename. The high resolution layers 
are named with a _hp, _hc, or _hr for the political boundaries, the 
coastlines, or the rivers, respectively. The low resolution layers are named 
similarly but with an _lp, etc. The USA States layer have _usa appended to 
the root name.

Warning
Building vector layers from the high resolution database creates very large 
output files (~20 MB each).

5. Click OK to build the vector layers.

The selected layers appear in the Available Vectors List.
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Converting Raster Images

Use Raster to Vector to create a vector layer for a specified DN contour value in a 
raster image.

1. Select Vector → Raster to Vector.

2. When the Raster to Vector Input Band dialog appears, select the desired input 
file and perform any subsetting.

3. When the Raster to Vector Parameters dialog appears, enter the desired DN 
value to use as a contour value in the Contour Value text box.

4. Enter an ENVI vector file layer name in the appropriate text box.

5. Select output to File or Memory.

6. Click OK.

ENVI makes a polygon vector layer using the entered contour value, and a vector 
attribute file (.dbf) containing the class ID, polygon length, and area information for 
the resulting ENVI vector file. The vector layer is listed in the Available Vectors List.
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Converting Classification Images

Use Classification to Vector to convert classification results to ENVI polygon vector 
layers (.evf files). The classification images will have a vector layer for each 
selected class. 

1. Select Vector → Classification to Vector.

2. When the Raster to Vector Input Band dialog appears, select the desired input 
classification file and perform any subsetting.

3. When the Raster to Vector Parameters dialog appears, select the desired class 
names to convert to vector polygons by clicking on the class names.

4. Select whether to output all selected classes as a single vector layer or as 
separate layers for each class by clicking the Output arrow toggle button.

5. Select output to File or Memory.

6. Click OK.

If a separate layer for each class is output, each selected class is saved to a separate 
vector file with an _1, _2, and so on, appended to the root name.
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Rasterizing Point Data

Use Rasterize Point Data to interpolate irregularly gridded data into a raster image. 
ENVI’s gridding function uses Delaunay triangulation of a planar set of points. After 
the irregularly gridded data points have been triangulated, they are interpolated to a 
regular grid. You can use linear or smooth quintic polynomial interpolation. You can 
also select extrapolation for grid points outside of the triangulation area. The grid 
points are read from an ASCII file and different input and output projections are 
supported.

1. Select Vector → Rasterize Point Data or Topographic → Rasterize Point 
Data.

2. When the Enter ASCII Grid Points Filename dialog appears, select the desired 
input ASCII file.

The Input Irregular Grid Points dialog appears.

3. Use the arrow increment buttons to enter the column numbers that contain the 
X and Y positions and Z data values.

4. Select the input projection type from the list and enter a Zone number if 
needed.

• To enter a custom projection type, click the New button and enter the 
customized map projection information (see “Building Customized Map 
Projections” on page 923).

5. Click OK.

The Gridding Output Parameters dialog appears.

6. Select the output image projection type and enter a Zone number if needed.

• To enter a custom projection type, click the New button and enter the 
customized map projection information (see “Building Customized Map 
Projections” on page 923).

7. Select the type of interpolation using the arrow toggle button.

8. Select whether or not to extrapolate edges by using the Yes/No arrow toggle 
button.

Note
If extrapolation is selected, quintic extrapolation is used.
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9. Enter X and Y output pixel sizes in the units that correspond to your projection 
type and select the output data type from the button menu.

10. Click OK.

A second Gridding Output Parameters dialog appears.

Setting Output Parameters

1. In the second Gridding Output Parameters dialog, select from the following 
options:

• To change the map coordinate or latitude/longitude information for the 
upper left coordinate of the pixel, or to change the pixel or image size, 
click the Change Output Parameters button and enter the desired values 
in the Output Image Parameter dialog.

• To change the projection for the upper left coordinate of the pixel, click the 
Change Projection button in the Output Image Parameters dialog and 
enter the new projection in the Projection Selection dialog.

Note
If your output projection is Geographic, the output pixel and image sizes 
need to be defined in degree units in the Output Image Parameter dialog.

2. In the Gridding Output Parameters dialog, select output to File or Memory.

3. Click OK to start the gridding.

A status window displays the progress of the operation and the resulting image 
filename is listed in the Available Bands List.
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Converting ROIs to DXF Files

To convert ENVI Region of Interest files to DXF format:

1. Select Vector → Convert ROI to DXF.

2. When the Enter Input ROI Filename dialog appears, select an input ROI file.

3. Click OK.

The Convert Region of Interest Files to DXF Files dialog appears. The 
filename appears in the Selected Input Files list.

4. Select from the following options.

• To add additional files to the list of selected files, click Input Additional 
File and select the desired ROI file.

• To remove a file from the list, click on the file name and click Delete.

• If output to Map Coordinates is desired, select Map Coordinates using 
the arrow toggle button.

• If output to Pixel Coordinates is desired, select Pixel Coordinates.

5. Enter an output filename or use the Choose button to select an output filename.

6. Click OK to convert the ROI files to DXF format.

• If you selected output to map coordinates, the Select File Containing Map 
Coordinates dialog appears. Select a file that contains the desired output 
map coordinates and click OK.
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Converting Annotation Files to DXF Files

To convert ENVI Annotation files (.ann) to DXF format:

1. Select Vector → Convert ANN to DXF.

Only rectangles, ellipses, polygons, and polylines will be converted. All other 
annotation items are ignored.

2. When the Enter Input ANN Filename dialog appears, select a filename.

3. Click OK.

The Convert Annotation Files to DXF Files dialog appears. The filename 
appears in the Selected Input Files list.

4. Select from the following options.

• To add additional annotation files to the list of selected files, click on 
Input Additional File and select the desired annotation file.

• To remove a file from the list, click on the file name and click Delete.

• If output to Map Coordinates is desired, select Map Coordinates using 
the arrow toggle button.

• If output to Pixel Coordinates is desired, select Pixel Coordinates.

5. Enter an output filename or use the Choose button to select an output filename.

6. Click OK to convert the annotation files to DXF format.

• If you selected output to map coordinates, the Select File Containing Map 
Coordinates dialog appears. Select a file that contains the desired output 
map coordinates and click OK.
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Converting EVFs to DXF Files

To convert ENVI Vector files to DXF format:

1. Select Vector → Convert EVF to DXF. 

2. When the Enter Input EVF Filename dialog appears, select a filename.

3. Click OK.

The Convert ENVI Vector Files to DXF Files dialog appears. The filename 
appears in the Selected Input Files list.

4. Select from the following options.

• To add additional files to the list of selected files, click Input Additional 
File and select the desired EVF file.

• To remove a file from the list, click on the file name and click Delete.

5. Enter an output filename or use the Choose button to select an output filename.

6. Click OK to convert the EVF files to DXF format.
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The Topographic Menu

Use Topographic to open, analyze, and output results from your topographic digital 
elevation data. Use Topographic Modeling to calculate a shaded relief image, slope, 
aspect, and various curvature values from your topographic data. Use Topographic 
Features to generate a classification image showing channels, ridges, peaks, pits, 
passes, and planes. Use Create Hill Shade Image to create a Hill Shade image that 
combines a color image with a shaded relief image. Use other topographic tools to 
replace bad values in your digital elevation data or to rasterize point data, and use the 
3D SurfaceView to fly-through your topographic data with vectors or a color image 
draped over it.

Figure 12-1: Topographic Menu
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Opening Topographic Files

Use Open Topographic File to read United States Geological Survey Digital 
Elevation Model (USGS DEM) data, Digital Terrain Elevation Data (DTED), Spatial 
Data Transfer Standard (SDTS DEM), and Shuttle Radar Topography Mission 
(SRTM DEM) formats directly into ENVI. Elevations are retained at full precision in 
the converted files. To georeference DEMs, use ENVI’s registration function to warp 
the DEM to a specified projection using the corner coordinates and given pixel size 
(see “Image-to-Map Ground Control Points” on page 864).

For detailed instructions, see “Opening Digital Elevation Files” on page 87.

Using Topographic Modeling

Use Topographic Modeling on your USGS DEM data and other digital elevation 
data to generate lambertian (shaded relief) surfaces, and to extract parametric 
information, including slope, aspect, and various convexities and curvatures. All of 
the parameters are calculated by fitting a quadratic surface to the digital elevation 
data for the entered kernel size and taking the appropriate derivatives. You can change 
the kernel size so that multi-scale topographic information can be extracted.

The slope is measured in degrees with the convention of 0 degrees for a horizontal 
plane. ENVI measures the aspect angle with the convention of 0 degrees to the north 
(up) and angles increasing clockwise. For the convexity and curvature measures, 
convex surfaces are given positive values and concave surfaces are given negative 
values. The profile convexity (intersecting with the plane of the z axis and aspect 
direction) measures the rate of change of the slope along the profile. The plan 
convexity (intersecting with the XY plane) measures the rate of change of the aspect 
along the plan. These two surface curvature measures are in orthogonal directions 
with the profile convexity in the direction of maximum gravity effects and the plan 
convexity in the direction of minimum gravity effects. The longitudinal curvature 
(intersecting with the plane of the slope normal and aspect direction) and cross-
sectional curvature (intersecting with the plane of the slope normal and perpendicular 
aspect direction) are also measures of the surface curvature orthogonally in the down 
slope and across slope directions, respectfully. The minimum and maximum overall 
surface curvatures can also be calculated. Finally, a root mean square (RMS) error 
image is also generated, which indicates how well the quadratic surface fits the actual 
digital elevation data.
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For more information, see the following reference on the World Wide Web at 
www.geog.le.ac.uk/jwo/research.

Wood, Joseph The Geomorphological Characterization of Digital Elevation Models, 
Ph. D. Thesis, University of Leicester, Department of Geography, Leicester, UK, 
1996.

Note
The Topographic Modeling Tools operate on image-format data, not on raw USGS-
format DEM data. If your topographic data is in profile format, use ENVI’s input 
file routines to convert the data to image format (see “Opening USGS DEM Files” 
on page 87 or “Reading Known Tape Formats” on page 142).

1. Select Topographic → Topographic Modeling.

2. When the Topo Model Input DEM dialog appears (see Figure 12-2), select a 
DEM image to process from the file list and perform any spatial subsetting.

• To open a new DEM image, select File → Open New File.

3. Click OK.

The Topo Model Parameters dialog appears.

4. Enter the desired kernel size. 

Tip
Use various kernel sizes to extract multi-scale topographic information. Larger 
kernel sizes run slower.
Using Topographic Modeling ENVI User’s Guide
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5. Select the topographic measures to compute by clicking on them in the Select 
Topographic Measures to Compute list. 

Each topographic measure is output as a band.

• If you select Shaded Relief, enter or compute the sun elevation and 
azimuth:

A. In the Topo Model Parameters dialog, click Compute Sun Elevation and 
Azimuth. — The Compute Sun Elevation and Azimuth dialog appears 
(see Figure 12-2).

B. Select the month and day from the button menus, and enter the year and 
time of day (GMT) by clicking the arrow increment buttons or by typing in 
the corresponding text boxes.

Figure 12-2: Topo Model Parameters Dialog (left) and Compute Sun Elevation 
and Azimuth Dialog (right)
ENVI User’s Guide Using Topographic Modeling
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C. Enter the latitude and longitude coordinates in the Lat and Lon text boxes.

D. Click OK to perform the calculations.

The calculated elevation and azimuth are automatically entered into the 
Topo Model Parameters dialog.

6. If the pixel size is not set in the header, enter the X and Y pixel sizes in meters. 

7. Select output to File or Memory.

8. Click OK to start the calculations. 

When the processing is complete, the selected images appear in the Available Bands 
List. Examples of Topographic Modeling output are shown in Figure 12-3.

Figure 12-3: Example of Topo Modeling for a Simulated Pyramid DEM with an 
Aspect of 135 Degrees and Elevation of 45 Degrees
Using Topographic Modeling ENVI User’s Guide
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Extracting Topographic Features

Use Topographic Features to produce a classification output image that classifies 
each pixel into one of the following terrain types or morphometric features: peak, 
ridge, pass, plane, channel, or pit.

The morphometric features are determined by fitting a quadratic surface to the digital 
elevation data for the entered kernel size and calculating the slope and curvatures of 
the surface (see “Using Topographic Modeling” on page 979). You can change the 
kernel size so that multi-scale topographic information can be extracted. 

The slope and curvature of the surface determines the morphometric feature. For 
example, a sloping surface that is concave in the cross-sectional direction is a 
channel. A sloping surface that is convex in the cross-sectional direction is a ridge. 
Peaks have a convex cross-section and convex longitudinal curvature while pits have 
concave curvatures. Passes have one convex curvature and one concave curvature. 

Figure 12-4: Example of Topographic Features Image Result
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For more information, see the following reference on the World Wide Web at 
www.geog.le.ac.uk/jwo/research.

Wood, Joseph The Geomorphological Characterization of Digital Elevation Models, 
Ph. D. Thesis, University of Leicester, Department of Geography, Leicester, UK, 
1996.

Note
If your DEM is noisy, striped, or stepped, you should smooth it before using this 
function. See Topographic Modeling section of the ENVI Topographic Tools 
tutorial for examples

1. Select Topographic → Topographic Features.

2. When the file selection dialog appears, select the input DEM file and any 
subsetting.

The Topographic Features Parameters dialog appears.

3. Enter the slope tolerance and curvature tolerance values. 

The slope (in degrees) and curvature tolerance values are used to determine 
when a pixel is classified as a peak, pit, or pass versus a channel or ridge. For a 
pixel to be classified as a peak, pit, or pass, the slope value must be less than 
the slope tolerance and the cross-sectional curvature must be greater than the 
curvature tolerance. Increasing the slope tolerance and decreasing the 
curvature tolerance increases the number of peaks, pits, and passes in the 
classified output.

4. Enter the desired kernel size in the corresponding text box or use the arrow 
increment buttons to set the value.

Tip
Use various kernel sizes to extract multi-scale topographic information. Larger 
kernel sizes run slower.

• If a pixel size was not found in the ENVI header for the DEM file, enter 
the X and Y pixel size (in meters) in the corresponding text boxes.

5. In the Select Features to Classify list, click on the features to be included in 
the output classification image.

If a feature type is not selected, those pixels will be unclassified.

• To select all of the features, click Select All Items.

• To deselect all of the selected features, click Clear All Items.
Extracting Topographic Features ENVI User’s Guide
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6. Select output to File or Memory.

7. Click OK.

A status window displays the progress of the operation. The output classification 
image file can be displayed from the Available Bands List: green represents plane, 
blue represents channel, orange represents ridge, red represents pass, yellow 
represents peak, and magenta represents pit. An example of a topographic features 
result is shown in Figure 12-4.

Tip
You can change the class colors by selecting Tools → Color Mapping → Class 
Color Mapping (see “Mapping Class Colors” on page 407).
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986 Chapter 12: Topographic Tools
Creating Hill Shade Images

Use Create Hill Shade Image to create a color shaded relief image from a digital 
elevation model using a color table or a displayed color image. 

Creating Hill Shade Images Using Color Images

Creating a Hill Shade image from a color image provides data fusion by adding 
topographic information to your image. The color image is transformed into hue, 
saturation, value space. The value band is replaced with a shaded relief image that 
was calculated from the DEM using the input sun angles, and the color image is 
transformed back to RGB space.

Note
The color image must be co-registered with the DEM file, displayed, and contrast 
stretched before you can create the Hill Shade image.

1. Select Topographic → Create Hill Shade Image.

2. When the Hill Shade Blend Input dialog appears, click on the display number 
of the color image.

3. When the file selection dialog appears, select the input DEM file and perform 
any subsetting.

4. Click OK.

The Hill Shade Image Parameters dialog appears.

5. Specify the sun elevation and azimuth for the shaded relief image by entering 
the values into the Sun Elevation Angle and Sun Azimuth Angle text boxes. 
(To compute sun elevation values, see “Computing Sun Elevation Values” on 
page 988.)

6. Select File or Memory output.

7. Click OK.

The resulting Hill Shade image is available for display from the Available Bands List.
Creating Hill Shade Images ENVI User’s Guide
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Creating Hill Shade Images from Color Tables

Use this procedure to create a Hill Shade image using a color table applied to the 
digital elevation data. The selected color table and stretch type are applied to the 
DEM. The DEM is transformed into hue-saturation-value space, the value band is 
replaced with a shaded relief image that was calculated using the input sun angles, 
and the HSV bands are transferred back to RGB space.

1. Select Topographic → Create Hill Shade Image.

• If the Hill Shade Blend Input dialog appears, click Color Table Lookup.

2. When the file selection dialog appears, select the input DEM file and perform 
any subsetting.

Figure 12-5: Example of a Hill Shade Image
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988 Chapter 12: Topographic Tools
3. Specify the sun elevation and azimuth for the shaded relief image by entering 
the values into the Sun Elevation Angle and Sun Azimuth Angle text boxes.

(To compute sun elevation values, see “Computing Sun Elevation Values” on 
page 988.)

4. Click on the name of a color table to select it from the list.

5. From the Stretch button menu, select a stretch type.

• If you select % Linear, enter the percentage to clip.

• If you select Linear Range, enter the minimum and maximum values.

• If you select Gaussian, enter the number of standard deviations for the 
data distribution. 

6. Select File or Memory output.

7. Click OK.

The Hill Shade image is available for display from the Available Bands List.

Computing Sun Elevation Values

1. In the Hill Shade Image Parameters dialog, click Compute Elevation and 
Azimuth.

The Compute Sun Angle dialog appears.

2. Select the month from the Month button menu, and enter the day, year, and 
time (GMT) in the appropriate text boxes. 

3. Enter the desired latitude and longitude coordinates in the appropriate text 
boxes.

4. Click OK to perform the calculations.

The calculated elevation and azimuth are automatically entered into the Hill Shade 
Image Parameters dialog.
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Replacing Bad Values

Use Replace Bad Values to fill bad values in digital elevation models (DEMs) with 
values calculated using a surface fitting technique. Bad pixels often occur in radar 
shadows of DEMs generated from interferometric radar. The locations of the bad 
pixels are identified in the DEM image by entering the DN value of the bad pixels or 
a range of bad values. You can also make a mask of the bad pixels and use it to locate 
the pixels that need to be replaced (see “Masking” on page 527). The surface fitting 
uses Delaunay triangulation to fill the bad pixels with triangles calculated from the 
surrounding good elevation values. 

Note
If there are large holes in your data set, you may see the triangles used to fill them.

1. Select Topographic → Replace Bad Values or Radar → TOPSAR Tools → 
DEM Replace Bad Values.

2. When the DEM Input File dialog appears, select the DEM file and perform any 
subsetting or masking.

The Replace Bad Data Parameters dialog appears.

3. Enter a bad pixel value or a range of bad pixel values in the appropriate text 
boxes.

Note
No values are needed if you selected a mask band that contains the locations of the 
bad pixels.

4. Select File or Memory output.

5. Click OK.

The output appears in the Available Bands List.
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Rasterizing Point Data

ENVI’s gridding function uses Delaunay triangulation of a planar set of points for the 
interpolation of irregularly-gridded data. After the irregularly gridded data points 
have been triangulated, they are interpolated to a regular grid. Linear or smooth 
quintic polynomial interpolation can be selected. Extrapolation for grid points outside 
of the triangulation area is also an option. The grid points are read from an ASCII file 
and input and output projections are supported.

For detailed instructions, see “Rasterizing Point Data” on page 971.
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Converting Vector Topo Maps into Raster 
DEMs

Topographic data is frequently available in both vector and raster formats. While each 
format has its advantages, ENVI offers several tools for extracting additional 
information from raster digital elevation model (DEM) data. For example, raster 
DEMs may be used to derive complementary topographic data sets including slope, 
aspect, and shaded relief (see “Using Topographic Modeling” on page 979), or used 
to create a topographic classification image (see “Extracting Topographic Features” 
on page 983). A raster DEM is also required for draping imagery onto topographic 
elevation data using the 3D Surface View (see “Using 3D SurfaceView” on 
page 993).

The Convert Contours to DEM routine uses the vector records’ nodes to triangulate 
a raster grid for the DEM. It is recommended that the output pixel size be set no 
smaller than the approximate sampling distance of the vector nodes. If the output 
pixel size differs significantly from the node sampling distance, the vector contour 
lines are automatically made more dense in an attempt to reduce interpolation 
artifacts. All vector records contained in the file are used unless their corresponding 
elevation attribute value falls outside the valid elevation range specified by the user.

Input Requirements

• Input from an EVF File. The vector data must be an ENVI Vector Format 
(EVF) file. If the vector topography is in an external format file (such as an 
ArcView Shapefile), converting it into an EVF is simple—just read the data 
into ENVI and the import routine will offer a conversion into an EVF (see 
“Opening Vector Files” on page 941 for more details). 

• Elevation Attributes Required. The EVF file must contain an attribute that 
defines the elevation of each vector contour line.

Using the Convert Contours to DEM Routine

1. From the main ENVI menu select Topographic → Convert Contours to 
DEM, or Vector → Convert Contours to DEM.

2. In the file selection dialog, select an EVF file containing topographic contour 
lines and an elevation attribute.

The Convert Elevation Contours to Raster DEM dialog appears.
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3. From the pull-down menu labeled Elevation Attribute Column, select the 
attribute that contains the elevation of the vector contours.

4. If desired, enter a valid elevation range in the same units as the elevation 
attributes. Vectors whose elevation falls outside of the valid range are omitted 
when constructing the DEM. 

5. Enter an output pixel size and data type.

Note
The pixel size can be changed before processing begins (see Step 9 below). It 
is recommended that the output pixel size be set no smaller than the 
approximate sampling distance between the nodes defining the vector 
contours. 

6. Set the gridding parameters by selecting an interpolation method and choosing 
an extrapolation option.

7. To spatially subset the output DEM, click on either the Map or File button at 
the bottom of the dialog. The Map button allows you to restrict the DEM 
output to an area defined in map coordinates. The File button allows you to 
restrict the output DEM to the same area as an existing georeferenced file.

8. Choose a map projection for the output DEM.

Note
This does not have to be the same projection as the input vector data.

9. Click OK to continue. 

The DEM Output Parameters dialog appears.

10. Examine the information displayed under the Gridded DEM Output Image 
title to make sure it is accurate. If you need to change any of the output 
parameters, including the pixel size, click the Change Output Parameters 
button.

11. Choose output to File or Memory for the DEM result.

12. Click OK to start the processing.
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Using 3D SurfaceView

Use ENVI’s 3D SurfaceViewTM window to visualize elevation or other surface data 
in three dimensions. The surface data can be displayed as a wire-frame, ruled grid, or 
points. It can also be draped with a grayscale or color image, and overlaid with ROIs 
and vectors. You can rotate, translate, and zoom in and out of the surface in realtime 
using the mouse cursor or the 3D SurfaceView Controls dialog. The cursor is also 
linked to your draped image allowing cursor locations, values, and profiles to be 
displayed from the three-dimensional view. The 3D SurfaceView window can also be 
used to define a flight path (interactively or with a drawn annotation). The flight path 
can be animated to produce three-dimensional fly-throughs of your data. The vertical 
and horizontal view angles can be controlled and you can fly through your data at a 
constant height above the surface or at a constant altitude. You can also use 
perspective controls to place the visual perspective in the 3D SurfaceView and rotate 
the surface around that perspective. 

Displaying 3D Files

Note
If you are running ENVI on a Windows system, you must be in 16-bit or 24-bit 
color display mode.

1. Display the grayscale or color image you want to drape over your DEM (or 
other three-dimensional dataset).

The entire image is used as the overlay image on the DEM unless both your 
image and DEM files are georeferenced. If both files are georeferenced, then 
only the part of the image that overlaps with your DEM is used. If the DEM is 
subset, then the georeferenced image is also subset to match. The spatial 
resolutions of the two files do not need to be the same. If the image and DEM 
are both georeferenced, they do not need to be in the same projection. ENVI 
will reproject the DEM on the fly to match the image projection.

2. Select one of the following options:

• From the ENVI main menu bar, select Topographic → 3D SurfaceView.

• From the Display menu bar, select Tools → 3D SurfaceView.

3. If more than one display window is open, select the display window that 
contains the desired image.
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4. Select the associated digital elevation model (DEM) input file (or other 3D 
dataset) and perform any spatial subsetting.

Note
If a DEM is already associated with the input image file in the image header, 
the associated DEM is used by default (you will not be prompted to select a 
DEM). For more information on associating a DEM with an image, see 
“Associating a DEM to a File” in Chapter 2.

The 3D SurfaceView Input Parameters dialog appears.

5. Select the desired DEM Resolution (number of pixels) check box to use for 
the 3D plot.

Warning
Using higher DEM resolutions will significantly slow the display and should only 
be used on powerful platforms.

More than one resolution can be selected. Typically you will want to use the 
lowest resolution (64) while you are determining the best flight path. Then a 
higher resolution can be used to display your final fly-through sequence.

Figure 12-6: 3D SurfaceView Input Parameters Dialog
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6. Select a Resampling: method by clicking either the Nearest Neighbor or 
Aggregate button.

Nearest neighbor resampling uses the nearest DEM value when resampling. 
Pixel aggregate averages all the DEM values that contribute to the output pixel. 
For example, if your DEM resolution is 30 meters and your image resolution is 
60 meters, the nearest neighbor resampling uses every other pixel and every 
other line to create the DEM in the 3D window, while the pixel aggregate 
option will average four pixels to create the output DEM.

7. Enter DEM min plot value and DEM max plot value if desired.

DEM values lower than the minimum value and higher than the maximum 
value are not plotted in the 3D views.

8. Enter the Vertical Exaggeration, if any. Default is 5.0.

The value entered produces a true scale vertical exaggeration applied to the Z 
axis where higher values correspond to greater exaggeration.

9. In the Image Resolution section, select either Full or Other. 

If you select Other, choose a resampling method by selecting the Nearest 
Neighbor or Aggregate button.

Note
To set a higher image resolution, use the Image Resolution section of the 3D 
SurfaceView Input Parameters dialog. Full resolution is the highest possible 
resolution, but if you have a large image, full resolution may cause you to run 
out of memory.

10. Set the High Resolution Texture Mapping parameter to Off or On by 
clicking the arrow button. Default is On.

When On is selected, and a higher resolution image is available, the high 
resolution image is used when you zoom into your the 3D SurfaceView. The 
input image must be at least 1024 x 1024 pixels in order for the High 
Resolution Texture Mapping parameter to have a noticeable effect in the 3D 
SurfaceView. 

Note
Using the High Resolution Texture Mapping option may slow the zoom 
and fly-through features of the 3D SurfaceView.

11. If desired, click on the Spatial Subset button and select a spatial subset of the 
image. The default is Full Scene. 
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The spatial dimensions of the DEM and image do not need to be same. The full 
dimensions (or selected subsets) of both data sets will be displayed.

12. When you are satisfied with your selections, click OK.

The 3D SurfaceView plot window appears (see Figure 12-7). 

Cursor Functions in the 3D SurfaceView Window

Use the mouse cursor and buttons to interactively rotate, translate, and scale the 
surface. Select from the following options:

• To rotate the surface around the Z axis, click and drag with the left mouse 
button in a horizontal direction. 

• To rotate the surface around the Y axis, click and drag with the left mouse 
button in a vertical direction.

• To translate (move the image) in any direction, click and drag with the middle 
mouse button in the desired direction.

Figure 12-7: Texture Type 3D Plot in a 3D SurfaceView Plot Window
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• To increase the zoom, click and drag to the right with the right mouse button.

• To decrease the zoom, click and drag to the left with the right mouse button.

• To reset the surface plot to its original position, select Options → Reset View 
in the 3D SurfaceView window.

The mouse button functions are listed in the following table.

You can also control the rotation, translation, and zoom by selecting Options → 
Surface Controls from the menu in the 3D SurfaceView window.

Displaying Cursor Location and Value

If the Cursor Location/Value dialog is open (by either double-clicking in the Display 
window, selecting Tools → Cursor Location/Value, or opening it from the ENVI 
main menu), the approximate X, Y, and Z (elevation) values are read from the 3D 
SurfaceView. If your draped image is georeferenced, the map locations are also 
reported.

• To move the zoom window to a specific pixel in the Display window 
containing the draped image, double-click with the left mouse button on the 
pixel in the 3D plot.

Note
This only works if both the DEM and the image are in the same projection.

Mouse Button Action

Left Click and drag to rotate X/Y plane

Or: 

Double-click to go to pixel in display 
window

Middle Click and drag to translate image

Right Click and drag to right to zoom in

Click and drag to left to zoom out

Table 12-1: Cursor Functions in the 3D SurfaceView Plot Window
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Controlling the Surface Display

You can use the 3D SurfaceView Controls dialog to access the following 
functionality:

• Rotating, moving, and zooming in and out of the surface display.

• Changing surface styles, vertical exaggeration, and DEM resolution.

• Setting, starting, and stopping a perspective rotation.

To access the 3D SurfaceView Controls dialog, select Options → Surface Control in 
the 3D SurfaceView window. When the 3D SurfaceView Controls dialog appears, use 
the buttons, text fields, and controls described in the following sections to control the 
surface display.

Rotating, Zooming, and Translating

In addition to using cursor functions (see “Cursor Functions in the 3D SurfaceView 
Window” on page 996) to manipulate the 3D SurfaceView plot, you can also perform 
these functions using controls in a dialog.

Changing Rotation

1. In the Rotation/Scale/Translation Controls section of the 3D SurfaceView 
Controls dialog, click on the curved arrow buttons to change the rotation of the 
surface plot in the direction desired.

2. Use the Inc text box to change the rotation increment. The default increment is 
5.

Figure 12-8: 3D SurfaceView Controls Dialog
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Zooming In and Out of the Display

1. In the Rotation/Scale/Translation Controls section of the 3D SurfaceView 
Controls dialog, click the + or – buttons to zoom in or out of the surface plot. 

2. Use the Inc text box to change the zoom increment. The default increment is 
0.10.

Translating the Image

1. In the Rotation/Scale/Translation Controls section of the 3D SurfaceView 
Controls dialog, click on the arrow buttons to move (translate) the surface plot 
in the direction desired.

2. Use the Inc text box to change the translation increment. The default 
increment is 0.05.

Changing the Surface Properties

The vertical exaggeration, depth offset, surface style, and DEM resolution surface 
properties can be changed in the 3D SurfaceView Controls dialog as well. 

Changing Vertical Exaggeration

• In the Surface Properties section of the 3D SurfaceView Controls dialog, 
enter the desired value in the Vertical Exaggeration text box or use the arrow 
increment buttons. The default value is 5.0.

The value entered will produce a true scale vertical exaggeration applied to the 
z-axis, where higher values correspond to greater exaggeration.

Changing Depth Offset

• In the Surface Properties section of the 3D SurfaceView Controls dialog, 
enter the desired value of the Depth Offset (or use the arrow increment 
buttons) to obtain the best results for your graphics card. The default value is 
25.

Note
The Depth Offset value is only used for hardware rendering (renderer = 0). 

Increasing the value will reduce the amount of vector stitching through the 
textured surface. Too large offset values may cause the textured surface to 
disappear entirely.
ENVI User’s Guide Using 3D SurfaceView



1000 Chapter 12: Topographic Tools
For the best results, RSI recommends starting a high resolution DEM and a 
small initial Depth Offset value. Then, increase the Depth Offset value until 
the vector stitching is eliminated.

The Depth Offset setting is only retained in your current ENVI session. To 
change the default value, edit the surfaceview depth offset value in the 
ENVI configuration file $ENVI_DIR/menu/envi.cfg.

Selecting a Surface Style

• In the Surface Properties section of the 3D SurfaceView Controls dialog, 
click the Surface Style pull-down button to plot the 3D SurfaceView plot with 
a Texture image draped over it, as a Wire mesh, as a Ruled XZ surface, as a 
Ruled YZ surface, or as a Point surface.

Selecting DEM Resolution

• In the Surface Properties section of the 3D SurfaceView Controls dialog, 
click the DEM Resolution button to choose the resolution (used for the plot) 
from the available DEM resolutions. If you selected more than one DEM 
resolution in the 3D SurfaceView Input Parameters dialog, you can select from 
any of these resolutions.

Using the Perspective Rotation Controls

The Perspective Controls section in the 3D SurfaceView Controls dialog allows you 
to click on a point in the 3D SurfaceView plot to specify a perspective origin around 
which the surface is rotated.

1. Click on the figure icon button to toggle the cursor to select mode. 

2. Move the arrow cursor onto the 3D SurfaceView plot and click on the plot to 
set the origin of the rotation.

The view zooms to the new origin of the perspective which is set at a height 
that is 0.05 normalized units (default) above the surface and rotation begins. 
You can modify the height of the perspective origin above the surface using the 
Translation controls in the 3D SurfaceView Controls dialog.

3. Click on the Start button to start a rotation which was stopped; or, if no 
perspective rotation has been initiated, to begin rotating the surface around its 
center point.

Click on the Stop button to pause the current rotation. 
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Note
If the cursor is in select mode, but no perspective origin in the surface has 
been chosen, clicking Stop toggles the cursor out of select mode.

4. Enter the desired value for the Rotation Delay in the text box or use the arrow 
increment buttons. The delay value is the number of seconds to wait between 
successive renderings of the rotating surface. The default value is 0.05. Setting 
the value to 0.0 sets the rotation speed to your computer’s limits for calculating 
the transformation matrix and rendering the surface. 

5. You can change the direction of the rotation of the surface by clicking on the 
Direction button and selecting either Left or Right. The default rotation 
direction is Right.

Note
Direction refers to the rotation direction of the surface, not the viewer’s 
perspective.

Resetting the 3D SurfaceView Plot

The 3D SurfaceView can be returned to its original orientation in the 3D SurfaceView 
window.

• In the 3D SurfaceView Controls dialog, click the Reset View button. The 
surface is rotated back to its original orientation, but all of the changes in the 
dialog are retained.

Defining and Displaying Flight Paths

When working with 3D SurfaceViews, you have the choice of using a User Defined 
path mode or Annotation path mode. In User Defined mode, you fly through your 
data based on a flight sequence you define. In Annotation mode, you fly through your 
data based on an annotation flight path. The annotation must be drawn on the image 
from which the surface plot was created or imported from a saved annotation file.

1. To work in either mode, select Options → Motion Controls in the 3D 
SurfaceView plot window. 

2. When the 3D SurfaceView Motion Controls dialog appears, select the desired 
mode from the Options menu.
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See the following sections for details about working in the two different modes.

Defining a Flight Path in User Defined Mode

Use the User Defined mode to define a flight path and to play a sequence of views 
that fly-through your data.

1. In the 3D SurfaceView Motion Controls dialog, select Options → Motion: 
User Defined Views.

2. Use the mouse to select the starting projection (view) for the fly-through. 

For instructions and mouse button function descriptions, see “Cursor 
Functions in the 3D SurfaceView Window” on page 996.

3. In the 3D SurfaceView Motion Controls dialog, click the Add button to add the 
selected projection to the flight path.

4. Use the mouse to select another projection and click the Add button.

The flight path will be smoothly interpolated between the two projections.

Figure 12-9: Surface View Motion Controls Dialog in User Defined Mode (left) 
and in Annotation Mode (right)
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5. Repeat Step 4 until you have selected as many projection steps as desired (only 
2 are required).

• To replace a projection in the flight path list, click on the path view number 
and click Replace.

• To delete a projection in the flight path list, click on the path view number 
and click Delete.

• To clear the flight path list, click Clear.

6. Enter the number of frames to be used in the fly-through animation.

The flight path will be smoothly interpolated between the projections.

7. Click the Play Sequence button to animate the fly-through.

• To control the speed and direction of the fly-through, select Options → 
Animate Sequence in the SurfaceView Motion Controls dialog (see 
“Animating Flight Paths” on page 1005).

Defining a Flight Path in Annotation Mode

Use Annotation mode to define a flight path based on annotation. Use a polyline, 
polygon, rectangle, or ellipse annotation object to define the flight path (see 
“Annotating Images” on page 240 for annotation details). You can control the vertical 
and horizontal look angles, fly at a constant elevation above the DEM terrain, or fly at 
a constant altitude.

Note
To use Annotation mode, you must have annotation drawn on the display window 
from which the 3D SurfaceView was created, or have the desired annotation object 
saved in an annotation file (.ann).

1. In the 3D SurfaceView Motion Controls dialog, select Options → Motion: 
Annotation Flight Path.

2. When the Input Annotation Flight Path dialog appears, select whether to 
import annotation from the display or from a file by clicking the corresponding 
button.

• If you select the option to input the annotation object from a display 
window, select the desired annotation object.

• If you select the option to import the annotation object from a saved 
annotation file, select the desired annotation (.ann) file and object.
ENVI User’s Guide Using 3D SurfaceView



1004 Chapter 12: Topographic Tools
The selected annotation object, number of nodes, and the number of points are 
displayed in the middle of the 3D SurfaceView Motion Controls dialog and the 
flight path is plotted on the 3D SurfaceView plot.

Tip
If you are already in Annotation mode and want to input annotation, select File → 
Input Annotation from Display or Input Annotation from File in the 3D 
SurfaceView Motion Controls dialog. 

3. Select from the following options:

• To smooth the flight path by using a running average of points along the 
line, enter the desired number of points to use in the average in the Flight 
Smooth Factor text box.

• To fly over the surface at a constant height above the DEM terrain, click 
the arrow toggle button until Flight Clearance appears and enter the 
desired height (in the same units as the DEM).

• To fly over the surface at a constant elevation, click the arrow toggle button 
until Flight Elevation appears and enter the desired elevation above sea 
level (in the same units as the DEM).

• To adjust the vertical look angle, enter the desired angle, in degrees, in the 
Up/Down text box.

A vertical look angle of –90 degrees looks straight down at the surface. A 
look angle of 0 degrees looks straight ahead (horizontal).

• To adjust the horizontal look angle, enter the desired angle, in degrees, in 
the Left/Right text box.

A horizontal look angle of –90 degrees looks to the left, a look angle of 0 
degrees looks straight ahead, and a look angle of 90 degrees looks to the 
right.

• To turn the annotation flight line trace off and on, select Options → 
Annotation Trace in either the 3D SurfaceView Motion Controls dialog 
or the 3D SurfaceView plot window.

4. Enter the desired number of frames to use when animating the data fly-through 
in the Frames text box.
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5. Click on the Play Sequence button to animate the fly-through.

• To have the sequence repeatedly restart when it reaches the end, select 
Options → Loop Play Sequence.

To control the speed and direction of the fly-through, select Options → Animate 
Sequence (see “Animating Flight Paths” on page 1005).

Animating Flight Paths

Use Animate Sequence (in either User Defined or Animation modes) to display and 
fly through your 3D SurfaceView plot in an animation window. In the animation 
window, you can control the characteristics of your fly-through with more precision 
than in the 3D SurfaceView Motion Controls dialog:

1. Select Options → Animate Sequence.

The 3D SurfaceView plot is displayed in the standard ENVI animation 
window. 

2. See “Controlling Animation Characteristics” on page 424 for details about 
using animation controls. 

Note
The first few times through the frame sequence may be slow until the frames 
are put in memory.

3. Select from the following options:

• To cancel the animation window, select File → Cancel.

• To save the animation to a MPEG (Moving Picture Experts Group) file, 
select File → Save as MPEG (see “Saving Animations” on page 425 for 
details).

Saving Flight Path Sequences to Files

To save the current flight path to a file:

1. In the 3D SurfaceView Motion Controls dialog, select File → Save Sequence 
to file.

2. Enter an output filename with the extension .pat for consistency. 

• To restore a previously saved flight path, select File → Restore Sequence 
from file and select the desired .pat filename.
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Note
Restoring is only available in User Defined mode. 

Exporting Flight Path Sequences to MPEG Files

To export a flight sequence to an MPEG (Movie Picture Experts Group) file:

Note
When creating MPEG files, you must be aware of the capabilities of the MPEG 
decoder you will be using to view it. Some decoders only support a limited set of 
sampling and bit rate parameters to normalize computational complexity, buffer 
size, and memory bandwidth. For example, the Windows Media Player supports a 
limited set of sampling and bit rate parameters. In this case, it is best to use 352 x 
240 x 30 fps or 352 x 288 x 25 fps when determining the dimensions and frame rate 
for your MPEG file. When opening a file in Windows Media Player that does not 
use these dimensions, you will receive a Bad Movie File error message. The file 
is not bad, this decoder just doesn't support the dimensions of the MPEG. 

1. In the SurfaceView Motion Controls dialog, select File → Save Sequence as 
MPEG.

The Output Sequence to MPEG Parameters dialog appears. 

Note
The default output size of the MPEG image window is the Windows standard.

• To change the output window size, enter the size (in pixels) in the MPEG 
Output Size text boxes.

2. In the Number of Frames text box, enter the number of frames (individual 
views) to be included in the output flight sequence (movie).

More frames will make a longer sequence, but will also make a larger output 
file.

3. From the MPEG Frame Rate button menu, select a rate in frames/second.

4. Enter the desired MPEG compression quality.

5. Enter a duplication factor, if desired.

This helps to make the MPEG output appear smoother. For example, a 
duplication factor of 2 will duplicate each frame and double the number of 
output frames. 
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6. Enter an output filename and click OK.

Note
The writing of the output MPEG file is done in two steps and the second step cannot 
be cancelled and can take up to many seconds per frame.

• The compression is a lossy compression where 0 is lowest quality and 100 is 
highest quality (no compression). Entering a compression quality factor less 
than 100 decreases the amount of disk space used to store the MPEG output.

Positioning the Perspective

In addition to the Perspective Controls in the 3D SurfaceView Controls dialog, you 
can also view the surface view panoramically (as if you were standing in the image) 
with the Position Controls dialog.

1. In the 3D SurfaceView window, select Options → Position Controls. The 
SurfaceView Position Controls dialog appears.

Figure 12-10: 3D SurfaceView Position Controls Dialog
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2. Click the arrow toggle button to select Map Coord for georeferenced images, 
or Pixel Coord for non-georeferenced images. The default is Pixel Coord.

• If you select Pixel Coord, enter the sample and line coordinates of where 
you want to stand in the image or use the arrow increment buttons to select 
the coordinates.

Note
If your image is a subset of a larger image, you can use the X and Y pixel 
offsets from the header file by clicking the arrow toggle button next to the 
Use Offset label to select Yes.

• If you select Map Coord, enter the map coordinates of the location where 
you want to stand and click Change Proj to change the projection (if 
desired).

3. Set whether changes will be automatically applied by clicking the Yes or No 
toggle buttons next to the Auto Apply label.

4. Select from the following options to change your position and viewing angle in 
the surface view image.

• To change the location where you are standing, double-click on a spot in 
the image to automatically move to that location.

The location change is reflected in both the Main Image display and the 
3D SurfaceView plot.

• To change the azimuth look direction (north = 0 and angles increase 
clockwise), use the slider bar next to the Azimuth label, or click on the 
arrow increment buttons to look around panoramically (to change the 
angle in increments of five degrees, click on the arrows with the middle 
mouse button).

• To change the elevation angle from which you are looking, use the slider 
bar next to the Elevation label (to change the angle in increments of five 
degrees, click on the arrows with the middle mouse button). 

An angle of 0 degrees is horizontal and a negative angle is down looking.

• To change the distance from which you are looking down on the image, 
enter a number in the Height Above Ground text box or use the arrow 
increment buttons to change the height. 

Note
The units used should be the same as the DEM elevation units.
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Changing Background Color

1. To change the background color of the 3D SurfaceView plot, select Options → 
Change Background Color from the menu bar in the 3D SurfaceView plot 
window. 

The 3D SurfaceView Background Color dialog appears.

2. From the System button menu, select RGB, HLS, or HSV.

3. Select a color from the V menu, or set color values by using the corresponding 
slider bars and text boxes.

4. When you are satisfied with your changes, click OK.

Importing Vectors and ROIs

Select Options → Import Vectors… to overlay ROIs (Regions of Interest) and 
vector layers on the 3D SurfaceView plot.

Note
You must have ROIs or vectors displayed in the original image display from which 
the 3D SurfaceView was created. For information about defining ROIs or 
overlaying vectors on an image, see “Defining Regions of Interest” or “Overlaying 
Vectors” in Chapter 4.

1. In the 3D SurfaceView window, select Options → Import Vectors.

All of the ROIs and vectors from the image will be overlaid on the 3D 
SurfaceView plot.

2. When ROIs and vectors are overlaid, select from the following options:

• To remove a layer or layers, select Options → Remove Vectors and select 
the layers to be removed.

• To turn the display of vector layers on or off, select Options → Plot 
Vector Layers.

Note
Turning layers off does not remove them from the 3D SurfaceView plot, it 
only hides them.
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• To display the vectors and ROIs while interactively positioning and 
moving the 3D SurfaceView image, select Options → Plot Vectors on 
Move.

• To avoid slow interactive repositioning when many vectors and ROIs are 
overlaid, deselect Options → Plot Vectors on Move.

• To change the appearance (e.g., line thickness, color) of vectors in the 3D 
SurfaceView plot, first make the changes to the vectors in the original 
image, then re-import the vectors from the image into the 3D SurfaceView.

Note
For details about working with vectors, see “Overlaying Vectors” on page 325.

Smoothing 3D Images

• To smooth 3D Surface View Images that appear pixelated, select Options → 
Bilinear Interpolation. 

• To turn off the smoothing effect, select Options → Interpolation:None.

Resetting Surface View

• To reset the surface view to the default position, select Options → Reset View.

Managing SurfaceView Files

Use the File menu in the 3D SurfaceView dialog to save or print the displayed 
surface, or to exit the plot window.

Saving 3D SurfaceViews

Use the File menu in the 3D SurfaceView plot window to save the plot to an image 
file or a Virtual Reality Modeling (VRML) file, or export the plot to a printer.

• To save a surface view as an image file, select File → Save Surface As → 
Image File.

• To save a surface view as a VRML 2.0 file, select File → Save Surface As → 
VRML.

• To print a 3D SurfaceView plot, select File → Print.

For more information and instructions, see “Display Output Options” on page 446. 
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Closing the Dialog

• To quit the 3D SurfaceView function, select File → Cancel in the 3D 
SurfaceView plot window.
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Chapter 13:

Radar Tools
This chapter covers the following topics:
The Radar Menu  . . . . . . . . . . . . . . . . . . .  1014
Opening Radar Files  . . . . . . . . . . . . . . . .  1015
Calibrating Radar Files  . . . . . . . . . . . . . .  1019
Removing Antenna Gain Variations  . . . .  1021
Resampling to Ground Ranges  . . . . . . . .  1023
Generating Incidence Angle Images . . . .  1025

Adaptive Filters  . . . . . . . . . . . . . . . . . . .  1026
Texture Filters . . . . . . . . . . . . . . . . . . . . .  1026
Creating Synthetic Color Images . . . . . .  1026
Using Polarimetric Tools  . . . . . . . . . . . .  1027
Using TOPSAR Tools  . . . . . . . . . . . . . .  1053
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The Radar Menu

Use the Radar menu to access standard and advanced tools for analysis of detected 
radar images and advanced SAR systems such as JPL’s fully polarimetric AIRSAR 
and SIR-C systems. ENVI can process ERS-1, JERS-1, RADARSAT, SIR-C, X-
SAR, and AIRSAR data and any other detected SAR data set. In addition, ENVI is 
designed to handle radar data distributed in the CEOS format, and should be able to 
handle data from other radar systems (not mentioned here) that also distribute their 
data in this format. 

Most standard ENVI processing functions are inherently radar-capable including all 
display capabilities, stretching, color manipulations, classification, registration, 
filters, geometric rectification, and so on. Additional specialized tools are provided 
for analyzing polarimetric radar data. For examples of using some of the radar 
functions, see the ENVI SAR Tutorials.

Figure 13-1: Radar Menu
The Radar Menu ENVI User’s Guide



Chapter 13: Radar Tools 1015
Opening Radar Files

Use Open/Prepare Radar File to open radar format files from CD or disk. 
Instructions for opening specific radar formats are described in the following 
sections.

Note
You can also use the File → Open External File → Radar to open these files. For 
detailed information, see “Opening Radar Files” on page 83.

Opening ERS Files

To read ERS-1 and ERS-2 format data:

1. Select Radar → Open/Prepare Radar File → ERS.

2. When the file selection dialog appears, select the image file to be read. 

ENVI automatically extracts the header information and places the image band in the 
Available Bands List. 

Opening JERS Files

To read JERS format data:

1. Select Radar → Open/Prepare Radar File → JERS.

2. When the file selection dialog appears, select the image file to be read. 

ENVI automatically extracts the header information and places the image band in the 
Available Bands List. 

Opening RADARSAT Files

To read RADARSAT data files into ENVI: 

1. Select Radar → Open/Prepare Radar File → RADARSAT.

2. When the file selection dialog appears, select the input data file. 

ENVI automatically extracts the needed header information (including UTM 
georeferencing information) from the data file, leader file, and/or trailer file. 
The image band is entered into the Available Bands List. 

3. Click OK to start the data reading.
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Opening Integer Format RADARSAT Data

When the RADARSAT File Import dialog appears, select Import Data Type → 
Unsigned Integer.

The image bandname is entered into the Available Bands List.

For Byte Scaling 

1. When the RADARSAT File Import dialog appears, select Import Data 
Type → Scale to Byte.

2. Enter the scaling minimum and maximum data values or keep the default 
values.

The Min and Max values are automatically entered as the 2% points from the 
histogram in the CEOS header if it is found. If the CEOS header is not 
available you must enter these values.

3. Click OK.

The image bandname is entered into the Available Bands List. 

Opening TOPSAR Files

To read the raw TOPSAR (AIRSAR Integrated Processor Data) format data files 
(Cvv, Incidence Angle, Correlation Image, or the DEM):

1. Select Radar → Open/Prepare Radar File → TOPSAR.

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the needed header information and places the image 
band into the Available Bands List. 

Note
To read all of the TOPSAR files and automatically convert them to physical units, 
see “Converting TOPSAR Data” on page 1053. To synthesize AIRSAR images, see 
“Synthesizing JPL AIRSAR Data” on page 1027.
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Viewing CEOS Headers

Use View Generic CEOS Header to produce a report of CEOS header information 
from generic CEOS data types (that is, ERS-1, JERS-1, SIR-C, X-SAR) or from 
RADARSAT headers.

1. Select Radar → Open/Prepare Radar File → View Generic CEOS Header.

2. When a standard ENVI file selection dialog appears, select the file from which 
the header will be read.

A report of the header information is printed on the screen. 

• To save the report to an output file, select File → Save Text to ASCII and 
enter an output filename.

Viewing RADARSAT Headers

1. Select Radar → Open/Prepare Radar File → View RADARSAT Header.

2. When a standard ENVI file selection dialog appears, select the file from which 
the header will be read. A report of the header information is printed on the 
screen. 

3. To save the report to an output file, select File → Save Text to ASCII and 
enter an output filename.

Viewing AIRSAR/TOPSAR Headers

To view the ASCII headers for the AIRSAR and TOPSAR data files:

1. Select Radar → Open/Prepare Radar File → View AIRSAR/TOPSAR 
Header

2. Select the data file. The header information is displayed in a report window.

Saving Header Information to ASCII Files

To save the AIRSAR/TOPSAR header information to an ASCII file, select File → 
Save Text to ASCII and enter an output filename.
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Synthesizing AIRSAR Data

AIRSAR images must be synthesized before they can be used in standard ENVI 
processing routines. For detailed instructions, see “Synthesizing JPL AIRSAR Data” 
on page 1027.

Synthesizing SIR-C Data

SIR-C Single Look Complex (SLC) and Multi-Look Complex (MLC) images must 
be synthesized before they can be used in standard ENVI processing routines. For 
detailed instructions, see “Synthesizing SIR-C Data” on page 1032.
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Calibrating Radar Files

Use Radar → Calibration to calibrate your ERS or Radarsat data files to radar 
brightness values (β0) or to radar backscatter coefficient values (σ0) using a DEM.

Calibrating to Beta Nought (β0)

Use Beta Nought to radiometrically calibrate your ERS or Radarsat data to radar 
brightness values (β0). The radar brightness values are output in decibels (dB). This 
function works for ERS PRI products and Radarsat SGF, SGX, SGC, SCN, SCW, and 
SLC detected products.

1. Select Radar → Calibration → Beta Nought.

2. When the input file selection dialog appears, select the desired ERS or 
Radarsat data file.

• If ENVI cannot find the leader file, it will prompt you to select the 
corresponding leader file.

If you are using ERS data, the Beta Nought Parameters dialog will appear.

3. The ERS Incidence Angle and ERS Absolute Calibration values will be 
automatically read from the leader file. If they are not found in the leader file, 
enter the center of image incidence angle and absolute calibration constant in 
the appropriate text boxes.

4. Enter an output filename and click OK.

Calibrating to Sigma Nought (σ0)

Use Sigma Nought to calibrate your ERS or Radarsat data to radar backscatter 
coefficient (σ0). This function requires a DEM with the same spatial dimensions and 
pixel size as the input radar data. The DEM image is used to accurately calculate the 
incidence angle over the image. The radar backscatter coefficient values are output in 
decibels (dB). This function works for ERS PRI products and Radarsat SGF, SGX, 
SGC, SCN, SCW, and SLC detected products.

1. Select Radar → Calibration → Sigma Nought.

2. When the input file selection dialog appears, select the desired ERS or 
Radarsat data file.

3. When the DEM input file selection dialog appears, select the corresponding 
DEM data file.
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Note
The DEM file must be the same dimensions and pixel size as the input radar file.

• If ENVI cannot find the radar image leader file, it will prompt you to select the 
corresponding leader file.

The Sigma Nought Parameters dialog appears.

4. If you are using ERS data, the ERS Incidence Angle and ERS Absolute 
Calibration values will be automatically read from the leader file. If they are 
not found in the leader file, enter the center of image incidence angle and 
absolute calibration constant in the appropriate text boxes.

5. If you are using Radarsat data, ENVI will automatically read the Near Range 
Angle and Far Range Angles from the leader file. If theses values are not 
found in the leader file, enter the near range angle and far range angle, in 
degrees, in the appropriate text boxes.

6. Enter an output filename and click OK.
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Removing Antenna Gain Variations

Radar images typically have a variation in gain across the range direction due to the 
instrument’s antenna gain pattern. Use ENVI’s Antenna Pattern Correction to 
remove this gain variation. Azimuth mean values are calculated and can be plotted to 
show the mean variation in the range direction. A polynomial function, with a user-
defined order, is fit to the means and used to remove the gain variation. Either an 
additive or multiplicative correction can be selected. For more information, see the 
following reference:

Ulaby, F. T., R. K. Moore, and A. K. Fung, 1982. Microwave Remote Sensing Active 
and Passive, Volume II, Artech House, Inc., Norwood, MA, p.1064.

1. Select Radar → Antenna Pattern Correction.

2. When the Antenna Pattern Input File dialog appears, select the input file and 
perform any spatial subsetting, spectral subsetting, or masking.

The Antenna Pattern Correction Parameters dialog appears.

3. Designate the range direction by clicking the Samples or Lines check box.

4. Select either an Additive or Multiplicative correction method.

Typically, a multiplicative correction is used for radar antenna pattern 
variations.

Figure 13-2: Antenna Pattern Correction Plot with First Order Polynomial Fit (in 
White)
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5. Enter the desired polynomial order and click Plot Polynomial to show a plot 
of the mean data values in red with the selected polynomial fit overlaid in 
white. The polynomial order can be changed and plotted again. It is best to use 
a low order polynomial so as not to remove the local variation in backscatter 
signal.

Note
The Antenna Pattern Correction plot pull-down menus will not be active until 
you close the Antenna Pattern Correction Parameters dialog.

6. Select output to Memory or File.

7. Click OK to start the processing.
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Resampling to Ground Ranges

Radar instruments measure distance to the side of the platform (slant range) which 
causes distortions in the true ground mapping (ground range). Use Slant to Ground 
Range to resample slant range radar images to ground range pixel sizes assuming flat 
terrain.

Using AIRSAR, RADARSAT, and SIR-C Data

The Slant-to-Ground Range function uses header information for AIRSAR, SIR-C, 
and RADARSAT data types. You can use other radar data sets by entering a few 
needed parameters (see “Using Generic Data”, next).

1. Select Radar → Slant to Ground Range → AIRSAR, RADARSAT, or 
SIR-C.

2. Select the radar header file that contains the data acquisition parameters. 
Necessary parameters will be automatically read from the selected input file 
and entered into the Slant to Ground Range Parameters dialog. To manually 
enter the necessary parameters, click Cancel and enter the parameters in the 
Slant to Ground Range Parameters dialog. 

Note
For AIRSAR and SIRC select the compressed data file; for Radarsat select the 
image file.

3. When a standard ENVI input file dialog appears, select the input file and any 
spatial and/or spectral subsetting.

4. Click OK.

The Slant to Ground Range Parameters dialog appears. 

5. Enter the desired output pixel size, select the desired resampling method, and 
select memory or file output.

6. From the Near Range button menu, select the location of the near range in the 
image: Top, Bottom, Left, or Right.

7. Click OK to start the processing.
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Using Generic Data

To compute ground range images from other data types:

1. Select Radar → Slant to Ground Range → Generic.

2. When a standard ENVI input file dialog appears, select the input file and 
spatial and/or spectral subsetting.

3. Click OK. The Slant to Ground Range Parameters dialog appears. 

4. Enter the instrument height, near range distance, slant range pixel size, and 
desired output pixel size.

5. From the Near Range button menu, select the location of the near range in the 
image: Top, Bottom, Left, or Right.

Note
See “Warping and Resampling” on page 870 for details about resampling 
methods.

6. Select output to Memory or File.

7. Click OK to start the processing.
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Generating Incidence Angle Images

Use Incidence Angle Image to generate incidence angle images from AIRSAR 
(excluding AIRSAR data associated with TOPSAR data sets), RADARSAT, SIR-C, 
and generic radar data. The incidence angles are calculated based on the near range 
and far range angles and assume flat topography. 

Using AIRSAR, RADARSAT, and SIR-C Data

To generate an incidence angle image from AIRSAR (excluding AIRSAR data 
associated with TOPSAR data sets), RADARSAT or SIR-C:

1. Select Radar → Incidence Angle Image → AIRSAR, RADARSAT, or 
SIR-C. 

2. Select the input file and click OK. The necessary information is read 
automatically from the header files. If all of the needed parameters are not 
found, enter the missing values in the corresponding text boxes.

3. When the Incidence Angle Parameters dialog appears, select incidence angle 
output in radians or degrees.

4. Select output to File or Memory.

5. Click OK to start the processing.

Using Generic Data

To generate an incidence angle image from other data types:

1. Select Radar → Incidence Angle Image → Generic. 

2. When the Incidence Angle Information dialog appears, enter the number of 
output samples and lines and the near and far range angles, in degrees, in the 
corresponding text boxes.

3. From the Near Range button menu, select the location of the near range in the 
image: Top, Bottom, Left, or Right.

4. Click OK.

5. When the Incidence Angle Parameters dialog appears, select incidence angle 
output in radians or degrees.

6. Select output to File or Memory and click OK.
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Adaptive Filters

ENVI includes several adaptive filters to use for SAR processing. The filters include 
Lee, Enhanced Lee, Frost, Enhanced Frost, Gamma, Kuan, and Local Sigma to 
reduce image speckle and a Bit Errors filter to remove bad pixels. 

To select a filter, select Radar → Adaptive Filters → Filters. The filters can also be 
accessed from the Filters menu on the ENVI main menu and are described in detail 
in “Using Adaptive Filters” on page 728.

Texture Filters

ENVI includes several texture filters for extracting textural information from SAR 
and other data types. These include filters based on the data range, RMS, 1st moment, 
and 2nd moment of the data. 

To select a filter, select Radar → Texture → the desired filter. The filters can also be 
accessed from the Filters menu on the ENVI main menu and are described in detail 
in “Using Texture Filters” on page 723.

Creating Synthetic Color Images

Use Synthetic Color Image to transform a grayscale image into a synthetic color 
image. This transform is often used with radar data to improve the display of subtle 
large-scale features while retaining fine detail. 

To create a synthetic color image, select Radar → Synthetic Color Image.

Note
For detailed instructions, see “Creating Synthetic Color Images” on page 704. 
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Using Polarimetric Tools

ENVI has a suite of polarimetric radar analysis tools for the NASA/JPL AIRSAR, 
TOPSAR and SIR-C data types. These polarimetric radar data are stored in a 
compressed Stokes or scattering matrix format. Because of the format, the data 
cannot be directly viewed and specialized functions are needed. Use the polarimetric 
tools in ENVI to view headers, decompress and synthesize images, multilook SIR-C 
compressed data, calculate phase and pedestal height images, perform an AIRSAR 
scattering classification technique, and extract polarization signatures.

Synthesizing JPL AIRSAR Data

AIRSAR images must be synthesized before they can be used in standard ENVI 
processing routines. Use Synthesize AIRSAR Data to synthesize standard and 
specific transmit and receive polarization and total power images from compressed 
Stokes files. The input AIRSAR data must be in JPL stokes matrix format (standard 
file extension .stk). JPL AIRSAR data are usually delivered on 9-track, 8mm, or 
4mm tape as three separate files (P, L, and C-band) in compressed Stokes Matrix 
format (see the JPL AIRSAR documentation for details).

van Zyl, J.J., H.A. Zebker, and C. Elachi: Imaging radar polarization signatures: 
theory and observation. Radio Science 22(4):pp. 529-543, 1987.

Zebker, H.A., J.J. van Zyl, and D.N. Held. Imaging radar polarimetry from wave 
synthesis. Journal of Geophysical Research 92(31): pp. 683-701, 1987.

Tip
To transfer the JPL AIRSAR files to your local disk, use standard system-level tape 
utilities or the ENVI Dump Tape routine (see “Dumping Tape Data” on page 165). 
You can use AIRSAR data with missing or non-standard headers, but you have to 
enter the data parameters as described in “Entering Missing AIRSAR Parameters” 
on page 1029).

For easier processing, name the three files with the following convention: 
filename_p.stk, filename_l.stk, and filename_c.stk. 
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Note
You can generate byte images to conserve disk space when quantitative analysis is 
not an issue.

1. Select Radar → Polarimetric Tools → Synthesize AIRSAR Data.

The Input Stokes Matrix Files dialog appears. Use this dialog to read the 
compressed Stokes matrix files.

Warning
Do not open the Stokes matrix files using the standard ENVI File menu selection.

2. Click Open File.

3. In the file selection dialog, select one of the Stokes matrix filenames. If the file 
has a valid AIRSAR header with all of the required parameters, the filename is 
listed in one of the Selected Files text boxes in the Input Stokes Matrix File 
dialog (depending on whether the file is P-, L-, or C-band data). If you 
followed the suggested file naming convention described above, correct file 
names for the other two files are automatically entered into the appropriate text 
boxes. Otherwise, the file selection process must be repeated for each of the 
bands.

Note
If your radar data filenames do not appear in your directory, set the filename 
filter to *.* using the Files of Type pull-down list. To clear the names in the 
Stokes Matrix Input File dialog at any time, click Reset or click Cancel to 
quit without processing. 

Note
If the Stokes Matrix input file does not have a valid AIRSAR header, or if 
values are missing from the header, the AIRSAR Header Parameters dialog 
appears. For instructions, see “Entering Missing AIRSAR Parameters”.

4. Click OK to accept the filenames.

The Synthesize Parameters Dialog appears.

5. Enter the parameters as described in “Selecting Synthesizing Parameters” on 
page 1029.

6. Select output to File or Memory. 

7. Click OK to start the processing.
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All of the synthesized bands are placed in a single file. The synthesized images are 
added to the Available Bands List and can be processed further using standard ENVI 
image processing functions.

Entering Missing AIRSAR Parameters

In the AIRSAR Header Parameters dialog, all of the known parameters are listed in 
the dialog. The dialog often appears because JPL has changed header parameters for 
a particular processor version. Typically, the COMP SCALE FACTOR (also known 
as GENFAC) or the Band might be missing from the header.

Note
A COMP scale factor of 1.0 seems to work in most cases.

1. In the AIRSAR Header Parameters dialog, verify the parameters and change 
values as required.

2. Enter any missing values.

3. Click OK to return to the Stokes Matrix Input File dialog.

Selecting Synthesizing Parameters

Use the Synthesize Parameters dialog to select specific send and receive polarization 
combinations to be synthesized into ENVI images. The standard polarizations 
(H=horizontal, V=vertical) HH, VV, HV, and a total power (TP) image are generated 
for each of the three frequencies (bands) by default. These bands appear in the Select 
Bands to Synthesize list.

Figure 13-3: Input Stokes Matrix Files Dialog
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Turning Bands On/Off

To toggle the standard bands on or off, click in the box to the left of the band name. 

Spatially Subsetting Images

To perform spatial subsetting of the image to be synthesized directly from the Stokes 
matrix data, click Spatial Subset and use standard ENVI spatial subsetting 
procedures (see “Selecting a Spatial Subset” on page 35).

Note
The Image subsetting option is not available because it requires image format data 
rather than compressed data.

Figure 13-4: Synthesize Parameters Dialog
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Selecting Additional Send and Receive Polarizations

1. In the Synthesize Parameters dialog, enter the desired transmit and receive 
ellipticity and orientation angles in the Transmit Ellip/Orien and Receive 
Ellip/Orien text boxes.

2. Click on the Add Combination button. Ellipticity values range from -45 to 45 
degrees with an ellipticity of 0 producing linear polarizations. Orientation 
values range from 0 to 180 degrees with 0 representing horizontal and 90 
degrees for vertical polarizations.

3. Select the desired bands, C, L, and /or P by clicking in the box to the left of the 
band name.

4. Click Add Combination.

The selected images are listed in the Additional Images: text box. 

Outputting in Decibels

To output images converted into dB (decibels):

1. Ensure that the Output Data Type button menu is set to Floating Point.

2. Select the Yes toggle button.

Note
If you select No, the images will be output as intensity values.

Outputting in Byte Format

When quantitative analysis is not required, you can select byte output:

1. From the Output Data Type button menu, select Byte. 

The Std Multiplier text box appears.

2. In the Std Multiplier text box, enter the standard deviation multiplier used to 
calculate a minimum and maximum for scaling.

Note
The default value of 1.5 works for most AIRSAR and SIR-C scenes. Selecting byte 
output automatically disables dB output.
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Masking Bad Data Values

If you are outputting to a floating point data type to mask bad data values, enter the 
minimum and maximum data values to use, in units of intensity, in the Intensity Min 
and Max text boxes.

When outputting images in dB, the minimum and maximum values are still entered in 
units of intensity as the output is bounded by these values prior to computing dB (for 
example, If you bound the data by 0 to 1 then a dB image will be bounded by -Inf to 
0).

Synthesized values less than the minimum will be set to zero (0) and values greater 
than the maximum will be replaced by the value one (1).

Synthesizing SIR-C Data

SIR-C Single Look Complex (SLC) and Multi-Look Complex (MLC) images must 
be synthesized before they can be used in standard ENVI processing routines. Use 
Synthesize SIR-C Images to synthesize standard and specific send and receive 
polarization and total power (TP) images from SIR-C compressed scattering matrix 
files. The input SIR-C data must be in ENVI compressed data product format (SIR-C 
standard file extension .cdp). For more information, see the references for 
“Synthesizing JPL AIRSAR Data” on page 1027.

Tip
To ensure that the SIR-C data are in the proper compressed data product format, use 
ENVI SIR-C tape routines (see “Reading SIR-C CEOS Tapes” on page 152). You 
can use SIR-C data on disk that weren’t read from tape, but you have to enter the 
data parameters as described “Entering Missing SIR-C Parameters” on page 1035. 

For easier processing, name the files with the following convention: 
filename_c.cdp and filename_l.cdp.

1. Select Radar → Polarimetric Tools → Decompress-Synthesize Images → 
Synthesize SIR-C Images.

The Input Data Products Files dialog appears. Use this dialog to read the SIR-
C compressed scattering matrix files.

Warning
Do not open Scattering matrix files using the standard ENVI File menu selection.
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2. Click Open File. 

3. In the file selection dialog, select one of the SIR-C scattering matrix (.cdp) 
filenames from the list. If the file is a valid ENVI compressed data file with all 
of the required parameters, the filename is listed in the one of the Selected 
Files text boxes in the Input Data Product Files dialog (depending on whether 
the file is L-, or C-band data). If you followed the suggested file naming 
convention described above, the correct file name for the other file is 
automatically entered into the corresponding text box. Otherwise, the file 
selection process must be repeated for each of the bands. 

Note
To clear the file names in the Data Products Input File dialog at any time, 
click Reset or click Cancel to quit the process without processing. 

Note
If the input file is not a valid ENVI compressed data file, the SIR-C Header 
Parameters dialog appears. For instructions, see “Entering Missing SIR-C 
Parameters” on page 1035.

4. Click OK to accept the filenames. The Synthesize Parameters Dialog appears.

Figure 13-5: Data Products Files Dialog
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5. Set the parameters as described in “Selecting Synthesizing Parameters” on 
page 1029.

6. In the Synthesize Parameters dialog, select output to File or Memory.

7. Click OK to start the processing.

All synthesized bands are placed in a single output file. The images are added to the 
Available Bands List and can be processed further using standard ENVI image 
processing functions.

Figure 13-6: Synthesize Parameters Dialog
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Entering Missing SIR-C Parameters

If the SIR-C Header Parameters dialog appears when you select an input file, it 
means that information is missing from the header. All of the known parameters are 
listed in the dialog.

1. Enter the number of samples and lines in the corresponding text boxes.

2. Enter the image size in the range direction (in kilometers) in the Width (km) 
text box.

3. Enter the scene size in the azimuth direction (in kilometers) in the Length 
(km) text box.

4. To skip any imbedded header and get to the beginning of the SIR-C data, enter 
the byte offset in the Offset text box.

5. Click the C or L band toggle button. 

6. Select SAR Channel Type by clicking on a SIR-C data type toggle button.

7. To strip line headers from the input data and exclude them from output image, 
click the Yes toggle button.

8. If the data have been dumped directly from tape in CEOS format, they may 
have an extra 12 bytes at the beginning of every line.

9. Click OK to return to the Data Products Input File dialog.

Tip
You can find missing information in the quicklook prints that JPL provided with the 
data, or by printing or viewing one of the ASCII CEOS header files that comes on 
the SIR-C distribution tapes.
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Extracting Polarization Signatures

Use Polarization Signatures to extract 3D representations of the complete scattering 
characteristics for a single pixel or the average for an ROI from either the Stokes 
Matrix for AIRSAR data or from the compressed scattering matrix for SIR-C data. 
You can extract the signatures based on the current pixel location on a displayed 
image or extract for ROIs that were defined using ENVI’s standardized ROI 
definition procedures. Both co- and cross-polarization signatures are extracted and 
you can view and process them as standard ENVI images or display them in a 
Polarization Signature Viewer (see “Using the Polarization Signature Viewer” on 
page 1040). For more information about polarization signatures, see the following 
references:

van Zyl, J.J., H.A. Zebker, and C. Elachi: Imaging radar polarization signatures: 
theory and observation. Radio Science 22(4): pp. 529-543, 1987.

van Zyl, J. J., 1989, Unsupervised classification of scattering behavior using radar 
polarimetry data, IEEE Trans. Geosci. Remote Sensing, vol. 27, no. 1, pp. 36-45.

Zebker, H.A., J.J. van Zyl, and D.N. Held. Imaging radar polarimetry from wave 
synthesis. Journal of Geophysical Research 92(31): pp. 683-701, 1987.

Figure 13-7: SIR-C Header Parameters Dialog
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Note
You can also extract polarization signatures using the Display Tools menu (see 
“Extracting Polarization Signatures” on page 403).

Extracting Polarization Signatures from Single Pixels

Use the following procedure to extract polarization signatures for single pixels in a 
display window directly from compressed quad-polarized AIRSAR Stokes matrix 
data or from SIR-C quad-polarized compressed scattering matrix data.

1. Display the synthesized image or another co-registered image.

2. Interactively set the pixel to be extracted in the displayed image by clicking the 
middle mouse button on the desired pixel in the Zoom window (see “The 
Zoom Window” on page 203).

3. From the Display menu, select Tools → Polarization Signatures → AIRSAR 
or SIR-C.

Note
Depending on whether AIRSAR or SIR-C data is selected, the Input Stokes 
Matrix Files or the Input Data Products dialog appears.

4. Enter the Stokes Matrix or Scattering Matrix file names as described in 
“Synthesizing JPL AIRSAR Data” on page 1027. The polarization signature 
for the currently selected pixel is automatically loaded into the #n Current 
Pixel Polarization Signature Viewer. To change the polarization signature 
being plotted, select Options → Extract Current Pixel to extract and plot a 
polarization signature for the pixel currently under the cross-hair in the Zoom 
window. 

You can set or control specific parameters. For details, see the “Using the Polarization 
Signature Viewer” on page 1040.
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Extracting Polarization Signatures from ROIs

Use the following procedure to calculate polarization signatures for Regions of 
Interest (ROI). The signatures are extracted directly from the AIRSAR Compressed 
Stokes Matrix files or SIR-C scattering matrix files, and will be available for display 
either in polarization signature viewers or as images in standard ENVI displays. Both 
co- and cross-polarized signatures are extracted and saved in a multiband output file. 
Each signature has 91 samples (-45 to 45 degrees ellipticity angle) and 181 lines (0 to 
180 degrees orientation angle).

1. Before selecting this option, display a synthesized image or other co-registered 
dataset and define Regions of Interest (see “Defining Regions of Interest” on 
page 289). 

2. From the ENVI main menu, select Radar → Polarimetric Tools → Extract 
Polarization Signatures → AIRSAR or SIR-C.

Either the Input Stokes Matrix Files or the Input Data Products dialog appears, 
depending on whether AIRSAR or SIR-C data are selected.

3. Enter the Stokes Matrix or Scattering Matrix file names as described in 
“Synthesizing JPL AIRSAR Data” on page 1027.

4. Click OK.

The Polsig Parameters dialog appears.

5. Set the parameters as described in the following section.

Setting Polsig Parameters

In the Polsig Parameters dialog, the ROIs appear in the Select Polsig Images text 
box. One entry is listed for each of the P-, L-, and C-band images (AIRSAR) or L- 
and C-band images (SIR-C). 

1. Click on the ROI name(s) to select the polarization signatures. (To select 
multiple ROI names, see “Selecting Multiple Items in Lists” on page 43.)

2. Select calculating the polarization signatures as floating-point intensity, 
normalized intensity (normalized using the maximum image value), or in dB 
(decibels). The normalized intensity from 0 to 1 is calculated by dividing the 
signature by its maximum value.
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Note
The z axis units you select will be used for the polarization signature images; all 
three axis units will be available when the data are visualized in the Polarization 
Signature Viewer.

3. Select the Output type by clicking the corresponding toggle button.

4. Select standard File or Memory output. The polarization signatures (co- or 
cross-polarized) are saved as a multiband image, where each band of the image 
is a separate 91 samples (-45 to 45 degrees ellipticity angle) by 181 lines (0 to 
180 degrees orientation angle) polarization signature for one of the selected 
frequencies with the intensity representing the Z axis (intensity, normalized 
intensity, or dB).

Figure 13-8: Polsig Parameters Dialog
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5. Select whether or not to load each signature into its own Polarization Signature 
Viewer after it is extracted by clicking the Yes or No toggle button.

Note
Selecting Yes may create numerous windows and use significant amounts of 
resources. The preferred alternative is to select No and to use the Polarization 
Signature Viewer function to view individual signatures (see the following 
“Using the Polarization Signature Viewer” section).

6. Click OK.

Both co-polarized and cross-polarized signatures are calculated for each selected 
ROI. When completed, the signatures are listed in the Available Bands list. They can 
also be analyzed in their own Polarization Signature Viewers (see the following 
“Using the Polarization Signature Viewer” section).

Using the Polarization Signature Viewer

Use the Polarization Signature Viewer to interactively view and analyze polarization 
signatures extracted from AIRSAR and SIR-C data. The polarization signatures are 
displayed as floating-point, two-dimensional images and three-dimensional surface 
plots (wire mesh, scaled wire mesh, or grayscale). The X and Y axes represent 
ellipticity and orientation respectively, and you can set the vertical axis to be plotted 
as intensity, dB, or normalized intensity. You can toggle the plots between co- and 
cross-polarized signatures and display signatures displayed for all of the available 
frequencies. Statistics are displayed for the signatures and you can save them to 
ASCII files. You can change the color tables applied to the plots, and save the plots to 
image files or print them.

Automatically Starting the Viewer

The Polarization Signature Viewer starts automatically when a polarization signature 
is extracted from the current pixel (see “Extracting Polarization Signatures from 
Single Pixels” on page 1037). It also starts automatically when polarization 
signatures are extracted from ROIs (see “Extracting Polarization Signatures from 
ROIs” on page 1038).

To load a previously extracted polarization signature, select Radar → Polarimetric 
Tools → Extract Polarization Signatures → View Saved Signatures.
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When the Polarization Signature Viewer appears, a three-dimensional wire mesh 
surface is displayed on the left and a two-dimensional grayscale image of the 
signature is displayed on the right. The statistics for the current signature are listed 
below the plot. 

Viewing Polarization Signature Data

In the Polarization Signature Viewer, you can interactively view the signature details, 
set the axes parameters, change the type of polarization signature being viewed, 
display the three-dimensional plot as a surface or as a wire frame, apply color tables 
to three-dimensional plot and the two-dimensional image, and rotate and move the 
three-dimensional plot.

Displaying Signature Details

An interactive cursor in the two-dimensional polarization signature drives a three-
dimensional cursor on the three-dimensional plot and vice versa. Orientation and 
ellipticity angles and pixel values representing the radar backscatter at each pixel 
track the three-dimensional cursor. These values are listed in the lower left corner of 
the three-dimensional plot in ellipticity, orientation angle, Z-value order.

Figure 13-9: Polarization Signature Viewer
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To plot cross-hairs on both the two-dimensional and three-dimensional plots, click 
and drag the cursor with the left mouse button in the two-dimensional signature or in 
the three-dimensional plot.

Setting Displayed Axes

• To turn the axes off, select Options → Axis:Off.

• To display a single (x,y,z) axis: Options → Axis:Single.

• To display an axis cube, select Options → Axis:Cube.

Changing Z-axis Units

To selectively plot the vertical axis of the polarization signature as intensity, dB 
(decibels) or normalized intensity (intensity divided by the maximum intensity giving 
a 0 to 1 data range), select Polsig_Data → the desired option. 

Setting Z-Axis Ranges 

To change the default range of the z-axis:

1. With the left mouse button, double-click on the z-axis or Select Options → 
Edit Z-Axis Ranges. The Z-Axis Scaling dialog appears.

2. For each signature type (Intensity, dB, Normalized), select whether to use auto 
scaling or custom scaling by clicking the Auto arrow toggle button and 
selecting Yes or No. If you select No, enter the desired minimum and 
maximum scaling values. Auto scaling uses the minimum and maximum of the 
signature data.

3. Click OK.

Displaying Co- and Cross-Polarized Signatures

To plot co-polarized or cross-polarized signatures in the Polarization Signature 
Viewer, select Polsig_Data → Co-Pol or Cross-Pol.

Applying Color Tables

To apply one of ENVI’s standard color tables to both the three-dimensional plot and 
the two-dimensional image:

1. Select Options → Color Tables.

2. Select a color table from the list in the Polsig Color Tables dialog.

The color table is applied to all displayed Polarization Signature Viewers. For more 
information about color tables, see“Applying ENVI Color Tables and Density Slices” 
on page 404.
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Note
The color table only applies to the three-dimensional plot if it is a shaded surface.

Plotting Band Polarization Signatures

When the Polarization Viewer is started by extracting from the current pixel, a 
Frequency pull-down menu with the band names (P, L, and C for AIRSAR, or L and 
C for SIR-C) is available. 

To plot the polarization signature for a band, select that band name from the 
Frequency menu.

Only frequencies (bands) that correspond to the currently opened compressed data 
files are available. 

Displaying Shaded Surfaces

• To display the signature as a three-dimensional shaded surface, select Options 
→ Surface:Shaded. 

• To return to the original three-dimensional wire frame image, select Options 
→ Surface:Wire Frame.

Any color table changes are retained.

Figure 13-10: Polsig Color Tables Dialog
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Changing Plot Colors

To change the background/foreground color scheme of the three-dimensional plot, 
select Options → Background:Black or White.

Rotating and Panning the Three-Dimensional Plot

• To rotate the three-dimensional surface or three-dimensional wire frame 
image, click with the left mouse button outside the signature surface and drag 
the signature to the desired orientation.

• To move the three-dimensional surface or three-dimensional wire frame image 
around on the screen, click with the middle mouse button and drag it to the 
desired location.

• To zoom in and out of the three-dimensional plot, click with the right mouse 
button and drag the cursor to the right to zoom in and drag it to the left to zoom 
out. 

•  To reset the surface to its default position, double click with the left button.

Changing the Default Position 

To change the default position, set the three-dimensional plot to the desired position 
and select Options → Save Current View as Default.

The next time you double-click to reset the image, it will appear in the new default 
position.

Polarization Signature Options

In addition to setting the display parameters, you can load new polarization 
signatures, display previously saved signatures, and copy signatures to another 
Signature Viewer.

Displaying Current Pixel Polarization Signature 

To display a polarization signature for the current pixel or to display a previously 
saved signature, respectively:

To display a polarization signature for the current pixel, select Options → Extract 
Current Pixel.
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Displaying Previously Saved Signatures

To display a previously saved signature:

1. Select Options → Load New Polsig.

2. From the New Polsig Bandname dialog, select the desired input signature from 
the list.

3. Click Apply to apply the changes to the three-dimensional plot.

Copying Signatures

To copy the current polarization signature to a new Polarization Signature Viewer, 
select Options → New Polsig Window.

Restoring Saved Polarization Signatures

1. Select Radar → Polarimetric Tools → Extract Polarization Signatures → 
View Saved Signatures.

A polarization signatures window appears.

2. Select Options → Load New Polsig and select the desired signature from the 
list of available polarization signatures. 

The available polarization signatures are contained in an ENVI file that must already 
be opened in ENVI.

Managing Polarization Signature Plots

Use the File menu to output the polarization signature plot, close plots, and to open 
other input compressed data files.

Specifying a Different File

To change the Stokes file used to calculate the polarization signature, choose File → 
Stokes Matrix Filename and select a new input file.

Note
This option is only available in the Current Pixel Polarization Viewer windows. 
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Outputting Signatures

• To save the three-dimensional signature as an image file, select File → Save 
Plot As → Image File.

• To save the three-dimensional signature as a VRML 2.0 file, select File → 
Save Plot As → VRML.

• To print the three-dimensional signature, select File → Print.

For detailed instructions, see “Display Output Options” on page 446. 

Outputting Statistics to ASCII Files

To save the current polarization signature statistics to an ASCII file:

1. Select File → Save Stats as ASCII.

2. Enter an output filename and click OK.

Tip
If you load another signature, you can save the statistics for it and append them to 
the same file by using the same filename. 

The numbers next to the title in the ASCII file are the pixel locations of the pixel the 
signature was extracted from.

Closing Polarization Signature Viewers

• To close the Polarization Signature Viewer, select File → Cancel. 

• To close all open Polarization Signature Viewers, select Options → Close all 
Polsig Windows.

Displaying Polarization Signatures as Images

Polarization signatures that have been saved as images can be displayed and 
manipulated using standard ENVI image processing functions.

To load the desired signatures into a display, use the Available Bands List (see “The 
Available Bands List” on page 189). 

The signatures are displayed with an orientation angle of 180 degrees and an 
ellipticity of -45 degrees in the upper left image corner 
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The following figure shows polarization signatures and surface plots that have been 
annotated to clarify the relation between the images and the default orientation three-
dimensional polarization signatures.

Figure 13-11: Examples of Two-Dimensional and Three-Dimensional (wire 
frame) Polarization Signatures Displayed as Images and Annotated to Clarify 

Relations Between Two-Dimensional and Three-Dimensional Plots
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Multilooking SIR-C Compressed Data

Use Multilook to reduce speckle noise in SAR data. Use SIR-C Multilook to 
multilook SIR-C data on disk to a specified number of looks, number of lines and 
samples, or azimuth and range resolutions. 

Note
The data to be multilooked must be compressed data. 

1. Select Radar → Polarimetric Tools → Multilook Compressed Data → 
SIR-C Multilook.

2. When the Input Data Product File dialog appears, select a compressed input 
file using the procedures described in “Synthesizing JPL AIRSAR Data” on 
page 1027. 

3. When the SIR-C Multi-look Parameters dialog appears, choose the files to 
multilook by clicking on the file name in the Select Files to Multilook list. 

Figure 13-12: SIR-C Multi-Look Parameters Dialog
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4. Enter the desired number of looks in the Samples (Range) and Lines 
(azimuth) directions or select from the following options.

• To specify the number of pixels desired in the output image, enter the 
values in the Pixels text boxes for the samples and lines.

• To specify the desired output pixel size in meters, enter the values in the 
Pixel Size (m) text boxes for samples and lines.

When one of these parameters is entered, the others are automatically 
calculated to match. For example, if you enter the Pixel Size as 30 m, then the 
corresponding number of pixels and the looks are calculated and change in the 
corresponding text boxes.

Note
Both integer and floating point number of looks are supported.

5. Click Spatial Subset to use standard ENVI Procedures to subset the data.

6. Enter a base name in the Enter Base Name text box. This name will be used as 
the basis for multiple file names, one for each frequency selected. For example 
if you enter sirc as the base name and both C-band and L-band data are being 
processed, then two output files will be created with the names sirc_c.cdp 
and sirc_l.cdp

7. Click OK to multilook the data.

Use the synthesize function to generate image data from the output multilooked 
compressed data files (see “Synthesizing SIR-C Data” on page 1032).

Generating Phase Images

Use Phase Image to generate a phase image for AIRSAR or SIR-C data as a means 
to measure the phase difference between the horizontal and vertical polarizations. 
The phase difference is measured in either radians or degrees and ranges from -π to π 
or -180 degrees to 180 degrees. 

A piecewise linear stretch that sets -π and π to 0 and 0 radians to 255 will map the 
positive and negative angles to the same level. 

Band math could also be used to calculate the absolute value of the result (using 
abs(b1)) (see “Band Math” on page 500).

1. Select Radar → Polarimetric Tools → Phase Image → AIRSAR or SIR-C. 

2. In the file selection dialog, click Open File and select the desired input 
compressed data file.
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3. Click OK. The Phase Image Parameters dialog appears.

4. Click the check boxes to select the bands to use for the phase image 
calculation.

5. Select radians or degrees and perform any spatial subsetting.

6. Choose Memory or File output.

7. Click OK to start the processing.

Generating Pedestal Height Images

Use Pedestal Height Image to generate a pedestal height image for AIRSAR or SIR-
C data as a means to measure the amount of multiple scatter of the radar wave for 
every pixel (higher pedestal heights mean more multiple scattering). The pedestal 
height is the height of a polarization signature above 0 and the value is calculated by 
averaging the following four polarization combinations: Orientation 0 degrees, 
Ellipticity -45 degrees; Orientation 90 degrees, Ellipticity -45 degrees; Orientation 0 
degrees, Ellipticity 45 degrees; Orientation 90 degrees, Ellipticity 45 degrees. See the 
references in “Extracting Polarization Signatures” on page 1036 for more 
information about pedestal height.

1. Select Radar → Polarimetric Tools → Pedestal Height Image → AIRSAR 
or SIR-C. 

2. Select the input compressed data file and click OK. The Pedestal Height Image 
Parameters dialog appears.

3. Click the check boxes to select the bands to use for the pedestal height image 
generation.

4. Select any spatial subsetting. 

5. Choose Memory or File output. 

6. Click OK to start the processing.
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Generating Scattering Classification Images

Use AIRSAR Scattering Classification to generate a classification image that 
discriminates between areas with no vegetation, areas with low and medium level 
vegetation cover, forested areas, and urban areas. Individual scattering mechanism 
images (odd bounce, double bounce, volume scattering) are also generated.

The classification routine uses fully polarimetric AIRSAR data to determine the 
nature of radar scattering mechanisms for each pixel within the scene. Particular 
attention is paid to the presence and nature of vegetation. (This is an IDL 
implementation of routines similar to the MAPVEG program developed by Dr. Tony 
Freeman at JPL.) 

Note
All three (P, L, and C-band) stokes matrix files are required as input for this 
classification.

1. Choose Radar → Polarimetric Tools → AIRSAR Scattering Classification. 
The Input Stokes Matrix Files dialog appears.

2. Click Open File.

3. Select the AIRSAR compressed Stokes matrix files to use for the 
classification. 

To clear the file names in the Input Stokes Matrix Files dialog at any time, 
click Reset or click Cancel to quit the process without processing.

If the file has a valid AIRSAR header with all of the required parameters, the 
filename is listed in one of the Selected Files text boxes in the Input Stokes 
Matrix File dialog, depending on whether it is P-, L-, or C-band data. If you 
followed the suggested file naming convention described previously, correct 
file names for the other two files are automatically entered into the appropriate 
text boxes. If not, you must repeat the file selection process for each band.

Note
If the file does not have a valid AIRSAR header, or if values are missing from 
the header, the AIRSAR Header Parameters dialog appears. Enter the 
missing values as described in “Entering Missing AIRSAR Parameters” on 
page 1029.

4. In the Input Stokes Matrix Files dialog, click OK. The AIRSAR Scatter 
Classification dialog appears.
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5. Enter the kernel size to use to determine the average values used in the 
scattering mechanism determination.

6. Select any spatial subsettting. 

7. Select File or Memory output for both the classification and the rule images 
(the scattering mechanism images).

8. Click OK to start the classification.

A status window appears during processing and the classification and rule images 
appear in the Available Bands List when the process is complete. You can display and 
analyze the classification image and the scattering mechanism images using standard 
ENVI display and analysis routines.
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Using TOPSAR Tools

Use TOPSAR Tools to read integrated TOPSAR data, view the headers, and convert 
the integrated TOPSAR files to physical units. Integrated TOPSAR data typically 
includes a digital elevation model (DEM), C-band VV data, incidence angle image, 
correlation image, and L- and P-band polarimetric AIRSAR data. See “Using 
Polarimetric Tools” on page 1027 for additional analysis tools. For more information 
about the integrated TOPSAR data, see the following reference:

AIRSAR Integrated Processor Documentation, Data Formats, Version 0.01, May 3, 
1995, JPL Publication, Jet Propulsion Laboratory, Pasadena, CA.

Opening TOPSAR Files

To read the raw TOPSAR format data files (Cvv, Incidence Angle, Correlation Image, 
or the DEM):

1. Select Radar → TOPSAR Tools → Open TOPSAR File.

2. When the file selection dialog appears, select the file to be read. 

ENVI automatically extracts the needed header information and places the image 
band into the Available Bands List. 

Note
To read all the TOPSAR files and automatically convert them to physical units see 
the following section. To synthesize AIRSAR images see “Synthesizing JPL 
AIRSAR Data” on page 1027.

Converting TOPSAR Data

Use Convert TOPSAR Data to read and convert the raw TOPSAR format data files 
to physical units (floating point data). The Cvv file is converted to sigma zero. The 
incidence angle file is converted to 0-180 degrees angles. The correlation file is 
converted to 0-1 values. The DEM is converted to meters.

1. Select Radar → TOPSAR Tools → Convert TOPSAR Data.

2. When the file selection dialog appears, select one of the data files. 

3. When the TOPSAR Conversion Parameters dialog appears, select which files 
to convert by clicking in the check boxes next to the file names.
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4. Select a spatial subset, if desired, by clicking on the “Spatial Subset” button 
and using the standard ENVI subsetting.

5. Select output to File or Memory.

ENVI places all of the converted files into a single output file with a band for each 
input file.

Replacing Bad DEM Values

Use Replace Bad Values or DEM Replace Bad Values to replace bad values in 
digital elevation models (DEMs) with values calculated using a surface fitting 
technique. Bad pixels often occur in radar shadows of DEMs generated from 
interferometric radar. The locations of the bad pixels are identified in the DEM image 
when you enter the DN value of the bad pixels or a range of bad values. You can also 
make a mask of the bad pixels and use it to locate the pixels that need to be replaced 
(see “Masking” on page 527). The surface fitting uses Delaunay triangulation to fill 
the bad pixels with triangles calculated from the surrounding good elevation values. 

Note
If there are large holes in the data set, you may see the triangles used to fill them.

1. Select Topographic → Replace Bad Value or Radar → TOPSAR Tools → 
DEM Replace Bad Values.

2. When the DEM Input File dialog appears, select the DEM file and perform any 
subsetting or masking. The Replace Bad Data Parameters dialog appears.

3. Enter a bad pixel value or a range of bad pixel values in the appropriate text 
boxes.

Note
No values are needed if you selected a mask band that contains the locations 
of the bad pixels.

4. Select File or Memory output.

5. Click OK.

The output appears in the Available Bands List.
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Appendix A:

Installing and 
Customizing ENVI

Appendix A describes ENVI hardware and software requirements and some details about 
installing and customizing ENVI. This appendix covers the following topics:
ENVI Hardware Requirements  . . . . . . . .  1056
Installing and Starting ENVI . . . . . . . . . .  1057
Platform Dependencies  . . . . . . . . . . . . . .  1058
Managing Important ENVI Interactions  .  1060
Customizing ENVI  . . . . . . . . . . . . . . . . .  1061

The ENVI Configuration File  . . . . . . . .  1063
The ENVI Main Menu Definition File . .  1071
The ENVI Display Menu Definition File  1072
ENVI Startup Script . . . . . . . . . . . . . . . .  1073
Additional Caching Information  . . . . . .  1074
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ENVI Hardware Requirements

For details on ENVI’s hardware requirements and recommendations, see Installing 
and Licensing ENVI 4.1. In addition to the information provided in Installing and 
Licensing ENVI 4.1, the following items are also required.

Mouse

UNIX — 3-Button Mouse

Windows — Three-button mouse with device driver for all three buttons is 
recommended. Microsoft 2-button mouse or equivalent 2-button mice are supported 
through emulation. The middle button is simulated using the left mouse button and 
the control key pressed simultaneously.

Macintosh — Use the single mouse button as the left mouse button (mouse button 
1); use Option + mouse button to emulate the right mouse button (mouse button 3); 
and use Command + mouse button to emulate the middle mouse button (mouse 
button 2).

Display

1024 x 768, 8-bit or 24-bit color display minimum.

Storage

Approximately 60 MB for program and supporting files (300 MB+ for data).
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Installing and Starting ENVI

Specific instructions for installation of ENVI are provided in the ENVI installation 
instructions and release notes. 

To start ENVI: 

• To start ENVI in UNIX or Mac OS X, enter envi at the UNIX command line. 

• To start ENVI RT in UNIX or Mac OS X, enter envi_rt at the UNIX 
command line. 

• To start ENVI from a Windows system, select from the Windows Task Bar: 
Start → Programs → Research Systems ENVI 4.1 → ENVI or ENVI 
Runtime.

The ENVI main menu appears when the program has successfully loaded and 
executed.

General Runtime Considerations

System memory configuration information has been set to the minimum requirements 
for ENVI in the file envi.cfg. To optimize performance on systems with more 
available RAM, edit this file and change the system memory and caching parameters. 
This and other considerations for optimizing ENVI at runtime are explained in the 
following sections.
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Platform Dependencies

SCSI Tape Support for PCs

ENVI includes tape support for PCs running Microsoft Windows 98, Windows 2000, 
Windows NT version 4.0, and Windows XP. To install the tape drivers for Windows, 
open the aspi_v470.exe self-extracting archive in the \tape32 directory on the 
ENVI for Windows installation CD. Please see the included README.DOC file for 
installation instructions.

Once installed, this routine provides transparent access to ENVI tape tools using the 
ASPI32 interface provided with Windows. All ENVI tape functions work the same as 
their UNIX counterparts on any SCSI tape device that runs under ASPI32. Tape32 for 
ENVI supports reading of many known tape formats including Landsat MSS, Landsat 
TM, AVHRR, AVIRIS, SPOT, etc. See the ENVI Tape Utilities menu for a complete 
list. Other formats that are not directly supported can be read using ENVI’s Scan 
Tape and Dump Tape functions.

• Select File → Tape Utilities → the appropriate tape function.

Setting the Window Drag in Windows NT

ENVI has problems resizing windows in Windows NT if Full Drag is on for window 
resizing. 

Turning off “Full Drag” in Windows NT 4.0

1. Click the right mouse button in the display background. 

2. Select Properties and click on the Plus! tab. 

3. Make sure that Show Window Contents While Dragging is deselected.

Setting the Hypertext Color on UNIX Platforms

When the ENVI Online Help is activated from ENVI on some 8-bit displays there are 
not enough reserved system colors for the links in the text to use a separate color from 
the regular text. In general this is not a problem since the links in the text are also 
underlined, however if the text is the same color you can try to change the default 
hyperlink color to an existing reserved system color. 

• For example, the following line placed in your .Xdefaults file will attempt to 
make the hypertext links red (usually a reserved system color on most 
machines).

HyperHelp*LinkColor: red
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Window Auto-Placement on UNIX

On some UNIX platforms, new windows may require your interaction for screen 
placement. We recommend that you disable this function. 

• For example, on SGI systems using 4Dwm, the following two lines placed in 
the .Xdefaults file will allow auto-placement of windows. See your system 
documentation for other options.

4Dwm*InteractivePlacement: false

4Dwm*ClientAutoPlace: false

Setting the Font on UNIX Platforms

You can select any font available to the X server for your IDL and ENVI session. The 
X windows command xlsfonts lists all the available fonts. The recommended font 
for ENVI is either a 12 or 14-point courier (fixed width), or a 12 or 14-point Times-
Bold (proportional). For more information see the Using IDL manual.

• To enable a particular font for your IDL session, include the following line in 
your .Xdefaults file with your selected font replacing the example.

Idl*fontList: -adobe-times-bold-r-normal--12-120-75-75-p-67-iso8859-1

Color Flashing on 24-Bit UNIX Machines

ENVI displays sometimes flash on 24-bit displays when other programs or the 
windowing system requires some of the colors.

• You may be able to stop this flashing by entering the following into your 
.Xdefaults file.

Idl.gr_visual: TrueColor

Idl.gr_depth: 24

Pseudocolor on 24-Bit UNIX Machines

ENVI automatically configures for both 8-bit and 24-bit displays. For more 
information see the Using IDL manual.

• To run ENVI in an 8-bit mode on a 24-bit display, enter the following line in 
your .Xdefaults file to force your system to operate in 8-bit mode whenever 
IDL is started.

Idl.gr_visual: PseudoColor
Idl.gr_depth: 8
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Managing Important ENVI Interactions

Checking Disk Space 

ENVI doesn’t check for available disk space before creating output files and may fail 
during the file write if insufficient space is available. A work around is to ensure that 
adequate disk resources are available prior to outputting a large file to disk.

Choosing an Output Directory Name Interactively

On the Windows and Macintosh platforms, you cannot select an output directory on 
its own. Only files within a directory may be chosen. For dialogs which request an 
output directory name, you can either select a file in the chosen directory 
interactively, or simply enter a valid directory name in the text box.

Choosing a Tape Device Name Interactively

On the UNIX platform, tape device names do not appear in the interactive file 
selection widget. A valid device name, however, may be entered into the given text 
widget without interactive selection.

No Horizontal Slider for Long List Items in List 
Widgets

On the Windows and Macintosh platforms, long strings in various lists may run off 
the right hand side of the widget without a scroll bar to view the right hand portion of 
the string. Many of these widgets can be resized to show the strings by clicking on a 
corner and dragging to the desired size. 

Tip
In the case of band names in the Available Bands List, you can resize the widget, or 
you can display shortened versions of the bands names by selecting Options → 
Display: Short Band Names. 
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Customizing ENVI

You can setup custom menus, system configuration variables, and even add your own 
ENVI routines to the ENVI menu. Several files are used for custom configurations 
(located in the /menu and /map_proj subdirectories):

colors.txt — ENVI graphics colors rgb file (see “ENVI Graphic Colors File” in 
Appendix B).

display.men — Display menu file (see page “The ENVI Display Menu Definition 
File” on page 1072).

e_locate.pro — ENVI directory locator file.

envi.cfg — System configuration file (see “The ENVI Configuration File” on 
page 1063).

envi.men — Main menu file (see “The ENVI Main Menu Definition File” on 
page 1071).

filetype.txt — Contains a list of ENVI file types and the routine name used to read 
the files that need specialized spatial and spectral readers.

map_proj.txt — User-defined map projections file (see “ENVI Map Projections 
File” on page 1085).

sensor.txt — List of sensor types that appears in the ENVI header (see “ENVI Sensor 
File (sensor.txt)” on page 1084).

useradd.txt — Used to define parameters for user-defined plot routines, Spectral 
Analyst routines, user-defined map projection routines, user-defined map projection 
units, and/or user-defined RPC readers. (see page 1064 for details)

usersym.txt — Contains user-defined symbols.

For example, if you want to setup your own private ENVI configuration in a 
directory, copy the above files from the installation directory to your personal 
directory. ENVI first searches for the file envi.cfg using the IDL !PATH variable, 
so the directory where you place the local copy of envi.cfg must be included in 
your IDL_PATH variable *BEFORE* the standard $IDL_DIR/lib entry. There 
must also be a file with a “.pro” or “.sav” extension in this directory as well, which is 
why the e_locate.pro dummy file is included. Once the envi.cfg file is located, 
ENVI uses this file to locate the other user definable files; envi.men, 
display.men, map_proj.txt, and colors.txt. 
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The configuration items “default envi menu file,” “default display menu file,” 
“default graphic colors file,” and “default map projection file” in “envi.cfg” can be 
used to tell ENVI where local copies of these files may be found. If any of these 
entries are left blank or are invalid, ENVI searches for the files in the default ENVI 
installation directories.

Once ENVI successfully locates your private copies of these files, they may be edited 
for your own configuration and menu setups. See the following section for details 
about the ENVI configuration and menu files.
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The ENVI Configuration File

Use the ENVI configuration file (envi.cfg) to customize ENVI and to optimize 
specific hardware configurations to suit your preferences. The file is an ASCII text 
file containing keywords and associated values. The way that ENVI uses memory, 
handles color, and other setup parameters can be changed by editing this file and 
entering new values. 

• Edit the file using a text editor or word processor, or change the file from 
within ENVI by selecting File → Preferences on the ENVI main menu.

Note
The envi.cfg file must be in a directory that is in the IDL search path.

Configuration File Details

The ENVI configuration file must have the keywords “ENVI CONFIGURATION 
FILE” at the top of the ASCII file. Keywords determine the ENVI startup 
configuration. Each keyword option of the envi.cfg configuration file is described 
below.

alternate header directory — This directory is used primarily for storage of headers 
for files on read-only devices such as CD-ROM. If ENVI is unable to write a header, 
it writes into the alternate header directory. If ENVI is unable to locate a header file, it 
will look in the alternate header directory.

annotation scale bar titles — Used to change the spelling of the annotation scale bar 
units, (e.g., changing “kilometers” to “kilometres”). 

auto append output filename extensions — Use to set whether or not to append the 
default extensions to the entered filename.

command line blocking — Determines if you have access to IDL command line 
programming during an ENVI session.

configuration name — A unique name assigned to this particular configuration.

default color table file — Specifies a user file to define the color tables (optional).

default data directory — This is the specified directory for input images and will be 
the default directory when ENVI is started.

default display menu file — Specifies a user file that defines the display menu 
(optional).
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default display shortcut menu file — Specifies a user file that defines the items in 
the display shortcut menu.

default envi menu file — Specifies a user file that defines the ENVI main menu 
(optional).

default graphic colors file — Specifies a user file to define the graphic colors 
(optional).

default math expression file — Specifies a user file to predefined math expression, 
which can be loaded by default into the Previous Expressions field of the Band Math 
and Spectral Math dialogs.

default map projection file — Specifies a user file that defines map projections 
(optional).

default output directory — This is the specified directory for output files and will 
be the default directory every time ENVI output files are written unless another 
specific path is specified.

default output page offset — Specifies the default x and y page offset for multiple 
page postscript output in inches or centimeters.

default output page size — Specifies the default page size for postscript output in 
either cm or inches.

default previous files file — (optional) Specifies a file name used to store the names 
of the 20 previous files opened in ENVI using the Open Image File menu item. 

default save_add directory — (optional) If you place your custom IDL routines in 
this directory they will automatically be restored or compiled when ENVI is started.

default spectral library directory — This is the default directory every time ENVI 
spectral library file selection functions are started.

default startup script file — (optional) Specifies a file name that contains the script 
that executes upon startup of ENVI.

default tmp directory — Used to store ENVI temporary files.

default useradd text file — (optional) Contains button name, event handler, etc., for 
user-defined plot routines, spectral analyst routines, user-defined map projection 
routines and/or user-defined map projection units (see User Defined Units in the 
ENVI Programmer’s Guide).
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display default stretch — Designates the default stretch that will be used for images 
loaded into ENVI display windows. Options are n% linear (where n is a specific 
value for example 0% linear, 2% linear, etc.), m n linear (where m is data minimum 
and n is data maximum), n gaussian (where n is the number of standard deviations 
about the mean), equalize (for histogram equalization), and square root (for square 
root stretch).

display retain value — Sets the control of the backing store. A retain value of 0 
specifies no backing store. A retain value of 1 requests that the server or window 
system provide backing store. A retain value of 2 (default) specifies that IDL provide 
backing store.

display window style — Determines which combination of three windows will 
appear.

exit idl on exit from envi — Determines if IDL is automatically exited when exiting 
from ENVI or if the IDL session remains open.

geo grid box — Controls whether the geo grid box is displayed or not.

geo grid box color — Sets the foreground color of the geo grid box.

geo grid box line style — Sets the line style of the sides of the geo grid box.

geo grid box thick — Sets the thickness of the sides of the geo grid box.

geo grid corners — Controls whether the corners of the geo grid are shown or not.

geo grid corners color — Sets the foreground color of the corners of the geo grid.

geo grid corners thick — Sets the thickness of the corners of the geo grid.

geo grid font — Sets the font of the labels of the geo grid.

geo grid labels — Controls whether the labels of the geo grid are displayed or not.

geo grid labels color — Sets the foreground color of the labels of the geo grid.

geo grid labels size — Sets the font size of the labels of the geo grid.

geo grid labels thick — Sets the thickness of the labels of the geo grid.

geo grid lines — Controls whether the lines of the geo grid are displayed or not.

geo grid lines line styles — Sets the line style of the lines of the geo grid.

geo grid lines thick — Sets the thickness of the lines of the geo grid.

geo grid x-axis labels — Controls whether the x-axis labels of the geo gird are 
displayed in a horizontal or vertical orientation.
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geo grid y-axis labels — Controls whether the y-axis labels of the geo gird are 
displayed in a horizontal or vertical orientation.

image tile size (MB) — Designates the tile size that will be used by ENVI for 
processing. Tiling is an internal ENVI image segmentation technique that allows the 
system to work on images larger than available RAM. This value should be set to 
about 1/10th the total cache size described on page 1069. Images of any size can be 
viewed in ENVI, but this field determines how much of that image is kept in memory 
at any given time.

image window default xsize and image window default ysize — Sets the initial size 
of the full resolution image windows in pixels.

image window scroll bars — Determines whether the main image display has scroll 
bars.

interactive stretch auto apply — Sets whether on not to automatically apply 
changes to the stretch in Interactive Stretching. This can also be toggled on/off from 
the Interactive Stretching dialog.

main menu orientation — Controls whether the ENVI main menu is displayed in a 
horizontal or vertical orientation.

map grid box — Controls whether the map grid box is displayed or not.

map grid box color — Sets the foreground color of the map grid box.

map grid box line style — Sets the line style of the sides of the map grid box.

map grid box thick — Sets the thickness of the sides of the map grid box.

map grid corners — Controls whether the corners of the map grid are shown or not.

map grid corners color — Sets the foreground color of the corners of the map grid.

map grid corners thick — Sets the thickness of the corners of the map grid.

map grid font — Sets the font of the labels of the map grid.

map grid labels — Controls whether the labels of the map grid are displayed or not.

map grid labels color — Sets the foreground color of the labels of the map grid.

map grid labels size — Sets the font size of the labels of the map grid.

map grid labels thick — Sets the thickness of the labels of the map grid.

map grid lines — Controls whether the lines of the map grid are displayed or not.

map grid lines line styles — Sets the line style of the lines of the map grid.
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map grid lines thick — Sets the thickness of the lines of the map grid.

map grid x-axis labels — Controls whether the x-axis labels of the map gird are 
displayed in a horizontal or vertical orientation.

map grid y-axis labels — Controls whether the y-axis labels of the map gird are 
displayed in a horizontal or vertical orientation.

max number of histogram bins — Indicates the maximum number of bins to use 
during histogram calculation.

max number of items for multilist — Indicates the maximum number of items to be 
listed in a widget. If the number of items listed is greater than the specified number, 
ENVI uses an alternate check box mode to speed up scrolling of the list.

max number of items in pull-down menus — Indicates the maximum number of 
items listed in a pull-down menu. If the number of items is greater than this 
maximum value then the pull-down menu breaks the items into sub-menus each 
containing only this max number of items or fewer. This keeps long lists of items 
from running off the display.

max number of vertices for memory — Indicates maximum number of polygon 
vertices for vector files loaded into ENVI. If the number of vertices is greater than the 
specified number, ENVI will not load the polygons into memory, but will create an 
ENVI vector (.evf) file.

menu border size and edge border size — Sets the window border sizes according 
to system specific parameters to allow consistent spacing of window.

number of colors per rgb image and number of colors per gray scale image — 
ENVI runs on 8- or 24-bit color workstations. These settings are for 8-bit mode. Each 
display window occupies a certain range of entries in the color table. These two 
parameters determine how many colors from the 256 colors in the color table are used 
for each RGB “color quantized” image display and for each grayscale display.

open applicable formats automatically to memory — sets whether or not to open 
BMP, HDF, JPEG, JPEG2000, PICT, SRF, and XWD external files directly to 
memory instead of prompting for file or memory output.

plot window default axis thickness — Sets the thickness of the X and Y axis lines 
(1 is normal).

plot window default background color — Sets the plot background color.

plot window default charsize — Sets the default character size.

plot window default font — Sets the default font for the axis labels and title.
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plot window default foreground color — Sets the plot foreground color.

plot window default key margin — Sets the size of the margin when the key or data 
labels are turned on.

plot window default minor ticks — Sets the number of minor tick marks.

plot window default tick length — Sets the length of the major tick marks, 
measured as a ratio of the axis length normalized to 1.0, (e.g., a length of .02 results 
in ticks that are 2% of the length of the entire axis).

plot window default xmargin — Two values used to set the size (in characters) of 
the margins around the plot axes. The first value is the left margin and the second 
value is the right margin.

plot window default xsize/ysize — Sets the initial size of a plot window in pixels.

plot window default ymargin — Two values used to set the size (in characters) of 
the margins around the plot axes. The first value is the bottom margin and the second 
value is the top margin.

scroll and zoom window default position — Allows selection of the initial position 
(left, right, above, below, within, off) of the zoom and scroll windows relative to the 
main image window.

scroll window default xsize and scroll window default ysize — Sets the initial size 
of the scroll windows

status window for input data reading — Specifies whether a status window will 
appear during input of data files.

status window for input data reading — Sets whether or not to show a status 
window when loading data of BIL or BIP format to a display window.

tape device name — Default system device name for tape drives. A typical example 
for a SCSI tape drive on a UNIX machine might be /dev/rst0 or /dev/rmt2h—check 
your system documentation for the correct default device name for your specific 
installation.

thread pool maximum elements — The maximum number of elements in a 
computation that will be processed using the thread pool. Computations with more 
than this number of elements will not use the IDL thread pool. Set this parameter if 
large jobs are causing virtual memory paging on your system. Setting this value to 0 
removes any limit on maximum number of elements. The default is 0.
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thread pool minimum elements — The number of data elements (each element 
being a single data value of a particular data type) in a computation that are necessary 
before IDL will use the thread pool. If the number of elements is less than the number 
you specify, ENVI will perform the computation without using the thread pool. Use 
this parameter to prevent ENVI from using the thread pool on tasks that are too small 
to benefit from it. The default is 100000.

thread pool number of processors — The number of threads that IDL will use in 
thread pool computations. The default value is equal to the value of the number of 
CPUs on your system, so that each thread will have the potential to run in parallel 
with the others. Note that there is no benefit to using more threads than your system 
has CPUs. However, depending on the size of the problem and the number of other 
programs running on the system, there may be a performance advantage to using 
fewer CPUs.

total cache size (MB) — Designates a soft limit for the amount of system RAM the 
program will expect to use. ENVI has an internal memory management/cache 
scheme that attempts to limit the amount of memory used. This is designed to avoid 
“unable to allocate array” errors in IDL and segmentation fault/core dumps back to 
system level from IDL on some platforms. This type of error results when the 
program attempts to use more memory than is available. Higher values for the cache 
size will speed up spatial processing functions. Set this value to slightly less than the 
amount of available system RAM (less on multi-user systems) (see “Additional 
Caching Information” on page 1074).

user defined motion routine — Specifies a user procedure that is called when the 
mouse is moved within a display window (optional; see the ENVI Programmer’s 
Guide). 

user defined move routine — Specifies a user procedure that is called when the 
zoom location is moved within a display window (optional; see User Move Routines 
in the ENVI Programmer’s Guide).

window graphic color — Determines the color of the graphics in the zoom and 
scroll windows.

zoom window default position — Determines the location of the zoom window, if 
only the zoom and scroll windows are displayed.

zoom window default xsize and zoom window default ysize — Sets the initial size 
of the zoom windows in pixels.
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zoom window interpolation — Determines the interpolation method used in the 
zoom window zoom.

zoom window scroll bars — Determines whether the zoom window has scroll bars.

zoom window zoom increment — Sets the integer zoom factor for each subsequent 
zoom event.
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The ENVI Main Menu Definition File

The ENVI main menu Definition File is named envi.men. The entire menu is user-
configurable. Existing items can be repositioned to suit your needs and new items can 
be added. ENVI does not distinguish between ENVI and user event handlers, thus 
allowing easy integration of user events (see User Functions are Widget Event 
Handlers in the ENVI Programmer’s Guide). One of ENVI’s most powerful features 
is this potential for customization. You should take the time to customize the menu to 
your liking. The specifics of how to configure the menu are included in the menu file 
text. 

• To use your created main menu file as the default menu, enter the complete 
filename in the envi.cfg file or enter it using File → Preferences.
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The ENVI Display Menu Definition File

The ENVI Display Menu Definition File is named display.men. The entire menu is 
user-configurable. Existing items can be repositioned to suit your needs and new 
items can be added. Instructions for customizing the menu are included in the menu 
file text. 

• To use your own display menu file as the default menu, enter the complete 
filename in the envi.cfg file or enter it using File → Preferences.
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ENVI Startup Script

The ENVI startup script is used to open files, load bands into displays, open ENVI 
vector files, and open region of interest files. This script is automatically executed 
when ENVI is started if a filename is set in the envi.cfg file. 

• To execute an ENVI startup file at any time during a session, select File → 
Execute Startup Script function.

The startup script consists of ASCII commands that can be entered using a text editor. 

An example of a startup file:

open file = e:\data\canyon\canyon.tm
load bands = 4,3,2
open file = e:\data\canyon.tif
load band = 1
open roi = e:\data\canyon\canyon.roi

The available startup commands and their formats are described here with the 
keywords shown in italics.

Opening an Image File

Open File = filename

Loading a Grayscale Image into a New Display 

Load Band = band number

The band number refers to the file opened in the line above the load band command.

Loading an RGB Color Image into a New Display

Load Bands = R band number, G band number, B band number

The band numbers refer to the file opened in the line above the load band command.

Opening an ENVI Vector File

Open evf = filename

Opening a Region of Interest file

Open ROI = filename

Opening a Saved Display Group

Open Display Group = display group filename
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Additional Caching Information

Total Cache Size

ENVI uses an internal caching method to monitor memory management and optimize 
memory usage. None of this memory management impacts you unless memory-only 
items need to be stored to a disk file. All caching of raw data and display data is 
hidden and does not effect any open windows or processing functions. 

You set the total cache size for ENVI to use as described in “The ENVI Configuration 
File” on page 1063. This number should be a function of a machine’s physical RAM, 
number of users, and other applications used while ENVI is active. If no other users 
are using the machine, set the total cache size to 50% to 75% of the total RAM. For 
example, for a machine with 32 Mbytes of RAM, use something less than 23 Mbytes 
and for a machine with 100 Mbytes of RAM use something less than 75 Mbytes for 
the total cache size.

Note
These are only suggestions; ENVI will work with any numbers you supply.

The cache system tracks the total memory used by all data in the system. If the size of 
a new process or display request exceeds the available memory, ENVI will remove 
some items from cache until there is enough memory to store the result. The first 
items removed are the raw data read from disk files, (oldest-by-use first), then the 
byte-scaled display images are removed (oldest-by-use first), and finally, if enough 
memory has not been freed, the memory-only items will be removed after requesting 
you to save/remove them. If, however, the data in the current request is a memory-
only item, you are required to store (not remove) the item. If the request still exceeds 
the total cache size with nothing in memory, the operation is still attempted. 

Tip
You should, however, periodically store memory images to disk to avoid cases 
where the “in memory” request is greater than the total cache size.

Image Tile Size

ENVI uses the “image tile size” keyword to segment the processing of large images. 
It specifies the amount of data processed in each segment (see “Tiling Operations” on 
page 31). A recommended tile size is 1/10 of the total cache size. Image tile size only 
affects the processing of data, not the displaying of images.
Additional Caching Information ENVI User’s Guide



Appendix B:

ENVI File Formats
This appendix covers the following topics:
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ENVI uses a generalized raster data format consisting of a simple “flat binary file” 
and a small associated ASCII (text) header file. This approach permits ENVI’s 
flexible use of nearly any image format, including those with embedded header 
information. The text header provides ENVI with information about the dimensions 
of the image, the internal header if present, the data format, and other pertinent 
information.

The generalized raster data is stored as a binary stream of bytes either in band 
sequential (BSQ), band interleaved by pixel (BIP), or band interleaved by line (BIL) 
format. In its simplest form, the data is in BSQ format, with each line of the data 
followed immediately by the next line in the same spectral band. This format is 
optimal for spatial (X, Y) access of any part of a single spectral band. Images stored 
in BIP format have the first pixel for all bands in sequential order, followed by the 
second pixel for all bands, followed by the third pixel for all bands, etc., interleaved 
up to the number of pixels. This format provides optimum performance for spectral 
(Z) access of the image data. Images stored in BIL format have the first line of the 
first band followed by the first line of the second band, followed by the first line of 
the third band, interleaved up to the number of bands. Subsequent lines for each band 
are interleaved in similar fashion. This format provides a compromise in performance 
between spatial and spectral processing.

Because ENVI uses ASCII header files that are built “on-the-fly” if required, you 
typically do not need to convert your image file formats. Additionally, the flexible file 
format allows direct utilization of generic BSQ, BIL, or BIP files. ENVI has been 
tested on numerous data types including MSS, TM, SPOT, ERS-1, AVHRR, AVIRIS, 
GERIS, GEOSCAN, TIMS, digitized aerial photographs, DEM data, AIRSAR, 
RADARSAT, and SIR-C data. All of these data types are supported in their native 
formats (byte, integer, floating-point, etc.).
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ENVI Header Format

The ENVI header file contains information used to read an image data file. It is 
normally created the first time a data file is accessed by ENVI. The required 
information is entered into the Header Info dialog, which appears when the file is 
opened and can be edited and changed later using the ENVI Edit Header function. 
You can generate an ENVI header outside ENVI using a text editor. A description of 
the required characteristics for an ENVI header file follows.

Note
Comments can be added to ENVI header files by inserting a line with a semicolon 
as the first character. These lines are ignored when the header file is parsed. 
Comments can appear anywhere within a header file but must be an entire line (and 
the semicolon must be the first character of that line). Comments can not follow a 
keyword/value pair.

The file must start with the text string ENVI to be recognized by ENVI as a native file 
header. Keywords within the file are used to indicate critical file information. The 
following are valid keywords: 

description - a character string describing the image or processing performed.

samples - number of samples (pixels) per image line for each band.

lines - number of lines per image for each band.

bands - number of bands per image file.

header offset - refers to the number of bytes of imbedded header information present 
in the file (for example 128 bytes for ERDAS 7.5 .lan files). These bytes are 
skipped when the ENVI file is read.

file type - refers to specific ENVI defined file types such as certain data formats and 
processing results. The available file types are listed in the filetype.txt file 
described on page 1083. The file type ASCII string must match an entry in the 
filetype.txt file verbatim, including case.
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data type - parameter identifying the type of data representation, where 1=8 bit byte; 
2=16-bit signed integer; 3=32-bit signed long integer; 4=32-bit floating point; 5=64-
bit double precision floating point; 6=2x32-bit complex, real-imaginary pair of 
double precision; 9=2x64-bit double precision complex, real-imaginary pair of 
double precision; 12=16-bit unsigned integer; 13=32-bit unsigned long integer; 
14=64-bit signed long integer; and 15=64-bit unsigned long integer.

interleave - refers to whether the data are band sequential (BSQ), band interleaved by 
pixel (BIP), or band interleaved by line (BIL).

sensor type - refers to specific instruments such as Landsat TM, SPOT, RadarSat, 
etc. The available sensor types are listed in the sensor.txt file described on page 
1084. The sensor type ASCII string defined here must match one of the entries in the 
sensor.txt file verbatim., including case.

byte order -describes the order of the bytes in integer, long integer, 64-bit integer, 
unsigned 64-bit integer, floating point, double precision, and complex data types; 
Byte order=0 is Least Significant Byte First (LSF) data (DEC and MS-DOS systems) 
and byte order=1 is Most Significant Byte First (MSF) data (all others - SUN, SGI, 
IBM, HP, DG).

x-start and y-start - parameters define the image coordinates for the upper left hand 
pixel in the image. The values in the header file are specified in “file coordinates,” 
which is a zero-based number.

map info - lists geographic coordinates information in the order of projection name 
(UTM), reference pixel x location in file coordinates, pixel y, pixel easting, pixel 
northing, x pixel size, y pixel size, Projection Zone, North or South for UTM only.

Note
In ENVI, pixel values always refer to the upper left corner of the pixel. Map 
coordinates also typically refer to the upper left corner of the pixel. However, if you 
entered “magic pixel” coordinates in the ENVI header, the map coordinates would 
refer to the x,y coordinates entered (e.g., x=1.5, y=1.5 would make the map 
coordinates refer to the center of the pixel).

projection info - parameters that describe user-defined projection information. This 
keyword is added to the ENVI header file if a user-defined projection is used instead 
of a standard projection. This information can be used to read this file in installations 
of ENVI that do not contain this user-defined projection in its map_proj.txt file.
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default bands - if set, indicates which band numbers to automatically load into the 
Available Bands List’s grayscale or R, G, and B text boxes every time the file is 
opened. By default, a new image is automatically loaded when a file that has default 
bands defined in its header is opened. If only 1 band number is used, then a grayscale 
image is loaded. 

wavelength units - text string indicating which units the wavelengths are in.

reflectance scale factor - the value that, when divided into your data, would scale it 
from 0 - 1 reflectance.

z plot range - values indicating the default minimum and maximum values for Z 
plots.

z plot average - values indicate the number of pixels in the X and Y directions to 
average for Z plots.

z plot titles - allows entry of specific X and Y axis titles for Z plots.

data ignore value - currently used only in ENVI programming (see 
ENVI_FILE_QUERY for more information).

pixel size - indicates X and Y pixel size in meters for non-georeferenced files.

default stretch - determines what type of stretch (% linear, linear range, gaussian, 
equalize, square root) is used when the image is displayed.

band names - allows entry of specific names for each band of an image. 

wavelength - lists the center wavelength values of each band in an image. Units 
should be the same as those used for the FWHM and set in the wavelength units 
parameter.

fwhm - lists full-width-half-max values of each band in an image. Units should be the 
same as those used for wavelength and set in the wavelength units parameter.

bbl - lists the bad band multiplier values of each band in an image, typically zero for 
bad bands and one for good bands.

data gain values - gain values for each band.

data offset values - offset values for each band.
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Example ENVI Header File

A typical ENVI Header File is shown below:

ENVI
description = {
  Registration Result. Method: 1st degree Polynomial w/ nearest 
neighbor [Wed Dec 20 23:59:19 1995] }
samples = 709
lines   = 946
bands   = 7
header offset = 0
file type = ENVI Standard
data type = 1
interleave = bsq
sensor type = Landsat TM
byte order = 0
map info = {UTM, 1, 1, 295380.000, 4763640.000, 30.000000, 
30.000000, 13, North}
z plot range = {0.00, 255.00}
z plot titles = {Wavelength, Reflectance}
pixel size = {30.000000, 30.000000}
default stretch = 5.0% linear
band names = {
 Warp (Band 1:rs_tm.img), Warp (Band 2:rs_tm.img), Warp (Band 
3:rs_tm.img), Warp (Band 4:rs_tm.img), Warp (Band 5:rs_tm.img), 
Warp (Band 6:rs_tm.img), Warp (Band 7:rs_tm.img)}
wavelength = {
  0.485000,  0.560000,  0.660000,  0.830000,  1.650000, 11.400000,  
2.215000}
fwhm = {
 0.070000, 0.080000, 0.060000, 0.140000, 0.200000, 2.100000, 
0.270000}

Class Keywords for Header Files

Some types of files may have additional keywords for specific required information. 
For example, classification results files will contain the additional keywords: classes, 
which defines the number of classes, including the unclassified, class lookup, which 
lists RGB color definitions for each respective class, and class names.
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These additional keywords with values assigned typically would consist of the 
following additional lines added to the .hdr file:

classes = 4
class lookup = {  0,  0,  0,255,  0,  0,  0,255,  0,255,255,  0}
class names = {
  Unclassified,
  region 1,
  region 2,

region 3}

Spectra Keywords for Header Files

Spectral library files will contain the additional keyword: spectra names. This 
additional keyword contains a comma-separated list of ASCII names enclosed in 
curly brackets. For example,

spectra names = {
ACTINOLITE IN-4A, ALBITE TS-6A, ALMANDINE GARNET NS-4A, ALUNITE 
SO-4A,
AMBLYGONITE P-3A, ANALCIME TS-18A, ANATASE SYNTHETIC O-12A,
ANDESINE TS-4A, ANGLESITE SO-10A, ANHYDRITE SO-1A, ANORTHITE TS-
5A,
ANTHOPHYLLITE IN-8A, ANTLERITE SO-11A, APATITE P-1A, APHTHITALITE 
SO-9A}
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ENVI Graphic Colors File

This file is a space-separated ASCII file that defines the graphic colors used in ENVI. 
The file has four columns for the red, green, and blue DN values, and color name. 
Colors can be added to this file using a text editor or colors can be changed by 
selecting File → Preferences and clicking the System Graphics Colors button to 
open the editing window (see “Editing System Graphic Colors” on page 176). A 
portion of the ENVI colors.txt file is shown below.

0   0   0   Black
255 255 255 White
255 0   0   Red
0   255 0   Green
0   0   255 Blue
255 255 0   Yellow
0   255 255 Cyan
255 0   255 Magenta
176 48  96  Maroon
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ENVI File Type File (filetype.txt)

This file is an ASCII file that lists the specific file types that are used in the ENVI 
header to identify special files. These file types include ENVI specific files such as 
meta files, classification results, virtual mosaics, spectral libraries, and fft results. The 
file types also include data specific formats such as ADRG and AVHRR. Files such 
as TIFF and BMP are also recognized as well as ERDAS 8.x and PCI files. The file 
type field allows these files to have an ENVI header but still exist in their native 
formats. The filetype.txt file contains the list of the recognized file types. You 
can edit this file and add your own (user-defined) file types. The first column in the 
file contains the full file type name, the second column contains a shorter abbreviated 
name which is used in the Header Info dialog (so the widget is not too big), and the 
third column contains the name of the routine used to read the data (see Chapter 7, 
“Custom File Input” of the ENVI Programmer’s Guide).

{ADRG} {ADRG} {envi_read_adrg}
{AVHRR CD} {AVHRR CD} {envi_read_avhrr}
{HDF Scientific Data} {HDF SD} {envi_read_hdf_sd}
{HDF Modis Simulator} {HDF MAS-50} {envi_read_modis}
{NOAA DMSP} {NOAA DMSP} {envi_read_dmsp}
{NLAPS CD} {NLAPS CD} {envi_read_nlaps}
{PDS Image} {PDS Image} {envi_read_pds}
{RADARSAT} {RADARSAT} {envi_read_radarsat}
{Spot CD} {Spot CD} {envi_read_spot}
{BMP} {BMP} {envi_read_bmp}
{TIFF} {TIFF} {envi_read_tiff}
{ERDAS 8.X} {ERDAS 8.X} {envi_read_erdas}
{PCI} {PCI} {envi_read_pci}
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ENVI Sensor File (sensor.txt)

This file is an ASCII file that lists sensor types that can be selected in the sensor 
parameter in an ENVI header. You can modify or add new sensors to the list using 
any text editor. A portion of the sensor list is shown here:

ADAR
ADEOS
ADRG
Air Photo
AIRSAR
ASTER
AVHRR
AVIRIS
CASI
DEM
DMSP
EARTHWATCH

Sensor types specified in the ENVI header file must match an entry in this list 
verbatim, including case.
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ENVI Map Projections File

This file is an ASCII file that defines the map projections used in ENVI. Use Build 
Customized Map Projection to build customized map projections (see “Building 
Customized Map Projections” on page 923). A portion of the ENVI map_proj.txt 
file included in the ENVI distribution is shown here:

; ENVI CUSTOMIZED PROJECTION FILE
;
; 3 - Transverse Mercator
;   a, b, lat0, lon0, x0, y0, k0, [datum], name
;
; 4 - Lambert Conformal Conic
;   a, b, lat0, lon0, x0, y0, sp1, sp2, [datum], name
;
; 5 - Hotine Oblique Mercator A
;   a, b, lat0, lat1, lon1, lat2, lon2, x0, y0, k0, [datum], name
;
; 6 - Hotine Oblique Mercator B
;   a, b, lat0, lon0, azimuth, x0, y0, k0, [datum], name
;     azimuth:azimuth of central line (degrees east of north)
;
; 7 - Stereographic (ellipsoid)
;   a, b, lat0, lon0, x0, y0, k0, [datum], name
;
; 9 - Albers Conical Equal Area
;   a, b, lat0, lon0, x0, y0, sp1, sp2, [datum], name
;
; 10- Polyconic
;   a, b, lat0, lon0, x0, y0, [datum], name
;
; 11- Lambert Azimuthal Equal Area
;   a, b, lat0, lon0, x0, y0, [datum], name
;
; 12- Azimuthal Equadistant
;   r, lat0, lon0, x0, y0, name
;
; 13- Gnomonic
;   r, lat0, lon0, x0, y0, name
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ENVI Ellipsoid File (ellipse.txt)

This file contains a list of the ellipsoids available for use in ENVI. It is a comma-
separated ASCII file containing three columns for the ellipsoid name, major axis in 
meters (a), and minor axis in meters (b). You can modify or add new data to the file 
using any text editor. A portion of the ENVI ellipse.txt file is shown here:

Airy, 6377563.4, 6356256.9
Australian National, 6378160.0, 6356774.7
Bessel 1841, 6377397.2, 6356079.0
Clarke 1858, 6378293.0, 6356619.0
Clarke 1866, 6378206.4, 6356583.8
Clarke 1880, 6378249.1, 6356514.9
Clarke IGN, 6378249.2, 6356515.0
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ENVI Datum File (datum.txt)

This file contains a list of the datums available for use in ENVI. It is a comma-
separated ASCII file containing five columns for the datum name, ellipsoid name, x, 
y, and z offsets from the WGS84 datum. You can edit this file using any text editor. A 
portion of the ENVI datum.txt file is shown here:

Adindan, Clarke 1880, -166, -15, 204
AFG, Krassovsky, -43, -163, 45
Ain El Abd 1970, International, -150, -251, -2
Alaska (NAD-27), Clarke 1866, -5, 135, 172
Alaska/Canada NAD-27, Clarke 1866, -9, 151, 185
Anna 1 Astro 1965, Australian National, -491, -22, 435
ARC-1950 mean, Clarke 1880, -143, -90, -294
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ENVI State Plane Projection Files

The sp_nad27.txt and sp_nad 83.txt files contain a list of the state plane projections 
available for use in ENVI. The sp_nad27.txt file uses the North American 1927 
datum to define the projections. The sp_nad83.txt file uses the North American 1983 
datum to define the projections. These files are ASCII files with the first column 
containing the NOS zone #, the second column containing the USGS zone #, and the 
last column has the projection name in alphabetical order. These files can be used to 
find state plane zone #s. A portion of the ENVI sp_nad27.txt file is shown here:

101, 3101, 3, 6378206.4, 6356583.8, 30.500000,  -85.833333, 
152400.0, 0.0, 0.999960, Alabama East
 102, 3126, 3, 6378206.4, 6356583.8, 30.000000,  -87.500000, 
152400.0, 0.0, 0.999933, Alabama West
 201, 3151, 3, 6378206.4, 6356583.8, 31.000000, -110.166667, 
152400.0, 0.0, 0.999900, Arizona East
 202, 3176, 3, 6378206.4, 6356583.8, 31.000000, -111.916667, 
152400.0, 0.0, 0.999900, Arizona Central
 203, 3201, 3, 6378206.4, 6356583.8, 31.000000, -113.750000, 
152400.0, 0.0, 0.999933, Arizona West
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ENVI Spectral Library Files

ENVI Spectral Library files are stored in ENVI binary image format with the number 
of samples equal to the number of bands and the number of lines equal to the number 
of spectra in the library. The file type is set to spectral library in the header and there 
are associated wavelengths. The ENVI spectral libraries can be displayed and 
enhanced using the standard ENVI image display and analysis routines (see “Spectral 
Libraries” on page 746 and Appendix C, “ENVI Spectral Libraries”).
ENVI User’s Guide ENVI Spectral Library Files
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ENVI Previous Files List

The ENVI Previous Files List contains a list of the last 20 files opened in ENVI. The 
complete path and file name of the listed files are stored in a file named in the 
envi.cfg file. In front of each file name is a + or –. Files with a + are sticky 
meaning they will remain on the top of the list and not fall off the end of the list. Files 
with a – will move down the list as new files are opened, and eventually fall off the 
list. A portion of a previous file list is shown below.

+E:\data\canyocanyon.tm
-E:\data\topsar\top_l.cub
-D:\rsi\envi30\spec_lib\usgs_sli.dat
-E:\data\canyon\tm800.img
-E:\data\dem\denver-e.img

You can edit the Previous Files List by selecting File → Preferences and clicking the 
Previous Files List button to open the editing window (see “Setting ENVI 
Preferences” on page 174).
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Other ENVI ASCII Files

Other ENVI ASCII file formats are described in the following sections. Files that are 
not described below (e.g., .ann, .roi, etc.) are files that are in a binary format.

Bad Lines List (.bll)

The ENVI Bad Line Removal files are used to save and recall lists of bad lines. Bad 
Line List files are simple ASCII files with the .bll file extension. The keywords 
ENVI Bad Lines List must appear on the first line of the file. Individual bad line 
locations (in pixels) are listed in subsequent lines, one bad location per line. An 
example of a typical .bll file is shown here:

ENVI Bad Lines List
111
532
729
924

Calibration Factors (.cff)

The ENVI Empirical Line Calibration file is used to save a calibration factor file that 
can be used in subsequent calibration of the same or related image scenes. The file is 
a simple ASCII file with the same format as the files saved by ENVI plotting 
functions using the ASCII option. The first line of the file contains the keywords 
ENVI ASCII Plot File. Subsequent lines indicate the date the file was created, 
descriptions of the data columns, followed by the actual columns of ASCII data. An 
example of a typical .cff file is shown here:

ENVI ASCII Plot File
[Fri May 13 22:31:30 1994]
Column 1: Wavelength
Column 2: Maximum Solar Irradiance
Column 3: Path Radiance
Column 4: RMS Error
        0.45000     5217.36377        0.00000        0.00000
        0.55000      310.44244        0.00000        0.00000
        0.65000       67.52143        0.00000        0.00000
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Density Slice Range File (.dsr)

The ENVI density slice range file is used to save and restore density slice ranges and 
colors. The file is an ASCII file and has the keywords ENVI Density Slice 
Range File on the first line. It has 5 columns, the first two are the data range 
minimum and maximum, the next three columns have the red, green, and blue DN 
values that define the color. An example of a typical .dsr file is shown here:

ENVI Density Slice Range File
       50.000000       70.000000     255       0       0
       70.000000       90.000000       0     255       0
       90.000000       110.00000      80      80     255
       110.00000       130.00000     255     255       0
       130.00000       150.00000       0     255     255

Band and/or Spectral Math Expressions (.exp)

Use the Band Math and Spectral Math utilities to save math expressions for later use. 
The expressions are stored in a simple ASCII file with the .exp file extension. They 
can be recalled in either the Band Math or Spectral Math functions. The keyword 
ENVI EXPRESSIONS must appear on the first line of the file. Individual math 
expressions are listed on subsequent lines, one expression per line. An example of a 
typical .exp file is shown here:

ENVI EXPRESSIONS
s1+s2+s3+s4+s5+s6
sqrt(s1)
s1+s2

Tape Script Format (.fmt)

Use the ENVI tape scan/dump script file to generate custom tape scripts for loading 
common tape formats that are not directly supported by ENVI. The script file, which 
can be loaded into the tape scan utility, is a simple ASCII file with the default file 
extension .fmt. Each line (row) of the file describes the attributes to be used to read 
the tape. The first column is the file number, the second and third the starting and 
ending records to read, and the fourth and fifth the starting and ending bytes to read in 
those records. An example of a typical .fmt file is shown here:

ENVI Tape Dump Record Format File
          17           1        4298           1       32768
          17        4299        4299           1        1000
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Grid File (.grd)

The ENVI grid file is used to save and restore grid parameters. It is an ASCII file and 
has the keywords ENVI Grid Parameters File on the first line. It lists the three 
grid types (pixel, map, and geographic) and their parameter values. An example of a 
portion of a typical .grd file is shown here:

ENVI Grid Parameters File
Pixel Grid: On
Pixel Grid Spacing: 100
Pixel Grid Dist: 1.00
Pixel Grid Font: 3
Pixel Grid X-Axis Labels: Horizontal
Pixel Grid Y-Axis Labels: Vertical
Pixel Grid Labels: On
Pixel Grid Labels Color: 0
Pixel Grid Labels Thick: 1
Pixel Grid Labels Size: 12
Pixel Grid Lines: On
Pixel Grid Lines Color: 1
Pixel Grid Lines Thick: 1
Pixel Grid Lines Line Style: 0
Pixel Grid Corners: On
Pixel Grid Corners Color: 1
Pixel Grid Corners Thick: 1
Pixel Grid Box: On
Pixel Grid Box Color: 0
Pixel Grid Box Thick: 1
Pixel Grid Box Line Style: 0

Filter Kernels (.ker)

The ENVI Convolution Filtering files are used to save kernel files for user-defined 
filters. The file is a simple ASCII file with the default file extension .ker. The 
keyword ENVI KERNEL must appear on the first line of the file followed by the row, 
column, and band filter dimensions (in pixels). The subsequent lines of the file are the 
kernel weights (which must have the same number of rows and columns as indicated 
by the first line of the file). An example of a typical .ker file is shown here:

ENVI KERNEL           3           3           1
      -1      -1      -1
      -1       8      -1
      -1      -1      -1
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Map Key File (.key)

The ENVI map key ASCII file is used to save and restore annotation map keys. The 
file has the keywords ENVI MAP KEY on the first line. It has 7 columns, the first three 
columns have the red, green, and blue DN values that define the key color, followed 
by the key fill, the fill orientation, fill spacing, and map key name. An example of a 
typical .key file is shown here:

ENVI MAP KEY
   0 255   0       1      45     0.100000 Vegetation
  80  80 255       1      45     0.100000 Water
 255   0   0       1      45     0.100000 Soil
 255 255   0       1      45     0.100000 Rock

Contour Levels File (.lev)

The ENVI contour levels ASCII file is used to save and restore contour levels and 
parameters. The file has the keywords ENVI CONTOUR LEVELS on the first line. It 
has 5 columns, the first is the contour level, the next three columns define the line 
color, style, and thickness, and the final column has the contour label. An example of 
a typical .lev file is shown here:

ENVI CONTOUR LEVELS
       1500.0000       1   0       1 1500 m
       1600.0000       1   1       1 
       1700.0000       1   1       1 
       1800.0000       1   1       1 
       1900.0000       1   1       1 
       2000.0000       1   0       1 2000 m
       2100.0000       1   1       1 
       2200.0000       1   1       1 
       2300.0000       1   1       1 
       2400.0000       1   1       1 

Mosaic Template File (.mos)

The ENVI mosaic template ASCII file is used to save and restore mosaic templates. 
The file has the keywords ENVI MOSAIC TEMPLATE (G) or (P) on the first line. 
The G is for georeferenced mosaics and the P is for pixel-based mosaics. The output 
size is listed under the keywords. These are followed by the mosaic input filenames, 
band numbers, file dimensions, and X and Y offsets, feathering width, cutline, cutline 
feathering width, and optional data value to ignore. An example of a typical .mos 
file is shown here:
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ENVI MOSAIC TEMPLATE (G)
Output Size: 1275 x 1934

File : E:\DATA\bldr_reg\bldr4m.img
Bands: 1
Dims : 1-359,1-516
Info : (1,1) {0} [ {0}] {}

File : E:\DATA\bldr_reg\bldr_sp.img
Bands: 1
Dims : 1-1071,1-1390
Info : (1,1) {20} [ {0}] {0.00}

GCP File Format (.pts)

The ENVI Ground Control Point (GCP) files are ASCII files that contain the pixel 
coordinates of tie points selected from a base and warp image using ENVI’s 
registration utilities. They are assigned the file extension .pts by default and begin 
with the keywords ENVI Registration GCP File. For image-to-image 
registration, pixel coordinates are listed in the order Base image X, Y, Warp Image X, 
Y. An example of a typical image-to-image .pts file is shown here:

ENVI Registration GCP File
       921.00000       2538.0000       2098.0000       111.00000
       1381.0000       2291.0000       2145.0000       85.000000
       1669.0000       2116.0000       2174.0000       66.000000
       119.00000       3032.0000       2017.0000       164.00000
       1286.0000       3820.0000       2140.0000       240.00000
       1294.0000       1754.0000       2132.0000       28.000000
       1783.0000       1814.0000       2184.0000       34.000000
       715.00000       4504.0000       2083.0000       312.00000
       351.00000       1708.0000       2039.0000       27.000000
       207.00000       2357.0000       2025.0000       98.000000

For image-to-map registration, coordinates are listed as map X, map Y, image X, 
image Y. An example of a typical image-to-map .pts file is shown here: 

ENVI Registration GCP File
        359459.810 4143531.300 288.000 496.000
        367681.530 4141772.000 232.000 23.000
        366343.470 4138660.500 458.000 35.000
        362337.840 4145969.500 71.000 388.000
        361339.910 4138479.300 569.000 301.000
        354457.530 4140550.300 591.000 714.000
        354352.590 4145685.000 261.000 819.000
        359918.310 4142412.000 351.000 448.000
        364900.910 4141752.300 290.000 172.000
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Vector Template File (.vec)

The ENVI vector template file is an ASCII file that is used to save and restore vector 
parameters. The file has the keywords ENVI VECTOR TEMPLATE on the first line. It 
lists the vector filenames, whether the vector is on (1) or off (0), line color, line style, 
and line thickness. An example of a typical .vec file is shown here:

ENVI VECTOR TEMPLATE
[F:\envi_cd\data\bldr_reg\hydro.evf] (1,4,0,1)
[F:\envi_cd\data\bldr_reg\rail.evf] (1,2,0,1)
[F:\envi_cd\data\bldr_reg\roads.evf] (1,3,1,1)
Other ENVI ASCII Files ENVI User’s Guide
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General Information

This appendix describes the ENVI spectral libraries that are provided with the ENVI 
distribution. The spectral libraries are contained in the SPEC_LIB directory in the 
ENVI installation tree. They are also provided in the ENVIDATA/SPEC_LIB 
directory on the ENVI Data and Tutorials CD. 
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USGS Spectral Library (Minerals)

These spectra were measured on a custom-modified, computer-controlled Beckman 
spectrometer at the USGS Denver Spectroscopy Lab. Wavelength accuracy is on the 
order of 0.0005 micron (0.5 nm) in the near-IR and 0.0002 micron (0.2 nm) in the 
visible.

The directory SPEC_LIB\USGS_MIN directory contains the following files:

The full details of the spectral library and the descriptions of the samples are 
available at: http://speclab.cr.usgs.gov/

Hardcopy is also available from the USGS. The reference is given here:

Clark, R.N., G.A. Swayze, A.J. Gallagher, T.V.V. King, and W.M. Calvin, 1993, The 
U. S. Geological Survey, Digital Spectral Library: Version 1: 0.2 to 3.0 microns, U.S. 
Geological Survey Open File Report 93-592, 1340 pages. 

USGS_MIN.SLI —USGS Mineral Spectral Library

USGS_MIN.HDR —ENVI Header for Above
ENVI User’s Guide USGS Spectral Library (Minerals)

http://speclab.cr.usgs.gov/


1100  
USGS Spectral Library (Vegetation)

These spectra were measured on a custom-modified, computer-controlled Beckman 
spectrometer at the USGS Denver Spectroscopy Lab. Wavelength accuracy is on the 
order of 0.0005 micron (0.5 nm) in the near-IR and 0.0002 micron (0.2 nm) in the 
visible. The following vegetation spectra were extracted from the main USGS Denver 
spectral library for convenience.

The directory SPEC_LIB\VEG_LIB directory contains the following files: 

The full details of the spectral library and the descriptions of the samples are 
available at: http://speclab.cr.usgs.gov/

Hardcopy is also available from the USGS. The reference is given here:

Clark, R.N., G.A. Swayze, A.J. Gallagher, T.V.V. King, and W.M. Calvin, 1993, The 
U. S. Geological Survey, Digital Spectral Library: Version 1: 0.2 to 3.0 microns, U.S. 
Geological Survey Open File Report 93-592, 1340 pages. 

USGS_VEG.SLI  USGS Vegetation Spectral Library

USGS_VEG.HDR  ENVI Header for Above
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Additional Vegetation Libraries

The following libraries in the SPEC_LIB/VEG_LIB directory are provided for dry 
and green vegetation.

The following vegetation spectra were provided by Chris Elvidge, DRI.

These spectra were measured as hemispherical reflectance using a Beckman UV-
5240 spectrophotometer equipped with an integrating sphere. A halon plate was used 
as the reflectance standard. Data were recorded every 1 nm in the 0.4 - 0.8 
micrometer range and every 4 nm from 0.8 to 2.5 micrometers. Bandwidths ranged 
from 1 to 28 nm, mostly better than 10 nm in the 0.4 - 1.9 micrometer range and 10-
28 in the 1.9 - 2.5 micrometer range. The resolution function and the complete 
spectral descriptions and discussions of these spectra can be found in:

Elvidge, C. D., 1990, Visible and infrared reflectance characteristics of dry plant 
materials: Int. J. of Remote Sensing, v. 11, no. 10, pp. 1775 - 1795.

The following vegetation spectra were also provided by Chris Elvidge, DRI. These 
are unpublished data for vegetation and geologic materials for the Jasper Ridge 
Biological Reserve owned by Stanford University. These spectra were measured as 
hemispherical reflectance using a Beckman UV-5240 spectrophotometer as described 
above.

VEG_1DRY.SLI  Published Dry Plant Material Spectra

VEG_1DRY.HDR  ENVI Header for Above

VEG_2GRN.SLI Jasper Ridge Spectral Library for Green Vegetation, 
Dry Vegetation, and Rocks

VEG_2GRN.HDR ENVI Header for Above
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JPL Spectral Library

This library contains spectra for 160 minerals. Data for 135 of the minerals are 
available at three different grain sizes: 125-500 microns, 45-125 microns, and <45 
microns. These serve to illustrate the effect of grain size on spectral reflectance. 
Supporting X-Ray Defraction (XRD) analysis was performed. 

The following data are contained in the SPEC_LIB\JPL_LIB directory:

The spectra are hemispherical reflectance made using a Beckman UV-5240 
spectrophotometer. The sampling interval is .001 micrometers from 0.4 - 0.8 and .004 
micrometers from 0.8 to 2.5 micrometers. Band-width ranges from 1-4 nm in the 0.4 
to 0.8 micrometer range, less than 20nm in the 0.8 - 2.2 micro- meter range, and 20-
40 in the 2.2 - 2.5 micrometer range. The bandwidths are published in Grove et al., 
1990. Illumination was via a single-pass monochronometer utilizing a diffraction 
grating. The reference material was HALON. 

Grove, C. I., Hook, S. J., and Paylor, E. D., 1992, Laboratory reflectance spectra for 
160 minerals 0.4 - 2.5 micrometers: JPL Publication 92-2, Jet Propulsion Laboratory, 
Pasadena, CA.

These data are also available via anonymous FTP from the ASTER homepage:  
http://asterweb.jpl.nasa.gov/speclib/

JPL1.SLI  JPL Mineral Spectral library with <45 micrometers 
grainsize

JPL1.HDR ENVI Header for Above

JPL2.SLI JPL Mineral Spectral library with 45-125 micrometers 
grainsize

JPL2.HDR ENVI Header for Above

JPL3.SLI JPL Mineral Spectral library with 125-500 micrometers 
grainsize

JPL3.HDR ENVI Header for Above
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IGCP264 Spectral Library

The IGCP 264 spectral libraries were collected as part of IGCP Project 264 during 
1990. They consist of five libraries measured on five different spectrometers for 26 
well-characterized samples. Samples were also characterized using Energy 
Dispersive X-Ray (EDX), Scanning Electron Microscope (SEM), and X-Ray 
Defraction (XRD). The purpose of these libraries is to allow comparison of the effect 
of spectral resolution and sampling on spectral signatures.

Samples were hand picked where applicable and crushed in a carborundum mortar, 
minimizing the grinding where possible. The sample material was passed through a 
set of <100 and <200 mesh sieves and all the material that passed the <200 mesh 
sieve was used. The fine powders were measured in a horizontal orientation on all 
spectrometers. 

The directory SPEC_LIB\IGCP264 contains the following files:

These spectra were measured at the Center for the Study of Earth from Space (CSES) 
at the University of Colorado on a custom modified Beckman 5270 dual beam 
spectrometer. This spectrometer was under direct computer control measuring 
reflectance spectra at constant high resolution (3.8 nm) sampled at 1.0 nm intervals 
throughout the 0.7 to 2.5 µm range. A tungsten light source was used and HALON 
was the reference material. The reference and sample spectra were collected 
simultaneously and ratioed in real time.

IGCP-1.SLI IGCP-264 Library - CSES Beckman Spectrometer

IGCP-1.HDR ENVI Header for Above

IGCP-2.SLI IGCP-264 Library - Brown University Relab 
Spectrometer

IGCP-2.HDR ENVI Header for Above
ENVI User’s Guide IGCP264 Spectral Library



1104  
These spectra were measured at Brown University on the RELAB spectrometer. 
RELAB spectra were collected at 2 - 13 nm resolution, sampled at 5nm in the 0.4 2.5 
micrometer range using a HALON standard and quartz-halogen illumination. Contact 
Dr. Carle Pieters at Brown University for additional information.

These spectra were measured in the laboratory under quartz-halogen illumination 
using a Single beam visible/InfraRed Intelligent Spectroradiometer SIRIS field 
spectrometer at CSES. SIRIS is a field-portable grating spectrometer manufactured 
by Geophysical and Environmental Research, Inc. The SIRIS measures radiance 
using three separate gratings; from 0.35 µm to 1.08 µm using the first grating, from 
1.08 µm to 1.8 µm with the second grating, and from 1.8 µm to 2.5 µm with the third 
grating. Because the SIRIS is a single-beam instrument, it is necessary to measure 
reference and sample radiance spectra separately. HALON was used as the 
reflectance standard. The SIRIS spectral sampling interval varies continuously with 
wavelength. 

These spectra were measured on a custom-modified, computer-controlled Beckman 
spectrometer at the USGS Denver Spectroscopy Lab. Wavelength accuracy is on the 
order of 0.0005 micron (0.5 nm) in the near-IR and 0.0002 micron (0.2 nm) in the 
visible. 

The full details of the spectral library and the descriptions of the samples are 
available at: http://speclab.cr.usgs.gov/

These spectra were measured on a PIMA II field spectrometer under laboratory 
conditions. PIMA, manufactured by Integrated Spectronics, Sydney, Australia, 
utilizes internal illumination and an integrating sphere to provide approximately 2.5 
nm resolution.

IGCP-3.SLI IGCP-264 Library - CSES SIRIS (GER) Spectrometer

IGCP-3.HDR ENVI Header for Above

IGCP-4.SLI IGCP-264 Library - USGS Denver Beckman Spectrometer

IGCP-4.HDR ENVI Header for Above

IGCP-5.SLI IGCP-264 Library - CSES PIMA Spectrometer

IGCP-5.HDR ENVI Header for Above
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JHU Spectral Library

The Johns Hopkins University Spectral Library was provided by Jack Salisbury at 
JHU. These data are also available on-line from JHU via anonymous ftp at 
rocky.eps.jhu.edu. Also see the data on the ASTER homepage at: 
http://asterweb.jpl.nasa.gov/speclib/

The following files are provided:

ign_crs.sli Igneous Rocks - Coarse (0.4 - 14 µm)

ign_crs.hdr ENVI Header for Above

ign_fn.sli Igneous Rocks - Fine (0.4 - 14 µm)

igne_fn.hdr ENVI Header for Above

lunar.sli Lunar Materials (2.08 - 14 µm)

lunar.hdr ENVI Header for Above

manmade1.sli Man Made Materials (0.42 - 14 µm)

manmade1.hdr ENVI Header for Above

manmade2.sli Man Made Materials (0.3 - 12.5 µm)

manmade2.hdr ENVI Header for Above

meta_crs.sli Metamorphic Rocks - Coarse (0.4 - 14.98 µm)

meta_crs.hdr ENVI Header for Above

meta_fn.sli Metamorphic Rocks - Fine (0.4 - 14.98 µm)

meta_fn.hdr ENVI Header for Above

meteor.sli Meteorites (2.08 - 25 µm)

meteor.hdr ENVI Header for Above

minerals.sli Minerals (2.08 - 25 µm)

minerals.hdr ENVI Header for Above

sed_crs.sli Sedimentary Rocks - Coarse (0.4 - 14 µm)

sed_crs.hdr ENVI Header for Above

sed_fn.sli Sedimentary Rocks - Fine (0.4 - 14.98 µm)

sed_fn.hdr ENVI Header for Above
ENVI User’s Guide JHU Spectral Library

http://asterweb.jpl.nasa.gov/speclib


1106  
The following is reproduced verbatim from the README file provided by JHU with 
the data:

With the exception of man-made materials, all spectra in the Johns Hopkins 
Library were measured under the direction of John W. Salisbury. Most 
measurements were made by Dana M. D'Aria, either at Johns Hopkins 
University in Baltimore, MD, or at the U.S. Geological Survey in Reston, VA.

This text is a general introduction to the library, with an overview of 
measurement techniques, which do differ for different materials. There is a 
separate introductory text for each kind of material (rocks, minerals, lunar 
soils, terrestrial soils, meteorites, etc.) that contains more detailed information.

Two different kinds of spectral data are resident in this library. Spectra of 
minerals and meteorites were measured in bidirectional (actually biconical) 
reflectance (see two Salisbury et al., 1991 references below for details). These 
spectra, recorded from 2.08-25 micrometers, cannot be used to quantitatively 
predict emissivity because only hemispherical reflectance can be used in this 
way. However, when recorded properly, as described in the meteorite paper, 
curve shape is accurate and can be used for remote sensing applications.

All other spectral data, with the exception of portions of generic snow and 
vegetation spectra (see the introductory text for each type of material), were 
measured in directional hemispherical reflectance. Under most conditions, the 
infrared portion of these data can be used to calculate emissivity using 
Kirchhoff's Law (E=1-R), which has been verified by both laboratory and field 
measurements (Salisbury et al., 1994; Korb et al., 1996). The unusual 
circumstances (e.g., the lunar environment) where thermal gradients may cause 
significant departure from Kirchhoffian behavior are discussed in Salisbury et 
al., 1994.

snow.sli Snow (0.3 - 14 µm)

snow.hdr ENVI Header for Above

soils.sli Soils (0.42 - 14 µm)

soils.hdr ENVI Header for Above

veg.sli Vegetation (0.3 - 14 µm)

veg.hdr ENVI Header for Above

water.sli Water (2.08 - 14 µm)

water.hdr ENVI Header for Above
JHU Spectral Library ENVI User’s Guide
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The apparently seamless reflectance spectra from 0.4 to 14 micrometers of 
rocks and soils were generated using two different instruments, both equipped 
with integrating spheres for measurement of directional hemispherical 
reflectance, with source radiation impinging on the sample from a centerline 
angle 10 degrees from the vertical. 

Unless specified otherwise (see relevant introductory texts for generic snow 
and vegetation spectra, and spectra of man-made materials), all visible/near-
infrared (VNIR) spectra were recorded using a Beckman Instruments model 
UV 5240 dual-beam, grating spectrophotometer at the U.S. Geological Survey, 
Reston, VA. The data were obtained digitally and corrected for both instrument 
function and the reflectance of the Halon reference using standards traceable to 
the U. S. National Institute of Science and Technology. Measurements of such 
standards indicate an absolute reflectance accuracy of plus or minus 3 percent. 
Wavelength accuracy was checked using a holmium oxide reference filter and 
is reproducible and accurate to within plus or minus 0.004 micrometers, or 4 
nm (one digitization step). Spectral resolution is variable because the Beckman 
uses an automatic slit program to keep the energy on the detector constant. The 
result is a spectral bandwidth typically less than 0.008 micrometers over the 
0.4 to 2.5 micrometers spectral range measured, but slightly larger at the two 
extremes of the range of the lead sulfide detector (0.8-0.9 micrometers and 2.4- 
2.5 micrometers). This instrument has a grating change at 0.8 micrometers, 
which sometimes results in a spectral artifact (either a small, sharp absorption 
band, or a slight offset of the spectral curve) at that wavelength.

Two similar instruments were used to record reflectance in the infrared range 
(2.08 to 15 micrometers). Briefly, both are Nicolet FTIR spectrophotometers 
and both have a reproducibility and absolute accuracy better than plus or minus 
1 percent over most of the spectral range. Early measurements of igneous 
rocks with an older detector were noisy in the 13.5-14 micrometers range and 
do not quite meet this standard. Because FTIR instruments record spectral data 
in frequency space, both wavelength accuracy and spectral resolution are given 
in wavenumbers (reciprocal centimeters). Wavelength accuracy of an 
interferometer type of instrument is limited by the spectral resolution, which 
yields a data point every 2 wavenumbers for these measurements. The X-axis 
was changed from wavenumbers to micrometers for all of these data before the 
infrared segment was joined to the VNIR data from the Beckman.
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Spectra from the Beckman and the FTIR instruments were compared in the 
overlap range of 2.08-2.5 micrometers. If the difference was greater than 3 
percent, measurements were repeated. Typically, however, the agreement was 
within the 3 percent limit. In view of the greater accuracy of the FTIR 
measurements, any small discrepancy between the two spectral segments was 
resolved by adjusting the Beckman data to fit the reflectance level of the 
segment measured by the FTIR instruments. 
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Introduction

ENVI uses the U.S. Geological Survey General Cartographic Transformation 
Package (GCTP) which includes many different map projection types. Brief 
descriptions and lists of ENVI supported map projections, coordinates, ellipsoids, 
and datums are given below. You can define your own parameters for the supported 
ENVI projection types and select the desired ellipsoid or datum (see “Building 
Customized Map Projections” on page 923). You can also define your own new 
projection types by providing the formula used to translate latitude and longitude 
coordinates into the new projection coordinates (see User Defined Map Projection 
Types in the ENVI Programmer’s Guide). More information about map projections 
can be found in the following references.

Snyder, J. P., 1987. Map Projections-A Working Manual, U.S. Geological Survey 
Professional Paper 1395:383

Peter H. Dana, The Geographer’s Craft Project, Department of Geography, University 
of Colorado at Boulder

http://www.colorado.edu/geography/gcraft/notes/datum/datum_f.html 

http://www.connect.net/jbanta/
Introduction ENVI User’s Guide
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Map Projections

Use map projections to represent all or part of the three-dimensional surface of the 
earth in two-dimensions. Distortion always occurs when projecting a spherical 
surface onto a planar map and different projections cause different map 
characteristics to be distorted. You must choose the projection that shows the 
characteristics important to your goals accurately at the expense of other 
characteristics, which will be distorted. Map projections can have properties such as 
equal area, conformal, equidistant, or true azimuth (direction) characteristics. On an 
equal area map projection, circles of a fixed diameter drawn on any part of the map 
will encompass the same geographic area. This projection is useful for comparing 
land areas. However, the shapes, angles, and scales of equal area maps may be 
distorted. On a conformal map projection (e.g., UTM), the local angles are correct 
and the local scale in every direction is constant showing the true shape correctly. 
This projection is useful for measuring distance and direction between relatively near 
points. An equidistant map projection has a true accurate scale between one or two 
points and every other point on the map. Reference lines are called standard parallels 
or standard meridians. True direction map projections show the correct directions or 
azimuths among all points on the map. Many map projections use a compromise 
between these characteristics to reduce distortion yet provide accurate measurements 
for local areas. Several map projections are designed for specific uses, i.e., air and sea 
navigation, satellite mapping, etc.

Map projections are typically projected onto one of three types of surface: cylinder, 
cone, or plane. These surfaces wrap around or intersect with the globe and then are 
cut and laid flat to produce a map. Cylindrical projections are made by wrapping a 
cylinder around the globe and projecting the surface onto the cylinder. Often, the 
cylinder touches the globe at the equator so the meridians of longitude are projected 
as equidistant straight lines perpendicular to the equator and the parallels of latitude 
are projected parallel to the equator (mathematically spaced). The Mercator 
projection is an example of a cylindrical projection. A conical projection is made by 
placing a cone over the globe. Often, the apex of the cone is along the polar axis of 
the globe and the cone touches the globe at a parallel of latitude. In this case, the 
meridians are projected onto the cone as equidistant straight lines and the parallels 
are lines around the circumference of the cone that are circular when the map is laid 
flat. Planar or azimuthal map projections are produced when a plane is placed tangent 
to the globe’s surface. In a polar azimuthal projection, the plane is tangent to one of 
the globe’s poles so the meridians are projected as straight lines radiating from the 
pole and the parallels are circles centered on the pole. Modifications are often made 
to these types of projections and there are other projections that are not constructed in 
these ways. 
ENVI User’s Guide Map Projections
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You can easily add or modify map projections in ENVI. You can define your own 
parameters for the supported ENVI projection types and select the desired ellipsoid 
or datum (see “Building Customized Map Projections” on page 923). You can also 
define new projection types by providing the formula used to translate latitude and 
longitude coordinates into the new projection coordinates 
(see “ENVI_CONVERT_PROJECTION_COORDINATES” in the ENVI Reference 
Guide).

The map projections available in ENVI are listed in Table 13-1. The ENVI projection 
number is used when creating map information structures when programming in 
ENVI. 

Projection Name and Description ENVI Projection 
Number

Alaska Conformal 
a, b, x0, y0, name

23

Albers Conical Equal Area
a, b, lat0, lon0, x0, y0, sp1, sp2, [datum], name

9 

Arbitrary 0

Azimuthal Equidistant
r, lat0, lon0, x0, y0, name

12

Equidistant Conic A
a, b, lat0, lon0, x0, y0, sp1, [datum], name

33

Equidistant Conic B
a, b, lat0, lon0, x0, y0, sp1, sp2, [datum], name

34

Equirectangular
r, lat0, lon0, x0, y0, name

17

General Vertical Nearside Perspective
r, lat0, lon0, x0, y0, height, [datum], name

15

Geographic 1

Gnomonic
r, lat0, lon0, x0, y0, name

13

Table 13-1: Map Projections Available in ENVI 
Map Projections ENVI User’s Guide
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Hammer
r, lon0, x0, y0, name

27

Hotine Oblique Mercator A 
a, b, lat0, lat1, lon1, lat2, lon2, x0, y0, k0, [datum], 
name

5 

Hotine Oblique Mercator
B a, b, lat0, lon0, azimuth, x0, y0, k0, [datum], name 
azimuth:azimuth of central line (degrees east of north)

6 

Integerized Sinusoidal
r, lon0, x0, y0, DZone, Djustify, [datum], name

38

Interrupted Goode
r, name

24

Interrupted Mollweide
r, name 

26

Lambert Azimuthal Equal Area (sphere)
r, lat0, lon0, x0, y0, [datum], name

36

Lambert Azimuthal Equal Area
a, b, lat0, lon0, x0, y0, [datum], name

11

Lambert Conformal Conic
a, b, lat0, lon0, x0, y0, sp1, sp2, [datum], name

4 

Mercator
a, b, lat0, lon0, x0, y0, [datum], name

20

Miller Cylindrical
r, lon0, x0, y0, name

18

Mollweide
r, lon0, x0, y0, name

25

New Zealand Map Grid
a, b, lat0, lon0, x0, y0, [datum], name

39

Projection Name and Description ENVI Projection 
Number

Table 13-1: Map Projections Available in ENVI 
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Oblated Equal Area
r, lat0, lon0, x0, y0, shapem, shapen, angle, name

30

Oblique Conformal Conic
a, b, lat0, lon0, azimuth, x0, y0, sp1, k0, [datum],
name 
azimuth: central azimuth angle (from center not skew)

41

Orthographic
r, lat0, lon0, x0, y0, name

14

Polar Stereographic
a, b, lat0, lon0, x0, y0, [datum], name

31

Polyconic
a, b, lat0, lon0, x0, y0, [datum], name

10

Rectified Skew Orthomorphic (RSO)
a, b, lat0, lon0, azimuth, x0, y0, k0, [datum], 
name 
azimuth: azimuth of central line at projection center

40

Robinson
r, lon0, x0, y0, name

21

Sinusoidal
r, lon0, x0, y0, name

16

Space Oblique Mercator A (generic)
a, b, IncAng, AscLong, x0, y0, PSRev, LRat, [datum],
name

37

Space Oblique Mercator A
a, b, sat num, path num, path flag, x0, y0, [datum], 
name

22

Space Oblique Mercator B
a, b, sat num, path num, x0, y0, [datum], name

32

State Plane 8

Projection Name and Description ENVI Projection 
Number

Table 13-1: Map Projections Available in ENVI 
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Coordinate Systems

The position of a point on a globe is often represented in spherical coordinates by 
degrees of latitude and longitude. The parallels of latitude run east-west and are 
formed by 90 equally spaced circles around the globe from the equator to each pole 
(north latitudes are positive and south latitudes are negative). The circle at the equator 
is at 0 degrees and the numbers increase to the north and south poles which are at 90 
degrees each. The meridians of longitude are defined by north-south lines passing 
through each pole that intersect the equator at 360 equally spaced intervals. The 
meridian that passes through Greenwich, England is defined as 0 degrees and is 
called the prime meridian. Degrees of longitude are defined between 0 degrees and 
180 degrees east (positive) or west (negative) of the prime meridian. Map projections 
are used to represent the latitude and longitude lines on a plan map. 

Stereographic (ellipsoid)
a, b, lat0, lon0, x0, y0, k0, [datum], name

7 

Stereographic (sphere)
r, lat0, lon0, x0, y0, [datum], name

35

Transverse Mercator
a, b, lat0, lon0, x0, y0, k0, [datum], name

3 

User Defined projection
a, b, lat0, lon0, x0, y0, [additional parameters], 
[datum], name, user defined projection name

99

UTM 2

Van der Griten
r, lat0, lon0, x0, y0, name

19

Wagner IV
r, lon0, x0, y0, name

28

Wagner VII
r, lon0, x0, y0, name

29

Projection Name and Description ENVI Projection 
Number

Table 13-1: Map Projections Available in ENVI 
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The position of a point on a map is often represented in Cartesian (x, y) rectangular 
coordinates. The x-axis coordinates typically increase to the east and the y-axis 
coordinates increase to the north. The x and y coordinates are often called eastings 
and northings and the origin may be defined with a false easting and false northing. 
These coordinate grids are often divided into zones to reduce distortion. The 
Universal Transverse Mercator (UTM) and State Plane projections are examples of 
these type of coordinate systems.

Ellipsoids

The shape of the Earth is often represented by an oblate ellipsoid, which is an ellipse 
that is rotated about its shorter axis. The ellipsoids are described by two parameters, 
the semi-major and semi-minor axes. Reference ellipsoids are used to represent the 
shape of the Earth and many are based on surface measurements to give a regional 
best fit and not an entire Earth best fit. Therefore, different ellipsoids are often used 
for different regions of the Earth.

You can easily add an ellipsoid to ENVI by adding it to the ellipse.txt file in the 
map_proj directory of the ENVI distribution. To add an ellipsoid, enter the name, 
semi-major axis (a) in meters, and semi-minor axis (b) in meters to this file. 

The ellipsoids available in ENVI are listed in Table 13-2.

Airy IUGG

Australian National Krassovsky

Bessel 1841 Mercury

Clarke 1858 Modified Airy

Clarke 1866 Modified Everest

Clarke 1880 Modified Fischer 1960

Clarke IGN New International

Danish Plessis

Delambre South American 1969

Everest Southeast Asia

Fischer 1960 Struve

Table 13-2: Ellipsoids Available in ENVI
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Fischer 1968 Walbeck

GRS 67 WGS 60

GRS 80 WGS 66

Helmert 1906 WGS 72

Hough WGS 84

IAU “165”

International

Table 13-2: Ellipsoids Available in ENVI
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Datums

A datum is a smooth, mathematical surface that closely fits the mean sea level surface 
throughout the area of interest. It is created when an ellipsoid model is fixed to a base 
point on the Earth. Since the ellipsoid models are approximate, as you move away 
from the fixed point you get larger errors. Therefore, different datums exist for 
different regional areas to reduce error. Because different datums are defined by 
fixing an ellipsoid to different base points, changing datums changes the latitude and 
longitude of a point on the surface of the Earth. Therefore, it is necessary to know 
which datum is used when defining the coordinates of your points.

ENVI supports many datums which are listed in the datum.txt file in the 
map_proj directory of the ENVI distribution. Users can easily add a datum to ENVI 
by adding it to the datum.txt file. To add a datum, enter the name, associated 
ellipsoid name (must be in ENVI’s ellipse.txt file), and the Molodensky x, y, and 
z shift values in meters from the WGS-84 datum. See the web pages listed on page 
1110 for more information.
Map Projections ENVI User’s Guide
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Numerics
3D SurfaceView

animating flight paths, 1005
annotation trace, 1004
changing background color, 1009
changing vertical exaggeration, 999
cursor functions, 996
cursor location/value, 997
defining flight paths, 1001
displaying three-dimensional files, 993
fly-through, 1002
importing vectors, 1009
modes, 1001

printing, 1010
resampling, 995
rotate, move, zoom, 998
saving files, 1010
smoothing images, 1010

A
abundances, 829
ACRES CCRS Landsat files, 69
ACRES SPOT files, 70
active display, 190
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adaptive filtering
bit error removal, 735
Frost, 731
gamma, 733
Kuan, 734
Lee, 728
local sigma, 734
using, 728

additional Z profile extraction, 380
ADRG files, 85
aerial photos orthorectification, 875
AIRSAR

extracting polarization signatures, 1036
generating incidence angle images, 1025
generating pedestal height images, 1050
generating phase images, 1049
generating scattering classification images, 

1051
opening TOPSAR files, 84, 1016, 1053
radar tools, 1014
resampling to ground ranges, 1023
synthesizing images, 1027
viewing ASCII header, 1017
viewing polarization signatures, 1040

alpha residual spectra, 574
analysis

data types, 472
hyperspectral images, 758, 763
integral spectrum, 377
interactive tools in ENVI, 371
majority/minority, 654
multispectral images, 758, 763
polarimetric tools, 1027
principal components, 675
radar images, 1014
spectral mapping wizard, 809

animation
characteristics, 424
creating, 422
resampling, 423
saving as MPEG, 425
three-dimensional surface views, 1005

annotation
adding to images, 240
adding to plots, 240
arrows, 250
color ramps, 252
convert to DXF, 974
declination diagram, 256
defining three-dimensional flight path, 1003
fonts, 245
grayscale ramps, 252
image, 258
joining polygons, 262
map key annotation, 254
mouse button functions, 242
placing in virtual borders, 243
plot, 258
polygons, 247
polylines, 249
positioning, 241
scale bar, 251
selection mode, 260
shapes, 249
symbols, 247
text, 244
trace in three-dimensional surface view, 1004
using QuickMap, 320

antenna
pattern correction, 1021
removing gain variations, 1021

arbitrary contrast stretch, 363
arbitrary image transects, 381
ARC/INFO interchange

loading vectors into displays, 213
Index ENVI User’s Guide
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ArcView raster (.bil)
opening files, 94
saving display as, 450
saving files as, 131

ArcView Shapefile
attributes, 346, 959
loading vectors into displays, 213

area of ROI, 305
ASCII files

importing points, 412
opening, 98
opening image files, 100
outputting ROIs, 317
saving files as, 130
saving points, 412

ASCII map coordinate conversions, 932
ASCII spectra

input, 390
saving, 401

associating DEMs, 113
ASTER 1A/1B files, 79
ASTER/MODIS files, 82
ATREM, 539
ATREM ATmosphere REMoval Program.

See  ATREM
ATSR files, 81
attributes of vectors

add, 348, 961
query, 346, 960
read into ENVI, 346, 959
table, 349, 962
viewing, 346, 959

automated spectral hourglass, 818

Available Bands List
displaying color images, 191
displaying grayscale images, 194
displaying infrared images, 193
displaying True Color image, 193
files in, 189
folding bands, 195
hiding, 198
locating bands by wavelength, 195
opening image files, 197
selecting the active display, 190
shortcut menu, 192, 193

Available Files List
getting file information, 185
opening image files, 187

Available Vectors List
creating new vector layers, 217
creating world boundaries, 216
data files listed, 212
exporting vector layers to ROIs, 218
loading vectors into displays, 213

AVHRR
build geometry files, 917
calibrating data, 559
georeferencing, 917
opening files, 77
sea surface temperature, 560
viewing header info, 559

AVIRIS
ATREM input, 540
NDVI bands, 706
reading tapes, 147

azimuth
Landsat 7 files, 67, 68
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B
background

selection, 802
suppressing data with BandMax, 803

bad bands
in ASCII header data, 110
excluding, 41, 108
in header file, 1079

bad lines
bad lines list file format, 1091
replacing, 418, 551

Band Math
file format, 1092
file math, 500

band names
editing, 108
in imported ASCII files, 109

band ratios
calculating, 672
complex, 674

BandMax
selecting background, 590, 802
significant bands, 803
suppressing background data, 803

bare Earth LIDAR model, 91
basic tools

Band Math, 500
computing statistics, 476
converting data types, 472
display information, 225, 443
layer stacking, 470
masking, 527
rotating images, 468
segmenting images, 518
statistics, 476
stretch data, 474
subset data via ROIs, 467

bias and gains, 67, 68
BIL interleave, 46
bilinear resampling, 870

binary encoding classification, 606
BIP interleave, 46
bit error removal filter, 735
BMP

opening files, 98
saving display as, 450

borders See virtual borders
boundaries. See world boundaries
Brovey sharpening, 666
BSQ interleave, 46
buffer zone image, 660

C
cache size, 1074
CADRG files, 85
calibrating

AVHRR Data, 559
empirical line, 546
flat field, 544
IAR reflectance, 545
Landsat MSS, 534
Landsat TM, 535
thermal IR to emissivity, 568
using ATREM, 539

calibration factors
applying, 534
file format, 1091

cartographic symbols, 245
CEOS

reading tapes, 157
view header, 1017

CIB files, 85
class color mapping, 407, 628
class key annotation, 254
class statistics

calculating, 634
changing associated file, 270
plotting, 269
text report, 270
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classes
See Also classification
combining, 657
editing, 266
overlaying on images, 265
training, 594
viewing distribution reports, 268

classification
See Also

post classification, supervised classifica-
tion, unsupervised classification

calculating rule images, 595
class key annotation, 254
collecting endmembers, 577
converting ROIs to classification, 311
converting to vector, 970
entering parameters, 595
functions, 576
ROI separability, 312
from rule images, 630

clearing DEM association, 113
closing

all displays, 227
all files, 171
all plot windows, 227

closing filter, 718
clump classes, 655
collecting

endmembers, 577
points, 412

color image from grayscale, 704
color mapping

class color mapping, 407
control RGB image planes, 406
density slicing, 404, 406
ENVI color tables, 404
functions, 404

color normalized sharpening, 666

color tables
applying, 404
system, 177

color transforms
converting images, 695
hue, lightness, saturation, 697
hue, saturation, value, 696
Munsell, 695, 700

colors.txt, 1082
combining

bands, 127
classes, 657

command line
See Also

ENVI command line, IDL command line
switches, 20

compile module, 137
complex data

calculating images, 557
converting, 557
display lookup function, 120
outputting images, 557

compressing output, 45
computing

AVHRR sea surface temperature, 560
ROI spectral separability, 312
statistics, 476, 675
sun elevation for hill shade, 988

configuration customization, 1061
confusion matrix

calculating, 636
example of, 640

contingency matrix, 636
continuum removal, 788
contour levels format (.lev), 1094
contour lines

exporting to vector files, 277
plotting on images, 272
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contrast stretching
arbitrary stretch, 363
default (quick) stretch, 356
defining look-up-tables, 364
file-to-file, 474
Gaussian stretch, 362
histogram equalization, 363
histogram matching, 363
interactive, 359
linear stretch, 361
piece-wise linear stretch, 362
restoring LUTs, 370
saving LUTs, 370
square root, 363

converting
ASCII coordinates, 932
band values to ROIs, 309
classification to vector, 970
complex data, 557
data type

file-to-file, 474
stretching, 369

map and lat/lon, 930
raster to vector, 969

converting LAS LIDAR data, 90
convex cones, 828
convolution filtering

directional, 714
Gaussian, 714
high pass, 713
Laplacian, 713
low pass, 713
median, 714
Roberts, 714
Sobel, 714
types, 713
user-defined, 714
using, 715

co-occurrence texture filters, 725

creating
animations, 422
meta file, 127
QuickMap overlays, 320
standard file, 127

cross platform file portability, 49
crosshair cursor, 206
cross-track illumination correction, 556
cubic convolution resampling, 870
cursor

 See Also mouse buttons
functions in three-dimensional plots, 996
location/value in image displays, 440
location/value in three-dimensional plots, 

997
mirroring in linked images, 372, 376
query vector info, 346, 959

customizing configurations, 1061

D
Dancing Pixels

image distribution, 429
linking to images and plots, 430, 433
scatter plot distribution, 427, 428

dark subtraction, 552
data editor, 418
data fusion

3D SurfaceView, 993
hill shade image, 986
image sharpening, 665

data input
supported formats, 50
tape utilities, 141

data management
cross-platform file portability, 49
ENVI file naming conventions, 47
Geo-Browser, 168
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data output
printing, 454
supported formats, 54
tape utilities, 141
types, 446

data type
caution when altering, 105
converting, 369, 472, 474
image file interleaves, 46

data viewer, 125
data-specific utilities

AVHRR, 559
Landsat MSS, 562
Landsat TM, 563
SeaWiFS, 564
thermal IR, 568
viewing HDF global attributes, 558

date
extracting from Landsat 7 files, 68
in vector attribute file, 961
vector attribute file, 348

datum file (datum.txt), 1087
decorrelation stretch, 701
default stretch

quick, 356
setting in header file, 119

Delaunay triangulation warping, 870
DEM

associating to a file, 113
editing associations, 113
LAS LIDAR conversion, 91

DEM. See digital elevation
density slice file format, 1092
density slicing, 404, 406
de-skewing MSS, 562
de-stripe data, 555

digital elevation
3D SurfaceView, 993
arbitrary profiles, 381
draping images over, 993
multiple resolutions in three-dimensional 

plots, 1000
opening DEM files, 87
opening files, 87
orthorectification, 875
reading DEM tapes, 148
replacing bad values, 989
topographic features, 983
topographic modeling, 979
X and Y profiles, 377

digital elevation model, see DEM.
dilate filter, 718
directional filters, 714
directory list, 166
display characteristics

changing display preferences, 235
indicator box colors, 237
Main Image window scroll bars, 235
positioning Scroll/Zoom windows, 211
resizing image windows, 236
virtual borders, 235

display concepts
active display, 26
Main Image window, 24, 199
resizing windows, 25
Scroll window, 24, 208
supplemental windows, 26
vectors, 26
Zoom window, 25, 203

display control
active display, 190
close all displays, 227
closing all plot windows, 227
maximize open displays, 226
new display, 191
output, 446
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display enhancements
filtering, 355
histogram matching, 358
stretches and filtering, 354

display images
from Available Bands List, 189
color composite, 191
color infrared, 193
grayscale, 194
True Color, 193
using spectral plots, 379

display information, 225, 443
display menu definition, 1072
DLG

loading vectors into displays, 213
reading tapes, 150

DMSP (NOAA) files, 81
DOQ files, 89
drag-and-drop

endmember spectra, 582
spectra between plots, 388

DRG files, 89
DTED files, 87
DXF

from annotation, 974
from EVF, 975
loading vectors into displays, 213
from ROI, 973

dynamic overlays, 373

E
editing

ENVI configuration, 174
ENVI header file, 104
ENVI preferences, 174
ROI attributes, 296
system color tables, 177
system graphic colors, 176
vector appearance, 333, 946

editing DEM association, 113

EFFORT polishing, 842
eigenvalues

calculating, 675
generating statistics files, 476
in MNF transform, 682
subsetting PC rotations, 675

ellipsoid file (ellipse.txt), 1086
emissivity

calculating from thermal IR, 572
calibration, 568
normalization, 573
producing alpha residual spectra, 574

empirical line calibration, 546
endmember collection, 577

importing from a text file, 588
saving to a text file, 593

endmember collection dialog
suppressing background data, 589

ENVI
customizing, 1055
functionality review, 16
GUI, 21
and IDL, 15
installing, 1057
logo, 245
review of functionality, 16
runtime version, 15

ENVI command line
displaying, 136
exporting data to IDL variable, 136
importing IDL variables to, 135

ENVI configuration
caching information

process tile size, 1074
total cache size, 1074

configuration file details, 1063
customizing, 1063
display menu definition file, 1072
main menu definition file, 1071
platform dependencies, 1058
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ENVI files
image, 46
naming conventions, 47
saving as meta files, 129
saving displays as, 450
saving files as, 127

ENVI header file
band offsets, 120
changing Z plot information, 118
complex lookup function, 120
creating, 61
editing, 104, 186
editing ancillary information

band names, 108
introduction, 107
spectral library names, 108

editing classification information, 117
entering geographic corners, 116
entering map information, 111
entering pixel sizes, 117
format, 1077
general image parameters, 105
header info window, 105
row offsets, 120
selecting bad bands, 108
selecting file type, 107
setting default stretch, 119

ENVI runtime (ENVI RT)
introduction, 15

ENVI vector file
loading vectors into displays, 213
saving points as, 414
from contour lines, 277

ENVI window finder, 183
EOS files, 79

ER Mapper
opening files, 95
saving display as, 450
saving files as, 132

ERDAS
opening 7.5 files, 95
opening 8.x files, 95
saving display as, 450
saving files as, 132

erode filter, 718
ERS

opening files, 84
reading tapes, 157

ESA CEOS Landsat TM files, 69
ESA SHARP files, 77
ESRI GRID format

reading, 97
support, 96
writing, 97

EVF See ENVI vector file
exporting

class results to ENVI statistics, 635
class results to text file, 635
classes to vector layers, 662
contours to vectors, 277
data to IDL variable, 136
density slices to class image, 283
density slices to vector file, 282
endmember collection as text, 593
endmember spectral library, 831
ESRI GRID format, 97
ROI results to ENVI statistics file, 300
ROI statistics to text, 300
significant bands to ASCII, 804
transect data to ASCII, 382
vectors to ArcView, 345, 957

extensions, 47
external file formats, 66
extracting

additional Z profile, 380
image spectrum, 378
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F
Fast Fourier Transform. See FFT filtering
FAST TM files, 67
feathering, 901
feature fitting. See Spectral Feature Fitting
FFT filtering

filter definition, 738
forward, 737
inverse, 741

file formats
bad lines list (.bll), 1091
calibration factors (.cff), 1091
contour levels file (.lev), 1094
datum file, 1087
density slice range file (.dsr), 1092
ellipsoid file, 1086
ENVI header file, 47, 1077
ENVI image file, 46
file type file, 1083
filter kernels (.ker), 1093
GCP file format (.pts), 1095
generalized raster, 1076
graphic colors file, 1082
grid file (.grd), 1093
map key file (.key), 1094
map projections file, 1085
math expressions (.exp), 1092
mosaic template file (.mos), 1094
previous files list, 1090
sensor file, 1084
spectral libraries, 1089
state plane projections, 1088
supported

input, 50
output, 54

tape script format (.fmt), 1092
vector template file, 1096

file header, see header file.

file name extensions, 47
file naming

conventions, 47
cross-platform portability, 49

file output
selecting, 44
vs. memory execution, 31

file type file (filetype.txt), 1083
files

See Also opening files
Available Files List, 185
closing all, 171
converting to vector, 63
creating new, 127
opening, 60
saving, 127

filter kernel format, 1093
filtering

adaptive, 728
convolution, 713
FFT (Fast Fourier Transform), 737
morphological, 718
texture, 723

finding windows, 183
first pulse LIDAR return, 91
flat field calibration, 544
fly-through. See 3D SurfaceView
fold bands, 195
fonts, 245
formats

supported input, 50
supported output, 54

formats supported
ESRI GRID, 96
LAS LIDAR, 90

Fourier Transform (FFT) See FFT filtering
Frost filters, 731
full feature LIDAR return, 91
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G
gain and offset user function, 554
gamma filters, 733
Gaussian contrast stretch, 362
Gaussian filters, 714
GCP

orthorectification
IKONOS data, 886
OrbView-3 data, 886
QuickBird data, 886
SPOT data, 886

GCPs
collecting from Vector window, 869
exporting from Vector window, 344, 957
file format, 1095
the GCP list, 859
map coordinate conversion, 932
selection

image-to-image, 856
image-to-map, 864

general information
compressing output, 45
ENVI functionality, 16
image display concepts, 23
queue, 45
review of ENVI functionality, 16
runtime considerations, 1057
selecting file or memory output, 44
selecting items in lists, 43
vector display concepts, 26

generating
AIRSAR pedestal height image, 1050
AIRSAR phase image, 1049
AIRSAR scattering classification images, 

1051
test data, 122

Geo-Browser, 168
geographic corners, 116
geographic image locations, 168
Geographic Lookup Table See GLT file

geometry files
AVHRR, 917
SeaWiFS, 914

georeferenced grid lines, 286
georeferenced images

attaching GPS link, 936
building multi-band files, 470
linking, 376
mosaicking, 526, 896
subsetting, 37

georeferencing
AVHRR data, 917
from GLT files, 906
from IGM files, 906
image-to-image, 856
image-to-map, 864
from input geometry, 904
SeaWiFS, 914
super, 910
from super GLT files, 908

GeoSPOT-ArcView raster (.bil) files, 70
GeoTIFF

opening files, 98
opening Landsat files, 67
saving display as, 450

GIS
attributes, 346, 959
digitizing on screen, 339, 952
exporting vectors to Shapefiles, 345
exporting vectors to Shapefiles files, 957
vector layers, 330
Vector window, 220

GLT file
building, 904
building super GLT files, 908
georeferencing from, 904
georeferencing from super GLT, 908

GPS-Link, 935
graphic colors

editing, 176
file format, 1082
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graphical user interface (GUI), 21
grid lines

burn-in, 446
file format, 1093
georeferenced, 286
overlaying on images, 284
pixel-based (generic), 285

gridding irregular points, 971
Ground Control Points See GCPs
growing regions of interest, 301

H
hardware mouse requirements, 21
HDF

opening files, 98, 101
saving display as, 450
view global attributes, 558

header file
associating a DEM, 113
LAS LIDAR, 90

header file See ENVI header file
heads up digitizing, 339, 952
hiding

dialogs, 239
layers, 239
point collection window, 414
Scroll window, 211
Zoom window, 211

high pass filter, 713
hill shade image

computing sun elevation values, 988
creating from color images, 986
creating from color tables, 987

histogram
equalization stretch, 363
in interactive stretching, 359
matching, 358, 363
of rule bands, 632
statistics, 476

history recorder, 173

HLS transform, 697
horizontal profile, 377
hourglass processing flow, 809
HSV sharpening, 665
HSV transform, 696
hue, lightness, saturation transform, 697
hue, saturation, value transform, 696
hyperspectral data

analysis, 758, 763
spectral hourglass wizard, 809

I
IAR reflectance calibration, 545
IDL

compiling code, 137
and ENVI, 15
logo, 245
turning off blocking, 175

IDL variables
export plot data to, 402
exporting data to, 136
importing, 135

IGCP spectral libraries, 1103
IKONOS files

opening
GeoTIFF, 72
NITF, 72

orthorectification, 881
IKONOS orthorectification, 886
illumination correction, 556
image

creating animations, 422
extracting spectral plots, 378
mosaic, 526, 888
overlays, 238
rotating, 468
segmenting by pixel DN, 518
specifying transects, 381

image borders, 243
image cube, 847
Index ENVI User’s Guide
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image displays
general concepts, 23
Main Image window, 199
outputting, 446
Scroll window, 208
shortcut menu, 231
Zoom window, 203

image file
formats, 46
generic formats, 98
opening from Available Bands List, 197
opening from Available Files List, 187
resampling to high resolution, 665
saving files as, 450
supported input formats, 50
supported output formats, 54

image processing files, 94
image sharpening, 665
image window See. Main Image window
importing

ASCII transect file, 386
endmember collection from text file, 588
ESRI GRID data, 97
IDL variables, 135
library spectra into n-D Visualizer, 773
multiple vector files, 63, 63
plot spectra to endmember collection, 581
points to ASCII, 412
ROIs into endmember collection, 587
ROIs to scatter plots, 437
vector files, 63
vectors into 3D SurfaceViews, 1009

incidence angle image, 1025
indicator box colors, 237
infrared images, 193
input file

ATSR, 81
AVHRR

ESA SHARP, 77
KLM/Level 1b, 77

digital elevation
DTED, 87
SRTM DEM, 89
USGS DEM, 87
USGS SDTS DEM, 88

DMSP (NOAA), 81
EOS, 79
generic image formats

ASCII, 98, 100
BMP, 98
GeoTIFF, 98
HDF, 98, 101
JPEG, 98
JPEG2000, 98
MrSID, 99
PDS image, 102
PICT, 98
PNG, 98
SRF, 98
TIFF, 98
XWD, 98

Geo-Browser, 168
IKONOS

GeoTIFF, 72
NITF, 72

image processing
ArcView raster (.bil), 94
ER Mapper, 95
ERDAS 7.5 (.lan), 95
ERDAS 8.x (.img), 95
PCI (.pix), 96

IRS-1, 76
Landsat

ACRES CCRS, 69
ESA CEOS TM, 69
FAST, 67
GeoTIFF, 67
HDF, 68
MRLC, 68
NLAPS, 68
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military
ADRG, 85
CADRG, 85
CIB, 85
NITF, 86

OrbView
GeoTIFF, 75
NITF, 75

plot data, 390
QuickBird

GeoTIFF, 73
NITF, 73

radar
ERS, 84
JERS, 84
RADARSAT, 83
TOPSAR, 84

scan directory list, 166
SeaWiFS, 78
selecting, 32
SPOT

ACRES SPOT, 70
GeoSPOT-ArcView raster (.bil), 70
vegetation files, 71

supported formats, 50
thermal

MODIS/ASTER, 82
TIMS, 81

thermal files, 81
USGS

DEM, 87
DOQ, 89
DRG, 89

installing ENVI, 1057
interactive analysis tools

classification overlays, 265
color mapping, 404
cursor location/value, 440
density slicing, 406

dynamic overlays, 372
linked displays, 372
overview, 371
pixel locator, 410
profiles and spectral plots, 377
regions of interest, 289
spatial pixel editor, 418
spectral pixel editor, 421
two-dimensional scatter plots, 427

interleave, 46
interpolation

in three-dimensional plots, 1010
of irregularly gridded data, 971
in system color tables, 177
Zoom window, 25, 207, 236

intersecting ROIs, 304
inverse FFT, 741
irregular points to grid, 971
IRS-1 files, 76
isodata classification, 611

J
JERS

opening files, 84
reading tapes, 157

Johns Hopkins University spectral libraries, 
1105

JPEG
.jgw files, 99
opening files, 98
outputting georeferenced file to, 451
saving display as, 450

JPEG2000
opening files, 98
saving display as, 450

JPL AIRSAR. See AIRSAR
JPL spectral libraries, 1102
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K
kappa coefficient, 636
KLM/Level 1b files, 77
k-means classification, 614
Kuan filter, 734

L
Landsat

opening files
ACRES CCRS, 69
ESA CEOS, 69
GeoTIFF, 67
HDF, 68
MRLC, 68
NLAPS, 68

TM FAST, 67
Landsat 7

bias and gains, 67
date extraction, 67, 68

Landsat MSS
aspect ratio, 562
calibration, 534
de-skewing, 562
read tapes, 142

Landsat TM
calibration, 535
input files, 67
reading tapes, 144

Laplacian filter, 713
LAS LIDAR format

converting data, 90
header, 90
model types, 91
support, 90

last pulse LIDAR return, 91

lat/lon
converter, 930
specifying world boundaries, 216

layer stacking, 470
Lee filtering, 728
libraries. See spectral libraries
line of sight calculator, 416
linear band prediction, 778
linear contrast stretch, 361
linear spectral unmixing, 780
linking

georeferenced images, 376
images, 372

list item selection, 43
local sigma filter, 734
log manager, 173
logos (ENVI and IDL), 245
look-up-tables (LUTs)

defining, 364
restoring, 370
saving, 370

low pass filter, 713
LS-Fit, 778
LUTs See look-up-tables

M
mahalanobis distance classification, 601
Main Image window

changing indicator box color, 237
controlling from Zoom window, 202
display menu, 230
displaying scroll bars, 201, 204, 235
mouse button functions, 203
resizing, 200, 236

majority analysis, 654
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map
building customized projections, 923
converting ASCII coordinates, 932
converting coordinates, 930
converting map projections, 927
georeferencing AVHRR data, 917
georeferencing from GLT files, 906
georeferencing from IGM files, 906
georeferencing from IGM files, super, 910
georeferencing from input geometry, 904
georeferencing from super GLT files, 908
georeferencing SeaWiFS data, 914
GPS-Link, 935
layer stacking, 470
merging old projection files, 934
mosaicking, 888
orthorectification, 875
registration, 855

map coordinate converter, 930
map information

entering ENVI header file, 111
map key

annotation, 254
file format, 1094

map projections
ASCII coordinate conversions, 932
build customized map projection, 923
convert projection, 927
converting, 927
converting coordinates, 930
customizing, 115, 922, 923
file (map_proj.txt), 1085
merge map_proj.txt files, 934
selecting types, 922

map scaling of PostScript output, 447

masking
apply mask, 532
apply to output

image, 453
PostScript, 449
printer, 456

build mask, 527
creating, 527
data ignore value, 532
including ROIs, 530
NaNs, 532
as spatial subset, 42

MASTER files, 82
matched filtering

mixture tuned, 785
results, 784
using, 783

math
band, 500
spectral, 833

maximize open displays, 226
measurement tool

arbitrary profile, 382
regions of interest, 305
using, 497

median filter, 714
memory management

file vs. memory execution, 31
resources, 31
tiling operations, 31

memory vs. file function execution, 31
menu definition file, 1071
menus. See shortcut menu
merge regions, 303
meta files

creating, 127
saving files as, 129

military files, 85
minimum noise fraction See MNF transform
mining symbols, 245
minority analysis, 654
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mirroring cursor location, 372, 376
Mixture Tuned Matched Filtering

in spectral hourglass wizard, 810, 817
using, 785

MNF transform
applying forward to spectra, 693
applying inverse to spectra, 694
dark image noise statistics, 689
in spectral hourglass wizard, 810, 814
inverse, 694
noise statistics from data, 683
overview, 682

modes
3D SurfaceView, 1001
controlling cursor in Vector window, 335
controlling cursor in Vector windows, 948
when drawing ROIs, 291

MODIS 1B files, 79
MODIS/ASTER files, 82
morphological filtering

applying filters, 721
closing, 718
dilate, 718
erode, 718
opening, 718
using, 719

mosaic images
feathering, 901
georeferenced, 526, 896
pixel-based, 526, 888
Virtual Mosaic, 894, 899

mosaic template format, 1094
mouse buttons

annotation, 242
functions in Main Image, 203
linked windows/dynamic overlay off, 375
linked windows/dynamic overlay on, 375
polygon drawing, 248
profiles, 387
regions of interest, 291
spectral plots, 387
three-button emulation, 21
viewing descriptions, 444

Movie Picture Experts Group. See MPEG
movie. See animation
MPEG

saving animation, 425
saving flight sequences, 1006

MRLC Files, 68
MrSID files, 99
MSS

aspect ratio, 562
calibration, 534
de-skewing, 562
read tapes, 142

MTMF. See Mixture Tuned Matched Filtering
multi part ROIs, 295
multiband files, 470
multilook SIR-C data, 1048
multiple file selection, 63, 63
multi-resolution image linking, 376
Munsell transform, 695, 700
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N
NaN masks, 533
n-Dimensional Visualizer

class controls, 768
collapse classes, 770
define classes, 768
export classes to ROIs, 775
export ROIs to, 316
import library spectra, 773
interact with classes, 768
overview, 763
pre-clustering, 764
shortcut menu, 768
in spectral hourglass wizard, 810, 815
Z profile, 772

NDVI transform, 706
nearest neighbor resampling, 870
neural net classification, 608
NITF

opening files, 86
saving files as, 133

NLAPS
opening files, 68
reading tapes, 151

O
occurrence texture filters, 723
open previous file, 103
opening

ASCII transect file, 386
endmember collection text file, 589
ESRI GRID format, 97
multiple vector files, 63, 63
plot spectra to endmember collection, 581
vector file parameters, 64

opening files
ACRES SPOT, 70
ADRG, 85
ArcView raster (.bil), 94
ASCII, 98
ATSR, 81
AVHRR, 77
BMP, 98
CADRG, 85
CIB, 85
digital elevation, 87
DMSP (NOAA), 81
DTED, 87
EOS, 79
ER Mapper, 95
ERDAS 7.5, 95
ERDAS 8.x, 95
ERS, 84
ESA CEOS Landsat TM, 69
ESA SHARP, 77
external formats, 66
generic image formats, 98
with Geo-Browser, 168
GeoSPOT-ArcView raster (.bil), 70
GeoTIFF, 98
HDF, 98, 101
IKONOS, 72
image processing, 94
IRS, 76
JERS, 84
JPEG, 98
JPEG2000, 98
KLM/Level 1b, 77
Landsat 7, 67, 68
Landsat ACRES CCRS, 69
Landsat FAST TM, 67
Landsat GeoTIFF, 67
Landsat HDF, 68
Landsat MRLC, 68
Landsat NLAPS, 68
military, 85
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MODIS/ASTER, 82
MRLC, 68
MrSID, 99
NITF, 86
OrbView, 75
PCI (.pix), 96
PDS, 102
PICT, 98
PNG, 98
QuickBird, 73
radar, 83
RADARSAT, 83
scan directory list, 166
SeaWiFS, 78
SPOT, 70
SPOT vegetation, 71
SRF, 98
SRTM DEM, 89
statistics, 484
thermal IR, 81
TIFF, 98
TIMS, 81
topographic, 979
TOPSAR, 84, 1053
USGS, 89
USGS DEM, 87
USGS DOQ, 89
USGS DRG, 89
USGS SDTS DEM, 88
vector, 63
XWD, 98

opening filter, 718
OrbView files

opening
GeoTIFF, 75
NITF, 75

orthorectification, 881

OrbView-3 files
orthorectifying with GCP, 886

orthorectification
aerial photos, 875
IKONOS, 881
IKONOS data, 886
OrbView, 881
QuickBird, 881
QuickBird data, 886

output
as ArcView raster (.bil), 131
as ASCII files, 130
compressing, 45
directory, 170
as ENVI files, 127
as ENVI meta files, 129
as ER Mapper files, 132
as ERDAS files, 132
as image files, 450
as NITF files, 133
as PCI files, 134
plots, 402
PostScript, 446
printing, 454
QuickMap options, 324
selecting file or memory, 44
standardized, 446
as TIFF files, 132, 134

overlays
burn-in to output, 446
classes, 265
classification results on image, 659
contours, 272
density slices, 406
grid lines, 284
image, 238
image annotation, 240
regions of interest, 289
vector layers, 325
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P
parallelepiped classification, 597
PCI

opening files, 96
saving display as, 450
saving files as, 134

PDS image files, 102
pedestal height image

radar tools, 1050
phase image

radar tools, 1049
PICT

opening files, 98
saving display as, 450

piece-wise linear contrast stretch, 362
pixel

Dancing Pixels, 427
entering size in header file, 117
replace bad values, 418
rotating and refining clusters, 764

pixel editor
spatial, 418
spectral, 421

pixel locator, 410
Pixel Purity Index

FAST PPI, 758
maximum iterations, 760
restarting, 761
in spectral hourglass wizard, 810, 815
using PPI images in endmember collection, 

762
pixel-based mosaics, 888

platform dependencies, 1058
plots

annotation, 240
data input, 390
data parameters, 393
input ASCII, 390
input spectral libraries, 390
interactive functions

display plot data labels, 388
move plot to new window, 388
rescale spectral plots, 389
x-y cursor, 388

legends, 388
new plot window, 397
output, 402, 446
plot functions, 400
plot parameters, 394
stack data, 398

PNG, 98
points

collecting, 412
saving as ENVI vector files, 414

polarimetric tools, 1027
polarization signatures

displaying as images, 1046
extracting, 1036
from ROIs, 1038
polarization signature viewer, 1040
single pixel, 403, 1037

polygon drawing. See annotation
polynomial warping, 870
positioning Scroll/Zoom windows, 211
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post classification
accuracy, 636
buffer zone image, 660
class colors, 628
classes to vector layer, 662
clump classes, 655
combine classes, 657
confusion matrix, 636
functions, 628
kappa coefficient, 636
majority/minority analysis, 654
overlay classes on grayscale image, 659
overlaying classes, 265
ROC curves, 644
rule classifier, 630
segmentation image, 661
sieve classes, 656
statistics, 634

PostScript output
multiple pages, 447
saving image as, 446
scaling, 447
setting graphics options, 448

PPI. See Pixel Purity Index
preferences

editing, 174
indicator box colors, 237
scroll bars, 235
virtual borders, 235
window sizes, 236

preview window, 596
previous files list

format, 1090
opening, 103

principal components
analysis, 675
compute new statistics and rotate, 675
eigenvalues, 675
forward rotate, 679
inverse rotate, 681
using a subset, 678, 686

printing
display windows, 454
QuickMaps, 324
three-dimensional plots, 1010

processing log, 173
profiles

additional Z profile, 380
arbitrary profiles (transects), 381
X profile (horizontal), 377
Y profile (vertical), 377
Z profiles (spectrum), 378

projections
ASCII coordinate conversions, 932
convert, 927
customizing, 923
map coordinate converter, 930
supported projections, 1085

Q
queue

executing queued functions, 172
holding functions, 45

quick stretching, 356
QuickBird files

opening
GeoTIFF, 73
NITF, 73

orthorectification, 881
QuickBird orthorectification, 886
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QuickMap
creating, 320
printing, 324
restore template, 324
setting parameters, 322
using small images, 320

R
radar files, 83
radar tools

adaptive filters, 1026
AIRSAR scattering mechanism classifier, 

1051
antenna pattern correction, 1021
extract polarization signatures from ROIs, 

1038
extracting polarization signatures, 1036
incidence angle image, 1025
multilook SIR-C data, 1048
pedestal height image, 1050
phase image, 1049
polarimetric tools, 1027
single pixel polarization signatures, 1037
slant to ground range, 1023
synthesize SIR-C images, 1032
synthesizing JPL AIRSAR data, 1027
texture filters, 1026
the polarization signature viewer, 1040
TOPSAR tools, 1053
view CEOS header, 1017

RADARSAT
generating incidence angle images, 1025
opening files, 83
reading tapes, 156
resampling to ground ranges, 1023
viewing header, 1017

radial resampling, 908
raster to vector conversion, 969

ratio bands, 672
reading

ASCII transect file, 386
endmember collection text file, 588
ESRI GRID format, 97
multiple vector files, 63, 63
plot spectra to endmember collection, 581
vector file parameters, 64

reference channel emissivity, 572
reflectance spectra. See spectral libraries
regions of interest

area of ROIs, 305
convert band values, 309
convert to DXF, 973
converting to classification images, 311
delete ROI, 298, 520
editing attributes, 296
export ROIs to EVF, 316
export to n-Dimensional Visualizer, 316
growing, 301
input points from ASCII, 302
intersect regions, 304
intersections as masks, 530
line of sight calculator, 416
measurement tool, 305
merge regions, 303
new region, 297
outputting to ASCII, 317
overview, 289
reconcile ROIs, 307
reconcile via map, 309
restore ROIs, 313
restore saved ROI, 520
ROI types

donut, 295
modes, 291
multi part, 295
point, 294
polygon, 292
polyline (vector), 293
Index ENVI User’s Guide



 1141
saving regions, 313
separability, 312
using as spatial subset, 39, 462

registration
assessing accuracy, 873
image-to-image, 856
image-to-map

enter GCPs from GPS, 935
enter GCPs from Vector window, 869
introduction, 864

mosaicking images, 888, 896
overview, 855
warp images from existing GCPs, 873
warping and resampling options, 870

removing
antenna gain variations, 1021
water vapor bands, 108

replacing
bad DEM values, 989, 1054
bad lines, 551
bad pixel values, 418

reporting
ROI area, 305
statistics, 480

resampling
in animation, 423
bilinear, 870
cubic convolution, 870
library spectra, 749
nearest neighbor, 870
options, 870
radial, 908
slant to ground range, 1023
spectral data files, 840

rescale spectral plots, 389
resizing

images, 459
Main Image window, 200
windows, 25

RGB image planes, 406
RGB sharpening, 665

Roberts filter, 714
ROC curves, 644
ROI

saving results to ENVI statistics file, 300
saving statistics to text file, 300

ROIs. See regions of interest
rotating

images, 468
three-dimensional plots, 998

RST warping, 870
rule classifier, 630
rule images, 595, 630

S
SAM Target Finder Wizard

examining results, 806
GUI description, 798
hyperspectral images, 795
reporting results, 807
starting, 796
workflow, 797

SAM. See Spectral Angle Mapper
SAR. See Radar Tools
saturation stretch, 703
saving

class results to ENVI statistics, 635
class results to text file, 635
current session to startup script, 170
density slices to class image, 283
endmember collection as text, 593
endmember spectral library, 831
ESRI GRID data, 97
files, 127
look-up-tables, 370
regions of interest to file, 313
ROI results to ENVI statistics file, 300
ROI statistics to text, 300
significant bands to ASCII, 804
transect data to ASCII, 382
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saving files
as ArcView raster (.bil), 131
as ASCII, 130
as ENVI files, 127
as ENVI meta files, 129
as ER Mapper, 132
as ERDAS, 132
as image, 450
as NITF, 133
as PCI, 134
as PostScript, 446
as TIFF, 132, 134

saving spectra
to ASCII, 401
to spectral library, 401

scan directory list, 166
scan tape, 163
scatter plots

Dancing Pixels on image, 429
Dancing Pixels on plot, 428
density distribution, 431
drawing ROIs, 432
n-dimensional, 763
shortcut menu, 433
two-dimensional, 427

scroll bars
displaying in Main Image window, 201, 204
set in preferences, 235

Scroll window
controlling main image from, 208
display, 208
hiding, 211
meta zoom, 209
mouse button functions, 210
positioning, 211
resizing, 208
shortcut menu, 210

SDTS
loading vectors into displays, 213

SDTS DEM files, 88
sea surface temperature, 560
SeaWiFS

build geometry file, 914
build IGM file, 914
georeference data, 915
opening files, 78

segmentation image, 661
segmenting images, 518
selecting

active display, 190
files to open, 32
map projection types, 922
multiple listed items, 43

sensor file (sensor.txt), 1084
separability measures, 312
SFF. See Spectral Feature Fitting
shaded relief, 986
Shapefile

attributes, 346, 959
exporting vector layers, 345, 957

sharpening
color normalized (Brovey), 666
HSV, 665
images, 665

shift difference, 683
shortcut menu

Available Bands List, 192
Main Image display, 231
n-Dimensional Visualizer, 768
Scroll window, 210
two-dimensional scatter plot, 433
Zoom window, 231

sieve classes, 656
significant bands

BandMax, 803
saving to ASCII file, 804
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SIR-C
extracting polarization signatures, 1036
generating incidence angle images, 1025
generating pedestal height images, 1050
generating phase images, 1049
generating scattering classification images, 

1051
multilook, 1048
radar tools, 1014
reading tapes, 152
resampling to ground ranges, 1023
synthesize images, 1032
viewing polarization signatures, 1040

slant to ground range, 1023
SMACC

spectral tool, 828
Sobel filter, 714
spatial pixel editor, 418
spatial profiles

overlaying ASCII data, 386
saving as ASCII, 382

spatial subsetting. See subsetting images
spectra

ASCII input, 390
saving ASCII spectra, 401
saving to spectral library, 401
spectral library input, 390
Z profiles, 378

Spectral Analyst, 820
spectral angle mapper

classification, 777
in spectral hourglass wizard, 810, 817

spectral angle mapper, see SAM Target Finder 
Wizard.

Spectral Feature Fitting
methodology, 789
Results, 790

spectral hourglass
automated, 818

spectral libraries
editing names in ENVI header, 108
file format, 1089
IGCP, 1103
Johns Hopkins University (JHU), 1105
JPL, 1102
library descriptions, 1097
overview, 746
plot options, 748
resampling, 749
saving from plot, 401
USGS mineral, 1099
USGS vegetation, 1100
vegetation, 1101
viewing spectra, 746

spectral mapping wizard, 809
Spectral Math

applying to multiband images, 838
assignment of variables, 836
basic operations, 833
execution, 837
file format, 1092
table of Spectral Math functions, 834
user functions, 838

spectral pixel editor, 421
spectral plots, 378
spectral resampling, 840
spectral slices

arbitrary, 756
extracting, 754
horizontal, 755
vertical, 755

spectral subsetting See subsetting images
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spectral tools
binary encoding, 777
continuum removal, 788
linear spectral unmixing, 780
LS-Fit, 778
mapping methods, 777
matched filtering, 783
Mixture Tuned Matched Filtering, 785
n-Dimensional Visualizer, 763
Pixel Purity Index (PPI), 758
plot options, 748
references, 849
Spectral Analyst, 820
spectral angle mapper (SAM), 777
Spectral Feature Fitting, 789
spectral hourglass wizard, 809
spectral libraries, 746
spectral library resampling, 749
spectral library viewer, 746
Spectral Math, 833
spectral slices, 754
unmixing, 780

spectral unmixing, 780
SPOT

opening files, 70
reading tapes, 146
vegetation files, 71

SPOT orthorectification, 886
square root stretch, 363
SRF

opening files, 98
saving display as, 450

SRTM DEM files, 89
stack plot data, 398

standard ENVI functions
compressing output, 45
file selection, 32
file/memory output, 44
masking, 42
output display, 446
queue, 45
selecting multiple items in lists, 43
spatial subsetting, 35
spectral subsetting, 40

startup script
commands, 1073
executing, 170
save session, 170

state plane projections files, 1088
statistics

average spectrum, 476
basic, 476
calculating on a subset, 479
classification statistics, 634
correlation matrix, 476
covariance matrix, 476
eigenvectors, 476
histograms, 476
noise statistics, 683
noise statistics from dark, 689
reports, 480
shift difference, 683
spectral, 484
sum bands, 484
tabulated frequency distributions, 476
view statistics, 484

stretching. See contrast stretching
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subsetting images
class preview window, 596
masking, 42
spatial

by image, 36, 460
by map coordinates, 37
by ROIs, 39, 462, 467
by samples/lines, 36, 460
selecting, 35, 460
using another file, 38, 462

spectral
excluding bad bands, 41
by range of bands, 41
selecting, 40, 459
using another file, 41

spectrally using BandMax, 804
sum bands, 484
sun elevation

computing, 981
Landsat 7 files, 67, 68

super GLT file
building, 908
georeferencing from, 908

supervised classification
binary encoding, 606
entering parameters, 595
functions, 594
mahalanobis distance, 601
maximum likelihood, 602
minimum distance, 598
neural net, 608
parallelepiped, 597
Spectral Angle Mapper (SAM), 604

supported formats
ESRI GRID, 96
LAS LIDAR, 90

supported input files, 50
supported output files, 54
surface plots. See 3D SurfaceView

switches along command line, 20
symbols, 245
synthesizing SAR data

AIRSAR, 1027
SIR-C images, 1032

synthetic color image, 704
system color tables, 177

T
tape script format, 1092
tape utilities

AVIRIS, 147
dump tape, 165
ENVI tape format, 160
formats

AVHRR, 145
ERS, 157
generic CEOS tapes, 157
JERS, 157
Landsat MSS, 142
Landsat TM, 144
NLAPS, 151
RADARSAT, 156
SIR-C CEOS, 152
SPOT, 146
USGS DEM, 148
USGS DLG, 150
X-SAR, 157

read ENVI tape, 161
read known tape formats, 142
reading tapes, 141
scan tape and customize dump, 163
write ENVI tape, 162

target finder, see SAM Target Finder Wizard.
target selection, 800
Tasseled Cap transform, 708
templates, QuickMap, 324
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test data
constant value, 123
Gaussian PSF images, 124
generating, 122
horizontal or vertical ramp, 123
random number images, 123

texture filters
co-occurrence measures, 725
occurrence measures, 723
radar, 1026
using, 723

thermal IR
calibrate to emissivity, 568
opening files, 81

three-dimensional image cube user function, 
847

TIFF
opening files, 98
saving display as, 450
saving files as, 132, 134

tile size, 1074
tiling, 31
TIMS

opening files, 81
TM

calibration, 535
reading tapes, 144

TM FAST files, 67
topographic tools

3D SurfaceView, 993
classification of features, 983
hill shade image, 986
line of sight calculator, 416
opening files, 979
rasterizing point data, 971
replacing bad values, 989, 1054
topographic features, 983
topographic modeling, 979

TOPSAR
convert data, 1053
DEM replace bad values, 989, 1054
opening files, 84, 1016, 1053
tools, 1053
viewing ASCII header, 1017

training classes, 594
transect data

reading from ASCII file, 386
saving to ASCII, 382

transects, 381
transforms

band ratios, 672
color transforms, 695
decorrelation stretch, 701
MNF transform, 682
NDVI, 706
principal components, 675
saturation stretch, 703
sharpening

color normalized (Brovey), 666
HSV, 665

synthetic color image, 704
Tasseled Cap, 708

True Color images, 193
two-dimensional scatter plots. See scatter plots

U
unmixing, 780
unmixing constraints, 828, 830
unsupervised classification

isodata, 611
k-means, 614

user functions
gain and offset, 554
three-dimensional image cube, 847

user-defined filters, 714
user-defined plot function, 400
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USGS
DEM, 87
DOQ, 89
DRG, 89
opening files, 89
SDTS DEM, 88

USGS Munsell transform, 700
USGS spectral library

minerals, 1099
vegetation, 1100

utilities
calibration

empirical line calibration, 546
factors, 534
flat field calibration, 544
IAR reflectance calibration, 545
MSS calibration, 534
TM calibration, 535

data-specific
AVHRR, 559
Landsat MSS, 562
landsat TM, 563
SeaWiFS, 564
thermal IR, 568

general purpose
dark subtraction, 552
de-stripe data, 555
replacing bad lines, 551

UTM projection, 923
UTM to lat/lon converter, 930

V
vector attribute file, 969
vector display group, 26
vector files

LAS LIDAR conversion, 90
vector key, 254
vector layers

creating new using query, 346, 960
displaying, 330
saving, 219

vector overlays, 238, 325
vector template format, 1096
Vector window

add annotation to, 955
collecting GCPs, 869
cursor modes, 335, 948
cursor tracking, 222
display vector layers, 330
displaying vector data, 220
load vector layers, 341, 953
mouse buttons, 221
vector appearance controls, 333, 946
zooming in the Vector window, 221
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vectors
add new, 339, 952
adding nodes, 336, 949
attributes

add, 348, 961
information, 336, 949
query, 346, 960
read into ENI, 346
table, 349, 962
viewing, 346, 959

attributesread into ENVI, 959
Available Vectors List, 212
convert ANN to DXF, 974
convert EVF to DXF, 975
convert layer projection, 215
convert ROI to DXF, 973
digitizing on screen, 339, 952
display, 213
editing layers, 333, 946
editing nodes, 336, 949
export from classification, 662
export to ROIs, 344, 957
file formats, 63
importing in three-dimensional plots, 1009
irregular points to grid, 971
layers list, 330, 330
load vector layer, 341, 953
mouse buttons, 221
new layer, 343, 956
opening files

formats, 63
output, 446
output to ArcView Shapefile, 345, 957
overlaying on images, 325
raster to vector conversion, 969
read from ASCII file, 340, 953
removing nodes, 336, 949
select GCPs, 869
world boundaries, 216, 968

vector-to-raster conversion, 344, 957

vegetation index
calculating, 706
NDVI, 706
Tassled Cap, 708

vertical exaggeration, 999
vertical profile, 377
view statistics file, 484
virtual borders

adding annotation to, 243
setting in preferences, 235

Virtual Mosaic
georeferenced, 899
pixel-based, 894

Virtual Reality Modeling. See VRML output
visualize n dimensions, 763
VRML output, 1010

W
warping

Delaunay, 870
from existing GCPs, 873
image-to-image, 856
image-to-map, 864
options, 870
orthorectification, 875
polynomial, 870
RST, 870

water vapor bands removal, 108
wavelengths

locating bands by, 195
window finder, 183
windows

closing all displays, 227
closing all plots, 227
display, 199
finding, 183
new display, 184
resizing, 25
start new vector, 184
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world boundaries vector, 216, 968
writing

class results to ENVI statistics, 635
class results to text file, 635
density slices to class image, 283
endmember collection to text file, 593
endmember spectral library, 831
ESRI GRID format, 97
ROI results to ENVI statistics file, 300
ROI statistics to text, 300
significant bands to ASCII, 804
transect data to ASCII, 382

X
X profiles, 377
X-SAR tapes, 157
XWD

opening files, 98
saving display as, 450

Y
Y profiles, 377

Z
Z plot information, 118
Z profiles

extracting, 378
extracting additional, 380

Zoom window
changing indicator box color, 237
controlling interpolation, 207, 236
controlling zoom factor, 205
display, 203
hiding, 211
interpolation, 25
mouse button functions, 207
positioning, 211
resizing, 204
shortcut menu, 231
symbol boxes, 206
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